Interaction Center Server Manager

Printable Help

Interactive Intelligence Customer Interaction Center® (CIC)
Messaging Interaction Center™ (MIC™)

Version 4.0 SU5

Last updated March 19, 2014

Abstract

This document contains a printable version of Interaction Center Server Manager help.
Copyright and Trademark Information

Interactive Intelligence, Interactive Intelligence Customer Interaction Center, Interaction Administrator, Interaction Attendant, Interaction Client, Interaction Designer, Interaction Tracker, Interaction Recorder, ION, icNotify, Interaction Mobile Office, Interaction Optimizer, and the “Spirograph” logo design are registered trademarks of Interactive Intelligence, Inc. Interactive Intelligence Group, Inc., Interaction Center Platform, Interaction Monitor, Customer Interaction Center, EIC, Interaction Fax Viewer, Interaction Server, Interaction Voicemail Player, Interactive Update, Interaction Supervisor, Interaction Migrator, and Interaction Screen Recorder are trademarks of Interactive Intelligence, Inc. The foregoing products are ©1997-2014 Interactive Intelligence, Inc. All rights reserved.

Interaction Dialer and Interaction Scripter are registered trademarks of Interactive Intelligence, Inc. The foregoing products are ©2000-2014 Interactive Intelligence, Inc. All rights reserved.

Messaging Interaction Center and MIC are trademarks of Interactive Intelligence, Inc. The foregoing products are ©2001-2014 Interactive Intelligence, Inc. All rights reserved.

e-FAQ and Interaction Director are registered trademarks of Interactive Intelligence, Inc. e-FAQ Knowledge Manager, Interaction FAQ, and Interaction Marquee are trademarks of Interactive Intelligence, Inc. The foregoing products are ©2002-2014 Interactive Intelligence, Inc. All rights reserved.

Interaction Conference is a trademark of Interactive Intelligence, Inc. The foregoing products are ©2004-2014 Interactive Intelligence, Inc. All rights reserved.

Interaction SIP Proxy and Interaction EasyScripter are trademarks of Interactive Intelligence, Inc. The foregoing products are ©2005-2014 Interactive Intelligence, Inc. All rights reserved.

Interaction Gateway is a registered trademark of Interactive Intelligence, Inc. Interaction Media Server is a trademark of Interactive Intelligence, Inc. The foregoing products are ©2006-2014 Interactive Intelligence, Inc. All rights reserved.

Interaction Desktop is a trademark of Interactive Intelligence, Inc. The foregoing products are ©2007-2014 Interactive Intelligence, Inc. All rights reserved.

Interaction Process Automation is a trademark of Interactive Intelligence, Inc. Deliberately Innovative, Interaction Feedback, and Interaction SIP Station are registered trademarks of Interactive Intelligence, Inc. The foregoing products are ©2009-2014 Interactive Intelligence, Inc. All rights reserved.

Interaction Web Portal, Interaction Analyzer, and IPA are trademarks of Interactive Intelligence, Inc. The foregoing products are ©2010-2014 Interactive Intelligence, Inc. All rights reserved.

Spotability is a trademark of Interactive Intelligence, Inc. ©2011-2014. All rights reserved.

Interaction Edge and Interaction Mobilizer are registered trademarks of Interactive Intelligence, Inc. Interaction SIP Bridge, Interactive Intelligence Marketplace℠, Interactive Intelligence Communications as a Service℠, CaaS Quick Spin™, and Interactive Intelligence CaaS℠ are trademarks of Interactive Intelligence, Inc. The foregoing products are ©2012-2014 Interactive Intelligence, Inc. All rights reserved.

Bay Bridge Decisions, Interaction Script Builder, and Interaction Speech Recognition are trademarks of Interactive Intelligence, Inc. The foregoing products are ©2013-2014 Interactive Intelligence, Inc. All rights reserved.

The veryPDF product is ©2000-2014 veryPDF, Inc. All rights reserved.

This product includes software licensed under the Common Development and Distribution License (6/24/2009). We hereby agree to indemnify the Initial Developer and every Contributor of the software licensed under the Common Development and Distribution License (6/24/2009) for any liability incurred by the Initial Developer or such Contributor as a result of any such terms we offer.

The source code for the included software may be found at http://wpflocalization.codeplex.com.

A database is incorporated in this software which is derived from a database licensed from Hexasoft Development Sdn. Bhd. (“HDSB”). All software and technologies used by HDSB are the properties of HDSB or its software suppliers and are protected by Malaysian and international copyright laws. No warranty is provided that the Databases are free of defects, or fit for a particular purpose. HDSB shall not be liable for any damages suffered by the Licensee or any third party resulting from use of the Databases. Other brand and/or product names referenced in this document are the trademarks or registered trademarks of their respective companies.

DISCLAIMER

INTERACTIVE INTELLIGENCE (INTERACTIVE) HAS NO RESPONSIBILITY UNDER WARRANTY, INDEMNIFICATION OR OTHERWISE, FOR MODIFICATION OR CUSTOMIZATION OF ANY INTERACTIVE SOFTWARE BY INTERACTIVE, CUSTOMER OR ANY THIRD PARTY EVEN IF SUCH CUSTOMIZATION AND/OR MODIFICATION IS DONE USING INTERACTIVE TOOLS, TRAINING OR METHODS DOCUMENTED BY INTERACTIVE.

Interactive Intelligence, Inc.
7601 Interactive Way
Indianapolis, Indiana  46278
Telephone/Fax (317) 872-3000
www.ININ.com
Interaction Center Platform® Statement

This document may describe Interaction Center (IC) features that are not available or licensed in your IC product. Multiple products are based on the Interaction Center Platform, and some features are disabled or unavailable in some products.

Products based on the Interaction Center Platform include:
- Interactive Intelligence Customer Interaction Center® (CIC)
- Messaging Interaction Center™ (MIC™)

Since these products share some common features, this document is intended for use with all IC products, unless specifically stated otherwise on the title page or in the context of the document.

How do I know if I have a documented feature?

Here are some indications that the documented feature is not currently licensed or available in your version:
- The menu, menu item, or button that accesses the feature appears grayed-out.
- One or more options or fields in a dialog box appear grayed-out or do not appear at all.
- The feature is not selectable from a list of options.

If you have questions about feature availability, contact your vendor regarding the feature set and licenses available in your version of this product.
# Table of Contents

IC Server Manager Help .............................................................................................................................. 1  

About the IC Server Manager user interface ......................................................................................... 1  

Feedback, support, and additional information ..................................................................................... 1  

Interactive Intelligence home page ....................................................................................................... 1  

Interactive Intelligence technical support website ............................................................................... 2  

Interactive Intelligence cCommunity ..................................................................................................... 2  

Interactive Intelligence Feedback ......................................................................................................... 2  

What’s new in IC Server Manager 4.0 service updates ......................................................................... 2  

IC 4.0 SU5 ........................................................................................................................................... 2  

IC 4.0 SU4 ........................................................................................................................................... 2  

IC 4.0 SU3 ........................................................................................................................................... 2  

IC 4.0 SU2 ........................................................................................................................................... 2  

IC 4.0 SU1 ........................................................................................................................................... 3  

Starting and Exiting ............................................................................................................................... 3  

Log on ................................................................................................................................................. 3  

Log off ................................................................................................................................................ 4  

Exit ..................................................................................................................................................... 4  

Change your password .......................................................................................................................... 4  

Using the Navigation Pane ..................................................................................................................... 5  

About the navigation pane ..................................................................................................................... 5  

Hide the navigation pane ....................................................................................................................... 5  

Move the navigation pane ..................................................................................................................... 6  

Understanding the Workspace ................................................................................................................... 7  

About built-in workspaces ....................................................................................................................... 7  

About custom workspaces ....................................................................................................................... 7  

Add or remove a custom workspace ........................................................................................................ 8  

Display the workspace in full screen view .............................................................................................. 10  

Set up a slide show ................................................................................................................................ 10  

About the workspace tabs ...................................................................................................................... 11  

Change the workspace order .................................................................................................................. 11  

Working with Views ............................................................................................................................... 12  

Add a new view to the workspace ......................................................................................................... 12  

Rename a view ...................................................................................................................................... 13
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Remove a view</td>
<td>14</td>
</tr>
<tr>
<td>Arranging Views</td>
<td>15</td>
</tr>
<tr>
<td>Keyboard Shortcuts</td>
<td>20</td>
</tr>
<tr>
<td>Use toolbars</td>
<td>21</td>
</tr>
<tr>
<td>Show or hide toolbars</td>
<td>21</td>
</tr>
<tr>
<td>Use command line parameters</td>
<td>21</td>
</tr>
<tr>
<td>Example shortcut</td>
<td>21</td>
</tr>
<tr>
<td>Understanding module management</td>
<td>22</td>
</tr>
<tr>
<td>Understanding Application Module Licensing</td>
<td>22</td>
</tr>
</tbody>
</table>
IC Server Manager Help

About the IC Server Manager user interface

IC Server Manager Application provides a user interface for easy access to the features of application program modules. The interface includes navigation panes, menus, toolbars, Workspace tabs, and a Workspace. To learn more about IC Server Manager features, pause the mouse pointer over an area on the graphic below, and click to display more information.

Feedback, support, and additional information

Options on the Interaction Center Business Server Manager Help menu enable you to learn more about Interactive Intelligence's products, promote and share ideas about Interactive Intelligence's software, access technical support, and submit feedback about bugs and enhancement requests.

Note: You must have internet access to visit the Interactive Intelligence website or submit feedback.

Interactive Intelligence home page

To visit the Interactive Intelligence home page, do one of the following:

- From the Help menu, select Interactive Intelligence, then click Home.
Interactive Intelligence technical support website

To access the Interactive Intelligence technical support website, do one of the following:

**Note:** You must log in to this site before you can access technical support.

- Go to [https://my.inin.com/support/Pages/default.aspx](https://my.inin.com/support/Pages/default.aspx).
- From the **Help** menu, select **Interactive Intelligence** and then click **Support**.
- From the **Help** menu, select **About IC Business Server Manager**, then in the **About - IC Server Manager** dialog, click the **Support** link.

Interactive Intelligence Community

Interactive Community is a free and public service provided by Interactive Intelligence to promote an online community devoted to the sharing of ideas and information regarding Interactive Intelligence software. To visit the Interactive Intelligence Interactive Community, do one of the following:

- Go to [http://community.inin.com](http://community.inin.com).
- From the **Help** menu, select **Interactive Intelligence** and then click **Community**.
- From the **Help** menu, select **About**, then in the **About - IC Server Manager** dialog, click the **Community** link.

Interactive Intelligence Feedback

To submit product feedback and report bugs, request enhancements, or submit other product-related information to Interactive Intelligence, do one of the following:

- Go to [http://feedback.inin.com](http://feedback.inin.com).
- From the **Help** menu, select **Interactive Intelligence** and then click **Feedback**.
- From the **Help** menu, select **About**, then in the **About - IC Server Manager** dialog, click the **Feedback** link.

To submit documentation feedback, do one of the following:

- If you have a comment or question about a specific help topic, click the **Send Feedback** link at the top right of that topic. An email window opens. The "To" address is set to documentation@inin.com. The "Subject" line includes information that helps us identify the help topic where you clicked the link. Enter your comments or questions in the body of the email message and then send us the message.
- Send an email message to documentation@inin.com.

What's new in IC Server Manager 4.0 service updates

The following changes and enhancements were introduced in Interaction Service Manager 4.0 Service Updates:

**IC 4.0 SU5**

Updated **Log in** and **Log off** topics to reflect the Log on button. Added information about the status bar, and how to log on from the status bar when you disconnect.

Updated link to Interaction Tracker help.

**IC 4.0 SU4**

No updates for IC 4.0 SU4.

**IC 4.0 SU3**

A Help topic was added for the About dialog, and for **Feedback**, **Support**, and **Additional information**. Also, screen captures were updated to reflect the more modern user interface technology currently in place.

**IC 4.0 SU2**
Floating views can be positioned anywhere on the screen and are not constrained to the Interaction Center Server Manager window. You can click and drag any tab off of the application so that it becomes its own separate window and remains on top of the main window. If you close or minimize Interaction Center Server Manager, the floating window will also close or minimize.

**IC 4.0 SU1**
No new changes or enhancements were introduced in this release.

**Starting and Exiting**
This section provides information on how to log in, log out, and exit IC Server Manager. It also contains information on changing your password.

See the following topics for starting and exiting IC Server Manager:

- Logging On
- Logging Out
- Exiting
- Changing Your Password

**Log on**
Use the log on dialog to provide credentials to the IC Server Host and to specify your logon information.

*Note:* If you disconnect from IC Server Manager, click the Connection Down message on the status bar to open the log on dialog box.

**Log on to IC Server Manager:**

1. Do one of the following:
   - Double-click the IC Server Manager icon on the Windows desktop or taskbar.
   - From the Start menu, select Interactive Intelligence and then select IC Server Manager.

   **Result:** The IC Server Manager log on dialog opens.

2. Make any necessary adjustments. See the Logon Settings below.

3. Click the Logon button.
Logon Settings
This section describes the settings available on the IC Server Manager logon dialog.

Use Windows Authentication
Select this check box to use your Windows Login credentials for authentication.

User
Type the user name to log on to the IC Server. If you selected the Use Windows Authentication check box, this field is unavailable.

Password
Type the password to log on to the IC Server. If you selected the Use Windows Authentication check box, this field is unavailable.

Save Password
Select this check box to avoid entering your password each time you log on. If you share this computer with others, do not select the Save Password check box.

Server
Type the name of the IC Server Host.

Log off
To log out of IC Server Manager and keep the application open, open the File menu and click Log off.

Note: To log out and close the application, click the X in the upper-right corner of IC Server Manager.

Exit
To exit IC Server Manager, do one of the following:

- Open the File menu and select Exit.
- Press the shortcut keys Alt+F4.
- Click the X in the upper-right corner of IC Server Manager.

Change your password
When you start IC Server Manager, if your IC Server Manager password has expired, the Change Password dialog appears and you must change your password immediately in order to login and continue loading IC Server Manager. Failure to change your password after an "Expired Password" warning causes IC Server Manager to exit.

Your Interaction Center administrator creates Password Policies in Interaction Administrator. The password policy assigned to you controls how often you must change your IC password. It also determines minimum password length, how many unique characters are required, whether sequential digits are allowed, how often you can reuse a password and other password restrictions.

Based on the password policy that your IC administrator has created for you, if your password is going to expire soon (within 2 days, today, etc.) a prompt appears periodically, asking if you want to change your password at this time. If you select Yes, the Change Password dialog appears.

Tip: You do not need to wait until you are prompted to change your password. You can change your password at any time.

Change your password at any time
1. Open the File menu and select Change Password. The Change Password dialog appears.
2. In the **Old Password** field, type your current IC Server Manager password.

3. In the **New Password** field, type your new IC Server Manager password.

4. In the **Confirm New Password** field, type your new IC Server Manager password again.

5. Click the **Change Password** button.

### Using the Navigation Pane

The IC Server Manager Navigation Pane provides easy access to the active module's features. The Navigation Pane provides centralized navigation to module components, which display their views in the Workspace. By default, the Navigation Pane is displayed on the left side of the window, and it can be hidden or closed for a larger view of the Workspace.

For more information about using the Navigation Pane, see the following topics:

- About the Navigation Pane
- Hide the Navigation Pane
- Move the Navigation Pane

#### About the navigation pane

The **navigation pane** helps you navigate within module components, which display their views in the Workspace. By default, the **navigation pane** appears on the left side of the window. You can hide or close it for a larger view of the Workspace. You can also minimize the **navigation pane** to increase the area of the Workspace.

#### Hide the navigation pane

To increase the area of the Workspace in the window, you can hide the Navigation Pane. There are several ways to minimize and expand the Navigation Pane. Choose the one that best fits your working style. You can also move the Navigation Pane to a new location in the workspace. For more information, see Move the Navigation Pane.

#### Hide the navigation pane

To hide the **navigation pane** so that it is turned off and completely hidden, do one of the following:

- Open the **View** menu, select **Navigation pane**, and click **Off**.
- Click the Navigation Pane drop down menu and select **Hide**.
- In the Navigation Pane title bar click the **X** in the upper right corner.
Note: To display the Navigation pane again, from the View menu click Reset Pane Layout.

Auto Hide the Navigation Pane
To automatically hide the Navigation Pane, from the View menu select Navigation Pane and select Auto.

Note: Use this option to turn off the Navigation Pane if it is empty, or to keep it open if it contains navigational information for the workspace.

Minimize the Navigation Pane
When you minimize the Navigation Pane, the slim profile of the minimized pane is pinned along the left side of the window, providing quick access to the Navigation Pane. To minimize the Navigation pane, do one of the following:

- Open the View menu, select Navigation pane, and choose Minimized.

Note: To temporarily display the Navigation Pane, pause the mouse pointer over the minimized Navigation Pane tab. The Navigation Pane expands, and it is automatically minimized when you move your mouse pointer away from the pane.

- Click the Navigation Pane drop down menu and select Auto Hide.

- In the Navigation Pane title bar, click the Auto Hide pin.

    ![Navigation Pane Auto Hide Pin](image)

    Note: To expand the Navigation Pane back to its original state on the left side of the window, pause the mouse over the minimized Navigation Pane tab to expand it, and then click the Auto Hide pin.

Dock the Navigation Pane
To dock the Navigation Pane and return it to the original state, open the View menu, select Navigation pane, and click Normal.

Move the navigation pane
You can drag and drop the navigation pane to a new location in the Workspace.

Dock (Move) the navigation pane to another location in the workspace

1. Click and hold the navigation pane title bar. The docking icons appear.
2. Without letting go of the mouse button, move the mouse over the icon that represents where you want to move the Navigation Pane.

    Note: IC Server Manager highlights the area to which the Navigation Pane will move. Only the outer docking icons are available.
3. Release the mouse button to drop the Navigation Pane into its new location. The Navigation Pane automatically moves to the chosen area.

Note: You can Hide the Navigation Pane in its Floating position by right-clicking in the Navigation Pane title bar and selecting Hide. To display the floating Navigation Pane again, open the View menu, select Navigation Pane, and click Normal.

Return the navigation pane to the original location
To return the navigation pane to its original state on the left side of the window, open the View menu and click Reset Pane Layout.
Understanding the Workspace

A Workspace contains the module view selected in the Navigation Pane and is displayed in the IC Server Manager.

IC Server Manager is installed with built-in Workspaces that cannot be deleted or renamed, may have a different set of views from which to choose, and are tailored to specific tasks. You can also create custom Workspaces, which can contain a collection of different views selected from the active modules and configured to suit your needs. In addition, IC Server Manager contains a Default Custom Workspace that you cannot rename, but you can add, modify, or remove custom views within it.

The Workspace Tabs located to the left of the Navigation Pane allow you to switch between available modules.

- The Workspace can be displayed in full-screen mode, so that toolbars, menus, and window borders do not appear.
- Tabbed views can be displayed in slide show mode, which cycles between views every 5 seconds.

For more information about using Workspaces, see the following topics:

- About Built-In Workspaces
- About Custom Workspaces
- Add or Remove a Custom Workspace
- Display the Workspace in Full Screen View
- Set Up a Slide Show
- Change the Workspace Order

About built-in workspaces

A workspace displays the module views that are selected in the Navigation Pane. IC Server Manager is installed with built-in Workspaces that cannot be deleted or renamed, may have a different set of views from which to choose, and are tailored to specific tasks. In some modules, you can add views and organize them into a custom layout by clicking and dragging a view's tab.

The Workspaces menu provides a detailed list of all available built-in and custom Workspaces. You can change the order in which the Workspaces are listed by selecting Reorder Workspaces from the Workspaces menu.

For information on adding views to a workspace, see Add a new view to the workspace. To add a custom workspace, see Add or remove a custom workspace.

About custom workspaces

A Workspace displays the module views you select in the navigation pane. Custom workspaces contain a collection of different views, which you select from the active modules and configure to suit your needs. You can add views to a custom Workspace, and you can organize the views into a custom layout by clicking and dragging a view's tab.

The Workspaces menu provides a detailed list of all available custom and built-in Workspaces. Custom Workspaces can be edited and deleted from the Workspaces menu. You can also change the order in which the Workspaces are listed by selecting Reorder Workspaces from the Workspaces menu.
Getting Started view

Each custom Workspace opens with a **Getting Started** view that contains information about setting up a custom Workspace, as well as links to built-in Workspaces and options for creating a new Workspace or View. To remove the **Getting Started** view from your Workspace, right-click the **Getting Started** tab and select **Close View** from the menu that appears.

![Getting Started](image)

**Custom workspaces** can contain a collection of different views which you can organize by task. You can add views by selecting "View..." from the "File->New" menu or by using the toolbar button. You can also create new custom workspaces from the "File->New" menu for additional areas to add views. You can organize the views into a custom layout by clicking and dragging the view’s tab.

The Workspaces menu provides a detailed list of all available custom and built-in workspaces. In addition, custom workspaces can be edited and deleted from the Workspaces menu. You can also change the order in which the workspaces are listed by selecting "Reorder workspaces..." from the "Workspaces" menu.

**Built-in workspaces** cannot be deleted or renamed and may have a different set of views to choose from and are tailored to specific tasks. The available built-in workspaces are shown to the left.

**Note**: To permanently remove the **Getting Started** view from future custom Workspaces you create, clear the **Show "Getting Started" on new workspaces** check box. If you clear this check box, IC Server Manager creates custom Workspaces without views. For information on creating views, see **Add a New View to the Workspace**.

The IC Server Manager default custom workspace

IC Server Manager contains a **default custom workspace**. You cannot rename the default workspace, but you can add, modify, or remove custom views within it.

**Add or remove a custom workspace**

You can add a custom Workspace to collect different views, which you can sort by task. You can also delete the custom Workspace if you no longer need or use it.

**Note**: Built-in Workspaces cannot be deleted.
**Add a new workspace:**

1. Do one of the following.
   - Click the down arrow to the right of the **New** button and select **Workspace** from the menu that appears.
   - OR
   - From the **Workspaces** menu, click **Create Workspace**.

2. In the **Create New Workspace** dialog, in the **Name** field type the title of the Workspace.

3. In the **Description** field, type a short, descriptive summary of the Workspace.

4. From the **Icon** drop down list, select an icon to associate with the Workspace.

5. Click the **OK** button.

   **Result:** A custom Workspace appears with the **Getting Started** view. To remove this view, right-click the **Getting Started** tab and select **Close View** from the menu that appears.

   **Note:** To permanently remove the Getting Started view from future custom Workspaces you create, clear the **Show "Getting Started" on new workspaces** check box. If you clear this check box, IC Server
Manager creates custom Workspaces without views. For information on creating views, see Add a New View to the Workspace.

To remove a custom Workspace:
1. Open the custom Workspace you want to delete.
2. From the Workspaces menu, click Delete Workspace.
3. Click the Yes button.

Display the workspace in full screen view
In full screen view, the workspace is maximized to fill the entire screen. Toolbars, menus, and other non-essential controls are hidden. This feature is helpful in environments that require overhead displays and general monitoring.

Display the workspace in full screen view
1. Do one of the following:
   - From the View menu, click Full Screen.
   - Press the F11 shortcut key.
   
   Result: The Workspace is expanded to a full-screen view.
2. To hide the Navigation Pane, open the View menu, select Navigation Pane, and click Off.

Restore the view to its original size
1. Do one of the following:
   - Pause the mouse pointer at the top of the screen to display the menu bar. The Full Screen button is displayed on the menu bar and highlighted. Click Full Screen to restore the Workspace view to its original size.
   - Press the F11 shortcut key.

   Result: The Workspace is restored to its original size.
2. To display the Navigation pane on the left, from the View menu select Navigation Pane and click Normal.

Set up a slide show
In slide show mode, the workspace can be configured to continuously cycle through open tabbed views at 5 second intervals. This mode makes it easy to monitor multiple views using an overhead monitor or kiosk. Before setting up a slide show, dock the views so they are in a tabbed arrangement. For information on docking the views, see Arrange Views in a Workspace.

Start an IC Server Manager slide show
1. Open the workspace that contains the views you want to rotate.
2. From the View menu, select Show slide show.

Result: The Show Slide Show button is displayed on the menu bar and highlighted.

Note: To restore the Workspace to its original view, click the Show Slide Show button.
About the workspace tabs

The workspace tabs, located to the left of the navigation pane, provide centralized navigation to module components, which display their views in the workspace. You can add or remove custom workspaces, and you can change the display order of the buttons.

**Note:** Built-in Workspaces cannot be deleted or renamed.

For more information about the workspace tabs, see:

- Add or remove a custom workspace
- Change the workspace order

**Change the workspace order**

You can change the order in which tabbed workspaces appear in the workspaces tab area of the IC Server Manager interface.

**Change the workspace order**

1. Open the **Workspaces** menu and select **Reorder workspaces**. The **Reorder Workspaces** dialog opens.
2. Highlight the name of a Workspace and click the up and down arrow buttons, as needed, to move the Workspace to a new location in the list.

3. Click the OK button.

Working with Views

A view is a window that displays data. You can add views to built-in or custom Workspaces. Views for built-in Workspaces are limited to the selections available for a particular module. Views for custom Workspaces allow you to add views according to your needs, and you can add views from different modules to a custom Workspace.

You can also remove or rename any view not required in a Built-In Workspace, and you can remove or rename any view from a Custom Workspace. You can close a single view, or you can close all views in the Workspace. The ability to remove or rename a view may vary depending on the module in the Workspace.

**Note:** When you close a view in a built-in or custom workspace, IC Server Manager does not save configuration you set up, if applicable. You can choose to display the view again at a future date, but you must reconfigure any custom modifications. Use caution when removing views from a workspace.

For more information on adding, renaming, or removing Views, see the following topics:

- Add a New View to the Workspace
- Rename a View
- Remove a View

In addition, you can arrange views within a workspace. See the following topics:

- Understanding the Docking Architecture
- Arrange Views in a Workspace
- Create Horizontal, Vertical, or Tabbed Group Views
- Resize a View

Add a new view to the workspace

You can add views to built-in or custom workspaces. Views for built-in workspaces are limited to the selections available for a particular module. Views for custom workspaces allow you to add views according to your needs, and you can add views from different modules to a custom workspace.

**Add a view**

1. Open the workspace for which you want to add a new view and do one of the following:
   - From the File menu, select New and click View.
Click the **New** button on the toolbar.

- Press the shortcut keys **Ctrl+Shift+N**.

**Result:** The **Create New View** window opens.

2. To group the available views according to the active modules in IC Server Manager, click the **Group by** drop down list and select **Products**.

   **Or...**

   To display available views by category (e.g. Agents and Workgroups, Historical Reports, System Status),
   click the **Group by** drop down list and select **Categories**.

3. To display the list of available views by icon, click the **Views** drop down list and choose **Icon View**.

   **Note:** IC Server Manager returns a brief description of the selected view in the grey area below the icons.

   **Or...**

   To display a list of views by detail, click the **Views** drop down list and choose **List View**.

   **Note:** The name of the view, the module to which it belongs, and a brief description of the view appear with the view's icon.

4. Double-click the view you want to add to the workspace.

   **Or...**

   Select the view you want to add to the workspace and click the **OK** button.

   **Note:** Depending on the module's view you select, IC Server Manager may prompt you through configuration options before the new view is added to the workspace. For more information, refer to help topics for the appropriate module.

**Rename a view**
After you add a view to the workspace, you can change the name of the custom view to distinguish it from other views.

**Rename a view**

1. Do one of the following:
   - Right-click the tab that contains the view you want to rename and select **Rename** from the menu that appears.
   - Open the **Window** menu and choose **Rename**.

   **Result**: The **Rename View** window opens.

   ![Rename View Window](image)

2. Click the **Use custom title** check box and in the field next to it type the name of the custom view.

   **Note**: The **Default title** appears below the custom title field. To revert to the default title at any time, clear the **Use custom title** check box.

3. Click the **OK** button.

**Remove a view**

You can remove any view not required in a built-in workspace, and you can remove any view from a custom workspace. You can close a single view, or you can close all views in the workspace. The ability to remove a view may vary depending on the module in the workspace.

**Note**: When you close a view in a built-in or custom workspace, IC Server Manager does not save configuration you set up, if applicable. You can choose to display the view again at a future date, but you must reconfigure any custom modifications. Use caution when removing views from a workspace.

**Remove a single view from a workspace**

Do one of the following:

- Right-click the tab for the view you no longer want to display and select **Close view** from the menu that appears.

- From the **Window** menu, select **Close view**.

   **Result**: The selected view is removed from the Workspace.

**Remove all views from a workspace**

Do one of the following:

- Right-click any tab in the workspace and select **Close all views** from the menu that appears.

- From the **Window** menu, select **Close all views**.

   **Result**: IC Server Manager removes all views from the workspace.
Arranging Views

In addition to adding, renaming, or removing views, you can arrange views within a workspace to suit your environment. See the following topics:

- Understanding the Docking Architecture
- Arrange Views in a Workspace
- Create Horizontal, Vertical, or Tabbed Group Views
- Resize a View

Understanding the docking architecture

Using a flexible docking architecture, you can arrange views within the IC Server Manager interface, placing them in more convenient locations to suit your needs. This capability is helpful if you manage multiple views within a workspace, such as workgroup overviews.

Note: IC Server Manager saves the arrangement of your docked views, so they remain in place if you close and restart the application.

To move a view, click the tab with your mouse and start dragging it. Docking icons appear on the IC Server Manager window, showing you the available locations to which you can move the view.

When you drag the view on top of an arrow, IC Server Manager highlights the area to which the view will move if you release your mouse and "drop" it onto that particular docking arrow. You can also drag a view within its current set of tabs to reorder it.

Use the Outer Docking Icons to move the selected view to an outer docking zone. For example, if you want to move Workgroup C so that it takes up the right side of the Workspace, click and drag the Workgroup C tab to the outer right arrow. The right side of the Workspace will be highlighted. Release the mouse and the Workgroup C tab moves to the right side of the Workspace, as shown in the image above.
Use the **Center Docking Icons** to relocate the view based on the view it is currently positioned over. For example, if you want to move Workgroup C so that it resides above Workgroup B, click and drag the Workgroup C tab until the center docking icons appear in the Workgroup B tab, and then position the mouse over the top Center Docking Icon arrow. The area above Workgroup B will be highlighted, as shown in the image above. Release the mouse and the Workgroup C tab moves to the area above the Workgroup B view.

### Docking icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>The outer left docking icon creates a new left dock zone.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>The outer top docking icon creates a new top dock zone.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>The outer right docking icon creates a new right dock zone.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>The outer bottom docking icon creates a new bottom dock zone.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>The center docking icons create a new dock zone based on the view over which they are currently positioned.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>The middle docking icon, located in the center docking icon, relocates the selected view so that it appears first in the currently highlighted dock zone.</td>
</tr>
</tbody>
</table>

### Arrange views in a workspace

You can arrange views in a workspace, placing them in locations that better suit your needs.

**Note:** IC Server Manager saves the arrangement of your docked views, so they remain in place if you close and restart the application.

### Move a view to a new location

1. Open the appropriate workspace.
2. Click and hold the tab of the view you want to move.
   
   **Result:** The docking icons appear.
3. Without letting go of the mouse button, move the mouse over the icon that represents where you want to move the view.
   
   **Note:** IC Server Manager highlights the area to which the view will move.
4. Release the mouse button to drop the view into its new location.
   
   **Result:** The view automatically moves to the chosen area.

### Example:

In this example, you want to move Workgroup C so that it is resides above Workgroup B. Click the Workgroup C tab and begin to drag it. The outer docking icons appear on the outer edge of the workspace, and the center docking icons appear in the Workgroup B tab.

Position the mouse over the top center docking Icon arrow. The area above Workgroup B will be highlighted, as shown in the image below. Release the mouse and the Workgroup C tab moves to the area above the Workgroup B view.
Display a view in a floating window

Floating views can be positioned anywhere on the screen and are not constrained to the Interaction Center Server Manager window. You can click and drag any tab off of the application so that it becomes its own separate window and remains on top of the main window. If you close or minimize Interaction Center Server Manager, the floating window will also close or minimize.

**Note:** Floating windows are workspace-specific. If you switch to a different workspace, Interaction Center Server Manager hides the current set of floating windows and displays floating windows for the new workspace.

If you close an instance of Interaction Center Server Manager that contains a floating window, when you re-open the application the floating window will open with the same size and position as when you closed it. If, for any reason, the floating window was partially off-screen when you exited Interaction Center Server Manager, the system will reposition it so that the entire view opens on the screen. This scenario may occur when you use a second monitor or remote desktop into a machine with two monitors.

**Display a view in a floating window**

1. Click the tab of the view you wish to float.
2. Drag the floating window anywhere you like. Resize as needed.
Create horizontal, vertical, or tabbed group views

You can position docked views several different ways. You can place your views into a horizontal group, a vertical group, or a tabbed group. Choose the arrangement that best suits your needs.

**Note:** In addition to arranging views into groups, you may need to resize them to better fit the workspace. See [Resizing a View](#) for more information on adjusting the size of a view.

Arrange views into a horizontal group

1. Do one of the following:
   - Click a tab for a view you want to place into a horizontally tabbed view and from the **Window** menu select **New horizontal tab group**.
   - Right-click a tab for a view you want to place into a horizontally tabbed view and select **New horizontal tab group** from the menu that appears.
2. Repeat Step 1 for any remaining tabs you want to add to the horizontally tabbed view.
**Arrange views into a vertical group**

1. Do one of the following:
   - Click a tab for a view you want to place into a vertically tabbed view and from the **Window** menu select **New vertical tab group**.
   - Right-click a tab for a view you want to place into a vertically tabbed view and select **New vertical tab group** from the menu that appears.

2. Repeat Step 1 for any remaining tabs you want to add to the vertically tabbed view.

**Arrange views into a tabbed group**

1. Do one of the following:
   - Click a tab for a view you want to place into a horizontally tabbed view and from the **Window** menu select **New horizontal tab group**.
Right-click a tab for a view you want to place into a horizontally tabbed view and select **New horizontal tab group** from the menu that appears.

2. To add additional views to the horizontally tabbed group, do one of the following:
   - Select the tab for the view you want to move and from the **Window** menu select **Move to previous tab** or **Move to next tab**.
   - Right-click the tab for the view you want to move and select **Move to previous tab** or **Move to next tab** from the menu that appears.

**Result**: IC Server Manager places the tab in front of the next or previous tabbed view.

3. Repeat Step 2 for any remaining tabs you want to add to the horizontally tabbed view.

### Resize a view

To change the width, point to the left or right area between the views. When the pointer changes into a resize cursor (as indicated by 

To change the height, point to area between the center views. When the pointer changes into a resize cursor (as indicated by 

### Use menus

Commands and actions are organized in menus you can use when working with program modules. Available commands and actions vary according to the active module.

### Keyboard Shortcuts

If a keyboard shortcut is available for a command, it is shown next to the command. For example, select **F11** to maximize the screen to full view or to restore down from full screen view. Or click **Ctrl+1** to open the first Workspace displayed in the Workspace Tab area, **Ctrl+2** to open the second Workspace displayed in the Workspace Tab area, etc. Unavailable commands are shown in gray and cannot be clicked.
Use toolbars

IC Server Manager toolbars contain command buttons that represent tasks you can do within the program modules. Available toolbars vary according to the active program module and the selection in the navigation pane. Unavailable command buttons are shown in gray and cannot be clicked.

Show or hide toolbars

- To display toolbars, from the View menu, select Toolbars and in the submenu that appears select the toolbar you want to view. A selected check box is displayed, indicating that the toolbar is available.
- To remove toolbars from view, right-click the toolbar you want to remove and in the submenu that appears, click to remove the check box next to the toolbar you no longer want to display.

Use command line parameters

IC Server Manager supports optional command line parameters that you can use when starting IC Server Manager. These parameters are typically added to a shortcut. Command-line switches are not case sensitive.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Abbreviation</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>-fullscreen</td>
<td>None</td>
<td>Opens the application in full screen mode.</td>
<td>-fullscreen</td>
</tr>
<tr>
<td>-user</td>
<td>-u</td>
<td>Allows you to specify the IC Server Manager user login name.</td>
<td>-user John.Doe or -u John.Doe</td>
</tr>
<tr>
<td>-pass</td>
<td>-p</td>
<td>Allows you to enter the password specified in Interaction Administrator.</td>
<td>-pass 1234 or -p 1234</td>
</tr>
<tr>
<td>-windowAuthentication</td>
<td>-winauth</td>
<td>Uses the Windows Authentication for login.</td>
<td>-windowAuthentication or -winauth</td>
</tr>
<tr>
<td>-server or -notifier</td>
<td>-n</td>
<td>Specifies the IC Server to which you point IC Server Manager. You can also specify an IP address.</td>
<td>-notifier DevIC1 or -n 204.180.46.8 or -server ICSvr1</td>
</tr>
<tr>
<td>-silent or -lastlogin</td>
<td>None</td>
<td>Logs into IC Server Manager using the credentials entered in the most recent login, without prompting for login information.</td>
<td>-silent or -lastlogin</td>
</tr>
<tr>
<td>-login</td>
<td>None</td>
<td>Opens the login dialog even if user, password, and server parameters have been specified.</td>
<td>-login</td>
</tr>
</tbody>
</table>

Example shortcut

For example, if the name of your IC server is ICSvr1, your IC User ID is John.Doe, and your password is PW1234, the command line would read:

"C:\Program Files\InteractiveIntelligence\ICServerManager.exe" -u John.Doe -p PW1234 -n ICSvr1

Command line arguments are separated by a space. If you prefer to use the verbose form of the command-line switches, the same command line would be:

"C:\Program Files\InteractiveIntelligence\ICServerManager.exe" -user John.Doe -pass PW1234 -notifier ICSvr1

or

"C:\Program Files\InteractiveIntelligence\ICServerManager.exe" -user John.Doe -pass PW1234 -server ICSvr1
Understanding module management

The Module Management dialog lists currently installed application modules, provides licensing details, and shows you whether the application is enabled or disabled. To view a list of modules and licensing details, open the Tools menu and select Module Management.

<table>
<thead>
<tr>
<th>Module</th>
<th>Status</th>
<th>License</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Interaction Administrator</td>
<td></td>
<td>N/A</td>
<td>Interaction Administrator</td>
</tr>
<tr>
<td>Interaction Process Automation Designer</td>
<td>✔️</td>
<td>Acquired</td>
<td>Design processes</td>
</tr>
<tr>
<td>Interaction Process Automation Monitor</td>
<td>✔️</td>
<td>Acquired</td>
<td>Monitor running processes</td>
</tr>
</tbody>
</table>

For more information on licensing, or if you have questions about your right to use a particular application, see your IC administrator.

Understanding Application Module Licensing

The Module Management dialog lists currently installed application modules, provides licensing details, and shows you whether the application is enabled or disabled. Your company must have appropriate licenses to work with specific applications. Licenses are assigned in Interaction Administrator.

If IC Server Manager detects a licensing issue, a warning icon (⚠️) appears in the lower right corner of IC Server Manager. For example, this warning may appear if all licenses are in use, you are using the license on a different computer, or an error occurred while IC Server Manager tried to acquire the license. Click the warning icon to open the Module Management dialog. An application with a licensing issue appears in the modules list accompanied by a warning icon and a description of the issue.

If you encounter licensing issues in IC Server Manager, or if you have questions about your right to use a particular application, see your IC administrator.