ININ.InteractionClient.AddIn Namespace

[image]

Interaction Client Add-In Technical Reference
ININ.InteractionClient.AddIn Namespace
Send Feedback

Classes

 | Class | Description
Public class | AddInVersion | Information about the current AddIn API version. The AddIn API version is used to determine whether or not breaking changes have occurred in the API since the version an AddIn was compiled against.
Public class | AddInVersionAttribute | An assembly-level attribute to indicate what version of the Interaction Client AddIn interface an AddIn was compiled against.
Public class | AddInWindow | A base class for implementing an Interaction Client AddIn-based window.
Public class | DuplicateWindowException | An exception thrown when a IWindow with the same category and identifier has already been registered.
Public class | InteractionAttributes | A helper class that exposes some common interaction attribute names.
Public class | InteractionAttributeValues | Helpers for common interaction attribute values.
Public class | InteractionAttributeValues..::..CallType | Values for the CallType interaction attribute.
Public class | InteractionAttributeValues..::..Direction | Values for the Direction interaction attribute.
Public class | InteractionAttributeValues..::..InteractionType | Values for the InteractionType interaction attribute.
Public class | InteractionAttributeValues..::..State | Values for the State interaction attribute.
Public class | InteractionEventArgs | EventArgs that contain an interaction.
Public class | NotificationServiceUtility | A helper class that adds common overloads (using defaults) to an INotificationService.
Public class | QueueMonitor | A base class for monitoring an Interaction Center queue.
Public class | ScreenPop | A base class for implementing a screen pop Interaction Client AddIn.
Public class | SecureInput | A base class for implementing a custom secure input Interaction Client AddIn.
Public class | ServiceNotFoundException | An exception thrown when a required service type is not found.
Public class | WindowRegistrationParameters | A set of values used to register a window.

Interfaces

 | Interface | Description
Public interface | IAddIn | The base interface for an Interaction Client AddIn.
Public interface | ICallService | A service that enables the creating of call interactions.
Public interface | IDialService | Obsolete. A service that exposes dial-related operations.
Public interface | IInteraction | An interaction on the Interaction Center server.
Public interface | IInteractionSelector | A service for retrieving the user's selected interaction.
Public interface | IInteractionService | A service that returns interactions from specified interaction IDs.
Public interface | INotificationService | A service that notifies the user using supplied information.
Public interface | IQueue | A queue in the Interaction Center server.
Public interface | IQueueService | An application service that returns a queue for a given queue name.
Public interface | IScreenPop | Initiates a screen pop. Implement this interface and add an instance of the implementation to the IScreenPopService to enable the screen pop.
Public interface | IScreenPopService | A service that manages IScreenPop instances.
Public interface | ISecureInput | Provides access to a custom secure input. Implement this interface and add an instance of the implementation to the ISecureInputService to make the custom secure input available.
Public interface | ISecureInputForm | A secure input form is a control (Windows Forms or WPF) that is embedded into a containing window and shown to the user in order to collect information before sending a caller into a secure IVR session.
Public interface | ISecureInputService | A service that manages ISecureInput instances.
Public interface | ITraceContext | A tracing context from which messages can be added to the Interaction Client log file.
Public interface | IWatchedInteraction | An IInteraction that raises the InteractionChanged event when its attributes change.
Public interface | IWindow | A window (also referred to as a "Page") in the Interaction Client user interface. Windows are added and removed by users.
Public interface | IWindowManager | Windows registered with this interface are made available to the user in the "Pages" dialog, the same place that allows the user to add directory or queue "tabs" to the Interaction Client's user interface.

Delegates

 | Delegate | Description
Public delegate | CreateWindowDelegate | Delegate used to create a new IWindow.

Enumerations

 | Enumeration | Description
Public enumeration | NotificationType | The type, or severity, of a notification. This will, at a minimum, influence the notification icon.

Send comments on this topic to PureConnectDoc@genesys.com

Copyright (c) 1994 - 2022 Genesys


AddInVersion Class

[image]

Interaction Client Add-In Technical Reference
AddInVersion Class
Members See Also Send Feedback
Information about the current AddIn API version. The AddIn API version is used to determine whether or not breaking changes have occurred in the API since the version an AddIn was compiled against.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class AddInVersion
Visual Basic
Public NotInheritable Class AddInVersion

Inheritance Hierarchy

System..::..Object
ININ.InteractionClient.AddIn..::..AddInVersion

See Also

AddInVersion Members
ININ.InteractionClient.AddIn Namespace


AddInVersion Members

[image] [image]

Interaction Client Add-In Technical Reference
AddInVersion Members
AddInVersion Class Fields See Also Send Feedback

The AddInVersion type exposes the following members.

Fields

Name | Description
CurrentVersion | The value representing the current version of the AddIn API.

See Also

AddInVersion Class


AddInVersion Fields

[image] [image]

Interaction Client Add-In Technical Reference
AddInVersion Fields
AddInVersion Class See Also Send Feedback

The AddInVersion type exposes the following members.

Fields

Name | Description
CurrentVersion | The value representing the current version of the AddIn API.

See Also

AddInVersion Class


CurrentVersion Field

[image]

Interaction Client Add-In Technical Reference
AddInVersion..::..CurrentVersion Field
AddInVersion Class See Also Send Feedback
The value representing the current version of the AddIn API.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public const string CurrentVersion
Visual Basic
Public Const CurrentVersion As String

Remarks

Use this string when creating your AddIn and using the AddInVersionAttribute on your AddIn assembly. This will ensure that your AddIn captures the API version it was written against, and will prevent it from loading if the API version changes due to a breaking change.

A public const field is compiled into the assembly that references it, so it is captured as a snapshot of the moment of compilation. Thus if the AddIn API version changes, AddIn assemblies will need to be rebuilt to pick up the new version number, and any breaking API changes will be discovered at compile time.

See Also

AddInVersion Class
AddInVersion Members


AddInVersionAttribute Class

[image]

Interaction Client Add-In Technical Reference
AddInVersionAttribute Class
Members See Also Send Feedback
An assembly-level attribute to indicate what version of the Interaction Client AddIn interface an AddIn was compiled against.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class AddInVersionAttribute : Attribute
Visual Basic
Public Class AddInVersionAttribute _
    Inherits Attribute

Inheritance Hierarchy

System..::..Object
System..::..Attribute
ININ.InteractionClient.AddIn..::..AddInVersionAttribute

See Also

AddInVersionAttribute Members


AddInVersionAttribute Members

[image] [image]

Interaction Client Add-In Technical Reference
AddInVersionAttribute Members
AddInVersionAttribute Class Constructors Methods Properties See Also Send Feedback

The AddInVersionAttribute type exposes the following members.

Constructors

 | Name | Description
Public method | AddInVersionAttribute(String) | Initializes a new instance of the AddInVersionAttribute class.
Public method | AddInVersionAttribute(Version) | Initializes a new instance of the AddInVersionAttribute class.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | Version | The version of the Interaction Client AddIn interface this AddIn was compiled against.

See Also

AddInVersionAttribute Class


AddInVersionAttribute Constructor

[image] [image]

Interaction Client Add-In Technical Reference
AddInVersionAttribute Constructor
AddInVersionAttribute Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddInVersionAttribute(String) | Initializes a new instance of the AddInVersionAttribute class.
Public method | AddInVersionAttribute(Version) | Initializes a new instance of the AddInVersionAttribute class.

See Also

AddInVersionAttribute Class
AddInVersionAttribute Members


AddInVersionAttribute Constructor (String)

[image]

Interaction Client Add-In Technical Reference
AddInVersionAttribute Constructor (String)
AddInVersionAttribute Class See Also Send Feedback
Initializes a new instance of the AddInVersionAttribute class.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AddInVersionAttribute(
    string version
)
Visual Basic
Public Sub New ( _
    version As String _
)

Parameters

version
Type: System..::..String
The version.

See Also

AddInVersionAttribute Class
AddInVersionAttribute Members
AddInVersionAttribute Overload


AddInVersionAttribute Constructor (Version)

[image]

Interaction Client Add-In Technical Reference
AddInVersionAttribute Constructor (Version)
AddInVersionAttribute Class See Also Send Feedback
Initializes a new instance of the AddInVersionAttribute class.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public AddInVersionAttribute(
    Version version
)
Visual Basic
Public Sub New ( _
    version As Version _
)

Parameters

version
Type: System..::..Version
The version of the Interaction Client AddIn interface this AddIn was compiled against.

See Also

AddInVersionAttribute Class
AddInVersionAttribute Members
AddInVersionAttribute Overload


AddInVersionAttribute Methods

[image] [image]

Interaction Client Add-In Technical Reference
AddInVersionAttribute Methods
AddInVersionAttribute Class See Also Send Feedback

The AddInVersionAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AddInVersionAttribute Class


AddInVersionAttribute Properties

[image] [image]

Interaction Client Add-In Technical Reference
AddInVersionAttribute Properties
AddInVersionAttribute Class See Also Send Feedback

The AddInVersionAttribute type exposes the following members.

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Public property | Version | The version of the Interaction Client AddIn interface this AddIn was compiled against.

See Also

AddInVersionAttribute Class


Version Property

[image]

Interaction Client Add-In Technical Reference
AddInVersionAttribute..::..Version Property
AddInVersionAttribute Class See Also Send Feedback
The version of the Interaction Client AddIn interface this AddIn was compiled against.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public Version Version { get; set; }
Visual Basic
Public Property Version As Version
    Get
    Set

Remarks

The Interaction Client will only load AddIns that have an AddInVersionAttribute with a version that matches the AddInVersionAttribute on the ININ.InteractionClient.AddIn.dll assembly.

See Also

AddInVersionAttribute Class
AddInVersionAttribute Members


AddInWindow Class

[image]

Interaction Client Add-In Technical Reference
AddInWindow Class
Members See Also Send Feedback
A base class for implementing an Interaction Client AddIn-based window.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class AddInWindow : IAddIn,
    IWindow, INotifyPropertyChanged
Visual Basic
Public MustInherit Class AddInWindow _
    Implements IAddIn, IWindow, INotifyPropertyChanged

Remarks

This "helper" base class encapsulates common functionality that allows a custom window implementation to focus on creating the window itself, and not on implementing the code to become an Interaction Client AddIn. Simply derive from this class and implement the abstract and virtual methods to register a window in the client.

Inheritance Hierarchy

System..::..Object
ININ.InteractionClient.AddIn..::..AddInWindow

See Also

AddInWindow Members


AddInWindow Members

[image] [image]

Interaction Client Add-In Technical Reference
AddInWindow Members
AddInWindow Class Constructors Methods Properties Events See Also Send Feedback

The AddInWindow type exposes the following members.

Constructors

 | Name | Description
Protected method | AddInWindow | Initializes a new instance of the AddInWindow class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads this AddIn.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnLoad | Called when the AddIn is being loaded.
Protected method | OnUnload | Called when the AddIn is being unloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unload | Unloads this AddIn.

Properties

 | Name | Description
Protected property | CategoryDisplayName | Gets the display name for the category this window should be grouped within.
Protected property | CategoryId | Gets the unique identifier of the category this window should be grouped within.
Public property | Content | Gets the content of the window in the form of a Windows Forms Control or a Windows Presentation Foundation Control.
Protected property | DisplayName | Gets the displayable name for this window.
Protected property | Id | Gets the unique identifier of this window.
Protected property | ServiceProvider | Gets the service provider which can be used to retrieve application services.
Public property | Title | Gets the value to show in the "tab" in the Interaction Client's user interface. By default this will return the DisplayName.
Protected property | Trace | Gets the trace context. Use this to trace messages to the Interaction Client log.

Events

 | Name | Description
Public event | PropertyChanged | Raised when a property value is changing.

See Also

AddInWindow Class


AddInWindow Constructor

[image]

Interaction Client Add-In Technical Reference
AddInWindow Constructor
AddInWindow Class See Also Send Feedback
Initializes a new instance of the AddInWindow class

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected AddInWindow()
Visual Basic
Protected Sub New

See Also

AddInWindow Class
AddInWindow Members


AddInWindow Methods

[image] [image]

Interaction Client Add-In Technical Reference
AddInWindow Methods
AddInWindow Class See Also Send Feedback

The AddInWindow type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads this AddIn.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnLoad | Called when the AddIn is being loaded.
Protected method | OnUnload | Called when the AddIn is being unloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unload | Unloads this AddIn.

See Also

AddInWindow Class


Load Method

[image]

Interaction Client Add-In Technical Reference
AddInWindow..::..Load Method
AddInWindow Class See Also Send Feedback
Loads this AddIn.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Load(
    IServiceProvider serviceProvider
)
Visual Basic
Public Sub Load ( _
    serviceProvider As IServiceProvider _
)

Parameters

serviceProvider
Type: System..::..IServiceProvider

Implements

IAddIn..::..Load(IServiceProvider)

See Also

AddInWindow Class
AddInWindow Members


OnLoad Method

[image]

Interaction Client Add-In Technical Reference
AddInWindow..::..OnLoad Method
AddInWindow Class See Also Send Feedback
Called when the AddIn is being loaded.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected virtual void OnLoad(
    IServiceProvider serviceProvider
)
Visual Basic
Protected Overridable Sub OnLoad ( _
    serviceProvider As IServiceProvider _
)

Parameters

serviceProvider
Type: System..::..IServiceProvider

Remarks

Override this method to perform any custom loading.

See Also

AddInWindow Class
AddInWindow Members


OnUnload Method

[image]

Interaction Client Add-In Technical Reference
AddInWindow..::..OnUnload Method
AddInWindow Class See Also Send Feedback
Called when the AddIn is being unloaded.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected virtual void OnUnload()
Visual Basic
Protected Overridable Sub OnUnload

Remarks

Override this method to perform any custom unloading.

See Also

AddInWindow Class
AddInWindow Members


Unload Method

[image]

Interaction Client Add-In Technical Reference
AddInWindow..::..Unload Method
AddInWindow Class See Also Send Feedback
Unloads this AddIn.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Unload()
Visual Basic
Public Sub Unload

Implements

IAddIn..::..Unload()()()()

See Also

AddInWindow Class
AddInWindow Members


AddInWindow Properties

[image] [image]

Interaction Client Add-In Technical Reference
AddInWindow Properties
AddInWindow Class See Also Send Feedback

The AddInWindow type exposes the following members.

Properties

 | Name | Description
Protected property | CategoryDisplayName | Gets the display name for the category this window should be grouped within.
Protected property | CategoryId | Gets the unique identifier of the category this window should be grouped within.
Public property | Content | Gets the content of the window in the form of a Windows Forms Control or a Windows Presentation Foundation Control.
Protected property | DisplayName | Gets the displayable name for this window.
Protected property | Id | Gets the unique identifier of this window.
Protected property | ServiceProvider | Gets the service provider which can be used to retrieve application services.
Public property | Title | Gets the value to show in the "tab" in the Interaction Client's user interface. By default this will return the DisplayName.
Protected property | Trace | Gets the trace context. Use this to trace messages to the Interaction Client log.

See Also

AddInWindow Class


CategoryDisplayName Property

[image]

Interaction Client Add-In Technical Reference
AddInWindow..::..CategoryDisplayName Property
AddInWindow Class See Also Send Feedback
Gets the display name for the category this window should be grouped within.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected abstract string CategoryDisplayName { get; }
Visual Basic
Protected MustOverride ReadOnly Property CategoryDisplayName As String
    Get

Remarks

This value is displayed to the user in the "Pages" dialog.

See Also

AddInWindow Class
AddInWindow Members


CategoryId Property

[image]

Interaction Client Add-In Technical Reference
AddInWindow..::..CategoryId Property
AddInWindow Class See Also Send Feedback
Gets the unique identifier of the category this window should be grouped within.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected abstract string CategoryId { get; }
Visual Basic
Protected MustOverride ReadOnly Property CategoryId As String
    Get

See Also

AddInWindow Class
AddInWindow Members


Content Property

[image]

Interaction Client Add-In Technical Reference
AddInWindow..::..Content Property
AddInWindow Class See Also Send Feedback
Gets the content of the window in the form of a Windows Forms Control or a Windows Presentation Foundation Control.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract Object Content { get; }
Visual Basic
Public MustOverride ReadOnly Property Content As Object
    Get

Return Value

A Windows Forms Control or a Windows Presentation Foundation Control.

Implements

IWindow..::..Content

See Also

AddInWindow Class
AddInWindow Members


DisplayName Property

[image]

Interaction Client Add-In Technical Reference
AddInWindow..::..DisplayName Property
AddInWindow Class See Also Send Feedback
Gets the displayable name for this window.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected abstract string DisplayName { get; }
Visual Basic
Protected MustOverride ReadOnly Property DisplayName As String
    Get

See Also

AddInWindow Class
AddInWindow Members


Id Property

[image]

Interaction Client Add-In Technical Reference
AddInWindow..::..Id Property
AddInWindow Class See Also Send Feedback
Gets the unique identifier of this window.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected abstract string Id { get; }
Visual Basic
Protected MustOverride ReadOnly Property Id As String
    Get

See Also

AddInWindow Class
AddInWindow Members


ServiceProvider Property

[image]

Interaction Client Add-In Technical Reference
AddInWindow..::..ServiceProvider Property
AddInWindow Class See Also Send Feedback
Gets the service provider which can be used to retrieve application services.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected IServiceProvider ServiceProvider { get; }
Visual Basic
Protected ReadOnly Property ServiceProvider As IServiceProvider
    Get

Remarks

The IServiceProvider can be used to gain access to other application services that might be needed in this screen pop implementation.

See Also

AddInWindow Class
AddInWindow Members


Title Property

[image]

Interaction Client Add-In Technical Reference
AddInWindow..::..Title Property
AddInWindow Class See Also Send Feedback
Gets the value to show in the "tab" in the Interaction Client's user interface. By default this will return the DisplayName.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public virtual string Title { get; }
Visual Basic
Public Overridable ReadOnly Property Title As String
    Get

Implements

IWindow..::..Title

See Also

AddInWindow Class
AddInWindow Members


Trace Property

[image]

Interaction Client Add-In Technical Reference
AddInWindow..::..Trace Property
AddInWindow Class See Also Send Feedback
Gets the trace context. Use this to trace messages to the Interaction Client log.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected ITraceContext Trace { get; }
Visual Basic
Protected ReadOnly Property Trace As ITraceContext
    Get

See Also

AddInWindow Class
AddInWindow Members


AddInWindow Events

[image] [image]

Interaction Client Add-In Technical Reference
AddInWindow Events
AddInWindow Class See Also Send Feedback

The AddInWindow type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Raised when a property value is changing.

See Also

AddInWindow Class


PropertyChanged Event

[image]

Interaction Client Add-In Technical Reference
AddInWindow..::..PropertyChanged Event
AddInWindow Class See Also Send Feedback
Raised when a property value is changing.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic
Public Event PropertyChanged As PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::..PropertyChanged

See Also

AddInWindow Class
AddInWindow Members


CreateWindowDelegate Delegate

[image]

Interaction Client Add-In Technical Reference
CreateWindowDelegate Delegate
See Also Send Feedback
Delegate used to create a new IWindow.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public delegate IWindow CreateWindowDelegate()
Visual Basic
Public Delegate Function CreateWindowDelegate As IWindow

Return Value

A new instance of an IWindow.

See Also

ININ.InteractionClient.AddIn Namespace

Send comments on this topic to PureConnectDoc@genesys.com

Copyright (c) 1994 - 2022 Genesys


DuplicateWindowException Class

[image]

Interaction Client Add-In Technical Reference
DuplicateWindowException Class
Members See Also Send Feedback
An exception thrown when a IWindow with the same category and identifier has already been registered.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class DuplicateWindowException : Exception
Visual Basic
Public Class DuplicateWindowException _
    Inherits Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
ININ.InteractionClient.AddIn..::..DuplicateWindowException

See Also

DuplicateWindowException Members


DuplicateWindowException Members

[image] [image]

Interaction Client Add-In Technical Reference
DuplicateWindowException Members
DuplicateWindowException Class Constructors Methods Properties Events See Also Send Feedback

The DuplicateWindowException type exposes the following members.

Constructors

 | Name | Description
Public method | DuplicateWindowException(String, String) | Initializes a new instance of the DuplicateWindowException class.
Public method | DuplicateWindowException(String, String, String) | Initializes a new instance of the DuplicateWindowException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Category | Gets the identifier of the category that was attempted to be added.
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | WindowId | Gets the identifier of the window that was attempted to be added.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateWindowException Class


DuplicateWindowException Constructor

[image] [image]

Interaction Client Add-In Technical Reference
DuplicateWindowException Constructor
DuplicateWindowException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DuplicateWindowException(String, String) | Initializes a new instance of the DuplicateWindowException class.
Public method | DuplicateWindowException(String, String, String) | Initializes a new instance of the DuplicateWindowException class.

See Also

DuplicateWindowException Class
DuplicateWindowException Members


DuplicateWindowException Constructor (String, String)

[image]

Interaction Client Add-In Technical Reference
DuplicateWindowException Constructor (String, String)
DuplicateWindowException Class See Also Send Feedback
Initializes a new instance of the DuplicateWindowException class.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DuplicateWindowException(
    string category,
    string windowId
)
Visual Basic
Public Sub New ( _
    category As String, _
    windowId As String _
)

Parameters

category
Type: System..::..String
The identifier of the category that was to be added.
windowId
Type: System..::..String
The identifier of the window that was to be added.

See Also

DuplicateWindowException Class
DuplicateWindowException Members
DuplicateWindowException Overload


DuplicateWindowException Constructor (String, String, String)

[image]

Interaction Client Add-In Technical Reference
DuplicateWindowException Constructor (String, String, String)
DuplicateWindowException Class See Also Send Feedback
Initializes a new instance of the DuplicateWindowException class.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public DuplicateWindowException(
    string category,
    string windowId,
    string message
)
Visual Basic
Public Sub New ( _
    category As String, _
    windowId As String, _
    message As String _
)

Parameters

category
Type: System..::..String
The identifier of the category that was to be added.
windowId
Type: System..::..String
The identifier of the window that was to be added.
message
Type: System..::..String
A message describing the error that occurred.

See Also

DuplicateWindowException Class
DuplicateWindowException Members
DuplicateWindowException Overload


DuplicateWindowException Methods

[image] [image]

Interaction Client Add-In Technical Reference
DuplicateWindowException Methods
DuplicateWindowException Class See Also Send Feedback

The DuplicateWindowException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DuplicateWindowException Class


DuplicateWindowException Properties

[image] [image]

Interaction Client Add-In Technical Reference
DuplicateWindowException Properties
DuplicateWindowException Class See Also Send Feedback

The DuplicateWindowException type exposes the following members.

Properties

 | Name | Description
Public property | Category | Gets the identifier of the category that was attempted to be added.
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Public property | WindowId | Gets the identifier of the window that was attempted to be added.

See Also

DuplicateWindowException Class


Category Property

[image]

Interaction Client Add-In Technical Reference
DuplicateWindowException..::..Category Property
DuplicateWindowException Class See Also Send Feedback
Gets the identifier of the category that was attempted to be added.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string Category { get; private set; }
Visual Basic
Public Property Category As String
    Get
    Private Set

See Also

DuplicateWindowException Class
DuplicateWindowException Members


WindowId Property

[image]

Interaction Client Add-In Technical Reference
DuplicateWindowException..::..WindowId Property
DuplicateWindowException Class See Also Send Feedback
Gets the identifier of the window that was attempted to be added.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string WindowId { get; private set; }
Visual Basic
Public Property WindowId As String
    Get
    Private Set

See Also

DuplicateWindowException Class
DuplicateWindowException Members


DuplicateWindowException Events

[image] [image]

Interaction Client Add-In Technical Reference
DuplicateWindowException Events
DuplicateWindowException Class See Also Send Feedback

The DuplicateWindowException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DuplicateWindowException Class


IAddIn Interface

[image]

Interaction Client Add-In Technical Reference
IAddIn Interface
Members See Also Send Feedback
The base interface for an Interaction Client AddIn.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public interface IAddIn
Visual Basic
Public Interface IAddIn

Remarks

Any classes that implement this interface will be loaded by the Interaction Client and the Load(IServiceProvider) method will be called.

See Also

IAddIn Members


IAddIn Members

[image] [image]

Interaction Client Add-In Technical Reference
IAddIn Members
IAddIn Interface Methods See Also Send Feedback

The IAddIn type exposes the following members.

Methods

 | Name | Description
Public method | Load | Loads the AddIn, supplying a service provider. The service provider can be used to access application services.
Public method | Unload | Unloads this AddIn instance.

See Also

IAddIn Interface


IAddIn Methods

[image] [image]

Interaction Client Add-In Technical Reference
IAddIn Methods
IAddIn Interface See Also Send Feedback

The IAddIn type exposes the following members.

Methods

 | Name | Description
Public method | Load | Loads the AddIn, supplying a service provider. The service provider can be used to access application services.
Public method | Unload | Unloads this AddIn instance.

See Also

IAddIn Interface


Load Method

[image]

Interaction Client Add-In Technical Reference
IAddIn..::..Load Method
IAddIn Interface See Also Send Feedback
Loads the AddIn, supplying a service provider. The service provider can be used to access application services.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
void Load(
    IServiceProvider serviceProvider
)
Visual Basic
Sub Load ( _
    serviceProvider As IServiceProvider _
)

Parameters

serviceProvider
Type: System..::..IServiceProvider

See Also

IAddIn Interface
IAddIn Members


Unload Method

[image]

Interaction Client Add-In Technical Reference
IAddIn..::..Unload Method
IAddIn Interface See Also Send Feedback
Unloads this AddIn instance.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
void Unload()
Visual Basic
Sub Unload

Remarks

Perform any cleanup or dispose of any objects at this time.

See Also

IAddIn Interface
IAddIn Members


ICallService Interface

[image]

Interaction Client Add-In Technical Reference
ICallService Interface
Members See Also Send Feedback
A service that enables the creating of call interactions.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public interface ICallService
Visual Basic
Public Interface ICallService

See Also

ICallService Members


ICallService Members

[image] [image]

Interaction Client Add-In Technical Reference
ICallService Members
ICallService Interface Methods See Also Send Feedback

Methods

 | Name | Description
Public method | CreateCall(String) | Creates a call interaction to the specified target.
Public method | CreateCall(String, String) | Creates a call interaction to the specified target, placing the interaction on the specified workgroup.

See Also

ICallService Interface


ICallService Methods

[image] [image]

Interaction Client Add-In Technical Reference
ICallService Methods
ICallService Interface See Also Send Feedback

Methods

 | Name | Description
Public method | CreateCall(String) | Creates a call interaction to the specified target.
Public method | CreateCall(String, String) | Creates a call interaction to the specified target, placing the interaction on the specified workgroup.

See Also

ICallService Interface


CreateCall Method

[image] [image]

Interaction Client Add-In Technical Reference
ICallService..::..CreateCall Method
ICallService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateCall(String) | Creates a call interaction to the specified target.
Public method | CreateCall(String, String) | Creates a call interaction to the specified target, placing the interaction on the specified workgroup.

See Also

ICallService Interface
ICallService Members


CreateCall Method (String)

[image]

Interaction Client Add-In Technical Reference
ICallService..::..CreateCall Method (String)
ICallService Interface See Also Send Feedback
Creates a call interaction to the specified target.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
string CreateCall(
    string target
)
Visual Basic
Function CreateCall ( _
    target As String _
) As String

Parameters

target
Type: System..::..String
The target of the call. Examples include "555-1234", "(123) 555-1234", and "+41225551234".

Return Value

The interaction ID of the created interaction, or an empty string if no interaction could be created.

See Also

ICallService Interface
ICallService Members
CreateCall Overload


CreateCall Method (String, String)

[image]

Interaction Client Add-In Technical Reference
ICallService..::..CreateCall Method (String, String)
ICallService Interface See Also Send Feedback
Creates a call interaction to the specified target, placing the interaction on the specified workgroup.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
string CreateCall(
    string target,
    string workgroup
)
Visual Basic
Function CreateCall ( _
    target As String, _
    workgroup As String _
) As String

Parameters

target
Type: System..::..String
The target of the call. Examples include "555-1234", "(123) 555-1234", and "+41225551234".
workgroup
Type: System..::..String
The name of the workgroup to dial on behalf of.

Return Value

The interaction ID of the created interaction, or an empty string if no interaction could be created.

See Also

ICallService Interface
ICallService Members
CreateCall Overload


IDialService Interface

[image]

Interaction Client Add-In Technical Reference
IDialService Interface
Members See Also Send Feedback
A service that exposes dial-related operations.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
[ObsoleteAttribute("Use the ICallService interface.")]
public interface IDialService
Visual Basic
<ObsoleteAttribute("Use the ICallService interface.")> _
Public Interface IDialService

See Also

IDialService Members


IDialService Members

[image] [image]

Interaction Client Add-In Technical Reference
IDialService Members
IDialService Interface Methods See Also Send Feedback

Methods

 | Name | Description
Public method | Dial(String) | Dials the specified target.
Public method | Dial(String, String) | Dials the specified target, on behalf of the specified workgroup.

See Also

IDialService Interface


IDialService Methods

[image] [image]

Interaction Client Add-In Technical Reference
IDialService Methods
IDialService Interface See Also Send Feedback

Methods

 | Name | Description
Public method | Dial(String) | Dials the specified target.
Public method | Dial(String, String) | Dials the specified target, on behalf of the specified workgroup.

See Also

IDialService Interface


Dial Method

[image] [image]

Interaction Client Add-In Technical Reference
IDialService..::..Dial Method
IDialService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | Dial(String) | Dials the specified target.
Public method | Dial(String, String) | Dials the specified target, on behalf of the specified workgroup.

See Also

IDialService Interface
IDialService Members


Dial Method (String)

[image]

Interaction Client Add-In Technical Reference
IDialService..::..Dial Method (String)
IDialService Interface See Also Send Feedback
Dials the specified target.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
void Dial(
    string target
)
Visual Basic
Sub Dial ( _
    target As String _
)

Parameters

target
Type: System..::..String
The dial target. Examples include "555-1234", "(123) 555-1234", and "+41225551234".

See Also

IDialService Interface
IDialService Members
Dial Overload


Dial Method (String, String)

[image]

Interaction Client Add-In Technical Reference
IDialService..::..Dial Method (String, String)
IDialService Interface See Also Send Feedback
Dials the specified target, on behalf of the specified workgroup.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
void Dial(
    string target,
    string workgroup
)
Visual Basic
Sub Dial ( _
    target As String, _
    workgroup As String _
)

Parameters

target
Type: System..::..String
The dial target. Examples include "555-1234", "(123) 555-1234", and "+41225551234".
workgroup
Type: System..::..String
The name of the workgroup to dial on behalf of.

See Also

IDialService Interface
IDialService Members
Dial Overload


IInteraction Interface

[image]

Interaction Client Add-In Technical Reference
IInteraction Interface
Members See Also Send Feedback
An interaction on the Interaction Center server.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public interface IInteraction : IDisposable
Visual Basic
Public Interface IInteraction _
    Inherits IDisposable

Remarks

An IInteraction represents an interaction on the Interaction Center server.

See Also

IInteraction Members


IInteraction Members

[image] [image]

Interaction Client Add-In Technical Reference
IInteraction Members
IInteraction Interface Methods Properties See Also Send Feedback

The IInteraction type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetAttribute | Gets the specified interaction attribute.
Public method | SetAttribute | Sets the specified interaction attribute.

Properties

 | Name | Description
Public property | InteractionId | Gets the ID of the interaction.
Public property | Item | Gets or sets the specified interaction attribute by name.

See Also

IInteraction Interface


IInteraction Methods

[image] [image]

Interaction Client Add-In Technical Reference
IInteraction Methods
IInteraction Interface See Also Send Feedback

The IInteraction type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetAttribute | Gets the specified interaction attribute.
Public method | SetAttribute | Sets the specified interaction attribute.

See Also

IInteraction Interface


GetAttribute Method

[image]

Interaction Client Add-In Technical Reference
IInteraction..::..GetAttribute Method
IInteraction Interface See Also Send Feedback
Gets the specified interaction attribute.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
string GetAttribute(
    string name
)
Visual Basic
Function GetAttribute ( _
    name As String _
) As String

Parameters

name
Type: System..::..String
The name of the interaction attribute to retrieve.

Return Value

The value of the interaction attribute, or an empty string if the attribute was not found.

See Also

IInteraction Interface
IInteraction Members


SetAttribute Method

[image]

Interaction Client Add-In Technical Reference
IInteraction..::..SetAttribute Method
IInteraction Interface See Also Send Feedback
Sets the specified interaction attribute.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
void SetAttribute(
    string name,
    string value
)
Visual Basic
Sub SetAttribute ( _
    name As String, _
    value As String _
)

Parameters

name
Type: System..::..String
The name of the attribute to set.
value
Type: System..::..String
The value of the attribute.

See Also

IInteraction Interface
IInteraction Members


IInteraction Properties

[image] [image]

Interaction Client Add-In Technical Reference
IInteraction Properties
IInteraction Interface See Also Send Feedback

The IInteraction type exposes the following members.

Properties

 | Name | Description
Public property | InteractionId | Gets the ID of the interaction.
Public property | Item | Gets or sets the specified interaction attribute by name.

See Also

IInteraction Interface


InteractionId Property

[image]

Interaction Client Add-In Technical Reference
IInteraction..::..InteractionId Property
IInteraction Interface See Also Send Feedback
Gets the ID of the interaction.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
string InteractionId { get; }
Visual Basic
ReadOnly Property InteractionId As String
    Get

Field Value

The interaction ID.

See Also

IInteraction Interface
IInteraction Members


Item Property

[image]

Interaction Client Add-In Technical Reference
IInteraction..::..Item Property
IInteraction Interface See Also Send Feedback
Gets or sets the specified interaction attribute by name.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
string this[
    string attributeName
] { get; set; }
Visual Basic
Default Property Item ( _
    attributeName As String _
) As String
    Get
    Set

Parameters

attributeName
Type: System..::..String

Field Value

Equivalent to calling GetAttribute(String) or SetAttribute(String, String).

See Also

IInteraction Interface
IInteraction Members


IInteractionSelector Interface

[image]

Interaction Client Add-In Technical Reference
IInteractionSelector Interface
Members See Also Send Feedback
A service for retrieving the user's selected interaction.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public interface IInteractionSelector
Visual Basic
Public Interface IInteractionSelector

See Also

IInteractionSelector Members


IInteractionSelector Members

[image] [image]

Interaction Client Add-In Technical Reference
IInteractionSelector Members
IInteractionSelector Interface Properties Events See Also Send Feedback

The IInteractionSelector type exposes the following members.

Properties

 | Name | Description
Public property | SelectedInteraction | Gets the currently selected interaction.

Events

 | Name | Description
Public event | SelectedInteractionChanged | Occurs when the selected interaction changes.

See Also

IInteractionSelector Interface


IInteractionSelector Properties

[image] [image]

Interaction Client Add-In Technical Reference
IInteractionSelector Properties
IInteractionSelector Interface See Also Send Feedback

The IInteractionSelector type exposes the following members.

Properties

 | Name | Description
Public property | SelectedInteraction | Gets the currently selected interaction.

See Also

IInteractionSelector Interface


SelectedInteraction Property

[image]

Interaction Client Add-In Technical Reference
IInteractionSelector..::..SelectedInteraction Property
IInteractionSelector Interface See Also Send Feedback
Gets the currently selected interaction.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
IInteraction SelectedInteraction { get; }
Visual Basic
ReadOnly Property SelectedInteraction As IInteraction
    Get

Field Value

The selected interaction, or nullNothingnullptra null reference (Nothing in Visual Basic) if nothing is selected.

See Also

IInteractionSelector Interface
IInteractionSelector Members


IInteractionSelector Events

[image] [image]

Interaction Client Add-In Technical Reference
IInteractionSelector Events
IInteractionSelector Interface See Also Send Feedback

The IInteractionSelector type exposes the following members.

Events

 | Name | Description
Public event | SelectedInteractionChanged | Occurs when the selected interaction changes.

See Also

IInteractionSelector Interface


SelectedInteractionChanged Event

[image]

Interaction Client Add-In Technical Reference
IInteractionSelector..::..SelectedInteractionChanged Event
IInteractionSelector Interface See Also Send Feedback
Occurs when the selected interaction changes.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
event EventHandler SelectedInteractionChanged
Visual Basic
Event SelectedInteractionChanged As EventHandler

See Also

IInteractionSelector Interface
IInteractionSelector Members


IInteractionService Interface

[image]

Interaction Client Add-In Technical Reference
IInteractionService Interface
Members See Also Send Feedback
A service that returns interactions from specified interaction IDs.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public interface IInteractionService
Visual Basic
Public Interface IInteractionService

See Also

IInteractionService Members


IInteractionService Members

[image] [image]

Interaction Client Add-In Technical Reference
IInteractionService Members
IInteractionService Interface Methods See Also Send Feedback

The IInteractionService type exposes the following members.

Methods

 | Name | Description
Public method | GetInteraction | Gets an interaction that is notified of changes to the specified attributes.

See Also

IInteractionService Interface


IInteractionService Methods

[image] [image]

Interaction Client Add-In Technical Reference
IInteractionService Methods
IInteractionService Interface See Also Send Feedback

The IInteractionService type exposes the following members.

Methods

 | Name | Description
Public method | GetInteraction | Gets an interaction that is notified of changes to the specified attributes.

See Also

IInteractionService Interface


GetInteraction Method

[image]

Interaction Client Add-In Technical Reference
IInteractionService..::..GetInteraction Method
IInteractionService Interface See Also Send Feedback
Gets an interaction that is notified of changes to the specified attributes.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
IWatchedInteraction GetInteraction(
    string interactionId,
    IEnumerable<string> attributes
)
Visual Basic
Function GetInteraction ( _
    interactionId As String, _
    attributes As IEnumerable(Of String) _
) As IWatchedInteraction

Parameters

interactionId
Type: System..::..String
The interaction ID.
attributes
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'String>)>)>
The attributes on the interaction to watch for changes.

See Also

IInteractionService Interface
IInteractionService Members


INotificationService Interface

[image]

Interaction Client Add-In Technical Reference
INotificationService Interface
Members See Also Send Feedback
A service that notifies the user using supplied information.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public interface INotificationService
Visual Basic
Public Interface INotificationService

See Also

INotificationService Members


INotificationService Members

[image] [image]

Interaction Client Add-In Technical Reference
INotificationService Members
INotificationService Interface Methods See Also Send Feedback

The INotificationService type exposes the following members.

Methods

 | Name | Description
Public method | Notify | Notifies the user using the supplied information.

See Also

INotificationService Interface


INotificationService Methods

[image] [image]

Interaction Client Add-In Technical Reference
INotificationService Methods
INotificationService Interface See Also Send Feedback

The INotificationService type exposes the following members.

Methods

 | Name | Description
Public method | Notify | Notifies the user using the supplied information.

See Also

INotificationService Interface


Notify Method

[image]

Interaction Client Add-In Technical Reference
INotificationService..::..Notify Method
INotificationService Interface See Also Send Feedback
Notifies the user using the supplied information.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
void Notify(
    string message,
    string caption,
    NotificationType type,
    TimeSpan duration
)
Visual Basic
Sub Notify ( _
    message As String, _
    caption As String, _
    type As NotificationType, _
    duration As TimeSpan _
)

Parameters

message
Type: System..::..String
The message to display. This value should not be very long (less than 255 characters) as the value may not be wrapped.
caption
Type: System..::..String
The caption to use in the notification area, if appropriate.
type
Type: ININ.InteractionClient.AddIn..::..NotificationType
The type of the notification. For example, Info or Warning.
duration
Type: System..::..TimeSpan
The duration of the notification. Specify MaxValue to indicate infinite duration.

Remarks

The notification is typically a desktop alert window, but can change depending on application context.

See Also

INotificationService Interface
INotificationService Members


InteractionAttributes Class

[image]

Interaction Client Add-In Technical Reference
InteractionAttributes Class
Members See Also Send Feedback
A helper class that exposes some common interaction attribute names.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class InteractionAttributes
Visual Basic
Public NotInheritable Class InteractionAttributes

Inheritance Hierarchy

System..::..Object
ININ.InteractionClient.AddIn..::..InteractionAttributes

See Also

InteractionAttributes Members


InteractionAttributes Members

[image] [image]

Interaction Client Add-In Technical Reference
InteractionAttributes Members
InteractionAttributes Class Properties See Also Send Feedback

The InteractionAttributes type exposes the following members.

Properties

Name | Description
CallType | The type of call interaction. (Intercom/External)
ConferenceId | The conference ID the interaction belongs to.
Direction | The direction of the current interaction.
InitiationTime | The time at which the interaction was initiated.
InteractionId | The interaction ID.
InteractionType | The interaction type.
LineName | The name of the line the interaction is currently on.
Log | The interaction log.
Muted | The muted state of the interaction.
Notes | The notes associated with the interaction.
Private | The private state of the interaction.
RemoteAddress | The remote address of the interaction. This is the value that was dialed, and should be used for dialing.
RemoteId | The remote ID of the interaction. This is a display-friendly value that represents the dial string.
RemoteName | The remote name of the interaction.
State | The current state of the interaction.
StateDisplay | A user displayable version of the current state of the interaction.
StationName | The name of the station the interaction is currently on.
TerminationTime | The time at which the interaction was terminated.
UserName | The name of the user the interaction is currently assigned to.
WorkgroupName | The workgroup name.

See Also

InteractionAttributes Class


InteractionAttributes Properties

[image] [image]

Interaction Client Add-In Technical Reference
InteractionAttributes Properties
InteractionAttributes Class See Also Send Feedback

The InteractionAttributes type exposes the following members.

Properties

Name | Description
CallType | The type of call interaction. (Intercom/External)
ConferenceId | The conference ID the interaction belongs to.
Direction | The direction of the current interaction.
InitiationTime | The time at which the interaction was initiated.
InteractionId | The interaction ID.
InteractionType | The interaction type.
LineName | The name of the line the interaction is currently on.
Log | The interaction log.
Muted | The muted state of the interaction.
Notes | The notes associated with the interaction.
Private | The private state of the interaction.
RemoteAddress | The remote address of the interaction. This is the value that was dialed, and should be used for dialing.
RemoteId | The remote ID of the interaction. This is a display-friendly value that represents the dial string.
RemoteName | The remote name of the interaction.
State | The current state of the interaction.
StateDisplay | A user displayable version of the current state of the interaction.
StationName | The name of the station the interaction is currently on.
TerminationTime | The time at which the interaction was terminated.
UserName | The name of the user the interaction is currently assigned to.
WorkgroupName | The workgroup name.

See Also

InteractionAttributes Class


CallType Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributes..::..CallType Property
InteractionAttributes Class See Also Send Feedback
The type of call interaction. (Intercom/External)

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string CallType { get; }
Visual Basic
Public Shared ReadOnly Property CallType As String
    Get

See Also

InteractionAttributes Class
InteractionAttributes Members


ConferenceId Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributes..::..ConferenceId Property
InteractionAttributes Class See Also Send Feedback
The conference ID the interaction belongs to.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string ConferenceId { get; }
Visual Basic
Public Shared ReadOnly Property ConferenceId As String
    Get

See Also

InteractionAttributes Class
InteractionAttributes Members


Direction Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributes..::..Direction Property
InteractionAttributes Class See Also Send Feedback
The direction of the current interaction.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string Direction { get; }
Visual Basic
Public Shared ReadOnly Property Direction As String
    Get

See Also

InteractionAttributes Class
InteractionAttributes Members


InitiationTime Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributes..::..InitiationTime Property
InteractionAttributes Class See Also Send Feedback
The time at which the interaction was initiated.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string InitiationTime { get; }
Visual Basic
Public Shared ReadOnly Property InitiationTime As String
    Get

See Also

InteractionAttributes Class
InteractionAttributes Members


InteractionId Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributes..::..InteractionId Property
InteractionAttributes Class See Also Send Feedback
The interaction ID.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string InteractionId { get; }
Visual Basic
Public Shared ReadOnly Property InteractionId As String
    Get

See Also

InteractionAttributes Class
InteractionAttributes Members


InteractionType Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributes..::..InteractionType Property
InteractionAttributes Class See Also Send Feedback
The interaction type.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string InteractionType { get; }
Visual Basic
Public Shared ReadOnly Property InteractionType As String
    Get

See Also

InteractionAttributes Class
InteractionAttributes Members


LineName Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributes..::..LineName Property
InteractionAttributes Class See Also Send Feedback
The name of the line the interaction is currently on.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string LineName { get; }
Visual Basic
Public Shared ReadOnly Property LineName As String
    Get

See Also

InteractionAttributes Class
InteractionAttributes Members


Log Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributes..::..Log Property
InteractionAttributes Class See Also Send Feedback
The interaction log.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string Log { get; }
Visual Basic
Public Shared ReadOnly Property Log As String
    Get

See Also

InteractionAttributes Class
InteractionAttributes Members


Muted Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributes..::..Muted Property
InteractionAttributes Class See Also Send Feedback
The muted state of the interaction.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string Muted { get; }
Visual Basic
Public Shared ReadOnly Property Muted As String
    Get

See Also

InteractionAttributes Class
InteractionAttributes Members


Notes Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributes..::..Notes Property
InteractionAttributes Class See Also Send Feedback
The notes associated with the interaction.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string Notes { get; }
Visual Basic
Public Shared ReadOnly Property Notes As String
    Get

See Also

InteractionAttributes Class
InteractionAttributes Members


Private Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributes..::..Private Property
InteractionAttributes Class See Also Send Feedback
The private state of the interaction.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string Private { get; }
Visual Basic
Public Shared ReadOnly Property Private As String
    Get

See Also

InteractionAttributes Class
InteractionAttributes Members


RemoteAddress Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributes..::..RemoteAddress Property
InteractionAttributes Class See Also Send Feedback
The remote address of the interaction. This is the value that was dialed, and should be used for dialing.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string RemoteAddress { get; }
Visual Basic
Public Shared ReadOnly Property RemoteAddress As String
    Get

See Also

InteractionAttributes Class
InteractionAttributes Members


RemoteId Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributes..::..RemoteId Property
InteractionAttributes Class See Also Send Feedback
The remote ID of the interaction. This is a display-friendly value that represents the dial string.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string RemoteId { get; }
Visual Basic
Public Shared ReadOnly Property RemoteId As String
    Get

See Also

InteractionAttributes Class
InteractionAttributes Members


RemoteName Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributes..::..RemoteName Property
InteractionAttributes Class See Also Send Feedback
The remote name of the interaction.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string RemoteName { get; }
Visual Basic
Public Shared ReadOnly Property RemoteName As String
    Get

See Also

InteractionAttributes Class
InteractionAttributes Members


State Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributes..::..State Property
InteractionAttributes Class See Also Send Feedback
The current state of the interaction.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string State { get; }
Visual Basic
Public Shared ReadOnly Property State As String
    Get

See Also

InteractionAttributes Class
InteractionAttributes Members


StateDisplay Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributes..::..StateDisplay Property
InteractionAttributes Class See Also Send Feedback
A user displayable version of the current state of the interaction.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string StateDisplay { get; }
Visual Basic
Public Shared ReadOnly Property StateDisplay As String
    Get

See Also

InteractionAttributes Class
InteractionAttributes Members


StationName Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributes..::..StationName Property
InteractionAttributes Class See Also Send Feedback
The name of the station the interaction is currently on.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string StationName { get; }
Visual Basic
Public Shared ReadOnly Property StationName As String
    Get

See Also

InteractionAttributes Class
InteractionAttributes Members


TerminationTime Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributes..::..TerminationTime Property
InteractionAttributes Class See Also Send Feedback
The time at which the interaction was terminated.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string TerminationTime { get; }
Visual Basic
Public Shared ReadOnly Property TerminationTime As String
    Get

See Also

InteractionAttributes Class
InteractionAttributes Members


UserName Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributes..::..UserName Property
InteractionAttributes Class See Also Send Feedback
The name of the user the interaction is currently assigned to.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string UserName { get; }
Visual Basic
Public Shared ReadOnly Property UserName As String
    Get

See Also

InteractionAttributes Class
InteractionAttributes Members


WorkgroupName Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributes..::..WorkgroupName Property
InteractionAttributes Class See Also Send Feedback
The workgroup name.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string WorkgroupName { get; }
Visual Basic
Public Shared ReadOnly Property WorkgroupName As String
    Get

See Also

InteractionAttributes Class
InteractionAttributes Members


InteractionAttributeValues Class

[image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues Class
See Also Send Feedback
Helpers for common interaction attribute values.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class InteractionAttributeValues
Visual Basic
Public NotInheritable Class InteractionAttributeValues

Inheritance Hierarchy

System..::..Object
ININ.InteractionClient.AddIn..::..InteractionAttributeValues

See Also

ININ.InteractionClient.AddIn Namespace

Send comments on this topic to PureConnectDoc@genesys.com

Copyright (c) 1994 - 2022 Genesys


InteractionAttributeValues.CallType Class

[image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..CallType Class
InteractionAttributeValues Class Members See Also Send Feedback
Values for the CallType interaction attribute.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class CallType
Visual Basic
Public NotInheritable Class CallType

Inheritance Hierarchy

System..::..Object
ININ.InteractionClient.AddIn..::..InteractionAttributeValues..::..CallType

See Also

InteractionAttributeValues..::..CallType Members


InteractionAttributeValues.CallType Members

[image] [image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..CallType Members
InteractionAttributeValues..::..CallType Class Properties See Also Send Feedback

The InteractionAttributeValues..::..CallType type exposes the following members.

Properties

Name | Description
External | An external interaction.
Intercom | An intercom interaction.

See Also

InteractionAttributeValues..::..CallType Class


InteractionAttributeValues.CallType Properties

[image] [image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..CallType Properties
InteractionAttributeValues..::..CallType Class See Also Send Feedback

The InteractionAttributeValues..::..CallType type exposes the following members.

Properties

Name | Description
External | An external interaction.
Intercom | An intercom interaction.

See Also

InteractionAttributeValues..::..CallType Class


External Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..CallType..::..External Property
InteractionAttributeValues..::..CallType Class See Also Send Feedback
An external interaction.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string External { get; }
Visual Basic
Public Shared ReadOnly Property External As String
    Get

See Also

InteractionAttributeValues..::..CallType Class
InteractionAttributeValues..::..CallType Members


Intercom Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..CallType..::..Intercom Property
InteractionAttributeValues..::..CallType Class See Also Send Feedback
An intercom interaction.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string Intercom { get; }
Visual Basic
Public Shared ReadOnly Property Intercom As String
    Get

See Also

InteractionAttributeValues..::..CallType Class
InteractionAttributeValues..::..CallType Members


InteractionAttributeValues.Direction Class

[image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..Direction Class
InteractionAttributeValues Class Members See Also Send Feedback
Values for the Direction interaction attribute.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class Direction
Visual Basic
Public NotInheritable Class Direction

Inheritance Hierarchy

System..::..Object
ININ.InteractionClient.AddIn..::..InteractionAttributeValues..::..Direction

See Also

InteractionAttributeValues..::..Direction Members


InteractionAttributeValues.Direction Members

[image] [image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..Direction Members
InteractionAttributeValues..::..Direction Class Properties See Also Send Feedback

The InteractionAttributeValues..::..Direction type exposes the following members.

Properties

Name | Description
Incoming | An incoming interaction direction.
Outgoing | An outgoing interaction direction.

See Also

InteractionAttributeValues..::..Direction Class


InteractionAttributeValues.Direction Properties

[image] [image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..Direction Properties
InteractionAttributeValues..::..Direction Class See Also Send Feedback

The InteractionAttributeValues..::..Direction type exposes the following members.

Properties

Name | Description
Incoming | An incoming interaction direction.
Outgoing | An outgoing interaction direction.

See Also

InteractionAttributeValues..::..Direction Class


Incoming Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..Direction..::..Incoming Property
InteractionAttributeValues..::..Direction Class See Also Send Feedback
An incoming interaction direction.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string Incoming { get; }
Visual Basic
Public Shared ReadOnly Property Incoming As String
    Get

See Also

InteractionAttributeValues..::..Direction Class
InteractionAttributeValues..::..Direction Members


Outgoing Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..Direction..::..Outgoing Property
InteractionAttributeValues..::..Direction Class See Also Send Feedback
An outgoing interaction direction.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string Outgoing { get; }
Visual Basic
Public Shared ReadOnly Property Outgoing As String
    Get

See Also

InteractionAttributeValues..::..Direction Class
InteractionAttributeValues..::..Direction Members


InteractionAttributeValues.InteractionType Class

[image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..InteractionType Class
InteractionAttributeValues Class Members See Also Send Feedback
Values for the InteractionType interaction attribute.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class InteractionType
Visual Basic
Public NotInheritable Class InteractionType

Inheritance Hierarchy

System..::..Object
ININ.InteractionClient.AddIn..::..InteractionAttributeValues..::..InteractionType

See Also

InteractionAttributeValues..::..InteractionType Members


InteractionAttributeValues.InteractionType Members

[image] [image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..InteractionType Members
InteractionAttributeValues..::..InteractionType Class Properties See Also Send Feedback

The InteractionAttributeValues..::..InteractionType type exposes the following members.

Properties

Name | Description
Call | A call interaction.
Callback | A callback interaction.
Chat | A chat interaction.
Email | An email interaction.
Generic | A generic interaction.
Monitor | A monitor interaction.
Recorder | A recorder interaction.
WebCollaboration | A web collaboration interaction.
WorkItem | A work item interaction.

See Also

InteractionAttributeValues..::..InteractionType Class


InteractionAttributeValues.InteractionType Properties

[image] [image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..InteractionType Properties
InteractionAttributeValues..::..InteractionType Class See Also Send Feedback

The InteractionAttributeValues..::..InteractionType type exposes the following members.

Properties

Name | Description
Call | A call interaction.
Callback | A callback interaction.
Chat | A chat interaction.
Email | An email interaction.
Generic | A generic interaction.
Monitor | A monitor interaction.
Recorder | A recorder interaction.
WebCollaboration | A web collaboration interaction.
WorkItem | A work item interaction.

See Also

InteractionAttributeValues..::..InteractionType Class


Call Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..InteractionType..::..Call Property
InteractionAttributeValues..::..InteractionType Class See Also Send Feedback
A call interaction.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string Call { get; }
Visual Basic
Public Shared ReadOnly Property Call As String
    Get

See Also

InteractionAttributeValues..::..InteractionType Class
InteractionAttributeValues..::..InteractionType Members


Callback Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..InteractionType..::..Callback Property
InteractionAttributeValues..::..InteractionType Class See Also Send Feedback
A callback interaction.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string Callback { get; }
Visual Basic
Public Shared ReadOnly Property Callback As String
    Get

See Also

InteractionAttributeValues..::..InteractionType Class
InteractionAttributeValues..::..InteractionType Members


Chat Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..InteractionType..::..Chat Property
InteractionAttributeValues..::..InteractionType Class See Also Send Feedback
A chat interaction.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string Chat { get; }
Visual Basic
Public Shared ReadOnly Property Chat As String
    Get

See Also

InteractionAttributeValues..::..InteractionType Class
InteractionAttributeValues..::..InteractionType Members


Email Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..InteractionType..::..Email Property
InteractionAttributeValues..::..InteractionType Class See Also Send Feedback
An email interaction.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string Email { get; }
Visual Basic
Public Shared ReadOnly Property Email As String
    Get

See Also

InteractionAttributeValues..::..InteractionType Class
InteractionAttributeValues..::..InteractionType Members


Generic Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..InteractionType..::..Generic Property
InteractionAttributeValues..::..InteractionType Class See Also Send Feedback
A generic interaction.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string Generic { get; }
Visual Basic
Public Shared ReadOnly Property Generic As String
    Get

See Also

InteractionAttributeValues..::..InteractionType Class
InteractionAttributeValues..::..InteractionType Members


Monitor Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..InteractionType..::..Monitor Property
InteractionAttributeValues..::..InteractionType Class See Also Send Feedback
A monitor interaction.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string Monitor { get; }
Visual Basic
Public Shared ReadOnly Property Monitor As String
    Get

See Also

InteractionAttributeValues..::..InteractionType Class
InteractionAttributeValues..::..InteractionType Members


Recorder Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..InteractionType..::..Recorder Property
InteractionAttributeValues..::..InteractionType Class See Also Send Feedback
A recorder interaction.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string Recorder { get; }
Visual Basic
Public Shared ReadOnly Property Recorder As String
    Get

See Also

InteractionAttributeValues..::..InteractionType Class
InteractionAttributeValues..::..InteractionType Members


WebCollaboration Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..InteractionType..::..WebCollaboration Property
InteractionAttributeValues..::..InteractionType Class See Also Send Feedback
A web collaboration interaction.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string WebCollaboration { get; }
Visual Basic
Public Shared ReadOnly Property WebCollaboration As String
    Get

See Also

InteractionAttributeValues..::..InteractionType Class
InteractionAttributeValues..::..InteractionType Members


WorkItem Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..InteractionType..::..WorkItem Property
InteractionAttributeValues..::..InteractionType Class See Also Send Feedback
A work item interaction.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string WorkItem { get; }
Visual Basic
Public Shared ReadOnly Property WorkItem As String
    Get

See Also

InteractionAttributeValues..::..InteractionType Class
InteractionAttributeValues..::..InteractionType Members


InteractionAttributeValues.State Class

[image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..State Class
InteractionAttributeValues Class Members See Also Send Feedback
Values for the State interaction attribute.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static class State
Visual Basic
Public NotInheritable Class State

Inheritance Hierarchy

System..::..Object
ININ.InteractionClient.AddIn..::..InteractionAttributeValues..::..State

See Also

InteractionAttributeValues..::..State Members


InteractionAttributeValues.State Members

[image] [image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..State Members
InteractionAttributeValues..::..State Class Properties See Also Send Feedback

The InteractionAttributeValues..::..State type exposes the following members.

Properties

Name | Description
Alerting | The alerting state.
Connected | The connected state.
ExternalDisconnect | The external disconnect state.
Held | The held state.
InternalDisconnect | The internal disconnect state.
Messaging | The messaging state.
Offering | The offering state.
Parked | The parked state.
Proceeding | The proceeding state.
System | The system state.

See Also

InteractionAttributeValues..::..State Class


InteractionAttributeValues.State Properties

[image] [image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..State Properties
InteractionAttributeValues..::..State Class See Also Send Feedback

The InteractionAttributeValues..::..State type exposes the following members.

Properties

Name | Description
Alerting | The alerting state.
Connected | The connected state.
ExternalDisconnect | The external disconnect state.
Held | The held state.
InternalDisconnect | The internal disconnect state.
Messaging | The messaging state.
Offering | The offering state.
Parked | The parked state.
Proceeding | The proceeding state.
System | The system state.

See Also

InteractionAttributeValues..::..State Class


Alerting Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..State..::..Alerting Property
InteractionAttributeValues..::..State Class See Also Send Feedback
The alerting state.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string Alerting { get; }
Visual Basic
Public Shared ReadOnly Property Alerting As String
    Get

See Also

InteractionAttributeValues..::..State Class
InteractionAttributeValues..::..State Members


Connected Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..State..::..Connected Property
InteractionAttributeValues..::..State Class See Also Send Feedback
The connected state.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string Connected { get; }
Visual Basic
Public Shared ReadOnly Property Connected As String
    Get

See Also

InteractionAttributeValues..::..State Class
InteractionAttributeValues..::..State Members


ExternalDisconnect Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..State..::..ExternalDisconnect Property
InteractionAttributeValues..::..State Class See Also Send Feedback
The external disconnect state.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string ExternalDisconnect { get; }
Visual Basic
Public Shared ReadOnly Property ExternalDisconnect As String
    Get

See Also

InteractionAttributeValues..::..State Class
InteractionAttributeValues..::..State Members


Held Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..State..::..Held Property
InteractionAttributeValues..::..State Class See Also Send Feedback
The held state.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string Held { get; }
Visual Basic
Public Shared ReadOnly Property Held As String
    Get

See Also

InteractionAttributeValues..::..State Class
InteractionAttributeValues..::..State Members


InternalDisconnect Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..State..::..InternalDisconnect Property
InteractionAttributeValues..::..State Class See Also Send Feedback
The internal disconnect state.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string InternalDisconnect { get; }
Visual Basic
Public Shared ReadOnly Property InternalDisconnect As String
    Get

See Also

InteractionAttributeValues..::..State Class
InteractionAttributeValues..::..State Members


Messaging Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..State..::..Messaging Property
InteractionAttributeValues..::..State Class See Also Send Feedback
The messaging state.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string Messaging { get; }
Visual Basic
Public Shared ReadOnly Property Messaging As String
    Get

See Also

InteractionAttributeValues..::..State Class
InteractionAttributeValues..::..State Members


Offering Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..State..::..Offering Property
InteractionAttributeValues..::..State Class See Also Send Feedback
The offering state.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string Offering { get; }
Visual Basic
Public Shared ReadOnly Property Offering As String
    Get

See Also

InteractionAttributeValues..::..State Class
InteractionAttributeValues..::..State Members


Parked Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..State..::..Parked Property
InteractionAttributeValues..::..State Class See Also Send Feedback
The parked state.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string Parked { get; }
Visual Basic
Public Shared ReadOnly Property Parked As String
    Get

See Also

InteractionAttributeValues..::..State Class
InteractionAttributeValues..::..State Members


Proceeding Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..State..::..Proceeding Property
InteractionAttributeValues..::..State Class See Also Send Feedback
The proceeding state.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string Proceeding { get; }
Visual Basic
Public Shared ReadOnly Property Proceeding As String
    Get

See Also

InteractionAttributeValues..::..State Class
InteractionAttributeValues..::..State Members


System Property

[image]

Interaction Client Add-In Technical Reference
InteractionAttributeValues..::..State..::..System Property
InteractionAttributeValues..::..State Class See Also Send Feedback
The system state.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public static string System { get; }
Visual Basic
Public Shared ReadOnly Property System As String
    Get

See Also

InteractionAttributeValues..::..State Class
InteractionAttributeValues..::..State Members


InteractionEventArgs Class

[image]

Interaction Client Add-In Technical Reference
InteractionEventArgs Class
Members See Also Send Feedback
EventArgs that contain an interaction.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class InteractionEventArgs : EventArgs
Visual Basic
Public Class InteractionEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.InteractionClient.AddIn..::..InteractionEventArgs

See Also

InteractionEventArgs Members


InteractionEventArgs Members

[image] [image]

Interaction Client Add-In Technical Reference
InteractionEventArgs Members
InteractionEventArgs Class Constructors Methods Properties See Also Send Feedback

The InteractionEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | InteractionEventArgs | Initializes a new instance of the InteractionEventArgs class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Interaction | Gets or sets the interaction for this event.

See Also

InteractionEventArgs Class


InteractionEventArgs Constructor

[image]

Interaction Client Add-In Technical Reference
InteractionEventArgs Constructor
InteractionEventArgs Class See Also Send Feedback
Initializes a new instance of the InteractionEventArgs class.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public InteractionEventArgs(
    IInteraction interaction
)
Visual Basic
Public Sub New ( _
    interaction As IInteraction _
)

Parameters

interaction
Type: ININ.InteractionClient.AddIn..::..IInteraction

See Also

InteractionEventArgs Class
InteractionEventArgs Members


InteractionEventArgs Methods

[image] [image]

Interaction Client Add-In Technical Reference
InteractionEventArgs Methods
InteractionEventArgs Class See Also Send Feedback

The InteractionEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InteractionEventArgs Class


InteractionEventArgs Properties

[image] [image]

Interaction Client Add-In Technical Reference
InteractionEventArgs Properties
InteractionEventArgs Class See Also Send Feedback

The InteractionEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Interaction | Gets or sets the interaction for this event.

See Also

InteractionEventArgs Class


Interaction Property

[image]

Interaction Client Add-In Technical Reference
InteractionEventArgs..::..Interaction Property
InteractionEventArgs Class See Also Send Feedback
Gets or sets the interaction for this event.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public IInteraction Interaction { get; }
Visual Basic
Public ReadOnly Property Interaction As IInteraction
    Get

See Also

InteractionEventArgs Class
InteractionEventArgs Members


IQueue Interface

[image]

Interaction Client Add-In Technical Reference
IQueue Interface
Members See Also Send Feedback
A queue in the Interaction Center server.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public interface IQueue : IDisposable
Visual Basic
Public Interface IQueue _
    Inherits IDisposable

Remarks

Retrieve the current list of IInteractions in the queue from the Interactions property. Subscribe to the InteractionAdded, InteractionRemoved, or InteractionChanged events to be notified when an interaction is added, removed, or changes. Dispose of this instance using the IDisposable interface to release server resources related to monitoring this queue.

See Also

IQueue Members


IQueue Members

[image] [image]

Interaction Client Add-In Technical Reference
IQueue Members
IQueue Interface Methods Properties Events See Also Send Feedback

The IQueue type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)

Properties

 | Name | Description
Public property | Interactions | Gets the interactions on the queue.
Public property | Name | Gets the name of the queue being watched.

Events

 | Name | Description
Public event | InteractionAdded | Occurs when an interaction is added to the queue.
Public event | InteractionChanged | Occurs when an interaction on the queue has changed.
Public event | InteractionRemoved | Occurs when an interaction is removed from the queue.

See Also

IQueue Interface


IQueue Methods

[image] [image]

Interaction Client Add-In Technical Reference
IQueue Methods
IQueue Interface See Also Send Feedback

The IQueue type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)

See Also

IQueue Interface


IQueue Properties

[image] [image]

Interaction Client Add-In Technical Reference
IQueue Properties
IQueue Interface See Also Send Feedback

The IQueue type exposes the following members.

Properties

 | Name | Description
Public property | Interactions | Gets the interactions on the queue.
Public property | Name | Gets the name of the queue being watched.

See Also

IQueue Interface


Interactions Property

[image]

Interaction Client Add-In Technical Reference
IQueue..::..Interactions Property
IQueue Interface See Also Send Feedback
Gets the interactions on the queue.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
ICollection<IInteraction> Interactions { get; }
Visual Basic
ReadOnly Property Interactions As ICollection(Of IInteraction)
    Get

Field Value

The interactions on the queue.

See Also

IQueue Interface
IQueue Members


Name Property

[image]

Interaction Client Add-In Technical Reference
IQueue..::..Name Property
IQueue Interface See Also Send Feedback
Gets the name of the queue being watched.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
string Name { get; }
Visual Basic
ReadOnly Property Name As String
    Get

See Also

IQueue Interface
IQueue Members


IQueue Events

[image] [image]

Interaction Client Add-In Technical Reference
IQueue Events
IQueue Interface See Also Send Feedback

The IQueue type exposes the following members.

Events

 | Name | Description
Public event | InteractionAdded | Occurs when an interaction is added to the queue.
Public event | InteractionChanged | Occurs when an interaction on the queue has changed.
Public event | InteractionRemoved | Occurs when an interaction is removed from the queue.

See Also

IQueue Interface


InteractionAdded Event

[image]

Interaction Client Add-In Technical Reference
IQueue..::..InteractionAdded Event
IQueue Interface See Also Send Feedback
Occurs when an interaction is added to the queue.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
event EventHandler<InteractionEventArgs> InteractionAdded
Visual Basic
Event InteractionAdded As EventHandler(Of InteractionEventArgs)

See Also

IQueue Interface
IQueue Members


InteractionChanged Event

[image]

Interaction Client Add-In Technical Reference
IQueue..::..InteractionChanged Event
IQueue Interface See Also Send Feedback
Occurs when an interaction on the queue has changed.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
event EventHandler<InteractionEventArgs> InteractionChanged
Visual Basic
Event InteractionChanged As EventHandler(Of InteractionEventArgs)

See Also

IQueue Interface
IQueue Members


InteractionRemoved Event

[image]

Interaction Client Add-In Technical Reference
IQueue..::..InteractionRemoved Event
IQueue Interface See Also Send Feedback
Occurs when an interaction is removed from the queue.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
event EventHandler<InteractionEventArgs> InteractionRemoved
Visual Basic
Event InteractionRemoved As EventHandler(Of InteractionEventArgs)

See Also

IQueue Interface
IQueue Members


IQueueService Interface

[image]

Interaction Client Add-In Technical Reference
IQueueService Interface
Members See Also Send Feedback
An application service that returns a queue for a given queue name.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public interface IQueueService
Visual Basic
Public Interface IQueueService

See Also

IQueueService Members


IQueueService Members

[image] [image]

Interaction Client Add-In Technical Reference
IQueueService Members
IQueueService Interface Methods Properties See Also Send Feedback

The IQueueService type exposes the following members.

Methods

 | Name | Description
Public method | GetMyInteractions(IEnumerable<(Of <<'(String>)>>)) | Gets the "My Interactions" queue for the logged in user.
Public method | GetMyInteractions(IEnumerable<(Of <<'(String>)>>), IEnumerable<(Of <<'(String>)>>)) | Gets the "My Interactions" queue for the logged in user.
Public method | GetQueue(String, IEnumerable<(Of <<'(String>)>>)) | Gets the specified queue.
Public method | GetQueue(String, IEnumerable<(Of <<'(String>)>>), IEnumerable<(Of <<'(String>)>>)) | Gets the specified queue.

Properties

 | Name | Description
Public property | MyInteractionsQueueName | Gets the queue name for the currently logged in user's "My Interactions" queue.

See Also

IQueueService Interface


IQueueService Methods

[image] [image]

Interaction Client Add-In Technical Reference
IQueueService Methods
IQueueService Interface See Also Send Feedback

Methods

 | Name | Description
Public method | GetMyInteractions(IEnumerable<(Of <<'(String>)>>)) | Gets the "My Interactions" queue for the logged in user.
Public method | GetMyInteractions(IEnumerable<(Of <<'(String>)>>), IEnumerable<(Of <<'(String>)>>)) | Gets the "My Interactions" queue for the logged in user.
Public method | GetQueue(String, IEnumerable<(Of <<'(String>)>>)) | Gets the specified queue.
Public method | GetQueue(String, IEnumerable<(Of <<'(String>)>>), IEnumerable<(Of <<'(String>)>>)) | Gets the specified queue.

See Also

IQueueService Interface


GetMyInteractions Method

[image] [image]

Interaction Client Add-In Technical Reference
IQueueService..::..GetMyInteractions Method
IQueueService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetMyInteractions(IEnumerable<(Of <<'(String>)>>)) | Gets the "My Interactions" queue for the logged in user.
Public method | GetMyInteractions(IEnumerable<(Of <<'(String>)>>), IEnumerable<(Of <<'(String>)>>)) | Gets the "My Interactions" queue for the logged in user.

See Also

IQueueService Interface
IQueueService Members


GetMyInteractions Method (IEnumerable(String))

[image]

Interaction Client Add-In Technical Reference
IQueueService..::..GetMyInteractions Method (IEnumerable<(Of <(<'String>)>)>)
IQueueService Interface See Also Send Feedback
Gets the "My Interactions" queue for the logged in user.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
IQueue GetMyInteractions(
    IEnumerable<string> attributes
)
Visual Basic
Function GetMyInteractions ( _
    attributes As IEnumerable(Of String) _
) As IQueue

Parameters

attributes
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'String>)>)>
The interaction attributes to monitor for changes on the queue.

Return Value

An IQueue instance corresponding to the "My Interactions" queue.

See Also

IQueueService Interface
IQueueService Members
GetMyInteractions Overload


GetMyInteractions Method (IEnumerable(String), IEnumerable(String))

[image]

Interaction Client Add-In Technical Reference
IQueueService..::..GetMyInteractions Method (IEnumerable<(Of <(<'String>)>)>, IEnumerable<(Of <(<'String>)>)>)
IQueueService Interface See Also Send Feedback
Gets the "My Interactions" queue for the logged in user.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
IQueue GetMyInteractions(
    IEnumerable<string> attributes,
    IEnumerable<string> supportingAttributes
)
Visual Basic
Function GetMyInteractions ( _
    attributes As IEnumerable(Of String), _
    supportingAttributes As IEnumerable(Of String) _
) As IQueue

Parameters

attributes
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'String>)>)>
The interaction attributes to monitor for changes on the queue.
supportingAttributes
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'String>)>)>
Additional interaction attributes for which change notifications are not raised, but are still available to query on an interaction.

Return Value

An IQueue instance corresponding to the "My Interactions" queue.

See Also

IQueueService Interface
IQueueService Members
GetMyInteractions Overload


GetQueue Method

[image] [image]

Interaction Client Add-In Technical Reference
IQueueService..::..GetQueue Method
IQueueService Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | GetQueue(String, IEnumerable<(Of <<'(String>)>>)) | Gets the specified queue.
Public method | GetQueue(String, IEnumerable<(Of <<'(String>)>>), IEnumerable<(Of <<'(String>)>>)) | Gets the specified queue.

See Also

IQueueService Interface
IQueueService Members


GetQueue Method (String, IEnumerable(String))

[image]

Interaction Client Add-In Technical Reference
IQueueService..::..GetQueue Method (String, IEnumerable<(Of <(<'String>)>)>)
IQueueService Interface See Also Send Feedback
Gets the specified queue.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
IQueue GetQueue(
    string name,
    IEnumerable<string> attributes
)
Visual Basic
Function GetQueue ( _
    name As String, _
    attributes As IEnumerable(Of String) _
) As IQueue

Parameters

name
Type: System..::..String
The name of the queue. An empty string will get the "My Interactions" queue, or use the MyInteractionsQueueName property to explicitly specify the "My Interactions" queue.
attributes
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'String>)>)>
The interaction attributes to monitor for changes on the queue.

Return Value

An IQueue instance corresponding to the specified queue name.

See Also

IQueueService Interface
IQueueService Members
GetQueue Overload


GetQueue Method (String, IEnumerable(String), IEnumerable(String))

[image]

Interaction Client Add-In Technical Reference
IQueueService..::..GetQueue Method (String, IEnumerable<(Of <(<'String>)>)>, IEnumerable<(Of <(<'String>)>)>)
IQueueService Interface See Also Send Feedback
Gets the specified queue.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
IQueue GetQueue(
    string name,
    IEnumerable<string> attributes,
    IEnumerable<string> supportingAttributes
)
Visual Basic
Function GetQueue ( _
    name As String, _
    attributes As IEnumerable(Of String), _
    supportingAttributes As IEnumerable(Of String) _
) As IQueue

Parameters

name
Type: System..::..String
The name of the queue. An empty string will get the "My Interactions" queue, or use the MyInteractionsQueueName property to explicitly specify the "My Interactions" queue.
attributes
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'String>)>)>
The interaction attributes to monitor for changes on the queue.
supportingAttributes
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'String>)>)>
Additional interaction attributes for which change notifications are not raised, but are still available to query on an interaction.

Return Value

An IQueue instance corresponding to the specified queue name.

See Also

IQueueService Interface
IQueueService Members
GetQueue Overload


IQueueService Properties

[image] [image]

Interaction Client Add-In Technical Reference
IQueueService Properties
IQueueService Interface See Also Send Feedback

The IQueueService type exposes the following members.

Properties

 | Name | Description
Public property | MyInteractionsQueueName | Gets the queue name for the currently logged in user's "My Interactions" queue.

See Also

IQueueService Interface


MyInteractionsQueueName Property

[image]

Interaction Client Add-In Technical Reference
IQueueService..::..MyInteractionsQueueName Property
IQueueService Interface See Also Send Feedback
Gets the queue name for the currently logged in user's "My Interactions" queue.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
string MyInteractionsQueueName { get; }
Visual Basic
ReadOnly Property MyInteractionsQueueName As String
    Get

Field Value

The queue name representing the "My Interactions" queue, or empty string if there is no currently logged in user.

See Also

IQueueService Interface
IQueueService Members


IScreenPop Interface

[image]

Interaction Client Add-In Technical Reference
IScreenPop Interface
Members See Also Send Feedback
Initiates a screen pop. Implement this interface and add an instance of the implementation to the IScreenPopService to enable the screen pop.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public interface IScreenPop
Visual Basic
Public Interface IScreenPop

Remarks

A "screen pop" can be initiated many ways, but is most commonly initiated by an interaction on the Interaction Center server. Information configured by an administrator dictates what information is passed into the Pop(IDictionary<(Of <<'(String, String>)>>)) method. In addition, interaction attributes (if available) specified by the AdditionalAttributes property will be included in the input to the Pop(IDictionary<(Of <<'(String, String>)>>)) method.

See Also

IScreenPop Members


IScreenPop Members

[image] [image]

Interaction Client Add-In Technical Reference
IScreenPop Members
IScreenPop Interface Methods Properties See Also Send Feedback

The IScreenPop type exposes the following members.

Methods

 | Name | Description
Public method | Pop | Initiates a screen pop.

Properties

 | Name | Description
Public property | AdditionalAttributes | Gets additional interaction attributes this screen pop needs. If the screen pop is being initiated from an interaction, these attributes will be gathered and passed to the Pop(IDictionary<(Of <<'(String, String>)>>)) method in addition to server-defined attributes.
Public property | Name | Gets the name of this screen pop. The name is used to find the screen pop and activate it.

See Also

IScreenPop Interface


IScreenPop Methods

[image] [image]

Interaction Client Add-In Technical Reference
IScreenPop Methods
IScreenPop Interface See Also Send Feedback

The IScreenPop type exposes the following members.

Methods

 | Name | Description
Public method | Pop | Initiates a screen pop.

See Also

IScreenPop Interface


Pop Method

[image]

Interaction Client Add-In Technical Reference
IScreenPop..::..Pop Method
IScreenPop Interface See Also Send Feedback
Initiates a screen pop.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
void Pop(
    IDictionary<string, string> attributes
)
Visual Basic
Sub Pop ( _
    attributes As IDictionary(Of String, String) _
)

Parameters

attributes
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, String>)>)>
The specified Interaction and screen pop provider-specific attributes.

See Also

IScreenPop Interface
IScreenPop Members


IScreenPop Properties

[image] [image]

Interaction Client Add-In Technical Reference
IScreenPop Properties
IScreenPop Interface See Also Send Feedback

The IScreenPop type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalAttributes | Gets additional interaction attributes this screen pop needs. If the screen pop is being initiated from an interaction, these attributes will be gathered and passed to the Pop(IDictionary<(Of <<'(String, String>)>>)) method in addition to server-defined attributes.
Public property | Name | Gets the name of this screen pop. The name is used to find the screen pop and activate it.

See Also

IScreenPop Interface


AdditionalAttributes Property

[image]

Interaction Client Add-In Technical Reference
IScreenPop..::..AdditionalAttributes Property
IScreenPop Interface See Also Send Feedback
Gets additional interaction attributes this screen pop needs. If the screen pop is being initiated from an interaction, these attributes will be gathered and passed to the Pop(IDictionary<(Of <<'(String, String>)>>)) method in addition to server-defined attributes.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
IEnumerable<string> AdditionalAttributes { get; }
Visual Basic
ReadOnly Property AdditionalAttributes As IEnumerable(Of String)
    Get

Field Value

The interaction attributes to retrieve.

See Also

IScreenPop Interface
IScreenPop Members


Name Property

[image]

Interaction Client Add-In Technical Reference
IScreenPop..::..Name Property
IScreenPop Interface See Also Send Feedback
Gets the name of this screen pop. The name is used to find the screen pop and activate it.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
string Name { get; }
Visual Basic
ReadOnly Property Name As String
    Get

Field Value

The name of the screen pop.

See Also

IScreenPop Interface
IScreenPop Members


IScreenPopService Interface

[image]

Interaction Client Add-In Technical Reference
IScreenPopService Interface
Members See Also Send Feedback
A service that manages IScreenPop instances.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public interface IScreenPopService
Visual Basic
Public Interface IScreenPopService

Remarks

Add your implementation of IScreenPop to this service, and this service will trigger the IScreenPop appropriately, using the Name property as the identifier.

See Also

IScreenPopService Members


IScreenPopService Members

[image] [image]

Interaction Client Add-In Technical Reference
IScreenPopService Members
IScreenPopService Interface Methods Properties See Also Send Feedback

The IScreenPopService type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an IScreenPop to the list of available screen pops.
Public method | Remove | Removes the IScreenPop from the list of available screen pops.

Properties

 | Name | Description
Public property | Item | Gets the IScreenPop with the specified name.

See Also

IScreenPopService Interface


IScreenPopService Methods

[image] [image]

Interaction Client Add-In Technical Reference
IScreenPopService Methods
IScreenPopService Interface See Also Send Feedback

The IScreenPopService type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an IScreenPop to the list of available screen pops.
Public method | Remove | Removes the IScreenPop from the list of available screen pops.

See Also

IScreenPopService Interface


Add Method

[image]

Interaction Client Add-In Technical Reference
IScreenPopService..::..Add Method
IScreenPopService Interface See Also Send Feedback
Adds an IScreenPop to the list of available screen pops.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
void Add(
    IScreenPop screenPop
)
Visual Basic
Sub Add ( _
    screenPop As IScreenPop _
)

Parameters

screenPop
Type: ININ.InteractionClient.AddIn..::..IScreenPop
The IScreenPop to add.

See Also

IScreenPopService Interface
IScreenPopService Members


Remove Method

[image]

Interaction Client Add-In Technical Reference
IScreenPopService..::..Remove Method
IScreenPopService Interface See Also Send Feedback
Removes the IScreenPop from the list of available screen pops.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
bool Remove(
    IScreenPop screenPop
)
Visual Basic
Function Remove ( _
    screenPop As IScreenPop _
) As Boolean

Parameters

screenPop
Type: ININ.InteractionClient.AddIn..::..IScreenPop
The IScreenPop to remove.

Return Value

trueTruetruetrue (True in Visual Basic) if removed, falseFalsefalsefalse (False in Visual Basic) if not removed or not found.

See Also

IScreenPopService Interface
IScreenPopService Members


IScreenPopService Properties

[image] [image]

Interaction Client Add-In Technical Reference
IScreenPopService Properties
IScreenPopService Interface See Also Send Feedback

The IScreenPopService type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets the IScreenPop with the specified name.

See Also

IScreenPopService Interface


Item Property

[image]

Interaction Client Add-In Technical Reference
IScreenPopService..::..Item Property
IScreenPopService Interface See Also Send Feedback
Gets the IScreenPop with the specified name.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
IScreenPop this[
    string name
] { get; }
Visual Basic
ReadOnly Default Property Item ( _
    name As String _
) As IScreenPop
    Get

Parameters

name
Type: System..::..String

Return Value

The IScreenPop, if found, or nullNothingnullptra null reference (Nothing in Visual Basic) if not found.

See Also

IScreenPopService Interface
IScreenPopService Members


ISecureInput Interface

[image]

Interaction Client Add-In Technical Reference
ISecureInput Interface
Members See Also Send Feedback
Provides access to a custom secure input. Implement this interface and add an instance of the implementation to the ISecureInputService to make the custom secure input available.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public interface ISecureInput
Visual Basic
Public Interface ISecureInput

Remarks

A secure input is selected by the user. If the user selects a custom secure input, the Interaction Client will use the matching named form which was added to the ISecureInputService. Parameters configured by an administrator dictates what information is passed into the GetForm(IDictionary<(Of <<'(String, String>)>>)) method. In addition, interaction attributes (if available) specified by the AdditionalAttributes property will be included in the parameter dictionary given to the GetForm(IDictionary<(Of <<'(String, String>)>>)) method.

See Also

ISecureInput Members


ISecureInput Members

[image] [image]

Interaction Client Add-In Technical Reference
ISecureInput Members
ISecureInput Interface Methods Properties See Also Send Feedback

The ISecureInput type exposes the following members.

Methods

 | Name | Description
Public method | GetForm | Gets the secure input form to display.

Properties

 | Name | Description
Public property | AdditionalAttributes | Gets additional interaction attributes this secure input needs. These attributes will be gathered and included in the parameter passed to the GetForm(IDictionary<(Of <<'(String, String>)>>)) method in addition to server-defined parameters.
Public property | Name | Gets the name of this secure input. The name is used to find the secure input and activate it.

See Also

ISecureInput Interface


ISecureInput Methods

[image] [image]

Interaction Client Add-In Technical Reference
ISecureInput Methods
ISecureInput Interface See Also Send Feedback

The ISecureInput type exposes the following members.

Methods

 | Name | Description
Public method | GetForm | Gets the secure input form to display.

See Also

ISecureInput Interface


GetForm Method

[image]

Interaction Client Add-In Technical Reference
ISecureInput..::..GetForm Method
ISecureInput Interface See Also Send Feedback
Gets the secure input form to display.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
ISecureInputForm GetForm(
    IDictionary<string, string> parameters
)
Visual Basic
Function GetForm ( _
    parameters As IDictionary(Of String, String) _
) As ISecureInputForm

Parameters

parameters
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, String>)>)>
The specified Interaction and secure input parameters.

See Also

ISecureInput Interface
ISecureInput Members


ISecureInput Properties

[image] [image]

Interaction Client Add-In Technical Reference
ISecureInput Properties
ISecureInput Interface See Also Send Feedback

The ISecureInput type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalAttributes | Gets additional interaction attributes this secure input needs. These attributes will be gathered and included in the parameter passed to the GetForm(IDictionary<(Of <<'(String, String>)>>)) method in addition to server-defined parameters.
Public property | Name | Gets the name of this secure input. The name is used to find the secure input and activate it.

See Also

ISecureInput Interface


AdditionalAttributes Property

[image]

Interaction Client Add-In Technical Reference
ISecureInput..::..AdditionalAttributes Property
ISecureInput Interface See Also Send Feedback
Gets additional interaction attributes this secure input needs. These attributes will be gathered and included in the parameter passed to the GetForm(IDictionary<(Of <<'(String, String>)>>)) method in addition to server-defined parameters.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
IEnumerable<string> AdditionalAttributes { get; }
Visual Basic
ReadOnly Property AdditionalAttributes As IEnumerable(Of String)
    Get

Field Value

The interaction attributes to retrieve.

See Also

ISecureInput Interface
ISecureInput Members


Name Property

[image]

Interaction Client Add-In Technical Reference
ISecureInput..::..Name Property
ISecureInput Interface See Also Send Feedback
Gets the name of this secure input. The name is used to find the secure input and activate it.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
string Name { get; }
Visual Basic
ReadOnly Property Name As String
    Get

Field Value

The name of the secure input.

See Also

ISecureInput Interface
ISecureInput Members


ISecureInputForm Interface

[image]

Interaction Client Add-In Technical Reference
ISecureInputForm Interface
Members See Also Send Feedback
A secure input form is a control (Windows Forms or WPF) that is embedded into a containing window and shown to the user in order to collect information before sending a caller into a secure IVR session.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public interface ISecureInputForm
Visual Basic
Public Interface ISecureInputForm

See Also

ISecureInputForm Members


ISecureInputForm Members

[image] [image]

Interaction Client Add-In Technical Reference
ISecureInputForm Members
ISecureInputForm Interface Properties Events See Also Send Feedback

The ISecureInputForm type exposes the following members.

Properties

 | Name | Description
Public property | Content | Gets the main content to be displayed in the secure input window displayed to the user.
Public property | IsValid | Gets a value indicating the state of the form.
Public property | SecureParameters | Gets a dictionary with the name/value pairs that will be provided to the secure IVR, and to the 3rd party service processing the secure input session.

Events

 | Name | Description
Public event | IsValidChanged | Occurs when the IsValid property is changed.

See Also

ISecureInputForm Interface


ISecureInputForm Properties

[image] [image]

Interaction Client Add-In Technical Reference
ISecureInputForm Properties
ISecureInputForm Interface See Also Send Feedback

The ISecureInputForm type exposes the following members.

Properties

 | Name | Description
Public property | Content | Gets the main content to be displayed in the secure input window displayed to the user.
Public property | IsValid | Gets a value indicating the state of the form.
Public property | SecureParameters | Gets a dictionary with the name/value pairs that will be provided to the secure IVR, and to the 3rd party service processing the secure input session.

See Also

ISecureInputForm Interface


Content Property

[image]

Interaction Client Add-In Technical Reference
ISecureInputForm..::..Content Property
ISecureInputForm Interface See Also Send Feedback
Gets the main content to be displayed in the secure input window displayed to the user.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
Object Content { get; }
Visual Basic
ReadOnly Property Content As Object
    Get

Return Value

Return either a Windows Forms Control or a Windows Presentation Foundation Control. Any other return type will be ignored.

See Also

ISecureInputForm Interface
ISecureInputForm Members


IsValid Property

[image]

Interaction Client Add-In Technical Reference
ISecureInputForm..::..IsValid Property
ISecureInputForm Interface See Also Send Feedback
Gets a value indicating the state of the form.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
bool IsValid { get; }
Visual Basic
ReadOnly Property IsValid As Boolean
    Get

Return Value

trueTruetruetrue (True in Visual Basic) if the data is valid and the user may proceed, falseFalsefalsefalse (False in Visual Basic) if the user is not allowed to proceed with the secure input form.

See Also

ISecureInputForm Interface
ISecureInputForm Members


SecureParameters Property

[image]

Interaction Client Add-In Technical Reference
ISecureInputForm..::..SecureParameters Property
ISecureInputForm Interface See Also Send Feedback
Gets a dictionary with the name/value pairs that will be provided to the secure IVR, and to the 3rd party service processing the secure input session.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
IDictionary<string, string> SecureParameters { get; }
Visual Basic
ReadOnly Property SecureParameters As IDictionary(Of String, String)
    Get

See Also

ISecureInputForm Interface
ISecureInputForm Members


ISecureInputForm Events

[image] [image]

Interaction Client Add-In Technical Reference
ISecureInputForm Events
ISecureInputForm Interface See Also Send Feedback

The ISecureInputForm type exposes the following members.

Events

 | Name | Description
Public event | IsValidChanged | Occurs when the IsValid property is changed.

See Also

ISecureInputForm Interface


IsValidChanged Event

[image]

Interaction Client Add-In Technical Reference
ISecureInputForm..::..IsValidChanged Event
ISecureInputForm Interface See Also Send Feedback
Occurs when the IsValid property is changed.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
event EventHandler IsValidChanged
Visual Basic
Event IsValidChanged As EventHandler

See Also

ISecureInputForm Interface
ISecureInputForm Members


ISecureInputService Interface

[image]

Interaction Client Add-In Technical Reference
ISecureInputService Interface
Members See Also Send Feedback
A service that manages ISecureInput instances.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public interface ISecureInputService
Visual Basic
Public Interface ISecureInputService

Remarks

Add your implementation of ISecureInput to this service, and this service will trigger the ISecureInput appropriately, using the Name property as the identifier.

See Also

ISecureInputService Members


ISecureInputService Members

[image] [image]

Interaction Client Add-In Technical Reference
ISecureInputService Members
ISecureInputService Interface Methods Properties See Also Send Feedback

The ISecureInputService type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an ISecureInput to the list of available secure inputs.
Public method | Remove | Removes the ISecureInput from the list of available secure inputs.

Properties

 | Name | Description
Public property | Item | Gets the ISecureInput with the specified name.

See Also

ISecureInputService Interface


ISecureInputService Methods

[image] [image]

Interaction Client Add-In Technical Reference
ISecureInputService Methods
ISecureInputService Interface See Also Send Feedback

The ISecureInputService type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an ISecureInput to the list of available secure inputs.
Public method | Remove | Removes the ISecureInput from the list of available secure inputs.

See Also

ISecureInputService Interface


Add Method

[image]

Interaction Client Add-In Technical Reference
ISecureInputService..::..Add Method
ISecureInputService Interface See Also Send Feedback
Adds an ISecureInput to the list of available secure inputs.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
void Add(
    ISecureInput secureInput
)
Visual Basic
Sub Add ( _
    secureInput As ISecureInput _
)

Parameters

secureInput
Type: ININ.InteractionClient.AddIn..::..ISecureInput
The ISecureInput to add.

See Also

ISecureInputService Interface
ISecureInputService Members


Remove Method

[image]

Interaction Client Add-In Technical Reference
ISecureInputService..::..Remove Method
ISecureInputService Interface See Also Send Feedback
Removes the ISecureInput from the list of available secure inputs.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
bool Remove(
    ISecureInput secureInput
)
Visual Basic
Function Remove ( _
    secureInput As ISecureInput _
) As Boolean

Parameters

secureInput
Type: ININ.InteractionClient.AddIn..::..ISecureInput
The ISecureInput to remove.

Return Value

trueTruetruetrue (True in Visual Basic) if removed, falseFalsefalsefalse (False in Visual Basic) if not removed or not found.

See Also

ISecureInputService Interface
ISecureInputService Members


ISecureInputService Properties

[image] [image]

Interaction Client Add-In Technical Reference
ISecureInputService Properties
ISecureInputService Interface See Also Send Feedback

The ISecureInputService type exposes the following members.

Properties

 | Name | Description
Public property | Item | Gets the ISecureInput with the specified name.

See Also

ISecureInputService Interface


Item Property

[image]

Interaction Client Add-In Technical Reference
ISecureInputService..::..Item Property
ISecureInputService Interface See Also Send Feedback
Gets the ISecureInput with the specified name.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
ISecureInput this[
    string name
] { get; }
Visual Basic
ReadOnly Default Property Item ( _
    name As String _
) As ISecureInput
    Get

Parameters

name
Type: System..::..String

Return Value

The ISecureInput, if found, or nullNothingnullptra null reference (Nothing in Visual Basic) if not found.

See Also

ISecureInputService Interface
ISecureInputService Members


ITraceContext Interface

[image]

Interaction Client Add-In Technical Reference
ITraceContext Interface
Members See Also Send Feedback
A tracing context from which messages can be added to the Interaction Client log file.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public interface ITraceContext
Visual Basic
Public Interface ITraceContext

Remarks

The trace messages are logged at levels in the following order (from low to high): Always(String), Error(String), Warning(String), Status(String), Note(String), Verbose(String). For example, traces logged with the Warning(String) method will be traced if the trace settings are at "Warning" level or higher. However if the trace setting is at "Error", the message will not be logged.

See Also

ITraceContext Members


ITraceContext Members

[image] [image]

Interaction Client Add-In Technical Reference
ITraceContext Members
ITraceContext Interface Methods See Also Send Feedback

The ITraceContext type exposes the following members.

Methods

 | Name | Description
Public method | Always | Always traces the specified message, regardless of trace level settings.
Public method | Error | Traces the specified message at the Error trace level.
Public method | Exception | Traces the specified exception and message at the Error trace level.
Public method | Note | Traces the specified message at the Note trace level.
Public method | Status | Traces the specified message at the Status trace level.
Public method | Verbose | Traces the specified message at the Verbose trace level.
Public method | Warning | Traces the specified message at the Warning trace level.

See Also

ITraceContext Interface


ITraceContext Methods

[image] [image]

Interaction Client Add-In Technical Reference
ITraceContext Methods
ITraceContext Interface See Also Send Feedback

The ITraceContext type exposes the following members.

Methods

 | Name | Description
Public method | Always | Always traces the specified message, regardless of trace level settings.
Public method | Error | Traces the specified message at the Error trace level.
Public method | Exception | Traces the specified exception and message at the Error trace level.
Public method | Note | Traces the specified message at the Note trace level.
Public method | Status | Traces the specified message at the Status trace level.
Public method | Verbose | Traces the specified message at the Verbose trace level.
Public method | Warning | Traces the specified message at the Warning trace level.

See Also

ITraceContext Interface


Always Method

[image]

Interaction Client Add-In Technical Reference
ITraceContext..::..Always Method
ITraceContext Interface See Also Send Feedback
Always traces the specified message, regardless of trace level settings.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
void Always(
    string message
)
Visual Basic
Sub Always ( _
    message As String _
)

Parameters

message
Type: System..::..String
The trace message.

See Also

ITraceContext Interface
ITraceContext Members


Error Method

[image]

Interaction Client Add-In Technical Reference
ITraceContext..::..Error Method
ITraceContext Interface See Also Send Feedback
Traces the specified message at the Error trace level.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
void Error(
    string message
)
Visual Basic
Sub Error ( _
    message As String _
)

Parameters

message
Type: System..::..String
The trace message.

See Also

ITraceContext Interface
ITraceContext Members


Exception Method

[image]

Interaction Client Add-In Technical Reference
ITraceContext..::..Exception Method
ITraceContext Interface See Also Send Feedback
Traces the specified exception and message at the Error trace level.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
void Exception(
    Exception exception,
    string message
)
Visual Basic
Sub Exception ( _
    exception As Exception, _
    message As String _
)

Parameters

exception
Type: System..::..Exception
The exception to trace. Inner exceptions will also be traced.
message
Type: System..::..String
The trace message.

See Also

ITraceContext Interface
ITraceContext Members


Note Method

[image]

Interaction Client Add-In Technical Reference
ITraceContext..::..Note Method
ITraceContext Interface See Also Send Feedback
Traces the specified message at the Note trace level.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
void Note(
    string message
)
Visual Basic
Sub Note ( _
    message As String _
)

Parameters

message
Type: System..::..String
The trace message.

See Also

ITraceContext Interface
ITraceContext Members


Status Method

[image]

Interaction Client Add-In Technical Reference
ITraceContext..::..Status Method
ITraceContext Interface See Also Send Feedback
Traces the specified message at the Status trace level.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
void Status(
    string message
)
Visual Basic
Sub Status ( _
    message As String _
)

Parameters

message
Type: System..::..String
The trace message.

See Also

ITraceContext Interface
ITraceContext Members


Verbose Method

[image]

Interaction Client Add-In Technical Reference
ITraceContext..::..Verbose Method
ITraceContext Interface See Also Send Feedback
Traces the specified message at the Verbose trace level.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
void Verbose(
    string message
)
Visual Basic
Sub Verbose ( _
    message As String _
)

Parameters

message
Type: System..::..String
The trace message.

See Also

ITraceContext Interface
ITraceContext Members


Warning Method

[image]

Interaction Client Add-In Technical Reference
ITraceContext..::..Warning Method
ITraceContext Interface See Also Send Feedback
Traces the specified message at the Warning trace level.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
void Warning(
    string message
)
Visual Basic
Sub Warning ( _
    message As String _
)

Parameters

message
Type: System..::..String
The trace message.

See Also

ITraceContext Interface
ITraceContext Members


IWatchedInteraction Interface

[image]

Interaction Client Add-In Technical Reference
IWatchedInteraction Interface
Members See Also Send Feedback
An IInteraction that raises the InteractionChanged event when its attributes change.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public interface IWatchedInteraction : IInteraction,
    IDisposable
Visual Basic
Public Interface IWatchedInteraction _
    Inherits IInteraction, IDisposable

Remarks

Dispose of the interaction using the IDisposable interface to release server resources involved in monitoring the interaction for changes.

See Also

IWatchedInteraction Members


IWatchedInteraction Members

[image] [image]

Interaction Client Add-In Technical Reference
IWatchedInteraction Members
IWatchedInteraction Interface Methods Properties Events See Also Send Feedback

The IWatchedInteraction type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetAttribute | Gets the specified interaction attribute. (Inherited from IInteraction.)
Public method | SetAttribute | Sets the specified interaction attribute. (Inherited from IInteraction.)

Properties

 | Name | Description
Public property | InteractionId | Gets the ID of the interaction. (Inherited from IInteraction.)
Public property | Item | Gets or sets the specified interaction attribute by name. (Inherited from IInteraction.)

Events

 | Name | Description
Public event | InteractionChanged | Occurs when the interaction changes.

See Also

IWatchedInteraction Interface


IWatchedInteraction Methods

[image] [image]

Interaction Client Add-In Technical Reference
IWatchedInteraction Methods
IWatchedInteraction Interface See Also Send Feedback

The IWatchedInteraction type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetAttribute | Gets the specified interaction attribute. (Inherited from IInteraction.)
Public method | SetAttribute | Sets the specified interaction attribute. (Inherited from IInteraction.)

See Also

IWatchedInteraction Interface


IWatchedInteraction Properties

[image] [image]

Interaction Client Add-In Technical Reference
IWatchedInteraction Properties
IWatchedInteraction Interface See Also Send Feedback

The IWatchedInteraction type exposes the following members.

Properties

 | Name | Description
Public property | InteractionId | Gets the ID of the interaction. (Inherited from IInteraction.)
Public property | Item | Gets or sets the specified interaction attribute by name. (Inherited from IInteraction.)

See Also

IWatchedInteraction Interface


IWatchedInteraction Events

[image] [image]

Interaction Client Add-In Technical Reference
IWatchedInteraction Events
IWatchedInteraction Interface See Also Send Feedback

The IWatchedInteraction type exposes the following members.

Events

 | Name | Description
Public event | InteractionChanged | Occurs when the interaction changes.

See Also

IWatchedInteraction Interface


InteractionChanged Event

[image]

Interaction Client Add-In Technical Reference
IWatchedInteraction..::..InteractionChanged Event
IWatchedInteraction Interface See Also Send Feedback
Occurs when the interaction changes.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
event EventHandler InteractionChanged
Visual Basic
Event InteractionChanged As EventHandler

Remarks

This event is raised when a watched interaction attribute changes on the server. For example, the "state" of the interaction. (connected, disconnected, etc.)

See Also

IWatchedInteraction Interface
IWatchedInteraction Members


IWindow Interface

[image]

Interaction Client Add-In Technical Reference
IWindow Interface
Members See Also Send Feedback
A window (also referred to as a "Page") in the Interaction Client user interface. Windows are added and removed by users.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public interface IWindow : INotifyPropertyChanged
Visual Basic
Public Interface IWindow _
    Inherits INotifyPropertyChanged

See Also

IWindow Members


IWindow Members

[image] [image]

Interaction Client Add-In Technical Reference
IWindow Members
IWindow Interface Properties Events See Also Send Feedback

The IWindow type exposes the following members.

Properties

 | Name | Description
Public property | Content | Gets the main window content to be displayed in the Interaction Client's user interface.
Public property | Title | Gets the title text to be displayed in the "Header" of the window's tab in the Interaction Client.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)

See Also

IWindow Interface


IWindow Properties

[image] [image]

Interaction Client Add-In Technical Reference
IWindow Properties
IWindow Interface See Also Send Feedback

The IWindow type exposes the following members.

Properties

 | Name | Description
Public property | Content | Gets the main window content to be displayed in the Interaction Client's user interface.
Public property | Title | Gets the title text to be displayed in the "Header" of the window's tab in the Interaction Client.

See Also

IWindow Interface


Content Property

[image]

Interaction Client Add-In Technical Reference
IWindow..::..Content Property
IWindow Interface See Also Send Feedback
Gets the main window content to be displayed in the Interaction Client's user interface.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
Object Content { get; }
Visual Basic
ReadOnly Property Content As Object
    Get

Return Value

Return either a Windows Forms Control or a Windows Presentation Foundation Control. Any other return type will be ignored.

See Also

IWindow Interface
IWindow Members


Title Property

[image]

Interaction Client Add-In Technical Reference
IWindow..::..Title Property
IWindow Interface See Also Send Feedback
Gets the title text to be displayed in the "Header" of the window's tab in the Interaction Client.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
string Title { get; }
Visual Basic
ReadOnly Property Title As String
    Get

See Also

IWindow Interface
IWindow Members


IWindow Events

[image] [image]

Interaction Client Add-In Technical Reference
IWindow Events
IWindow Interface See Also Send Feedback

The IWindow type exposes the following members.

Events

 | Name | Description
Public event | PropertyChanged | Occurs when a property value changes. (Inherited from INotifyPropertyChanged.)

See Also

IWindow Interface


IWindowManager Interface

[image]

Interaction Client Add-In Technical Reference
IWindowManager Interface
Members See Also Send Feedback
Windows registered with this interface are made available to the user in the "Pages" dialog, the same place that allows the user to add directory or queue "tabs" to the Interaction Client's user interface.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public interface IWindowManager
Visual Basic
Public Interface IWindowManager

See Also

IWindowManager Members


IWindowManager Members

[image] [image]

Interaction Client Add-In Technical Reference
IWindowManager Members
IWindowManager Interface Methods See Also Send Feedback

Methods

 | Name | Description
Public method | RegisterWindow<(Of <<'(TWindow>)>>)(WindowRegistrationParameters) | Register an IWindow with the Interaction Client. Once registered, this window will appear in the list of choices the user can select to add to their client user interface.
Public method | RegisterWindow<(Of <<'(TWindow>)>>)(WindowRegistrationParameters, CreateWindowDelegate) | Register an IWindow with the Interaction Client. Once registered, this window will appear in the list of choices the user can select to add to their client user interface.

See Also

IWindowManager Interface


IWindowManager Methods

[image] [image]

Interaction Client Add-In Technical Reference
IWindowManager Methods
IWindowManager Interface See Also Send Feedback

Methods

 | Name | Description
Public method | RegisterWindow<(Of <<'(TWindow>)>>)(WindowRegistrationParameters) | Register an IWindow with the Interaction Client. Once registered, this window will appear in the list of choices the user can select to add to their client user interface.
Public method | RegisterWindow<(Of <<'(TWindow>)>>)(WindowRegistrationParameters, CreateWindowDelegate) | Register an IWindow with the Interaction Client. Once registered, this window will appear in the list of choices the user can select to add to their client user interface.

See Also

IWindowManager Interface


RegisterWindow Method

[image] [image]

Interaction Client Add-In Technical Reference
IWindowManager..::..RegisterWindow Method
IWindowManager Interface See Also Send Feedback

Overload List

 | Name | Description
Public method | RegisterWindow<(Of <<'(TWindow>)>>)(WindowRegistrationParameters) | Register an IWindow with the Interaction Client. Once registered, this window will appear in the list of choices the user can select to add to their client user interface.
Public method | RegisterWindow<(Of <<'(TWindow>)>>)(WindowRegistrationParameters, CreateWindowDelegate) | Register an IWindow with the Interaction Client. Once registered, this window will appear in the list of choices the user can select to add to their client user interface.

See Also

IWindowManager Interface
IWindowManager Members


RegisterWindow(TWindow) Method (WindowRegistrationParameters)

[image]

Interaction Client Add-In Technical Reference
IWindowManager..::..RegisterWindow<(Of <(<'TWindow>)>)> Method (WindowRegistrationParameters)
IWindowManager Interface See Also Send Feedback
Register an IWindow with the Interaction Client. Once registered, this window will appear in the list of choices the user can select to add to their client user interface.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
void RegisterWindow<TWindow>(
    WindowRegistrationParameters registrationParameters
)
where TWindow : new(), IWindow
Visual Basic
Sub RegisterWindow(Of TWindow As {New, IWindow}) ( _
    registrationParameters As WindowRegistrationParameters _
)

Parameters

registrationParameters
Type: ININ.InteractionClient.AddIn..::..WindowRegistrationParameters
The parameters to use when registering the window. Pass in a new instance of this class to specify category and window identifiers (unique IDs) and display names.

Type Parameters

TWindow
The Type of the IWindow to register. The specified class must have a default (parameterless) constructor.

Exceptions

Exception | Condition
ININ.InteractionClient.AddIn..::..DuplicateWindowException | Thrown when a window with the same WindowId and CategoryId has already been registered.

See Also

IWindowManager Interface
IWindowManager Members
RegisterWindow Overload


RegisterWindow(TWindow) Method (WindowRegistrationParameters, CreateWindowDelegate)

[image]

Interaction Client Add-In Technical Reference
IWindowManager..::..RegisterWindow<(Of <(<'TWindow>)>)> Method (WindowRegistrationParameters, CreateWindowDelegate)
IWindowManager Interface See Also Send Feedback
Register an IWindow with the Interaction Client. Once registered, this window will appear in the list of choices the user can select to add to their client user interface.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
void RegisterWindow<TWindow>(
    WindowRegistrationParameters registrationParameters,
    CreateWindowDelegate createWindow
)
where TWindow : IWindow
Visual Basic
Sub RegisterWindow(Of TWindow As IWindow) ( _
    registrationParameters As WindowRegistrationParameters, _
    createWindow As CreateWindowDelegate _
)

Parameters

registrationParameters
Type: ININ.InteractionClient.AddIn..::..WindowRegistrationParameters
The parameters to use when registering the window. Pass in a new instance of this class to specify category and window identifiers (unique IDs) and display names.
createWindow
Type: ININ.InteractionClient.AddIn..::..CreateWindowDelegate
A delegate invoked by the Interaction Client when the registered window is being added to the user interface. This delegate should create a new instance of the window and return it. Use this, for example, if your window class (TWindow) does not have a default empty constructor and requires constructor arguments.

Type Parameters

TWindow
The Type of the IWindow to register.

Exceptions

Exception | Condition
ININ.InteractionClient.AddIn..::..DuplicateWindowException | Thrown when a window with the same WindowId and CategoryId has already been registered.

See Also

IWindowManager Interface
IWindowManager Members
RegisterWindow Overload


NotificationServiceUtility Class

[image]

Interaction Client Add-In Technical Reference
NotificationServiceUtility Class
Members See Also Send Feedback
A helper class that adds common overloads (using defaults) to an INotificationService.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class NotificationServiceUtility : INotificationService
Visual Basic
Public Class NotificationServiceUtility _
    Implements INotificationService

Inheritance Hierarchy

System..::..Object
ININ.InteractionClient.AddIn..::..NotificationServiceUtility

See Also

NotificationServiceUtility Members


NotificationServiceUtility Members

[image] [image]

Interaction Client Add-In Technical Reference
NotificationServiceUtility Members
NotificationServiceUtility Class Constructors Methods See Also Send Feedback

The NotificationServiceUtility type exposes the following members.

Constructors

 | Name | Description
Public method | NotificationServiceUtility | Initializes a new instance of the NotificationServiceUtility class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Notify(String) | Notifies the user using the supplied information.
Public method | Notify(String, NotificationType) | Notifies the user using the supplied information.
Public method | Notify(String, String) | Notifies the user using the supplied information.
Public method | Notify(String, TimeSpan) | Notifies the user using the supplied information.
Public method | Notify(String, NotificationType, TimeSpan) | Notifies the user using the supplied information.
Public method | Notify(String, String, NotificationType) | Notifies the user using the supplied information.
Public method | Notify(String, String, TimeSpan) | Notifies the user.
Public method | Notify(String, String, NotificationType, TimeSpan) | Notifies the user using the supplied information.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NotificationServiceUtility Class


NotificationServiceUtility Constructor

[image]

Interaction Client Add-In Technical Reference
NotificationServiceUtility Constructor
NotificationServiceUtility Class See Also Send Feedback
Initializes a new instance of the NotificationServiceUtility class.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public NotificationServiceUtility(
    INotificationService notificationService
)
Visual Basic
Public Sub New ( _
    notificationService As INotificationService _
)

Parameters

notificationService
Type: ININ.InteractionClient.AddIn..::..INotificationService
The notification service to wrap.

See Also

NotificationServiceUtility Class
NotificationServiceUtility Members


NotificationServiceUtility Methods

[image] [image]

Interaction Client Add-In Technical Reference
NotificationServiceUtility Methods
NotificationServiceUtility Class See Also Send Feedback

The NotificationServiceUtility type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Notify(String) | Notifies the user using the supplied information.
Public method | Notify(String, NotificationType) | Notifies the user using the supplied information.
Public method | Notify(String, String) | Notifies the user using the supplied information.
Public method | Notify(String, TimeSpan) | Notifies the user using the supplied information.
Public method | Notify(String, NotificationType, TimeSpan) | Notifies the user using the supplied information.
Public method | Notify(String, String, NotificationType) | Notifies the user using the supplied information.
Public method | Notify(String, String, TimeSpan) | Notifies the user.
Public method | Notify(String, String, NotificationType, TimeSpan) | Notifies the user using the supplied information.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NotificationServiceUtility Class


Notify Method

[image] [image]

Interaction Client Add-In Technical Reference
NotificationServiceUtility..::..Notify Method
NotificationServiceUtility Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Notify(String) | Notifies the user using the supplied information.
Public method | Notify(String, NotificationType) | Notifies the user using the supplied information.
Public method | Notify(String, String) | Notifies the user using the supplied information.
Public method | Notify(String, TimeSpan) | Notifies the user using the supplied information.
Public method | Notify(String, NotificationType, TimeSpan) | Notifies the user using the supplied information.
Public method | Notify(String, String, NotificationType) | Notifies the user using the supplied information.
Public method | Notify(String, String, TimeSpan) | Notifies the user.
Public method | Notify(String, String, NotificationType, TimeSpan) | Notifies the user using the supplied information.

See Also

NotificationServiceUtility Class
NotificationServiceUtility Members


Notify Method (String)

[image]

Interaction Client Add-In Technical Reference
NotificationServiceUtility..::..Notify Method (String)
NotificationServiceUtility Class See Also Send Feedback
Notifies the user using the supplied information.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Notify(
    string message
)
Visual Basic
Public Sub Notify ( _
    message As String _
)

Parameters

message
Type: System..::..String
The textual message to display. This value should not be very long (less than 255 characters) as the value may not be wrapped.

See Also

NotificationServiceUtility Class
NotificationServiceUtility Members
Notify Overload


Notify Method (String, NotificationType)

[image]

Interaction Client Add-In Technical Reference
NotificationServiceUtility..::..Notify Method (String, NotificationType)
NotificationServiceUtility Class See Also Send Feedback
Notifies the user using the supplied information.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Notify(
    string message,
    NotificationType type
)
Visual Basic
Public Sub Notify ( _
    message As String, _
    type As NotificationType _
)

Parameters

message
Type: System..::..String
The textual message to display. This value should not be very long (less than 255 characters) as the value may not be wrapped.
type
Type: ININ.InteractionClient.AddIn..::..NotificationType
The type of the notification. For example, Info or Warning.

See Also

NotificationServiceUtility Class
NotificationServiceUtility Members
Notify Overload


Notify Method (String, String)

[image]

Interaction Client Add-In Technical Reference
NotificationServiceUtility..::..Notify Method (String, String)
NotificationServiceUtility Class See Also Send Feedback
Notifies the user using the supplied information.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Notify(
    string message,
    string caption
)
Visual Basic
Public Sub Notify ( _
    message As String, _
    caption As String _
)

Parameters

message
Type: System..::..String
The textual message to display. This value should not be very long (less than 255 characters) as the value may not be wrapped.
caption
Type: System..::..String
The caption to use in the notification area, if appropriate.

See Also

NotificationServiceUtility Class
NotificationServiceUtility Members
Notify Overload


Notify Method (String, TimeSpan)

[image]

Interaction Client Add-In Technical Reference
NotificationServiceUtility..::..Notify Method (String, TimeSpan)
NotificationServiceUtility Class See Also Send Feedback
Notifies the user using the supplied information.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Notify(
    string message,
    TimeSpan duration
)
Visual Basic
Public Sub Notify ( _
    message As String, _
    duration As TimeSpan _
)

Parameters

message
Type: System..::..String
The textual message to display. This value should not be very long (less than 255 characters) as the value may not be wrapped.
duration
Type: System..::..TimeSpan
The duration of the notification. Specify MaxValue to indicate infinite duration.

See Also

NotificationServiceUtility Class
NotificationServiceUtility Members
Notify Overload


Notify Method (String, NotificationType, TimeSpan)

[image]

Interaction Client Add-In Technical Reference
NotificationServiceUtility..::..Notify Method (String, NotificationType, TimeSpan)
NotificationServiceUtility Class See Also Send Feedback
Notifies the user using the supplied information.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Notify(
    string message,
    NotificationType type,
    TimeSpan duration
)
Visual Basic
Public Sub Notify ( _
    message As String, _
    type As NotificationType, _
    duration As TimeSpan _
)

Parameters

message
Type: System..::..String
The textual message to display. This value should not be very long (less than 255 characters) as the value may not be wrapped.
type
Type: ININ.InteractionClient.AddIn..::..NotificationType
The type of the notification. For example, Info or Warning.
duration
Type: System..::..TimeSpan
The duration of the notification. Specify MaxValue to indicate infinite duration.

See Also

NotificationServiceUtility Class
NotificationServiceUtility Members
Notify Overload


Notify Method (String, String, NotificationType)

[image]

Interaction Client Add-In Technical Reference
NotificationServiceUtility..::..Notify Method (String, String, NotificationType)
NotificationServiceUtility Class See Also Send Feedback
Notifies the user using the supplied information.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Notify(
    string message,
    string caption,
    NotificationType type
)
Visual Basic
Public Sub Notify ( _
    message As String, _
    caption As String, _
    type As NotificationType _
)

Parameters

message
Type: System..::..String
The textual message to display. This value should not be very long (less than 255 characters) as the value may not be wrapped.
caption
Type: System..::..String
The caption to use in the notification area, if appropriate.
type
Type: ININ.InteractionClient.AddIn..::..NotificationType
The type of the notification. For example, Info or Warning.

See Also

NotificationServiceUtility Class
NotificationServiceUtility Members
Notify Overload


Notify Method (String, String, TimeSpan)

[image]

Interaction Client Add-In Technical Reference
NotificationServiceUtility..::..Notify Method (String, String, TimeSpan)
NotificationServiceUtility Class See Also Send Feedback
Notifies the user.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Notify(
    string message,
    string caption,
    TimeSpan duration
)
Visual Basic
Public Sub Notify ( _
    message As String, _
    caption As String, _
    duration As TimeSpan _
)

Parameters

message
Type: System..::..String
The textual message to display. This value should not be very long (less than 255 characters) as the value may not be wrapped.
caption
Type: System..::..String
The caption to use in the notification area, if appropriate.
duration
Type: System..::..TimeSpan
The duration of the notification. Specify MaxValue to indicate infinite duration.

See Also

NotificationServiceUtility Class
NotificationServiceUtility Members
Notify Overload


Notify Method (String, String, NotificationType, TimeSpan)

[image]

Interaction Client Add-In Technical Reference
NotificationServiceUtility..::..Notify Method (String, String, NotificationType, TimeSpan)
NotificationServiceUtility Class See Also Send Feedback
Notifies the user using the supplied information.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Notify(
    string message,
    string caption,
    NotificationType type,
    TimeSpan duration
)
Visual Basic
Public Sub Notify ( _
    message As String, _
    caption As String, _
    type As NotificationType, _
    duration As TimeSpan _
)

Parameters

message
Type: System..::..String
The message to display. This value should not be very long (less than 255 characters) as the value may not be wrapped.
caption
Type: System..::..String
The caption to use in the notification area, if appropriate.
type
Type: ININ.InteractionClient.AddIn..::..NotificationType
The type of the notification. For example, Info or Warning.
duration
Type: System..::..TimeSpan
The duration of the notification. Specify MaxValue to indicate infinite duration.

Implements

INotificationService..::..Notify(String, String, NotificationType, TimeSpan)

Remarks

The notification is typically a desktop alert window, but can change depending on application context.

See Also

NotificationServiceUtility Class
NotificationServiceUtility Members
Notify Overload


NotificationType Enumeration

[image]

Interaction Client Add-In Technical Reference
NotificationType Enumeration
See Also Send Feedback
The type, or severity, of a notification. This will, at a minimum, influence the notification icon.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public enum NotificationType
Visual Basic
Public Enumeration NotificationType

Members

Member name | Value | Description
None | 0 | No type is specified, the system default will be used.
Info | 1 | The notification is informational.
Question | 2 | The notification is a question.
Warning | 3 | The notification is a warning.
Error | 4 | The notification is an error.

See Also

ININ.InteractionClient.AddIn Namespace

Send comments on this topic to PureConnectDoc@genesys.com

Copyright (c) 1994 - 2022 Genesys


QueueMonitor Class

[image]

Interaction Client Add-In Technical Reference
QueueMonitor Class
Members See Also Send Feedback
A base class for monitoring an Interaction Center queue.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class QueueMonitor : IAddIn,
    IDisposable
Visual Basic
Public MustInherit Class QueueMonitor _
    Implements IAddIn, IDisposable

Remarks

This "helper" base class encapsulates common functionality that allows a queue monitor implementation to focus on actually responding to queue events (added, removed, changed), and not on implementing the code to become an Interaction Client AddIn. Simply derive from this class and implement the virtual methods to handle queue events.

Inheritance Hierarchy

System..::..Object
ININ.InteractionClient.AddIn..::..QueueMonitor

See Also

QueueMonitor Members


QueueMonitor Members

[image] [image]

Interaction Client Add-In Technical Reference
QueueMonitor Members
QueueMonitor Class Constructors Methods Properties See Also Send Feedback

The QueueMonitor type exposes the following members.

Constructors

 | Name | Description
Protected method | QueueMonitor()()()() | Initializes a new instance of the QueueMonitor class.
Protected method | QueueMonitor(String) | Initializes a new instance of the QueueMonitor class.

Methods

 | Name | Description
Public method | Dispose()()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the QueueMonitor is reclaimed by garbage collection. (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InteractionAdded | Called when an interaction was added.
Protected method | InteractionChanged | Called when an interaction was changed.
Protected method | InteractionRemoved | Called when an interaction was removed.
Public method | Load | Loads the AddIn, supplying a service provider. The service provider can be used to access application services.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnLoad | Called when the AddIn is being loaded.
Protected method | OnUnload | Called when the AddIn is being unloaded.
Public method | StartMonitoring | Starts monitoring the queue.
Public method | StopMonitoring | Stops monitoring the queue.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unload | Unloads this AddIn instance.

Properties

 | Name | Description
Protected property | Attributes | Gets the attributes to monitor for changes in this queue.
Protected property | Interactions | Gets the interactions on the queue.
Protected property | ServiceProvider | Gets the service provider which can be used to retrieve application services.
Protected property | SupportingAttributes | Gets additional interaction attributes for which change notifications are not raised, but are still available to query on an interaction.
Protected property | Trace | Gets the trace context. Use this to trace messages to the Interaction Client log.

See Also

QueueMonitor Class


QueueMonitor Constructor

[image] [image]

Interaction Client Add-In Technical Reference
QueueMonitor Constructor
QueueMonitor Class See Also Send Feedback

Overload List

 | Name | Description
Protected method | QueueMonitor()()()() | Initializes a new instance of the QueueMonitor class.
Protected method | QueueMonitor(String) | Initializes a new instance of the QueueMonitor class.

See Also

QueueMonitor Class
QueueMonitor Members


QueueMonitor Constructor

[image]

Interaction Client Add-In Technical Reference
QueueMonitor Constructor
QueueMonitor Class See Also Send Feedback
Initializes a new instance of the QueueMonitor class.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected QueueMonitor()
Visual Basic
Protected Sub New

Remarks

Monitors the "My Interactions" queue.

See Also

QueueMonitor Class
QueueMonitor Members
QueueMonitor Overload


QueueMonitor Constructor (String)

[image]

Interaction Client Add-In Technical Reference
QueueMonitor Constructor (String)
QueueMonitor Class See Also Send Feedback
Initializes a new instance of the QueueMonitor class.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected QueueMonitor(
    string queueName
)
Visual Basic
Protected Sub New ( _
    queueName As String _
)

Parameters

queueName
Type: System..::..String
The name of the queue. (Required)

See Also

QueueMonitor Class
QueueMonitor Members
QueueMonitor Overload


QueueMonitor Methods

[image] [image]

Interaction Client Add-In Technical Reference
QueueMonitor Methods
QueueMonitor Class See Also Send Feedback

The QueueMonitor type exposes the following members.

Methods

 | Name | Description
Public method | Dispose()()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the QueueMonitor is reclaimed by garbage collection. (Overrides Object..::..Finalize()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InteractionAdded | Called when an interaction was added.
Protected method | InteractionChanged | Called when an interaction was changed.
Protected method | InteractionRemoved | Called when an interaction was removed.
Public method | Load | Loads the AddIn, supplying a service provider. The service provider can be used to access application services.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnLoad | Called when the AddIn is being loaded.
Protected method | OnUnload | Called when the AddIn is being unloaded.
Public method | StartMonitoring | Starts monitoring the queue.
Public method | StopMonitoring | Stops monitoring the queue.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unload | Unloads this AddIn instance.

See Also

QueueMonitor Class


Dispose Method

[image] [image]

Interaction Client Add-In Technical Reference
QueueMonitor..::..Dispose Method
QueueMonitor Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Dispose()()()() | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Protected method | Dispose(Boolean) | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

See Also

QueueMonitor Class
QueueMonitor Members


Dispose Method

[image]

Interaction Client Add-In Technical Reference
QueueMonitor..::..Dispose Method
QueueMonitor Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Dispose()
Visual Basic
Public Sub Dispose

Implements

IDisposable..::..Dispose()()()()

See Also

QueueMonitor Class
QueueMonitor Members
Dispose Overload


Dispose Method (Boolean)

[image]

Interaction Client Add-In Technical Reference
QueueMonitor..::..Dispose Method (Boolean)
QueueMonitor Class See Also Send Feedback
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)

Parameters

disposing
Type: System..::..Boolean
trueTruetruetrue (True in Visual Basic) if being called from Dispose()()()(), falseFalsefalsefalse (False in Visual Basic) if being called from the finalizer.

See Also

QueueMonitor Class
QueueMonitor Members
Dispose Overload


Finalize Method

[image]

Interaction Client Add-In Technical Reference
QueueMonitor..::..Finalize Method
QueueMonitor Class See Also Send Feedback
Releases unmanaged resources and performs other cleanup operations before the QueueMonitor is reclaimed by garbage collection.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize

See Also

QueueMonitor Class
QueueMonitor Members


InteractionAdded Method

[image]

Interaction Client Add-In Technical Reference
QueueMonitor..::..InteractionAdded Method
QueueMonitor Class See Also Send Feedback
Called when an interaction was added.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected virtual void InteractionAdded(
    IInteraction interaction
)
Visual Basic
Protected Overridable Sub InteractionAdded ( _
    interaction As IInteraction _
)

Parameters

interaction
Type: ININ.InteractionClient.AddIn..::..IInteraction
The interaction.

See Also

QueueMonitor Class
QueueMonitor Members


InteractionChanged Method

[image]

Interaction Client Add-In Technical Reference
QueueMonitor..::..InteractionChanged Method
QueueMonitor Class See Also Send Feedback
Called when an interaction was changed.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected virtual void InteractionChanged(
    IInteraction interaction
)
Visual Basic
Protected Overridable Sub InteractionChanged ( _
    interaction As IInteraction _
)

Parameters

interaction
Type: ININ.InteractionClient.AddIn..::..IInteraction
The interaction.

See Also

QueueMonitor Class
QueueMonitor Members


InteractionRemoved Method

[image]

Interaction Client Add-In Technical Reference
QueueMonitor..::..InteractionRemoved Method
QueueMonitor Class See Also Send Feedback
Called when an interaction was removed.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected virtual void InteractionRemoved(
    IInteraction interaction
)
Visual Basic
Protected Overridable Sub InteractionRemoved ( _
    interaction As IInteraction _
)

Parameters

interaction
Type: ININ.InteractionClient.AddIn..::..IInteraction
The interaction.

See Also

QueueMonitor Class
QueueMonitor Members


Load Method

[image]

Interaction Client Add-In Technical Reference
QueueMonitor..::..Load Method
QueueMonitor Class See Also Send Feedback
Loads the AddIn, supplying a service provider. The service provider can be used to access application services.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Load(
    IServiceProvider serviceProvider
)
Visual Basic
Public Sub Load ( _
    serviceProvider As IServiceProvider _
)

Parameters

serviceProvider
Type: System..::..IServiceProvider

Implements

IAddIn..::..Load(IServiceProvider)

See Also

QueueMonitor Class
QueueMonitor Members


OnLoad Method

[image]

Interaction Client Add-In Technical Reference
QueueMonitor..::..OnLoad Method
QueueMonitor Class See Also Send Feedback
Called when the AddIn is being loaded.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected virtual void OnLoad(
    IServiceProvider serviceProvider
)
Visual Basic
Protected Overridable Sub OnLoad ( _
    serviceProvider As IServiceProvider _
)

Parameters

serviceProvider
Type: System..::..IServiceProvider

Remarks

Override this method to perform any custom loading.

See Also

QueueMonitor Class
QueueMonitor Members


OnUnload Method

[image]

Interaction Client Add-In Technical Reference
QueueMonitor..::..OnUnload Method
QueueMonitor Class See Also Send Feedback
Called when the AddIn is being unloaded.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected virtual void OnUnload()
Visual Basic
Protected Overridable Sub OnUnload

Remarks

Override this method to perform any custom unloading.

See Also

QueueMonitor Class
QueueMonitor Members


StartMonitoring Method

[image]

Interaction Client Add-In Technical Reference
QueueMonitor..::..StartMonitoring Method
QueueMonitor Class See Also Send Feedback
Starts monitoring the queue.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StartMonitoring()
Visual Basic
Public Sub StartMonitoring

See Also

QueueMonitor Class
QueueMonitor Members


StopMonitoring Method

[image]

Interaction Client Add-In Technical Reference
QueueMonitor..::..StopMonitoring Method
QueueMonitor Class See Also Send Feedback
Stops monitoring the queue.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void StopMonitoring()
Visual Basic
Public Sub StopMonitoring

See Also

QueueMonitor Class
QueueMonitor Members


Unload Method

[image]

Interaction Client Add-In Technical Reference
QueueMonitor..::..Unload Method
QueueMonitor Class See Also Send Feedback
Unloads this AddIn instance.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Unload()
Visual Basic
Public Sub Unload

Implements

IAddIn..::..Unload()()()()

Remarks

AddIns are unloaded when the application exits. Perform any cleanup or dispose of any objects at this time.

See Also

QueueMonitor Class
QueueMonitor Members


QueueMonitor Properties

[image] [image]

Interaction Client Add-In Technical Reference
QueueMonitor Properties
QueueMonitor Class See Also Send Feedback

The QueueMonitor type exposes the following members.

Properties

 | Name | Description
Protected property | Attributes | Gets the attributes to monitor for changes in this queue.
Protected property | Interactions | Gets the interactions on the queue.
Protected property | ServiceProvider | Gets the service provider which can be used to retrieve application services.
Protected property | SupportingAttributes | Gets additional interaction attributes for which change notifications are not raised, but are still available to query on an interaction.
Protected property | Trace | Gets the trace context. Use this to trace messages to the Interaction Client log.

See Also

QueueMonitor Class


Attributes Property

[image]

Interaction Client Add-In Technical Reference
QueueMonitor..::..Attributes Property
QueueMonitor Class See Also Send Feedback
Gets the attributes to monitor for changes in this queue.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected virtual IEnumerable<string> Attributes { get; }
Visual Basic
Protected Overridable ReadOnly Property Attributes As IEnumerable(Of String)
    Get

Field Value

The attributes to monitor for changes.

Remarks

The OnInteractionChanged(Object, InteractionEventArgs) method will be called when the specified attributes change.

See Also

QueueMonitor Class
QueueMonitor Members


Interactions Property

[image]

Interaction Client Add-In Technical Reference
QueueMonitor..::..Interactions Property
QueueMonitor Class See Also Send Feedback
Gets the interactions on the queue.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected ICollection<IInteraction> Interactions { get; }
Visual Basic
Protected ReadOnly Property Interactions As ICollection(Of IInteraction)
    Get

Remarks

Returns a collection of the IInteractions currently on the monitored queue.

See Also

QueueMonitor Class
QueueMonitor Members


ServiceProvider Property

[image]

Interaction Client Add-In Technical Reference
QueueMonitor..::..ServiceProvider Property
QueueMonitor Class See Also Send Feedback
Gets the service provider which can be used to retrieve application services.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected IServiceProvider ServiceProvider { get; private set; }
Visual Basic
Protected Property ServiceProvider As IServiceProvider
    Get
    Private Set

Remarks

The IServiceProvider can be used to gain access to other application services that might be needed in this screen pop implementation.

See Also

QueueMonitor Class
QueueMonitor Members


SupportingAttributes Property

[image]

Interaction Client Add-In Technical Reference
QueueMonitor..::..SupportingAttributes Property
QueueMonitor Class See Also Send Feedback
Gets additional interaction attributes for which change notifications are not raised, but are still available to query on an interaction.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected virtual IEnumerable<string> SupportingAttributes { get; }
Visual Basic
Protected Overridable ReadOnly Property SupportingAttributes As IEnumerable(Of String)
    Get

Field Value

The attributes to make available on an interaction.

Remarks

The OnInteractionChanged(Object, InteractionEventArgs) method will NOT be called when these specified attributes change.

See Also

QueueMonitor Class
QueueMonitor Members


Trace Property

[image]

Interaction Client Add-In Technical Reference
QueueMonitor..::..Trace Property
QueueMonitor Class See Also Send Feedback
Gets the trace context. Use this to trace messages to the Interaction Client log.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected ITraceContext Trace { get; private set; }
Visual Basic
Protected Property Trace As ITraceContext
    Get
    Private Set

See Also

QueueMonitor Class
QueueMonitor Members


ScreenPop Class

[image]

Interaction Client Add-In Technical Reference
ScreenPop Class
Members See Also Send Feedback
A base class for implementing a screen pop Interaction Client AddIn.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class ScreenPop : IAddIn,
    IScreenPop
Visual Basic
Public MustInherit Class ScreenPop _
    Implements IAddIn, IScreenPop

Remarks

This "helper" base class encapsulates common functionality that allows a screen pop implementation to focus on actually popping an application's screen, and not on implementing the code to become an Interaction Client AddIn. Simply derive from this class and implement the abstract and virtual methods to handle a screen pop event.

Inheritance Hierarchy

System..::..Object
ININ.InteractionClient.AddIn..::..ScreenPop

See Also

ScreenPop Members


ScreenPop Members

[image] [image]

Interaction Client Add-In Technical Reference
ScreenPop Members
ScreenPop Class Constructors Methods Properties See Also Send Feedback

The ScreenPop type exposes the following members.

Constructors

 | Name | Description
Protected method | ScreenPop | Initializes a new instance of the ScreenPop class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads the AddIn, supplying a service provider. The service provider can be used to access application services.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Notify | Notifies the user using the default caption and duration.
Protected method | OnLoad | Called when the AddIn is being loaded.
Protected method | OnUnload | Called when the AddIn is being unloaded.
Public method | Pop | Initiates a screen pop.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unload | Unloads this AddIn instance.

Properties

 | Name | Description
Public property | AdditionalAttributes | Gets additional interaction attributes this screen pop needs. If the screen pop is being initiated from an interaction, these attributes will be gathered and passed to the Pop(IDictionary<(Of <<'(String, String>)>>)) method in addition to server-defined attributes.
Public property | Name | Gets the name of this screen pop. The name is used to find the screen pop and activate it.
Protected property | NotificationService | Gets the notification service.
Protected property | ServiceProvider | Gets the service provider which can be used to retrieve application services.
Protected property | Trace | Gets the trace context. Use this to trace messages to the Interaction Client log.

See Also

ScreenPop Class


ScreenPop Constructor

[image]

Interaction Client Add-In Technical Reference
ScreenPop Constructor
ScreenPop Class See Also Send Feedback
Initializes a new instance of the ScreenPop class

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected ScreenPop()
Visual Basic
Protected Sub New

See Also

ScreenPop Class
ScreenPop Members


ScreenPop Methods

[image] [image]

Interaction Client Add-In Technical Reference
ScreenPop Methods
ScreenPop Class See Also Send Feedback

The ScreenPop type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads the AddIn, supplying a service provider. The service provider can be used to access application services.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Notify | Notifies the user using the default caption and duration.
Protected method | OnLoad | Called when the AddIn is being loaded.
Protected method | OnUnload | Called when the AddIn is being unloaded.
Public method | Pop | Initiates a screen pop.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unload | Unloads this AddIn instance.

See Also

ScreenPop Class


Load Method

[image]

Interaction Client Add-In Technical Reference
ScreenPop..::..Load Method
ScreenPop Class See Also Send Feedback
Loads the AddIn, supplying a service provider. The service provider can be used to access application services.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Load(
    IServiceProvider serviceProvider
)
Visual Basic
Public Sub Load ( _
    serviceProvider As IServiceProvider _
)

Parameters

serviceProvider
Type: System..::..IServiceProvider

Implements

IAddIn..::..Load(IServiceProvider)

See Also

ScreenPop Class
ScreenPop Members


Notify Method

[image]

Interaction Client Add-In Technical Reference
ScreenPop..::..Notify Method
ScreenPop Class See Also Send Feedback
Notifies the user using the default caption and duration.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected void Notify(
    string message,
    NotificationType type
)
Visual Basic
Protected Sub Notify ( _
    message As String, _
    type As NotificationType _
)

Parameters

message
Type: System..::..String
The textual message to display.
type
Type: ININ.InteractionClient.AddIn..::..NotificationType
The type of the notification.

Remarks

If more control is required over the notification, use the NotificationService property.

See Also

ScreenPop Class
ScreenPop Members


OnLoad Method

[image]

Interaction Client Add-In Technical Reference
ScreenPop..::..OnLoad Method
ScreenPop Class See Also Send Feedback
Called when the AddIn is being loaded.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected virtual void OnLoad(
    IServiceProvider serviceProvider
)
Visual Basic
Protected Overridable Sub OnLoad ( _
    serviceProvider As IServiceProvider _
)

Parameters

serviceProvider
Type: System..::..IServiceProvider

Remarks

Override this method to perform any custom loading.

See Also

ScreenPop Class
ScreenPop Members


OnUnload Method

[image]

Interaction Client Add-In Technical Reference
ScreenPop..::..OnUnload Method
ScreenPop Class See Also Send Feedback
Called when the AddIn is being unloaded.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected virtual void OnUnload()
Visual Basic
Protected Overridable Sub OnUnload

Remarks

Override this method to perform any custom unloading.

See Also

ScreenPop Class
ScreenPop Members


Pop Method

[image]

Interaction Client Add-In Technical Reference
ScreenPop..::..Pop Method
ScreenPop Class See Also Send Feedback
Initiates a screen pop.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract void Pop(
    IDictionary<string, string> attributes
)
Visual Basic
Public MustOverride Sub Pop ( _
    attributes As IDictionary(Of String, String) _
)

Parameters

attributes
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, String>)>)>
The specified Interaction and screen pop provider-specific attributes.

Implements

IScreenPop..::..Pop(IDictionary<(Of <<'(String, String>)>>))

See Also

ScreenPop Class
ScreenPop Members


Unload Method

[image]

Interaction Client Add-In Technical Reference
ScreenPop..::..Unload Method
ScreenPop Class See Also Send Feedback
Unloads this AddIn instance.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Unload()
Visual Basic
Public Sub Unload

Implements

IAddIn..::..Unload()()()()

Remarks

AddIns are unloaded when the application exits. Perform any cleanup or dispose of any objects at this time.

See Also

ScreenPop Class
ScreenPop Members


ScreenPop Properties

[image] [image]

Interaction Client Add-In Technical Reference
ScreenPop Properties
ScreenPop Class See Also Send Feedback

The ScreenPop type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalAttributes | Gets additional interaction attributes this screen pop needs. If the screen pop is being initiated from an interaction, these attributes will be gathered and passed to the Pop(IDictionary<(Of <<'(String, String>)>>)) method in addition to server-defined attributes.
Public property | Name | Gets the name of this screen pop. The name is used to find the screen pop and activate it.
Protected property | NotificationService | Gets the notification service.
Protected property | ServiceProvider | Gets the service provider which can be used to retrieve application services.
Protected property | Trace | Gets the trace context. Use this to trace messages to the Interaction Client log.

See Also

ScreenPop Class


AdditionalAttributes Property

[image]

Interaction Client Add-In Technical Reference
ScreenPop..::..AdditionalAttributes Property
ScreenPop Class See Also Send Feedback
Gets additional interaction attributes this screen pop needs. If the screen pop is being initiated from an interaction, these attributes will be gathered and passed to the Pop(IDictionary<(Of <<'(String, String>)>>)) method in addition to server-defined attributes.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public virtual IEnumerable<string> AdditionalAttributes { get; }
Visual Basic
Public Overridable ReadOnly Property AdditionalAttributes As IEnumerable(Of String)
    Get

Field Value

The interaction attributes to retrieve.

Implements

IScreenPop..::..AdditionalAttributes

See Also

ScreenPop Class
ScreenPop Members


Name Property

[image]

Interaction Client Add-In Technical Reference
ScreenPop..::..Name Property
ScreenPop Class See Also Send Feedback
Gets the name of this screen pop. The name is used to find the screen pop and activate it.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract string Name { get; }
Visual Basic
Public MustOverride ReadOnly Property Name As String
    Get

Field Value

The name of the screen pop.

Implements

IScreenPop..::..Name

See Also

ScreenPop Class
ScreenPop Members


NotificationService Property

[image]

Interaction Client Add-In Technical Reference
ScreenPop..::..NotificationService Property
ScreenPop Class See Also Send Feedback
Gets the notification service.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected INotificationService NotificationService { get; private set; }
Visual Basic
Protected Property NotificationService As INotificationService
    Get
    Private Set

Remarks

It is preferred to use the Notify(String, NotificationType) method to display notifications, however for more advanced usage, the NotificationService property will return a reference to the actual notification service.

See Also

ScreenPop Class
ScreenPop Members


ServiceProvider Property

[image]

Interaction Client Add-In Technical Reference
ScreenPop..::..ServiceProvider Property
ScreenPop Class See Also Send Feedback
Gets the service provider which can be used to retrieve application services.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected IServiceProvider ServiceProvider { get; private set; }
Visual Basic
Protected Property ServiceProvider As IServiceProvider
    Get
    Private Set

Remarks

The IServiceProvider can be used to gain access to other application services that might be needed in this screen pop implementation.

See Also

ScreenPop Class
ScreenPop Members


Trace Property

[image]

Interaction Client Add-In Technical Reference
ScreenPop..::..Trace Property
ScreenPop Class See Also Send Feedback
Gets the trace context. Use this to trace messages to the Interaction Client log.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected ITraceContext Trace { get; private set; }
Visual Basic
Protected Property Trace As ITraceContext
    Get
    Private Set

See Also

ScreenPop Class
ScreenPop Members


SecureInput Class

[image]

Interaction Client Add-In Technical Reference
SecureInput Class
Members See Also Send Feedback
A base class for implementing a custom secure input Interaction Client AddIn.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract class SecureInput : IAddIn,
    ISecureInput
Visual Basic
Public MustInherit Class SecureInput _
    Implements IAddIn, ISecureInput

Remarks

This "helper" base class encapsulates common functionality that allows a secure input form implementation to focus on the logic behind showing a form, and not on implementing the code to become an Interaction Client AddIn. Simply derive from this class and implement the abstract and virtual methods to display a custom secure input form.

Inheritance Hierarchy

System..::..Object
ININ.InteractionClient.AddIn..::..SecureInput

See Also

SecureInput Members


SecureInput Members

[image] [image]

Interaction Client Add-In Technical Reference
SecureInput Members
SecureInput Class Constructors Methods Properties See Also Send Feedback

The SecureInput type exposes the following members.

Constructors

 | Name | Description
Protected method | SecureInput | Initializes a new instance of the SecureInput class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetForm | Gets the secure input form to display.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads the AddIn, supplying a service provider. The service provider can be used to access application services.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Notify | Notifies the user using the default caption and duration.
Protected method | OnLoad | Called when the AddIn is being loaded.
Protected method | OnUnload | Called when the AddIn is being unloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unload | Unloads this AddIn instance.

Properties

 | Name | Description
Public property | AdditionalAttributes | Gets additional interaction attributes this secure input needs. These attributes will be gathered and included in the parameter passed to the GetForm(IDictionary<(Of <<'(String, String>)>>)) method in addition to server-defined parameters.
Public property | Name | Gets the name of this secure input. The name is used to find the secure input and activate it.
Protected property | NotificationService | Gets the notification service.
Protected property | ServiceProvider | Gets the service provider which can be used to retrieve application services.
Protected property | Trace | Gets the trace context. Use this to trace messages to the Interaction Client log.

See Also

SecureInput Class


SecureInput Constructor

[image]

Interaction Client Add-In Technical Reference
SecureInput Constructor
SecureInput Class See Also Send Feedback
Initializes a new instance of the SecureInput class

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected SecureInput()
Visual Basic
Protected Sub New

See Also

SecureInput Class
SecureInput Members


SecureInput Methods

[image] [image]

Interaction Client Add-In Technical Reference
SecureInput Methods
SecureInput Class See Also Send Feedback

The SecureInput type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetForm | Gets the secure input form to display.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads the AddIn, supplying a service provider. The service provider can be used to access application services.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Notify | Notifies the user using the default caption and duration.
Protected method | OnLoad | Called when the AddIn is being loaded.
Protected method | OnUnload | Called when the AddIn is being unloaded.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | Unload | Unloads this AddIn instance.

See Also

SecureInput Class


GetForm Method

[image]

Interaction Client Add-In Technical Reference
SecureInput..::..GetForm Method
SecureInput Class See Also Send Feedback
Gets the secure input form to display.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract ISecureInputForm GetForm(
    IDictionary<string, string> parameters
)
Visual Basic
Public MustOverride Function GetForm ( _
    parameters As IDictionary(Of String, String) _
) As ISecureInputForm

Parameters

parameters
Type: System.Collections.Generic..::..IDictionary<(Of <(<'String, String>)>)>
The specified Interaction and secure input parameters.

Implements

ISecureInput..::..GetForm(IDictionary<(Of <<'(String, String>)>>))

See Also

SecureInput Class
SecureInput Members


Load Method

[image]

Interaction Client Add-In Technical Reference
SecureInput..::..Load Method
SecureInput Class See Also Send Feedback
Loads the AddIn, supplying a service provider. The service provider can be used to access application services.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Load(
    IServiceProvider serviceProvider
)
Visual Basic
Public Sub Load ( _
    serviceProvider As IServiceProvider _
)

Parameters

serviceProvider
Type: System..::..IServiceProvider

Implements

IAddIn..::..Load(IServiceProvider)

See Also

SecureInput Class
SecureInput Members


Notify Method

[image]

Interaction Client Add-In Technical Reference
SecureInput..::..Notify Method
SecureInput Class See Also Send Feedback
Notifies the user using the default caption and duration.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected void Notify(
    string message,
    NotificationType type
)
Visual Basic
Protected Sub Notify ( _
    message As String, _
    type As NotificationType _
)

Parameters

message
Type: System..::..String
The textual message to display.
type
Type: ININ.InteractionClient.AddIn..::..NotificationType
The type of the notification.

Remarks

If more control is required over the notification, use the NotificationService property.

See Also

SecureInput Class
SecureInput Members


OnLoad Method

[image]

Interaction Client Add-In Technical Reference
SecureInput..::..OnLoad Method
SecureInput Class See Also Send Feedback
Called when the AddIn is being loaded.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected virtual void OnLoad(
    IServiceProvider serviceProvider
)
Visual Basic
Protected Overridable Sub OnLoad ( _
    serviceProvider As IServiceProvider _
)

Parameters

serviceProvider
Type: System..::..IServiceProvider

Remarks

Override this method to perform any custom loading.

See Also

SecureInput Class
SecureInput Members


OnUnload Method

[image]

Interaction Client Add-In Technical Reference
SecureInput..::..OnUnload Method
SecureInput Class See Also Send Feedback
Called when the AddIn is being unloaded.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected virtual void OnUnload()
Visual Basic
Protected Overridable Sub OnUnload

Remarks

Override this method to perform any custom unloading.

See Also

SecureInput Class
SecureInput Members


Unload Method

[image]

Interaction Client Add-In Technical Reference
SecureInput..::..Unload Method
SecureInput Class See Also Send Feedback
Unloads this AddIn instance.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public void Unload()
Visual Basic
Public Sub Unload

Implements

IAddIn..::..Unload()()()()

Remarks

AddIns are unloaded when the application exits. Perform any cleanup or dispose of any objects at this time.

See Also

SecureInput Class
SecureInput Members


SecureInput Properties

[image] [image]

Interaction Client Add-In Technical Reference
SecureInput Properties
SecureInput Class See Also Send Feedback

The SecureInput type exposes the following members.

Properties

 | Name | Description
Public property | AdditionalAttributes | Gets additional interaction attributes this secure input needs. These attributes will be gathered and included in the parameter passed to the GetForm(IDictionary<(Of <<'(String, String>)>>)) method in addition to server-defined parameters.
Public property | Name | Gets the name of this secure input. The name is used to find the secure input and activate it.
Protected property | NotificationService | Gets the notification service.
Protected property | ServiceProvider | Gets the service provider which can be used to retrieve application services.
Protected property | Trace | Gets the trace context. Use this to trace messages to the Interaction Client log.

See Also

SecureInput Class


AdditionalAttributes Property

[image]

Interaction Client Add-In Technical Reference
SecureInput..::..AdditionalAttributes Property
SecureInput Class See Also Send Feedback
Gets additional interaction attributes this secure input needs. These attributes will be gathered and included in the parameter passed to the GetForm(IDictionary<(Of <<'(String, String>)>>)) method in addition to server-defined parameters.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public virtual IEnumerable<string> AdditionalAttributes { get; }
Visual Basic
Public Overridable ReadOnly Property AdditionalAttributes As IEnumerable(Of String)
    Get

Field Value

The interaction attributes to retrieve.

Implements

ISecureInput..::..AdditionalAttributes

See Also

SecureInput Class
SecureInput Members


Name Property

[image]

Interaction Client Add-In Technical Reference
SecureInput..::..Name Property
SecureInput Class See Also Send Feedback
Gets the name of this secure input. The name is used to find the secure input and activate it.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public abstract string Name { get; }
Visual Basic
Public MustOverride ReadOnly Property Name As String
    Get

Field Value

The name of the secure input.

Implements

ISecureInput..::..Name

See Also

SecureInput Class
SecureInput Members


NotificationService Property

[image]

Interaction Client Add-In Technical Reference
SecureInput..::..NotificationService Property
SecureInput Class See Also Send Feedback
Gets the notification service.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected INotificationService NotificationService { get; private set; }
Visual Basic
Protected Property NotificationService As INotificationService
    Get
    Private Set

Remarks

It is preferred to use the Notify(String, NotificationType) method to display notifications, however for more advanced usage, the NotificationService property will return a reference to the actual notification service.

See Also

SecureInput Class
SecureInput Members


ServiceProvider Property

[image]

Interaction Client Add-In Technical Reference
SecureInput..::..ServiceProvider Property
SecureInput Class See Also Send Feedback
Gets the service provider which can be used to retrieve application services.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected IServiceProvider ServiceProvider { get; private set; }
Visual Basic
Protected Property ServiceProvider As IServiceProvider
    Get
    Private Set

Remarks

The IServiceProvider can be used to gain access to other application services that might be needed in this secure input implementation.

See Also

SecureInput Class
SecureInput Members


Trace Property

[image]

Interaction Client Add-In Technical Reference
SecureInput..::..Trace Property
SecureInput Class See Also Send Feedback
Gets the trace context. Use this to trace messages to the Interaction Client log.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
protected ITraceContext Trace { get; private set; }
Visual Basic
Protected Property Trace As ITraceContext
    Get
    Private Set

See Also

SecureInput Class
SecureInput Members


ServiceNotFoundException Class

[image]

Interaction Client Add-In Technical Reference
ServiceNotFoundException Class
Members See Also Send Feedback
An exception thrown when a required service type is not found.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class ServiceNotFoundException : Exception
Visual Basic
Public Class ServiceNotFoundException _
    Inherits Exception

Inheritance Hierarchy

System..::..Object
System..::..Exception
ININ.InteractionClient.AddIn..::..ServiceNotFoundException

See Also

ServiceNotFoundException Members


ServiceNotFoundException Members

[image] [image]

Interaction Client Add-In Technical Reference
ServiceNotFoundException Members
ServiceNotFoundException Class Constructors Methods Properties Events See Also Send Feedback

The ServiceNotFoundException type exposes the following members.

Constructors

 | Name | Description
Public method | ServiceNotFoundException()()()() | Initializes a new instance of the ServiceNotFoundException class.
Public method | ServiceNotFoundException(String) | Initializes a new instance of the ServiceNotFoundException class.
Public method | ServiceNotFoundException(String, String) | Initializes a new instance of the ServiceNotFoundException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | ServiceName | Gets the name of the service type that was not found.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ServiceNotFoundException Class


ServiceNotFoundException Constructor

[image] [image]

Interaction Client Add-In Technical Reference
ServiceNotFoundException Constructor
ServiceNotFoundException Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ServiceNotFoundException()()()() | Initializes a new instance of the ServiceNotFoundException class.
Public method | ServiceNotFoundException(String) | Initializes a new instance of the ServiceNotFoundException class.
Public method | ServiceNotFoundException(String, String) | Initializes a new instance of the ServiceNotFoundException class.

See Also

ServiceNotFoundException Class
ServiceNotFoundException Members


ServiceNotFoundException Constructor

[image]

Interaction Client Add-In Technical Reference
ServiceNotFoundException Constructor
ServiceNotFoundException Class See Also Send Feedback
Initializes a new instance of the ServiceNotFoundException class.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ServiceNotFoundException()
Visual Basic
Public Sub New

See Also

ServiceNotFoundException Class
ServiceNotFoundException Members
ServiceNotFoundException Overload


ServiceNotFoundException Constructor (String)

[image]

Interaction Client Add-In Technical Reference
ServiceNotFoundException Constructor (String)
ServiceNotFoundException Class See Also Send Feedback
Initializes a new instance of the ServiceNotFoundException class.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ServiceNotFoundException(
    string serviceName
)
Visual Basic
Public Sub New ( _
    serviceName As String _
)

Parameters

serviceName
Type: System..::..String
The name of the service type that was not found.

See Also

ServiceNotFoundException Class
ServiceNotFoundException Members
ServiceNotFoundException Overload


ServiceNotFoundException Constructor (String, String)

[image]

Interaction Client Add-In Technical Reference
ServiceNotFoundException Constructor (String, String)
ServiceNotFoundException Class See Also Send Feedback
Initializes a new instance of the ServiceNotFoundException class.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public ServiceNotFoundException(
    string serviceName,
    string message
)
Visual Basic
Public Sub New ( _
    serviceName As String, _
    message As String _
)

Parameters

serviceName
Type: System..::..String
The name of the service type that was not found.
message
Type: System..::..String
A descriptive message describing context about the exception.

See Also

ServiceNotFoundException Class
ServiceNotFoundException Members
ServiceNotFoundException Overload


ServiceNotFoundException Methods

[image] [image]

Interaction Client Add-In Technical Reference
ServiceNotFoundException Methods
ServiceNotFoundException Class See Also Send Feedback

The ServiceNotFoundException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ServiceNotFoundException Class


ServiceNotFoundException Properties

[image] [image]

Interaction Client Add-In Technical Reference
ServiceNotFoundException Properties
ServiceNotFoundException Class See Also Send Feedback

The ServiceNotFoundException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | ServiceName | Gets the name of the service type that was not found.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ServiceNotFoundException Class


ServiceName Property

[image]

Interaction Client Add-In Technical Reference
ServiceNotFoundException..::..ServiceName Property
ServiceNotFoundException Class See Also Send Feedback
Gets the name of the service type that was not found.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string ServiceName { get; private set; }
Visual Basic
Public Property ServiceName As String
    Get
    Private Set

See Also

ServiceNotFoundException Class
ServiceNotFoundException Members


ServiceNotFoundException Events

[image] [image]

Interaction Client Add-In Technical Reference
ServiceNotFoundException Events
ServiceNotFoundException Class See Also Send Feedback

The ServiceNotFoundException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

ServiceNotFoundException Class


WindowRegistrationParameters Class

[image]

Interaction Client Add-In Technical Reference
WindowRegistrationParameters Class
Members See Also Send Feedback
A set of values used to register a window.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public class WindowRegistrationParameters
Visual Basic
Public Class WindowRegistrationParameters

Remarks

This class is a configuration object used to group several values together related to the registering of an IWindow. Create and pass a new instance of this class into the IWindowManager when registering a window. The WindowId and CategoryId must be globally unique values to avoid having multiple windows registered with the same identifier.

Inheritance Hierarchy

System..::..Object
ININ.InteractionClient.AddIn..::..WindowRegistrationParameters

See Also

WindowRegistrationParameters Members


WindowRegistrationParameters Members

[image] [image]

Interaction Client Add-In Technical Reference
WindowRegistrationParameters Members
WindowRegistrationParameters Class Constructors Methods Properties See Also Send Feedback

The WindowRegistrationParameters type exposes the following members.

Constructors

 | Name | Description
Public method | WindowRegistrationParameters | Initializes a new instance of the WindowRegistrationParameters class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CategoryId | Gets or sets a unique identifier for the category this window is grouped within when displayed to the user in the "Pages" dialog.
Public property | CategoryName | Gets or sets a displayable name for the category this window is grouped within.
Public property | WindowId | Gets or sets a unique identifier for this window.
Public property | WindowName | Gets or sets a displayable name for the window.

See Also

WindowRegistrationParameters Class


WindowRegistrationParameters Constructor

[image]

Interaction Client Add-In Technical Reference
WindowRegistrationParameters Constructor
WindowRegistrationParameters Class See Also Send Feedback
Initializes a new instance of the WindowRegistrationParameters class.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public WindowRegistrationParameters()
Visual Basic
Public Sub New

See Also

WindowRegistrationParameters Class
WindowRegistrationParameters Members


WindowRegistrationParameters Methods

[image] [image]

Interaction Client Add-In Technical Reference
WindowRegistrationParameters Methods
WindowRegistrationParameters Class See Also Send Feedback

The WindowRegistrationParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WindowRegistrationParameters Class


WindowRegistrationParameters Properties

[image] [image]

Interaction Client Add-In Technical Reference
WindowRegistrationParameters Properties
WindowRegistrationParameters Class See Also Send Feedback

The WindowRegistrationParameters type exposes the following members.

Properties

 | Name | Description
Public property | CategoryId | Gets or sets a unique identifier for the category this window is grouped within when displayed to the user in the "Pages" dialog.
Public property | CategoryName | Gets or sets a displayable name for the category this window is grouped within.
Public property | WindowId | Gets or sets a unique identifier for this window.
Public property | WindowName | Gets or sets a displayable name for the window.

See Also

WindowRegistrationParameters Class


CategoryId Property

[image]

Interaction Client Add-In Technical Reference
WindowRegistrationParameters..::..CategoryId Property
WindowRegistrationParameters Class See Also Send Feedback
Gets or sets a unique identifier for the category this window is grouped within when displayed to the user in the "Pages" dialog.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string CategoryId { get; set; }
Visual Basic
Public Property CategoryId As String
    Get
    Set

Remarks

This value is not displayed, it should not be translated.

See Also

WindowRegistrationParameters Class
WindowRegistrationParameters Members


CategoryName Property

[image]

Interaction Client Add-In Technical Reference
WindowRegistrationParameters..::..CategoryName Property
WindowRegistrationParameters Class See Also Send Feedback
Gets or sets a displayable name for the category this window is grouped within.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string CategoryName { get; set; }
Visual Basic
Public Property CategoryName As String
    Get
    Set

Remarks

This will be displayed to the user when they view the "Pages" dialog in the Interaction Client.

See Also

WindowRegistrationParameters Class
WindowRegistrationParameters Members


WindowId Property

[image]

Interaction Client Add-In Technical Reference
WindowRegistrationParameters..::..WindowId Property
WindowRegistrationParameters Class See Also Send Feedback
Gets or sets a unique identifier for this window.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string WindowId { get; set; }
Visual Basic
Public Property WindowId As String
    Get
    Set

Remarks

This value is not displayed, it should not be translated.

See Also

WindowRegistrationParameters Class
WindowRegistrationParameters Members


WindowName Property

[image]

Interaction Client Add-In Technical Reference
WindowRegistrationParameters..::..WindowName Property
WindowRegistrationParameters Class See Also Send Feedback
Gets or sets a displayable name for the window.

Namespace: ININ.InteractionClient.AddIn
Assembly: ININ.InteractionClient.AddIn (in ININ.InteractionClient.AddIn.dll) Version: 0.0.0.0 (22.3.0.218)

Syntax

C#
public string WindowName { get; set; }
Visual Basic
Public Property WindowName As String
    Get
    Set

Remarks

This will be displayed to the user when they select to add or remove this window.

See Also

WindowRegistrationParameters Class
WindowRegistrationParameters Members