ININ.IceLib.Configuration.Dialer Namespace

[image]

IceLib Dialer Technical Reference
ININ.IceLib.Configuration.Dialer Namespace
Send Feedback

The ININ.IceLib.Configuration.Dialer namespace contains classes for accessing Interaction Dialer's configuration data.

The DialerConfigurationManager class is the entry point to accessing your Dialer server's configuration.

Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.

Classes

 | Class | Description
Public class | AbandonCondition | A policy condition that checks if a call was considered abandoned. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | ActiveRuleGroupChangedEventEventArgs | Contains the name of the group that the campaign was just transitioned to. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | AgentlessActionBehavior | A PolicyBehavior which plays a wav file or redirects to an Attendant profile. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | AgentRuleAction | A RuleAction that logs agents in or out of one or more campaigns. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | AggregateExpression | An expression representing an aggregate function. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | AttributeBehavior | A PolicyBehavior which sets a contact attribute. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | AttributeCondition | A policy condition that checks if an attribute on a contact record matches a desired value. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | BadRevisionException | The exception thrown when an attempt is made to modify a configuration object with a revision level that does not match what the server expects. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | BaseScriptConfiguration | Contains configuration and administration settings for a Dialer BaseScript. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | BaseScriptConfigurationList | Allows for querying and managing BaseScript configuration objects. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | BaseScriptControl | Represents a user interface control on a script page. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | BaseScriptDateTimeControl | Represents a date/time control on a base script page. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | BaseScriptDisposition | Represents a button on a script page that dispositions a call. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | BaseScriptDispositionBase | Provides common class members for a disposition button or navigation link on a script. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | BaseScriptDropListControl | Represents a drop-down control on a base script page. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | BaseScriptNavLink | Represents a link on a script page that navigates to another script page. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | BaseScriptNumericControl | Represents a numeric slider/spinner control on a base script page. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | BaseScriptPageConfiguration | Contains configuration and administration settings for a Dialer BaseScriptPage. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | BaseScriptPageConfigurationList | Allows for querying and managing base script page configuration objects. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | BaseScriptRadioBoxControl | Represents a collection of radio buttons on a script page. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | BaseScriptTextControl | Represents a text box control on a base script page. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | BinaryExpression | An expression representing a binary logical or arithmetic operation. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | CallAnalysisBehavior | A PolicyBehavior which can configure call analysis on a per-call basis. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | CallAnalysisCondition | A policy condition that check if the result of call analysis is contained within a desired subset of results. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | CallAttributeBehavior | A PolicyBehavior which sets a call attribute for the call. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | CallAttributeCondition | A policy condition that checks if a call attribute matches a certain value. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | CallbackBehavior | A PolicyBehavior which schedules a return call. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | CallCategoryCondition | A policy condition that checks if the call category is contained within a desired subset of categories. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | CallDialingModeCondition | A policy condition that checks if the call's dialing mode is contained within a desired subset of modes. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | CallDurationCondition | A policy condition that checks if the duration of a call matches a certain value. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | CallingPartyBehavior | A PolicyBehavior which can alter callerID information on a per-call basis. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | CallRoutingBehavior | A PolicyBehavior which can set skill information and change routing behavior for a call. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | CampaignConfiguration | Contains configuration and administration settings for a Dialer campaign. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | CampaignConfigurationList | Allows for querying and managing Campaign configuration objects. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | CampaignGroup | A class representing a group of campaign properties that will be adjusted when activated during the execution of a Sequence. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | CampaignGroupPropertyItem | A class representing a specific CampaignConfiguration..::..Property and the value it should be changed to when the CampaignGroup is activated by the Sequence. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | CampaignPropertyRuleAction | A RuleAction that sets the value a campaign property. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | CampaignRuleAction | A RuleAction that will alters the execution state of a Campaign. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | CampaignServerConnectionStateEventArgs | Contains details about Campaign Server connection status Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | CampaignStatusChangedEventArgs | Contains details about a campaign status change. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | CCSConfiguration | Contains configuration and administration settings for the central campaign server. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | CCSConfigurationList | Allows for querying the central campaign server object. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | ColumnExpression | An expression representing a single database column. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | ConnectionConfiguration | Contains configuration and administration settings for a Dialer database connection. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | ConnectionConfigurationList | Allows for querying and managing database connection configuration objects. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | ConstantExpression | An expression representing a single constant. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | ContactColumnConfiguration | Contains configuration and administration settings for a database column that contains phone numbers. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | ContactColumnConfigurationList | Allows for querying and managing contact column configuration objects. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | ContactColumnsBehavior | A PolicyBehavior which can enable or disable contact columns. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | ContactListCommand | A command to run against a database associated with a contact list. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | ContactListConfiguration | Contains configuration and administration settings for a Dialer Contact List. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | ContactListConfigurationList | Allows for querying and managing contact list configuration objects. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | ContactListTransaction | Encapsulates one or more commands to run as one as transaction. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | CustomDataBehavior | A PolicyBehavior which sets CustomData1 and CustomData2 attributes. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | CustomStatRule | A rule that evalutes statistics for a specific field in a contact list. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | CustomStoredProcBehavior | A PolicyBehavior which sets CustomSprocValue1 and CustomSprocValue2 attributes. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | DeleteCommand | A command that deletes records from a contact list table or call schedule table. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | DialerConfigurationManager | A class that provides access to Dialer configuration and administration information. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | DialerSkill | An skill held by an agent in a Dialer campaign. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | DispositionBehavior | A PolicyBehavior which dispositions the call. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | DispositionCondition | A policy condition that checks if the call's disposition is contained within a desired subset of dispositions. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | DNCRecord | A class containing the information necessary to call one of the AddEntryToDNCTable functions in the DNCUpdate class. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | DNCSourceConfiguration | Contains configuration and administration settings for a do-not-call source configuration object. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | DNCSourceConfigurationList | Allows for querying DNCSource configuration objects. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | DNCUpdate | Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | DncUpdateBehavior | A PolicyBehavior which sets the DNC Source information for the call. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | EmailBehavior | A PolicyBehavior which sends an email. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | EmailRuleAction | A RuleAction that sends an e-mail. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | EmptyExpression | An empty expression used only as a placeholder. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | EventLogBehavior | A PolicyBehavior which creates an entry in the Dialer server's event log. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | EventLogRuleAction | A RuleAction that writes an entry to the event log. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | EventRule | A rule with a event-based condition. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | EventSequenceItem | A class that represents a sequence item that is triggered by a SystemEvent Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | FilterConfiguration | Contains configuration and administration settings for a Dialer filter. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | FilterConfigurationList | Allows for querying and managing filter configuration objects. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | HandlerBehavior | A PolicyBehavior which runs the Dialer_RuleActionEvent handler on each Dialer server. It allows for configuration of user-defined EventID and EventData parameters which will be passed to the handler. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | HandlerRuleAction | A RuleAction that executes a custom handler. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | HtmlEmailBehavior | A PolicyBehavior which sends an html email. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | HttpRequestKey | A class containing all the information necessary to send a request to the Central Campaign Server's http server. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | HttpRequestKey..::..HttpInterface | A network interface on the Central Campaign Server. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | InsertCommand | A command that inserts a new contact into an existing contact list. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | NumberToDialBehavior | A PolicyBehavior which sets a different (specific) phone number to be dialed. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | ODSConfiguration | Contains configuration and administration settings for an outbound dialing server. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | ODSConfigurationList | Allows for querying and managing outbound dialing servers. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | ParameterNameValue | Parameter Name and Value Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | PhoneNumberDetailCondition | A PolicyCondition which will check phone number detail counters of the number being dialed. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | PhoneNumberTypeCondition | A PolicyCondition which will check the phone number type of the number being dialed. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | PhoneNumberTypeConfiguration | Contains configuration and administration settings for a Dialer phone number type Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | PhoneNumberTypeConfigurationList | Allows for querying and managing phone number types. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | Policy | A rule that provides control over the processing of individual contact records. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | PolicyBehavior | Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | PolicyCondition | A logical condition evaluated as part of a policy. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | PolicySetConfiguration | Contains configuration and administration settings for a Dialer Policy Set. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | PolicySetConfigurationList | Allows for querying and managing policy set configuration objects. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | PreviewDialingBehavior | A PolicyBehavior which sets the Preview Dialing information for the call. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | PropertyDescriptionAttribute | Attribute specifying names and descriptions for object properties Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | Rule | A class representing a group of actions to be executed upon satisfaction of a specified condition. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | RuleAction | An action to perform upon satisfaction of a rule condition. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | RuleGroupRuleAction | A RuleAction that shifts rule evaluation to a different group of rules. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | RuleSetConfiguration | Contains configuration and administration settings for a Dialer Rule Set. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | RuleSetConfigurationList | Allows for querying and managing rule set configuration objects. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | ScheduleConfiguration | Contains configuration and administration settings for a Dialer schedule. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | ScheduleConfigurationList | Allows for querying and managing schedule configuration objects. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | SelectCommand | A command that retrieves contact records from a database table associated with a contact list. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | Sequence | a class representing a group of CampaignGroup and CampaignSequence objects. Together these represent a series of triggers and property changes a campaign can undergo during execution. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | SequenceItem | A class representing a named member of a CampaignSequence Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | SkillSetConfiguration | Contains configuration and administration settings for a Dialer skill set. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | SkillSetConfigurationList | Allows for querying and managing skill set configuration objects. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | SMSBehavior | A PolicyBehavior which sends an email. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | SMSBrokerAccount | An SMS Broker Account belonging to an SMS Broker. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | SMSBrokerConfiguration | Contains configuration for a Dialer SMS Broker. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | SMSBrokerConfigurationList | Allows for querying and managing SMS Broker configuration objects. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | SMSRuleAction |
Public class | StageSetConfiguration | Contains configuration and administration settings for a Dialer Call Stage Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | StageSetConfigurationList | Allows for querying and management stage set objects. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | StatCondition | A policy condition that checks if a system statistic matches a certain value. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | StatRule | A rule with a statistics-based condition. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | StatSequenceItem | A Class that represents a Sequence Item that is triggered when a Stat meets a specific condition. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | TimeAndDateCondition | A PolicyCondition which will check the current time and date. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | TimeAndDayCondition | A PolicyCondition which will check the current time and day of the week. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | TimeCondition | A PolicyCondition which will check the current time. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | TimeRule | A rule with a time-based condition. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | TimeSequenceItem | A class that represents a sequence item that is triggered as a specific moment in time, or repeatedly at a specific interval of time. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | TimezoneMapDatasetConfiguration | Contains configuration settings for a Dialer timezone map dataset. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | TimezoneMapDatasetConfigurationList | Allows for querying and managing timezone map dataset configuration objects. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | UpdateCommand | A command that updates existing records in a contact list table. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | ZoneSetConfiguration | Contains configuration and administration settings for a Dialer zone set. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public class | ZoneSetConfigurationList | Allows for querying and managing zone set configuration objects. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.

Structures

 | Structure | Description
Public structure | CampaignConfiguration..::..CampaignTestResults | Contains a series of values returned from the Test(Int32) method. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public structure | CampaignConfiguration..::..QuickValidateResults | Contains the results from a call to QuickValidate()()()(). Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public structure | CampaignConfiguration..::..SkillCombination | Represents a single combination of skill values occuring in the contact list. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.

Interfaces

 | Interface | Description
Public interface | IExpression | The base class of all expression classes used to construct expression trees by subclasses of ContactListCommand. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.

Enumerations

 | Enumeration | Description
Public enumeration | AbandonControl | Specifies if a call is considered abandoned. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public enumeration | AggregateFunctionType | Aggregate function types.. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public enumeration | BaseScriptConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public enumeration | BaseScriptControlType | Possible types of controls appearing in a script. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public enumeration | BaseScriptDateTimeFormat | Possible types of date/time formats appearing in a script. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public enumeration | BaseScriptPageConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public enumeration | BinaryOperationType | Binary operators that can be applied to expressions. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public enumeration | CampaignConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public enumeration | CampaignStatus | Bit flags indicating the status of a campaign. Used with the CampaignStatusChanged event. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public enumeration | CCSConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public enumeration | ConnectionConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public enumeration | ContactColumnConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public enumeration | ContactListConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public enumeration | DialerConnectionState | Campaign Server connection state Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public enumeration | DNCSourceConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public enumeration | FilterConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public enumeration | FilterType | Filters types to apply to object queries. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public enumeration | ODSConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public enumeration | PhoneNumberTypeConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public enumeration | PolicySetConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public enumeration | ResourceType | Types of files that can be uploaded to the central campaign server. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public enumeration | RuleSetConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public enumeration | ScheduleConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public enumeration | ServerType | Dialer Server Types Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public enumeration | SkillSetConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public enumeration | StageSetConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public enumeration | TableType | The database tables associated with a contact list object. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public enumeration | TimezoneMapDatasetConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.
Public enumeration | ZoneSetConfiguration..::..Property | Specifies constants indicating what properties this configuration object supports. Note: This is supported for IC Server version 4.0 (with Interaction Dialer 4.0) and beyond.

Send comments on this topic to PureConnectDoc@genesys.com

Copyright (c) 1994 - 2022 Genesys


AbandonCondition Class

[image]

IceLib Dialer Technical Reference
AbandonCondition Class
Members See Also Send Feedback
A policy condition that checks if a call was considered abandoned.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class AbandonCondition : PolicyCondition
Visual Basic
Public NotInheritable Class AbandonCondition _
    Inherits PolicyCondition

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyCondition
ININ.IceLib.Configuration.Dialer..::..AbandonCondition

See Also

AbandonCondition Members


AbandonCondition Members

[image] [image]

IceLib Dialer Technical Reference
AbandonCondition Members
AbandonCondition Class Constructors Methods Properties See Also Send Feedback

The AbandonCondition type exposes the following members.

Constructors

 | Name | Description
Public method | AbandonCondition | Creates a new instance of the AbandonCondition class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConditionType | The type of condition. (Inherited from PolicyCondition.)
Public property | Id | The Id of the condition. (Inherited from PolicyCondition.)
Public property | Negated | When true, the logical result of the condition evaluation is flipped. (Inherited from PolicyCondition.)

See Also

AbandonCondition Class


AbandonCondition Constructor

[image]

IceLib Dialer Technical Reference
AbandonCondition Constructor
AbandonCondition Class See Also Send Feedback
Creates a new instance of the AbandonCondition class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public AbandonCondition()
Visual Basic
Public Sub New

See Also

AbandonCondition Class
AbandonCondition Members


AbandonCondition Methods

[image] [image]

IceLib Dialer Technical Reference
AbandonCondition Methods
AbandonCondition Class See Also Send Feedback

The AbandonCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AbandonCondition Class


AbandonCondition Properties

[image] [image]

IceLib Dialer Technical Reference
AbandonCondition Properties
AbandonCondition Class See Also Send Feedback

The AbandonCondition type exposes the following members.

Properties

 | Name | Description
Public property | ConditionType | The type of condition. (Inherited from PolicyCondition.)
Public property | Id | The Id of the condition. (Inherited from PolicyCondition.)
Public property | Negated | When true, the logical result of the condition evaluation is flipped. (Inherited from PolicyCondition.)

See Also

AbandonCondition Class


AbandonControl Enumeration

[image]

IceLib Dialer Technical Reference
AbandonControl Enumeration
See Also Send Feedback
Specifies if a call is considered abandoned.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum AbandonControl
Visual Basic
Public Enumeration AbandonControl

Members

Member name | Value | Description
Unspecified | 0 | Whether the call was abandoned or not is not specified.
Abandoned | 1 | The call was abandoned.
NotAbandoned | 2 | The call was not abandoned.

See Also


ActiveRuleGroupChangedEventEventArgs Class

[image]

IceLib Dialer Technical Reference
ActiveRuleGroupChangedEventEventArgs Class
Members See Also Send Feedback
Contains the name of the group that the campaign was just transitioned to.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class ActiveRuleGroupChangedEventEventArgs : EventArgs
Visual Basic
Public Class ActiveRuleGroupChangedEventEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Configuration.Dialer..::..ActiveRuleGroupChangedEventEventArgs

See Also

ActiveRuleGroupChangedEventEventArgs Members
ININ.IceLib.Configuration.Dialer Namespace
[!:ININ.IceLib.Configuration.Dialer.DialerConfigurationManager.CampaignGroupChanged]


ActiveRuleGroupChangedEventEventArgs Members

[image] [image]

IceLib Dialer Technical Reference
ActiveRuleGroupChangedEventEventArgs Members
ActiveRuleGroupChangedEventEventArgs Class Methods Properties See Also Send Feedback

The ActiveRuleGroupChangedEventEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActiveRuleGroupName | The name of the active campaign group.
Public property | DisplayTransitionAlerts | a flag indicating whether or not the client should display alerts when the ActiveRuleGroupChanged fires. This value is set in Interactive Administrator.
Public property | Id | the configuration id of the campaign
Public property | PreviousRuleGroupName | The name of the campaign group just transitioned from

See Also

ActiveRuleGroupChangedEventEventArgs Class


ActiveRuleGroupChangedEventEventArgs Methods

[image] [image]

IceLib Dialer Technical Reference
ActiveRuleGroupChangedEventEventArgs Methods
ActiveRuleGroupChangedEventEventArgs Class See Also Send Feedback

The ActiveRuleGroupChangedEventEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ActiveRuleGroupChangedEventEventArgs Class


ActiveRuleGroupChangedEventEventArgs Properties

[image] [image]

IceLib Dialer Technical Reference
ActiveRuleGroupChangedEventEventArgs Properties
ActiveRuleGroupChangedEventEventArgs Class See Also Send Feedback

The ActiveRuleGroupChangedEventEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ActiveRuleGroupName | The name of the active campaign group.
Public property | DisplayTransitionAlerts | a flag indicating whether or not the client should display alerts when the ActiveRuleGroupChanged fires. This value is set in Interactive Administrator.
Public property | Id | the configuration id of the campaign
Public property | PreviousRuleGroupName | The name of the campaign group just transitioned from

See Also

ActiveRuleGroupChangedEventEventArgs Class


ActiveRuleGroupName Property

[image]

IceLib Dialer Technical Reference
ActiveRuleGroupChangedEventEventArgs..::..ActiveRuleGroupName Property
ActiveRuleGroupChangedEventEventArgs Class See Also Send Feedback
The name of the active campaign group.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string ActiveRuleGroupName { get; private set; }
Visual Basic
Public Property ActiveRuleGroupName As String
    Get
    Private Set

See Also

ActiveRuleGroupChangedEventEventArgs Class
ActiveRuleGroupChangedEventEventArgs Members


DisplayTransitionAlerts Property

[image]

IceLib Dialer Technical Reference
ActiveRuleGroupChangedEventEventArgs..::..DisplayTransitionAlerts Property
ActiveRuleGroupChangedEventEventArgs Class See Also Send Feedback
a flag indicating whether or not the client should display alerts when the ActiveRuleGroupChanged fires. This value is set in Interactive Administrator.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool DisplayTransitionAlerts { get; set; }
Visual Basic
Public Property DisplayTransitionAlerts As Boolean
    Get
    Set

See Also

ActiveRuleGroupChangedEventEventArgs Class
ActiveRuleGroupChangedEventEventArgs Members


Id Property

[image]

IceLib Dialer Technical Reference
ActiveRuleGroupChangedEventEventArgs..::..Id Property
ActiveRuleGroupChangedEventEventArgs Class See Also Send Feedback
the configuration id of the campaign

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ConfigurationId Id { get; set; }
Visual Basic
Public Property Id As ConfigurationId
    Get
    Set

See Also

ActiveRuleGroupChangedEventEventArgs Class
ActiveRuleGroupChangedEventEventArgs Members


PreviousRuleGroupName Property

[image]

IceLib Dialer Technical Reference
ActiveRuleGroupChangedEventEventArgs..::..PreviousRuleGroupName Property
ActiveRuleGroupChangedEventEventArgs Class See Also Send Feedback
The name of the campaign group just transitioned from

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string PreviousRuleGroupName { get; private set; }
Visual Basic
Public Property PreviousRuleGroupName As String
    Get
    Private Set

See Also

ActiveRuleGroupChangedEventEventArgs Class
ActiveRuleGroupChangedEventEventArgs Members


AgentlessActionBehavior Class

[image]

IceLib Dialer Technical Reference
AgentlessActionBehavior Class
Members See Also Send Feedback
A PolicyBehavior which plays a wav file or redirects to an Attendant profile.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class AgentlessActionBehavior : PolicyBehavior
Visual Basic
Public NotInheritable Class AgentlessActionBehavior _
    Inherits PolicyBehavior

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyBehavior
ININ.IceLib.Configuration.Dialer..::..AgentlessActionBehavior

See Also

AgentlessActionBehavior Members


AgentlessActionBehavior Members

[image] [image]

IceLib Dialer Technical Reference
AgentlessActionBehavior Members
AgentlessActionBehavior Class Constructors Methods Properties See Also Send Feedback

The AgentlessActionBehavior type exposes the following members.

Constructors

 | Name | Description
Public method | AgentlessActionBehavior | Initializes a new instance of the AgentlessActionBehavior class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Action | Get or set the type of action to be performed.
Public property | AttendantProfile | Get or set the attentant profile calls should be routed to.
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | FaxFile | Get or set the full path (on the server) of the fax recording file. This must be an i3f file.
Public property | Id | (Inherited from PolicyBehavior.)
Public property | SecondsOfSilence | Get or set a number of seconds to wait before playing a voice message or starting an attendant profile.
Public property | VoiceFile | Get or set the full path (on the server) of the voice recording file. This must be a wav file.

See Also

AgentlessActionBehavior Class


AgentlessActionBehavior Constructor

[image]

IceLib Dialer Technical Reference
AgentlessActionBehavior Constructor
AgentlessActionBehavior Class See Also Send Feedback
Initializes a new instance of the AgentlessActionBehavior class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public AgentlessActionBehavior()
Visual Basic
Public Sub New

See Also

AgentlessActionBehavior Class
AgentlessActionBehavior Members


AgentlessActionBehavior Methods

[image] [image]

IceLib Dialer Technical Reference
AgentlessActionBehavior Methods
AgentlessActionBehavior Class See Also Send Feedback

The AgentlessActionBehavior type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AgentlessActionBehavior Class


AgentlessActionBehavior Properties

[image] [image]

IceLib Dialer Technical Reference
AgentlessActionBehavior Properties
AgentlessActionBehavior Class See Also Send Feedback

The AgentlessActionBehavior type exposes the following members.

Properties

 | Name | Description
Public property | Action | Get or set the type of action to be performed.
Public property | AttendantProfile | Get or set the attentant profile calls should be routed to.
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | FaxFile | Get or set the full path (on the server) of the fax recording file. This must be an i3f file.
Public property | Id | (Inherited from PolicyBehavior.)
Public property | SecondsOfSilence | Get or set a number of seconds to wait before playing a voice message or starting an attendant profile.
Public property | VoiceFile | Get or set the full path (on the server) of the voice recording file. This must be a wav file.

See Also

AgentlessActionBehavior Class


Action Property

[image]

IceLib Dialer Technical Reference
AgentlessActionBehavior..::..Action Property
AgentlessActionBehavior Class See Also Send Feedback
Get or set the type of action to be performed.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ActionType Action { get; set; }
Visual Basic
Public Property Action As ActionType
    Get
    Set

See Also

AgentlessActionBehavior Class
AgentlessActionBehavior Members


AttendantProfile Property

[image]

IceLib Dialer Technical Reference
AgentlessActionBehavior..::..AttendantProfile Property
AgentlessActionBehavior Class See Also Send Feedback
Get or set the attentant profile calls should be routed to.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string AttendantProfile { get; set; }
Visual Basic
Public Property AttendantProfile As String
    Get
    Set

See Also

AgentlessActionBehavior Class
AgentlessActionBehavior Members


FaxFile Property

[image]

IceLib Dialer Technical Reference
AgentlessActionBehavior..::..FaxFile Property
AgentlessActionBehavior Class See Also Send Feedback
Get or set the full path (on the server) of the fax recording file. This must be an i3f file.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string FaxFile { get; set; }
Visual Basic
Public Property FaxFile As String
    Get
    Set

See Also

AgentlessActionBehavior Class
AgentlessActionBehavior Members


SecondsOfSilence Property

[image]

IceLib Dialer Technical Reference
AgentlessActionBehavior..::..SecondsOfSilence Property
AgentlessActionBehavior Class See Also Send Feedback
Get or set a number of seconds to wait before playing a voice message or starting an attendant profile.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public double SecondsOfSilence { get; set; }
Visual Basic
Public Property SecondsOfSilence As Double
    Get
    Set

See Also

AgentlessActionBehavior Class
AgentlessActionBehavior Members


VoiceFile Property

[image]

IceLib Dialer Technical Reference
AgentlessActionBehavior..::..VoiceFile Property
AgentlessActionBehavior Class See Also Send Feedback
Get or set the full path (on the server) of the voice recording file. This must be a wav file.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string VoiceFile { get; set; }
Visual Basic
Public Property VoiceFile As String
    Get
    Set

See Also

AgentlessActionBehavior Class
AgentlessActionBehavior Members


AgentRuleAction Class

[image]

IceLib Dialer Technical Reference
AgentRuleAction Class
Members See Also Send Feedback
A RuleAction that logs agents in or out of one or more campaigns.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class AgentRuleAction : RuleAction
Visual Basic
Public NotInheritable Class AgentRuleAction _
    Inherits RuleAction

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..RuleAction
ININ.IceLib.Configuration.Dialer..::..AgentRuleAction

See Also

AgentRuleAction Members


AgentRuleAction Members

[image] [image]

IceLib Dialer Technical Reference
AgentRuleAction Members
AgentRuleAction Class Constructors Methods Properties See Also Send Feedback

The AgentRuleAction type exposes the following members.

Constructors

 | Name | Description
Public method | AgentRuleAction | Creates a new instance of the AgentRuleAction class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActionType | The type of action to perform. (Inherited from RuleAction.)
Public property | Agents | The list of agents the action applies to.
Public property | CampaignsIn | The list of campaigns that agents will be logged into.
Public property | CampaignsOut | The list of campaigns that agents will be logged out of.
Public property | Id | The Id of the action. (Inherited from RuleAction.)
Public property | Index | The ordinal number of this action in relation to other actions in a rule. (Inherited from RuleAction.)
Public property | Workgroups | The list of workgroups the action applies to.

See Also

AgentRuleAction Class


AgentRuleAction Constructor

[image]

IceLib Dialer Technical Reference
AgentRuleAction Constructor
AgentRuleAction Class See Also Send Feedback
Creates a new instance of the AgentRuleAction class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public AgentRuleAction()
Visual Basic
Public Sub New

See Also

AgentRuleAction Class
AgentRuleAction Members


AgentRuleAction Methods

[image] [image]

IceLib Dialer Technical Reference
AgentRuleAction Methods
AgentRuleAction Class See Also Send Feedback

The AgentRuleAction type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AgentRuleAction Class


AgentRuleAction Properties

[image] [image]

IceLib Dialer Technical Reference
AgentRuleAction Properties
AgentRuleAction Class See Also Send Feedback

The AgentRuleAction type exposes the following members.

Properties

 | Name | Description
Public property | ActionType | The type of action to perform. (Inherited from RuleAction.)
Public property | Agents | The list of agents the action applies to.
Public property | CampaignsIn | The list of campaigns that agents will be logged into.
Public property | CampaignsOut | The list of campaigns that agents will be logged out of.
Public property | Id | The Id of the action. (Inherited from RuleAction.)
Public property | Index | The ordinal number of this action in relation to other actions in a rule. (Inherited from RuleAction.)
Public property | Workgroups | The list of workgroups the action applies to.

See Also

AgentRuleAction Class


Agents Property

[image]

IceLib Dialer Technical Reference
AgentRuleAction..::..Agents Property
AgentRuleAction Class See Also Send Feedback
The list of agents the action applies to.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<string> Agents { get; private set; }
Visual Basic
Public Property Agents As Collection(Of String)
    Get
    Private Set

See Also

AgentRuleAction Class
AgentRuleAction Members


CampaignsIn Property

[image]

IceLib Dialer Technical Reference
AgentRuleAction..::..CampaignsIn Property
AgentRuleAction Class See Also Send Feedback
The list of campaigns that agents will be logged into.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<ConfigurationId> CampaignsIn { get; private set; }
Visual Basic
Public Property CampaignsIn As Collection(Of ConfigurationId)
    Get
    Private Set

See Also

AgentRuleAction Class
AgentRuleAction Members


CampaignsOut Property

[image]

IceLib Dialer Technical Reference
AgentRuleAction..::..CampaignsOut Property
AgentRuleAction Class See Also Send Feedback
The list of campaigns that agents will be logged out of.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<ConfigurationId> CampaignsOut { get; private set; }
Visual Basic
Public Property CampaignsOut As Collection(Of ConfigurationId)
    Get
    Private Set

See Also

AgentRuleAction Class
AgentRuleAction Members


Workgroups Property

[image]

IceLib Dialer Technical Reference
AgentRuleAction..::..Workgroups Property
AgentRuleAction Class See Also Send Feedback
The list of workgroups the action applies to.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<string> Workgroups { get; private set; }
Visual Basic
Public Property Workgroups As Collection(Of String)
    Get
    Private Set

See Also

AgentRuleAction Class
AgentRuleAction Members


AggregateExpression Class

[image]

IceLib Dialer Technical Reference
AggregateExpression Class
Members See Also Send Feedback
An expression representing an aggregate function.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class AggregateExpression : IInternalExpression,
    IExpression, ICloneable
Visual Basic
Public Class AggregateExpression _
    Implements IInternalExpression, IExpression, ICloneable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..AggregateExpression

See Also

AggregateExpression Members


AggregateExpression Members

[image] [image]

IceLib Dialer Technical Reference
AggregateExpression Members
AggregateExpression Class Constructors Methods Properties See Also Send Feedback

The AggregateExpression type exposes the following members.

Constructors

 | Name | Description
Public method | AggregateExpression()()()() | Initializes a new instance of the AggregateExpression class.
Public method | AggregateExpression(AggregateFunctionType, DBColumn, String, Boolean) | Initializes a new instance of the AggregateExpression class.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Column | The expression to perform the aggregate function on.
Public property | Distinct | A flag indicating whether this expression should be evaluated with only distinct values.
Public property | Function | The type of aggregate function used in this expression.
Public property | ResultName | The column name to use if this expression is part of a result set.

See Also

AggregateExpression Class


AggregateExpression Constructor

[image] [image]

IceLib Dialer Technical Reference
AggregateExpression Constructor
AggregateExpression Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AggregateExpression()()()() | Initializes a new instance of the AggregateExpression class.
Public method | AggregateExpression(AggregateFunctionType, DBColumn, String, Boolean) | Initializes a new instance of the AggregateExpression class.

See Also

AggregateExpression Class
AggregateExpression Members


AggregateExpression Constructor

[image]

IceLib Dialer Technical Reference
AggregateExpression Constructor
AggregateExpression Class See Also Send Feedback
Initializes a new instance of the AggregateExpression class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public AggregateExpression()
Visual Basic
Public Sub New

See Also

AggregateExpression Class
AggregateExpression Members
AggregateExpression Overload


AggregateExpression Constructor (AggregateFunctionType, DBColumn, String, Boolean)

[image]

IceLib Dialer Technical Reference
AggregateExpression Constructor (AggregateFunctionType, DBColumn, String, Boolean)
AggregateExpression Class See Also Send Feedback
Initializes a new instance of the AggregateExpression class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public AggregateExpression(
    AggregateFunctionType function,
    DBColumn column,
    string resultName,
    bool distinct
)
Visual Basic
Public Sub New ( _
    function As AggregateFunctionType, _
    column As DBColumn, _
    resultName As String, _
    distinct As Boolean _
)

Parameters

function
Type: ININ.IceLib.Configuration.Dialer..::..AggregateFunctionType
The type of aggregate function to use in this expression.
column
Type: ININ.IceLib.Configuration.Dialer.DataTypes..::..DBColumn
The parameter passed to the aggregate function.
resultName
Type: System..::..String
The column name to use if this expression is part of a result set.
distinct
Type: System..::..Boolean
A flag indicating whether this expression should be evaluated with only distinct values.

See Also

AggregateExpression Class
AggregateExpression Members
AggregateExpression Overload


AggregateExpression Methods

[image] [image]

IceLib Dialer Technical Reference
AggregateExpression Methods
AggregateExpression Class See Also Send Feedback

The AggregateExpression type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

AggregateExpression Class


Clone Method

[image]

IceLib Dialer Technical Reference
AggregateExpression..::..Clone Method
AggregateExpression Class See Also Send Feedback
Creates a new object that is a copy of the current instance.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

A new object that is a copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

AggregateExpression Class
AggregateExpression Members


ToString Method

[image]

IceLib Dialer Technical Reference
AggregateExpression..::..ToString Method
AggregateExpression Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

See Also

AggregateExpression Class
AggregateExpression Members


AggregateExpression Properties

[image] [image]

IceLib Dialer Technical Reference
AggregateExpression Properties
AggregateExpression Class See Also Send Feedback

The AggregateExpression type exposes the following members.

Properties

 | Name | Description
Public property | Column | The expression to perform the aggregate function on.
Public property | Distinct | A flag indicating whether this expression should be evaluated with only distinct values.
Public property | Function | The type of aggregate function used in this expression.
Public property | ResultName | The column name to use if this expression is part of a result set.

See Also

AggregateExpression Class


Column Property

[image]

IceLib Dialer Technical Reference
AggregateExpression..::..Column Property
AggregateExpression Class See Also Send Feedback
The expression to perform the aggregate function on.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DBColumn Column { get; set; }
Visual Basic
Public Property Column As DBColumn
    Get
    Set

See Also

AggregateExpression Class
AggregateExpression Members


Distinct Property

[image]

IceLib Dialer Technical Reference
AggregateExpression..::..Distinct Property
AggregateExpression Class See Also Send Feedback
A flag indicating whether this expression should be evaluated with only distinct values.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool Distinct { get; set; }
Visual Basic
Public Property Distinct As Boolean
    Get
    Set

See Also

AggregateExpression Class
AggregateExpression Members


Function Property

[image]

IceLib Dialer Technical Reference
AggregateExpression..::..Function Property
AggregateExpression Class See Also Send Feedback
The type of aggregate function used in this expression.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public AggregateFunctionType Function { get; set; }
Visual Basic
Public Property Function As AggregateFunctionType
    Get
    Set

See Also

AggregateExpression Class
AggregateExpression Members


ResultName Property

[image]

IceLib Dialer Technical Reference
AggregateExpression..::..ResultName Property
AggregateExpression Class See Also Send Feedback
The column name to use if this expression is part of a result set.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string ResultName { get; set; }
Visual Basic
Public Property ResultName As String
    Get
    Set

See Also

AggregateExpression Class
AggregateExpression Members


AggregateFunctionType Enumeration

[image]

IceLib Dialer Technical Reference
AggregateFunctionType Enumeration
See Also Send Feedback
Aggregate function types..

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum AggregateFunctionType
Visual Basic
Public Enumeration AggregateFunctionType

Members

Member name | Value | Description
Unknown | 0 | No aggregate function specified.
Avg | 1 | The average value of a given column across all records returned.
Count | 2 | The total number of records returned.
Min | 3 | The minimum value of a given column across all records returned.
Max | 4 | The maximum value of a given column across all records returned.
Sum | 5 | The sum of all values of a given column across all records returned.

See Also


AttributeBehavior Class

[image]

IceLib Dialer Technical Reference
AttributeBehavior Class
Members See Also Send Feedback
A PolicyBehavior which sets a contact attribute.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class AttributeBehavior : PolicyBehavior
Visual Basic
Public NotInheritable Class AttributeBehavior _
    Inherits PolicyBehavior

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyBehavior
ININ.IceLib.Configuration.Dialer..::..AttributeBehavior

See Also

AttributeBehavior Members


AttributeBehavior Members

[image] [image]

IceLib Dialer Technical Reference
AttributeBehavior Members
AttributeBehavior Class Constructors Methods Properties See Also Send Feedback

The AttributeBehavior type exposes the following members.

Constructors

 | Name | Description
Public method | AttributeBehavior | Initializes a new instance of the AttributeBehavior class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AttributeName | Get or set the name of the target attribute.
Public property | AttributeValue | Get or set the new value to be assigned to the attribute. (may include macros)
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | ContactList | Get or set the contact list containing the attribute to which this behavior pertains.
Public property | Id | (Inherited from PolicyBehavior.)
Public property | Operand | Get or set the right hand value for use with Operation.
Public property | Operation | Get or set the operation to be applied to the new value before assigning.

See Also

AttributeBehavior Class


AttributeBehavior Constructor

[image]

IceLib Dialer Technical Reference
AttributeBehavior Constructor
AttributeBehavior Class See Also Send Feedback
Initializes a new instance of the AttributeBehavior class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public AttributeBehavior()
Visual Basic
Public Sub New

See Also

AttributeBehavior Class
AttributeBehavior Members


AttributeBehavior Methods

[image] [image]

IceLib Dialer Technical Reference
AttributeBehavior Methods
AttributeBehavior Class See Also Send Feedback

The AttributeBehavior type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AttributeBehavior Class


AttributeBehavior Properties

[image] [image]

IceLib Dialer Technical Reference
AttributeBehavior Properties
AttributeBehavior Class See Also Send Feedback

The AttributeBehavior type exposes the following members.

Properties

 | Name | Description
Public property | AttributeName | Get or set the name of the target attribute.
Public property | AttributeValue | Get or set the new value to be assigned to the attribute. (may include macros)
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | ContactList | Get or set the contact list containing the attribute to which this behavior pertains.
Public property | Id | (Inherited from PolicyBehavior.)
Public property | Operand | Get or set the right hand value for use with Operation.
Public property | Operation | Get or set the operation to be applied to the new value before assigning.

See Also

AttributeBehavior Class


AttributeName Property

[image]

IceLib Dialer Technical Reference
AttributeBehavior..::..AttributeName Property
AttributeBehavior Class See Also Send Feedback
Get or set the name of the target attribute.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string AttributeName { get; set; }
Visual Basic
Public Property AttributeName As String
    Get
    Set

See Also

AttributeBehavior Class
AttributeBehavior Members


AttributeValue Property

[image]

IceLib Dialer Technical Reference
AttributeBehavior..::..AttributeValue Property
AttributeBehavior Class See Also Send Feedback
Get or set the new value to be assigned to the attribute. (may include macros)

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string AttributeValue { get; set; }
Visual Basic
Public Property AttributeValue As String
    Get
    Set

See Also

AttributeBehavior Class
AttributeBehavior Members


ContactList Property

[image]

IceLib Dialer Technical Reference
AttributeBehavior..::..ContactList Property
AttributeBehavior Class See Also Send Feedback
Get or set the contact list containing the attribute to which this behavior pertains.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ConfigurationId ContactList { get; set; }
Visual Basic
Public Property ContactList As ConfigurationId
    Get
    Set

See Also

AttributeBehavior Class
AttributeBehavior Members


Operand Property

[image]

IceLib Dialer Technical Reference
AttributeBehavior..::..Operand Property
AttributeBehavior Class See Also Send Feedback
Get or set the right hand value for use with Operation.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Operand { get; set; }
Visual Basic
Public Property Operand As String
    Get
    Set

See Also

AttributeBehavior Class
AttributeBehavior Members


Operation Property

[image]

IceLib Dialer Technical Reference
AttributeBehavior..::..Operation Property
AttributeBehavior Class See Also Send Feedback
Get or set the operation to be applied to the new value before assigning.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public AttributeOperation Operation { get; set; }
Visual Basic
Public Property Operation As AttributeOperation
    Get
    Set

See Also

AttributeBehavior Class
AttributeBehavior Members


AttributeCondition Class

[image]

IceLib Dialer Technical Reference
AttributeCondition Class
Members See Also Send Feedback
A policy condition that checks if an attribute on a contact record matches a desired value.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class AttributeCondition : PolicyCondition
Visual Basic
Public NotInheritable Class AttributeCondition _
    Inherits PolicyCondition

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyCondition
ININ.IceLib.Configuration.Dialer..::..AttributeCondition

See Also

AttributeCondition Members


AttributeCondition Members

[image] [image]

IceLib Dialer Technical Reference
AttributeCondition Members
AttributeCondition Class Constructors Methods Properties See Also Send Feedback

The AttributeCondition type exposes the following members.

Constructors

 | Name | Description
Public method | AttributeCondition | Creates a new instance of the AttributeCondition class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AttributeName | The name of the attribute to be checked.
Public property | AttributeType | The data type of the attribute.
Public property | ConditionType | The type of condition. (Inherited from PolicyCondition.)
Public property | ContactList | The Id of the contact list containing the attribute. The campaign referencing this policy must be using this contact list.
Public property | DateValue | The matching value for date-based attributes.
Public property | Id | The Id of the condition. (Inherited from PolicyCondition.)
Public property | Negated | When true, the logical result of the condition evaluation is flipped. (Inherited from PolicyCondition.)
Public property | NumericValue | The matching value for numeric attributes.
Public property | Operation | An conditional operator that compares the attribute value to the matching value.
Public property | StringValue | The matching value for a text attribute.
Public property | TimeValue | The matching value for a time-based attribute.

See Also

AttributeCondition Class


AttributeCondition Constructor

[image]

IceLib Dialer Technical Reference
AttributeCondition Constructor
AttributeCondition Class See Also Send Feedback
Creates a new instance of the AttributeCondition class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public AttributeCondition()
Visual Basic
Public Sub New

See Also

AttributeCondition Class
AttributeCondition Members


AttributeCondition Methods

[image] [image]

IceLib Dialer Technical Reference
AttributeCondition Methods
AttributeCondition Class See Also Send Feedback

The AttributeCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AttributeCondition Class


AttributeCondition Properties

[image] [image]

IceLib Dialer Technical Reference
AttributeCondition Properties
AttributeCondition Class See Also Send Feedback

The AttributeCondition type exposes the following members.

Properties

 | Name | Description
Public property | AttributeName | The name of the attribute to be checked.
Public property | AttributeType | The data type of the attribute.
Public property | ConditionType | The type of condition. (Inherited from PolicyCondition.)
Public property | ContactList | The Id of the contact list containing the attribute. The campaign referencing this policy must be using this contact list.
Public property | DateValue | The matching value for date-based attributes.
Public property | Id | The Id of the condition. (Inherited from PolicyCondition.)
Public property | Negated | When true, the logical result of the condition evaluation is flipped. (Inherited from PolicyCondition.)
Public property | NumericValue | The matching value for numeric attributes.
Public property | Operation | An conditional operator that compares the attribute value to the matching value.
Public property | StringValue | The matching value for a text attribute.
Public property | TimeValue | The matching value for a time-based attribute.

See Also

AttributeCondition Class


AttributeName Property

[image]

IceLib Dialer Technical Reference
AttributeCondition..::..AttributeName Property
AttributeCondition Class See Also Send Feedback
The name of the attribute to be checked.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string AttributeName { get; set; }
Visual Basic
Public Property AttributeName As String
    Get
    Set

See Also

AttributeCondition Class
AttributeCondition Members


AttributeType Property

[image]

IceLib Dialer Technical Reference
AttributeCondition..::..AttributeType Property
AttributeCondition Class See Also Send Feedback
The data type of the attribute.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public RecordAttributeType AttributeType { get; set; }
Visual Basic
Public Property AttributeType As RecordAttributeType
    Get
    Set

See Also

AttributeCondition Class
AttributeCondition Members


ContactList Property

[image]

IceLib Dialer Technical Reference
AttributeCondition..::..ContactList Property
AttributeCondition Class See Also Send Feedback
The Id of the contact list containing the attribute. The campaign referencing this policy must be using this contact list.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ConfigurationId ContactList { get; set; }
Visual Basic
Public Property ContactList As ConfigurationId
    Get
    Set

See Also

AttributeCondition Class
AttributeCondition Members


DateValue Property

[image]

IceLib Dialer Technical Reference
AttributeCondition..::..DateValue Property
AttributeCondition Class See Also Send Feedback
The matching value for date-based attributes.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DateTime DateValue { get; set; }
Visual Basic
Public Property DateValue As DateTime
    Get
    Set

See Also

AttributeCondition Class
AttributeCondition Members


NumericValue Property

[image]

IceLib Dialer Technical Reference
AttributeCondition..::..NumericValue Property
AttributeCondition Class See Also Send Feedback
The matching value for numeric attributes.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public double NumericValue { get; set; }
Visual Basic
Public Property NumericValue As Double
    Get
    Set

See Also

AttributeCondition Class
AttributeCondition Members


Operation Property

[image]

IceLib Dialer Technical Reference
AttributeCondition..::..Operation Property
AttributeCondition Class See Also Send Feedback
An conditional operator that compares the attribute value to the matching value.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ComparisonOperator Operation { get; set; }
Visual Basic
Public Property Operation As ComparisonOperator
    Get
    Set

See Also

AttributeCondition Class
AttributeCondition Members


StringValue Property

[image]

IceLib Dialer Technical Reference
AttributeCondition..::..StringValue Property
AttributeCondition Class See Also Send Feedback
The matching value for a text attribute.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string StringValue { get; set; }
Visual Basic
Public Property StringValue As String
    Get
    Set

See Also

AttributeCondition Class
AttributeCondition Members


TimeValue Property

[image]

IceLib Dialer Technical Reference
AttributeCondition..::..TimeValue Property
AttributeCondition Class See Also Send Feedback
The matching value for a time-based attribute.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DateTime TimeValue { get; set; }
Visual Basic
Public Property TimeValue As DateTime
    Get
    Set

See Also

AttributeCondition Class
AttributeCondition Members


BadRevisionException Class

[image]

IceLib Dialer Technical Reference
BadRevisionException Class
Members See Also Send Feedback
The exception thrown when an attempt is made to modify a configuration object with a revision level that does not match what the server expects.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
[SerializableAttribute]
public class BadRevisionException : IceLibException
Visual Basic
<SerializableAttribute> _
Public Class BadRevisionException _
    Inherits IceLibException

Inheritance Hierarchy

System..::..Object
System..::..Exception
IceLibException
ININ.IceLib.Configuration.Dialer..::..BadRevisionException

See Also

BadRevisionException Members


BadRevisionException Members

[image] [image]

IceLib Dialer Technical Reference
BadRevisionException Members
BadRevisionException Class Constructors Methods Properties Events See Also Send Feedback

The BadRevisionException type exposes the following members.

Constructors

 | Name | Description
Public method | BadRevisionException | Initializes a new instance of the BadRevisionException class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | (Inherited from IceLibException.)
Public property | ErrorType | (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

BadRevisionException Class


BadRevisionException Constructor

[image]

IceLib Dialer Technical Reference
BadRevisionException Constructor
BadRevisionException Class See Also Send Feedback
Initializes a new instance of the BadRevisionException class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public BadRevisionException(
    string info
)
Visual Basic
Public Sub New ( _
    info As String _
)

Parameters

info
Type: System..::..String

See Also

BadRevisionException Class
BadRevisionException Members


BadRevisionException Methods

[image] [image]

IceLib Dialer Technical Reference
BadRevisionException Methods
BadRevisionException Class See Also Send Feedback

The BadRevisionException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

BadRevisionException Class


BadRevisionException Properties

[image] [image]

IceLib Dialer Technical Reference
BadRevisionException Properties
BadRevisionException Class See Also Send Feedback

The BadRevisionException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | (Inherited from IceLibException.)
Public property | ErrorType | (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

BadRevisionException Class


BadRevisionException Events

[image] [image]

IceLib Dialer Technical Reference
BadRevisionException Events
BadRevisionException Class See Also Send Feedback

The BadRevisionException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

BadRevisionException Class


BaseScriptConfiguration Class

[image]

IceLib Dialer Technical Reference
BaseScriptConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for a Dialer BaseScript.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class BaseScriptConfiguration : EditableListConfigurationObject<BaseScriptConfiguration..::..Property>,
    IExportable
Visual Basic
Public Class BaseScriptConfiguration _
    Inherits EditableListConfigurationObject(Of BaseScriptConfiguration..::..Property) _
    Implements IExportable

Inheritance Hierarchy

System..::..Object
ConfigurationObject
ListConfigurationObject
EditableListConfigurationObject<(Of <(<' BaseScriptConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..BaseScriptConfiguration

See Also

BaseScriptConfiguration Members


BaseScriptConfiguration Members

[image] [image]

IceLib Dialer Technical Reference
BaseScriptConfiguration Members
BaseScriptConfiguration Class Methods Properties See Also Send Feedback

The BaseScriptConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptConfiguration..::..Property >)>)>.)
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptConfiguration..::..Property >)>)>.)
Public method | ToString | (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptConfiguration..::..Property >)>)>.)
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | ContactList | The contact list that the script applies to.
Public property | IsDefaultObect | Indicates whether this is the default instance of this object type.
Public property | IsExporting | Tells whether the current BaseScriptConfiguration is being used for exporting.
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | Miscellaneous | A collection of miscellaneous script settings.
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | Pages | The list of individual pages contained in the script.
Public property | PropertiesChanged | Contains the properties that have been modified since this object was last committed.
Public property | RevisionLevel | The current version of the object.

See Also

BaseScriptConfiguration Class


BaseScriptConfiguration Methods

[image] [image]

IceLib Dialer Technical Reference
BaseScriptConfiguration Methods
BaseScriptConfiguration Class See Also Send Feedback

The BaseScriptConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptConfiguration..::..Property >)>)>.)
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptConfiguration..::..Property >)>)>.)
Public method | ToString | (Inherited from ConfigurationObject.)

See Also

BaseScriptConfiguration Class


BaseScriptConfiguration Properties

[image] [image]

IceLib Dialer Technical Reference
BaseScriptConfiguration Properties
BaseScriptConfiguration Class See Also Send Feedback

The BaseScriptConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptConfiguration..::..Property >)>)>.)
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | ContactList | The contact list that the script applies to.
Public property | IsDefaultObect | Indicates whether this is the default instance of this object type.
Public property | IsExporting | Tells whether the current BaseScriptConfiguration is being used for exporting.
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | Miscellaneous | A collection of miscellaneous script settings.
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | Pages | The list of individual pages contained in the script.
Public property | PropertiesChanged | Contains the properties that have been modified since this object was last committed.
Public property | RevisionLevel | The current version of the object.

See Also

BaseScriptConfiguration Class


ContactList Property

[image]

IceLib Dialer Technical Reference
BaseScriptConfiguration..::..ContactList Property
BaseScriptConfiguration Class See Also Send Feedback
The contact list that the script applies to.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<BaseScriptConfiguration..::..Property, ConfigurationId> ContactList { get; }
Visual Basic
Public ReadOnly Property ContactList As GeneralConfigurationProperty(Of BaseScriptConfiguration..::..Property, ConfigurationId)
    Get

See Also

BaseScriptConfiguration Class
BaseScriptConfiguration Members


IsDefaultObect Property

[image]

IceLib Dialer Technical Reference
BaseScriptConfiguration..::..IsDefaultObect Property
BaseScriptConfiguration Class See Also Send Feedback
Indicates whether this is the default instance of this object type.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsDefaultObect { get; }
Visual Basic
Public ReadOnly Property IsDefaultObect As Boolean
    Get

See Also

BaseScriptConfiguration Class
BaseScriptConfiguration Members


IsExporting Property

[image]

IceLib Dialer Technical Reference
BaseScriptConfiguration..::..IsExporting Property
BaseScriptConfiguration Class See Also Send Feedback
Tells whether the current BaseScriptConfiguration is being used for exporting.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsExporting { get; private set; }
Visual Basic
Public Property IsExporting As Boolean
    Get
    Private Set

See Also

BaseScriptConfiguration Class
BaseScriptConfiguration Members


Miscellaneous Property

[image]

IceLib Dialer Technical Reference
BaseScriptConfiguration..::..Miscellaneous Property
BaseScriptConfiguration Class See Also Send Feedback
A collection of miscellaneous script settings.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<BaseScriptConfiguration..::..Property, BaseScriptMiscellaneous> Miscellaneous { get; }
Visual Basic
Public ReadOnly Property Miscellaneous As GeneralConfigurationProperty(Of BaseScriptConfiguration..::..Property, BaseScriptMiscellaneous)
    Get

See Also

BaseScriptConfiguration Class
BaseScriptConfiguration Members


Pages Property

[image]

IceLib Dialer Technical Reference
BaseScriptConfiguration..::..Pages Property
BaseScriptConfiguration Class See Also Send Feedback
The list of individual pages contained in the script.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<BaseScriptConfiguration..::..Property, Collection<BaseScriptPageConfiguration>> Pages { get; }
Visual Basic
Public ReadOnly Property Pages As GeneralConfigurationProperty(Of BaseScriptConfiguration..::..Property, Collection(Of BaseScriptPageConfiguration))
    Get

See Also

BaseScriptConfiguration Class
BaseScriptConfiguration Members


PropertiesChanged Property

[image]

IceLib Dialer Technical Reference
BaseScriptConfiguration..::..PropertiesChanged Property
BaseScriptConfiguration Class See Also Send Feedback
Contains the properties that have been modified since this object was last committed.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ReadOnlyCollection<BaseScriptConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of BaseScriptConfiguration..::..Property)
    Get

See Also

BaseScriptConfiguration Class
BaseScriptConfiguration Members


RevisionLevel Property

[image]

IceLib Dialer Technical Reference
BaseScriptConfiguration..::..RevisionLevel Property
BaseScriptConfiguration Class See Also Send Feedback
The current version of the object.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<BaseScriptConfiguration..::..Property, int> RevisionLevel { get; }
Visual Basic
Public ReadOnly Property RevisionLevel As GeneralConfigurationProperty(Of BaseScriptConfiguration..::..Property, Integer)
    Get

See Also

BaseScriptConfiguration Class
BaseScriptConfiguration Members


BaseScriptConfiguration.Property Enumeration

[image]

IceLib Dialer Technical Reference
BaseScriptConfiguration..::..Property Enumeration
BaseScriptConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Id | 0 | Represents the Id part of the ConfigurationId property.
DisplayName | 1 | Represents the DisplayName part of the ConfigurationId property.
RevisionLevel | 2 | Represents the RevisionLevel property.
ContactList | 3 | Represents the ContactList property.
Pages | 4 | Represents the Pages property.
Miscellaneous | 5 | Represents the Miscellaneous property.

See Also


BaseScriptConfigurationList Class

[image]

IceLib Dialer Technical Reference
BaseScriptConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing BaseScript configuration objects.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class BaseScriptConfigurationList : EditableConfigurationList<BaseScriptConfiguration, BaseScriptConfiguration..::..Property>
Visual Basic
Public Class BaseScriptConfigurationList _
    Inherits EditableConfigurationList(Of BaseScriptConfiguration, BaseScriptConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>
DynamicConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>
EditableConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..BaseScriptConfigurationList

See Also

BaseScriptConfigurationList Members


BaseScriptConfigurationList Members

[image] [image]

IceLib Dialer Technical Reference
BaseScriptConfigurationList Members
BaseScriptConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The BaseScriptConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | BaseScriptConfigurationList | Initializes a new instance of the BaseScriptConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)

See Also

BaseScriptConfigurationList Class


BaseScriptConfigurationList Constructor

[image]

IceLib Dialer Technical Reference
BaseScriptConfigurationList Constructor
BaseScriptConfigurationList Class See Also Send Feedback
Initializes a new instance of the BaseScriptConfigurationList class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public BaseScriptConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

BaseScriptConfigurationList Class
BaseScriptConfigurationList Members


BaseScriptConfigurationList Methods

[image] [image]

IceLib Dialer Technical Reference
BaseScriptConfigurationList Methods
BaseScriptConfigurationList Class See Also Send Feedback

The BaseScriptConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseScriptConfigurationList Class


BaseScriptConfigurationList Properties

[image] [image]

IceLib Dialer Technical Reference
BaseScriptConfigurationList Properties
BaseScriptConfigurationList Class See Also Send Feedback

The BaseScriptConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)

See Also

BaseScriptConfigurationList Class


BaseScriptConfigurationList Events

[image] [image]

IceLib Dialer Technical Reference
BaseScriptConfigurationList Events
BaseScriptConfigurationList Class See Also Send Feedback

The BaseScriptConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptConfiguration, BaseScriptConfiguration..::..Property >)>)>.)

See Also

BaseScriptConfigurationList Class


BaseScriptControl Class

[image]

IceLib Dialer Technical Reference
BaseScriptControl Class
Members See Also Send Feedback
Represents a user interface control on a script page.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public abstract class BaseScriptControl
Visual Basic
Public MustInherit Class BaseScriptControl

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..BaseScriptControl
ININ.IceLib.Configuration.Dialer..::..BaseScriptDateTimeControl
ININ.IceLib.Configuration.Dialer..::..BaseScriptDropListControl
ININ.IceLib.Configuration.Dialer..::..BaseScriptNumericControl
ININ.IceLib.Configuration.Dialer..::..BaseScriptRadioBoxControl
ININ.IceLib.Configuration.Dialer..::..BaseScriptTextControl

See Also

BaseScriptControl Members


BaseScriptControl Members

[image] [image]

IceLib Dialer Technical Reference
BaseScriptControl Members
BaseScriptControl Class Constructors Methods Properties See Also Send Feedback

The BaseScriptControl type exposes the following members.

Constructors

 | Name | Description
Protected method | BaseScriptControl | Initializes a new instance of the BaseScriptControl class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ColumnName | The contact attribute that this control is associated with.
Public property | ControlType | The type of the control (text, numeric, date/time, radio, droplist).
Public property | IsReadOnly | If true, agents cannot modify the value of the associated contact attribute.
Public property | Label | The name of the control.

See Also

BaseScriptControl Class


BaseScriptControl Constructor

[image]

IceLib Dialer Technical Reference
BaseScriptControl Constructor
BaseScriptControl Class See Also Send Feedback
Initializes a new instance of the BaseScriptControl class

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
protected BaseScriptControl()
Visual Basic
Protected Sub New

See Also

BaseScriptControl Class
BaseScriptControl Members


BaseScriptControl Methods

[image] [image]

IceLib Dialer Technical Reference
BaseScriptControl Methods
BaseScriptControl Class See Also Send Feedback

The BaseScriptControl type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseScriptControl Class


BaseScriptControl Properties

[image] [image]

IceLib Dialer Technical Reference
BaseScriptControl Properties
BaseScriptControl Class See Also Send Feedback

The BaseScriptControl type exposes the following members.

Properties

 | Name | Description
Public property | ColumnName | The contact attribute that this control is associated with.
Public property | ControlType | The type of the control (text, numeric, date/time, radio, droplist).
Public property | IsReadOnly | If true, agents cannot modify the value of the associated contact attribute.
Public property | Label | The name of the control.

See Also

BaseScriptControl Class


ColumnName Property

[image]

IceLib Dialer Technical Reference
BaseScriptControl..::..ColumnName Property
BaseScriptControl Class See Also Send Feedback
The contact attribute that this control is associated with.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string ColumnName { get; set; }
Visual Basic
Public Property ColumnName As String
    Get
    Set

See Also

BaseScriptControl Class
BaseScriptControl Members


ControlType Property

[image]

IceLib Dialer Technical Reference
BaseScriptControl..::..ControlType Property
BaseScriptControl Class See Also Send Feedback
The type of the control (text, numeric, date/time, radio, droplist).

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public abstract BaseScriptControlType ControlType { get; }
Visual Basic
Public MustOverride ReadOnly Property ControlType As BaseScriptControlType
    Get

See Also

BaseScriptControl Class
BaseScriptControl Members


IsReadOnly Property

[image]

IceLib Dialer Technical Reference
BaseScriptControl..::..IsReadOnly Property
BaseScriptControl Class See Also Send Feedback
If true, agents cannot modify the value of the associated contact attribute.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsReadOnly { get; set; }
Visual Basic
Public Property IsReadOnly As Boolean
    Get
    Set

See Also

BaseScriptControl Class
BaseScriptControl Members


Label Property

[image]

IceLib Dialer Technical Reference
BaseScriptControl..::..Label Property
BaseScriptControl Class See Also Send Feedback
The name of the control.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Label { get; set; }
Visual Basic
Public Property Label As String
    Get
    Set

See Also

BaseScriptControl Class
BaseScriptControl Members


BaseScriptControlType Enumeration

[image]

IceLib Dialer Technical Reference
BaseScriptControlType Enumeration
See Also Send Feedback
Possible types of controls appearing in a script.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum BaseScriptControlType
Visual Basic
Public Enumeration BaseScriptControlType

Members

Member name | Value | Description
Text | 0 | A basic text input box.
Numeric | 1 | A textbox that accepts only numeric input.
RadioBox | 2 | A list of mutually exclusive options appearing as individual controls.
DropList | 3 | A list of mutually exclusive options.
DateTime | 4 | Manages date/time values.

See Also


BaseScriptDateTimeControl Class

[image]

IceLib Dialer Technical Reference
BaseScriptDateTimeControl Class
Members See Also Send Feedback
Represents a date/time control on a base script page.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class BaseScriptDateTimeControl : BaseScriptControl
Visual Basic
Public Class BaseScriptDateTimeControl _
    Inherits BaseScriptControl

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..BaseScriptControl
ININ.IceLib.Configuration.Dialer..::..BaseScriptDateTimeControl

See Also

BaseScriptDateTimeControl Members


BaseScriptDateTimeControl Members

[image] [image]

IceLib Dialer Technical Reference
BaseScriptDateTimeControl Members
BaseScriptDateTimeControl Class Constructors Methods Properties See Also Send Feedback

The BaseScriptDateTimeControl type exposes the following members.

Constructors

 | Name | Description
Public method | BaseScriptDateTimeControl | Initializes a new instance of the BaseScriptDateTimeControl class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ColumnName | The contact attribute that this control is associated with. (Inherited from BaseScriptControl.)
Public property | ControlType | The type of the control (text, numeric, date/time, radio, droplist). (Overrides BaseScriptControl..::..ControlType.)
Public property | Format | Specifies how the date/time should be formatted.
Public property | IsReadOnly | If true, agents cannot modify the value of the associated contact attribute. (Inherited from BaseScriptControl.)
Public property | Label | The name of the control. (Inherited from BaseScriptControl.)

See Also

BaseScriptDateTimeControl Class


BaseScriptDateTimeControl Constructor

[image]

IceLib Dialer Technical Reference
BaseScriptDateTimeControl Constructor
BaseScriptDateTimeControl Class See Also Send Feedback
Initializes a new instance of the BaseScriptDateTimeControl class

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public BaseScriptDateTimeControl()
Visual Basic
Public Sub New

See Also

BaseScriptDateTimeControl Class
BaseScriptDateTimeControl Members


BaseScriptDateTimeControl Methods

[image] [image]

IceLib Dialer Technical Reference
BaseScriptDateTimeControl Methods
BaseScriptDateTimeControl Class See Also Send Feedback

The BaseScriptDateTimeControl type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseScriptDateTimeControl Class


BaseScriptDateTimeControl Properties

[image] [image]

IceLib Dialer Technical Reference
BaseScriptDateTimeControl Properties
BaseScriptDateTimeControl Class See Also Send Feedback

The BaseScriptDateTimeControl type exposes the following members.

Properties

 | Name | Description
Public property | ColumnName | The contact attribute that this control is associated with. (Inherited from BaseScriptControl.)
Public property | ControlType | The type of the control (text, numeric, date/time, radio, droplist). (Overrides BaseScriptControl..::..ControlType.)
Public property | Format | Specifies how the date/time should be formatted.
Public property | IsReadOnly | If true, agents cannot modify the value of the associated contact attribute. (Inherited from BaseScriptControl.)
Public property | Label | The name of the control. (Inherited from BaseScriptControl.)

See Also

BaseScriptDateTimeControl Class


ControlType Property

[image]

IceLib Dialer Technical Reference
BaseScriptDateTimeControl..::..ControlType Property
BaseScriptDateTimeControl Class See Also Send Feedback
The type of the control (text, numeric, date/time, radio, droplist).

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override BaseScriptControlType ControlType { get; }
Visual Basic
Public Overrides ReadOnly Property ControlType As BaseScriptControlType
    Get

See Also

BaseScriptDateTimeControl Class
BaseScriptDateTimeControl Members


Format Property

[image]

IceLib Dialer Technical Reference
BaseScriptDateTimeControl..::..Format Property
BaseScriptDateTimeControl Class See Also Send Feedback
Specifies how the date/time should be formatted.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public BaseScriptDateTimeFormat Format { get; set; }
Visual Basic
Public Property Format As BaseScriptDateTimeFormat
    Get
    Set

See Also

BaseScriptDateTimeControl Class
BaseScriptDateTimeControl Members
ININ.IceLib.Configuration.Dialer Namespace
ININ.IceLib.Configuration.Dialer..::..BaseScriptDateTimeFormat


BaseScriptDateTimeFormat Enumeration

[image]

IceLib Dialer Technical Reference
BaseScriptDateTimeFormat Enumeration
See Also Send Feedback
Possible types of date/time formats appearing in a script.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum BaseScriptDateTimeFormat
Visual Basic
Public Enumeration BaseScriptDateTimeFormat

Members

Member name | Value | Description
ShortDate | 1 | 6/15/2009 1:45:30 PM -> 6/15/2009
LongDate | 2 | 6/15/2009 1:45:30 PM -> Monday, June 15, 2009
Time | 4 | 6/15/2009 1:45:30 PM -> 1:45:30 PM
ShortDateWithTime | 5 | 6/15/2009 1:45:30 PM -> 6/15/2009 1:45:30 PM
LongDateWithTime | 6 | 6/15/2009 1:45:30 PM -> Monday, June 15, 2009 1:45:30 PM

See Also


BaseScriptDisposition Class

[image]

IceLib Dialer Technical Reference
BaseScriptDisposition Class
Members See Also Send Feedback
Represents a button on a script page that dispositions a call.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class BaseScriptDisposition : BaseScriptDispositionBase
Visual Basic
Public Class BaseScriptDisposition _
    Inherits BaseScriptDispositionBase

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..BaseScriptDispositionBase
ININ.IceLib.Configuration.Dialer..::..BaseScriptDisposition

See Also

BaseScriptDisposition Members


BaseScriptDisposition Members

[image] [image]

IceLib Dialer Technical Reference
BaseScriptDisposition Members
BaseScriptDisposition Class Constructors Methods Properties See Also Send Feedback

The BaseScriptDisposition type exposes the following members.

Constructors

 | Name | Description
Public method | BaseScriptDisposition | Initializes a new instance of the BaseScriptDisposition class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Abandon | Specifies if a call is marked as abandoned.
Public property | Label | The caption on the button or link that activates the disposition. (Inherited from BaseScriptDispositionBase.)
Public property | WrapUpCategory | The wrap up category assigned to the call.
Public property | WrapUpCode | The wrap up code assigned to the call.

See Also

BaseScriptDisposition Class


BaseScriptDisposition Constructor

[image]

IceLib Dialer Technical Reference
BaseScriptDisposition Constructor
BaseScriptDisposition Class See Also Send Feedback
Initializes a new instance of the BaseScriptDisposition class

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public BaseScriptDisposition()
Visual Basic
Public Sub New

See Also

BaseScriptDisposition Class
BaseScriptDisposition Members


BaseScriptDisposition Methods

[image] [image]

IceLib Dialer Technical Reference
BaseScriptDisposition Methods
BaseScriptDisposition Class See Also Send Feedback

The BaseScriptDisposition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseScriptDisposition Class


BaseScriptDisposition Properties

[image] [image]

IceLib Dialer Technical Reference
BaseScriptDisposition Properties
BaseScriptDisposition Class See Also Send Feedback

The BaseScriptDisposition type exposes the following members.

Properties

 | Name | Description
Public property | Abandon | Specifies if a call is marked as abandoned.
Public property | Label | The caption on the button or link that activates the disposition. (Inherited from BaseScriptDispositionBase.)
Public property | WrapUpCategory | The wrap up category assigned to the call.
Public property | WrapUpCode | The wrap up code assigned to the call.

See Also

BaseScriptDisposition Class


Abandon Property

[image]

IceLib Dialer Technical Reference
BaseScriptDisposition..::..Abandon Property
BaseScriptDisposition Class See Also Send Feedback
Specifies if a call is marked as abandoned.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public AbandonControl Abandon { get; set; }
Visual Basic
Public Property Abandon As AbandonControl
    Get
    Set

See Also

BaseScriptDisposition Class
BaseScriptDisposition Members


WrapUpCategory Property

[image]

IceLib Dialer Technical Reference
BaseScriptDisposition..::..WrapUpCategory Property
BaseScriptDisposition Class See Also Send Feedback
The wrap up category assigned to the call.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string WrapUpCategory { get; set; }
Visual Basic
Public Property WrapUpCategory As String
    Get
    Set

See Also

BaseScriptDisposition Class
BaseScriptDisposition Members


WrapUpCode Property

[image]

IceLib Dialer Technical Reference
BaseScriptDisposition..::..WrapUpCode Property
BaseScriptDisposition Class See Also Send Feedback
The wrap up code assigned to the call.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string WrapUpCode { get; set; }
Visual Basic
Public Property WrapUpCode As String
    Get
    Set

See Also

BaseScriptDisposition Class
BaseScriptDisposition Members


BaseScriptDispositionBase Class

[image]

IceLib Dialer Technical Reference
BaseScriptDispositionBase Class
Members See Also Send Feedback
Provides common class members for a disposition button or navigation link on a script.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class BaseScriptDispositionBase
Visual Basic
Public Class BaseScriptDispositionBase

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..BaseScriptDispositionBase
ININ.IceLib.Configuration.Dialer..::..BaseScriptDisposition
ININ.IceLib.Configuration.Dialer..::..BaseScriptNavLink

See Also

BaseScriptDispositionBase Members


BaseScriptDispositionBase Members

[image] [image]

IceLib Dialer Technical Reference
BaseScriptDispositionBase Members
BaseScriptDispositionBase Class Constructors Methods Properties See Also Send Feedback

The BaseScriptDispositionBase type exposes the following members.

Constructors

 | Name | Description
Public method | BaseScriptDispositionBase | Initializes a new instance of the BaseScriptDispositionBase class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Label | The caption on the button or link that activates the disposition.

See Also

BaseScriptDispositionBase Class


BaseScriptDispositionBase Constructor

[image]

IceLib Dialer Technical Reference
BaseScriptDispositionBase Constructor
BaseScriptDispositionBase Class See Also Send Feedback
Initializes a new instance of the BaseScriptDispositionBase class

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public BaseScriptDispositionBase()
Visual Basic
Public Sub New

See Also

BaseScriptDispositionBase Class
BaseScriptDispositionBase Members


BaseScriptDispositionBase Methods

[image] [image]

IceLib Dialer Technical Reference
BaseScriptDispositionBase Methods
BaseScriptDispositionBase Class See Also Send Feedback

The BaseScriptDispositionBase type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseScriptDispositionBase Class


BaseScriptDispositionBase Properties

[image] [image]

IceLib Dialer Technical Reference
BaseScriptDispositionBase Properties
BaseScriptDispositionBase Class See Also Send Feedback

The BaseScriptDispositionBase type exposes the following members.

Properties

 | Name | Description
Public property | Label | The caption on the button or link that activates the disposition.

See Also

BaseScriptDispositionBase Class


Label Property

[image]

IceLib Dialer Technical Reference
BaseScriptDispositionBase..::..Label Property
BaseScriptDispositionBase Class See Also Send Feedback
The caption on the button or link that activates the disposition.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Label { get; set; }
Visual Basic
Public Property Label As String
    Get
    Set

See Also

BaseScriptDispositionBase Class
BaseScriptDispositionBase Members


BaseScriptDropListControl Class

[image]

IceLib Dialer Technical Reference
BaseScriptDropListControl Class
Members See Also Send Feedback
Represents a drop-down control on a base script page.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class BaseScriptDropListControl : BaseScriptControl
Visual Basic
Public Class BaseScriptDropListControl _
    Inherits BaseScriptControl

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..BaseScriptControl
ININ.IceLib.Configuration.Dialer..::..BaseScriptDropListControl

See Also

BaseScriptDropListControl Members


BaseScriptDropListControl Members

[image] [image]

IceLib Dialer Technical Reference
BaseScriptDropListControl Members
BaseScriptDropListControl Class Constructors Methods Properties See Also Send Feedback

The BaseScriptDropListControl type exposes the following members.

Constructors

 | Name | Description
Public method | BaseScriptDropListControl | Initializes a new instance of the BaseScriptDropListControl class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ColumnName | The contact attribute that this control is associated with. (Inherited from BaseScriptControl.)
Public property | ControlType | The type of the control (text, numeric, date/time, radio, droplist). (Overrides BaseScriptControl..::..ControlType.)
Public property | IsReadOnly | If true, agents cannot modify the value of the associated contact attribute. (Inherited from BaseScriptControl.)
Public property | Label | The name of the control. (Inherited from BaseScriptControl.)
Public property | NameValueCollection | The names and values of the drop-down items. Name (key) is the label for the item, value is the value assigned to the contact attribute.

See Also

BaseScriptDropListControl Class


BaseScriptDropListControl Constructor

[image]

IceLib Dialer Technical Reference
BaseScriptDropListControl Constructor
BaseScriptDropListControl Class See Also Send Feedback
Initializes a new instance of the BaseScriptDropListControl class

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public BaseScriptDropListControl()
Visual Basic
Public Sub New

See Also

BaseScriptDropListControl Class
BaseScriptDropListControl Members


BaseScriptDropListControl Methods

[image] [image]

IceLib Dialer Technical Reference
BaseScriptDropListControl Methods
BaseScriptDropListControl Class See Also Send Feedback

The BaseScriptDropListControl type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseScriptDropListControl Class


BaseScriptDropListControl Properties

[image] [image]

IceLib Dialer Technical Reference
BaseScriptDropListControl Properties
BaseScriptDropListControl Class See Also Send Feedback

The BaseScriptDropListControl type exposes the following members.

Properties

 | Name | Description
Public property | ColumnName | The contact attribute that this control is associated with. (Inherited from BaseScriptControl.)
Public property | ControlType | The type of the control (text, numeric, date/time, radio, droplist). (Overrides BaseScriptControl..::..ControlType.)
Public property | IsReadOnly | If true, agents cannot modify the value of the associated contact attribute. (Inherited from BaseScriptControl.)
Public property | Label | The name of the control. (Inherited from BaseScriptControl.)
Public property | NameValueCollection | The names and values of the drop-down items. Name (key) is the label for the item, value is the value assigned to the contact attribute.

See Also

BaseScriptDropListControl Class


ControlType Property

[image]

IceLib Dialer Technical Reference
BaseScriptDropListControl..::..ControlType Property
BaseScriptDropListControl Class See Also Send Feedback
The type of the control (text, numeric, date/time, radio, droplist).

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override BaseScriptControlType ControlType { get; }
Visual Basic
Public Overrides ReadOnly Property ControlType As BaseScriptControlType
    Get

See Also

BaseScriptDropListControl Class
BaseScriptDropListControl Members


NameValueCollection Property

[image]

IceLib Dialer Technical Reference
BaseScriptDropListControl..::..NameValueCollection Property
BaseScriptDropListControl Class See Also Send Feedback
The names and values of the drop-down items. Name (key) is the label for the item, value is the value assigned to the contact attribute.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public IDictionary<string, string> NameValueCollection { get; set; }
Visual Basic
Public Property NameValueCollection As IDictionary(Of String, String)
    Get
    Set

See Also

BaseScriptDropListControl Class
BaseScriptDropListControl Members


BaseScriptNavLink Class

[image]

IceLib Dialer Technical Reference
BaseScriptNavLink Class
Members See Also Send Feedback
Represents a link on a script page that navigates to another script page.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class BaseScriptNavLink : BaseScriptDispositionBase
Visual Basic
Public Class BaseScriptNavLink _
    Inherits BaseScriptDispositionBase

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..BaseScriptDispositionBase
ININ.IceLib.Configuration.Dialer..::..BaseScriptNavLink

See Also

BaseScriptNavLink Members


BaseScriptNavLink Members

[image] [image]

IceLib Dialer Technical Reference
BaseScriptNavLink Members
BaseScriptNavLink Class Constructors Methods Properties See Also Send Feedback

The BaseScriptNavLink type exposes the following members.

Constructors

 | Name | Description
Public method | BaseScriptNavLink | Initializes a new instance of the BaseScriptNavLink class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Label | The caption on the button or link that activates the disposition. (Inherited from BaseScriptDispositionBase.)
Public property | NavigationPage | The Id of the target script page.

See Also

BaseScriptNavLink Class


BaseScriptNavLink Constructor

[image]

IceLib Dialer Technical Reference
BaseScriptNavLink Constructor
BaseScriptNavLink Class See Also Send Feedback
Initializes a new instance of the BaseScriptNavLink class

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public BaseScriptNavLink()
Visual Basic
Public Sub New

See Also

BaseScriptNavLink Class
BaseScriptNavLink Members


BaseScriptNavLink Methods

[image] [image]

IceLib Dialer Technical Reference
BaseScriptNavLink Methods
BaseScriptNavLink Class See Also Send Feedback

The BaseScriptNavLink type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseScriptNavLink Class


BaseScriptNavLink Properties

[image] [image]

IceLib Dialer Technical Reference
BaseScriptNavLink Properties
BaseScriptNavLink Class See Also Send Feedback

The BaseScriptNavLink type exposes the following members.

Properties

 | Name | Description
Public property | Label | The caption on the button or link that activates the disposition. (Inherited from BaseScriptDispositionBase.)
Public property | NavigationPage | The Id of the target script page.

See Also

BaseScriptNavLink Class


NavigationPage Property

[image]

IceLib Dialer Technical Reference
BaseScriptNavLink..::..NavigationPage Property
BaseScriptNavLink Class See Also Send Feedback
The Id of the target script page.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ConfigurationId NavigationPage { get; set; }
Visual Basic
Public Property NavigationPage As ConfigurationId
    Get
    Set

See Also

BaseScriptNavLink Class
BaseScriptNavLink Members


BaseScriptNumericControl Class

[image]

IceLib Dialer Technical Reference
BaseScriptNumericControl Class
Members See Also Send Feedback
Represents a numeric slider/spinner control on a base script page.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class BaseScriptNumericControl : BaseScriptControl
Visual Basic
Public Class BaseScriptNumericControl _
    Inherits BaseScriptControl

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..BaseScriptControl
ININ.IceLib.Configuration.Dialer..::..BaseScriptNumericControl

See Also

BaseScriptNumericControl Members


BaseScriptNumericControl Members

[image] [image]

IceLib Dialer Technical Reference
BaseScriptNumericControl Members
BaseScriptNumericControl Class Constructors Methods Properties See Also Send Feedback

The BaseScriptNumericControl type exposes the following members.

Constructors

 | Name | Description
Public method | BaseScriptNumericControl | Initializes a new instance of the BaseScriptNumericControl class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ColumnName | The contact attribute that this control is associated with. (Inherited from BaseScriptControl.)
Public property | ControlType | The type of the control (text, numeric, date/time, radio, droplist). (Overrides BaseScriptControl..::..ControlType.)
Public property | IsReadOnly | If true, agents cannot modify the value of the associated contact attribute. (Inherited from BaseScriptControl.)
Public property | Label | The name of the control. (Inherited from BaseScriptControl.)
Public property | MaxValue | The maximum value that may be entered.
Public property | MinValue | The minimum value that may be entered.

See Also

BaseScriptNumericControl Class


BaseScriptNumericControl Constructor

[image]

IceLib Dialer Technical Reference
BaseScriptNumericControl Constructor
BaseScriptNumericControl Class See Also Send Feedback
Initializes a new instance of the BaseScriptNumericControl class

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public BaseScriptNumericControl()
Visual Basic
Public Sub New

See Also

BaseScriptNumericControl Class
BaseScriptNumericControl Members


BaseScriptNumericControl Methods

[image] [image]

IceLib Dialer Technical Reference
BaseScriptNumericControl Methods
BaseScriptNumericControl Class See Also Send Feedback

The BaseScriptNumericControl type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseScriptNumericControl Class


BaseScriptNumericControl Properties

[image] [image]

IceLib Dialer Technical Reference
BaseScriptNumericControl Properties
BaseScriptNumericControl Class See Also Send Feedback

The BaseScriptNumericControl type exposes the following members.

Properties

 | Name | Description
Public property | ColumnName | The contact attribute that this control is associated with. (Inherited from BaseScriptControl.)
Public property | ControlType | The type of the control (text, numeric, date/time, radio, droplist). (Overrides BaseScriptControl..::..ControlType.)
Public property | IsReadOnly | If true, agents cannot modify the value of the associated contact attribute. (Inherited from BaseScriptControl.)
Public property | Label | The name of the control. (Inherited from BaseScriptControl.)
Public property | MaxValue | The maximum value that may be entered.
Public property | MinValue | The minimum value that may be entered.

See Also

BaseScriptNumericControl Class


ControlType Property

[image]

IceLib Dialer Technical Reference
BaseScriptNumericControl..::..ControlType Property
BaseScriptNumericControl Class See Also Send Feedback
The type of the control (text, numeric, date/time, radio, droplist).

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override BaseScriptControlType ControlType { get; }
Visual Basic
Public Overrides ReadOnly Property ControlType As BaseScriptControlType
    Get

See Also

BaseScriptNumericControl Class
BaseScriptNumericControl Members


MaxValue Property

[image]

IceLib Dialer Technical Reference
BaseScriptNumericControl..::..MaxValue Property
BaseScriptNumericControl Class See Also Send Feedback
The maximum value that may be entered.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public double MaxValue { get; set; }
Visual Basic
Public Property MaxValue As Double
    Get
    Set

See Also

BaseScriptNumericControl Class
BaseScriptNumericControl Members


MinValue Property

[image]

IceLib Dialer Technical Reference
BaseScriptNumericControl..::..MinValue Property
BaseScriptNumericControl Class See Also Send Feedback
The minimum value that may be entered.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public double MinValue { get; set; }
Visual Basic
Public Property MinValue As Double
    Get
    Set

See Also

BaseScriptNumericControl Class
BaseScriptNumericControl Members


BaseScriptPageConfiguration Class

[image]

IceLib Dialer Technical Reference
BaseScriptPageConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for a Dialer BaseScriptPage.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class BaseScriptPageConfiguration : EditableListConfigurationObject<BaseScriptPageConfiguration..::..Property>
Visual Basic
Public Class BaseScriptPageConfiguration _
    Inherits EditableListConfigurationObject(Of BaseScriptPageConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ConfigurationObject
ListConfigurationObject
EditableListConfigurationObject<(Of <(<' BaseScriptPageConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..BaseScriptPageConfiguration

See Also

BaseScriptPageConfiguration Members


BaseScriptPageConfiguration Members

[image] [image]

IceLib Dialer Technical Reference
BaseScriptPageConfiguration Members
BaseScriptPageConfiguration Class Methods Properties See Also Send Feedback

The BaseScriptPageConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | Commit | BaseScriptPageConfiguration does not directly support commit. Use the parent BaseScriptConfiguration's Commit()()()() instead. (Overrides EditableListConfigurationObjectCommit()()()().)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptPageConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | ToString | (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | BackgroundColor | The page's background color.
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptPageConfiguration..::..Property >)>)>.)
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | ForegroundColor | The page's foreground color.
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | PageControls | The collection of user interface controls displayed on the page.
Public property | PageDispositions | The collection of dispositions that may be applied to the call. These appear as buttons or links on the page.
Public property | PropertiesChanged | Determines which properties have been modified since the object was last saved.
Public property | RevisionLevel | The version number of this object.
Public property | Stage | The number of the stage corresponding to this script page.
Public property | StaticText | Read-only text appearing on the page, typically used to assist the agent. May contain plain text, macros, and/or HTML tags.

See Also

BaseScriptPageConfiguration Class


BaseScriptPageConfiguration Methods

[image] [image]

IceLib Dialer Technical Reference
BaseScriptPageConfiguration Methods
BaseScriptPageConfiguration Class See Also Send Feedback

The BaseScriptPageConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | Commit | BaseScriptPageConfiguration does not directly support commit. Use the parent BaseScriptConfiguration's Commit()()()() instead. (Overrides EditableListConfigurationObjectCommit()()()().)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptPageConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | ToString | (Inherited from ConfigurationObject.)

See Also

BaseScriptPageConfiguration Class


Commit Method

[image]

IceLib Dialer Technical Reference
BaseScriptPageConfiguration..::..Commit Method
BaseScriptPageConfiguration Class See Also Send Feedback
BaseScriptPageConfiguration does not directly support commit. Use the parent BaseScriptConfiguration's Commit()()()() instead.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override void Commit()
Visual Basic
Public Overrides Sub Commit

Exceptions

Exception | Condition
System..::..NotSupportedException | BaseScriptPageConfiguration does not directly support commit. Use commit on the parent BaseScriptConfiguration instead.

See Also

BaseScriptPageConfiguration Class
BaseScriptPageConfiguration Members


BaseScriptPageConfiguration Properties

[image] [image]

IceLib Dialer Technical Reference
BaseScriptPageConfiguration Properties
BaseScriptPageConfiguration Class See Also Send Feedback

The BaseScriptPageConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | BackgroundColor | The page's background color.
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' BaseScriptPageConfiguration..::..Property >)>)>.)
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | ForegroundColor | The page's foreground color.
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | PageControls | The collection of user interface controls displayed on the page.
Public property | PageDispositions | The collection of dispositions that may be applied to the call. These appear as buttons or links on the page.
Public property | PropertiesChanged | Determines which properties have been modified since the object was last saved.
Public property | RevisionLevel | The version number of this object.
Public property | Stage | The number of the stage corresponding to this script page.
Public property | StaticText | Read-only text appearing on the page, typically used to assist the agent. May contain plain text, macros, and/or HTML tags.

See Also

BaseScriptPageConfiguration Class


BackgroundColor Property

[image]

IceLib Dialer Technical Reference
BaseScriptPageConfiguration..::..BackgroundColor Property
BaseScriptPageConfiguration Class See Also Send Feedback
The page's background color.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<BaseScriptPageConfiguration..::..Property, Color> BackgroundColor { get; }
Visual Basic
Public ReadOnly Property BackgroundColor As GeneralConfigurationProperty(Of BaseScriptPageConfiguration..::..Property, Color)
    Get

See Also

BaseScriptPageConfiguration Class
BaseScriptPageConfiguration Members


ForegroundColor Property

[image]

IceLib Dialer Technical Reference
BaseScriptPageConfiguration..::..ForegroundColor Property
BaseScriptPageConfiguration Class See Also Send Feedback
The page's foreground color.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<BaseScriptPageConfiguration..::..Property, Color> ForegroundColor { get; }
Visual Basic
Public ReadOnly Property ForegroundColor As GeneralConfigurationProperty(Of BaseScriptPageConfiguration..::..Property, Color)
    Get

See Also

BaseScriptPageConfiguration Class
BaseScriptPageConfiguration Members


IsDefaultObject Property

[image]

IceLib Dialer Technical Reference
BaseScriptPageConfiguration..::..IsDefaultObject Property
BaseScriptPageConfiguration Class See Also Send Feedback
Indicates whether this is the default instance of this object type.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsDefaultObject { get; }
Visual Basic
Public ReadOnly Property IsDefaultObject As Boolean
    Get

See Also

BaseScriptPageConfiguration Class
BaseScriptPageConfiguration Members


PageControls Property

[image]

IceLib Dialer Technical Reference
BaseScriptPageConfiguration..::..PageControls Property
BaseScriptPageConfiguration Class See Also Send Feedback
The collection of user interface controls displayed on the page.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<BaseScriptPageConfiguration..::..Property, Collection<BaseScriptControl>> PageControls { get; }
Visual Basic
Public ReadOnly Property PageControls As GeneralConfigurationProperty(Of BaseScriptPageConfiguration..::..Property, Collection(Of BaseScriptControl))
    Get

See Also

BaseScriptPageConfiguration Class
BaseScriptPageConfiguration Members


PageDispositions Property

[image]

IceLib Dialer Technical Reference
BaseScriptPageConfiguration..::..PageDispositions Property
BaseScriptPageConfiguration Class See Also Send Feedback
The collection of dispositions that may be applied to the call. These appear as buttons or links on the page.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<BaseScriptPageConfiguration..::..Property, Collection<BaseScriptDispositionBase>> PageDispositions { get; }
Visual Basic
Public ReadOnly Property PageDispositions As GeneralConfigurationProperty(Of BaseScriptPageConfiguration..::..Property, Collection(Of BaseScriptDispositionBase))
    Get

See Also

BaseScriptPageConfiguration Class
BaseScriptPageConfiguration Members


PropertiesChanged Property

[image]

IceLib Dialer Technical Reference
BaseScriptPageConfiguration..::..PropertiesChanged Property
BaseScriptPageConfiguration Class See Also Send Feedback
Determines which properties have been modified since the object was last saved.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ReadOnlyCollection<BaseScriptPageConfiguration..::..Property> PropertiesChanged { get; }
Visual Basic
Public ReadOnly Property PropertiesChanged As ReadOnlyCollection(Of BaseScriptPageConfiguration..::..Property)
    Get

See Also

BaseScriptPageConfiguration Class
BaseScriptPageConfiguration Members


RevisionLevel Property

[image]

IceLib Dialer Technical Reference
BaseScriptPageConfiguration..::..RevisionLevel Property
BaseScriptPageConfiguration Class See Also Send Feedback
The version number of this object.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<BaseScriptPageConfiguration..::..Property, int> RevisionLevel { get; }
Visual Basic
Public ReadOnly Property RevisionLevel As GeneralConfigurationProperty(Of BaseScriptPageConfiguration..::..Property, Integer)
    Get

See Also

BaseScriptPageConfiguration Class
BaseScriptPageConfiguration Members


Stage Property

[image]

IceLib Dialer Technical Reference
BaseScriptPageConfiguration..::..Stage Property
BaseScriptPageConfiguration Class See Also Send Feedback
The number of the stage corresponding to this script page.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<BaseScriptPageConfiguration..::..Property, int> Stage { get; }
Visual Basic
Public ReadOnly Property Stage As GeneralConfigurationProperty(Of BaseScriptPageConfiguration..::..Property, Integer)
    Get

See Also

BaseScriptPageConfiguration Class
BaseScriptPageConfiguration Members


StaticText Property

[image]

IceLib Dialer Technical Reference
BaseScriptPageConfiguration..::..StaticText Property
BaseScriptPageConfiguration Class See Also Send Feedback
Read-only text appearing on the page, typically used to assist the agent. May contain plain text, macros, and/or HTML tags.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<BaseScriptPageConfiguration..::..Property, string> StaticText { get; }
Visual Basic
Public ReadOnly Property StaticText As GeneralConfigurationProperty(Of BaseScriptPageConfiguration..::..Property, String)
    Get

See Also

BaseScriptPageConfiguration Class
BaseScriptPageConfiguration Members


BaseScriptPageConfiguration.Property Enumeration

[image]

IceLib Dialer Technical Reference
BaseScriptPageConfiguration..::..Property Enumeration
BaseScriptPageConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Id | 0 | Represents the Id part of the ConfigurationId property.
DisplayName | 1 | Represents the DisplayName part of the ConfigurationId property.
RevisionLevel | 2 | Represents the RevisionLevel property.
PageDispositions | 3 | Represents the PageDispositions property.
PageControls | 4 | Represents the PageControls property.
StaticText | 5 | Represents the StaticText property.
Stage | 6 | Represents the Stage property.
ForegroundColor | 7 | Represents the ForegroundColor property.
BackgroundColor | 8 | Represents the BackgroundColor property.

See Also


BaseScriptPageConfigurationList Class

[image]

IceLib Dialer Technical Reference
BaseScriptPageConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing base script page configuration objects.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class BaseScriptPageConfigurationList : EditableConfigurationList<BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property>
Visual Basic
Public Class BaseScriptPageConfigurationList _
    Inherits EditableConfigurationList(Of BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>
DynamicConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>
EditableConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..BaseScriptPageConfigurationList

See Also

BaseScriptPageConfigurationList Members


BaseScriptPageConfigurationList Members

[image] [image]

IceLib Dialer Technical Reference
BaseScriptPageConfigurationList Members
BaseScriptPageConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The BaseScriptPageConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | BaseScriptPageConfigurationList | Initializes a new instance of the BaseScriptPageConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)

See Also

BaseScriptPageConfigurationList Class


BaseScriptPageConfigurationList Constructor

[image]

IceLib Dialer Technical Reference
BaseScriptPageConfigurationList Constructor
BaseScriptPageConfigurationList Class See Also Send Feedback
Initializes a new instance of the BaseScriptPageConfigurationList class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public BaseScriptPageConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

BaseScriptPageConfigurationList Class
BaseScriptPageConfigurationList Members


BaseScriptPageConfigurationList Methods

[image] [image]

IceLib Dialer Technical Reference
BaseScriptPageConfigurationList Methods
BaseScriptPageConfigurationList Class See Also Send Feedback

The BaseScriptPageConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseScriptPageConfigurationList Class


BaseScriptPageConfigurationList Properties

[image] [image]

IceLib Dialer Technical Reference
BaseScriptPageConfigurationList Properties
BaseScriptPageConfigurationList Class See Also Send Feedback

The BaseScriptPageConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)

See Also

BaseScriptPageConfigurationList Class


BaseScriptPageConfigurationList Events

[image] [image]

IceLib Dialer Technical Reference
BaseScriptPageConfigurationList Events
BaseScriptPageConfigurationList Class See Also Send Feedback

The BaseScriptPageConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' BaseScriptPageConfiguration, BaseScriptPageConfiguration..::..Property >)>)>.)

See Also

BaseScriptPageConfigurationList Class


BaseScriptRadioBoxControl Class

[image]

IceLib Dialer Technical Reference
BaseScriptRadioBoxControl Class
Members See Also Send Feedback
Represents a collection of radio buttons on a script page.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class BaseScriptRadioBoxControl : BaseScriptControl
Visual Basic
Public Class BaseScriptRadioBoxControl _
    Inherits BaseScriptControl

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..BaseScriptControl
ININ.IceLib.Configuration.Dialer..::..BaseScriptRadioBoxControl

See Also

BaseScriptRadioBoxControl Members


BaseScriptRadioBoxControl Members

[image] [image]

IceLib Dialer Technical Reference
BaseScriptRadioBoxControl Members
BaseScriptRadioBoxControl Class Constructors Methods Properties See Also Send Feedback

The BaseScriptRadioBoxControl type exposes the following members.

Constructors

 | Name | Description
Public method | BaseScriptRadioBoxControl | Initializes a new instance of the BaseScriptRadioBoxControl class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ColumnName | The contact attribute that this control is associated with. (Inherited from BaseScriptControl.)
Public property | ControlType | The type of the control (text, numeric, date/time, radio, droplist). (Overrides BaseScriptControl..::..ControlType.)
Public property | IsReadOnly | If true, agents cannot modify the value of the associated contact attribute. (Inherited from BaseScriptControl.)
Public property | Label | The name of the control. (Inherited from BaseScriptControl.)
Public property | NameValueCollection | The names and values of the radio buttons. Name (key) is the label for the button, and value is the value assigned to the contact attribute.

See Also

BaseScriptRadioBoxControl Class


BaseScriptRadioBoxControl Constructor

[image]

IceLib Dialer Technical Reference
BaseScriptRadioBoxControl Constructor
BaseScriptRadioBoxControl Class See Also Send Feedback
Initializes a new instance of the BaseScriptRadioBoxControl class

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public BaseScriptRadioBoxControl()
Visual Basic
Public Sub New

See Also

BaseScriptRadioBoxControl Class
BaseScriptRadioBoxControl Members


BaseScriptRadioBoxControl Methods

[image] [image]

IceLib Dialer Technical Reference
BaseScriptRadioBoxControl Methods
BaseScriptRadioBoxControl Class See Also Send Feedback

The BaseScriptRadioBoxControl type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseScriptRadioBoxControl Class


BaseScriptRadioBoxControl Properties

[image] [image]

IceLib Dialer Technical Reference
BaseScriptRadioBoxControl Properties
BaseScriptRadioBoxControl Class See Also Send Feedback

The BaseScriptRadioBoxControl type exposes the following members.

Properties

 | Name | Description
Public property | ColumnName | The contact attribute that this control is associated with. (Inherited from BaseScriptControl.)
Public property | ControlType | The type of the control (text, numeric, date/time, radio, droplist). (Overrides BaseScriptControl..::..ControlType.)
Public property | IsReadOnly | If true, agents cannot modify the value of the associated contact attribute. (Inherited from BaseScriptControl.)
Public property | Label | The name of the control. (Inherited from BaseScriptControl.)
Public property | NameValueCollection | The names and values of the radio buttons. Name (key) is the label for the button, and value is the value assigned to the contact attribute.

See Also

BaseScriptRadioBoxControl Class


ControlType Property

[image]

IceLib Dialer Technical Reference
BaseScriptRadioBoxControl..::..ControlType Property
BaseScriptRadioBoxControl Class See Also Send Feedback
The type of the control (text, numeric, date/time, radio, droplist).

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override BaseScriptControlType ControlType { get; }
Visual Basic
Public Overrides ReadOnly Property ControlType As BaseScriptControlType
    Get

See Also

BaseScriptRadioBoxControl Class
BaseScriptRadioBoxControl Members


NameValueCollection Property

[image]

IceLib Dialer Technical Reference
BaseScriptRadioBoxControl..::..NameValueCollection Property
BaseScriptRadioBoxControl Class See Also Send Feedback
The names and values of the radio buttons. Name (key) is the label for the button, and value is the value assigned to the contact attribute.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public IDictionary<string, string> NameValueCollection { get; set; }
Visual Basic
Public Property NameValueCollection As IDictionary(Of String, String)
    Get
    Set

See Also

BaseScriptRadioBoxControl Class
BaseScriptRadioBoxControl Members


BaseScriptTextControl Class

[image]

IceLib Dialer Technical Reference
BaseScriptTextControl Class
Members See Also Send Feedback
Represents a text box control on a base script page.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class BaseScriptTextControl : BaseScriptControl
Visual Basic
Public Class BaseScriptTextControl _
    Inherits BaseScriptControl

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..BaseScriptControl
ININ.IceLib.Configuration.Dialer..::..BaseScriptTextControl

See Also

BaseScriptTextControl Members


BaseScriptTextControl Members

[image] [image]

IceLib Dialer Technical Reference
BaseScriptTextControl Members
BaseScriptTextControl Class Constructors Methods Properties See Also Send Feedback

The BaseScriptTextControl type exposes the following members.

Constructors

 | Name | Description
Public method | BaseScriptTextControl | Creates a new instance of the BaseScriptTextControl class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ColumnName | The contact attribute that this control is associated with. (Inherited from BaseScriptControl.)
Public property | ControlType | The type of the control (text, numeric, date/time, radio, droplist). (Overrides BaseScriptControl..::..ControlType.)
Public property | IsReadOnly | If true, agents cannot modify the value of the associated contact attribute. (Inherited from BaseScriptControl.)
Public property | Label | The name of the control. (Inherited from BaseScriptControl.)
Public property | Lines | The maximum number of lines that can be entered into this text control.
Public property | MaxChars | The maximum number of characters that can be entered into this text control.

See Also

BaseScriptTextControl Class


BaseScriptTextControl Constructor

[image]

IceLib Dialer Technical Reference
BaseScriptTextControl Constructor
BaseScriptTextControl Class See Also Send Feedback
Creates a new instance of the BaseScriptTextControl class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public BaseScriptTextControl()
Visual Basic
Public Sub New

See Also

BaseScriptTextControl Class
BaseScriptTextControl Members


BaseScriptTextControl Methods

[image] [image]

IceLib Dialer Technical Reference
BaseScriptTextControl Methods
BaseScriptTextControl Class See Also Send Feedback

The BaseScriptTextControl type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseScriptTextControl Class


BaseScriptTextControl Properties

[image] [image]

IceLib Dialer Technical Reference
BaseScriptTextControl Properties
BaseScriptTextControl Class See Also Send Feedback

The BaseScriptTextControl type exposes the following members.

Properties

 | Name | Description
Public property | ColumnName | The contact attribute that this control is associated with. (Inherited from BaseScriptControl.)
Public property | ControlType | The type of the control (text, numeric, date/time, radio, droplist). (Overrides BaseScriptControl..::..ControlType.)
Public property | IsReadOnly | If true, agents cannot modify the value of the associated contact attribute. (Inherited from BaseScriptControl.)
Public property | Label | The name of the control. (Inherited from BaseScriptControl.)
Public property | Lines | The maximum number of lines that can be entered into this text control.
Public property | MaxChars | The maximum number of characters that can be entered into this text control.

See Also

BaseScriptTextControl Class


ControlType Property

[image]

IceLib Dialer Technical Reference
BaseScriptTextControl..::..ControlType Property
BaseScriptTextControl Class See Also Send Feedback
The type of the control (text, numeric, date/time, radio, droplist).

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override BaseScriptControlType ControlType { get; }
Visual Basic
Public Overrides ReadOnly Property ControlType As BaseScriptControlType
    Get

See Also

BaseScriptTextControl Class
BaseScriptTextControl Members


Lines Property

[image]

IceLib Dialer Technical Reference
BaseScriptTextControl..::..Lines Property
BaseScriptTextControl Class See Also Send Feedback
The maximum number of lines that can be entered into this text control.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int Lines { get; set; }
Visual Basic
Public Property Lines As Integer
    Get
    Set

Remarks

The default value is 5.

See Also

BaseScriptTextControl Class
BaseScriptTextControl Members


MaxChars Property

[image]

IceLib Dialer Technical Reference
BaseScriptTextControl..::..MaxChars Property
BaseScriptTextControl Class See Also Send Feedback
The maximum number of characters that can be entered into this text control.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int MaxChars { get; set; }
Visual Basic
Public Property MaxChars As Integer
    Get
    Set

Remarks

The default value is 1024.

See Also

BaseScriptTextControl Class
BaseScriptTextControl Members


BinaryExpression Class

[image]

IceLib Dialer Technical Reference
BinaryExpression Class
Members See Also Send Feedback
An expression representing a binary logical or arithmetic operation.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class BinaryExpression : IInternalExpression,
    IExpression, ICloneable
Visual Basic
Public Class BinaryExpression _
    Implements IInternalExpression, IExpression, ICloneable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..BinaryExpression

See Also

BinaryExpression Members


BinaryExpression Members

[image] [image]

IceLib Dialer Technical Reference
BinaryExpression Members
BinaryExpression Class Constructors Methods Properties See Also Send Feedback

The BinaryExpression type exposes the following members.

Constructors

 | Name | Description
Public method | BinaryExpression()()()() | Creates a new empty binary expression.
Public method | BinaryExpression(IExpression, IExpression, BinaryOperationType) | Creates a new binary expression.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Left | The expression on the left side of the operation.
Public property | Negate | A flag indicating whether this expression should be set to its logical opposite.
Public property | Operation | The binary operation type.
Public property | Right | The expression on the right side of the operation.

See Also

BinaryExpression Class


BinaryExpression Constructor

[image] [image]

IceLib Dialer Technical Reference
BinaryExpression Constructor
BinaryExpression Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BinaryExpression()()()() | Creates a new empty binary expression.
Public method | BinaryExpression(IExpression, IExpression, BinaryOperationType) | Creates a new binary expression.

See Also

BinaryExpression Class
BinaryExpression Members


BinaryExpression Constructor

[image]

IceLib Dialer Technical Reference
BinaryExpression Constructor
BinaryExpression Class See Also Send Feedback
Creates a new empty binary expression.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public BinaryExpression()
Visual Basic
Public Sub New

See Also

BinaryExpression Class
BinaryExpression Members
BinaryExpression Overload


BinaryExpression Constructor (IExpression, IExpression, BinaryOperationType)

[image]

IceLib Dialer Technical Reference
BinaryExpression Constructor (IExpression, IExpression, BinaryOperationType)
BinaryExpression Class See Also Send Feedback
Creates a new binary expression.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public BinaryExpression(
    IExpression left,
    IExpression right,
    BinaryOperationType op
)
Visual Basic
Public Sub New ( _
    left As IExpression, _
    right As IExpression, _
    op As BinaryOperationType _
)

Parameters

left
Type: ININ.IceLib.Configuration.Dialer..::..IExpression
The expression appearing to the left of the operation.
right
Type: ININ.IceLib.Configuration.Dialer..::..IExpression
The expression appearing to the right of the operation.
op
Type: ININ.IceLib.Configuration.Dialer..::..BinaryOperationType
The operation to perform.

See Also

BinaryExpression Class
BinaryExpression Members
BinaryExpression Overload


BinaryExpression Methods

[image] [image]

IceLib Dialer Technical Reference
BinaryExpression Methods
BinaryExpression Class See Also Send Feedback

The BinaryExpression type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

BinaryExpression Class


Clone Method

[image]

IceLib Dialer Technical Reference
BinaryExpression..::..Clone Method
BinaryExpression Class See Also Send Feedback
Creates a new object that is a copy of the current instance.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

A new object that is a copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

BinaryExpression Class
BinaryExpression Members


ToString Method

[image]

IceLib Dialer Technical Reference
BinaryExpression..::..ToString Method
BinaryExpression Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

See Also

BinaryExpression Class
BinaryExpression Members


BinaryExpression Properties

[image] [image]

IceLib Dialer Technical Reference
BinaryExpression Properties
BinaryExpression Class See Also Send Feedback

The BinaryExpression type exposes the following members.

Properties

 | Name | Description
Public property | Left | The expression on the left side of the operation.
Public property | Negate | A flag indicating whether this expression should be set to its logical opposite.
Public property | Operation | The binary operation type.
Public property | Right | The expression on the right side of the operation.

See Also

BinaryExpression Class


Left Property

[image]

IceLib Dialer Technical Reference
BinaryExpression..::..Left Property
BinaryExpression Class See Also Send Feedback
The expression on the left side of the operation.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public IExpression Left { get; set; }
Visual Basic
Public Property Left As IExpression
    Get
    Set

See Also

BinaryExpression Class
BinaryExpression Members


Negate Property

[image]

IceLib Dialer Technical Reference
BinaryExpression..::..Negate Property
BinaryExpression Class See Also Send Feedback
A flag indicating whether this expression should be set to its logical opposite.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool Negate { get; set; }
Visual Basic
Public Property Negate As Boolean
    Get
    Set

See Also

BinaryExpression Class
BinaryExpression Members


Operation Property

[image]

IceLib Dialer Technical Reference
BinaryExpression..::..Operation Property
BinaryExpression Class See Also Send Feedback
The binary operation type.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public BinaryOperationType Operation { get; set; }
Visual Basic
Public Property Operation As BinaryOperationType
    Get
    Set

See Also

BinaryExpression Class
BinaryExpression Members


Right Property

[image]

IceLib Dialer Technical Reference
BinaryExpression..::..Right Property
BinaryExpression Class See Also Send Feedback
The expression on the right side of the operation.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public IExpression Right { get; set; }
Visual Basic
Public Property Right As IExpression
    Get
    Set

See Also

BinaryExpression Class
BinaryExpression Members


BinaryOperationType Enumeration

[image]

IceLib Dialer Technical Reference
BinaryOperationType Enumeration
See Also Send Feedback
Binary operators that can be applied to expressions.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum BinaryOperationType
Visual Basic
Public Enumeration BinaryOperationType

Members

Member name | Value | Description
Unknown | 0 | No operation specified.
Add | 1 | Addition (+)
And | 2 | Short-circuit conditional AND (&&)
Divide | 3 | Division (/)
Equal | 4 | Equality comparison (==)
GreaterThan | 5 | Numeric comparison (>)
GreaterThanOrEqual | 6 | Numeric comparison (>=)
LessThan | 7 | Numeric comparison (<)
LessThanOrEqual | 8 | Numeric comparison (<=)
Like | 9 | String pattern search (LIKE)
Modulo | 10 | Arithmetic remainder operation (%)
Multiply | 11 | Multiplication (*)
NotEqual | 12 | Inequality comparison (!=)
Or | 13 | Short-circuit conditional OR (||)
Subtract | 14 | Subtraction (-)

See Also


CallAnalysisBehavior Class

[image]

IceLib Dialer Technical Reference
CallAnalysisBehavior Class
Members See Also Send Feedback
A PolicyBehavior which can configure call analysis on a per-call basis.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class CallAnalysisBehavior : PolicyBehavior
Visual Basic
Public NotInheritable Class CallAnalysisBehavior _
    Inherits PolicyBehavior

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyBehavior
ININ.IceLib.Configuration.Dialer..::..CallAnalysisBehavior

See Also

CallAnalysisBehavior Members


CallAnalysisBehavior Members

[image] [image]

IceLib Dialer Technical Reference
CallAnalysisBehavior Members
CallAnalysisBehavior Class Constructors Methods Properties See Also Send Feedback

The CallAnalysisBehavior type exposes the following members.

Constructors

 | Name | Description
Public method | CallAnalysisBehavior | Initializes a new instance of the CallAnalysisBehavior class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | DetectAnsweringMachines | Get or set whether to perform answering machine detection for this call.
Public property | Id | (Inherited from PolicyBehavior.)
Public property | NoAnswerTimeoutSeconds | Get or set the number of seconds to wait for an answer before timing out.
Public property | PerformCallAnalysis | Get or set whether to perform any call analysis on this call.

See Also

CallAnalysisBehavior Class


CallAnalysisBehavior Constructor

[image]

IceLib Dialer Technical Reference
CallAnalysisBehavior Constructor
CallAnalysisBehavior Class See Also Send Feedback
Initializes a new instance of the CallAnalysisBehavior class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CallAnalysisBehavior()
Visual Basic
Public Sub New

See Also

CallAnalysisBehavior Class
CallAnalysisBehavior Members


CallAnalysisBehavior Methods

[image] [image]

IceLib Dialer Technical Reference
CallAnalysisBehavior Methods
CallAnalysisBehavior Class See Also Send Feedback

The CallAnalysisBehavior type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CallAnalysisBehavior Class


CallAnalysisBehavior Properties

[image] [image]

IceLib Dialer Technical Reference
CallAnalysisBehavior Properties
CallAnalysisBehavior Class See Also Send Feedback

The CallAnalysisBehavior type exposes the following members.

Properties

 | Name | Description
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | DetectAnsweringMachines | Get or set whether to perform answering machine detection for this call.
Public property | Id | (Inherited from PolicyBehavior.)
Public property | NoAnswerTimeoutSeconds | Get or set the number of seconds to wait for an answer before timing out.
Public property | PerformCallAnalysis | Get or set whether to perform any call analysis on this call.

See Also

CallAnalysisBehavior Class


DetectAnsweringMachines Property

[image]

IceLib Dialer Technical Reference
CallAnalysisBehavior..::..DetectAnsweringMachines Property
CallAnalysisBehavior Class See Also Send Feedback
Get or set whether to perform answering machine detection for this call.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool DetectAnsweringMachines { get; set; }
Visual Basic
Public Property DetectAnsweringMachines As Boolean
    Get
    Set

See Also

CallAnalysisBehavior Class
CallAnalysisBehavior Members


NoAnswerTimeoutSeconds Property

[image]

IceLib Dialer Technical Reference
CallAnalysisBehavior..::..NoAnswerTimeoutSeconds Property
CallAnalysisBehavior Class See Also Send Feedback
Get or set the number of seconds to wait for an answer before timing out.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int NoAnswerTimeoutSeconds { get; set; }
Visual Basic
Public Property NoAnswerTimeoutSeconds As Integer
    Get
    Set

See Also

CallAnalysisBehavior Class
CallAnalysisBehavior Members


PerformCallAnalysis Property

[image]

IceLib Dialer Technical Reference
CallAnalysisBehavior..::..PerformCallAnalysis Property
CallAnalysisBehavior Class See Also Send Feedback
Get or set whether to perform any call analysis on this call.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool PerformCallAnalysis { get; set; }
Visual Basic
Public Property PerformCallAnalysis As Boolean
    Get
    Set

See Also

CallAnalysisBehavior Class
CallAnalysisBehavior Members


CallAnalysisCondition Class

[image]

IceLib Dialer Technical Reference
CallAnalysisCondition Class
Members See Also Send Feedback
A policy condition that check if the result of call analysis is contained within a desired subset of results.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class CallAnalysisCondition : PolicyCondition
Visual Basic
Public NotInheritable Class CallAnalysisCondition _
    Inherits PolicyCondition

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyCondition
ININ.IceLib.Configuration.Dialer..::..CallAnalysisCondition

See Also

CallAnalysisCondition Members


CallAnalysisCondition Members

[image] [image]

IceLib Dialer Technical Reference
CallAnalysisCondition Members
CallAnalysisCondition Class Constructors Methods Properties See Also Send Feedback

The CallAnalysisCondition type exposes the following members.

Constructors

 | Name | Description
Public method | CallAnalysisCondition | Creates a new instance of the CallAnalysisCondition

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CallAnalysisResults | The desired subset of call analysis results.
Public property | ConditionType | The type of condition. (Inherited from PolicyCondition.)
Public property | Id | The Id of the condition. (Inherited from PolicyCondition.)
Public property | Negated | When true, the logical result of the condition evaluation is flipped. (Inherited from PolicyCondition.)

See Also

CallAnalysisCondition Class


CallAnalysisCondition Constructor

[image]

IceLib Dialer Technical Reference
CallAnalysisCondition Constructor
CallAnalysisCondition Class See Also Send Feedback
Creates a new instance of the CallAnalysisCondition

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CallAnalysisCondition()
Visual Basic
Public Sub New

See Also

CallAnalysisCondition Class
CallAnalysisCondition Members


CallAnalysisCondition Methods

[image] [image]

IceLib Dialer Technical Reference
CallAnalysisCondition Methods
CallAnalysisCondition Class See Also Send Feedback

The CallAnalysisCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CallAnalysisCondition Class


CallAnalysisCondition Properties

[image] [image]

IceLib Dialer Technical Reference
CallAnalysisCondition Properties
CallAnalysisCondition Class See Also Send Feedback

The CallAnalysisCondition type exposes the following members.

Properties

 | Name | Description
Public property | CallAnalysisResults | The desired subset of call analysis results.
Public property | ConditionType | The type of condition. (Inherited from PolicyCondition.)
Public property | Id | The Id of the condition. (Inherited from PolicyCondition.)
Public property | Negated | When true, the logical result of the condition evaluation is flipped. (Inherited from PolicyCondition.)

See Also

CallAnalysisCondition Class


CallAnalysisResults Property

[image]

IceLib Dialer Technical Reference
CallAnalysisCondition..::..CallAnalysisResults Property
CallAnalysisCondition Class See Also Send Feedback
The desired subset of call analysis results.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<CallAnalysisResult> CallAnalysisResults { get; }
Visual Basic
Public ReadOnly Property CallAnalysisResults As Collection(Of CallAnalysisResult)
    Get

See Also

CallAnalysisCondition Class
CallAnalysisCondition Members


CallAttributeBehavior Class

[image]

IceLib Dialer Technical Reference
CallAttributeBehavior Class
Members See Also Send Feedback
A PolicyBehavior which sets a call attribute for the call.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class CallAttributeBehavior : PolicyBehavior
Visual Basic
Public NotInheritable Class CallAttributeBehavior _
    Inherits PolicyBehavior

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyBehavior
ININ.IceLib.Configuration.Dialer..::..CallAttributeBehavior

See Also

CallAttributeBehavior Members


CallAttributeBehavior Members

[image] [image]

IceLib Dialer Technical Reference
CallAttributeBehavior Members
CallAttributeBehavior Class Constructors Methods Properties See Also Send Feedback

The CallAttributeBehavior type exposes the following members.

Constructors

 | Name | Description
Public method | CallAttributeBehavior | Initializes a new instance of the CallAttributeBehavior class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | CallAttributeName | Get or set the name of the call attribute.
Public property | CallAttributeValue | Get or set the new value which will be assigned to the call attribute.
Public property | Id | (Inherited from PolicyBehavior.)

See Also

CallAttributeBehavior Class


CallAttributeBehavior Constructor

[image]

IceLib Dialer Technical Reference
CallAttributeBehavior Constructor
CallAttributeBehavior Class See Also Send Feedback
Initializes a new instance of the CallAttributeBehavior class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CallAttributeBehavior()
Visual Basic
Public Sub New

See Also

CallAttributeBehavior Class
CallAttributeBehavior Members


CallAttributeBehavior Methods

[image] [image]

IceLib Dialer Technical Reference
CallAttributeBehavior Methods
CallAttributeBehavior Class See Also Send Feedback

The CallAttributeBehavior type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CallAttributeBehavior Class


CallAttributeBehavior Properties

[image] [image]

IceLib Dialer Technical Reference
CallAttributeBehavior Properties
CallAttributeBehavior Class See Also Send Feedback

The CallAttributeBehavior type exposes the following members.

Properties

 | Name | Description
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | CallAttributeName | Get or set the name of the call attribute.
Public property | CallAttributeValue | Get or set the new value which will be assigned to the call attribute.
Public property | Id | (Inherited from PolicyBehavior.)

See Also

CallAttributeBehavior Class


CallAttributeName Property

[image]

IceLib Dialer Technical Reference
CallAttributeBehavior..::..CallAttributeName Property
CallAttributeBehavior Class See Also Send Feedback
Get or set the name of the call attribute.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string CallAttributeName { get; set; }
Visual Basic
Public Property CallAttributeName As String
    Get
    Set

See Also

CallAttributeBehavior Class
CallAttributeBehavior Members


CallAttributeValue Property

[image]

IceLib Dialer Technical Reference
CallAttributeBehavior..::..CallAttributeValue Property
CallAttributeBehavior Class See Also Send Feedback
Get or set the new value which will be assigned to the call attribute.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string CallAttributeValue { get; set; }
Visual Basic
Public Property CallAttributeValue As String
    Get
    Set

See Also

CallAttributeBehavior Class
CallAttributeBehavior Members


CallAttributeCondition Class

[image]

IceLib Dialer Technical Reference
CallAttributeCondition Class
Members See Also Send Feedback
A policy condition that checks if a call attribute matches a certain value.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class CallAttributeCondition : PolicyCondition
Visual Basic
Public NotInheritable Class CallAttributeCondition _
    Inherits PolicyCondition

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyCondition
ININ.IceLib.Configuration.Dialer..::..CallAttributeCondition

See Also

CallAttributeCondition Members


CallAttributeCondition Members

[image] [image]

IceLib Dialer Technical Reference
CallAttributeCondition Members
CallAttributeCondition Class Constructors Methods Properties See Also Send Feedback

The CallAttributeCondition type exposes the following members.

Constructors

 | Name | Description
Public method | CallAttributeCondition | Creates a new instance of the CallAttributeCondition class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CallAttributeName | The name of the call attribute to be checked.
Public property | CallAttributeType | The datatype of the call attribute.
Public property | ConditionType | The type of condition. (Inherited from PolicyCondition.)
Public property | DateValue | The matching value for a date-based attribute.
Public property | Id | The Id of the condition. (Inherited from PolicyCondition.)
Public property | Negated | When true, the logical result of the condition evaluation is flipped. (Inherited from PolicyCondition.)
Public property | NumericValue | The matching value for a numeric attribute.
Public property | Operation | An conditional operator that compares the attribute value to the matching value.
Public property | StringValue | The matching value for a text attribute.
Public property | TimeValue | The matching value for a time-based attribute.

See Also

CallAttributeCondition Class


CallAttributeCondition Constructor

[image]

IceLib Dialer Technical Reference
CallAttributeCondition Constructor
CallAttributeCondition Class See Also Send Feedback
Creates a new instance of the CallAttributeCondition class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CallAttributeCondition()
Visual Basic
Public Sub New

See Also

CallAttributeCondition Class
CallAttributeCondition Members


CallAttributeCondition Methods

[image] [image]

IceLib Dialer Technical Reference
CallAttributeCondition Methods
CallAttributeCondition Class See Also Send Feedback

The CallAttributeCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CallAttributeCondition Class


CallAttributeCondition Properties

[image] [image]

IceLib Dialer Technical Reference
CallAttributeCondition Properties
CallAttributeCondition Class See Also Send Feedback

The CallAttributeCondition type exposes the following members.

Properties

 | Name | Description
Public property | CallAttributeName | The name of the call attribute to be checked.
Public property | CallAttributeType | The datatype of the call attribute.
Public property | ConditionType | The type of condition. (Inherited from PolicyCondition.)
Public property | DateValue | The matching value for a date-based attribute.
Public property | Id | The Id of the condition. (Inherited from PolicyCondition.)
Public property | Negated | When true, the logical result of the condition evaluation is flipped. (Inherited from PolicyCondition.)
Public property | NumericValue | The matching value for a numeric attribute.
Public property | Operation | An conditional operator that compares the attribute value to the matching value.
Public property | StringValue | The matching value for a text attribute.
Public property | TimeValue | The matching value for a time-based attribute.

See Also

CallAttributeCondition Class


CallAttributeName Property

[image]

IceLib Dialer Technical Reference
CallAttributeCondition..::..CallAttributeName Property
CallAttributeCondition Class See Also Send Feedback
The name of the call attribute to be checked.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string CallAttributeName { get; set; }
Visual Basic
Public Property CallAttributeName As String
    Get
    Set

See Also

CallAttributeCondition Class
CallAttributeCondition Members


CallAttributeType Property

[image]

IceLib Dialer Technical Reference
CallAttributeCondition..::..CallAttributeType Property
CallAttributeCondition Class See Also Send Feedback
The datatype of the call attribute.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CallAttributeType CallAttributeType { get; set; }
Visual Basic
Public Property CallAttributeType As CallAttributeType
    Get
    Set

See Also

CallAttributeCondition Class
CallAttributeCondition Members


DateValue Property

[image]

IceLib Dialer Technical Reference
CallAttributeCondition..::..DateValue Property
CallAttributeCondition Class See Also Send Feedback
The matching value for a date-based attribute.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DateTime DateValue { get; set; }
Visual Basic
Public Property DateValue As DateTime
    Get
    Set

See Also

CallAttributeCondition Class
CallAttributeCondition Members


NumericValue Property

[image]

IceLib Dialer Technical Reference
CallAttributeCondition..::..NumericValue Property
CallAttributeCondition Class See Also Send Feedback
The matching value for a numeric attribute.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public double NumericValue { get; set; }
Visual Basic
Public Property NumericValue As Double
    Get
    Set

See Also

CallAttributeCondition Class
CallAttributeCondition Members


Operation Property

[image]

IceLib Dialer Technical Reference
CallAttributeCondition..::..Operation Property
CallAttributeCondition Class See Also Send Feedback
An conditional operator that compares the attribute value to the matching value.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ComparisonOperator Operation { get; set; }
Visual Basic
Public Property Operation As ComparisonOperator
    Get
    Set

See Also

CallAttributeCondition Class
CallAttributeCondition Members


StringValue Property

[image]

IceLib Dialer Technical Reference
CallAttributeCondition..::..StringValue Property
CallAttributeCondition Class See Also Send Feedback
The matching value for a text attribute.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string StringValue { get; set; }
Visual Basic
Public Property StringValue As String
    Get
    Set

See Also

CallAttributeCondition Class
CallAttributeCondition Members


TimeValue Property

[image]

IceLib Dialer Technical Reference
CallAttributeCondition..::..TimeValue Property
CallAttributeCondition Class See Also Send Feedback
The matching value for a time-based attribute.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DateTime TimeValue { get; set; }
Visual Basic
Public Property TimeValue As DateTime
    Get
    Set

See Also

CallAttributeCondition Class
CallAttributeCondition Members


CallbackBehavior Class

[image]

IceLib Dialer Technical Reference
CallbackBehavior Class
Members See Also Send Feedback
A PolicyBehavior which schedules a return call.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class CallbackBehavior : PolicyBehavior
Visual Basic
Public NotInheritable Class CallbackBehavior _
    Inherits PolicyBehavior

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyBehavior
ININ.IceLib.Configuration.Dialer..::..CallbackBehavior

See Also

CallbackBehavior Members


CallbackBehavior Members

[image] [image]

IceLib Dialer Technical Reference
CallbackBehavior Members
CallbackBehavior Class Constructors Methods Properties See Also Send Feedback

The CallbackBehavior type exposes the following members.

Constructors

 | Name | Description
Public method | CallbackBehavior | Initializes a new instance of the CallbackBehavior class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | CallbackDate | Get or set a fixed date on which to call the contact back.
Public property | CallbackTime | Get or set a fixed time at which to call the contact back.
Public property | DateMode | Get or set whether to use the relative or fixed Callback date.
Public property | Id | (Inherited from PolicyBehavior.)
Public property | OffsetDays | Get or set how many days in the future to call the contact back.
Public property | OffsetTime | Get or set a relative time at which to call the contact back.
Public property | TimeMode | Get or set whether to use the relative or fixed Callback time.

See Also

CallbackBehavior Class


CallbackBehavior Constructor

[image]

IceLib Dialer Technical Reference
CallbackBehavior Constructor
CallbackBehavior Class See Also Send Feedback
Initializes a new instance of the CallbackBehavior class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CallbackBehavior()
Visual Basic
Public Sub New

See Also

CallbackBehavior Class
CallbackBehavior Members


CallbackBehavior Methods

[image] [image]

IceLib Dialer Technical Reference
CallbackBehavior Methods
CallbackBehavior Class See Also Send Feedback

The CallbackBehavior type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CallbackBehavior Class


CallbackBehavior Properties

[image] [image]

IceLib Dialer Technical Reference
CallbackBehavior Properties
CallbackBehavior Class See Also Send Feedback

The CallbackBehavior type exposes the following members.

Properties

 | Name | Description
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | CallbackDate | Get or set a fixed date on which to call the contact back.
Public property | CallbackTime | Get or set a fixed time at which to call the contact back.
Public property | DateMode | Get or set whether to use the relative or fixed Callback date.
Public property | Id | (Inherited from PolicyBehavior.)
Public property | OffsetDays | Get or set how many days in the future to call the contact back.
Public property | OffsetTime | Get or set a relative time at which to call the contact back.
Public property | TimeMode | Get or set whether to use the relative or fixed Callback time.

See Also

CallbackBehavior Class


CallbackDate Property

[image]

IceLib Dialer Technical Reference
CallbackBehavior..::..CallbackDate Property
CallbackBehavior Class See Also Send Feedback
Get or set a fixed date on which to call the contact back.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DateTime CallbackDate { get; set; }
Visual Basic
Public Property CallbackDate As DateTime
    Get
    Set

See Also

CallbackBehavior Class
CallbackBehavior Members


CallbackTime Property

[image]

IceLib Dialer Technical Reference
CallbackBehavior..::..CallbackTime Property
CallbackBehavior Class See Also Send Feedback
Get or set a fixed time at which to call the contact back.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DateTime CallbackTime { get; set; }
Visual Basic
Public Property CallbackTime As DateTime
    Get
    Set

See Also

CallbackBehavior Class
CallbackBehavior Members


DateMode Property

[image]

IceLib Dialer Technical Reference
CallbackBehavior..::..DateMode Property
CallbackBehavior Class See Also Send Feedback
Get or set whether to use the relative or fixed Callback date.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CallbackTimeMode DateMode { get; set; }
Visual Basic
Public Property DateMode As CallbackTimeMode
    Get
    Set

See Also

CallbackBehavior Class
CallbackBehavior Members


OffsetDays Property

[image]

IceLib Dialer Technical Reference
CallbackBehavior..::..OffsetDays Property
CallbackBehavior Class See Also Send Feedback
Get or set how many days in the future to call the contact back.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int OffsetDays { get; set; }
Visual Basic
Public Property OffsetDays As Integer
    Get
    Set

See Also

CallbackBehavior Class
CallbackBehavior Members


OffsetTime Property

[image]

IceLib Dialer Technical Reference
CallbackBehavior..::..OffsetTime Property
CallbackBehavior Class See Also Send Feedback
Get or set a relative time at which to call the contact back.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public TimeSpan OffsetTime { get; set; }
Visual Basic
Public Property OffsetTime As TimeSpan
    Get
    Set

See Also

CallbackBehavior Class
CallbackBehavior Members


TimeMode Property

[image]

IceLib Dialer Technical Reference
CallbackBehavior..::..TimeMode Property
CallbackBehavior Class See Also Send Feedback
Get or set whether to use the relative or fixed Callback time.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CallbackTimeMode TimeMode { get; set; }
Visual Basic
Public Property TimeMode As CallbackTimeMode
    Get
    Set

See Also

CallbackBehavior Class
CallbackBehavior Members


CallCategoryCondition Class

[image]

IceLib Dialer Technical Reference
CallCategoryCondition Class
Members See Also Send Feedback
A policy condition that checks if the call category is contained within a desired subset of categories.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class CallCategoryCondition : PolicyCondition
Visual Basic
Public NotInheritable Class CallCategoryCondition _
    Inherits PolicyCondition

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyCondition
ININ.IceLib.Configuration.Dialer..::..CallCategoryCondition

See Also

CallCategoryCondition Members


CallCategoryCondition Members

[image] [image]

IceLib Dialer Technical Reference
CallCategoryCondition Members
CallCategoryCondition Class Constructors Methods Properties See Also Send Feedback

The CallCategoryCondition type exposes the following members.

Constructors

 | Name | Description
Public method | CallCategoryCondition | Creates a new instance of the CallCategoryCondition class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Categories | The desired subset of call categories.
Public property | ConditionType | The type of condition. (Inherited from PolicyCondition.)
Public property | Id | The Id of the condition. (Inherited from PolicyCondition.)
Public property | Negated | When true, the logical result of the condition evaluation is flipped. (Inherited from PolicyCondition.)

See Also

CallCategoryCondition Class


CallCategoryCondition Constructor

[image]

IceLib Dialer Technical Reference
CallCategoryCondition Constructor
CallCategoryCondition Class See Also Send Feedback
Creates a new instance of the CallCategoryCondition class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CallCategoryCondition()
Visual Basic
Public Sub New

See Also

CallCategoryCondition Class
CallCategoryCondition Members


CallCategoryCondition Methods

[image] [image]

IceLib Dialer Technical Reference
CallCategoryCondition Methods
CallCategoryCondition Class See Also Send Feedback

The CallCategoryCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CallCategoryCondition Class


CallCategoryCondition Properties

[image] [image]

IceLib Dialer Technical Reference
CallCategoryCondition Properties
CallCategoryCondition Class See Also Send Feedback

The CallCategoryCondition type exposes the following members.

Properties

 | Name | Description
Public property | Categories | The desired subset of call categories.
Public property | ConditionType | The type of condition. (Inherited from PolicyCondition.)
Public property | Id | The Id of the condition. (Inherited from PolicyCondition.)
Public property | Negated | When true, the logical result of the condition evaluation is flipped. (Inherited from PolicyCondition.)

See Also

CallCategoryCondition Class


Categories Property

[image]

IceLib Dialer Technical Reference
CallCategoryCondition..::..Categories Property
CallCategoryCondition Class See Also Send Feedback
The desired subset of call categories.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<CallCategory> Categories { get; }
Visual Basic
Public ReadOnly Property Categories As Collection(Of CallCategory)
    Get

See Also

CallCategoryCondition Class
CallCategoryCondition Members


CallDialingModeCondition Class

[image]

IceLib Dialer Technical Reference
CallDialingModeCondition Class
Members See Also Send Feedback
A policy condition that checks if the call's dialing mode is contained within a desired subset of modes.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class CallDialingModeCondition : PolicyCondition
Visual Basic
Public NotInheritable Class CallDialingModeCondition _
    Inherits PolicyCondition

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyCondition
ININ.IceLib.Configuration.Dialer..::..CallDialingModeCondition

See Also

CallDialingModeCondition Members


CallDialingModeCondition Members

[image] [image]

IceLib Dialer Technical Reference
CallDialingModeCondition Members
CallDialingModeCondition Class Constructors Methods Properties See Also Send Feedback

The CallDialingModeCondition type exposes the following members.

Constructors

 | Name | Description
Public method | CallDialingModeCondition | Creates a new instance of the CallDialingModeCondition class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConditionType | The type of condition. (Inherited from PolicyCondition.)
Public property | Id | The Id of the condition. (Inherited from PolicyCondition.)
Public property | Modes | The desired subset of dialing modes.
Public property | Negated | When true, the logical result of the condition evaluation is flipped. (Inherited from PolicyCondition.)

See Also

CallDialingModeCondition Class


CallDialingModeCondition Constructor

[image]

IceLib Dialer Technical Reference
CallDialingModeCondition Constructor
CallDialingModeCondition Class See Also Send Feedback
Creates a new instance of the CallDialingModeCondition class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CallDialingModeCondition()
Visual Basic
Public Sub New

See Also

CallDialingModeCondition Class
CallDialingModeCondition Members


CallDialingModeCondition Methods

[image] [image]

IceLib Dialer Technical Reference
CallDialingModeCondition Methods
CallDialingModeCondition Class See Also Send Feedback

The CallDialingModeCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CallDialingModeCondition Class


CallDialingModeCondition Properties

[image] [image]

IceLib Dialer Technical Reference
CallDialingModeCondition Properties
CallDialingModeCondition Class See Also Send Feedback

The CallDialingModeCondition type exposes the following members.

Properties

 | Name | Description
Public property | ConditionType | The type of condition. (Inherited from PolicyCondition.)
Public property | Id | The Id of the condition. (Inherited from PolicyCondition.)
Public property | Modes | The desired subset of dialing modes.
Public property | Negated | When true, the logical result of the condition evaluation is flipped. (Inherited from PolicyCondition.)

See Also

CallDialingModeCondition Class


Modes Property

[image]

IceLib Dialer Technical Reference
CallDialingModeCondition..::..Modes Property
CallDialingModeCondition Class See Also Send Feedback
The desired subset of dialing modes.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<PolicyDialingMode> Modes { get; }
Visual Basic
Public ReadOnly Property Modes As Collection(Of PolicyDialingMode)
    Get

See Also

CallDialingModeCondition Class
CallDialingModeCondition Members


CallDurationCondition Class

[image]

IceLib Dialer Technical Reference
CallDurationCondition Class
Members See Also Send Feedback
A policy condition that checks if the duration of a call matches a certain value.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class CallDurationCondition : PolicyCondition
Visual Basic
Public NotInheritable Class CallDurationCondition _
    Inherits PolicyCondition

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyCondition
ININ.IceLib.Configuration.Dialer..::..CallDurationCondition

See Also

CallDurationCondition Members


CallDurationCondition Members

[image] [image]

IceLib Dialer Technical Reference
CallDurationCondition Members
CallDurationCondition Class Constructors Methods Properties See Also Send Feedback

The CallDurationCondition type exposes the following members.

Constructors

 | Name | Description
Public method | CallDurationCondition | Creates a new instance of the CallDurationCondition

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConditionType | The type of condition. (Inherited from PolicyCondition.)
Public property | DurationInSeconds | The value to check the duration against, in units of seconds.
Public property | Id | The Id of the condition. (Inherited from PolicyCondition.)
Public property | Negated | When true, the logical result of the condition evaluation is flipped. (Inherited from PolicyCondition.)
Public property | Operation | An conditional operator that compares the call duration to DurationInSeconds.

See Also

CallDurationCondition Class


CallDurationCondition Constructor

[image]

IceLib Dialer Technical Reference
CallDurationCondition Constructor
CallDurationCondition Class See Also Send Feedback
Creates a new instance of the CallDurationCondition

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CallDurationCondition()
Visual Basic
Public Sub New

See Also

CallDurationCondition Class
CallDurationCondition Members


CallDurationCondition Methods

[image] [image]

IceLib Dialer Technical Reference
CallDurationCondition Methods
CallDurationCondition Class See Also Send Feedback

The CallDurationCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CallDurationCondition Class


CallDurationCondition Properties

[image] [image]

IceLib Dialer Technical Reference
CallDurationCondition Properties
CallDurationCondition Class See Also Send Feedback

The CallDurationCondition type exposes the following members.

Properties

 | Name | Description
Public property | ConditionType | The type of condition. (Inherited from PolicyCondition.)
Public property | DurationInSeconds | The value to check the duration against, in units of seconds.
Public property | Id | The Id of the condition. (Inherited from PolicyCondition.)
Public property | Negated | When true, the logical result of the condition evaluation is flipped. (Inherited from PolicyCondition.)
Public property | Operation | An conditional operator that compares the call duration to DurationInSeconds.

See Also

CallDurationCondition Class


DurationInSeconds Property

[image]

IceLib Dialer Technical Reference
CallDurationCondition..::..DurationInSeconds Property
CallDurationCondition Class See Also Send Feedback
The value to check the duration against, in units of seconds.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int DurationInSeconds { get; set; }
Visual Basic
Public Property DurationInSeconds As Integer
    Get
    Set

See Also

CallDurationCondition Class
CallDurationCondition Members


Operation Property

[image]

IceLib Dialer Technical Reference
CallDurationCondition..::..Operation Property
CallDurationCondition Class See Also Send Feedback
An conditional operator that compares the call duration to DurationInSeconds.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ComparisonOperator Operation { get; set; }
Visual Basic
Public Property Operation As ComparisonOperator
    Get
    Set

See Also

CallDurationCondition Class
CallDurationCondition Members


CallingPartyBehavior Class

[image]

IceLib Dialer Technical Reference
CallingPartyBehavior Class
Members See Also Send Feedback
A PolicyBehavior which can alter callerID information on a per-call basis.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class CallingPartyBehavior : PolicyBehavior
Visual Basic
Public NotInheritable Class CallingPartyBehavior _
    Inherits PolicyBehavior

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyBehavior
ININ.IceLib.Configuration.Dialer..::..CallingPartyBehavior

See Also

CallingPartyBehavior Members


CallingPartyBehavior Members

[image] [image]

IceLib Dialer Technical Reference
CallingPartyBehavior Members
CallingPartyBehavior Class Constructors Methods Properties See Also Send Feedback

The CallingPartyBehavior type exposes the following members.

Constructors

 | Name | Description
Public method | CallingPartyBehavior | Initializes a new instance of the CallingPartyBehavior class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | CallingPartyName | Get or set the caller's name that will show up on contact's callerID.
Public property | CallingPartyNumber | Get or set the caller's phone number that will show up on contact's callerID.
Public property | Id | (Inherited from PolicyBehavior.)

See Also

CallingPartyBehavior Class


CallingPartyBehavior Constructor

[image]

IceLib Dialer Technical Reference
CallingPartyBehavior Constructor
CallingPartyBehavior Class See Also Send Feedback
Initializes a new instance of the CallingPartyBehavior class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CallingPartyBehavior()
Visual Basic
Public Sub New

See Also

CallingPartyBehavior Class
CallingPartyBehavior Members


CallingPartyBehavior Methods

[image] [image]

IceLib Dialer Technical Reference
CallingPartyBehavior Methods
CallingPartyBehavior Class See Also Send Feedback

The CallingPartyBehavior type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CallingPartyBehavior Class


CallingPartyBehavior Properties

[image] [image]

IceLib Dialer Technical Reference
CallingPartyBehavior Properties
CallingPartyBehavior Class See Also Send Feedback

The CallingPartyBehavior type exposes the following members.

Properties

 | Name | Description
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | CallingPartyName | Get or set the caller's name that will show up on contact's callerID.
Public property | CallingPartyNumber | Get or set the caller's phone number that will show up on contact's callerID.
Public property | Id | (Inherited from PolicyBehavior.)

See Also

CallingPartyBehavior Class


CallingPartyName Property

[image]

IceLib Dialer Technical Reference
CallingPartyBehavior..::..CallingPartyName Property
CallingPartyBehavior Class See Also Send Feedback
Get or set the caller's name that will show up on contact's callerID.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string CallingPartyName { get; set; }
Visual Basic
Public Property CallingPartyName As String
    Get
    Set

See Also

CallingPartyBehavior Class
CallingPartyBehavior Members


CallingPartyNumber Property

[image]

IceLib Dialer Technical Reference
CallingPartyBehavior..::..CallingPartyNumber Property
CallingPartyBehavior Class See Also Send Feedback
Get or set the caller's phone number that will show up on contact's callerID.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string CallingPartyNumber { get; set; }
Visual Basic
Public Property CallingPartyNumber As String
    Get
    Set

See Also

CallingPartyBehavior Class
CallingPartyBehavior Members


CallRoutingBehavior Class

[image]

IceLib Dialer Technical Reference
CallRoutingBehavior Class
Members See Also Send Feedback
A PolicyBehavior which can set skill information and change routing behavior for a call.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class CallRoutingBehavior : PolicyBehavior
Visual Basic
Public NotInheritable Class CallRoutingBehavior _
    Inherits PolicyBehavior

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyBehavior
ININ.IceLib.Configuration.Dialer..::..CallRoutingBehavior

See Also

CallRoutingBehavior Members


CallRoutingBehavior Members

[image] [image]

IceLib Dialer Technical Reference
CallRoutingBehavior Members
CallRoutingBehavior Class Constructors Methods Properties See Also Send Feedback

The CallRoutingBehavior type exposes the following members.

Constructors

 | Name | Description
Public method | CallRoutingBehavior | Initializes a new instance of the CallRoutingBehavior class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | DesireToUseWeight | Get or set how heavily skill desire will be considered in routing the call.
Public property | EnableMaxPreviewTime | Gets or sets whether the interaction will enforce a maximum preview time.
Public property | Id | (Inherited from PolicyBehavior.)
Public property | MaxDesireToUse | Get or set the maximum skill desire of agents that will receive this call based on the specified skill.
Public property | MaxPreviewSeconds | Gets or sets the maximum number of seconds for which the interaction can be previewed.
Public property | MaxProficiency | Get or set the maximum skill proficiency of agents that will receive this call based on the specified skill.
Public property | MinDesireToUse | Get or set the minimum skill desire of agents that will receive this call based on the specified skill.
Public property | MinProficiency | Get or set the minimum skill proficiency of agents that will receive this call based on the specified skill.
Public property | ProficiencyWeight | Get or set how heavily skill proficiency will be considered in routing the call.
Public property | RequiredSkill | Get or set the skill requirement that will be attached to this call (if any).
Public property | RoutingMode | Get or set how the call will be routed.

See Also

CallRoutingBehavior Class


CallRoutingBehavior Constructor

[image]

IceLib Dialer Technical Reference
CallRoutingBehavior Constructor
CallRoutingBehavior Class See Also Send Feedback
Initializes a new instance of the CallRoutingBehavior class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CallRoutingBehavior()
Visual Basic
Public Sub New

See Also

CallRoutingBehavior Class
CallRoutingBehavior Members


CallRoutingBehavior Methods

[image] [image]

IceLib Dialer Technical Reference
CallRoutingBehavior Methods
CallRoutingBehavior Class See Also Send Feedback

The CallRoutingBehavior type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CallRoutingBehavior Class


CallRoutingBehavior Properties

[image] [image]

IceLib Dialer Technical Reference
CallRoutingBehavior Properties
CallRoutingBehavior Class See Also Send Feedback

The CallRoutingBehavior type exposes the following members.

Properties

 | Name | Description
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | DesireToUseWeight | Get or set how heavily skill desire will be considered in routing the call.
Public property | EnableMaxPreviewTime | Gets or sets whether the interaction will enforce a maximum preview time.
Public property | Id | (Inherited from PolicyBehavior.)
Public property | MaxDesireToUse | Get or set the maximum skill desire of agents that will receive this call based on the specified skill.
Public property | MaxPreviewSeconds | Gets or sets the maximum number of seconds for which the interaction can be previewed.
Public property | MaxProficiency | Get or set the maximum skill proficiency of agents that will receive this call based on the specified skill.
Public property | MinDesireToUse | Get or set the minimum skill desire of agents that will receive this call based on the specified skill.
Public property | MinProficiency | Get or set the minimum skill proficiency of agents that will receive this call based on the specified skill.
Public property | ProficiencyWeight | Get or set how heavily skill proficiency will be considered in routing the call.
Public property | RequiredSkill | Get or set the skill requirement that will be attached to this call (if any).
Public property | RoutingMode | Get or set how the call will be routed.

See Also

CallRoutingBehavior Class


DesireToUseWeight Property

[image]

IceLib Dialer Technical Reference
CallRoutingBehavior..::..DesireToUseWeight Property
CallRoutingBehavior Class See Also Send Feedback
Get or set how heavily skill desire will be considered in routing the call.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public double DesireToUseWeight { get; set; }
Visual Basic
Public Property DesireToUseWeight As Double
    Get
    Set

See Also

CallRoutingBehavior Class
CallRoutingBehavior Members


EnableMaxPreviewTime Property

[image]

IceLib Dialer Technical Reference
CallRoutingBehavior..::..EnableMaxPreviewTime Property
CallRoutingBehavior Class See Also Send Feedback
Gets or sets whether the interaction will enforce a maximum preview time.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool EnableMaxPreviewTime { get; set; }
Visual Basic
Public Property EnableMaxPreviewTime As Boolean
    Get
    Set

See Also

CallRoutingBehavior Class
CallRoutingBehavior Members


MaxDesireToUse Property

[image]

IceLib Dialer Technical Reference
CallRoutingBehavior..::..MaxDesireToUse Property
CallRoutingBehavior Class See Also Send Feedback
Get or set the maximum skill desire of agents that will receive this call based on the specified skill.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int MaxDesireToUse { get; set; }
Visual Basic
Public Property MaxDesireToUse As Integer
    Get
    Set

See Also

CallRoutingBehavior Class
CallRoutingBehavior Members


MaxPreviewSeconds Property

[image]

IceLib Dialer Technical Reference
CallRoutingBehavior..::..MaxPreviewSeconds Property
CallRoutingBehavior Class See Also Send Feedback
Gets or sets the maximum number of seconds for which the interaction can be previewed.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int MaxPreviewSeconds { get; set; }
Visual Basic
Public Property MaxPreviewSeconds As Integer
    Get
    Set

Remarks

After MaxPreviewSeconds seconds have passed the preview interaction will be automatically placed.

See Also

CallRoutingBehavior Class
CallRoutingBehavior Members


MaxProficiency Property

[image]

IceLib Dialer Technical Reference
CallRoutingBehavior..::..MaxProficiency Property
CallRoutingBehavior Class See Also Send Feedback
Get or set the maximum skill proficiency of agents that will receive this call based on the specified skill.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int MaxProficiency { get; set; }
Visual Basic
Public Property MaxProficiency As Integer
    Get
    Set

See Also

CallRoutingBehavior Class
CallRoutingBehavior Members


MinDesireToUse Property

[image]

IceLib Dialer Technical Reference
CallRoutingBehavior..::..MinDesireToUse Property
CallRoutingBehavior Class See Also Send Feedback
Get or set the minimum skill desire of agents that will receive this call based on the specified skill.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int MinDesireToUse { get; set; }
Visual Basic
Public Property MinDesireToUse As Integer
    Get
    Set

See Also

CallRoutingBehavior Class
CallRoutingBehavior Members


MinProficiency Property

[image]

IceLib Dialer Technical Reference
CallRoutingBehavior..::..MinProficiency Property
CallRoutingBehavior Class See Also Send Feedback
Get or set the minimum skill proficiency of agents that will receive this call based on the specified skill.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int MinProficiency { get; set; }
Visual Basic
Public Property MinProficiency As Integer
    Get
    Set

See Also

CallRoutingBehavior Class
CallRoutingBehavior Members


ProficiencyWeight Property

[image]

IceLib Dialer Technical Reference
CallRoutingBehavior..::..ProficiencyWeight Property
CallRoutingBehavior Class See Also Send Feedback
Get or set how heavily skill proficiency will be considered in routing the call.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public double ProficiencyWeight { get; set; }
Visual Basic
Public Property ProficiencyWeight As Double
    Get
    Set

See Also

CallRoutingBehavior Class
CallRoutingBehavior Members


RequiredSkill Property

[image]

IceLib Dialer Technical Reference
CallRoutingBehavior..::..RequiredSkill Property
CallRoutingBehavior Class See Also Send Feedback
Get or set the skill requirement that will be attached to this call (if any).

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string RequiredSkill { get; set; }
Visual Basic
Public Property RequiredSkill As String
    Get
    Set

See Also

CallRoutingBehavior Class
CallRoutingBehavior Members


RoutingMode Property

[image]

IceLib Dialer Technical Reference
CallRoutingBehavior..::..RoutingMode Property
CallRoutingBehavior Class See Also Send Feedback
Get or set how the call will be routed.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CallRoutingMode RoutingMode { get; set; }
Visual Basic
Public Property RoutingMode As CallRoutingMode
    Get
    Set

See Also

CallRoutingBehavior Class
CallRoutingBehavior Members


CampaignConfiguration Class

[image]

IceLib Dialer Technical Reference
CampaignConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for a Dialer campaign.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class CampaignConfiguration : EditableListConfigurationObject<CampaignConfiguration..::..Property>,
    IExportable
Visual Basic
Public Class CampaignConfiguration _
    Inherits EditableListConfigurationObject(Of CampaignConfiguration..::..Property) _
    Implements IExportable

Inheritance Hierarchy

System..::..Object
ConfigurationObject
ListConfigurationObject
EditableListConfigurationObject<(Of <(<' CampaignConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..CampaignConfiguration

See Also

CampaignConfiguration Members


CampaignConfiguration Members

[image] [image]

IceLib Dialer Technical Reference
CampaignConfiguration Members
CampaignConfiguration Class Methods Properties See Also Send Feedback

The CampaignConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' CampaignConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' CampaignConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' CampaignConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' CampaignConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' CampaignConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDescription |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaxLineSetting | returns the Max lines per campaign setting of the campaign
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' CampaignConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' CampaignConfiguration..::..Property >)>)>.)
Public method | MapPhoneNumbersToZones | Recycles the contact list referenced by this campaign.
Public method | MapPhoneNumbersToZonesAsync | Asynchronously recycles the contact list referenced by this campaign.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PerformBulkDNCScrub | Scrubs the campaign's contact list using the assigned DNC source.
Public method | PerformBulkDNCScrubAsync | Asynchronously scrubs the campaign's contact list using the assigned DNC source.
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' CampaignConfiguration..::..Property >)>)>.)
Public method | QuickValidate | Performs a test to validate if this campaign can operate correctly at a very basic level.
Public method | QuickValidateAsync | Performs a test to validate if this campaign can operate correctly at a very basic level.
Public method | RecycleContactList | Recycles the contact list referenced by this campaign.
Public method | RecycleContactListAsync | Asynchronously recycles the contact list referenced by this campaign.
Public method | ResetCampaign | Resets the campaign by recycling the contact list, resetting the recycle count to 0, and picking up any saved configuration changes since the last time the campaign started.
Public method | ResetCampaignAsync | Asynchronously resets the campaign by recycling the contact list, resetting the recycle count to 0, and picking up any saved configuration changes since the last time the campaign started.
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' CampaignConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' CampaignConfiguration..::..Property >)>)>.)
Public method | Test | Verify database, contact list, and skill set settings.
Public method | TestAsync | Asynchronously verify database, contact list, and skill set settings.
Public method | ToString | (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | AbandonRateCalculation | The manner in which the abandon rate is calculated.
Public property | AcdAgentAvailableTimeInterval | The amount of time (in seconds) before incrementing agent available time/>
Public property | AcdAgentAvailableTimeWeight | The level of importance for agent available time in the agent score formula
Public property | AcdAgentCostWeight | The level of importance for agent cost in the agent score formula
Public property | AcdAgentSkillWeight | The level of importance for agent skill in the agent score formula
Public property | AcdPriorityLevel | The level of importance of call priority in the call score formula
Public property | AcdPriorityWeight | The priority assigned to calls
Public property | AcdSkillsWeight | The level of importance of agent skill in the call score formula
Public property | AcdTimeInQueueWeight | The level of importance of time spent in queue in the call score formula
Public property | AcdTimeInSystemWeight | The amount of time (in seconds) before increasing the time in system value
Public property | AcdWorkgroup | The ACD workgroup used by the dialing server
Public property | ActiveRuleGroup | The activue rule group associated with the campaign RuleSet.
Public property | AgentlessAllowAcdIfNoAgentAvailable | Toggles ACD routing when no agent is available to take a call. If enabled, the called party is immediately rerouted to a newly available agent. If disabled, the call is disconnected after any specified wave audio file or Attendant Profile completes, even if an agent becomes available.
Public property | AgentlessAnsweringMachineAttendantProfile | The Attendant Profile to route the call to when an answering machine is encountered.
Public property | AgentlessAnsweringMachineFile | The wave audio file to play when an answering machine is encountered.
Public property | AgentlessAnsweringMachineSecondsOfSilence | The amount of time the system will wait before playing a wave audio file to an answering machine.
Public property | AgentlessAnsweringMachineType | The action to perform when an answering machine is encountered.
Public property | AgentlessFaxAttendantProfile | The Attendant Profile to route the call to when a fax machine is encountered.
Public property | AgentlessFaxFile | The fax file (.i3f) to play when a fax machine is encountered.
Public property | AgentlessFaxMaxRetries | The maximum number of times a fax machine may be encountered before the contact is considered a failure.
Public property | AgentlessFaxType | The action to perform when a fax machine is encountered.
Public property | AgentlessFileRepeat | The number of additional times a file should be played. A ten second period of silence separates each play.
Public property | AgentlessLiveAttendantProfile | The Attendant Profile to route the call to when a live person is reached.
Public property | AgentlessLiveFile | The wave audio file to play when a live person is reached.
Public property | AgentlessLiveType | The action to perform when a live person is reached.
Public property | AgentlessNoAgentAttendantProfile | The Attendant Profile to route the call to when no agent is available to take the call.
Public property | AgentlessNoAgentFile | The wave audio file to play when no agent is available to take the call.
Public property | AgentlessNoAgentType | The action to perform when no agent is available to take the call.
Public property | AgentOwnedCallbackCacheTimeout | The interval in minutes to check for agent-owned callbacks and either reschedule or flush them out.
Public property | AutomapTimeZone | Toggles automatic mapping of phone numbers to a predefined zone
Public property | AutopacingMaxPace | The upper limit on dialing pace. Auto-adjustments may not exceed this value.
Public property | AutoscheduleAnsweringMachineMaxAttempts | The maximum number of times a rescheduled call may reach an answering machine before the contact is marked as uncallable
Public property | AutoscheduleAnsweringMachineRescheduleDelay | The number of minutes the system will wait before retrying a call that previously reached an answering machine
Public property | AutoscheduleBusyMaxAttempts | The maximum number of times a rescheduled call may encounter a busy signal before the contact is marked as uncallable
Public property | AutoscheduleBusyRescheduleDelay | The number of minutes the system will wait before retrying a call that previously encountered a busy signal
Public property | AutoscheduledCallsIgnoreRecycles | When enabled, auto-scheduled calls are flagged so that future recycles of the contact list do not dial this entry as a normal contact
Public property | AutoscheduleFaxMaxAttempts | The maximum number of times a rescheduled call may reach a fax machine before the contact is marked as uncallable
Public property | AutoscheduleFaxRescheduleDelay | The number of minutes the system will wait before retrying a call that previously reached a fax machine
Public property | AutoscheduleNoAnswerMaxAttempts | The maximum number of times the system will call a contact that is not answering before it is marked as uncallable
Public property | AutoscheduleNoAnswerRescheduleDelay | The number of minutes the system will wait before retrying a call that previously received no answer
Public property | AutoscheduleRemoteHangupMaxAttempts | The maximum number of times a rescheduled call may be disconnected by the remote party before the contact is marked as uncallable
Public property | AutoscheduleRemoteHangupRescheduleDelay | The number of minutes the system will wait before retrying a call that was terminated by the remote party
Public property | AutoscheduleSystemHangupMaxAttempts | The maximum number of times the system will call a contact back if the system itself terminated the call before marking the contact as uncallable
Public property | AutoscheduleSystemHangupRescheduleDelay | The number of minutes the system will wait before retrying a call that was terminated by the system itself
Public property | BaseScript | The Id of the Base Script used by the campaign
Public property | CallerIdDisplayName | The name that contacts will see on Caller ID devices
Public property | CallerIdDisplayNumber | The telephone number that contacts will see on Caller ID devices
Public property | CallingMode | The calling mode of the campaign.
Public property | CallStages | The Id of the Stage Set used by the campaign
Public property | CallTimeoutSeconds | The amount of time (in seconds) the system will wait for an available agent before disconnecting the remote party
Public property | CampaignGroup | The (optional) logical group that the campaign belongs to.
Public property | CampaignStatsInterval | The interval at which campaign statistics are gathered and logged.
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' CampaignConfiguration..::..Property >)>)>.)
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | ContactColumns | The Ids of the contact columns used in contact queries. This is only used if CustomizeContactColumns is true
Public property | ContactList | The Id of the Contact List used by the campaign
Public property | CopyDialerAttributesToCallAttributes | Toggles whether to copy contact attributes (columns/values) to the call's attributes before forwarding the call to an Attendant Profile.
Public property | CustomDNCSource | The Id of the Custom Do-Not-Call source object used by the campaign.
Public property | CustomizeContactColumns | Specifies if contact columns use the customized list available in ContactColumns
Public property | CustomScriptURL | The URL of the first HTML page displayed by the custom script used by this campaign. Leave blank if using a base script.
Public property | DialingActive | Specifies if the campaign is currently running, whether manually controlled or automatically scheduled.
Public property | DialingAutoOnOff | Specifies if the campaign is currently running under the control of a dialing schedule.
Public property | DialingPace | (Deprecated) The aggressiveness of outbound dialing ranging from -100 (not aggressive) to 100 (very aggressive).
Public property | DialingPriority | The level of importance of this campaign in relation to other running campaigns
Public property | DialingSchedule | The Id of the dialing schedule used by the campaign.
Public property | DialingScheduledOnly | Toggles whether the campaign should only dial scheduled callbacks.
Public property | DisplayTransitionAlerts | Specifies if the client should alert users when the active rule group changes.
Public property | DNCExclusionId | The Id of the Do-Not-Call exclusion object used by the campaign.
Public property | DNCSource | The Id of the Do-Not-Call source object used by the campaign.
Public property | EnableAnsweringMachineDetection | Toggles whether call analysis should also attempt to detect answering machines.
Public property | EnableCallAnalysis | Toggles the use of call analysis to determine the nature of the connected party (live person, fax machine, etc).
Public property | EnableMaxPreviewTime | Toggles the use of max preview time when using Preview for CallingMode.
Public property | FilterAutoscheduledCallbacks | Toggles the application of filter criteria when querying for auto-scheduled callbacks.
Public property | Filters | The Ids of the filters used in contact queries.
Public property | FilterScheduledCallbacks | Toggles the application of filter criteria when querying for scheduled callbacks.
Public property | FollowUpStatus | The status that Dialer sets the agent to when a Dialer call disconnects but has not been dispositioned yet.
Public property | InboundWorkgroups | Workgroup-specific thresholds used to automatically disable or enable prediction in blended environments.
Public property | IncludeNoAgentAsAbandon | Specifies the manner in which calls with no agents available are considered abandoned.
Public property | IncludeRemoteHangupAsAbandon | Specifies the manner in which calls disconnected by the remote party are considered abandoned.
Public property | IncludeSystemHangupAsAbandon | Specifies the manner in which calls disconnected by the system are considered abandoned.
Public property | InitialCallsPerRequest | The number of calls to place when contact rate information is not yet available, such as when a campaign starts.
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsExporting | Tells whether the current object is being used for exporting
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | IsNonDialerStatDisabled | If true, Dialer will not reserve agents for non-Dialer calls, decreasing idle times for blended sites.
Public property | KeepOpen | Toggles whether the Scripter client should keep the campaign's script open between calls
Public property | MaxAbandonRate | The maximum percentage of calls that are abandoned the dialing server will allow before adjusting the dialing pace.
Public property | MaxAgentCallbackReschedules | The maximum number of reschedule delays before an own-agent callback is converted into a campaign-wide callback and placed immediately.
Public property | MaxAttempts | The maximum number of times a contact record will be dialed before it is marked as uncallable.
Public property | MaxAttemptsPerPhoneNumber | The maximum number of times a phone number will be dialed before it is marked as uncallable.
Public property | MaxDailyAttempts | The maximum number of times a phone number can be dialed in one day.
Public property | MaxDailyAttemptsDefinition | The maximum number of times a contact can be dialed in one day regardless of how many phone numbers the contact contains.
Public property | MaxLines | The maximum number of lines a campaign may use.
Public property | MaxPreviewSeconds | The maximum number of seconds a user may preview a number.
Public property | MaxRecycles | The number of additional times the system will go through the contact list before ending the campaign.
Public property | MinimumNextDial | The minimum number of minutes that must elapse before a phone number may be dialed again.
Public property | NoAgentAbandonDelay | The number of seconds that may elapse before a call with no available agent is considered to be abandoned.
Public property | NoAnswerTimeout | The number of seconds the system will wait for a contact to answer before disconnecting the call.
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | OutboundDialingLineType | Specifies whether the campaign should adhere strictly to a dial plan, or use one specific line group.
Public property | OutboundDialPlanLocation | The dial plan location used by the campaign.
Public property | OutboundLinegroup | The name of the line group used by the campaign.
Public property | OutboundSMSEnabled | Specifies whether outbound SMS is enabled or disabled.
Public property | OverallInboundHighThreshold | The number of inbound waiting calls in the ACD workgroup that will cause the dialing server to stop making predictions.
Public property | OverallInboundLowThreshold | The number of inbound waiting calls in the ACD workgroup that will cause the dialing server to resume making predictions.
Public property | Paused | Pauses or unpauses the campaign.
Public property | PersistentConnectionWavFile | The wave audio file to play to Scripter client users upon a succcessful login.
Public property | PolicySets | The Ids of the Policy Sets used by the campaign.
Public property | PriorityDialingEnabled | Toggles the priority (just-in-time) dialing feature.
Public property | PriorityQueryFrequency | The interval (in seconds) at which the dialing server queries for contacts marked as priority (just-in-time).
Public property | PrioritySortColumns | Criteria for sorting the contact list by column when querying for priority (just-in-time) calls.
Public property | QueryTimeFilters | The Ids of the filters used in phone number details queries.
Public property | RecyclesRemaining | The number of recycles left to be executed in order for the campaign to complete. This property is read-only.
Public property | RecycleTable | The name of the database table containing recycle information for the campaign. This value is automatically generated by the central campaign server and is read-only.
Public property | RemoteHangUpAbandonDelay | The amount of time (in seconds) before a call is disconnected by the remote party which designates the call as abandoned.
Public property | RescheduleDelay | The amount of time (in minutes) the system will wait before checking if an agent is available to take an auto-scheduled callback. The delay process is repeated if the agent is stil not available, up to the number of attempts specified by MaxAgentCallbackReschedules.
Public property | RevisionLevel | The current version of this object. This property is read-only.
Public property | RuleSet | The Id of the Rule Set assigned to the campaign.
Public property | Sequence | The Id of the Sequence assigned to the campaign.
Public property | Servers | The Ids of dialing servers participating in the campaign.
Public property | SkillSets | The Ids of Skill Sets used by this campaign for skills-based dialing.
Public property | SMSBroker | The name of the SMS Broker used by the campaign.
Public property | SMSBrokerAccount | The name of the SMS Broker Account used by the campaign.
Public property | SortColumns | Criteria for sorting the contact list by column.
Public property | StrictMaxAbandon | Toggles the forcing of the system to adhere to maximum abandon rate settings.
Public property | SupervisorAccess | Returns a boolean based on the user's ability to perform certain Supervisor-related tasks on the campaign. Examples of such actions are: stopping, starting, turning the campaign on in scheduled calls only mode, pausing, unpausing, recycling and resetting the campaign.
Public property | TimeZoneAutoMappingMode | The manner in which to map phone numbers to time zones
Public property | UseAllDialingServers | Specifies whether this campaign should use every ODS available when dialing. Setting this property to trueTruetruetrue (True in Visual Basic) will clear the Servers collection except for one special "All Servers" object.
Public property | UseAutoScheduleSettingsForAgentCallbacks | Toggles whether this campaign's Auto-Schedule settings apply to own-agent callbacks.
Public property | UseBulkApi | Toggles the use of the Bulk Call API, allowing higher call throughput using less system resources.
Public property | UseCallingTimeRestrictions | Toggles the use of DNC.Com's Calling Time Restrictions flag.
Public property | UseCallingTimeWindow | Toggles the use of DNC.Com's Calling Time Window flag.
Public property | UseContactListZone | Toggles the use of contact record zone for zone blocking.
Public property | UseDefaultZoneForZoneBlocking | Toggles the use of default zone for zone blocking.
Public property | UseDoNotCallToday | Toggles the use of DNC.Com's Do not call today flag.
Public property | UsePermissionEbr | Toggles the use of DNC.Com's Use Permission EBR flag.
Public property | ZoneSet | The Id of the Zone Set used by this campaign.

See Also

CampaignConfiguration Class


CampaignConfiguration Methods

[image] [image]

IceLib Dialer Technical Reference
CampaignConfiguration Methods
CampaignConfiguration Class See Also Send Feedback

The CampaignConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' CampaignConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' CampaignConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' CampaignConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' CampaignConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' CampaignConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDescription |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMaxLineSetting | returns the Max lines per campaign setting of the campaign
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' CampaignConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' CampaignConfiguration..::..Property >)>)>.)
Public method | MapPhoneNumbersToZones | Recycles the contact list referenced by this campaign.
Public method | MapPhoneNumbersToZonesAsync | Asynchronously recycles the contact list referenced by this campaign.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PerformBulkDNCScrub | Scrubs the campaign's contact list using the assigned DNC source.
Public method | PerformBulkDNCScrubAsync | Asynchronously scrubs the campaign's contact list using the assigned DNC source.
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' CampaignConfiguration..::..Property >)>)>.)
Public method | QuickValidate | Performs a test to validate if this campaign can operate correctly at a very basic level.
Public method | QuickValidateAsync | Performs a test to validate if this campaign can operate correctly at a very basic level.
Public method | RecycleContactList | Recycles the contact list referenced by this campaign.
Public method | RecycleContactListAsync | Asynchronously recycles the contact list referenced by this campaign.
Public method | ResetCampaign | Resets the campaign by recycling the contact list, resetting the recycle count to 0, and picking up any saved configuration changes since the last time the campaign started.
Public method | ResetCampaignAsync | Asynchronously resets the campaign by recycling the contact list, resetting the recycle count to 0, and picking up any saved configuration changes since the last time the campaign started.
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' CampaignConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' CampaignConfiguration..::..Property >)>)>.)
Public method | Test | Verify database, contact list, and skill set settings.
Public method | TestAsync | Asynchronously verify database, contact list, and skill set settings.
Public method | ToString | (Inherited from ConfigurationObject.)

See Also

CampaignConfiguration Class


GetDescription Method

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..GetDescription Method
CampaignConfiguration Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static PropertyDescriptionAttribute GetDescription(
    CampaignConfiguration..::..Property property
)
Visual Basic
Public Shared Function GetDescription ( _
    property As CampaignConfiguration..::..Property _
) As PropertyDescriptionAttribute

Parameters

property
Type: ININ.IceLib.Configuration.Dialer..::..CampaignConfiguration..::..Property

See Also

CampaignConfiguration Class
CampaignConfiguration Members


GetMaxLineSetting Method

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..GetMaxLineSetting Method
CampaignConfiguration Class See Also Send Feedback
returns the Max lines per campaign setting of the campaign

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int GetMaxLineSetting()
Visual Basic
Public Function GetMaxLineSetting As Integer

Return Value

An int representing the Max Lines per campagin Setting of the campaign.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


MapPhoneNumbersToZones Method

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..MapPhoneNumbersToZones Method
CampaignConfiguration Class See Also Send Feedback
Recycles the contact list referenced by this campaign.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool MapPhoneNumbersToZones()
Visual Basic
Public Function MapPhoneNumbersToZones As Boolean

Return Value

The number of records remaining in the current recycle.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


MapPhoneNumbersToZonesAsync Method

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..MapPhoneNumbersToZonesAsync Method
CampaignConfiguration Class See Also Send Feedback
Asynchronously recycles the contact list referenced by this campaign.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void MapPhoneNumbersToZonesAsync(
    EventHandler<AsyncCompletedEventArgs<bool>> callback,
    Object userState
)
Visual Basic
Public Sub MapPhoneNumbersToZonesAsync ( _
    callback As EventHandler(Of AsyncCompletedEventArgs(Of Boolean)), _
    userState As Object _
)

Parameters

callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Boolean>)>)>>)>)>
userState
Type: System..::..Object

See Also

CampaignConfiguration Class
CampaignConfiguration Members


PerformBulkDNCScrub Method

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..PerformBulkDNCScrub Method
CampaignConfiguration Class See Also Send Feedback
Scrubs the campaign's contact list using the assigned DNC source.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ReadOnlyCollection<DNCScrubResult> PerformBulkDNCScrub()
Visual Basic
Public Function PerformBulkDNCScrub As ReadOnlyCollection(Of DNCScrubResult)

Return Value

DNCScrubResult

See Also

CampaignConfiguration Class
CampaignConfiguration Members


PerformBulkDNCScrubAsync Method

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..PerformBulkDNCScrubAsync Method
CampaignConfiguration Class See Also Send Feedback
Asynchronously scrubs the campaign's contact list using the assigned DNC source.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void PerformBulkDNCScrubAsync(
    EventHandler<AsyncCompletedEventArgs<ReadOnlyCollection<DNCScrubResult>>> completionCallback,
    Object state
)
Visual Basic
Public Sub PerformBulkDNCScrubAsync ( _
    completionCallback As EventHandler(Of AsyncCompletedEventArgs(Of ReadOnlyCollection(Of DNCScrubResult))), _
    state As Object _
)

Parameters

completionCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'ReadOnlyCollection<(Of <(<' DNCScrubResult >)>)>>)>)>>)>)>
state
Type: System..::..Object

See Also

CampaignConfiguration Class
CampaignConfiguration Members


QuickValidate Method

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..QuickValidate Method
CampaignConfiguration Class See Also Send Feedback
Performs a test to validate if this campaign can operate correctly at a very basic level.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CampaignConfiguration..::..QuickValidateResults QuickValidate()
Visual Basic
Public Function QuickValidate As CampaignConfiguration..::..QuickValidateResults

Return Value

A CampaignConfiguration..::..QuickValidateResults object that tells if and why the test failed.

Remarks

The relevant properties in this test are as follows: ContactList, Filters, and SortColumns.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


QuickValidateAsync Method

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..QuickValidateAsync Method
CampaignConfiguration Class See Also Send Feedback
Performs a test to validate if this campaign can operate correctly at a very basic level.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void QuickValidateAsync(
    EventHandler<AsyncCompletedEventArgs<CampaignConfiguration..::..QuickValidateResults>> callback,
    Object userState
)
Visual Basic
Public Sub QuickValidateAsync ( _
    callback As EventHandler(Of AsyncCompletedEventArgs(Of CampaignConfiguration..::..QuickValidateResults)), _
    userState As Object _
)

Parameters

callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<' CampaignConfiguration..::..QuickValidateResults >)>)>>)>)>
userState
Type: System..::..Object

Remarks

The relevant properties in this test are as follows: ContactList, Filters, and SortColumns.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


RecycleContactList Method

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..RecycleContactList Method
CampaignConfiguration Class See Also Send Feedback
Recycles the contact list referenced by this campaign.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int RecycleContactList()
Visual Basic
Public Function RecycleContactList As Integer

Return Value

The number of records remaining in the current recycle.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


RecycleContactListAsync Method

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..RecycleContactListAsync Method
CampaignConfiguration Class See Also Send Feedback
Asynchronously recycles the contact list referenced by this campaign.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void RecycleContactListAsync(
    EventHandler<AsyncCompletedEventArgs<int>> callback,
    Object userState
)
Visual Basic
Public Sub RecycleContactListAsync ( _
    callback As EventHandler(Of AsyncCompletedEventArgs(Of Integer)), _
    userState As Object _
)

Parameters

callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Int32>)>)>>)>)>
userState
Type: System..::..Object

See Also

CampaignConfiguration Class
CampaignConfiguration Members


ResetCampaign Method

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..ResetCampaign Method
CampaignConfiguration Class See Also Send Feedback
Resets the campaign by recycling the contact list, resetting the recycle count to 0, and picking up any saved configuration changes since the last time the campaign started.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int ResetCampaign()
Visual Basic
Public Function ResetCampaign As Integer

Return Value

The number of records in the current recycle.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


ResetCampaignAsync Method

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..ResetCampaignAsync Method
CampaignConfiguration Class See Also Send Feedback
Asynchronously resets the campaign by recycling the contact list, resetting the recycle count to 0, and picking up any saved configuration changes since the last time the campaign started.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void ResetCampaignAsync(
    EventHandler<AsyncCompletedEventArgs<int>> callback,
    Object userState
)
Visual Basic
Public Sub ResetCampaignAsync ( _
    callback As EventHandler(Of AsyncCompletedEventArgs(Of Integer)), _
    userState As Object _
)

Parameters

callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Int32>)>)>>)>)>
userState
Type: System..::..Object

See Also

CampaignConfiguration Class
CampaignConfiguration Members


Test Method

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..Test Method
CampaignConfiguration Class See Also Send Feedback
Verify database, contact list, and skill set settings.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CampaignConfiguration..::..CampaignTestResults Test(
    int numSampleRecords
)
Visual Basic
Public Function Test ( _
    numSampleRecords As Integer _
) As CampaignConfiguration..::..CampaignTestResults

Parameters

numSampleRecords
Type: System..::..Int32
The number of sample records to return.

Return Value

See Also

CampaignConfiguration Class
CampaignConfiguration Members


TestAsync Method

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..TestAsync Method
CampaignConfiguration Class See Also Send Feedback
Asynchronously verify database, contact list, and skill set settings.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void TestAsync(
    int numSampleRecords,
    EventHandler<AsyncCompletedEventArgs<CampaignConfiguration..::..CampaignTestResults>> callback,
    Object userState
)
Visual Basic
Public Sub TestAsync ( _
    numSampleRecords As Integer, _
    callback As EventHandler(Of AsyncCompletedEventArgs(Of CampaignConfiguration..::..CampaignTestResults)), _
    userState As Object _
)

Parameters

numSampleRecords
Type: System..::..Int32
The number of sample records to return.
callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<' CampaignConfiguration..::..CampaignTestResults >)>)>>)>)>
userState
Type: System..::..Object

See Also

CampaignConfiguration Class
CampaignConfiguration Members


CampaignConfiguration Properties

[image] [image]

IceLib Dialer Technical Reference
CampaignConfiguration Properties
CampaignConfiguration Class See Also Send Feedback

The CampaignConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AbandonRateCalculation | The manner in which the abandon rate is calculated.
Public property | AcdAgentAvailableTimeInterval | The amount of time (in seconds) before incrementing agent available time/>
Public property | AcdAgentAvailableTimeWeight | The level of importance for agent available time in the agent score formula
Public property | AcdAgentCostWeight | The level of importance for agent cost in the agent score formula
Public property | AcdAgentSkillWeight | The level of importance for agent skill in the agent score formula
Public property | AcdPriorityLevel | The level of importance of call priority in the call score formula
Public property | AcdPriorityWeight | The priority assigned to calls
Public property | AcdSkillsWeight | The level of importance of agent skill in the call score formula
Public property | AcdTimeInQueueWeight | The level of importance of time spent in queue in the call score formula
Public property | AcdTimeInSystemWeight | The amount of time (in seconds) before increasing the time in system value
Public property | AcdWorkgroup | The ACD workgroup used by the dialing server
Public property | ActiveRuleGroup | The activue rule group associated with the campaign RuleSet.
Public property | AgentlessAllowAcdIfNoAgentAvailable | Toggles ACD routing when no agent is available to take a call. If enabled, the called party is immediately rerouted to a newly available agent. If disabled, the call is disconnected after any specified wave audio file or Attendant Profile completes, even if an agent becomes available.
Public property | AgentlessAnsweringMachineAttendantProfile | The Attendant Profile to route the call to when an answering machine is encountered.
Public property | AgentlessAnsweringMachineFile | The wave audio file to play when an answering machine is encountered.
Public property | AgentlessAnsweringMachineSecondsOfSilence | The amount of time the system will wait before playing a wave audio file to an answering machine.
Public property | AgentlessAnsweringMachineType | The action to perform when an answering machine is encountered.
Public property | AgentlessFaxAttendantProfile | The Attendant Profile to route the call to when a fax machine is encountered.
Public property | AgentlessFaxFile | The fax file (.i3f) to play when a fax machine is encountered.
Public property | AgentlessFaxMaxRetries | The maximum number of times a fax machine may be encountered before the contact is considered a failure.
Public property | AgentlessFaxType | The action to perform when a fax machine is encountered.
Public property | AgentlessFileRepeat | The number of additional times a file should be played. A ten second period of silence separates each play.
Public property | AgentlessLiveAttendantProfile | The Attendant Profile to route the call to when a live person is reached.
Public property | AgentlessLiveFile | The wave audio file to play when a live person is reached.
Public property | AgentlessLiveType | The action to perform when a live person is reached.
Public property | AgentlessNoAgentAttendantProfile | The Attendant Profile to route the call to when no agent is available to take the call.
Public property | AgentlessNoAgentFile | The wave audio file to play when no agent is available to take the call.
Public property | AgentlessNoAgentType | The action to perform when no agent is available to take the call.
Public property | AgentOwnedCallbackCacheTimeout | The interval in minutes to check for agent-owned callbacks and either reschedule or flush them out.
Public property | AutomapTimeZone | Toggles automatic mapping of phone numbers to a predefined zone
Public property | AutopacingMaxPace | The upper limit on dialing pace. Auto-adjustments may not exceed this value.
Public property | AutoscheduleAnsweringMachineMaxAttempts | The maximum number of times a rescheduled call may reach an answering machine before the contact is marked as uncallable
Public property | AutoscheduleAnsweringMachineRescheduleDelay | The number of minutes the system will wait before retrying a call that previously reached an answering machine
Public property | AutoscheduleBusyMaxAttempts | The maximum number of times a rescheduled call may encounter a busy signal before the contact is marked as uncallable
Public property | AutoscheduleBusyRescheduleDelay | The number of minutes the system will wait before retrying a call that previously encountered a busy signal
Public property | AutoscheduledCallsIgnoreRecycles | When enabled, auto-scheduled calls are flagged so that future recycles of the contact list do not dial this entry as a normal contact
Public property | AutoscheduleFaxMaxAttempts | The maximum number of times a rescheduled call may reach a fax machine before the contact is marked as uncallable
Public property | AutoscheduleFaxRescheduleDelay | The number of minutes the system will wait before retrying a call that previously reached a fax machine
Public property | AutoscheduleNoAnswerMaxAttempts | The maximum number of times the system will call a contact that is not answering before it is marked as uncallable
Public property | AutoscheduleNoAnswerRescheduleDelay | The number of minutes the system will wait before retrying a call that previously received no answer
Public property | AutoscheduleRemoteHangupMaxAttempts | The maximum number of times a rescheduled call may be disconnected by the remote party before the contact is marked as uncallable
Public property | AutoscheduleRemoteHangupRescheduleDelay | The number of minutes the system will wait before retrying a call that was terminated by the remote party
Public property | AutoscheduleSystemHangupMaxAttempts | The maximum number of times the system will call a contact back if the system itself terminated the call before marking the contact as uncallable
Public property | AutoscheduleSystemHangupRescheduleDelay | The number of minutes the system will wait before retrying a call that was terminated by the system itself
Public property | BaseScript | The Id of the Base Script used by the campaign
Public property | CallerIdDisplayName | The name that contacts will see on Caller ID devices
Public property | CallerIdDisplayNumber | The telephone number that contacts will see on Caller ID devices
Public property | CallingMode | The calling mode of the campaign.
Public property | CallStages | The Id of the Stage Set used by the campaign
Public property | CallTimeoutSeconds | The amount of time (in seconds) the system will wait for an available agent before disconnecting the remote party
Public property | CampaignGroup | The (optional) logical group that the campaign belongs to.
Public property | CampaignStatsInterval | The interval at which campaign statistics are gathered and logged.
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' CampaignConfiguration..::..Property >)>)>.)
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | ContactColumns | The Ids of the contact columns used in contact queries. This is only used if CustomizeContactColumns is true
Public property | ContactList | The Id of the Contact List used by the campaign
Public property | CopyDialerAttributesToCallAttributes | Toggles whether to copy contact attributes (columns/values) to the call's attributes before forwarding the call to an Attendant Profile.
Public property | CustomDNCSource | The Id of the Custom Do-Not-Call source object used by the campaign.
Public property | CustomizeContactColumns | Specifies if contact columns use the customized list available in ContactColumns
Public property | CustomScriptURL | The URL of the first HTML page displayed by the custom script used by this campaign. Leave blank if using a base script.
Public property | DialingActive | Specifies if the campaign is currently running, whether manually controlled or automatically scheduled.
Public property | DialingAutoOnOff | Specifies if the campaign is currently running under the control of a dialing schedule.
Public property | DialingPace | (Deprecated) The aggressiveness of outbound dialing ranging from -100 (not aggressive) to 100 (very aggressive).
Public property | DialingPriority | The level of importance of this campaign in relation to other running campaigns
Public property | DialingSchedule | The Id of the dialing schedule used by the campaign.
Public property | DialingScheduledOnly | Toggles whether the campaign should only dial scheduled callbacks.
Public property | DisplayTransitionAlerts | Specifies if the client should alert users when the active rule group changes.
Public property | DNCExclusionId | The Id of the Do-Not-Call exclusion object used by the campaign.
Public property | DNCSource | The Id of the Do-Not-Call source object used by the campaign.
Public property | EnableAnsweringMachineDetection | Toggles whether call analysis should also attempt to detect answering machines.
Public property | EnableCallAnalysis | Toggles the use of call analysis to determine the nature of the connected party (live person, fax machine, etc).
Public property | EnableMaxPreviewTime | Toggles the use of max preview time when using Preview for CallingMode.
Public property | FilterAutoscheduledCallbacks | Toggles the application of filter criteria when querying for auto-scheduled callbacks.
Public property | Filters | The Ids of the filters used in contact queries.
Public property | FilterScheduledCallbacks | Toggles the application of filter criteria when querying for scheduled callbacks.
Public property | FollowUpStatus | The status that Dialer sets the agent to when a Dialer call disconnects but has not been dispositioned yet.
Public property | InboundWorkgroups | Workgroup-specific thresholds used to automatically disable or enable prediction in blended environments.
Public property | IncludeNoAgentAsAbandon | Specifies the manner in which calls with no agents available are considered abandoned.
Public property | IncludeRemoteHangupAsAbandon | Specifies the manner in which calls disconnected by the remote party are considered abandoned.
Public property | IncludeSystemHangupAsAbandon | Specifies the manner in which calls disconnected by the system are considered abandoned.
Public property | InitialCallsPerRequest | The number of calls to place when contact rate information is not yet available, such as when a campaign starts.
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsExporting | Tells whether the current object is being used for exporting
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | IsNonDialerStatDisabled | If true, Dialer will not reserve agents for non-Dialer calls, decreasing idle times for blended sites.
Public property | KeepOpen | Toggles whether the Scripter client should keep the campaign's script open between calls
Public property | MaxAbandonRate | The maximum percentage of calls that are abandoned the dialing server will allow before adjusting the dialing pace.
Public property | MaxAgentCallbackReschedules | The maximum number of reschedule delays before an own-agent callback is converted into a campaign-wide callback and placed immediately.
Public property | MaxAttempts | The maximum number of times a contact record will be dialed before it is marked as uncallable.
Public property | MaxAttemptsPerPhoneNumber | The maximum number of times a phone number will be dialed before it is marked as uncallable.
Public property | MaxDailyAttempts | The maximum number of times a phone number can be dialed in one day.
Public property | MaxDailyAttemptsDefinition | The maximum number of times a contact can be dialed in one day regardless of how many phone numbers the contact contains.
Public property | MaxLines | The maximum number of lines a campaign may use.
Public property | MaxPreviewSeconds | The maximum number of seconds a user may preview a number.
Public property | MaxRecycles | The number of additional times the system will go through the contact list before ending the campaign.
Public property | MinimumNextDial | The minimum number of minutes that must elapse before a phone number may be dialed again.
Public property | NoAgentAbandonDelay | The number of seconds that may elapse before a call with no available agent is considered to be abandoned.
Public property | NoAnswerTimeout | The number of seconds the system will wait for a contact to answer before disconnecting the call.
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | OutboundDialingLineType | Specifies whether the campaign should adhere strictly to a dial plan, or use one specific line group.
Public property | OutboundDialPlanLocation | The dial plan location used by the campaign.
Public property | OutboundLinegroup | The name of the line group used by the campaign.
Public property | OutboundSMSEnabled | Specifies whether outbound SMS is enabled or disabled.
Public property | OverallInboundHighThreshold | The number of inbound waiting calls in the ACD workgroup that will cause the dialing server to stop making predictions.
Public property | OverallInboundLowThreshold | The number of inbound waiting calls in the ACD workgroup that will cause the dialing server to resume making predictions.
Public property | Paused | Pauses or unpauses the campaign.
Public property | PersistentConnectionWavFile | The wave audio file to play to Scripter client users upon a succcessful login.
Public property | PolicySets | The Ids of the Policy Sets used by the campaign.
Public property | PriorityDialingEnabled | Toggles the priority (just-in-time) dialing feature.
Public property | PriorityQueryFrequency | The interval (in seconds) at which the dialing server queries for contacts marked as priority (just-in-time).
Public property | PrioritySortColumns | Criteria for sorting the contact list by column when querying for priority (just-in-time) calls.
Public property | QueryTimeFilters | The Ids of the filters used in phone number details queries.
Public property | RecyclesRemaining | The number of recycles left to be executed in order for the campaign to complete. This property is read-only.
Public property | RecycleTable | The name of the database table containing recycle information for the campaign. This value is automatically generated by the central campaign server and is read-only.
Public property | RemoteHangUpAbandonDelay | The amount of time (in seconds) before a call is disconnected by the remote party which designates the call as abandoned.
Public property | RescheduleDelay | The amount of time (in minutes) the system will wait before checking if an agent is available to take an auto-scheduled callback. The delay process is repeated if the agent is stil not available, up to the number of attempts specified by MaxAgentCallbackReschedules.
Public property | RevisionLevel | The current version of this object. This property is read-only.
Public property | RuleSet | The Id of the Rule Set assigned to the campaign.
Public property | Sequence | The Id of the Sequence assigned to the campaign.
Public property | Servers | The Ids of dialing servers participating in the campaign.
Public property | SkillSets | The Ids of Skill Sets used by this campaign for skills-based dialing.
Public property | SMSBroker | The name of the SMS Broker used by the campaign.
Public property | SMSBrokerAccount | The name of the SMS Broker Account used by the campaign.
Public property | SortColumns | Criteria for sorting the contact list by column.
Public property | StrictMaxAbandon | Toggles the forcing of the system to adhere to maximum abandon rate settings.
Public property | SupervisorAccess | Returns a boolean based on the user's ability to perform certain Supervisor-related tasks on the campaign. Examples of such actions are: stopping, starting, turning the campaign on in scheduled calls only mode, pausing, unpausing, recycling and resetting the campaign.
Public property | TimeZoneAutoMappingMode | The manner in which to map phone numbers to time zones
Public property | UseAllDialingServers | Specifies whether this campaign should use every ODS available when dialing. Setting this property to trueTruetruetrue (True in Visual Basic) will clear the Servers collection except for one special "All Servers" object.
Public property | UseAutoScheduleSettingsForAgentCallbacks | Toggles whether this campaign's Auto-Schedule settings apply to own-agent callbacks.
Public property | UseBulkApi | Toggles the use of the Bulk Call API, allowing higher call throughput using less system resources.
Public property | UseCallingTimeRestrictions | Toggles the use of DNC.Com's Calling Time Restrictions flag.
Public property | UseCallingTimeWindow | Toggles the use of DNC.Com's Calling Time Window flag.
Public property | UseContactListZone | Toggles the use of contact record zone for zone blocking.
Public property | UseDefaultZoneForZoneBlocking | Toggles the use of default zone for zone blocking.
Public property | UseDoNotCallToday | Toggles the use of DNC.Com's Do not call today flag.
Public property | UsePermissionEbr | Toggles the use of DNC.Com's Use Permission EBR flag.
Public property | ZoneSet | The Id of the Zone Set used by this campaign.

See Also

CampaignConfiguration Class


AbandonRateCalculation Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AbandonRateCalculation Property
CampaignConfiguration Class See Also Send Feedback
The manner in which the abandon rate is calculated.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, AbandonCalculationMode> AbandonRateCalculation { get; }
Visual Basic
Public ReadOnly Property AbandonRateCalculation As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, AbandonCalculationMode)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AcdAgentAvailableTimeInterval Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AcdAgentAvailableTimeInterval Property
CampaignConfiguration Class See Also Send Feedback
The amount of time (in seconds) before incrementing agent available time/>

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> AcdAgentAvailableTimeInterval { get; }
Visual Basic
Public ReadOnly Property AcdAgentAvailableTimeInterval As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AcdAgentAvailableTimeWeight Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AcdAgentAvailableTimeWeight Property
CampaignConfiguration Class See Also Send Feedback
The level of importance for agent available time in the agent score formula

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, double> AcdAgentAvailableTimeWeight { get; }
Visual Basic
Public ReadOnly Property AcdAgentAvailableTimeWeight As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Double)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AcdAgentCostWeight Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AcdAgentCostWeight Property
CampaignConfiguration Class See Also Send Feedback
The level of importance for agent cost in the agent score formula

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, double> AcdAgentCostWeight { get; }
Visual Basic
Public ReadOnly Property AcdAgentCostWeight As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Double)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AcdAgentSkillWeight Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AcdAgentSkillWeight Property
CampaignConfiguration Class See Also Send Feedback
The level of importance for agent skill in the agent score formula

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, double> AcdAgentSkillWeight { get; }
Visual Basic
Public ReadOnly Property AcdAgentSkillWeight As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Double)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AcdPriorityLevel Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AcdPriorityLevel Property
CampaignConfiguration Class See Also Send Feedback
The level of importance of call priority in the call score formula

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> AcdPriorityLevel { get; }
Visual Basic
Public ReadOnly Property AcdPriorityLevel As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AcdPriorityWeight Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AcdPriorityWeight Property
CampaignConfiguration Class See Also Send Feedback
The priority assigned to calls

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, double> AcdPriorityWeight { get; }
Visual Basic
Public ReadOnly Property AcdPriorityWeight As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Double)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AcdSkillsWeight Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AcdSkillsWeight Property
CampaignConfiguration Class See Also Send Feedback
The level of importance of agent skill in the call score formula

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, double> AcdSkillsWeight { get; }
Visual Basic
Public ReadOnly Property AcdSkillsWeight As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Double)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AcdTimeInQueueWeight Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AcdTimeInQueueWeight Property
CampaignConfiguration Class See Also Send Feedback
The level of importance of time spent in queue in the call score formula

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, double> AcdTimeInQueueWeight { get; }
Visual Basic
Public ReadOnly Property AcdTimeInQueueWeight As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Double)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AcdTimeInSystemWeight Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AcdTimeInSystemWeight Property
CampaignConfiguration Class See Also Send Feedback
The amount of time (in seconds) before increasing the time in system value

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, double> AcdTimeInSystemWeight { get; }
Visual Basic
Public ReadOnly Property AcdTimeInSystemWeight As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Double)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AcdWorkgroup Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AcdWorkgroup Property
CampaignConfiguration Class See Also Send Feedback
The ACD workgroup used by the dialing server

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, ConfigurationId> AcdWorkgroup { get; }
Visual Basic
Public ReadOnly Property AcdWorkgroup As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, ConfigurationId)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


ActiveRuleGroup Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..ActiveRuleGroup Property
CampaignConfiguration Class See Also Send Feedback
The activue rule group associated with the campaign RuleSet.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, string> ActiveRuleGroup { get; }
Visual Basic
Public ReadOnly Property ActiveRuleGroup As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, String)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AgentlessAllowAcdIfNoAgentAvailable Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AgentlessAllowAcdIfNoAgentAvailable Property
CampaignConfiguration Class See Also Send Feedback
Toggles ACD routing when no agent is available to take a call. If enabled, the called party is immediately rerouted to a newly available agent. If disabled, the call is disconnected after any specified wave audio file or Attendant Profile completes, even if an agent becomes available.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, bool> AgentlessAllowAcdIfNoAgentAvailable { get; }
Visual Basic
Public ReadOnly Property AgentlessAllowAcdIfNoAgentAvailable As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AgentlessAnsweringMachineAttendantProfile Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AgentlessAnsweringMachineAttendantProfile Property
CampaignConfiguration Class See Also Send Feedback
The Attendant Profile to route the call to when an answering machine is encountered.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, ConfigurationId> AgentlessAnsweringMachineAttendantProfile { get; }
Visual Basic
Public ReadOnly Property AgentlessAnsweringMachineAttendantProfile As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, ConfigurationId)
    Get

Remarks

The AgentlessAnsweringMachineType property must be set to RouteToAttendantProfile in order for this property to apply.

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AgentlessAnsweringMachineFile Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AgentlessAnsweringMachineFile Property
CampaignConfiguration Class See Also Send Feedback
The wave audio file to play when an answering machine is encountered.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, string> AgentlessAnsweringMachineFile { get; }
Visual Basic
Public ReadOnly Property AgentlessAnsweringMachineFile As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, String)
    Get

Remarks

The AgentlessAnsweringMachineType property must be set to PlayFile in order for this property to apply.

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AgentlessAnsweringMachineSecondsOfSilence Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AgentlessAnsweringMachineSecondsOfSilence Property
CampaignConfiguration Class See Also Send Feedback
The amount of time the system will wait before playing a wave audio file to an answering machine.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, double> AgentlessAnsweringMachineSecondsOfSilence { get; }
Visual Basic
Public ReadOnly Property AgentlessAnsweringMachineSecondsOfSilence As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Double)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AgentlessAnsweringMachineType Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AgentlessAnsweringMachineType Property
CampaignConfiguration Class See Also Send Feedback
The action to perform when an answering machine is encountered.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, AgentlessAction> AgentlessAnsweringMachineType { get; }
Visual Basic
Public ReadOnly Property AgentlessAnsweringMachineType As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, AgentlessAction)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members
ININ.IceLib.Configuration.Dialer Namespace
CampaignConfiguration..::..AgentlessAnsweringMachineAttendantProfile
CampaignConfiguration..::..AgentlessAnsweringMachineFile


AgentlessFaxAttendantProfile Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AgentlessFaxAttendantProfile Property
CampaignConfiguration Class See Also Send Feedback
The Attendant Profile to route the call to when a fax machine is encountered.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, ConfigurationId> AgentlessFaxAttendantProfile { get; }
Visual Basic
Public ReadOnly Property AgentlessFaxAttendantProfile As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, ConfigurationId)
    Get

Remarks

The AgentlessFaxType property must be set to RouteToAttendantProfile in order for this property to apply.

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AgentlessFaxFile Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AgentlessFaxFile Property
CampaignConfiguration Class See Also Send Feedback
The fax file (.i3f) to play when a fax machine is encountered.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, string> AgentlessFaxFile { get; }
Visual Basic
Public ReadOnly Property AgentlessFaxFile As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, String)
    Get

Remarks

The AgentlessFaxType property must be set to PlayFile in order for this property to apply.

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AgentlessFaxMaxRetries Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AgentlessFaxMaxRetries Property
CampaignConfiguration Class See Also Send Feedback
The maximum number of times a fax machine may be encountered before the contact is considered a failure.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> AgentlessFaxMaxRetries { get; }
Visual Basic
Public ReadOnly Property AgentlessFaxMaxRetries As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AgentlessFaxType Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AgentlessFaxType Property
CampaignConfiguration Class See Also Send Feedback
The action to perform when a fax machine is encountered.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, AgentlessAction> AgentlessFaxType { get; }
Visual Basic
Public ReadOnly Property AgentlessFaxType As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, AgentlessAction)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members
ININ.IceLib.Configuration.Dialer Namespace
CampaignConfiguration..::..AgentlessFaxAttendantProfile
CampaignConfiguration..::..AgentlessFaxFile


AgentlessFileRepeat Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AgentlessFileRepeat Property
CampaignConfiguration Class See Also Send Feedback
The number of additional times a file should be played. A ten second period of silence separates each play.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> AgentlessFileRepeat { get; }
Visual Basic
Public ReadOnly Property AgentlessFileRepeat As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AgentlessLiveAttendantProfile Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AgentlessLiveAttendantProfile Property
CampaignConfiguration Class See Also Send Feedback
The Attendant Profile to route the call to when a live person is reached.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, ConfigurationId> AgentlessLiveAttendantProfile { get; }
Visual Basic
Public ReadOnly Property AgentlessLiveAttendantProfile As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, ConfigurationId)
    Get

Remarks

The AgentlessLiveType property must be set to RouteToAttendantProfile in order for this property to apply.

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AgentlessLiveFile Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AgentlessLiveFile Property
CampaignConfiguration Class See Also Send Feedback
The wave audio file to play when a live person is reached.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, string> AgentlessLiveFile { get; }
Visual Basic
Public ReadOnly Property AgentlessLiveFile As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, String)
    Get

Remarks

The AgentlessLiveType property must be set to PlayFile in order for this property to apply.

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AgentlessLiveType Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AgentlessLiveType Property
CampaignConfiguration Class See Also Send Feedback
The action to perform when a live person is reached.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, AgentlessAction> AgentlessLiveType { get; }
Visual Basic
Public ReadOnly Property AgentlessLiveType As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, AgentlessAction)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members
ININ.IceLib.Configuration.Dialer Namespace
CampaignConfiguration..::..AgentlessLiveAttendantProfile
CampaignConfiguration..::..AgentlessLiveFile


AgentlessNoAgentAttendantProfile Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AgentlessNoAgentAttendantProfile Property
CampaignConfiguration Class See Also Send Feedback
The Attendant Profile to route the call to when no agent is available to take the call.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, ConfigurationId> AgentlessNoAgentAttendantProfile { get; }
Visual Basic
Public ReadOnly Property AgentlessNoAgentAttendantProfile As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, ConfigurationId)
    Get

Remarks

The AgentlessNoAgentType property must be set to RouteToAttendantProfile in order for this property to apply.

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AgentlessNoAgentFile Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AgentlessNoAgentFile Property
CampaignConfiguration Class See Also Send Feedback
The wave audio file to play when no agent is available to take the call.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, string> AgentlessNoAgentFile { get; }
Visual Basic
Public ReadOnly Property AgentlessNoAgentFile As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, String)
    Get

Remarks

The AgentlessNoAgentType property must be set to PlayFile in order for this property to apply.

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AgentlessNoAgentType Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AgentlessNoAgentType Property
CampaignConfiguration Class See Also Send Feedback
The action to perform when no agent is available to take the call.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, AgentlessAction> AgentlessNoAgentType { get; }
Visual Basic
Public ReadOnly Property AgentlessNoAgentType As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, AgentlessAction)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members
ININ.IceLib.Configuration.Dialer Namespace
CampaignConfiguration..::..AgentlessNoAgentFile
CampaignConfiguration..::..AgentlessNoAgentAttendantProfile


AgentOwnedCallbackCacheTimeout Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AgentOwnedCallbackCacheTimeout Property
CampaignConfiguration Class See Also Send Feedback
The interval in minutes to check for agent-owned callbacks and either reschedule or flush them out.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> AgentOwnedCallbackCacheTimeout { get; }
Visual Basic
Public ReadOnly Property AgentOwnedCallbackCacheTimeout As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AutomapTimeZone Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AutomapTimeZone Property
CampaignConfiguration Class See Also Send Feedback
Toggles automatic mapping of phone numbers to a predefined zone

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, bool> AutomapTimeZone { get; }
Visual Basic
Public ReadOnly Property AutomapTimeZone As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AutopacingMaxPace Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AutopacingMaxPace Property
CampaignConfiguration Class See Also Send Feedback
The upper limit on dialing pace. Auto-adjustments may not exceed this value.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> AutopacingMaxPace { get; }
Visual Basic
Public ReadOnly Property AutopacingMaxPace As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AutoscheduleAnsweringMachineMaxAttempts Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AutoscheduleAnsweringMachineMaxAttempts Property
CampaignConfiguration Class See Also Send Feedback
The maximum number of times a rescheduled call may reach an answering machine before the contact is marked as uncallable

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> AutoscheduleAnsweringMachineMaxAttempts { get; }
Visual Basic
Public ReadOnly Property AutoscheduleAnsweringMachineMaxAttempts As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AutoscheduleAnsweringMachineRescheduleDelay Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AutoscheduleAnsweringMachineRescheduleDelay Property
CampaignConfiguration Class See Also Send Feedback
The number of minutes the system will wait before retrying a call that previously reached an answering machine

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> AutoscheduleAnsweringMachineRescheduleDelay { get; }
Visual Basic
Public ReadOnly Property AutoscheduleAnsweringMachineRescheduleDelay As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AutoscheduleBusyMaxAttempts Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AutoscheduleBusyMaxAttempts Property
CampaignConfiguration Class See Also Send Feedback
The maximum number of times a rescheduled call may encounter a busy signal before the contact is marked as uncallable

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> AutoscheduleBusyMaxAttempts { get; }
Visual Basic
Public ReadOnly Property AutoscheduleBusyMaxAttempts As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AutoscheduleBusyRescheduleDelay Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AutoscheduleBusyRescheduleDelay Property
CampaignConfiguration Class See Also Send Feedback
The number of minutes the system will wait before retrying a call that previously encountered a busy signal

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> AutoscheduleBusyRescheduleDelay { get; }
Visual Basic
Public ReadOnly Property AutoscheduleBusyRescheduleDelay As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AutoscheduledCallsIgnoreRecycles Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AutoscheduledCallsIgnoreRecycles Property
CampaignConfiguration Class See Also Send Feedback
When enabled, auto-scheduled calls are flagged so that future recycles of the contact list do not dial this entry as a normal contact

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, bool> AutoscheduledCallsIgnoreRecycles { get; }
Visual Basic
Public ReadOnly Property AutoscheduledCallsIgnoreRecycles As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AutoscheduleFaxMaxAttempts Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AutoscheduleFaxMaxAttempts Property
CampaignConfiguration Class See Also Send Feedback
The maximum number of times a rescheduled call may reach a fax machine before the contact is marked as uncallable

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> AutoscheduleFaxMaxAttempts { get; }
Visual Basic
Public ReadOnly Property AutoscheduleFaxMaxAttempts As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AutoscheduleFaxRescheduleDelay Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AutoscheduleFaxRescheduleDelay Property
CampaignConfiguration Class See Also Send Feedback
The number of minutes the system will wait before retrying a call that previously reached a fax machine

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> AutoscheduleFaxRescheduleDelay { get; }
Visual Basic
Public ReadOnly Property AutoscheduleFaxRescheduleDelay As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AutoscheduleNoAnswerMaxAttempts Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AutoscheduleNoAnswerMaxAttempts Property
CampaignConfiguration Class See Also Send Feedback
The maximum number of times the system will call a contact that is not answering before it is marked as uncallable

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> AutoscheduleNoAnswerMaxAttempts { get; }
Visual Basic
Public ReadOnly Property AutoscheduleNoAnswerMaxAttempts As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AutoscheduleNoAnswerRescheduleDelay Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AutoscheduleNoAnswerRescheduleDelay Property
CampaignConfiguration Class See Also Send Feedback
The number of minutes the system will wait before retrying a call that previously received no answer

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> AutoscheduleNoAnswerRescheduleDelay { get; }
Visual Basic
Public ReadOnly Property AutoscheduleNoAnswerRescheduleDelay As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AutoscheduleRemoteHangupMaxAttempts Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AutoscheduleRemoteHangupMaxAttempts Property
CampaignConfiguration Class See Also Send Feedback
The maximum number of times a rescheduled call may be disconnected by the remote party before the contact is marked as uncallable

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> AutoscheduleRemoteHangupMaxAttempts { get; }
Visual Basic
Public ReadOnly Property AutoscheduleRemoteHangupMaxAttempts As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AutoscheduleRemoteHangupRescheduleDelay Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AutoscheduleRemoteHangupRescheduleDelay Property
CampaignConfiguration Class See Also Send Feedback
The number of minutes the system will wait before retrying a call that was terminated by the remote party

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> AutoscheduleRemoteHangupRescheduleDelay { get; }
Visual Basic
Public ReadOnly Property AutoscheduleRemoteHangupRescheduleDelay As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AutoscheduleSystemHangupMaxAttempts Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AutoscheduleSystemHangupMaxAttempts Property
CampaignConfiguration Class See Also Send Feedback
The maximum number of times the system will call a contact back if the system itself terminated the call before marking the contact as uncallable

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> AutoscheduleSystemHangupMaxAttempts { get; }
Visual Basic
Public ReadOnly Property AutoscheduleSystemHangupMaxAttempts As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


AutoscheduleSystemHangupRescheduleDelay Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..AutoscheduleSystemHangupRescheduleDelay Property
CampaignConfiguration Class See Also Send Feedback
The number of minutes the system will wait before retrying a call that was terminated by the system itself

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> AutoscheduleSystemHangupRescheduleDelay { get; }
Visual Basic
Public ReadOnly Property AutoscheduleSystemHangupRescheduleDelay As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


BaseScript Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..BaseScript Property
CampaignConfiguration Class See Also Send Feedback
The Id of the Base Script used by the campaign

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, ConfigurationId> BaseScript { get; }
Visual Basic
Public ReadOnly Property BaseScript As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, ConfigurationId)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members
CampaignConfiguration..::..CustomScriptURL


CallerIdDisplayName Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CallerIdDisplayName Property
CampaignConfiguration Class See Also Send Feedback
The name that contacts will see on Caller ID devices

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, string> CallerIdDisplayName { get; }
Visual Basic
Public ReadOnly Property CallerIdDisplayName As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, String)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


CallerIdDisplayNumber Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CallerIdDisplayNumber Property
CampaignConfiguration Class See Also Send Feedback
The telephone number that contacts will see on Caller ID devices

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, string> CallerIdDisplayNumber { get; }
Visual Basic
Public ReadOnly Property CallerIdDisplayNumber As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, String)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


CallingMode Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CallingMode Property
CampaignConfiguration Class See Also Send Feedback
The calling mode of the campaign.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, CampaignDialingMode> CallingMode { get; }
Visual Basic
Public ReadOnly Property CallingMode As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, CampaignDialingMode)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members
ININ.IceLib.Configuration.Dialer Namespace
ININ.IceLib.Configuration.Dialer.DataTypes..::..CampaignDialingMode


CallStages Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CallStages Property
CampaignConfiguration Class See Also Send Feedback
The Id of the Stage Set used by the campaign

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, ConfigurationId> CallStages { get; }
Visual Basic
Public ReadOnly Property CallStages As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, ConfigurationId)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


CallTimeoutSeconds Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CallTimeoutSeconds Property
CampaignConfiguration Class See Also Send Feedback
The amount of time (in seconds) the system will wait for an available agent before disconnecting the remote party

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> CallTimeoutSeconds { get; }
Visual Basic
Public ReadOnly Property CallTimeoutSeconds As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


CampaignGroup Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CampaignGroup Property
CampaignConfiguration Class See Also Send Feedback
The (optional) logical group that the campaign belongs to.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, string> CampaignGroup { get; }
Visual Basic
Public ReadOnly Property CampaignGroup As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, String)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


CampaignStatsInterval Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CampaignStatsInterval Property
CampaignConfiguration Class See Also Send Feedback
The interval at which campaign statistics are gathered and logged.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> CampaignStatsInterval { get; }
Visual Basic
Public ReadOnly Property CampaignStatsInterval As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


ContactColumns Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..ContactColumns Property
CampaignConfiguration Class See Also Send Feedback
The Ids of the contact columns used in contact queries. This is only used if CustomizeContactColumns is true

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, Collection<ConfigurationId>> ContactColumns { get; }
Visual Basic
Public ReadOnly Property ContactColumns As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members
CampaignConfiguration..::..CustomizeContactColumns


ContactList Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..ContactList Property
CampaignConfiguration Class See Also Send Feedback
The Id of the Contact List used by the campaign

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, ConfigurationId> ContactList { get; }
Visual Basic
Public ReadOnly Property ContactList As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, ConfigurationId)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


CopyDialerAttributesToCallAttributes Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CopyDialerAttributesToCallAttributes Property
CampaignConfiguration Class See Also Send Feedback
Toggles whether to copy contact attributes (columns/values) to the call's attributes before forwarding the call to an Attendant Profile.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, bool> CopyDialerAttributesToCallAttributes { get; }
Visual Basic
Public ReadOnly Property CopyDialerAttributesToCallAttributes As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


CustomDNCSource Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CustomDNCSource Property
CampaignConfiguration Class See Also Send Feedback
The Id of the Custom Do-Not-Call source object used by the campaign.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, ConfigurationId> CustomDNCSource { get; }
Visual Basic
Public ReadOnly Property CustomDNCSource As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, ConfigurationId)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


CustomizeContactColumns Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CustomizeContactColumns Property
CampaignConfiguration Class See Also Send Feedback
Specifies if contact columns use the customized list available in ContactColumns

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, bool> CustomizeContactColumns { get; }
Visual Basic
Public ReadOnly Property CustomizeContactColumns As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members
CampaignConfiguration..::..ContactColumns


CustomScriptURL Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CustomScriptURL Property
CampaignConfiguration Class See Also Send Feedback
The URL of the first HTML page displayed by the custom script used by this campaign. Leave blank if using a base script.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, string> CustomScriptURL { get; }
Visual Basic
Public ReadOnly Property CustomScriptURL As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, String)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


DialingActive Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..DialingActive Property
CampaignConfiguration Class See Also Send Feedback
Specifies if the campaign is currently running, whether manually controlled or automatically scheduled.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, bool> DialingActive { get; }
Visual Basic
Public ReadOnly Property DialingActive As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members
CampaignConfiguration..::..DialingAutoOnOff


DialingAutoOnOff Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..DialingAutoOnOff Property
CampaignConfiguration Class See Also Send Feedback
Specifies if the campaign is currently running under the control of a dialing schedule.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, bool> DialingAutoOnOff { get; }
Visual Basic
Public ReadOnly Property DialingAutoOnOff As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members
CampaignConfiguration..::..DialingSchedule


DialingPace Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..DialingPace Property
CampaignConfiguration Class See Also Send Feedback
(Deprecated) The aggressiveness of outbound dialing ranging from -100 (not aggressive) to 100 (very aggressive).

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> DialingPace { get; }
Visual Basic
Public ReadOnly Property DialingPace As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Remarks

For control of the campaign's pace, use the AutopacingMaxPace property.

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


DialingPriority Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..DialingPriority Property
CampaignConfiguration Class See Also Send Feedback
The level of importance of this campaign in relation to other running campaigns

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> DialingPriority { get; }
Visual Basic
Public ReadOnly Property DialingPriority As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


DialingSchedule Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..DialingSchedule Property
CampaignConfiguration Class See Also Send Feedback
The Id of the dialing schedule used by the campaign.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, ConfigurationId> DialingSchedule { get; }
Visual Basic
Public ReadOnly Property DialingSchedule As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, ConfigurationId)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


DialingScheduledOnly Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..DialingScheduledOnly Property
CampaignConfiguration Class See Also Send Feedback
Toggles whether the campaign should only dial scheduled callbacks.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, bool> DialingScheduledOnly { get; }
Visual Basic
Public ReadOnly Property DialingScheduledOnly As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


DisplayTransitionAlerts Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..DisplayTransitionAlerts Property
CampaignConfiguration Class See Also Send Feedback
Specifies if the client should alert users when the active rule group changes.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, bool> DisplayTransitionAlerts { get; }
Visual Basic
Public ReadOnly Property DisplayTransitionAlerts As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


DNCExclusionId Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..DNCExclusionId Property
CampaignConfiguration Class See Also Send Feedback
The Id of the Do-Not-Call exclusion object used by the campaign.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, ConfigurationId> DNCExclusionId { get; }
Visual Basic
Public ReadOnly Property DNCExclusionId As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, ConfigurationId)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


DNCSource Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..DNCSource Property
CampaignConfiguration Class See Also Send Feedback
The Id of the Do-Not-Call source object used by the campaign.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, ConfigurationId> DNCSource { get; }
Visual Basic
Public ReadOnly Property DNCSource As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, ConfigurationId)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


EnableAnsweringMachineDetection Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..EnableAnsweringMachineDetection Property
CampaignConfiguration Class See Also Send Feedback
Toggles whether call analysis should also attempt to detect answering machines.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, bool> EnableAnsweringMachineDetection { get; }
Visual Basic
Public ReadOnly Property EnableAnsweringMachineDetection As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Boolean)
    Get

Remarks

This setting is ignored if EnableCallAnalysis is disabled.

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


EnableCallAnalysis Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..EnableCallAnalysis Property
CampaignConfiguration Class See Also Send Feedback
Toggles the use of call analysis to determine the nature of the connected party (live person, fax machine, etc).

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, bool> EnableCallAnalysis { get; }
Visual Basic
Public ReadOnly Property EnableCallAnalysis As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


EnableMaxPreviewTime Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..EnableMaxPreviewTime Property
CampaignConfiguration Class See Also Send Feedback
Toggles the use of max preview time when using Preview for CallingMode.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, bool> EnableMaxPreviewTime { get; }
Visual Basic
Public ReadOnly Property EnableMaxPreviewTime As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


FilterAutoscheduledCallbacks Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..FilterAutoscheduledCallbacks Property
CampaignConfiguration Class See Also Send Feedback
Toggles the application of filter criteria when querying for auto-scheduled callbacks.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, bool> FilterAutoscheduledCallbacks { get; }
Visual Basic
Public ReadOnly Property FilterAutoscheduledCallbacks As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members
CampaignConfiguration..::..Filters


Filters Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..Filters Property
CampaignConfiguration Class See Also Send Feedback
The Ids of the filters used in contact queries.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, Collection<ConfigurationId>> Filters { get; }
Visual Basic
Public ReadOnly Property Filters As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members
ININ.IceLib.Configuration.Dialer Namespace
CampaignConfiguration..::..FilterAutoscheduledCallbacks
CampaignConfiguration..::..FilterScheduledCallbacks


FilterScheduledCallbacks Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..FilterScheduledCallbacks Property
CampaignConfiguration Class See Also Send Feedback
Toggles the application of filter criteria when querying for scheduled callbacks.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, bool> FilterScheduledCallbacks { get; }
Visual Basic
Public ReadOnly Property FilterScheduledCallbacks As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members
CampaignConfiguration..::..Filters


FollowUpStatus Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..FollowUpStatus Property
CampaignConfiguration Class See Also Send Feedback
The status that Dialer sets the agent to when a Dialer call disconnects but has not been dispositioned yet.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, string> FollowUpStatus { get; }
Visual Basic
Public ReadOnly Property FollowUpStatus As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, String)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


InboundWorkgroups Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..InboundWorkgroups Property
CampaignConfiguration Class See Also Send Feedback
Workgroup-specific thresholds used to automatically disable or enable prediction in blended environments.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, Collection<InboundWorkgroup>> InboundWorkgroups { get; }
Visual Basic
Public ReadOnly Property InboundWorkgroups As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Collection(Of InboundWorkgroup))
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


IncludeNoAgentAsAbandon Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..IncludeNoAgentAsAbandon Property
CampaignConfiguration Class See Also Send Feedback
Specifies the manner in which calls with no agents available are considered abandoned.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, AbandonInclusionMode> IncludeNoAgentAsAbandon { get; }
Visual Basic
Public ReadOnly Property IncludeNoAgentAsAbandon As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, AbandonInclusionMode)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members
CampaignConfiguration..::..NoAgentAbandonDelay


IncludeRemoteHangupAsAbandon Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..IncludeRemoteHangupAsAbandon Property
CampaignConfiguration Class See Also Send Feedback
Specifies the manner in which calls disconnected by the remote party are considered abandoned.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, AbandonInclusionMode> IncludeRemoteHangupAsAbandon { get; }
Visual Basic
Public ReadOnly Property IncludeRemoteHangupAsAbandon As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, AbandonInclusionMode)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members
CampaignConfiguration..::..RemoteHangUpAbandonDelay


IncludeSystemHangupAsAbandon Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..IncludeSystemHangupAsAbandon Property
CampaignConfiguration Class See Also Send Feedback
Specifies the manner in which calls disconnected by the system are considered abandoned.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, AbandonInclusionMode> IncludeSystemHangupAsAbandon { get; }
Visual Basic
Public ReadOnly Property IncludeSystemHangupAsAbandon As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, AbandonInclusionMode)
    Get

Remarks

AfterDelay is NOT a valid option. Only Always and Never are allowed.

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


InitialCallsPerRequest Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..InitialCallsPerRequest Property
CampaignConfiguration Class See Also Send Feedback
The number of calls to place when contact rate information is not yet available, such as when a campaign starts.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> InitialCallsPerRequest { get; }
Visual Basic
Public ReadOnly Property InitialCallsPerRequest As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


IsDefaultObject Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..IsDefaultObject Property
CampaignConfiguration Class See Also Send Feedback
Indicates whether this is the default instance of this object type.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsDefaultObject { get; }
Visual Basic
Public ReadOnly Property IsDefaultObject As Boolean
    Get

See Also

CampaignConfiguration Class
CampaignConfiguration Members


IsExporting Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..IsExporting Property
CampaignConfiguration Class See Also Send Feedback
Tells whether the current object is being used for exporting

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsExporting { get; private set; }
Visual Basic
Public Property IsExporting As Boolean
    Get
    Private Set

See Also

CampaignConfiguration Class
CampaignConfiguration Members


IsNonDialerStatDisabled Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..IsNonDialerStatDisabled Property
CampaignConfiguration Class See Also Send Feedback
If true, Dialer will not reserve agents for non-Dialer calls, decreasing idle times for blended sites.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, bool> IsNonDialerStatDisabled { get; }
Visual Basic
Public ReadOnly Property IsNonDialerStatDisabled As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


KeepOpen Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..KeepOpen Property
CampaignConfiguration Class See Also Send Feedback
Toggles whether the Scripter client should keep the campaign's script open between calls

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, bool> KeepOpen { get; }
Visual Basic
Public ReadOnly Property KeepOpen As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


MaxAbandonRate Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..MaxAbandonRate Property
CampaignConfiguration Class See Also Send Feedback
The maximum percentage of calls that are abandoned the dialing server will allow before adjusting the dialing pace.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, double> MaxAbandonRate { get; }
Visual Basic
Public ReadOnly Property MaxAbandonRate As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Double)
    Get

Remarks

If the value is set to 0.0 or less, the dialing pace will not be adjusted based on the abandon rate.

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members
ININ.IceLib.Configuration.Dialer Namespace
CampaignConfiguration..::..StrictMaxAbandon
CampaignConfiguration..::..AbandonRateCalculation


MaxAgentCallbackReschedules Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..MaxAgentCallbackReschedules Property
CampaignConfiguration Class See Also Send Feedback
The maximum number of reschedule delays before an own-agent callback is converted into a campaign-wide callback and placed immediately.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> MaxAgentCallbackReschedules { get; }
Visual Basic
Public ReadOnly Property MaxAgentCallbackReschedules As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Remarks

A value of -1 indicates that own-agent callbacks should not be converted into campaign-wide callbacks.

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members
CampaignConfiguration..::..RescheduleDelay


MaxAttempts Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..MaxAttempts Property
CampaignConfiguration Class See Also Send Feedback
The maximum number of times a contact record will be dialed before it is marked as uncallable.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> MaxAttempts { get; }
Visual Basic
Public ReadOnly Property MaxAttempts As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


MaxAttemptsPerPhoneNumber Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..MaxAttemptsPerPhoneNumber Property
CampaignConfiguration Class See Also Send Feedback
The maximum number of times a phone number will be dialed before it is marked as uncallable.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> MaxAttemptsPerPhoneNumber { get; }
Visual Basic
Public ReadOnly Property MaxAttemptsPerPhoneNumber As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


MaxDailyAttempts Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..MaxDailyAttempts Property
CampaignConfiguration Class See Also Send Feedback
The maximum number of times a phone number can be dialed in one day.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> MaxDailyAttempts { get; }
Visual Basic
Public ReadOnly Property MaxDailyAttempts As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


MaxDailyAttemptsDefinition Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..MaxDailyAttemptsDefinition Property
CampaignConfiguration Class See Also Send Feedback
The maximum number of times a contact can be dialed in one day regardless of how many phone numbers the contact contains.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, MaxDailyAttemptType> MaxDailyAttemptsDefinition { get; }
Visual Basic
Public ReadOnly Property MaxDailyAttemptsDefinition As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, MaxDailyAttemptType)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


MaxLines Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..MaxLines Property
CampaignConfiguration Class See Also Send Feedback
The maximum number of lines a campaign may use.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> MaxLines { get; }
Visual Basic
Public ReadOnly Property MaxLines As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


MaxPreviewSeconds Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..MaxPreviewSeconds Property
CampaignConfiguration Class See Also Send Feedback
The maximum number of seconds a user may preview a number.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> MaxPreviewSeconds { get; }
Visual Basic
Public ReadOnly Property MaxPreviewSeconds As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


MaxRecycles Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..MaxRecycles Property
CampaignConfiguration Class See Also Send Feedback
The number of additional times the system will go through the contact list before ending the campaign.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> MaxRecycles { get; }
Visual Basic
Public ReadOnly Property MaxRecycles As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Remarks

The word "recycle" in this context means a single passthrough of the contact list, not be confused with the act of recycling, or restarting, the contact list. If, for example, this property is set to 5, the campaign will restart the contact list 4 times, but will go through the contact list 5 times because the initial passthrough does not require a restart.

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


MinimumNextDial Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..MinimumNextDial Property
CampaignConfiguration Class See Also Send Feedback
The minimum number of minutes that must elapse before a phone number may be dialed again.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> MinimumNextDial { get; }
Visual Basic
Public ReadOnly Property MinimumNextDial As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


NoAgentAbandonDelay Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..NoAgentAbandonDelay Property
CampaignConfiguration Class See Also Send Feedback
The number of seconds that may elapse before a call with no available agent is considered to be abandoned.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, double> NoAgentAbandonDelay { get; }
Visual Basic
Public ReadOnly Property NoAgentAbandonDelay As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Double)
    Get

Remarks

The IncludeNoAgentAsAbandon property must be set to AfterDelay in order for this property to apply.

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


NoAnswerTimeout Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..NoAnswerTimeout Property
CampaignConfiguration Class See Also Send Feedback
The number of seconds the system will wait for a contact to answer before disconnecting the call.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> NoAnswerTimeout { get; }
Visual Basic
Public ReadOnly Property NoAnswerTimeout As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


OutboundDialingLineType Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..OutboundDialingLineType Property
CampaignConfiguration Class See Also Send Feedback
Specifies whether the campaign should adhere strictly to a dial plan, or use one specific line group.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, OutboundLineType> OutboundDialingLineType { get; }
Visual Basic
Public ReadOnly Property OutboundDialingLineType As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, OutboundLineType)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members
ININ.IceLib.Configuration.Dialer Namespace
CampaignConfiguration..::..OutboundDialPlanLocation
CampaignConfiguration..::..OutboundLinegroup


OutboundDialPlanLocation Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..OutboundDialPlanLocation Property
CampaignConfiguration Class See Also Send Feedback
The dial plan location used by the campaign.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, ConfigurationId> OutboundDialPlanLocation { get; }
Visual Basic
Public ReadOnly Property OutboundDialPlanLocation As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, ConfigurationId)
    Get

Remarks

The OutboundDialingLineType property must be set to DialPlan for this property to apply.

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members
CampaignConfiguration..::..OutboundDialingLineType


OutboundLinegroup Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..OutboundLinegroup Property
CampaignConfiguration Class See Also Send Feedback
The name of the line group used by the campaign.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, ConfigurationId> OutboundLinegroup { get; }
Visual Basic
Public ReadOnly Property OutboundLinegroup As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, ConfigurationId)
    Get

Remarks

The OutboundDialingLineType property must be set to LineGroup for this property to apply.

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members
CampaignConfiguration..::..OutboundDialingLineType


OutboundSMSEnabled Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..OutboundSMSEnabled Property
CampaignConfiguration Class See Also Send Feedback
Specifies whether outbound SMS is enabled or disabled.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, bool> OutboundSMSEnabled { get; }
Visual Basic
Public ReadOnly Property OutboundSMSEnabled As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


OverallInboundHighThreshold Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..OverallInboundHighThreshold Property
CampaignConfiguration Class See Also Send Feedback
The number of inbound waiting calls in the ACD workgroup that will cause the dialing server to stop making predictions.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> OverallInboundHighThreshold { get; }
Visual Basic
Public ReadOnly Property OverallInboundHighThreshold As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


OverallInboundLowThreshold Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..OverallInboundLowThreshold Property
CampaignConfiguration Class See Also Send Feedback
The number of inbound waiting calls in the ACD workgroup that will cause the dialing server to resume making predictions.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> OverallInboundLowThreshold { get; }
Visual Basic
Public ReadOnly Property OverallInboundLowThreshold As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


Paused Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..Paused Property
CampaignConfiguration Class See Also Send Feedback
Pauses or unpauses the campaign.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, bool> Paused { get; }
Visual Basic
Public ReadOnly Property Paused As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


PersistentConnectionWavFile Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..PersistentConnectionWavFile Property
CampaignConfiguration Class See Also Send Feedback
The wave audio file to play to Scripter client users upon a succcessful login.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, string> PersistentConnectionWavFile { get; }
Visual Basic
Public ReadOnly Property PersistentConnectionWavFile As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, String)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


PolicySets Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..PolicySets Property
CampaignConfiguration Class See Also Send Feedback
The Ids of the Policy Sets used by the campaign.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, Collection<ConfigurationId>> PolicySets { get; }
Visual Basic
Public ReadOnly Property PolicySets As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


PriorityDialingEnabled Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..PriorityDialingEnabled Property
CampaignConfiguration Class See Also Send Feedback
Toggles the priority (just-in-time) dialing feature.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, bool> PriorityDialingEnabled { get; }
Visual Basic
Public ReadOnly Property PriorityDialingEnabled As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


PriorityQueryFrequency Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..PriorityQueryFrequency Property
CampaignConfiguration Class See Also Send Feedback
The interval (in seconds) at which the dialing server queries for contacts marked as priority (just-in-time).

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> PriorityQueryFrequency { get; }
Visual Basic
Public ReadOnly Property PriorityQueryFrequency As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


PrioritySortColumns Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..PrioritySortColumns Property
CampaignConfiguration Class See Also Send Feedback
Criteria for sorting the contact list by column when querying for priority (just-in-time) calls.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, Collection<SortColumn>> PrioritySortColumns { get; }
Visual Basic
Public ReadOnly Property PrioritySortColumns As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Collection(Of SortColumn))
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


QueryTimeFilters Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..QueryTimeFilters Property
CampaignConfiguration Class See Also Send Feedback
The Ids of the filters used in phone number details queries.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, Collection<ConfigurationId>> QueryTimeFilters { get; }
Visual Basic
Public ReadOnly Property QueryTimeFilters As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members
ININ.IceLib.Configuration.Dialer Namespace
CampaignConfiguration..::..FilterAutoscheduledCallbacks
CampaignConfiguration..::..FilterScheduledCallbacks


RecyclesRemaining Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..RecyclesRemaining Property
CampaignConfiguration Class See Also Send Feedback
The number of recycles left to be executed in order for the campaign to complete. This property is read-only.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> RecyclesRemaining { get; }
Visual Basic
Public ReadOnly Property RecyclesRemaining As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members
CampaignConfiguration..::..MaxRecycles


RecycleTable Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..RecycleTable Property
CampaignConfiguration Class See Also Send Feedback
The name of the database table containing recycle information for the campaign. This value is automatically generated by the central campaign server and is read-only.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, string> RecycleTable { get; }
Visual Basic
Public ReadOnly Property RecycleTable As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, String)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


RemoteHangUpAbandonDelay Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..RemoteHangUpAbandonDelay Property
CampaignConfiguration Class See Also Send Feedback
The amount of time (in seconds) before a call is disconnected by the remote party which designates the call as abandoned.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, double> RemoteHangUpAbandonDelay { get; }
Visual Basic
Public ReadOnly Property RemoteHangUpAbandonDelay As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Double)
    Get

Remarks

The IncludeRemoteHangupAsAbandon property must be set to AfterDelay in order for this property to apply.

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


RescheduleDelay Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..RescheduleDelay Property
CampaignConfiguration Class See Also Send Feedback
The amount of time (in minutes) the system will wait before checking if an agent is available to take an auto-scheduled callback. The delay process is repeated if the agent is stil not available, up to the number of attempts specified by MaxAgentCallbackReschedules.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> RescheduleDelay { get; }
Visual Basic
Public ReadOnly Property RescheduleDelay As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members
CampaignConfiguration..::..MaxAgentCallbackReschedules


RevisionLevel Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..RevisionLevel Property
CampaignConfiguration Class See Also Send Feedback
The current version of this object. This property is read-only.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, int> RevisionLevel { get; }
Visual Basic
Public ReadOnly Property RevisionLevel As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Integer)
    Get

See Also

CampaignConfiguration Class
CampaignConfiguration Members


RuleSet Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..RuleSet Property
CampaignConfiguration Class See Also Send Feedback
The Id of the Rule Set assigned to the campaign.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, ConfigurationId> RuleSet { get; }
Visual Basic
Public ReadOnly Property RuleSet As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, ConfigurationId)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


Sequence Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..Sequence Property
CampaignConfiguration Class See Also Send Feedback
The Id of the Sequence assigned to the campaign.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, Sequence> Sequence { get; }
Visual Basic
Public ReadOnly Property Sequence As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Sequence)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


Servers Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..Servers Property
CampaignConfiguration Class See Also Send Feedback
The Ids of dialing servers participating in the campaign.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, Collection<ConfigurationId>> Servers { get; }
Visual Basic
Public ReadOnly Property Servers As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members
CampaignConfiguration..::..UseAllDialingServers


SkillSets Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..SkillSets Property
CampaignConfiguration Class See Also Send Feedback
The Ids of Skill Sets used by this campaign for skills-based dialing.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, Collection<ConfigurationId>> SkillSets { get; }
Visual Basic
Public ReadOnly Property SkillSets As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


SMSBroker Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..SMSBroker Property
CampaignConfiguration Class See Also Send Feedback
The name of the SMS Broker used by the campaign.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, ConfigurationId> SMSBroker { get; }
Visual Basic
Public ReadOnly Property SMSBroker As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, ConfigurationId)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


SMSBrokerAccount Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..SMSBrokerAccount Property
CampaignConfiguration Class See Also Send Feedback
The name of the SMS Broker Account used by the campaign.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, ConfigurationId> SMSBrokerAccount { get; }
Visual Basic
Public ReadOnly Property SMSBrokerAccount As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, ConfigurationId)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


SortColumns Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..SortColumns Property
CampaignConfiguration Class See Also Send Feedback
Criteria for sorting the contact list by column.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, Collection<SortColumn>> SortColumns { get; }
Visual Basic
Public ReadOnly Property SortColumns As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Collection(Of SortColumn))
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


StrictMaxAbandon Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..StrictMaxAbandon Property
CampaignConfiguration Class See Also Send Feedback
Toggles the forcing of the system to adhere to maximum abandon rate settings.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, bool> StrictMaxAbandon { get; }
Visual Basic
Public ReadOnly Property StrictMaxAbandon As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Boolean)
    Get

Remarks

This setting is ignored if the MaxAbandonRate property is set to 0.0 or less.

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members
ININ.IceLib.Configuration.Dialer Namespace
CampaignConfiguration..::..AbandonRateCalculation
CampaignConfiguration..::..MaxAbandonRate


SupervisorAccess Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..SupervisorAccess Property
CampaignConfiguration Class See Also Send Feedback
Returns a boolean based on the user's ability to perform certain Supervisor-related tasks on the campaign. Examples of such actions are: stopping, starting, turning the campaign on in scheduled calls only mode, pausing, unpausing, recycling and resetting the campaign.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool SupervisorAccess { get; }
Visual Basic
Public ReadOnly Property SupervisorAccess As Boolean
    Get

See Also

CampaignConfiguration Class
CampaignConfiguration Members


TimeZoneAutoMappingMode Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..TimeZoneAutoMappingMode Property
CampaignConfiguration Class See Also Send Feedback
The manner in which to map phone numbers to time zones

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, TimeZoneAutoMapping> TimeZoneAutoMappingMode { get; }
Visual Basic
Public ReadOnly Property TimeZoneAutoMappingMode As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, TimeZoneAutoMapping)
    Get

Remarks

The AutomapTimeZone property must be enabled in order for this property to apply.

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members
CampaignConfiguration..::..AutomapTimeZone


UseAllDialingServers Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..UseAllDialingServers Property
CampaignConfiguration Class See Also Send Feedback
Specifies whether this campaign should use every ODS available when dialing. Setting this property to trueTruetruetrue (True in Visual Basic) will clear the Servers collection except for one special "All Servers" object.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool UseAllDialingServers { get; set; }
Visual Basic
Public Property UseAllDialingServers As Boolean
    Get
    Set

See Also

CampaignConfiguration Class
CampaignConfiguration Members


UseAutoScheduleSettingsForAgentCallbacks Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..UseAutoScheduleSettingsForAgentCallbacks Property
CampaignConfiguration Class See Also Send Feedback
Toggles whether this campaign's Auto-Schedule settings apply to own-agent callbacks.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, bool> UseAutoScheduleSettingsForAgentCallbacks { get; }
Visual Basic
Public ReadOnly Property UseAutoScheduleSettingsForAgentCallbacks As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


UseBulkApi Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..UseBulkApi Property
CampaignConfiguration Class See Also Send Feedback
Toggles the use of the Bulk Call API, allowing higher call throughput using less system resources.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, bool> UseBulkApi { get; }
Visual Basic
Public ReadOnly Property UseBulkApi As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


UseCallingTimeRestrictions Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..UseCallingTimeRestrictions Property
CampaignConfiguration Class See Also Send Feedback
Toggles the use of DNC.Com's Calling Time Restrictions flag.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, bool> UseCallingTimeRestrictions { get; }
Visual Basic
Public ReadOnly Property UseCallingTimeRestrictions As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


UseCallingTimeWindow Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..UseCallingTimeWindow Property
CampaignConfiguration Class See Also Send Feedback
Toggles the use of DNC.Com's Calling Time Window flag.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, bool> UseCallingTimeWindow { get; }
Visual Basic
Public ReadOnly Property UseCallingTimeWindow As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


UseContactListZone Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..UseContactListZone Property
CampaignConfiguration Class See Also Send Feedback
Toggles the use of contact record zone for zone blocking.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, bool> UseContactListZone { get; }
Visual Basic
Public ReadOnly Property UseContactListZone As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


UseDefaultZoneForZoneBlocking Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..UseDefaultZoneForZoneBlocking Property
CampaignConfiguration Class See Also Send Feedback
Toggles the use of default zone for zone blocking.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, bool> UseDefaultZoneForZoneBlocking { get; }
Visual Basic
Public ReadOnly Property UseDefaultZoneForZoneBlocking As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


UseDoNotCallToday Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..UseDoNotCallToday Property
CampaignConfiguration Class See Also Send Feedback
Toggles the use of DNC.Com's Do not call today flag.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, bool> UseDoNotCallToday { get; }
Visual Basic
Public ReadOnly Property UseDoNotCallToday As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


UsePermissionEbr Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..UsePermissionEbr Property
CampaignConfiguration Class See Also Send Feedback
Toggles the use of DNC.Com's Use Permission EBR flag.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, bool> UsePermissionEbr { get; }
Visual Basic
Public ReadOnly Property UsePermissionEbr As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


ZoneSet Property

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..ZoneSet Property
CampaignConfiguration Class See Also Send Feedback
The Id of the Zone Set used by this campaign.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CampaignConfiguration..::..Property, ConfigurationId> ZoneSet { get; }
Visual Basic
Public ReadOnly Property ZoneSet As GeneralConfigurationProperty(Of CampaignConfiguration..::..Property, ConfigurationId)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CampaignConfiguration Class
CampaignConfiguration Members


CampaignConfiguration.CampaignTestResults Structure

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CampaignTestResults Structure
CampaignConfiguration Class Members See Also Send Feedback
Contains a series of values returned from the Test(Int32) method.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public struct CampaignTestResults
Visual Basic
Public Structure CampaignTestResults

See Also

CampaignConfiguration..::..CampaignTestResults Members


CampaignConfiguration.CampaignTestResults Members

[image] [image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CampaignTestResults Members
CampaignConfiguration..::..CampaignTestResults Structure Methods Fields See Also Send Feedback

The CampaignConfiguration..::..CampaignTestResults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | CallableRecords | The total number of callable records in the contact list.
Public field | ContactListTable | The name of the contact list table.
Public field | ErrorMessage | Contains a message indicating why the test failed.
Public field | Filter | The SQL clause use to filter records, as it appears in contact list queries.
Public field | FilteredRecords | The total number of records in the contact list blocked after applying filters.
Public field | NoPhoneNumberRecords | The total number of records in the contact list without a phone number.
Public field | NRRLib | Indicates whether the Number Request and Response plug-in is in use.
Public field | QueryTimeFilter | The SQL clause used to filter records, as it appears in phone number detail queries.
Public field | QueryTimeFilteredRecords | The total number of records in the contact list blocked after applying query-time filters.
Public field | SampleRecordColumns | Database table columns corresponding to data in SampleRecords. Included fields are defined contact columns and columns found in Sort.
Public field | SampleRecords | Sample of callable records from the contact list. Included fields can be found in SampleRecordColumns.
Public field | ScheduledCalls | The total number of calls scheduled for records in the contact list.
Public field | SkillCombinationColumns | Database table columns corresponding to data in SkillCombinations.
Public field | SkillCombinations | Breakdown of callable records by skill combination.
Public field | Sort | The SQL clause used to sort contact records, as it appears in contact list queries.
Public field | Success | Indicates whether the test completed without errors. If false, check ErrorMessage for details.
Public field | TotalRecords | The total number of records in the contact list.
Public field | UncallableRecords | The total number of uncallable records in the contact list.

See Also

CampaignConfiguration..::..CampaignTestResults Structure


CampaignConfiguration.CampaignTestResults Fields

[image] [image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CampaignTestResults Fields
CampaignConfiguration..::..CampaignTestResults Structure See Also Send Feedback

The CampaignConfiguration..::..CampaignTestResults type exposes the following members.

Fields

 | Name | Description
Public field | CallableRecords | The total number of callable records in the contact list.
Public field | ContactListTable | The name of the contact list table.
Public field | ErrorMessage | Contains a message indicating why the test failed.
Public field | Filter | The SQL clause use to filter records, as it appears in contact list queries.
Public field | FilteredRecords | The total number of records in the contact list blocked after applying filters.
Public field | NoPhoneNumberRecords | The total number of records in the contact list without a phone number.
Public field | NRRLib | Indicates whether the Number Request and Response plug-in is in use.
Public field | QueryTimeFilter | The SQL clause used to filter records, as it appears in phone number detail queries.
Public field | QueryTimeFilteredRecords | The total number of records in the contact list blocked after applying query-time filters.
Public field | SampleRecordColumns | Database table columns corresponding to data in SampleRecords. Included fields are defined contact columns and columns found in Sort.
Public field | SampleRecords | Sample of callable records from the contact list. Included fields can be found in SampleRecordColumns.
Public field | ScheduledCalls | The total number of calls scheduled for records in the contact list.
Public field | SkillCombinationColumns | Database table columns corresponding to data in SkillCombinations.
Public field | SkillCombinations | Breakdown of callable records by skill combination.
Public field | Sort | The SQL clause used to sort contact records, as it appears in contact list queries.
Public field | Success | Indicates whether the test completed without errors. If false, check ErrorMessage for details.
Public field | TotalRecords | The total number of records in the contact list.
Public field | UncallableRecords | The total number of uncallable records in the contact list.

See Also

CampaignConfiguration..::..CampaignTestResults Structure


CallableRecords Field

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CampaignTestResults..::..CallableRecords Field
CampaignConfiguration..::..CampaignTestResults Structure See Also Send Feedback
The total number of callable records in the contact list.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly int CallableRecords
Visual Basic
Public ReadOnly CallableRecords As Integer

See Also

CampaignConfiguration..::..CampaignTestResults Structure
CampaignConfiguration..::..CampaignTestResults Members


ContactListTable Field

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CampaignTestResults..::..ContactListTable Field
CampaignConfiguration..::..CampaignTestResults Structure See Also Send Feedback
The name of the contact list table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly string ContactListTable
Visual Basic
Public ReadOnly ContactListTable As String

See Also

CampaignConfiguration..::..CampaignTestResults Structure
CampaignConfiguration..::..CampaignTestResults Members


ErrorMessage Field

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CampaignTestResults..::..ErrorMessage Field
CampaignConfiguration..::..CampaignTestResults Structure See Also Send Feedback
Contains a message indicating why the test failed.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly string ErrorMessage
Visual Basic
Public ReadOnly ErrorMessage As String

See Also

CampaignConfiguration..::..CampaignTestResults Structure
CampaignConfiguration..::..CampaignTestResults Members


Filter Field

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CampaignTestResults..::..Filter Field
CampaignConfiguration..::..CampaignTestResults Structure See Also Send Feedback
The SQL clause use to filter records, as it appears in contact list queries.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly string Filter
Visual Basic
Public ReadOnly Filter As String

See Also

CampaignConfiguration..::..CampaignTestResults Structure
CampaignConfiguration..::..CampaignTestResults Members


FilteredRecords Field

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CampaignTestResults..::..FilteredRecords Field
CampaignConfiguration..::..CampaignTestResults Structure See Also Send Feedback
The total number of records in the contact list blocked after applying filters.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly int FilteredRecords
Visual Basic
Public ReadOnly FilteredRecords As Integer

See Also

CampaignConfiguration..::..CampaignTestResults Structure
CampaignConfiguration..::..CampaignTestResults Members


NoPhoneNumberRecords Field

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CampaignTestResults..::..NoPhoneNumberRecords Field
CampaignConfiguration..::..CampaignTestResults Structure See Also Send Feedback
The total number of records in the contact list without a phone number.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly int NoPhoneNumberRecords
Visual Basic
Public ReadOnly NoPhoneNumberRecords As Integer

See Also

CampaignConfiguration..::..CampaignTestResults Structure
CampaignConfiguration..::..CampaignTestResults Members


NRRLib Field

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CampaignTestResults..::..NRRLib Field
CampaignConfiguration..::..CampaignTestResults Structure See Also Send Feedback
Indicates whether the Number Request and Response plug-in is in use.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly bool NRRLib
Visual Basic
Public ReadOnly NRRLib As Boolean

See Also

CampaignConfiguration..::..CampaignTestResults Structure
CampaignConfiguration..::..CampaignTestResults Members


QueryTimeFilter Field

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CampaignTestResults..::..QueryTimeFilter Field
CampaignConfiguration..::..CampaignTestResults Structure See Also Send Feedback
The SQL clause used to filter records, as it appears in phone number detail queries.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly string QueryTimeFilter
Visual Basic
Public ReadOnly QueryTimeFilter As String

See Also

CampaignConfiguration..::..CampaignTestResults Structure
CampaignConfiguration..::..CampaignTestResults Members


QueryTimeFilteredRecords Field

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CampaignTestResults..::..QueryTimeFilteredRecords Field
CampaignConfiguration..::..CampaignTestResults Structure See Also Send Feedback
The total number of records in the contact list blocked after applying query-time filters.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly int QueryTimeFilteredRecords
Visual Basic
Public ReadOnly QueryTimeFilteredRecords As Integer

See Also

CampaignConfiguration..::..CampaignTestResults Structure
CampaignConfiguration..::..CampaignTestResults Members


SampleRecordColumns Field

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CampaignTestResults..::..SampleRecordColumns Field
CampaignConfiguration..::..CampaignTestResults Structure See Also Send Feedback
Database table columns corresponding to data in SampleRecords. Included fields are defined contact columns and columns found in Sort.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly ReadOnlyCollection<DBColumn> SampleRecordColumns
Visual Basic
Public ReadOnly SampleRecordColumns As ReadOnlyCollection(Of DBColumn)

See Also

CampaignConfiguration..::..CampaignTestResults Structure
CampaignConfiguration..::..CampaignTestResults Members


SampleRecords Field

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CampaignTestResults..::..SampleRecords Field
CampaignConfiguration..::..CampaignTestResults Structure See Also Send Feedback
Sample of callable records from the contact list. Included fields can be found in SampleRecordColumns.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly ReadOnlyCollection<ReadOnlyCollection<string>> SampleRecords
Visual Basic
Public ReadOnly SampleRecords As ReadOnlyCollection(Of ReadOnlyCollection(Of String))

See Also

CampaignConfiguration..::..CampaignTestResults Structure
CampaignConfiguration..::..CampaignTestResults Members


ScheduledCalls Field

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CampaignTestResults..::..ScheduledCalls Field
CampaignConfiguration..::..CampaignTestResults Structure See Also Send Feedback
The total number of calls scheduled for records in the contact list.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly int ScheduledCalls
Visual Basic
Public ReadOnly ScheduledCalls As Integer

See Also

CampaignConfiguration..::..CampaignTestResults Structure
CampaignConfiguration..::..CampaignTestResults Members


SkillCombinationColumns Field

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CampaignTestResults..::..SkillCombinationColumns Field
CampaignConfiguration..::..CampaignTestResults Structure See Also Send Feedback
Database table columns corresponding to data in SkillCombinations.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly ReadOnlyCollection<string> SkillCombinationColumns
Visual Basic
Public ReadOnly SkillCombinationColumns As ReadOnlyCollection(Of String)

See Also

CampaignConfiguration..::..CampaignTestResults Structure
CampaignConfiguration..::..CampaignTestResults Members


SkillCombinations Field

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CampaignTestResults..::..SkillCombinations Field
CampaignConfiguration..::..CampaignTestResults Structure See Also Send Feedback
Breakdown of callable records by skill combination.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly ReadOnlyCollection<CampaignConfiguration..::..SkillCombination> SkillCombinations
Visual Basic
Public ReadOnly SkillCombinations As ReadOnlyCollection(Of CampaignConfiguration..::..SkillCombination)

See Also

CampaignConfiguration..::..CampaignTestResults Structure
CampaignConfiguration..::..CampaignTestResults Members


Sort Field

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CampaignTestResults..::..Sort Field
CampaignConfiguration..::..CampaignTestResults Structure See Also Send Feedback
The SQL clause used to sort contact records, as it appears in contact list queries.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly string Sort
Visual Basic
Public ReadOnly Sort As String

See Also

CampaignConfiguration..::..CampaignTestResults Structure
CampaignConfiguration..::..CampaignTestResults Members


Success Field

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CampaignTestResults..::..Success Field
CampaignConfiguration..::..CampaignTestResults Structure See Also Send Feedback
Indicates whether the test completed without errors. If false, check ErrorMessage for details.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly bool Success
Visual Basic
Public ReadOnly Success As Boolean

See Also

CampaignConfiguration..::..CampaignTestResults Structure
CampaignConfiguration..::..CampaignTestResults Members


TotalRecords Field

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CampaignTestResults..::..TotalRecords Field
CampaignConfiguration..::..CampaignTestResults Structure See Also Send Feedback
The total number of records in the contact list.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly int TotalRecords
Visual Basic
Public ReadOnly TotalRecords As Integer

See Also

CampaignConfiguration..::..CampaignTestResults Structure
CampaignConfiguration..::..CampaignTestResults Members


UncallableRecords Field

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CampaignTestResults..::..UncallableRecords Field
CampaignConfiguration..::..CampaignTestResults Structure See Also Send Feedback
The total number of uncallable records in the contact list.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly int UncallableRecords
Visual Basic
Public ReadOnly UncallableRecords As Integer

See Also

CampaignConfiguration..::..CampaignTestResults Structure
CampaignConfiguration..::..CampaignTestResults Members


CampaignConfiguration.CampaignTestResults Methods

[image] [image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..CampaignTestResults Methods
CampaignConfiguration..::..CampaignTestResults Structure See Also Send Feedback

The CampaignConfiguration..::..CampaignTestResults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

CampaignConfiguration..::..CampaignTestResults Structure


CampaignConfiguration.Property Enumeration

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..Property Enumeration
CampaignConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Id | 0 | Represents the Id part of the ConfigurationId property.
DisplayName | 1 | Represents the DisplayName part of the ConfigurationId property.
AbandonRateCalculation | 2 | Represents the AbandonRateCalculation property.
AcdAgentAvailableTimeInterval | 3 | Represents the AcdAgentAvailableTimeInterval property.
AcdAgentAvailableTimeWeight | 4 | Represents the AcdAgentAvailableTimeWeight property.
AcdAgentCostWeight | 5 | Represents the AcdAgentCostWeight property.
AcdAgentSkillWeight | 6 | Represents the AcdAgentSkillWeight property.
AcdPriorityLevel | 7 | Represents the AcdPriorityLevel property.
AcdPriorityWeight | 8 | Represents the AcdPriorityWeight property.
AcdSkillsWeight | 9 | Represents the AcdSkillsWeight property.
AcdTimeInQueueWeight | 10 | Represents the AcdTimeInQueueWeight property.
AcdTimeInSystemWeight | 11 | Represents the AcdTimeInSystemWeight property.
AcdWorkgroup | 12 | Represents the AcdWorkgroup property.
AgentlessAllowAcdIfNoAgentAvailable | 13 | Represents the AgentlessAllowAcdIfNoAgentAvailable property.
AgentlessAnsweringMachineAttendantProfile | 14 | Represents the AgentlessAnsweringMachineAttendantProfile property.
AgentlessAnsweringMachineFile | 15 | Represents the AgentlessAnsweringMachineFile property.
AgentlessAnsweringMachineSecondsOfSilence | 16 | Represents the AgentlessAnsweringMachineSecondsOfSilence property.
AgentlessAnsweringMachineType | 17 | Represents the AgentlessAnsweringMachineType property.
AgentlessFaxAttendantProfile | 18 | Represents the AgentlessFaxAttendantProfile property.
AgentlessFaxFile | 19 | Represents the AgentlessFaxFile property.
AgentlessFaxMaxRetries | 20 | Represents the AgentlessFaxMaxRetries property.
AgentlessFaxType | 21 | Represents the AgentlessFaxType property.
AgentlessFileRepeat | 22 | Represents the AgentlessFileRepeat property.
AgentlessLiveAttendantProfile | 23 | Represents the AgentlessLiveAttendantProfile property.
AgentlessLiveFile | 24 | Represents the AgentlessLiveFile property.
AgentlessLiveType | 25 | Represents the AgentlessLiveType property.
AgentlessNoAgentAttendantProfile | 26 | Represents the AgentlessNoAgentAttendantProfile property.
AgentlessNoAgentFile | 27 | Represents the AgentlessNoAgentFile property.
AgentlessNoAgentType | 28 | Represents the AgentlessNoAgentType property.
AutomapTimeZone | 29 | Represents the AutomapTimeZone property.
AutopacingMaxPace | 30 | Represents the AutopacingMaxPace property.
AutoscheduleAnsweringMachineRescheduleDelay | 31 | Represents the AutoscheduleAnsweringMachineRescheduleDelay property.
AutoscheduleAnsweringMachineMaxAttempts | 32 | Represents the AutoscheduleAnsweringMachineMaxAttempts property.
AutoscheduleBusyRescheduleDelay | 33 | Represents the AutoscheduleBusyRescheduleDelay property.
AutoscheduleBusyMaxAttempts | 34 | Represents the AutoscheduleBusyMaxAttempts property.
AutoscheduleFaxRescheduleDelay | 35 | Represents the AutoscheduleFaxRescheduleDelay property.
AutoscheduleFaxMaxAttempts | 36 | Represents the AutoscheduleFaxMaxAttempts property.
AutoscheduleNoAnswerRescheduleDelay | 37 | Represents the AutoscheduleNoAnswerRescheduleDelay property.
AutoscheduleNoAnswerMaxAttempts | 38 | Represents the AutoscheduleNoAnswerMaxAttempts property.
AutoscheduleRemoteHangupRescheduleDelay | 39 | Represents the AutoscheduleRemoteHangupRescheduleDelay property.
AutoscheduleRemoteHangupMaxAttempts | 40 | Represents the AutoscheduleRemoteHangupMaxAttempts property.
AutoscheduleSystemHangupRescheduleDelay | 41 | Represents the AutoscheduleSystemHangupRescheduleDelay property.
AutoscheduleSystemHangupMaxAttempts | 42 | Represents the AutoscheduleSystemHangupMaxAttempts property.
AutoscheduledCallsIgnoreRecycles | 43 | Represents the AutoscheduledCallsIgnoreRecycles property.
BaseScript | 44 | Represents the BaseScript property.
CallerIdDisplayName | 45 | Represents the CallerIdDisplayName property.
CallerIdDisplayNumber | 46 | Represents the CallerIdDisplayNumber property.
CallingMode | 47 | Represents the CallingMode property.
ContactList | 48 | Represents the ContactList property.
CallStages | 49 | Represents the CallStages property.
CallTimeoutSeconds | 50 | Represents the CallTimeoutSeconds property.
CampaignGroup | 51 | Represents the CampaignGroup property.
CampaignStatInterval | 52 | Represents the CampaignStatsInterval property.
ContactColumns | 53 | Represents the ContactColumns property.
CopyDialerAttributesToCallAttributes | 54 | Represents the CopyDialerAttributesToCallAttributes property.
CustomScriptURL | 55 | Represents the CustomScriptURL property.
CustomizeContactColumns | 56 | Represents the CustomizeContactColumns property.
DialingAutoOnOff | 57 | Represents the DialingAutoOnOff property.
DialingActive | 58 | Represents the DialingActive property.
DialingPace | 59 | (Deprecated) Represents the DialingPace property.
DialingPriority | 60 | Represents the DialingPriority property.
DialingSchedule | 61 | Represents the DialingSchedule property.
DialingScheduledOnly | 62 | Represents the DialingScheduledOnly property.
DisplayTransitionAlerts | 63 | Represents the DisplayTransitionAlerts property.
DNCSource | 64 | Represents the DNCSource property.
DNCExclusionId | 65 | Represents the DNCExclusionId property.
EnableAnsweringMachineDetection | 66 | Represents the EnableAnsweringMachineDetection property.
EnableCallAnalysis | 67 | Represents the EnableCallAnalysis property.
EnableMaxPreviewTime | 68 | Represents the EnableMaxPreviewTime property.
FilterAutoscheduledCallbacks | 69 | Represents the FilterAutoscheduledCallbacks property.
FilterScheduledCallbacks | 70 | Represents the FilterScheduledCallbacks property.
Filters | 71 | Represents the Filters property.
FollowUpStatus | 72 | Represents the FollowUpStatus property.
IsNonDialerStatDisabled | 73 | Represents the IsNonDialerStatDisabled property.
InboundWorkgroups | 74 | Represents the InboundWorkgroups property.
IncludeNoAgentAsAbandon | 75 | Represents the IncludeNoAgentAsAbandon property.
IncludeRemoteHangupAsAbandon | 76 | Represents the IncludeRemoteHangupAsAbandon property.
IncludeSystemHangupAsAbandon | 77 | Represents the IncludeSystemHangupAsAbandon property.
InitialCallsPerRequest | 78 | Represents the InitialCallsPerRequest property.
KeepOpen | 79 | Represents the KeepOpen property.
MaxAbandonRate | 80 | Represents the MaxAbandonRate property.
MaxAgentCallbackReschedules | 81 | Represents the MaxAgentCallbackReschedules property.
MaxAttempts | 82 | Represents the MaxAttempts property.
MaxAttemptsPerPhoneNumber | 83 | Represents the MaxAttemptsPerPhoneNumber property.
MaxDailyAttempts | 84 | Represents the MaxDailyAttempts property.
MaxLines | 85 | Represents the MaxLines property.
MaxPreviewSeconds | 86 | Represents the MaxPreviewSeconds property.
MaxRecycles | 87 | Represents the MaxRecycles property.
MinimumNextDial | 88 | Represents the MinimumNextDial property.
NoAgentAbandonDelay | 89 | Represents the NoAgentAbandonDelay property.
NoAnswerTimeout | 90 | Represents the NoAnswerTimeout property.
OutboundDialingLineType | 91 | Represents the OutboundDialingLineType property.
OutboundDialPlanLocation | 92 | Represents the OutboundDialPlanLocation property.
OutboundLinegroup | 93 | Represents the OutboundLinegroup property.
SMSBroker | 94 | Represents the SMSBroker property.
SMSBrokerAccount | 95 | Represents the SMSBrokerAccount property.
OutboundSMSEnabled | 96 | Represents the OutboundSMSEnabled property.
OverallInboundHighThreshold | 97 | Represents the OverallInboundHighThreshold property.
OverallInboundLowThreshold | 98 | Represents the OverallInboundLowThreshold property.
Paused | 99 | Represents the Paused property.
PersistentConnectionWavFile | 100 | Represents the PersistentConnectionWavFile property.
PolicySets | 101 | Represents the PolicySets property.
PriorityDialingEnabled | 102 | Represents the PriorityDialingEnabled property.
PriorityQueryFrequency | 103 | Represents the PriorityQueryFrequency property.
PrioritySortColumns | 104 | Represents the PrioritySortColumns property.
RecyclesRemaining | 105 | Represents the RecyclesRemaining property.
RecycleTable | 106 | Represents the RecycleTable property.
RemoteHangUpAbandonDelay | 107 | Represents the RemoteHangUpAbandonDelay property.
RescheduleDelay | 108 | Represents the RescheduleDelay property.
RuleSet | 109 | Represents the RuleSet property.
Sequence | 110 | Represents the Sequence property.
Servers | 111 | Represents the Servers property.
SkillSets | 112 | Represents the SkillSets property.
SortColumns | 113 | Represents the SortColumns property.
StrictMaxAbandon | 114 | Represents the StrictMaxAbandon property.
TimeZoneAutoMappingMode | 115 | Represents the TimeZoneAutoMappingMode property.
UseAutoScheduleSettingsForAgentCallbacks | 116 | Represents the UseAutoScheduleSettingsForAgentCallbacks property.
UseBulkApi | 117 | Represents the UseBulkApi property.
ZoneSet | 118 | Represents the ZoneSet property.
QueryTimeFilters | 119 | Represents the Filters property.
UseContactListZone | 120 | Represents the UseContactListZone property.
ActiveRuleGroup | 121 | Represents the ActiveRuleGroup property.
UseDefaultZoneForZoneBlocking | 122 | Represents the UseDefaultZoneForZoneBlocking property.
AgentOwnedCallbackCacheTimeout | 123 | Represents the ActiveRuleGroup property.
RevisionLevel | 124 | Represents the RevisionLevel property.
MaxDailyAttemptsDefinition | 125 | Represents the MaxDailyAttemptsDefinition property.
CustomDNCSource | 126 | Represents the CustomDNCSource property.
UseCallingTimeRestrictions | 127 | Represents the UseCallingTimeRestrictions property.
UseDoNotCallToday | 128 | Represents the UseDoNotCallToday property.
UsePermissionEbr | 129 | Represents the UsePermissionEbr property.
UseCallingTimeWindow | 130 | Represents the UseCallingTimeWindow property.

See Also


CampaignConfiguration.QuickValidateResults Structure

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..QuickValidateResults Structure
CampaignConfiguration Class Members See Also Send Feedback
Contains the results from a call to QuickValidate()()()().

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public struct QuickValidateResults
Visual Basic
Public Structure QuickValidateResults

See Also

CampaignConfiguration..::..QuickValidateResults Members


CampaignConfiguration.QuickValidateResults Members

[image] [image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..QuickValidateResults Members
CampaignConfiguration..::..QuickValidateResults Structure Methods Fields See Also Send Feedback

The CampaignConfiguration..::..QuickValidateResults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | ErrorMessage | Contains a human-readable message if an error occurred.
Public field | Success | Indicates whether validation succeeded or not.

See Also

CampaignConfiguration..::..QuickValidateResults Structure


CampaignConfiguration.QuickValidateResults Fields

[image] [image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..QuickValidateResults Fields
CampaignConfiguration..::..QuickValidateResults Structure See Also Send Feedback

The CampaignConfiguration..::..QuickValidateResults type exposes the following members.

Fields

 | Name | Description
Public field | ErrorMessage | Contains a human-readable message if an error occurred.
Public field | Success | Indicates whether validation succeeded or not.

See Also

CampaignConfiguration..::..QuickValidateResults Structure


ErrorMessage Field

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..QuickValidateResults..::..ErrorMessage Field
CampaignConfiguration..::..QuickValidateResults Structure See Also Send Feedback
Contains a human-readable message if an error occurred.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly string ErrorMessage
Visual Basic
Public ReadOnly ErrorMessage As String

See Also

CampaignConfiguration..::..QuickValidateResults Structure
CampaignConfiguration..::..QuickValidateResults Members


Success Field

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..QuickValidateResults..::..Success Field
CampaignConfiguration..::..QuickValidateResults Structure See Also Send Feedback
Indicates whether validation succeeded or not.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly bool Success
Visual Basic
Public ReadOnly Success As Boolean

See Also

CampaignConfiguration..::..QuickValidateResults Structure
CampaignConfiguration..::..QuickValidateResults Members


CampaignConfiguration.QuickValidateResults Methods

[image] [image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..QuickValidateResults Methods
CampaignConfiguration..::..QuickValidateResults Structure See Also Send Feedback

The CampaignConfiguration..::..QuickValidateResults type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

CampaignConfiguration..::..QuickValidateResults Structure


CampaignConfiguration.SkillCombination Structure

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..SkillCombination Structure
CampaignConfiguration Class Members See Also Send Feedback
Represents a single combination of skill values occuring in the contact list.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public struct SkillCombination
Visual Basic
Public Structure SkillCombination

See Also

CampaignConfiguration..::..SkillCombination Members


CampaignConfiguration.SkillCombination Members

[image] [image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..SkillCombination Members
CampaignConfiguration..::..SkillCombination Structure Methods Fields See Also Send Feedback

The CampaignConfiguration..::..SkillCombination type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | RecordCount | The number of callable records applicable towards this skill combination.
Public field | SkillValues | Values composing this skill combination.

See Also

CampaignConfiguration..::..SkillCombination Structure


CampaignConfiguration.SkillCombination Fields

[image] [image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..SkillCombination Fields
CampaignConfiguration..::..SkillCombination Structure See Also Send Feedback

The CampaignConfiguration..::..SkillCombination type exposes the following members.

Fields

 | Name | Description
Public field | RecordCount | The number of callable records applicable towards this skill combination.
Public field | SkillValues | Values composing this skill combination.

See Also

CampaignConfiguration..::..SkillCombination Structure


RecordCount Field

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..SkillCombination..::..RecordCount Field
CampaignConfiguration..::..SkillCombination Structure See Also Send Feedback
The number of callable records applicable towards this skill combination.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly int RecordCount
Visual Basic
Public ReadOnly RecordCount As Integer

See Also

CampaignConfiguration..::..SkillCombination Structure
CampaignConfiguration..::..SkillCombination Members


SkillValues Field

[image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..SkillCombination..::..SkillValues Field
CampaignConfiguration..::..SkillCombination Structure See Also Send Feedback
Values composing this skill combination.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly ReadOnlyCollection<string> SkillValues
Visual Basic
Public ReadOnly SkillValues As ReadOnlyCollection(Of String)

See Also

CampaignConfiguration..::..SkillCombination Structure
CampaignConfiguration..::..SkillCombination Members


CampaignConfiguration.SkillCombination Methods

[image] [image]

IceLib Dialer Technical Reference
CampaignConfiguration..::..SkillCombination Methods
CampaignConfiguration..::..SkillCombination Structure See Also Send Feedback

The CampaignConfiguration..::..SkillCombination type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

CampaignConfiguration..::..SkillCombination Structure


CampaignConfigurationList Class

[image]

IceLib Dialer Technical Reference
CampaignConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing Campaign configuration objects.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class CampaignConfigurationList : EditableConfigurationList<CampaignConfiguration, CampaignConfiguration..::..Property>
Visual Basic
Public Class CampaignConfigurationList _
    Inherits EditableConfigurationList(Of CampaignConfiguration, CampaignConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>
DynamicConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>
EditableConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..CampaignConfigurationList

See Also

CampaignConfigurationList Members


CampaignConfigurationList Members

[image] [image]

IceLib Dialer Technical Reference
CampaignConfigurationList Members
CampaignConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The CampaignConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | CampaignConfigurationList | Initializes a new instance of the CampaignConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)

See Also

CampaignConfigurationList Class


CampaignConfigurationList Constructor

[image]

IceLib Dialer Technical Reference
CampaignConfigurationList Constructor
CampaignConfigurationList Class See Also Send Feedback
Initializes a new instance of the CampaignConfigurationList class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CampaignConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

CampaignConfigurationList Class
CampaignConfigurationList Members


CampaignConfigurationList Methods

[image] [image]

IceLib Dialer Technical Reference
CampaignConfigurationList Methods
CampaignConfigurationList Class See Also Send Feedback

The CampaignConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CampaignConfigurationList Class


CampaignConfigurationList Properties

[image] [image]

IceLib Dialer Technical Reference
CampaignConfigurationList Properties
CampaignConfigurationList Class See Also Send Feedback

The CampaignConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)

See Also

CampaignConfigurationList Class


CampaignConfigurationList Events

[image] [image]

IceLib Dialer Technical Reference
CampaignConfigurationList Events
CampaignConfigurationList Class See Also Send Feedback

The CampaignConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' CampaignConfiguration, CampaignConfiguration..::..Property >)>)>.)

See Also

CampaignConfigurationList Class


CampaignGroup Class

[image]

IceLib Dialer Technical Reference
CampaignGroup Class
Members See Also Send Feedback
A class representing a group of campaign properties that will be adjusted when activated during the execution of a Sequence.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class CampaignGroup : IDeepCloneable
Visual Basic
Public Class CampaignGroup _
    Implements IDeepCloneable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..CampaignGroup

See Also

CampaignGroup Members


CampaignGroup Members

[image] [image]

IceLib Dialer Technical Reference
CampaignGroup Members
CampaignGroup Class Constructors Methods Properties See Also Send Feedback

The CampaignGroup type exposes the following members.

Constructors

 | Name | Description
Public method | CampaignGroup(ConfigurationId) | Constructs a new instance of CampaignGroup
Public method | CampaignGroup(String) | Constructs a new instance of CampaignGroup

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDisplayName | Public method to change the display name of a CampaignGroup
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | The id of the Campaign Group
Public property | Index | Specifies the order to display and execute this group in relation to other groups in the sequence.
Public property | Properties | A list of the CampaignGroupPropertyItem associated with this group

See Also

CampaignGroup Class


CampaignGroup Constructor

[image] [image]

IceLib Dialer Technical Reference
CampaignGroup Constructor
CampaignGroup Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CampaignGroup(ConfigurationId) | Constructs a new instance of CampaignGroup
Public method | CampaignGroup(String) | Constructs a new instance of CampaignGroup

See Also

CampaignGroup Class
CampaignGroup Members


CampaignGroup Constructor (ConfigurationId)

[image]

IceLib Dialer Technical Reference
CampaignGroup Constructor (ConfigurationId)
CampaignGroup Class See Also Send Feedback
Constructs a new instance of CampaignGroup

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CampaignGroup(
    ConfigurationId id
)
Visual Basic
Public Sub New ( _
    id As ConfigurationId _
)

Parameters

id
Type: ConfigurationId
The Id ConfigurationId you wish to assign to the group.

See Also

CampaignGroup Class
CampaignGroup Members
CampaignGroup Overload


CampaignGroup Constructor (String)

[image]

IceLib Dialer Technical Reference
CampaignGroup Constructor (String)
CampaignGroup Class See Also Send Feedback
Constructs a new instance of CampaignGroup

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CampaignGroup(
    string displayName
)
Visual Basic
Public Sub New ( _
    displayName As String _
)

Parameters

displayName
Type: System..::..String
The display name you wish to assign to the group.

See Also

CampaignGroup Class
CampaignGroup Members
CampaignGroup Overload


CampaignGroup Methods

[image] [image]

IceLib Dialer Technical Reference
CampaignGroup Methods
CampaignGroup Class See Also Send Feedback

The CampaignGroup type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDisplayName | Public method to change the display name of a CampaignGroup
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CampaignGroup Class


SetDisplayName Method

[image]

IceLib Dialer Technical Reference
CampaignGroup..::..SetDisplayName Method
CampaignGroup Class See Also Send Feedback
Public method to change the display name of a CampaignGroup

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void SetDisplayName(
    string displayName
)
Visual Basic
Public Sub SetDisplayName ( _
    displayName As String _
)

Parameters

displayName
Type: System..::..String

See Also

CampaignGroup Class
CampaignGroup Members


CampaignGroup Properties

[image] [image]

IceLib Dialer Technical Reference
CampaignGroup Properties
CampaignGroup Class See Also Send Feedback

The CampaignGroup type exposes the following members.

Properties

 | Name | Description
Public property | Id | The id of the Campaign Group
Public property | Index | Specifies the order to display and execute this group in relation to other groups in the sequence.
Public property | Properties | A list of the CampaignGroupPropertyItem associated with this group

See Also

CampaignGroup Class


Id Property

[image]

IceLib Dialer Technical Reference
CampaignGroup..::..Id Property
CampaignGroup Class See Also Send Feedback
The id of the Campaign Group

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ConfigurationId Id { get; internal set; }
Visual Basic
Public Property Id As ConfigurationId
    Get
    Friend Set

See Also

CampaignGroup Class
CampaignGroup Members


Index Property

[image]

IceLib Dialer Technical Reference
CampaignGroup..::..Index Property
CampaignGroup Class See Also Send Feedback
Specifies the order to display and execute this group in relation to other groups in the sequence.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int Index { get; set; }
Visual Basic
Public Property Index As Integer
    Get
    Set

See Also

CampaignGroup Class
CampaignGroup Members


Properties Property

[image]

IceLib Dialer Technical Reference
CampaignGroup..::..Properties Property
CampaignGroup Class See Also Send Feedback
A list of the CampaignGroupPropertyItem associated with this group

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<CampaignGroupPropertyItem> Properties { get; private set; }
Visual Basic
Public Property Properties As Collection(Of CampaignGroupPropertyItem)
    Get
    Private Set

See Also

CampaignGroup Class
CampaignGroup Members


CampaignGroupPropertyItem Class

[image]

IceLib Dialer Technical Reference
CampaignGroupPropertyItem Class
Members See Also Send Feedback
A class representing a specific CampaignConfiguration..::..Property and the value it should be changed to when the CampaignGroup is activated by the Sequence.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class CampaignGroupPropertyItem : IDeepCloneable
Visual Basic
Public Class CampaignGroupPropertyItem _
    Implements IDeepCloneable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..CampaignGroupPropertyItem

See Also

CampaignGroupPropertyItem Members


CampaignGroupPropertyItem Members

[image] [image]

IceLib Dialer Technical Reference
CampaignGroupPropertyItem Members
CampaignGroupPropertyItem Class Constructors Methods Properties See Also Send Feedback

The CampaignGroupPropertyItem type exposes the following members.

Constructors

 | Name | Description
Public method | CampaignGroupPropertyItem()()()() | Constructs a new instance of CampaignGroupPropertyItem
Public method | CampaignGroupPropertyItem(ConfigurationId) | Constructs a new instance of CampaignGroupPropertyItem

Methods

 | Name | Description
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | The id of the Campaign Group Property Item
Public property | Property | The campaign property to set.
Public property | Values | The new value of the Property

See Also

CampaignGroupPropertyItem Class


CampaignGroupPropertyItem Constructor

[image] [image]

IceLib Dialer Technical Reference
CampaignGroupPropertyItem Constructor
CampaignGroupPropertyItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CampaignGroupPropertyItem()()()() | Constructs a new instance of CampaignGroupPropertyItem
Public method | CampaignGroupPropertyItem(ConfigurationId) | Constructs a new instance of CampaignGroupPropertyItem

See Also

CampaignGroupPropertyItem Class
CampaignGroupPropertyItem Members


CampaignGroupPropertyItem Constructor

[image]

IceLib Dialer Technical Reference
CampaignGroupPropertyItem Constructor
CampaignGroupPropertyItem Class See Also Send Feedback
Constructs a new instance of CampaignGroupPropertyItem

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CampaignGroupPropertyItem()
Visual Basic
Public Sub New

See Also

CampaignGroupPropertyItem Class
CampaignGroupPropertyItem Members
CampaignGroupPropertyItem Overload


CampaignGroupPropertyItem Constructor (ConfigurationId)

[image]

IceLib Dialer Technical Reference
CampaignGroupPropertyItem Constructor (ConfigurationId)
CampaignGroupPropertyItem Class See Also Send Feedback
Constructs a new instance of CampaignGroupPropertyItem

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CampaignGroupPropertyItem(
    ConfigurationId id
)
Visual Basic
Public Sub New ( _
    id As ConfigurationId _
)

Parameters

id
Type: ConfigurationId
The Id ConfigurationId you wish to assign to the property item.

See Also

CampaignGroupPropertyItem Class
CampaignGroupPropertyItem Members
CampaignGroupPropertyItem Overload


CampaignGroupPropertyItem Methods

[image] [image]

IceLib Dialer Technical Reference
CampaignGroupPropertyItem Methods
CampaignGroupPropertyItem Class See Also Send Feedback

The CampaignGroupPropertyItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CampaignGroupPropertyItem Class


Equals Method

[image]

IceLib Dialer Technical Reference
CampaignGroupPropertyItem..::..Equals Method
CampaignGroupPropertyItem Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object

See Also

CampaignGroupPropertyItem Class
CampaignGroupPropertyItem Members


CampaignGroupPropertyItem Properties

[image] [image]

IceLib Dialer Technical Reference
CampaignGroupPropertyItem Properties
CampaignGroupPropertyItem Class See Also Send Feedback

The CampaignGroupPropertyItem type exposes the following members.

Properties

 | Name | Description
Public property | Id | The id of the Campaign Group Property Item
Public property | Property | The campaign property to set.
Public property | Values | The new value of the Property

See Also

CampaignGroupPropertyItem Class


Id Property

[image]

IceLib Dialer Technical Reference
CampaignGroupPropertyItem..::..Id Property
CampaignGroupPropertyItem Class See Also Send Feedback
The id of the Campaign Group Property Item

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ConfigurationId Id { get; internal set; }
Visual Basic
Public Property Id As ConfigurationId
    Get
    Friend Set

See Also

CampaignGroupPropertyItem Class
CampaignGroupPropertyItem Members


Property Property

[image]

IceLib Dialer Technical Reference
CampaignGroupPropertyItem..::..Property Property
CampaignGroupPropertyItem Class See Also Send Feedback
The campaign property to set.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CampaignConfiguration..::..Property Property { get; set; }
Visual Basic
Public Property Property As CampaignConfiguration..::..Property
    Get
    Set

See Also

CampaignGroupPropertyItem Class
CampaignGroupPropertyItem Members


Values Property

[image]

IceLib Dialer Technical Reference
CampaignGroupPropertyItem..::..Values Property
CampaignGroupPropertyItem Class See Also Send Feedback
The new value of the Property

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Object Values { get; set; }
Visual Basic
Public Property Values As Object
    Get
    Set

See Also

CampaignGroupPropertyItem Class
CampaignGroupPropertyItem Members


CampaignPropertyRuleAction Class

[image]

IceLib Dialer Technical Reference
CampaignPropertyRuleAction Class
Members See Also Send Feedback
A RuleAction that sets the value a campaign property.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class CampaignPropertyRuleAction : RuleAction
Visual Basic
Public NotInheritable Class CampaignPropertyRuleAction _
    Inherits RuleAction

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..RuleAction
ININ.IceLib.Configuration.Dialer..::..CampaignPropertyRuleAction

See Also

CampaignPropertyRuleAction Members


CampaignPropertyRuleAction Members

[image] [image]

IceLib Dialer Technical Reference
CampaignPropertyRuleAction Members
CampaignPropertyRuleAction Class Constructors Methods Properties See Also Send Feedback

The CampaignPropertyRuleAction type exposes the following members.

Constructors

 | Name | Description
Public method | CampaignPropertyRuleAction | Constructs a new instance of the CampaignPropertyRuleAction class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides RuleActionToString()()()().)

Properties

 | Name | Description
Public property | ActionType | The type of action to perform. (Inherited from RuleAction.)
Public property | Id | The Id of the action. (Inherited from RuleAction.)
Public property | Index | The ordinal number of this action in relation to other actions in a rule. (Inherited from RuleAction.)
Public property | Property | The campaign property to set.
Public property | PropertyValue | The new property value.

See Also

CampaignPropertyRuleAction Class


CampaignPropertyRuleAction Constructor

[image]

IceLib Dialer Technical Reference
CampaignPropertyRuleAction Constructor
CampaignPropertyRuleAction Class See Also Send Feedback
Constructs a new instance of the CampaignPropertyRuleAction class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CampaignPropertyRuleAction()
Visual Basic
Public Sub New

See Also

CampaignPropertyRuleAction Class
CampaignPropertyRuleAction Members


CampaignPropertyRuleAction Methods

[image] [image]

IceLib Dialer Technical Reference
CampaignPropertyRuleAction Methods
CampaignPropertyRuleAction Class See Also Send Feedback

The CampaignPropertyRuleAction type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides RuleActionToString()()()().)

See Also

CampaignPropertyRuleAction Class


ToString Method

[image]

IceLib Dialer Technical Reference
CampaignPropertyRuleAction..::..ToString Method
CampaignPropertyRuleAction Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

CampaignPropertyRuleAction Class
CampaignPropertyRuleAction Members


CampaignPropertyRuleAction Properties

[image] [image]

IceLib Dialer Technical Reference
CampaignPropertyRuleAction Properties
CampaignPropertyRuleAction Class See Also Send Feedback

The CampaignPropertyRuleAction type exposes the following members.

Properties

 | Name | Description
Public property | ActionType | The type of action to perform. (Inherited from RuleAction.)
Public property | Id | The Id of the action. (Inherited from RuleAction.)
Public property | Index | The ordinal number of this action in relation to other actions in a rule. (Inherited from RuleAction.)
Public property | Property | The campaign property to set.
Public property | PropertyValue | The new property value.

See Also

CampaignPropertyRuleAction Class


Property Property

[image]

IceLib Dialer Technical Reference
CampaignPropertyRuleAction..::..Property Property
CampaignPropertyRuleAction Class See Also Send Feedback
The campaign property to set.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CampaignConfiguration..::..Property Property { get; set; }
Visual Basic
Public Property Property As CampaignConfiguration..::..Property
    Get
    Set

See Also

CampaignPropertyRuleAction Class
CampaignPropertyRuleAction Members


PropertyValue Property

[image]

IceLib Dialer Technical Reference
CampaignPropertyRuleAction..::..PropertyValue Property
CampaignPropertyRuleAction Class See Also Send Feedback
The new property value.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Object PropertyValue { get; set; }
Visual Basic
Public Property PropertyValue As Object
    Get
    Set

Remarks

Use the Id property when setting this property to a Dialer object.

See Also

CampaignPropertyRuleAction Class
CampaignPropertyRuleAction Members


CampaignRuleAction Class

[image]

IceLib Dialer Technical Reference
CampaignRuleAction Class
Members See Also Send Feedback
A RuleAction that will alters the execution state of a Campaign.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class CampaignRuleAction : RuleAction
Visual Basic
Public NotInheritable Class CampaignRuleAction _
    Inherits RuleAction

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..RuleAction
ININ.IceLib.Configuration.Dialer..::..CampaignRuleAction

See Also

CampaignRuleAction Members


CampaignRuleAction Members

[image] [image]

IceLib Dialer Technical Reference
CampaignRuleAction Members
CampaignRuleAction Class Constructors Methods Properties See Also Send Feedback

The CampaignRuleAction type exposes the following members.

Constructors

 | Name | Description
Public method | CampaignRuleAction | Constructs a new instance of the CampaignRuleAction class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides RuleActionToString()()()().)

Properties

 | Name | Description
Public property | Action | The action to perform.
Public property | ActionType | The type of action to perform. (Inherited from RuleAction.)
Public property | Id | The Id of the action. (Inherited from RuleAction.)
Public property | Index | The ordinal number of this action in relation to other actions in a rule. (Inherited from RuleAction.)
Public property | ScheduledCallsOnlyEnabled | Sets or gets whether scheduled calls only mode is enabled. Only valid when Action is ScheduledCallsOnly.

See Also

CampaignRuleAction Class


CampaignRuleAction Constructor

[image]

IceLib Dialer Technical Reference
CampaignRuleAction Constructor
CampaignRuleAction Class See Also Send Feedback
Constructs a new instance of the CampaignRuleAction class

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CampaignRuleAction()
Visual Basic
Public Sub New

See Also

CampaignRuleAction Class
CampaignRuleAction Members


CampaignRuleAction Methods

[image] [image]

IceLib Dialer Technical Reference
CampaignRuleAction Methods
CampaignRuleAction Class See Also Send Feedback

The CampaignRuleAction type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides RuleActionToString()()()().)

See Also

CampaignRuleAction Class


ToString Method

[image]

IceLib Dialer Technical Reference
CampaignRuleAction..::..ToString Method
CampaignRuleAction Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

CampaignRuleAction Class
CampaignRuleAction Members


CampaignRuleAction Properties

[image] [image]

IceLib Dialer Technical Reference
CampaignRuleAction Properties
CampaignRuleAction Class See Also Send Feedback

The CampaignRuleAction type exposes the following members.

Properties

 | Name | Description
Public property | Action | The action to perform.
Public property | ActionType | The type of action to perform. (Inherited from RuleAction.)
Public property | Id | The Id of the action. (Inherited from RuleAction.)
Public property | Index | The ordinal number of this action in relation to other actions in a rule. (Inherited from RuleAction.)
Public property | ScheduledCallsOnlyEnabled | Sets or gets whether scheduled calls only mode is enabled. Only valid when Action is ScheduledCallsOnly.

See Also

CampaignRuleAction Class


Action Property

[image]

IceLib Dialer Technical Reference
CampaignRuleAction..::..Action Property
CampaignRuleAction Class See Also Send Feedback
The action to perform.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CampaignAction Action { get; set; }
Visual Basic
Public Property Action As CampaignAction
    Get
    Set

See Also

CampaignRuleAction Class
CampaignRuleAction Members


ScheduledCallsOnlyEnabled Property

[image]

IceLib Dialer Technical Reference
CampaignRuleAction..::..ScheduledCallsOnlyEnabled Property
CampaignRuleAction Class See Also Send Feedback
Sets or gets whether scheduled calls only mode is enabled. Only valid when Action is ScheduledCallsOnly.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool ScheduledCallsOnlyEnabled { get; set; }
Visual Basic
Public Property ScheduledCallsOnlyEnabled As Boolean
    Get
    Set

See Also

CampaignRuleAction Class
CampaignRuleAction Members


CampaignServerConnectionStateEventArgs Class

[image]

IceLib Dialer Technical Reference
CampaignServerConnectionStateEventArgs Class
Members See Also Send Feedback
Contains details about Campaign Server connection status

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class CampaignServerConnectionStateEventArgs : EventArgs
Visual Basic
Public Class CampaignServerConnectionStateEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Configuration.Dialer..::..CampaignServerConnectionStateEventArgs

See Also

CampaignServerConnectionStateEventArgs Members


CampaignServerConnectionStateEventArgs Members

[image] [image]

IceLib Dialer Technical Reference
CampaignServerConnectionStateEventArgs Members
CampaignServerConnectionStateEventArgs Class Methods Properties See Also Send Feedback

The CampaignServerConnectionStateEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | State | The state of the connection

See Also

CampaignServerConnectionStateEventArgs Class


CampaignServerConnectionStateEventArgs Methods

[image] [image]

IceLib Dialer Technical Reference
CampaignServerConnectionStateEventArgs Methods
CampaignServerConnectionStateEventArgs Class See Also Send Feedback

The CampaignServerConnectionStateEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CampaignServerConnectionStateEventArgs Class


CampaignServerConnectionStateEventArgs Properties

[image] [image]

IceLib Dialer Technical Reference
CampaignServerConnectionStateEventArgs Properties
CampaignServerConnectionStateEventArgs Class See Also Send Feedback

The CampaignServerConnectionStateEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | State | The state of the connection

See Also

CampaignServerConnectionStateEventArgs Class


State Property

[image]

IceLib Dialer Technical Reference
CampaignServerConnectionStateEventArgs..::..State Property
CampaignServerConnectionStateEventArgs Class See Also Send Feedback
The state of the connection

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DialerConnectionState State { get; private set; }
Visual Basic
Public Property State As DialerConnectionState
    Get
    Private Set

See Also

CampaignServerConnectionStateEventArgs Class
CampaignServerConnectionStateEventArgs Members


CampaignStatus Enumeration

[image]

IceLib Dialer Technical Reference
CampaignStatus Enumeration
See Also Send Feedback
Bit flags indicating the status of a campaign. Used with the CampaignStatusChanged event.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
[FlagsAttribute]
public enum CampaignStatus
Visual Basic
<FlagsAttribute> _
Public Enumeration CampaignStatus

Members

Member name | Value | Description
Invalid | 0 | The campaign is not in a valid state.
On | 1 | The campaign is running.
Off | 2 | The campaign is not running.
ScheduledOnly | 4 | The campaign is only dialing scheduled calls.
Auto | 8 | The campaign is running according to its assigned schedule.
Paused | 16 | The campaign has paused.
Completed | 32 | The campaign has finished dialing.

See Also


CampaignStatusChangedEventArgs Class

[image]

IceLib Dialer Technical Reference
CampaignStatusChangedEventArgs Class
Members See Also Send Feedback
Contains details about a campaign status change.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class CampaignStatusChangedEventArgs : EventArgs
Visual Basic
Public Class CampaignStatusChangedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Configuration.Dialer..::..CampaignStatusChangedEventArgs

See Also

CampaignStatusChangedEventArgs Members
DialerConfigurationManager..::..CampaignStatusChanged


CampaignStatusChangedEventArgs Members

[image] [image]

IceLib Dialer Technical Reference
CampaignStatusChangedEventArgs Members
CampaignStatusChangedEventArgs Class Methods Properties See Also Send Feedback

The CampaignStatusChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CampaignId | The Id of the campaign that changed.
Public property | Status | The new status of the campaign.

See Also

CampaignStatusChangedEventArgs Class


CampaignStatusChangedEventArgs Methods

[image] [image]

IceLib Dialer Technical Reference
CampaignStatusChangedEventArgs Methods
CampaignStatusChangedEventArgs Class See Also Send Feedback

The CampaignStatusChangedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CampaignStatusChangedEventArgs Class


CampaignStatusChangedEventArgs Properties

[image] [image]

IceLib Dialer Technical Reference
CampaignStatusChangedEventArgs Properties
CampaignStatusChangedEventArgs Class See Also Send Feedback

The CampaignStatusChangedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | CampaignId | The Id of the campaign that changed.
Public property | Status | The new status of the campaign.

See Also

CampaignStatusChangedEventArgs Class


CampaignId Property

[image]

IceLib Dialer Technical Reference
CampaignStatusChangedEventArgs..::..CampaignId Property
CampaignStatusChangedEventArgs Class See Also Send Feedback
The Id of the campaign that changed.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string CampaignId { get; private set; }
Visual Basic
Public Property CampaignId As String
    Get
    Private Set

See Also

CampaignStatusChangedEventArgs Class
CampaignStatusChangedEventArgs Members


Status Property

[image]

IceLib Dialer Technical Reference
CampaignStatusChangedEventArgs..::..Status Property
CampaignStatusChangedEventArgs Class See Also Send Feedback
The new status of the campaign.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CampaignStatus Status { get; private set; }
Visual Basic
Public Property Status As CampaignStatus
    Get
    Private Set

See Also

CampaignStatusChangedEventArgs Class
CampaignStatusChangedEventArgs Members


CCSConfiguration Class

[image]

IceLib Dialer Technical Reference
CCSConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for the central campaign server.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class CCSConfiguration : EditableListConfigurationObject<CCSConfiguration..::..Property>
Visual Basic
Public Class CCSConfiguration _
    Inherits EditableListConfigurationObject(Of CCSConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ConfigurationObject
ListConfigurationObject
EditableListConfigurationObject<(Of <(<' CCSConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..CCSConfiguration

See Also

CCSConfiguration Members


CCSConfiguration Members

[image] [image]

IceLib Dialer Technical Reference
CCSConfiguration Members
CCSConfiguration Class Methods Properties See Also Send Feedback

The CCSConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' CCSConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' CCSConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' CCSConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' CCSConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' CCSConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' CCSConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' CCSConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' CCSConfiguration..::..Property >)>)>.)
Public method | RestartHttpServer | Starts or restarts the Central Campaign Server's http server.
Public method | RestartHttpserverAsync | Asynchronously starts or restarts the Central Campaign Server's http server.
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' CCSConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' CCSConfiguration..::..Property >)>)>.)
Public method | ToString | (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | AuditingConnection | The Id of the connection where the configuration auditing table resides.
Public property | AuditingEnabled | Toggles activation of configuration auditing.
Public property | AuditingRetentionTime | The maximum number of days to retain configuration audit entries before deleting them.
Public property | AutomaticDispositionDelay | The length of time in seconds that automatic dispositions are delayed when an interaction disconnects without an explicit disposition. This only applies to interactions that were transferred away from the agent or to an Attendant profile.
Public property | CampaignPauseErrorThreshold | The maximum of database query failures that may occur in a campaign before it is paused.
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' CCSConfiguration..::..Property >)>)>.)
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | DialerVersion | The current version of Dialer.
Public property | EnableHistoryLoggingOnODS | Obsolete. Toggles the logging of history data as .csv files on outbound dialing servers.
Public property | HttpAddress | The name of the network interface that the HTTP server accepts requests on.
Public property | HttpPort | The port number that the HTTP Server accepts requests on.
Public property | IsdnBusySignalFile | The name of the wave file to play to agents when a busy signal is encountered on a Preview call.
Public property | IsdnConnectFailedFile | The name of the wave file to play to agents when a Preview call encounters Special Information Tones, such as an invalid number, out of service, etc.
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | MasterODS | The Id of the outbound dialing server which should be used to send notifications when errors or outages occur.
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | OverrideLogonCampaign | Overrides Logon Campaign security right.
Public property | PenetrationRetentionDuration | The amount of time before penetration data is deleted from the database.
Public property | ResetTimeCalendarDay | Determines whether the call totals are reset at midnight using local time or UTC time based on the ResetTimeLocal property, or reset after 24 hours. By default, it is set to false, meaning to reset counts after 24 hours
Public property | ResetTimeLocal | Determines whether the call totals are reset at midnight using local time. By default, it is set to false, meaning to reset counts using UTC time.
Public property | RevisionLevel | The current version of this object.
Public property | SwitchoverBackupServer | The name of the backup server in the Switchover pair.
Public property | UdlPath | The file path where UDL files are stored on the Central Campaign Server.
Public property | UseHttps | Toggles the requirement of secure connections for the HTTP Server.

See Also

CCSConfiguration Class


CCSConfiguration Methods

[image] [image]

IceLib Dialer Technical Reference
CCSConfiguration Methods
CCSConfiguration Class See Also Send Feedback

The CCSConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' CCSConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' CCSConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' CCSConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' CCSConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' CCSConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' CCSConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' CCSConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' CCSConfiguration..::..Property >)>)>.)
Public method | RestartHttpServer | Starts or restarts the Central Campaign Server's http server.
Public method | RestartHttpserverAsync | Asynchronously starts or restarts the Central Campaign Server's http server.
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' CCSConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' CCSConfiguration..::..Property >)>)>.)
Public method | ToString | (Inherited from ConfigurationObject.)

See Also

CCSConfiguration Class


RestartHttpServer Method

[image]

IceLib Dialer Technical Reference
CCSConfiguration..::..RestartHttpServer Method
CCSConfiguration Class See Also Send Feedback
Starts or restarts the Central Campaign Server's http server.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool RestartHttpServer()
Visual Basic
Public Function RestartHttpServer As Boolean

Return Value

true if successful, false otherwise

See Also

CCSConfiguration Class
CCSConfiguration Members


RestartHttpserverAsync Method

[image]

IceLib Dialer Technical Reference
CCSConfiguration..::..RestartHttpserverAsync Method
CCSConfiguration Class See Also Send Feedback
Asynchronously starts or restarts the Central Campaign Server's http server.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void RestartHttpserverAsync(
    EventHandler<AsyncCompletedEventArgs<bool>> completionCallback,
    Object state
)
Visual Basic
Public Sub RestartHttpserverAsync ( _
    completionCallback As EventHandler(Of AsyncCompletedEventArgs(Of Boolean)), _
    state As Object _
)

Parameters

completionCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Boolean>)>)>>)>)>
The method to call upon completion.
state
Type: System..::..Object

See Also

CCSConfiguration Class
CCSConfiguration Members


CCSConfiguration Properties

[image] [image]

IceLib Dialer Technical Reference
CCSConfiguration Properties
CCSConfiguration Class See Also Send Feedback

The CCSConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AuditingConnection | The Id of the connection where the configuration auditing table resides.
Public property | AuditingEnabled | Toggles activation of configuration auditing.
Public property | AuditingRetentionTime | The maximum number of days to retain configuration audit entries before deleting them.
Public property | AutomaticDispositionDelay | The length of time in seconds that automatic dispositions are delayed when an interaction disconnects without an explicit disposition. This only applies to interactions that were transferred away from the agent or to an Attendant profile.
Public property | CampaignPauseErrorThreshold | The maximum of database query failures that may occur in a campaign before it is paused.
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' CCSConfiguration..::..Property >)>)>.)
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | DialerVersion | The current version of Dialer.
Public property | EnableHistoryLoggingOnODS | Obsolete. Toggles the logging of history data as .csv files on outbound dialing servers.
Public property | HttpAddress | The name of the network interface that the HTTP server accepts requests on.
Public property | HttpPort | The port number that the HTTP Server accepts requests on.
Public property | IsdnBusySignalFile | The name of the wave file to play to agents when a busy signal is encountered on a Preview call.
Public property | IsdnConnectFailedFile | The name of the wave file to play to agents when a Preview call encounters Special Information Tones, such as an invalid number, out of service, etc.
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | MasterODS | The Id of the outbound dialing server which should be used to send notifications when errors or outages occur.
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | OverrideLogonCampaign | Overrides Logon Campaign security right.
Public property | PenetrationRetentionDuration | The amount of time before penetration data is deleted from the database.
Public property | ResetTimeCalendarDay | Determines whether the call totals are reset at midnight using local time or UTC time based on the ResetTimeLocal property, or reset after 24 hours. By default, it is set to false, meaning to reset counts after 24 hours
Public property | ResetTimeLocal | Determines whether the call totals are reset at midnight using local time. By default, it is set to false, meaning to reset counts using UTC time.
Public property | RevisionLevel | The current version of this object.
Public property | SwitchoverBackupServer | The name of the backup server in the Switchover pair.
Public property | UdlPath | The file path where UDL files are stored on the Central Campaign Server.
Public property | UseHttps | Toggles the requirement of secure connections for the HTTP Server.

See Also

CCSConfiguration Class


AuditingConnection Property

[image]

IceLib Dialer Technical Reference
CCSConfiguration..::..AuditingConnection Property
CCSConfiguration Class See Also Send Feedback
The Id of the connection where the configuration auditing table resides.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CCSConfiguration..::..Property, ConfigurationId> AuditingConnection { get; }
Visual Basic
Public ReadOnly Property AuditingConnection As GeneralConfigurationProperty(Of CCSConfiguration..::..Property, ConfigurationId)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CCSConfiguration Class
CCSConfiguration Members


AuditingEnabled Property

[image]

IceLib Dialer Technical Reference
CCSConfiguration..::..AuditingEnabled Property
CCSConfiguration Class See Also Send Feedback
Toggles activation of configuration auditing.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CCSConfiguration..::..Property, bool> AuditingEnabled { get; }
Visual Basic
Public ReadOnly Property AuditingEnabled As GeneralConfigurationProperty(Of CCSConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CCSConfiguration Class
CCSConfiguration Members


AuditingRetentionTime Property

[image]

IceLib Dialer Technical Reference
CCSConfiguration..::..AuditingRetentionTime Property
CCSConfiguration Class See Also Send Feedback
The maximum number of days to retain configuration audit entries before deleting them.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CCSConfiguration..::..Property, int> AuditingRetentionTime { get; }
Visual Basic
Public ReadOnly Property AuditingRetentionTime As GeneralConfigurationProperty(Of CCSConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CCSConfiguration Class
CCSConfiguration Members


AutomaticDispositionDelay Property

[image]

IceLib Dialer Technical Reference
CCSConfiguration..::..AutomaticDispositionDelay Property
CCSConfiguration Class See Also Send Feedback
The length of time in seconds that automatic dispositions are delayed when an interaction disconnects without an explicit disposition. This only applies to interactions that were transferred away from the agent or to an Attendant profile.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CCSConfiguration..::..Property, int> AutomaticDispositionDelay { get; }
Visual Basic
Public ReadOnly Property AutomaticDispositionDelay As GeneralConfigurationProperty(Of CCSConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CCSConfiguration Class
CCSConfiguration Members


CampaignPauseErrorThreshold Property

[image]

IceLib Dialer Technical Reference
CCSConfiguration..::..CampaignPauseErrorThreshold Property
CCSConfiguration Class See Also Send Feedback
The maximum of database query failures that may occur in a campaign before it is paused.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CCSConfiguration..::..Property, int> CampaignPauseErrorThreshold { get; }
Visual Basic
Public ReadOnly Property CampaignPauseErrorThreshold As GeneralConfigurationProperty(Of CCSConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CCSConfiguration Class
CCSConfiguration Members


DialerVersion Property

[image]

IceLib Dialer Technical Reference
CCSConfiguration..::..DialerVersion Property
CCSConfiguration Class See Also Send Feedback
The current version of Dialer.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CCSConfiguration..::..Property, string> DialerVersion { get; }
Visual Basic
Public ReadOnly Property DialerVersion As GeneralConfigurationProperty(Of CCSConfiguration..::..Property, String)
    Get

See Also

CCSConfiguration Class
CCSConfiguration Members


EnableHistoryLoggingOnODS Property

[image]

IceLib Dialer Technical Reference
CCSConfiguration..::..EnableHistoryLoggingOnODS Property
CCSConfiguration Class See Also Send Feedback
Toggles the logging of history data as .csv files on outbound dialing servers.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
[ObsoleteAttribute("This option is no longer supported")]
public GeneralConfigurationProperty<CCSConfiguration..::..Property, bool> EnableHistoryLoggingOnODS { get; }
Visual Basic
<ObsoleteAttribute("This option is no longer supported")> _
Public ReadOnly Property EnableHistoryLoggingOnODS As GeneralConfigurationProperty(Of CCSConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CCSConfiguration Class
CCSConfiguration Members


HttpAddress Property

[image]

IceLib Dialer Technical Reference
CCSConfiguration..::..HttpAddress Property
CCSConfiguration Class See Also Send Feedback
The name of the network interface that the HTTP server accepts requests on.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CCSConfiguration..::..Property, string> HttpAddress { get; }
Visual Basic
Public ReadOnly Property HttpAddress As GeneralConfigurationProperty(Of CCSConfiguration..::..Property, String)
    Get

Remarks

Valid values are obtained by accessing the Name of an object in the Interfaces collection of an HttpRequestKey.

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CCSConfiguration Class
CCSConfiguration Members


HttpPort Property

[image]

IceLib Dialer Technical Reference
CCSConfiguration..::..HttpPort Property
CCSConfiguration Class See Also Send Feedback
The port number that the HTTP Server accepts requests on.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CCSConfiguration..::..Property, int> HttpPort { get; }
Visual Basic
Public ReadOnly Property HttpPort As GeneralConfigurationProperty(Of CCSConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CCSConfiguration Class
CCSConfiguration Members


IsdnBusySignalFile Property

[image]

IceLib Dialer Technical Reference
CCSConfiguration..::..IsdnBusySignalFile Property
CCSConfiguration Class See Also Send Feedback
The name of the wave file to play to agents when a busy signal is encountered on a Preview call.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CCSConfiguration..::..Property, string> IsdnBusySignalFile { get; }
Visual Basic
Public ReadOnly Property IsdnBusySignalFile As GeneralConfigurationProperty(Of CCSConfiguration..::..Property, String)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CCSConfiguration Class
CCSConfiguration Members


IsdnConnectFailedFile Property

[image]

IceLib Dialer Technical Reference
CCSConfiguration..::..IsdnConnectFailedFile Property
CCSConfiguration Class See Also Send Feedback
The name of the wave file to play to agents when a Preview call encounters Special Information Tones, such as an invalid number, out of service, etc.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CCSConfiguration..::..Property, string> IsdnConnectFailedFile { get; }
Visual Basic
Public ReadOnly Property IsdnConnectFailedFile As GeneralConfigurationProperty(Of CCSConfiguration..::..Property, String)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CCSConfiguration Class
CCSConfiguration Members


MasterODS Property

[image]

IceLib Dialer Technical Reference
CCSConfiguration..::..MasterODS Property
CCSConfiguration Class See Also Send Feedback
The Id of the outbound dialing server which should be used to send notifications when errors or outages occur.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CCSConfiguration..::..Property, ConfigurationId> MasterODS { get; }
Visual Basic
Public ReadOnly Property MasterODS As GeneralConfigurationProperty(Of CCSConfiguration..::..Property, ConfigurationId)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CCSConfiguration Class
CCSConfiguration Members


OverrideLogonCampaign Property

[image]

IceLib Dialer Technical Reference
CCSConfiguration..::..OverrideLogonCampaign Property
CCSConfiguration Class See Also Send Feedback
Overrides Logon Campaign security right.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CCSConfiguration..::..Property, bool> OverrideLogonCampaign { get; }
Visual Basic
Public ReadOnly Property OverrideLogonCampaign As GeneralConfigurationProperty(Of CCSConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CCSConfiguration Class
CCSConfiguration Members


PenetrationRetentionDuration Property

[image]

IceLib Dialer Technical Reference
CCSConfiguration..::..PenetrationRetentionDuration Property
CCSConfiguration Class See Also Send Feedback
The amount of time before penetration data is deleted from the database.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CCSConfiguration..::..Property, int> PenetrationRetentionDuration { get; }
Visual Basic
Public ReadOnly Property PenetrationRetentionDuration As GeneralConfigurationProperty(Of CCSConfiguration..::..Property, Integer)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CCSConfiguration Class
CCSConfiguration Members


ResetTimeCalendarDay Property

[image]

IceLib Dialer Technical Reference
CCSConfiguration..::..ResetTimeCalendarDay Property
CCSConfiguration Class See Also Send Feedback
Determines whether the call totals are reset at midnight using local time or UTC time based on the ResetTimeLocal property, or reset after 24 hours. By default, it is set to false, meaning to reset counts after 24 hours

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CCSConfiguration..::..Property, bool> ResetTimeCalendarDay { get; }
Visual Basic
Public ReadOnly Property ResetTimeCalendarDay As GeneralConfigurationProperty(Of CCSConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CCSConfiguration Class
CCSConfiguration Members


ResetTimeLocal Property

[image]

IceLib Dialer Technical Reference
CCSConfiguration..::..ResetTimeLocal Property
CCSConfiguration Class See Also Send Feedback
Determines whether the call totals are reset at midnight using local time. By default, it is set to false, meaning to reset counts using UTC time.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CCSConfiguration..::..Property, bool> ResetTimeLocal { get; }
Visual Basic
Public ReadOnly Property ResetTimeLocal As GeneralConfigurationProperty(Of CCSConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CCSConfiguration Class
CCSConfiguration Members


RevisionLevel Property

[image]

IceLib Dialer Technical Reference
CCSConfiguration..::..RevisionLevel Property
CCSConfiguration Class See Also Send Feedback
The current version of this object.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CCSConfiguration..::..Property, int> RevisionLevel { get; }
Visual Basic
Public ReadOnly Property RevisionLevel As GeneralConfigurationProperty(Of CCSConfiguration..::..Property, Integer)
    Get

See Also

CCSConfiguration Class
CCSConfiguration Members


SwitchoverBackupServer Property

[image]

IceLib Dialer Technical Reference
CCSConfiguration..::..SwitchoverBackupServer Property
CCSConfiguration Class See Also Send Feedback
The name of the backup server in the Switchover pair.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CCSConfiguration..::..Property, string> SwitchoverBackupServer { get; }
Visual Basic
Public ReadOnly Property SwitchoverBackupServer As GeneralConfigurationProperty(Of CCSConfiguration..::..Property, String)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CCSConfiguration Class
CCSConfiguration Members


UdlPath Property

[image]

IceLib Dialer Technical Reference
CCSConfiguration..::..UdlPath Property
CCSConfiguration Class See Also Send Feedback
The file path where UDL files are stored on the Central Campaign Server.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CCSConfiguration..::..Property, string> UdlPath { get; }
Visual Basic
Public ReadOnly Property UdlPath As GeneralConfigurationProperty(Of CCSConfiguration..::..Property, String)
    Get

See Also

CCSConfiguration Class
CCSConfiguration Members


UseHttps Property

[image]

IceLib Dialer Technical Reference
CCSConfiguration..::..UseHttps Property
CCSConfiguration Class See Also Send Feedback
Toggles the requirement of secure connections for the HTTP Server.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<CCSConfiguration..::..Property, bool> UseHttps { get; }
Visual Basic
Public ReadOnly Property UseHttps As GeneralConfigurationProperty(Of CCSConfiguration..::..Property, Boolean)
    Get

Exceptions

Exception | Condition
InsufficientRightsException | The user does not have permission to view the property.

See Also

CCSConfiguration Class
CCSConfiguration Members


CCSConfiguration.Property Enumeration

[image]

IceLib Dialer Technical Reference
CCSConfiguration..::..Property Enumeration
CCSConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Id | 0 | Represents the Id part of the ConfigurationId property.
DisplayName | 1 | Represents the DisplayName part of the ConfigurationId property.
AuditingEnabled | 2 | Represents the AuditingEnabled property.
AuditingConnection | 3 | Represents the AuditingConnection property.
AuditingRetentionTime | 4 | Represents the AuditingRetentionTime property.
AutomaticDispositionDelay | 5 | Represents the AutomaticDispositionDelay property.
CampaignPauseErrorThreshold | 6 | Represents the CampaignPauseErrorThreshold property.
PenetrationRetentionDuration | 7 | Represents the PenetrationRetentionDuration property.
DialerVersion | 8 | Represents the DialerVersion property.
HttpAddress | 9 | Represents the HttpAddress property.
HttpPort | 10 | Represents the HttpPort property.
IsdnBusySignalFile | 11 | Represents the IsdnBusySignalFile property.
IsdnConnectFailedFile | 12 | Represents the IsdnConnectFailedFile property.
EnableHistoryLoggingOnODS | 13 | Obsolete. Represents the EnableHistoryLoggingOnODS property.
MasterODS | 14 | Represents the MasterODS property.
SwitchoverBackupServer | 15 | Represents the SwitchoverBackupServer property.
UdlPath | 16 | Represents the UdlPath property.
UseHttps | 17 | Represents the UseHttps property.
RevisionLevel | 18 | Represents the RevisionLevel property.
OverrideLogonCampaign | 19 | Represents the OverrideLogonCampaign property.
ResetTimeLocal | 20 | Represents the ResetTimeLocal property.
ResetTimeCalendarDay | 21 | Represents the ResetTimeCalendarDay property.

See Also


CCSConfigurationList Class

[image]

IceLib Dialer Technical Reference
CCSConfigurationList Class
Members See Also Send Feedback
Allows for querying the central campaign server object.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class CCSConfigurationList : EditableConfigurationList<CCSConfiguration, CCSConfiguration..::..Property>
Visual Basic
Public Class CCSConfigurationList _
    Inherits EditableConfigurationList(Of CCSConfiguration, CCSConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>
DynamicConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>
EditableConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..CCSConfigurationList

See Also

CCSConfigurationList Members


CCSConfigurationList Members

[image] [image]

IceLib Dialer Technical Reference
CCSConfigurationList Members
CCSConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The CCSConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | CCSConfigurationList | Creates a new instance of the CCSConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)

See Also

CCSConfigurationList Class


CCSConfigurationList Constructor

[image]

IceLib Dialer Technical Reference
CCSConfigurationList Constructor
CCSConfigurationList Class See Also Send Feedback
Creates a new instance of the CCSConfigurationList class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CCSConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ConfigurationManager

See Also

CCSConfigurationList Class
CCSConfigurationList Members


CCSConfigurationList Methods

[image] [image]

IceLib Dialer Technical Reference
CCSConfigurationList Methods
CCSConfigurationList Class See Also Send Feedback

The CCSConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CCSConfigurationList Class


CCSConfigurationList Properties

[image] [image]

IceLib Dialer Technical Reference
CCSConfigurationList Properties
CCSConfigurationList Class See Also Send Feedback

The CCSConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)

See Also

CCSConfigurationList Class


CCSConfigurationList Events

[image] [image]

IceLib Dialer Technical Reference
CCSConfigurationList Events
CCSConfigurationList Class See Also Send Feedback

The CCSConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' CCSConfiguration, CCSConfiguration..::..Property >)>)>.)

See Also

CCSConfigurationList Class


ColumnExpression Class

[image]

IceLib Dialer Technical Reference
ColumnExpression Class
Members See Also Send Feedback
An expression representing a single database column.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class ColumnExpression : IInternalExpression,
    IExpression, ICloneable
Visual Basic
Public Class ColumnExpression _
    Implements IInternalExpression, IExpression, ICloneable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..ColumnExpression

See Also

ColumnExpression Members


ColumnExpression Members

[image] [image]

IceLib Dialer Technical Reference
ColumnExpression Members
ColumnExpression Class Constructors Methods Properties See Also Send Feedback

The ColumnExpression type exposes the following members.

Constructors

 | Name | Description
Public method | ColumnExpression | Creates a new column expression.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Column | The underlying table column.

See Also

ColumnExpression Class


ColumnExpression Constructor

[image]

IceLib Dialer Technical Reference
ColumnExpression Constructor
ColumnExpression Class See Also Send Feedback
Creates a new column expression.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ColumnExpression(
    DBColumn column
)
Visual Basic
Public Sub New ( _
    column As DBColumn _
)

Parameters

column
Type: ININ.IceLib.Configuration.Dialer.DataTypes..::..DBColumn
The table column represented by this expression.

See Also

ColumnExpression Class
ColumnExpression Members


ColumnExpression Methods

[image] [image]

IceLib Dialer Technical Reference
ColumnExpression Methods
ColumnExpression Class See Also Send Feedback

The ColumnExpression type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ColumnExpression Class


Clone Method

[image]

IceLib Dialer Technical Reference
ColumnExpression..::..Clone Method
ColumnExpression Class See Also Send Feedback
Creates a new object that is a copy of the current instance.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

A new object that is a copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

ColumnExpression Class
ColumnExpression Members


ToString Method

[image]

IceLib Dialer Technical Reference
ColumnExpression..::..ToString Method
ColumnExpression Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

See Also

ColumnExpression Class
ColumnExpression Members


ColumnExpression Properties

[image] [image]

IceLib Dialer Technical Reference
ColumnExpression Properties
ColumnExpression Class See Also Send Feedback

The ColumnExpression type exposes the following members.

Properties

 | Name | Description
Public property | Column | The underlying table column.

See Also

ColumnExpression Class


Column Property

[image]

IceLib Dialer Technical Reference
ColumnExpression..::..Column Property
ColumnExpression Class See Also Send Feedback
The underlying table column.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DBColumn Column { get; set; }
Visual Basic
Public Property Column As DBColumn
    Get
    Set

See Also

ColumnExpression Class
ColumnExpression Members


ConnectionConfiguration Class

[image]

IceLib Dialer Technical Reference
ConnectionConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for a Dialer database connection.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class ConnectionConfiguration : EditableListConfigurationObject<ConnectionConfiguration..::..Property>,
    IExportable
Visual Basic
Public Class ConnectionConfiguration _
    Inherits EditableListConfigurationObject(Of ConnectionConfiguration..::..Property) _
    Implements IExportable

Inheritance Hierarchy

System..::..Object
ConfigurationObject
ListConfigurationObject
EditableListConfigurationObject<(Of <(<' ConnectionConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..ConnectionConfiguration

See Also

ConnectionConfiguration Members


ConnectionConfiguration Members

[image] [image]

IceLib Dialer Technical Reference
ConnectionConfiguration Members
ConnectionConfiguration Class Methods Properties See Also Send Feedback

The ConnectionConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' ConnectionConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' ConnectionConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ConnectionConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' ConnectionConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ConnectionConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetColumns | Gets a list of columns from a table in the database.
Public method | GetColumnsAsync | Asynchronously retrieves a list of columns from a table in the database.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTables | Gets a list of tables from the database.
Public method | GetTablesAsync | Asynchronously retrieves a list of tables from the database.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' ConnectionConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ConnectionConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' ConnectionConfiguration..::..Property >)>)>.)
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' ConnectionConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' ConnectionConfiguration..::..Property >)>)>.)
Public method | Test | Verifies connection information by attempting to establish a connection to the database server.
Public method | TestAsync | Asynchronously verifies connection information by attempting to establish a connection to the database server.
Public method | ToString | (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' ConnectionConfiguration..::..Property >)>)>.)
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | DBMS | The type of database system represented by this connection.
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsExporting | Tells whether the current object is being used for exporting
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | RevisionLevel | The current version of this object.
Public property | UdlFile | The UDL file with connection information dialer to communicate with this database. This should be admin connection information.

See Also

ConnectionConfiguration Class


ConnectionConfiguration Methods

[image] [image]

IceLib Dialer Technical Reference
ConnectionConfiguration Methods
ConnectionConfiguration Class See Also Send Feedback

The ConnectionConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' ConnectionConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' ConnectionConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ConnectionConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' ConnectionConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ConnectionConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetColumns | Gets a list of columns from a table in the database.
Public method | GetColumnsAsync | Asynchronously retrieves a list of columns from a table in the database.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTables | Gets a list of tables from the database.
Public method | GetTablesAsync | Asynchronously retrieves a list of tables from the database.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' ConnectionConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ConnectionConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' ConnectionConfiguration..::..Property >)>)>.)
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' ConnectionConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' ConnectionConfiguration..::..Property >)>)>.)
Public method | Test | Verifies connection information by attempting to establish a connection to the database server.
Public method | TestAsync | Asynchronously verifies connection information by attempting to establish a connection to the database server.
Public method | ToString | (Inherited from ConfigurationObject.)

See Also

ConnectionConfiguration Class


GetColumns Method

[image]

IceLib Dialer Technical Reference
ConnectionConfiguration..::..GetColumns Method
ConnectionConfiguration Class See Also Send Feedback
Gets a list of columns from a table in the database.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DBColumn[] GetColumns(
    string tableName
)
Visual Basic
Public Function GetColumns ( _
    tableName As String _
) As DBColumn()

Parameters

tableName
Type: System..::..String
The name of the table to get columns from.

Return Value

An array of DBColumns

See Also

ConnectionConfiguration Class
ConnectionConfiguration Members


GetColumnsAsync Method

[image]

IceLib Dialer Technical Reference
ConnectionConfiguration..::..GetColumnsAsync Method
ConnectionConfiguration Class See Also Send Feedback
Asynchronously retrieves a list of columns from a table in the database.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void GetColumnsAsync(
    string tableName,
    EventHandler<AsyncCompletedEventArgs<DBColumn[]>> completionCallback,
    Object state
)
Visual Basic
Public Sub GetColumnsAsync ( _
    tableName As String, _
    completionCallback As EventHandler(Of AsyncCompletedEventArgs(Of DBColumn())), _
    state As Object _
)

Parameters

tableName
Type: System..::..String
The name of the table to get columns from.
completionCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'array< DBColumn >[]()[][]>)>)>>)>)>
state
Type: System..::..Object

See Also

ConnectionConfiguration Class
ConnectionConfiguration Members


GetTables Method

[image]

IceLib Dialer Technical Reference
ConnectionConfiguration..::..GetTables Method
ConnectionConfiguration Class See Also Send Feedback
Gets a list of tables from the database.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string[] GetTables()
Visual Basic
Public Function GetTables As String()

Return Value

An array of strings.

See Also

ConnectionConfiguration Class
ConnectionConfiguration Members


GetTablesAsync Method

[image]

IceLib Dialer Technical Reference
ConnectionConfiguration..::..GetTablesAsync Method
ConnectionConfiguration Class See Also Send Feedback
Asynchronously retrieves a list of tables from the database.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void GetTablesAsync(
    EventHandler<AsyncCompletedEventArgs<string[]>> completionCallback,
    Object state
)
Visual Basic
Public Sub GetTablesAsync ( _
    completionCallback As EventHandler(Of AsyncCompletedEventArgs(Of String())), _
    state As Object _
)

Parameters

completionCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'array<String>[]()[][]>)>)>>)>)>
state
Type: System..::..Object

See Also

ConnectionConfiguration Class
ConnectionConfiguration Members


Test Method

[image]

IceLib Dialer Technical Reference
ConnectionConfiguration..::..Test Method
ConnectionConfiguration Class See Also Send Feedback
Verifies connection information by attempting to establish a connection to the database server.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool Test()
Visual Basic
Public Function Test As Boolean

Return Value

true if successful, flase otherwise

See Also

ConnectionConfiguration Class
ConnectionConfiguration Members


TestAsync Method

[image]

IceLib Dialer Technical Reference
ConnectionConfiguration..::..TestAsync Method
ConnectionConfiguration Class See Also Send Feedback
Asynchronously verifies connection information by attempting to establish a connection to the database server.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void TestAsync(
    EventHandler<AsyncCompletedEventArgs<bool>> completionCallback,
    Object state
)
Visual Basic
Public Sub TestAsync ( _
    completionCallback As EventHandler(Of AsyncCompletedEventArgs(Of Boolean)), _
    state As Object _
)

Parameters

completionCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Boolean>)>)>>)>)>
state
Type: System..::..Object

See Also

ConnectionConfiguration Class
ConnectionConfiguration Members


ConnectionConfiguration Properties

[image] [image]

IceLib Dialer Technical Reference
ConnectionConfiguration Properties
ConnectionConfiguration Class See Also Send Feedback

The ConnectionConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' ConnectionConfiguration..::..Property >)>)>.)
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | DBMS | The type of database system represented by this connection.
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsExporting | Tells whether the current object is being used for exporting
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | RevisionLevel | The current version of this object.
Public property | UdlFile | The UDL file with connection information dialer to communicate with this database. This should be admin connection information.

See Also

ConnectionConfiguration Class


DBMS Property

[image]

IceLib Dialer Technical Reference
ConnectionConfiguration..::..DBMS Property
ConnectionConfiguration Class See Also Send Feedback
The type of database system represented by this connection.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<ConnectionConfiguration..::..Property, DatabaseType> DBMS { get; }
Visual Basic
Public ReadOnly Property DBMS As GeneralConfigurationProperty(Of ConnectionConfiguration..::..Property, DatabaseType)
    Get

See Also

ConnectionConfiguration Class
ConnectionConfiguration Members


IsDefaultObject Property

[image]

IceLib Dialer Technical Reference
ConnectionConfiguration..::..IsDefaultObject Property
ConnectionConfiguration Class See Also Send Feedback
Indicates whether this is the default instance of this object type.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsDefaultObject { get; }
Visual Basic
Public ReadOnly Property IsDefaultObject As Boolean
    Get

See Also

ConnectionConfiguration Class
ConnectionConfiguration Members


IsExporting Property

[image]

IceLib Dialer Technical Reference
ConnectionConfiguration..::..IsExporting Property
ConnectionConfiguration Class See Also Send Feedback
Tells whether the current object is being used for exporting

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsExporting { get; private set; }
Visual Basic
Public Property IsExporting As Boolean
    Get
    Private Set

See Also

ConnectionConfiguration Class
ConnectionConfiguration Members


RevisionLevel Property

[image]

IceLib Dialer Technical Reference
ConnectionConfiguration..::..RevisionLevel Property
ConnectionConfiguration Class See Also Send Feedback
The current version of this object.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<ConnectionConfiguration..::..Property, int> RevisionLevel { get; }
Visual Basic
Public ReadOnly Property RevisionLevel As GeneralConfigurationProperty(Of ConnectionConfiguration..::..Property, Integer)
    Get

See Also

ConnectionConfiguration Class
ConnectionConfiguration Members


UdlFile Property

[image]

IceLib Dialer Technical Reference
ConnectionConfiguration..::..UdlFile Property
ConnectionConfiguration Class See Also Send Feedback
The UDL file with connection information dialer to communicate with this database. This should be admin connection information.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<ConnectionConfiguration..::..Property, string> UdlFile { get; }
Visual Basic
Public ReadOnly Property UdlFile As GeneralConfigurationProperty(Of ConnectionConfiguration..::..Property, String)
    Get

See Also

ConnectionConfiguration Class
ConnectionConfiguration Members


ConnectionConfiguration.Property Enumeration

[image]

IceLib Dialer Technical Reference
ConnectionConfiguration..::..Property Enumeration
ConnectionConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Id | 0 | Represents the Id part of the ConfigurationId property.
DisplayName | 1 | Represents the DisplayName part of the ConfigurationId property.
UdlFile | 2 | Represents the UdlFile property.
DBMS | 3 | Represents the DBMS property.
RevisionLevel | 4 | Represents the RevisionLevel property.

See Also


ConnectionConfigurationList Class

[image]

IceLib Dialer Technical Reference
ConnectionConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing database connection configuration objects.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class ConnectionConfigurationList : EditableConfigurationList<ConnectionConfiguration, ConnectionConfiguration..::..Property>
Visual Basic
Public Class ConnectionConfigurationList _
    Inherits EditableConfigurationList(Of ConnectionConfiguration, ConnectionConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>
DynamicConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>
EditableConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..ConnectionConfigurationList

See Also

ConnectionConfigurationList Members


ConnectionConfigurationList Members

[image] [image]

IceLib Dialer Technical Reference
ConnectionConfigurationList Members
ConnectionConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The ConnectionConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | ConnectionConfigurationList | Initializes a new instance of the FilterConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)

See Also

ConnectionConfigurationList Class


ConnectionConfigurationList Constructor

[image]

IceLib Dialer Technical Reference
ConnectionConfigurationList Constructor
ConnectionConfigurationList Class See Also Send Feedback
Initializes a new instance of the FilterConfigurationList class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ConnectionConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

ConnectionConfigurationList Class
ConnectionConfigurationList Members


ConnectionConfigurationList Methods

[image] [image]

IceLib Dialer Technical Reference
ConnectionConfigurationList Methods
ConnectionConfigurationList Class See Also Send Feedback

The ConnectionConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ConnectionConfigurationList Class


ConnectionConfigurationList Properties

[image] [image]

IceLib Dialer Technical Reference
ConnectionConfigurationList Properties
ConnectionConfigurationList Class See Also Send Feedback

The ConnectionConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)

See Also

ConnectionConfigurationList Class


ConnectionConfigurationList Events

[image] [image]

IceLib Dialer Technical Reference
ConnectionConfigurationList Events
ConnectionConfigurationList Class See Also Send Feedback

The ConnectionConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' ConnectionConfiguration, ConnectionConfiguration..::..Property >)>)>.)

See Also

ConnectionConfigurationList Class


ConstantExpression Class

[image]

IceLib Dialer Technical Reference
ConstantExpression Class
Members See Also Send Feedback
An expression representing a single constant.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class ConstantExpression : IInternalExpression,
    IExpression, ICloneable
Visual Basic
Public Class ConstantExpression _
    Implements IInternalExpression, IExpression, ICloneable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..ConstantExpression

See Also

ConstantExpression Members


ConstantExpression Members

[image] [image]

IceLib Dialer Technical Reference
ConstantExpression Members
ConstantExpression Class Constructors Methods Properties See Also Send Feedback

The ConstantExpression type exposes the following members.

Constructors

 | Name | Description
Public method | ConstantExpression(Object, DBColumn) | Creates a new instance of the ConstantExpression class.
Public method | ConstantExpression(Object, OleDbType, Int32, Int32, Int32) | Creates a new instance of the ConstantExpression class.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | DataType | The datatype of the constant.
Public property | Precision | The the maximum number of digits used to represent numeric values.
Public property | Scale | The number of decimal places to which numeric values should be resolved.
Public property | Size | The size of the constant.
Public property | Value | The value of the underlying constant.

See Also

ConstantExpression Class


ConstantExpression Constructor

[image] [image]

IceLib Dialer Technical Reference
ConstantExpression Constructor
ConstantExpression Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ConstantExpression(Object, DBColumn) | Creates a new instance of the ConstantExpression class.
Public method | ConstantExpression(Object, OleDbType, Int32, Int32, Int32) | Creates a new instance of the ConstantExpression class.

See Also

ConstantExpression Class
ConstantExpression Members


ConstantExpression Constructor (Object, DBColumn)

[image]

IceLib Dialer Technical Reference
ConstantExpression Constructor (Object, DBColumn)
ConstantExpression Class See Also Send Feedback
Creates a new instance of the ConstantExpression class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ConstantExpression(
    Object value,
    DBColumn column
)
Visual Basic
Public Sub New ( _
    value As Object, _
    column As DBColumn _
)

Parameters

value
Type: System..::..Object
The value of the constant.
column
Type: ININ.IceLib.Configuration.Dialer.DataTypes..::..DBColumn
The database column that corresponds to the value.

See Also

ConstantExpression Class
ConstantExpression Members
ConstantExpression Overload


ConstantExpression Constructor (Object, OleDbType, Int32, Int32, Int32)

[image]

IceLib Dialer Technical Reference
ConstantExpression Constructor (Object, OleDbType, Int32, Int32, Int32)
ConstantExpression Class See Also Send Feedback
Creates a new instance of the ConstantExpression class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ConstantExpression(
    Object value,
    OleDbType dataType,
    int size,
    int scale,
    int precision
)
Visual Basic
Public Sub New ( _
    value As Object, _
    dataType As OleDbType, _
    size As Integer, _
    scale As Integer, _
    precision As Integer _
)

Parameters

value
Type: System..::..Object
The value of the constant.
dataType
Type: System.Data.OleDb..::..OleDbType
The datatype of the constant.
size
Type: System..::..Int32
The size of the constant. This may be zero unless the constant is a variable type (ex. varchar).
scale
Type: System..::..Int32
The scale of the constant. This may be zero unless the constant is a decimal type.
precision
Type: System..::..Int32
The precision of the constant. This may be zero unless the constant is a decimal type.

See Also

ConstantExpression Class
ConstantExpression Members
ConstantExpression Overload


ConstantExpression Methods

[image] [image]

IceLib Dialer Technical Reference
ConstantExpression Methods
ConstantExpression Class See Also Send Feedback

The ConstantExpression type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

ConstantExpression Class


Clone Method

[image]

IceLib Dialer Technical Reference
ConstantExpression..::..Clone Method
ConstantExpression Class See Also Send Feedback
Creates a new object that is a copy of the current instance.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

A new object that is a copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

ConstantExpression Class
ConstantExpression Members


ToString Method

[image]

IceLib Dialer Technical Reference
ConstantExpression..::..ToString Method
ConstantExpression Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

See Also

ConstantExpression Class
ConstantExpression Members


ConstantExpression Properties

[image] [image]

IceLib Dialer Technical Reference
ConstantExpression Properties
ConstantExpression Class See Also Send Feedback

The ConstantExpression type exposes the following members.

Properties

 | Name | Description
Public property | DataType | The datatype of the constant.
Public property | Precision | The the maximum number of digits used to represent numeric values.
Public property | Scale | The number of decimal places to which numeric values should be resolved.
Public property | Size | The size of the constant.
Public property | Value | The value of the underlying constant.

See Also

ConstantExpression Class


DataType Property

[image]

IceLib Dialer Technical Reference
ConstantExpression..::..DataType Property
ConstantExpression Class See Also Send Feedback
The datatype of the constant.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public OleDbType DataType { get; set; }
Visual Basic
Public Property DataType As OleDbType
    Get
    Set

See Also

ConstantExpression Class
ConstantExpression Members


Precision Property

[image]

IceLib Dialer Technical Reference
ConstantExpression..::..Precision Property
ConstantExpression Class See Also Send Feedback
The the maximum number of digits used to represent numeric values.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int Precision { get; set; }
Visual Basic
Public Property Precision As Integer
    Get
    Set

See Also

ConstantExpression Class
ConstantExpression Members


Scale Property

[image]

IceLib Dialer Technical Reference
ConstantExpression..::..Scale Property
ConstantExpression Class See Also Send Feedback
The number of decimal places to which numeric values should be resolved.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int Scale { get; set; }
Visual Basic
Public Property Scale As Integer
    Get
    Set

See Also

ConstantExpression Class
ConstantExpression Members


Size Property

[image]

IceLib Dialer Technical Reference
ConstantExpression..::..Size Property
ConstantExpression Class See Also Send Feedback
The size of the constant.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int Size { get; set; }
Visual Basic
Public Property Size As Integer
    Get
    Set

See Also

ConstantExpression Class
ConstantExpression Members


Value Property

[image]

IceLib Dialer Technical Reference
ConstantExpression..::..Value Property
ConstantExpression Class See Also Send Feedback
The value of the underlying constant.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Object Value { get; set; }
Visual Basic
Public Property Value As Object
    Get
    Set

See Also

ConstantExpression Class
ConstantExpression Members


ContactColumnConfiguration Class

[image]

IceLib Dialer Technical Reference
ContactColumnConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for a database column that contains phone numbers.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class ContactColumnConfiguration : EditableListConfigurationObject<ContactColumnConfiguration..::..Property>,
    IExportable
Visual Basic
Public Class ContactColumnConfiguration _
    Inherits EditableListConfigurationObject(Of ContactColumnConfiguration..::..Property) _
    Implements IExportable

Inheritance Hierarchy

System..::..Object
ConfigurationObject
ListConfigurationObject
EditableListConfigurationObject<(Of <(<' ContactColumnConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..ContactColumnConfiguration

See Also

ContactColumnConfiguration Members


ContactColumnConfiguration Members

[image] [image]

IceLib Dialer Technical Reference
ContactColumnConfiguration Members
ContactColumnConfiguration Class Methods Properties See Also Send Feedback

The ContactColumnConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' ContactColumnConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' ContactColumnConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ContactColumnConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' ContactColumnConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ContactColumnConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' ContactColumnConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ContactColumnConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' ContactColumnConfiguration..::..Property >)>)>.)
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' ContactColumnConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' ContactColumnConfiguration..::..Property >)>)>.)
Public method | ToString | (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' ContactColumnConfiguration..::..Property >)>)>.)
Public property | ColumnName | The name of the database column.
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | ContactColumnId | An internally-maintained Id for this contact column.
Public property | ContactList | The Id of the contact list associated with this contact column.
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsExporting | Tells whether the current object is being used for exporting
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | PhoneNumberType | The Id of the phone number type associated with this contact column.
Public property | RevisionLevel | The current version of this object.
Public property | TableName | The name of the database table housing the column specified by ColumnName.

See Also

ContactColumnConfiguration Class


ContactColumnConfiguration Methods

[image] [image]

IceLib Dialer Technical Reference
ContactColumnConfiguration Methods
ContactColumnConfiguration Class See Also Send Feedback

The ContactColumnConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' ContactColumnConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' ContactColumnConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ContactColumnConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' ContactColumnConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ContactColumnConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' ContactColumnConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ContactColumnConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' ContactColumnConfiguration..::..Property >)>)>.)
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' ContactColumnConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' ContactColumnConfiguration..::..Property >)>)>.)
Public method | ToString | (Inherited from ConfigurationObject.)

See Also

ContactColumnConfiguration Class


ContactColumnConfiguration Properties

[image] [image]

IceLib Dialer Technical Reference
ContactColumnConfiguration Properties
ContactColumnConfiguration Class See Also Send Feedback

The ContactColumnConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' ContactColumnConfiguration..::..Property >)>)>.)
Public property | ColumnName | The name of the database column.
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | ContactColumnId | An internally-maintained Id for this contact column.
Public property | ContactList | The Id of the contact list associated with this contact column.
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsExporting | Tells whether the current object is being used for exporting
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | PhoneNumberType | The Id of the phone number type associated with this contact column.
Public property | RevisionLevel | The current version of this object.
Public property | TableName | The name of the database table housing the column specified by ColumnName.

See Also

ContactColumnConfiguration Class


ColumnName Property

[image]

IceLib Dialer Technical Reference
ContactColumnConfiguration..::..ColumnName Property
ContactColumnConfiguration Class See Also Send Feedback
The name of the database column.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<ContactColumnConfiguration..::..Property, string> ColumnName { get; }
Visual Basic
Public ReadOnly Property ColumnName As GeneralConfigurationProperty(Of ContactColumnConfiguration..::..Property, String)
    Get

See Also

ContactColumnConfiguration Class
ContactColumnConfiguration Members


ContactColumnId Property

[image]

IceLib Dialer Technical Reference
ContactColumnConfiguration..::..ContactColumnId Property
ContactColumnConfiguration Class See Also Send Feedback
An internally-maintained Id for this contact column.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<ContactColumnConfiguration..::..Property, long> ContactColumnId { get; }
Visual Basic
Public ReadOnly Property ContactColumnId As GeneralConfigurationProperty(Of ContactColumnConfiguration..::..Property, Long)
    Get

See Also

ContactColumnConfiguration Class
ContactColumnConfiguration Members


ContactList Property

[image]

IceLib Dialer Technical Reference
ContactColumnConfiguration..::..ContactList Property
ContactColumnConfiguration Class See Also Send Feedback
The Id of the contact list associated with this contact column.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<ContactColumnConfiguration..::..Property, ConfigurationId> ContactList { get; }
Visual Basic
Public ReadOnly Property ContactList As GeneralConfigurationProperty(Of ContactColumnConfiguration..::..Property, ConfigurationId)
    Get

See Also

ContactColumnConfiguration Class
ContactColumnConfiguration Members


IsDefaultObject Property

[image]

IceLib Dialer Technical Reference
ContactColumnConfiguration..::..IsDefaultObject Property
ContactColumnConfiguration Class See Also Send Feedback
Indicates whether this is the default instance of this object type.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsDefaultObject { get; }
Visual Basic
Public ReadOnly Property IsDefaultObject As Boolean
    Get

See Also

ContactColumnConfiguration Class
ContactColumnConfiguration Members


IsExporting Property

[image]

IceLib Dialer Technical Reference
ContactColumnConfiguration..::..IsExporting Property
ContactColumnConfiguration Class See Also Send Feedback
Tells whether the current object is being used for exporting

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsExporting { get; private set; }
Visual Basic
Public Property IsExporting As Boolean
    Get
    Private Set

See Also

ContactColumnConfiguration Class
ContactColumnConfiguration Members


PhoneNumberType Property

[image]

IceLib Dialer Technical Reference
ContactColumnConfiguration..::..PhoneNumberType Property
ContactColumnConfiguration Class See Also Send Feedback
The Id of the phone number type associated with this contact column.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<ContactColumnConfiguration..::..Property, ConfigurationId> PhoneNumberType { get; }
Visual Basic
Public ReadOnly Property PhoneNumberType As GeneralConfigurationProperty(Of ContactColumnConfiguration..::..Property, ConfigurationId)
    Get

See Also

ContactColumnConfiguration Class
ContactColumnConfiguration Members


RevisionLevel Property

[image]

IceLib Dialer Technical Reference
ContactColumnConfiguration..::..RevisionLevel Property
ContactColumnConfiguration Class See Also Send Feedback
The current version of this object.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<ContactColumnConfiguration..::..Property, int> RevisionLevel { get; }
Visual Basic
Public ReadOnly Property RevisionLevel As GeneralConfigurationProperty(Of ContactColumnConfiguration..::..Property, Integer)
    Get

See Also

ContactColumnConfiguration Class
ContactColumnConfiguration Members


TableName Property

[image]

IceLib Dialer Technical Reference
ContactColumnConfiguration..::..TableName Property
ContactColumnConfiguration Class See Also Send Feedback
The name of the database table housing the column specified by ColumnName.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<ContactColumnConfiguration..::..Property, string> TableName { get; }
Visual Basic
Public ReadOnly Property TableName As GeneralConfigurationProperty(Of ContactColumnConfiguration..::..Property, String)
    Get

See Also

ContactColumnConfiguration Class
ContactColumnConfiguration Members


ContactColumnConfiguration.Property Enumeration

[image]

IceLib Dialer Technical Reference
ContactColumnConfiguration..::..Property Enumeration
ContactColumnConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Id | 0 | Represents the Id part of the ConfigurationId property.
DisplayName | 1 | Represents the DisplayName part of the ConfigurationId property.
ColumnName | 2 | Represents the ColumnName property.
ContactColumnId | 3 | Represents the ContactColumnId property.
ContactList | 4 | Represents the ContactList property.
PhoneNumberType | 5 | Represents the PhoneNumberType property.
TableName | 6 | Represents the TableName property.
RevisionLevel | 7 | Represents the RevisionLevel property.

See Also


ContactColumnConfigurationList Class

[image]

IceLib Dialer Technical Reference
ContactColumnConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing contact column configuration objects.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class ContactColumnConfigurationList : EditableConfigurationList<ContactColumnConfiguration, ContactColumnConfiguration..::..Property>
Visual Basic
Public Class ContactColumnConfigurationList _
    Inherits EditableConfigurationList(Of ContactColumnConfiguration, ContactColumnConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>
DynamicConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>
EditableConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..ContactColumnConfigurationList

See Also

ContactColumnConfigurationList Members


ContactColumnConfigurationList Members

[image] [image]

IceLib Dialer Technical Reference
ContactColumnConfigurationList Members
ContactColumnConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The ContactColumnConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | ContactColumnConfigurationList | Initializes a new instance of the ContactColumnConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)

See Also

ContactColumnConfigurationList Class


ContactColumnConfigurationList Constructor

[image]

IceLib Dialer Technical Reference
ContactColumnConfigurationList Constructor
ContactColumnConfigurationList Class See Also Send Feedback
Initializes a new instance of the ContactColumnConfigurationList class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ContactColumnConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

ContactColumnConfigurationList Class
ContactColumnConfigurationList Members


ContactColumnConfigurationList Methods

[image] [image]

IceLib Dialer Technical Reference
ContactColumnConfigurationList Methods
ContactColumnConfigurationList Class See Also Send Feedback

The ContactColumnConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContactColumnConfigurationList Class


ContactColumnConfigurationList Properties

[image] [image]

IceLib Dialer Technical Reference
ContactColumnConfigurationList Properties
ContactColumnConfigurationList Class See Also Send Feedback

The ContactColumnConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)

See Also

ContactColumnConfigurationList Class


ContactColumnConfigurationList Events

[image] [image]

IceLib Dialer Technical Reference
ContactColumnConfigurationList Events
ContactColumnConfigurationList Class See Also Send Feedback

The ContactColumnConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' ContactColumnConfiguration, ContactColumnConfiguration..::..Property >)>)>.)

See Also

ContactColumnConfigurationList Class


ContactColumnsBehavior Class

[image]

IceLib Dialer Technical Reference
ContactColumnsBehavior Class
Members See Also Send Feedback
A PolicyBehavior which can enable or disable contact columns.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class ContactColumnsBehavior : PolicyBehavior
Visual Basic
Public NotInheritable Class ContactColumnsBehavior _
    Inherits PolicyBehavior

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyBehavior
ININ.IceLib.Configuration.Dialer..::..ContactColumnsBehavior

See Also

ContactColumnsBehavior Members


ContactColumnsBehavior Members

[image] [image]

IceLib Dialer Technical Reference
ContactColumnsBehavior Members
ContactColumnsBehavior Class Constructors Methods Properties See Also Send Feedback

The ContactColumnsBehavior type exposes the following members.

Constructors

 | Name | Description
Public method | ContactColumnsBehavior | Initializes a new instance of the ContactColumnsBehavior class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActiveContactColumns | The list of contact columns that will be enabled after this behavior is executed.
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | ContactList | Get or set the contact list from which to select contact columns.
Public property | Id | (Inherited from PolicyBehavior.)

See Also

ContactColumnsBehavior Class


ContactColumnsBehavior Constructor

[image]

IceLib Dialer Technical Reference
ContactColumnsBehavior Constructor
ContactColumnsBehavior Class See Also Send Feedback
Initializes a new instance of the ContactColumnsBehavior class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ContactColumnsBehavior()
Visual Basic
Public Sub New

See Also

ContactColumnsBehavior Class
ContactColumnsBehavior Members


ContactColumnsBehavior Methods

[image] [image]

IceLib Dialer Technical Reference
ContactColumnsBehavior Methods
ContactColumnsBehavior Class See Also Send Feedback

The ContactColumnsBehavior type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContactColumnsBehavior Class


ContactColumnsBehavior Properties

[image] [image]

IceLib Dialer Technical Reference
ContactColumnsBehavior Properties
ContactColumnsBehavior Class See Also Send Feedback

The ContactColumnsBehavior type exposes the following members.

Properties

 | Name | Description
Public property | ActiveContactColumns | The list of contact columns that will be enabled after this behavior is executed.
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | ContactList | Get or set the contact list from which to select contact columns.
Public property | Id | (Inherited from PolicyBehavior.)

See Also

ContactColumnsBehavior Class


ActiveContactColumns Property

[image]

IceLib Dialer Technical Reference
ContactColumnsBehavior..::..ActiveContactColumns Property
ContactColumnsBehavior Class See Also Send Feedback
The list of contact columns that will be enabled after this behavior is executed.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<ConfigurationId> ActiveContactColumns { get; }
Visual Basic
Public ReadOnly Property ActiveContactColumns As Collection(Of ConfigurationId)
    Get

See Also

ContactColumnsBehavior Class
ContactColumnsBehavior Members


ContactList Property

[image]

IceLib Dialer Technical Reference
ContactColumnsBehavior..::..ContactList Property
ContactColumnsBehavior Class See Also Send Feedback
Get or set the contact list from which to select contact columns.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ConfigurationId ContactList { get; set; }
Visual Basic
Public Property ContactList As ConfigurationId
    Get
    Set

See Also

ContactColumnsBehavior Class
ContactColumnsBehavior Members


ContactListCommand Class

[image]

IceLib Dialer Technical Reference
ContactListCommand Class
Members See Also Send Feedback
A command to run against a database associated with a contact list.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public abstract class ContactListCommand : ICloneable
Visual Basic
Public MustInherit Class ContactListCommand _
    Implements ICloneable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..ContactListCommand
ININ.IceLib.Configuration.Dialer..::..DeleteCommand
ININ.IceLib.Configuration.Dialer..::..InsertCommand
ININ.IceLib.Configuration.Dialer..::..SelectCommand
ININ.IceLib.Configuration.Dialer..::..UpdateCommand

See Also

ContactListCommand Members


ContactListCommand Members

[image] [image]

IceLib Dialer Technical Reference
ContactListCommand Members
ContactListCommand Class Constructors Methods Properties See Also Send Feedback

The ContactListCommand type exposes the following members.

Constructors

 | Name | Description
Public method | ContactListCommand(ContactListConfiguration) | The base constructor of classes derived from ContactListCommand
Public method | ContactListCommand(ContactListConfiguration, IEnumerable<(Of <<'(FilterConfiguration>)>>)) | The base constructor of classes derived from ContactListCommand.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EscapeString | Encloses a string in escape characters.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetDatabaseType | Retrieves the type of database associated with the contact list's connection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ContactList | The contact list to run this command against.
Public property | Filters | The filter to use in the where predicate.
Public property | RecordsAffected | The number of records affected by this command. If this is a paged SelectCommand, the value reflects the total number of records in the unpaged version.
Public property | TableType | Specifies which database table the command applies to.
Public property | Where | An expression representing a logical predicate with which to filter records.

See Also

ContactListCommand Class


ContactListCommand Constructor

[image] [image]

IceLib Dialer Technical Reference
ContactListCommand Constructor
ContactListCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ContactListCommand(ContactListConfiguration) | The base constructor of classes derived from ContactListCommand
Public method | ContactListCommand(ContactListConfiguration, IEnumerable<(Of <<'(FilterConfiguration>)>>)) | The base constructor of classes derived from ContactListCommand.

See Also

ContactListCommand Class
ContactListCommand Members


ContactListCommand Constructor (ContactListConfiguration)

[image]

IceLib Dialer Technical Reference
ContactListCommand Constructor (ContactListConfiguration)
ContactListCommand Class See Also Send Feedback
The base constructor of classes derived from ContactListCommand

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ContactListCommand(
    ContactListConfiguration contactList
)
Visual Basic
Public Sub New ( _
    contactList As ContactListConfiguration _
)

Parameters

contactList
Type: ININ.IceLib.Configuration.Dialer..::..ContactListConfiguration
The contact list to create this command for.

See Also

ContactListCommand Class
ContactListCommand Members
ContactListCommand Overload


ContactListCommand Constructor (ContactListConfiguration, IEnumerable(FilterConfiguration))

[image]

IceLib Dialer Technical Reference
ContactListCommand Constructor (ContactListConfiguration, IEnumerable<(Of <(<'FilterConfiguration>)>)>)
ContactListCommand Class See Also Send Feedback
The base constructor of classes derived from ContactListCommand.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ContactListCommand(
    ContactListConfiguration contactList,
    IEnumerable<FilterConfiguration> filters
)
Visual Basic
Public Sub New ( _
    contactList As ContactListConfiguration, _
    filters As IEnumerable(Of FilterConfiguration) _
)

Parameters

contactList
Type: ININ.IceLib.Configuration.Dialer..::..ContactListConfiguration
The contact list to create this command for.
filters
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' FilterConfiguration >)>)>
The filters to add as series of "AND" clauses in the where predicate.

See Also

ContactListCommand Class
ContactListCommand Members
ContactListCommand Overload


ContactListCommand Methods

[image] [image]

IceLib Dialer Technical Reference
ContactListCommand Methods
ContactListCommand Class See Also Send Feedback

The ContactListCommand type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EscapeString | Encloses a string in escape characters.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetDatabaseType | Retrieves the type of database associated with the contact list's connection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContactListCommand Class


Clone Method

[image]

IceLib Dialer Technical Reference
ContactListCommand..::..Clone Method
ContactListCommand Class See Also Send Feedback
Creates a new object that is a copy of the current instance.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public abstract Object Clone()
Visual Basic
Public MustOverride Function Clone As Object

Return Value

A new object that is a copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

ContactListCommand Class
ContactListCommand Members


EscapeString Method

[image]

IceLib Dialer Technical Reference
ContactListCommand..::..EscapeString Method
ContactListCommand Class See Also Send Feedback
Encloses a string in escape characters.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static string EscapeString(
    string item,
    DatabaseType databaseType
)
Visual Basic
Public Shared Function EscapeString ( _
    item As String, _
    databaseType As DatabaseType _
) As String

Parameters

item
Type: System..::..String
The string to escape.
databaseType
Type: ININ.IceLib.Configuration.Dialer.DataTypes..::..DatabaseType
The database type that determines which escape characters to use.

Return Value

An escaped version of item.

See Also

ContactListCommand Class
ContactListCommand Members


GetDatabaseType Method

[image]

IceLib Dialer Technical Reference
ContactListCommand..::..GetDatabaseType Method
ContactListCommand Class See Also Send Feedback
Retrieves the type of database associated with the contact list's connection.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
protected DatabaseType GetDatabaseType(
    ConfigurationManager manager
)
Visual Basic
Protected Function GetDatabaseType ( _
    manager As ConfigurationManager _
) As DatabaseType

Parameters

manager
Type: ConfigurationManager
The configuration manager object.

Return Value

See Also

ContactListCommand Class
ContactListCommand Members


ContactListCommand Properties

[image] [image]

IceLib Dialer Technical Reference
ContactListCommand Properties
ContactListCommand Class See Also Send Feedback

The ContactListCommand type exposes the following members.

Properties

 | Name | Description
Public property | ContactList | The contact list to run this command against.
Public property | Filters | The filter to use in the where predicate.
Public property | RecordsAffected | The number of records affected by this command. If this is a paged SelectCommand, the value reflects the total number of records in the unpaged version.
Public property | TableType | Specifies which database table the command applies to.
Public property | Where | An expression representing a logical predicate with which to filter records.

See Also

ContactListCommand Class


ContactList Property

[image]

IceLib Dialer Technical Reference
ContactListCommand..::..ContactList Property
ContactListCommand Class See Also Send Feedback
The contact list to run this command against.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ContactListConfiguration ContactList { get; private set; }
Visual Basic
Public Property ContactList As ContactListConfiguration
    Get
    Private Set

See Also

ContactListCommand Class
ContactListCommand Members


Filters Property

[image]

IceLib Dialer Technical Reference
ContactListCommand..::..Filters Property
ContactListCommand Class See Also Send Feedback
The filter to use in the where predicate.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public IList<FilterConfiguration> Filters { get; private set; }
Visual Basic
Public Property Filters As IList(Of FilterConfiguration)
    Get
    Private Set

See Also

ContactListCommand Class
ContactListCommand Members


RecordsAffected Property

[image]

IceLib Dialer Technical Reference
ContactListCommand..::..RecordsAffected Property
ContactListCommand Class See Also Send Feedback
The number of records affected by this command. If this is a paged SelectCommand, the value reflects the total number of records in the unpaged version.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int RecordsAffected { get; internal set; }
Visual Basic
Public Property RecordsAffected As Integer
    Get
    Friend Set

Remarks

This member holds no meaning until the command is actually executed.

See Also

ContactListCommand Class
ContactListCommand Members


TableType Property

[image]

IceLib Dialer Technical Reference
ContactListCommand..::..TableType Property
ContactListCommand Class See Also Send Feedback
Specifies which database table the command applies to.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public virtual TableType TableType { get; set; }
Visual Basic
Public Overridable Property TableType As TableType
    Get
    Set

See Also

ContactListCommand Class
ContactListCommand Members


Where Property

[image]

IceLib Dialer Technical Reference
ContactListCommand..::..Where Property
ContactListCommand Class See Also Send Feedback
An expression representing a logical predicate with which to filter records.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public IExpression Where { get; set; }
Visual Basic
Public Property Where As IExpression
    Get
    Set

Remarks

AggregateExpression cannot be used within a Where predicate.

See Also

ContactListCommand Class
ContactListCommand Members


ContactListConfiguration Class

[image]

IceLib Dialer Technical Reference
ContactListConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for a Dialer Contact List.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class ContactListConfiguration : EditableListConfigurationObject<ContactListConfiguration..::..Property>,
    IExportable
Visual Basic
Public Class ContactListConfiguration _
    Inherits EditableListConfigurationObject(Of ContactListConfiguration..::..Property) _
    Implements IExportable

Inheritance Hierarchy

System..::..Object
ConfigurationObject
ListConfigurationObject
EditableListConfigurationObject<(Of <(<' ContactListConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..ContactListConfiguration

See Also

ContactListConfiguration Members


ContactListConfiguration Members

[image] [image]

IceLib Dialer Technical Reference
ContactListConfiguration Members
ContactListConfiguration Class Methods Fields Properties See Also Send Feedback

The ContactListConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | AddScheduledCalls | Adds scheduled calls to the scheduled calls table, or replaces entries with the same campaign and identity.
Public method | AddScheduledCallsAsync | Asynchronously adds scheduled calls to the scheduled calls table or replaces entries with the same campaign and identity.
Public method | BulkExport | Exports contacts from the contact list into a file or database table.
Public method | BulkExportAsync | Asynchronously exports contacts from the contact list into a file or database table.
Public method | BulkExportDNCMetadata | Exports metadata from the DNC Metadata table into a file or database table.
Public method | BulkExportDNCMetadataAsync | Asynchronously exports metadata from the DNC Metadata table into a file or database table.
Public method | BulkImport(HttpRequestKey, IDataSet, IDictionary<(Of <<'(DBColumn, DBColumn>)>>)) | Imports contacts from a data set into the contact list.
Public method | BulkImport(HttpRequestKey, IDataSet, IDictionary<(Of <<'(DBColumn, DBColumn>)>>), Boolean) | Imports contacts from a data set into the contact list.
Public method | BulkImportAsync(HttpRequestKey, IDataSet, IDictionary<(Of <<'(DBColumn, DBColumn>)>>), EventHandler<(Of <<'(AsyncCompletedEventArgs<(Of <<'(Int32>)>>)>)>>), Object) | Asynchronously imports contacts from a data set into the contact list.
Public method | BulkImportAsync(HttpRequestKey, IDataSet, IDictionary<(Of <<'(DBColumn, DBColumn>)>>), Boolean, EventHandler<(Of <<'(AsyncCompletedEventArgs<(Of <<'(Int32>)>>)>)>>), Object) | Asynchronously imports contacts from a data set into the contact list.
Public method | BulkMoveIn | Copies records from a database table (not necessarily a contact list) accessible via a Dialer connection into this contact list.
Public method | BulkMoveInAsync | Asynchronously copies records from a database table (not necessarily a contact list) accessible via a Dialer connection into this contact list.
Public method | BulkMoveOut | Moves contacts from the contact list into a database table accessible from a Dialer connection.
Public method | BulkMoveOutAsync | Asynchronously moves contacts from the contact list into a database table accessible from a Dialer connection.
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' ContactListConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' ContactListConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ContactListConfiguration..::..Property >)>)>.)
Public method | CreateTables(TableType) | Create database tables and associate them with the contact list.
Public method | CreateTables(TableType, IEnumerable<(Of <<'(DBColumn>)>>)) | Create database tables and associate them with the contact list.
Public method | CreateTablesAsync | Asynchronously create database tables and associate them with the contact list.
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' ContactListConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ContactListConfiguration..::..Property >)>)>.)
Public method | DropTables | Drops the database tables associated with the contact list. A bitmask of TableTypes specifying which tables to drop.
Public method | DropTablesAsync | Asynchronously drops the database tables associated with the contact list.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FlushContacts | Flush contact records from the dialing queue in order to prevent them from being dialed.
Public method | FlushContactsAsync | Asynchronously flushes contact records from the dialing queue in order to prevent them from being dialed.
Public method | GetColumns | Retrieves the fields in this contact list.
Public method | GetColumnsAsync | Asynchrously retrieves the fields in this contact list.
Public method | GetContacts | Run a query to retrieve records from the contact list.
Public method | GetContactsAsync | Run a query to retrieve records from the contact list.
Public method | GetCustomPNDColumnMap | Returns a list of custom columns that exist in the PND table.
Public method | GetDNCMetadata | Run a query to retrieve records from the contact list DNC Metadata.
Public method | GetDNCMetadataAsync | Run a query to retrieve records from the contact list DNC Metadata.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' ContactListConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ContactListConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' ContactListConfiguration..::..Property >)>)>.)
Public method | RunSmallQuery | Run a query to retrieve records from the contact list.
Public method | RunSmallQueryAsync | Asynchronously runs a query to retrieve records from the contact list.
Public method | RunTransaction | Executes one or more commands against the contact list as a transaction.
Public method | RunTransactionAsync | Asynchronously executes one or more commands against the contact list as a transaction.
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' ContactListConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' ContactListConfiguration..::..Property >)>)>.)
Public method | ToString | (Inherited from ConfigurationObject.)

Fields

Name | Description
AgentID | Agent Id column residing in the scheduled call table.
Attempts | Attempts column residing in the contact list table and phone number details table.
CallingTimeRestrictions |
CallingWindow |
CampaignName | CampaignName column residing in the scheduled call table.
CarrierInfo |
CCID |
Country |
DateField |
DateTimeClm |
DoNotCallToday |
EBRType |
I3_ActiveCampaignID | I3_ActiveCampaignID column residing in the contact list table.
I3_Attempts | Attempts column residing in the contact list table and phone number details table.
I3_AttemptsAbandoned | AttemptsAbandoned column residing in the contact list table and phone number details table.
I3_AttemptsBusy | AttemptsBusy column residing in the contact list table and phone number details table.
I3_AttemptsDaily | I3_AttemptsDaily column residing in the contact list table.
I3_AttemptsFax | AttemptsFax column residing in the contact list table and phone number details table.
I3_AttemptsMachine | AttemptsMachine column residing in the contact list table and phone number details table.
I3_AttemptsNoAnswer | AttemptsNoAnswer column residing in the contact list table and phone number details table.
I3_AttemptsRemoteHangUp | AttemptsRemoteHangUp column residing in the contact list table and phone number details table.
I3_AttemptsRescheduled | AttemptsRescheduled column residing in the contact list table and phone number details table.
I3_AttemptsSITCallable | I3_AttemptsSITCallable column residing in the contact list table and phone number details table.
I3_AttemptsSystemHangUp | AttemptsSystemHangUp column residing in the contact list table and phone number details table.
I3_CampaignOwnerExpiration | When the contact ownership expires
I3_CampaignOwnerID | Id of the campaign that owns this contact
I3_CampaignOwnerName | Name of the campaign that owns this contact
I3_CCID | Contact column Id column residing in the phone number details table
I3_Identity | I3_Identity column residing in all tables associated with a contact list.
I3_LastCalled_UTC | I3_LastCalled_UTC column residing in the contact list table.
I3_SiteID | I3_SiteID column residing in the contact list table.
I3_Status | Status column residing in the contact list table and phone number details table.
I3_Upload_Id | I3_Upload_Id column residing in the contact list table.
I3_Zone | Zone column residing in the contact list table and phone number details table.
IsWireless |
Locale |
MetadataColumns |
NewAreaCode |
OwnershipColumns | The list of columns used for contact ownership information
PhoneNumber |
PNDColumns | The ordered list of columns in the phone number details table.
Reason |
RegionAbbrev |
RequiredColumns | The list of columns required in a valid contact list.
ResultCode |
ScheduleColumns | The ordered list of columns in the scheduled call table.
ScheduledCCID | Scheduled contact column Id column residing in the scheduled call table.
ScheduledPhone | Scheduled phone column residing in the scheduled call table.
ScheduledTime | Scheduled time residing in the scheduled call table.
SiteID | AttemptsRemoteHangUp column residing in the contact list table and phone number details table.
Status | Status column residing in the contact list table and phone number details table.
SuccessResult | SuccessResult column residing in the contact list table.
TZCode |
UTCOffset |
Zone | Zone column residing in the contact list table and phone number details table.

Properties

 | Name | Description
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' ContactListConfiguration..::..Property >)>)>.)
Public property | ColumnMap | A case-insensitive mapping of all column names in the contact list to their column definitions.
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | Connection | The Id of the database connection used to access the contact list table.
Public property | ContactColumns | The columns in the contact list table that are marked as phone number columns.
Public property | DNCMetadataColumnMap | A case-insensitive mapping of all column names in the DNC Metadata table to their column definitions.
Public property | DurationOfOwnership | The number of hours a contact record is exclusively owned by a campaign.
Public property | EnableCampaignOwnership | Toggles whether or not the records in the contact list can be exclusively owned by a campaign.
Public property | EnableDncComMetaData | Toggles whether or not Dialer is recording DNC.Com meta data.
Public property | EnableMetaDataCleanup | Toggles whether or not Dialer automatically deletes records from the table older than then MetadataDuration period.
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsExporting | Tells whether the current object is being used for exporting
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | MetaDataDuration | The number of days dialer will wait before deleting a record from the meta data table.
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | PNDColumnMap | A case-insensitive mapping of all column names in the Phone Number Details table to their column definitions.
Public property | RevisionLevel | The current version of this object.
Public property | TableName | The name of the contact list table.

See Also

ContactListConfiguration Class


ContactListConfiguration Fields

[image] [image]

IceLib Dialer Technical Reference
ContactListConfiguration Fields
ContactListConfiguration Class See Also Send Feedback

The ContactListConfiguration type exposes the following members.

Fields

Name | Description
AgentID | Agent Id column residing in the scheduled call table.
Attempts | Attempts column residing in the contact list table and phone number details table.
CallingTimeRestrictions |
CallingWindow |
CampaignName | CampaignName column residing in the scheduled call table.
CarrierInfo |
CCID |
Country |
DateField |
DateTimeClm |
DoNotCallToday |
EBRType |
I3_ActiveCampaignID | I3_ActiveCampaignID column residing in the contact list table.
I3_Attempts | Attempts column residing in the contact list table and phone number details table.
I3_AttemptsAbandoned | AttemptsAbandoned column residing in the contact list table and phone number details table.
I3_AttemptsBusy | AttemptsBusy column residing in the contact list table and phone number details table.
I3_AttemptsDaily | I3_AttemptsDaily column residing in the contact list table.
I3_AttemptsFax | AttemptsFax column residing in the contact list table and phone number details table.
I3_AttemptsMachine | AttemptsMachine column residing in the contact list table and phone number details table.
I3_AttemptsNoAnswer | AttemptsNoAnswer column residing in the contact list table and phone number details table.
I3_AttemptsRemoteHangUp | AttemptsRemoteHangUp column residing in the contact list table and phone number details table.
I3_AttemptsRescheduled | AttemptsRescheduled column residing in the contact list table and phone number details table.
I3_AttemptsSITCallable | I3_AttemptsSITCallable column residing in the contact list table and phone number details table.
I3_AttemptsSystemHangUp | AttemptsSystemHangUp column residing in the contact list table and phone number details table.
I3_CampaignOwnerExpiration | When the contact ownership expires
I3_CampaignOwnerID | Id of the campaign that owns this contact
I3_CampaignOwnerName | Name of the campaign that owns this contact
I3_CCID | Contact column Id column residing in the phone number details table
I3_Identity | I3_Identity column residing in all tables associated with a contact list.
I3_LastCalled_UTC | I3_LastCalled_UTC column residing in the contact list table.
I3_SiteID | I3_SiteID column residing in the contact list table.
I3_Status | Status column residing in the contact list table and phone number details table.
I3_Upload_Id | I3_Upload_Id column residing in the contact list table.
I3_Zone | Zone column residing in the contact list table and phone number details table.
IsWireless |
Locale |
MetadataColumns |
NewAreaCode |
OwnershipColumns | The list of columns used for contact ownership information
PhoneNumber |
PNDColumns | The ordered list of columns in the phone number details table.
Reason |
RegionAbbrev |
RequiredColumns | The list of columns required in a valid contact list.
ResultCode |
ScheduleColumns | The ordered list of columns in the scheduled call table.
ScheduledCCID | Scheduled contact column Id column residing in the scheduled call table.
ScheduledPhone | Scheduled phone column residing in the scheduled call table.
ScheduledTime | Scheduled time residing in the scheduled call table.
SiteID | AttemptsRemoteHangUp column residing in the contact list table and phone number details table.
Status | Status column residing in the contact list table and phone number details table.
SuccessResult | SuccessResult column residing in the contact list table.
TZCode |
UTCOffset |
Zone | Zone column residing in the contact list table and phone number details table.

See Also

ContactListConfiguration Class


AgentID Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..AgentID Field
ContactListConfiguration Class See Also Send Feedback
Agent Id column residing in the scheduled call table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn AgentID
Visual Basic
Public Shared ReadOnly AgentID As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


Attempts Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..Attempts Field
ContactListConfiguration Class See Also Send Feedback
Attempts column residing in the contact list table and phone number details table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn Attempts
Visual Basic
Public Shared ReadOnly Attempts As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


CallingTimeRestrictions Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..CallingTimeRestrictions Field
ContactListConfiguration Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn CallingTimeRestrictions
Visual Basic
Public Shared ReadOnly CallingTimeRestrictions As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


CallingWindow Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..CallingWindow Field
ContactListConfiguration Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn CallingWindow
Visual Basic
Public Shared ReadOnly CallingWindow As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


CampaignName Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..CampaignName Field
ContactListConfiguration Class See Also Send Feedback
CampaignName column residing in the scheduled call table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn CampaignName
Visual Basic
Public Shared ReadOnly CampaignName As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


CarrierInfo Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..CarrierInfo Field
ContactListConfiguration Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn CarrierInfo
Visual Basic
Public Shared ReadOnly CarrierInfo As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


CCID Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..CCID Field
ContactListConfiguration Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn CCID
Visual Basic
Public Shared ReadOnly CCID As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


Country Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..Country Field
ContactListConfiguration Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn Country
Visual Basic
Public Shared ReadOnly Country As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


DateField Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..DateField Field
ContactListConfiguration Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn DateField
Visual Basic
Public Shared ReadOnly DateField As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


DateTimeClm Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..DateTimeClm Field
ContactListConfiguration Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn DateTimeClm
Visual Basic
Public Shared ReadOnly DateTimeClm As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


DoNotCallToday Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..DoNotCallToday Field
ContactListConfiguration Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn DoNotCallToday
Visual Basic
Public Shared ReadOnly DoNotCallToday As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


EBRType Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..EBRType Field
ContactListConfiguration Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn EBRType
Visual Basic
Public Shared ReadOnly EBRType As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


I3_ActiveCampaignID Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..I3_ActiveCampaignID Field
ContactListConfiguration Class See Also Send Feedback
I3_ActiveCampaignID column residing in the contact list table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn I3_ActiveCampaignID
Visual Basic
Public Shared ReadOnly I3_ActiveCampaignID As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


I3_Attempts Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..I3_Attempts Field
ContactListConfiguration Class See Also Send Feedback
Attempts column residing in the contact list table and phone number details table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn I3_Attempts
Visual Basic
Public Shared ReadOnly I3_Attempts As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


I3_AttemptsAbandoned Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..I3_AttemptsAbandoned Field
ContactListConfiguration Class See Also Send Feedback
AttemptsAbandoned column residing in the contact list table and phone number details table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn I3_AttemptsAbandoned
Visual Basic
Public Shared ReadOnly I3_AttemptsAbandoned As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


I3_AttemptsBusy Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..I3_AttemptsBusy Field
ContactListConfiguration Class See Also Send Feedback
AttemptsBusy column residing in the contact list table and phone number details table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn I3_AttemptsBusy
Visual Basic
Public Shared ReadOnly I3_AttemptsBusy As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


I3_AttemptsDaily Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..I3_AttemptsDaily Field
ContactListConfiguration Class See Also Send Feedback
I3_AttemptsDaily column residing in the contact list table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn I3_AttemptsDaily
Visual Basic
Public Shared ReadOnly I3_AttemptsDaily As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


I3_AttemptsFax Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..I3_AttemptsFax Field
ContactListConfiguration Class See Also Send Feedback
AttemptsFax column residing in the contact list table and phone number details table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn I3_AttemptsFax
Visual Basic
Public Shared ReadOnly I3_AttemptsFax As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


I3_AttemptsMachine Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..I3_AttemptsMachine Field
ContactListConfiguration Class See Also Send Feedback
AttemptsMachine column residing in the contact list table and phone number details table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn I3_AttemptsMachine
Visual Basic
Public Shared ReadOnly I3_AttemptsMachine As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


I3_AttemptsNoAnswer Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..I3_AttemptsNoAnswer Field
ContactListConfiguration Class See Also Send Feedback
AttemptsNoAnswer column residing in the contact list table and phone number details table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn I3_AttemptsNoAnswer
Visual Basic
Public Shared ReadOnly I3_AttemptsNoAnswer As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


I3_AttemptsRemoteHangUp Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..I3_AttemptsRemoteHangUp Field
ContactListConfiguration Class See Also Send Feedback
AttemptsRemoteHangUp column residing in the contact list table and phone number details table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn I3_AttemptsRemoteHangUp
Visual Basic
Public Shared ReadOnly I3_AttemptsRemoteHangUp As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


I3_AttemptsRescheduled Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..I3_AttemptsRescheduled Field
ContactListConfiguration Class See Also Send Feedback
AttemptsRescheduled column residing in the contact list table and phone number details table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn I3_AttemptsRescheduled
Visual Basic
Public Shared ReadOnly I3_AttemptsRescheduled As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


I3_AttemptsSITCallable Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..I3_AttemptsSITCallable Field
ContactListConfiguration Class See Also Send Feedback
I3_AttemptsSITCallable column residing in the contact list table and phone number details table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn I3_AttemptsSITCallable
Visual Basic
Public Shared ReadOnly I3_AttemptsSITCallable As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


I3_AttemptsSystemHangUp Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..I3_AttemptsSystemHangUp Field
ContactListConfiguration Class See Also Send Feedback
AttemptsSystemHangUp column residing in the contact list table and phone number details table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn I3_AttemptsSystemHangUp
Visual Basic
Public Shared ReadOnly I3_AttemptsSystemHangUp As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


I3_CampaignOwnerExpiration Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..I3_CampaignOwnerExpiration Field
ContactListConfiguration Class See Also Send Feedback
When the contact ownership expires

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn I3_CampaignOwnerExpiration
Visual Basic
Public Shared ReadOnly I3_CampaignOwnerExpiration As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


I3_CampaignOwnerID Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..I3_CampaignOwnerID Field
ContactListConfiguration Class See Also Send Feedback
Id of the campaign that owns this contact

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn I3_CampaignOwnerID
Visual Basic
Public Shared ReadOnly I3_CampaignOwnerID As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


I3_CampaignOwnerName Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..I3_CampaignOwnerName Field
ContactListConfiguration Class See Also Send Feedback
Name of the campaign that owns this contact

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn I3_CampaignOwnerName
Visual Basic
Public Shared ReadOnly I3_CampaignOwnerName As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


I3_CCID Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..I3_CCID Field
ContactListConfiguration Class See Also Send Feedback
Contact column Id column residing in the phone number details table

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn I3_CCID
Visual Basic
Public Shared ReadOnly I3_CCID As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


I3_Identity Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..I3_Identity Field
ContactListConfiguration Class See Also Send Feedback
I3_Identity column residing in all tables associated with a contact list.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn I3_Identity
Visual Basic
Public Shared ReadOnly I3_Identity As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


I3_LastCalled_UTC Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..I3_LastCalled_UTC Field
ContactListConfiguration Class See Also Send Feedback
I3_LastCalled_UTC column residing in the contact list table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn I3_LastCalled_UTC
Visual Basic
Public Shared ReadOnly I3_LastCalled_UTC As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


I3_SiteID Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..I3_SiteID Field
ContactListConfiguration Class See Also Send Feedback
I3_SiteID column residing in the contact list table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn I3_SiteID
Visual Basic
Public Shared ReadOnly I3_SiteID As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


I3_Status Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..I3_Status Field
ContactListConfiguration Class See Also Send Feedback
Status column residing in the contact list table and phone number details table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn I3_Status
Visual Basic
Public Shared ReadOnly I3_Status As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


I3_Upload_Id Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..I3_Upload_Id Field
ContactListConfiguration Class See Also Send Feedback
I3_Upload_Id column residing in the contact list table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn I3_Upload_Id
Visual Basic
Public Shared ReadOnly I3_Upload_Id As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


I3_Zone Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..I3_Zone Field
ContactListConfiguration Class See Also Send Feedback
Zone column residing in the contact list table and phone number details table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn I3_Zone
Visual Basic
Public Shared ReadOnly I3_Zone As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


IsWireless Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..IsWireless Field
ContactListConfiguration Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn IsWireless
Visual Basic
Public Shared ReadOnly IsWireless As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


Locale Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..Locale Field
ContactListConfiguration Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn Locale
Visual Basic
Public Shared ReadOnly Locale As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


MetadataColumns Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..MetadataColumns Field
ContactListConfiguration Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly ReadOnlyCollection<DBColumn> MetadataColumns
Visual Basic
Public Shared ReadOnly MetadataColumns As ReadOnlyCollection(Of DBColumn)

See Also

ContactListConfiguration Class
ContactListConfiguration Members


NewAreaCode Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..NewAreaCode Field
ContactListConfiguration Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn NewAreaCode
Visual Basic
Public Shared ReadOnly NewAreaCode As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


OwnershipColumns Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..OwnershipColumns Field
ContactListConfiguration Class See Also Send Feedback
The list of columns used for contact ownership information

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly ReadOnlyCollection<DBColumn> OwnershipColumns
Visual Basic
Public Shared ReadOnly OwnershipColumns As ReadOnlyCollection(Of DBColumn)

See Also

ContactListConfiguration Class
ContactListConfiguration Members


PhoneNumber Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..PhoneNumber Field
ContactListConfiguration Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn PhoneNumber
Visual Basic
Public Shared ReadOnly PhoneNumber As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


PNDColumns Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..PNDColumns Field
ContactListConfiguration Class See Also Send Feedback
The ordered list of columns in the phone number details table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly ReadOnlyCollection<DBColumn> PNDColumns
Visual Basic
Public Shared ReadOnly PNDColumns As ReadOnlyCollection(Of DBColumn)

See Also

ContactListConfiguration Class
ContactListConfiguration Members


Reason Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..Reason Field
ContactListConfiguration Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn Reason
Visual Basic
Public Shared ReadOnly Reason As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


RegionAbbrev Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..RegionAbbrev Field
ContactListConfiguration Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn RegionAbbrev
Visual Basic
Public Shared ReadOnly RegionAbbrev As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


RequiredColumns Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..RequiredColumns Field
ContactListConfiguration Class See Also Send Feedback
The list of columns required in a valid contact list.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static ReadOnlyCollection<DBColumn> RequiredColumns
Visual Basic
Public Shared RequiredColumns As ReadOnlyCollection(Of DBColumn)

See Also

ContactListConfiguration Class
ContactListConfiguration Members


ResultCode Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..ResultCode Field
ContactListConfiguration Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn ResultCode
Visual Basic
Public Shared ReadOnly ResultCode As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


ScheduleColumns Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..ScheduleColumns Field
ContactListConfiguration Class See Also Send Feedback
The ordered list of columns in the scheduled call table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly ReadOnlyCollection<DBColumn> ScheduleColumns
Visual Basic
Public Shared ReadOnly ScheduleColumns As ReadOnlyCollection(Of DBColumn)

See Also

ContactListConfiguration Class
ContactListConfiguration Members


ScheduledCCID Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..ScheduledCCID Field
ContactListConfiguration Class See Also Send Feedback
Scheduled contact column Id column residing in the scheduled call table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn ScheduledCCID
Visual Basic
Public Shared ReadOnly ScheduledCCID As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


ScheduledPhone Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..ScheduledPhone Field
ContactListConfiguration Class See Also Send Feedback
Scheduled phone column residing in the scheduled call table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn ScheduledPhone
Visual Basic
Public Shared ReadOnly ScheduledPhone As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


ScheduledTime Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..ScheduledTime Field
ContactListConfiguration Class See Also Send Feedback
Scheduled time residing in the scheduled call table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn ScheduledTime
Visual Basic
Public Shared ReadOnly ScheduledTime As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


SiteID Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..SiteID Field
ContactListConfiguration Class See Also Send Feedback
AttemptsRemoteHangUp column residing in the contact list table and phone number details table.
Site Id column residing in the scheduled call table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn SiteID
Visual Basic
Public Shared ReadOnly SiteID As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


Status Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..Status Field
ContactListConfiguration Class See Also Send Feedback
Status column residing in the contact list table and phone number details table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn Status
Visual Basic
Public Shared ReadOnly Status As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


SuccessResult Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..SuccessResult Field
ContactListConfiguration Class See Also Send Feedback
SuccessResult column residing in the contact list table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn SuccessResult
Visual Basic
Public Shared ReadOnly SuccessResult As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


TZCode Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..TZCode Field
ContactListConfiguration Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn TZCode
Visual Basic
Public Shared ReadOnly TZCode As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


UTCOffset Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..UTCOffset Field
ContactListConfiguration Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn UTCOffset
Visual Basic
Public Shared ReadOnly UTCOffset As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


Zone Field

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..Zone Field
ContactListConfiguration Class See Also Send Feedback
Zone column residing in the contact list table and phone number details table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static readonly DBColumn Zone
Visual Basic
Public Shared ReadOnly Zone As DBColumn

See Also

ContactListConfiguration Class
ContactListConfiguration Members


ContactListConfiguration Methods

[image] [image]

IceLib Dialer Technical Reference
ContactListConfiguration Methods
ContactListConfiguration Class See Also Send Feedback

The ContactListConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | AddScheduledCalls | Adds scheduled calls to the scheduled calls table, or replaces entries with the same campaign and identity.
Public method | AddScheduledCallsAsync | Asynchronously adds scheduled calls to the scheduled calls table or replaces entries with the same campaign and identity.
Public method | BulkExport | Exports contacts from the contact list into a file or database table.
Public method | BulkExportAsync | Asynchronously exports contacts from the contact list into a file or database table.
Public method | BulkExportDNCMetadata | Exports metadata from the DNC Metadata table into a file or database table.
Public method | BulkExportDNCMetadataAsync | Asynchronously exports metadata from the DNC Metadata table into a file or database table.
Public method | BulkImport(HttpRequestKey, IDataSet, IDictionary<(Of <<'(DBColumn, DBColumn>)>>)) | Imports contacts from a data set into the contact list.
Public method | BulkImport(HttpRequestKey, IDataSet, IDictionary<(Of <<'(DBColumn, DBColumn>)>>), Boolean) | Imports contacts from a data set into the contact list.
Public method | BulkImportAsync(HttpRequestKey, IDataSet, IDictionary<(Of <<'(DBColumn, DBColumn>)>>), EventHandler<(Of <<'(AsyncCompletedEventArgs<(Of <<'(Int32>)>>)>)>>), Object) | Asynchronously imports contacts from a data set into the contact list.
Public method | BulkImportAsync(HttpRequestKey, IDataSet, IDictionary<(Of <<'(DBColumn, DBColumn>)>>), Boolean, EventHandler<(Of <<'(AsyncCompletedEventArgs<(Of <<'(Int32>)>>)>)>>), Object) | Asynchronously imports contacts from a data set into the contact list.
Public method | BulkMoveIn | Copies records from a database table (not necessarily a contact list) accessible via a Dialer connection into this contact list.
Public method | BulkMoveInAsync | Asynchronously copies records from a database table (not necessarily a contact list) accessible via a Dialer connection into this contact list.
Public method | BulkMoveOut | Moves contacts from the contact list into a database table accessible from a Dialer connection.
Public method | BulkMoveOutAsync | Asynchronously moves contacts from the contact list into a database table accessible from a Dialer connection.
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' ContactListConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' ContactListConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ContactListConfiguration..::..Property >)>)>.)
Public method | CreateTables(TableType) | Create database tables and associate them with the contact list.
Public method | CreateTables(TableType, IEnumerable<(Of <<'(DBColumn>)>>)) | Create database tables and associate them with the contact list.
Public method | CreateTablesAsync | Asynchronously create database tables and associate them with the contact list.
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' ContactListConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ContactListConfiguration..::..Property >)>)>.)
Public method | DropTables | Drops the database tables associated with the contact list. A bitmask of TableTypes specifying which tables to drop.
Public method | DropTablesAsync | Asynchronously drops the database tables associated with the contact list.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FlushContacts | Flush contact records from the dialing queue in order to prevent them from being dialed.
Public method | FlushContactsAsync | Asynchronously flushes contact records from the dialing queue in order to prevent them from being dialed.
Public method | GetColumns | Retrieves the fields in this contact list.
Public method | GetColumnsAsync | Asynchrously retrieves the fields in this contact list.
Public method | GetContacts | Run a query to retrieve records from the contact list.
Public method | GetContactsAsync | Run a query to retrieve records from the contact list.
Public method | GetCustomPNDColumnMap | Returns a list of custom columns that exist in the PND table.
Public method | GetDNCMetadata | Run a query to retrieve records from the contact list DNC Metadata.
Public method | GetDNCMetadataAsync | Run a query to retrieve records from the contact list DNC Metadata.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' ContactListConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ContactListConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' ContactListConfiguration..::..Property >)>)>.)
Public method | RunSmallQuery | Run a query to retrieve records from the contact list.
Public method | RunSmallQueryAsync | Asynchronously runs a query to retrieve records from the contact list.
Public method | RunTransaction | Executes one or more commands against the contact list as a transaction.
Public method | RunTransactionAsync | Asynchronously executes one or more commands against the contact list as a transaction.
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' ContactListConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' ContactListConfiguration..::..Property >)>)>.)
Public method | ToString | (Inherited from ConfigurationObject.)

See Also

ContactListConfiguration Class


AddScheduledCalls Method

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..AddScheduledCalls Method
ContactListConfiguration Class See Also Send Feedback
Adds scheduled calls to the scheduled calls table, or replaces entries with the same campaign and identity.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int AddScheduledCalls(
    IList<ScheduledCall> calls
)
Visual Basic
Public Function AddScheduledCalls ( _
    calls As IList(Of ScheduledCall) _
) As Integer

Parameters

calls
Type: System.Collections.Generic..::..IList<(Of <(<' ScheduledCall >)>)>
The scheduled calls to add.

Return Value

The number of calls added and/or replaced.

See Also

ContactListConfiguration Class
ContactListConfiguration Members


AddScheduledCallsAsync Method

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..AddScheduledCallsAsync Method
ContactListConfiguration Class See Also Send Feedback
Asynchronously adds scheduled calls to the scheduled calls table or replaces entries with the same campaign and identity.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void AddScheduledCallsAsync(
    IList<ScheduledCall> calls,
    EventHandler<AsyncCompletedEventArgs<int>> callback,
    Object userState
)
Visual Basic
Public Sub AddScheduledCallsAsync ( _
    calls As IList(Of ScheduledCall), _
    callback As EventHandler(Of AsyncCompletedEventArgs(Of Integer)), _
    userState As Object _
)

Parameters

calls
Type: System.Collections.Generic..::..IList<(Of <(<' ScheduledCall >)>)>
The calls to add.
callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Int32>)>)>>)>)>
The event handler to call upon completion.
userState
Type: System..::..Object
The user state.

See Also

ContactListConfiguration Class
ContactListConfiguration Members


BulkExport Method

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..BulkExport Method
ContactListConfiguration Class See Also Send Feedback
Exports contacts from the contact list into a file or database table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int BulkExport(
    HttpRequestKey requestKey,
    SelectCommand command,
    IDataSet destination,
    IDictionary<DBColumn, DBColumn> columnMapping
)
Visual Basic
Public Function BulkExport ( _
    requestKey As HttpRequestKey, _
    command As SelectCommand, _
    destination As IDataSet, _
    columnMapping As IDictionary(Of DBColumn, DBColumn) _
) As Integer

Parameters

requestKey
Type: ININ.IceLib.Configuration.Dialer..::..HttpRequestKey
The request key obtained by calling GetHttpRequestKey(ConfigurationId, ServerType).
command
Type: ININ.IceLib.Configuration.Dialer..::..SelectCommand
The command that determines which contacts are pulled from the call list.
destination
Type: ININ.IceLib.Configuration.Dialer.DataTypes..::..IDataSet
The data set to export the contacts to (the table/file must already exist).
columnMapping
Type: System.Collections.Generic..::..IDictionary<(Of <(<' DBColumn, DBColumn >)>)>
A mapping between contact list columns (keys) and the columns in the destination (values).

Return Value

The number of contacts exported.

See Also

ContactListConfiguration Class
ContactListConfiguration Members


BulkExportAsync Method

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..BulkExportAsync Method
ContactListConfiguration Class See Also Send Feedback
Asynchronously exports contacts from the contact list into a file or database table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void BulkExportAsync(
    HttpRequestKey requestKey,
    SelectCommand command,
    IDataSet destination,
    IDictionary<DBColumn, DBColumn> columnMapping,
    EventHandler<AsyncCompletedEventArgs<int>> callback,
    Object userState
)
Visual Basic
Public Sub BulkExportAsync ( _
    requestKey As HttpRequestKey, _
    command As SelectCommand, _
    destination As IDataSet, _
    columnMapping As IDictionary(Of DBColumn, DBColumn), _
    callback As EventHandler(Of AsyncCompletedEventArgs(Of Integer)), _
    userState As Object _
)

Parameters

requestKey
Type: ININ.IceLib.Configuration.Dialer..::..HttpRequestKey
The request key obtained by calling GetHttpRequestKey(ConfigurationId, ServerType).
command
Type: ININ.IceLib.Configuration.Dialer..::..SelectCommand
The command that determines which contacts are pulled from the call list.
destination
Type: ININ.IceLib.Configuration.Dialer.DataTypes..::..IDataSet
The data set to export the contacts to.
columnMapping
Type: System.Collections.Generic..::..IDictionary<(Of <(<' DBColumn, DBColumn >)>)>
A mapping between contact list columns (keys) and the columns in the destination (values).
callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Int32>)>)>>)>)>
The event handler to call upon completion.
userState
Type: System..::..Object
The user state.

See Also

ContactListConfiguration Class
ContactListConfiguration Members


BulkExportDNCMetadata Method

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..BulkExportDNCMetadata Method
ContactListConfiguration Class See Also Send Feedback
Exports metadata from the DNC Metadata table into a file or database table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int BulkExportDNCMetadata(
    HttpRequestKey requestKey,
    SelectCommand command,
    IDataSet destination,
    IDictionary<DBColumn, DBColumn> columnMapping
)
Visual Basic
Public Function BulkExportDNCMetadata ( _
    requestKey As HttpRequestKey, _
    command As SelectCommand, _
    destination As IDataSet, _
    columnMapping As IDictionary(Of DBColumn, DBColumn) _
) As Integer

Parameters

requestKey
Type: ININ.IceLib.Configuration.Dialer..::..HttpRequestKey
The request key obtained by calling GetHttpRequestKey(ConfigurationId, ServerType).
command
Type: ININ.IceLib.Configuration.Dialer..::..SelectCommand
The command that determines which records are pulled from the metadata.
destination
Type: ININ.IceLib.Configuration.Dialer.DataTypes..::..IDataSet
The data set to export the metadata to (the table/file must already exist).
columnMapping
Type: System.Collections.Generic..::..IDictionary<(Of <(<' DBColumn, DBColumn >)>)>
A mapping between the metadata columns (keys) and the columns in the destination (values).

Return Value

The number of records exported.

See Also

ContactListConfiguration Class
ContactListConfiguration Members


BulkExportDNCMetadataAsync Method

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..BulkExportDNCMetadataAsync Method
ContactListConfiguration Class See Also Send Feedback
Asynchronously exports metadata from the DNC Metadata table into a file or database table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void BulkExportDNCMetadataAsync(
    HttpRequestKey requestKey,
    SelectCommand command,
    IDataSet destination,
    IDictionary<DBColumn, DBColumn> columnMapping,
    EventHandler<AsyncCompletedEventArgs<int>> callback,
    Object userState
)
Visual Basic
Public Sub BulkExportDNCMetadataAsync ( _
    requestKey As HttpRequestKey, _
    command As SelectCommand, _
    destination As IDataSet, _
    columnMapping As IDictionary(Of DBColumn, DBColumn), _
    callback As EventHandler(Of AsyncCompletedEventArgs(Of Integer)), _
    userState As Object _
)

Parameters

requestKey
Type: ININ.IceLib.Configuration.Dialer..::..HttpRequestKey
The request key obtained by calling GetHttpRequestKey(ConfigurationId, ServerType).
command
Type: ININ.IceLib.Configuration.Dialer..::..SelectCommand
The command that determines which records are pulled from the metadata.
destination
Type: ININ.IceLib.Configuration.Dialer.DataTypes..::..IDataSet
The data set to export the metadata to.
columnMapping
Type: System.Collections.Generic..::..IDictionary<(Of <(<' DBColumn, DBColumn >)>)>
A mapping between the metadata columns (keys) and the columns in the destination (values).
callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Int32>)>)>>)>)>
The event handler to call upon completion.
userState
Type: System..::..Object
The user state.

See Also

ContactListConfiguration Class
ContactListConfiguration Members


BulkImport Method

[image] [image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..BulkImport Method
ContactListConfiguration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BulkImport(HttpRequestKey, IDataSet, IDictionary<(Of <<'(DBColumn, DBColumn>)>>)) | Imports contacts from a data set into the contact list.
Public method | BulkImport(HttpRequestKey, IDataSet, IDictionary<(Of <<'(DBColumn, DBColumn>)>>), Boolean) | Imports contacts from a data set into the contact list.

See Also

ContactListConfiguration Class
ContactListConfiguration Members


BulkImport Method (HttpRequestKey, IDataSet, IDictionary(DBColumn, DBColumn))

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..BulkImport Method (HttpRequestKey, IDataSet, IDictionary<(Of <(<'DBColumn, DBColumn>)>)>)
ContactListConfiguration Class See Also Send Feedback
Imports contacts from a data set into the contact list.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int BulkImport(
    HttpRequestKey requestKey,
    IDataSet source,
    IDictionary<DBColumn, DBColumn> columnMapping
)
Visual Basic
Public Function BulkImport ( _
    requestKey As HttpRequestKey, _
    source As IDataSet, _
    columnMapping As IDictionary(Of DBColumn, DBColumn) _
) As Integer

Parameters

requestKey
Type: ININ.IceLib.Configuration.Dialer..::..HttpRequestKey
The request key obtained by calling GetHttpRequestKey(ConfigurationId, ServerType).
source
Type: ININ.IceLib.Configuration.Dialer.DataTypes..::..IDataSet
The data set to to pull records from.
columnMapping
Type: System.Collections.Generic..::..IDictionary<(Of <(<' DBColumn, DBColumn >)>)>
A mapping between the data source columns (keys) and the contact list columns (values).

Remarks

If the contact list doesn't have an associated table, a new table will be created.

See Also

ContactListConfiguration Class
ContactListConfiguration Members
BulkImport Overload


BulkImport Method (HttpRequestKey, IDataSet, IDictionary(DBColumn, DBColumn), Boolean)

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..BulkImport Method (HttpRequestKey, IDataSet, IDictionary<(Of <(<'DBColumn, DBColumn>)>)>, Boolean)
ContactListConfiguration Class See Also Send Feedback
Imports contacts from a data set into the contact list.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int BulkImport(
    HttpRequestKey requestKey,
    IDataSet source,
    IDictionary<DBColumn, DBColumn> columnMapping,
    bool cleanInputData
)
Visual Basic
Public Function BulkImport ( _
    requestKey As HttpRequestKey, _
    source As IDataSet, _
    columnMapping As IDictionary(Of DBColumn, DBColumn), _
    cleanInputData As Boolean _
) As Integer

Parameters

requestKey
Type: ININ.IceLib.Configuration.Dialer..::..HttpRequestKey
The request key obtained by calling GetHttpRequestKey(ConfigurationId, ServerType).
source
Type: ININ.IceLib.Configuration.Dialer.DataTypes..::..IDataSet
The data set to to pull records from.
columnMapping
Type: System.Collections.Generic..::..IDictionary<(Of <(<' DBColumn, DBColumn >)>)>
A mapping between the data source columns (keys) and the contact list columns (values).
cleanInputData
Type: System..::..Boolean
remove special characters that might cause BCP to fail.

Remarks

If the contact list doesn't have an associated table, a new table will be created.

See Also

ContactListConfiguration Class
ContactListConfiguration Members
BulkImport Overload


BulkImportAsync Method

[image] [image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..BulkImportAsync Method
ContactListConfiguration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | BulkImportAsync(HttpRequestKey, IDataSet, IDictionary<(Of <<'(DBColumn, DBColumn>)>>), EventHandler<(Of <<'(AsyncCompletedEventArgs<(Of <<'(Int32>)>>)>)>>), Object) | Asynchronously imports contacts from a data set into the contact list.
Public method | BulkImportAsync(HttpRequestKey, IDataSet, IDictionary<(Of <<'(DBColumn, DBColumn>)>>), Boolean, EventHandler<(Of <<'(AsyncCompletedEventArgs<(Of <<'(Int32>)>>)>)>>), Object) | Asynchronously imports contacts from a data set into the contact list.

See Also

ContactListConfiguration Class
ContactListConfiguration Members


BulkImportAsync Method (HttpRequestKey, IDataSet, IDictionary(DBColumn, DBColumn), EventHandler(AsyncCompletedEventArgs`1(Int32)), Object)

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..BulkImportAsync Method (HttpRequestKey, IDataSet, IDictionary<(Of <(<'DBColumn, DBColumn>)>)>, EventHandler<(Of <(<'AsyncCompletedEventArgs`1<(Of <(<'Int32>)>)>>)>)>, Object)
ContactListConfiguration Class See Also Send Feedback
Asynchronously imports contacts from a data set into the contact list.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void BulkImportAsync(
    HttpRequestKey requestKey,
    IDataSet source,
    IDictionary<DBColumn, DBColumn> columnMapping,
    EventHandler<AsyncCompletedEventArgs<int>> completionCallback,
    Object state
)
Visual Basic
Public Sub BulkImportAsync ( _
    requestKey As HttpRequestKey, _
    source As IDataSet, _
    columnMapping As IDictionary(Of DBColumn, DBColumn), _
    completionCallback As EventHandler(Of AsyncCompletedEventArgs(Of Integer)), _
    state As Object _
)

Parameters

requestKey
Type: ININ.IceLib.Configuration.Dialer..::..HttpRequestKey
The request key obtained by calling GetHttpRequestKey(ConfigurationId, ServerType).
source
Type: ININ.IceLib.Configuration.Dialer.DataTypes..::..IDataSet
The data set to to pull records from.
columnMapping
Type: System.Collections.Generic..::..IDictionary<(Of <(<' DBColumn, DBColumn >)>)>
A mapping between the data source columns (keys) and the contact list columns (values).
completionCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Int32>)>)>>)>)>
The event handler to call upon completion.
state
Type: System..::..Object
The user state.

Remarks

If the contact list does not have an associated table, a new table will be created .

See Also

ContactListConfiguration Class
ContactListConfiguration Members
BulkImportAsync Overload


BulkImportAsync Method (HttpRequestKey, IDataSet, IDictionary(DBColumn, DBColumn), Boolean, EventHandler(AsyncCompletedEventArgs`1(Int32)), Object)

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..BulkImportAsync Method (HttpRequestKey, IDataSet, IDictionary<(Of <(<'DBColumn, DBColumn>)>)>, Boolean, EventHandler<(Of <(<'AsyncCompletedEventArgs`1<(Of <(<'Int32>)>)>>)>)>, Object)
ContactListConfiguration Class See Also Send Feedback
Asynchronously imports contacts from a data set into the contact list.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void BulkImportAsync(
    HttpRequestKey requestKey,
    IDataSet source,
    IDictionary<DBColumn, DBColumn> columnMapping,
    bool cleanInputData,
    EventHandler<AsyncCompletedEventArgs<int>> completionCallback,
    Object state
)
Visual Basic
Public Sub BulkImportAsync ( _
    requestKey As HttpRequestKey, _
    source As IDataSet, _
    columnMapping As IDictionary(Of DBColumn, DBColumn), _
    cleanInputData As Boolean, _
    completionCallback As EventHandler(Of AsyncCompletedEventArgs(Of Integer)), _
    state As Object _
)

Parameters

requestKey
Type: ININ.IceLib.Configuration.Dialer..::..HttpRequestKey
The request key obtained by calling GetHttpRequestKey(ConfigurationId, ServerType).
source
Type: ININ.IceLib.Configuration.Dialer.DataTypes..::..IDataSet
The data set to to pull records from.
columnMapping
Type: System.Collections.Generic..::..IDictionary<(Of <(<' DBColumn, DBColumn >)>)>
A mapping between the data source columns (keys) and the contact list columns (values).
cleanInputData
Type: System..::..Boolean
remove special characters that might cause BCP to fail.
completionCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Int32>)>)>>)>)>
The event handler to call upon completion.
state
Type: System..::..Object
The user state.

Remarks

If the contact list does not have an associated table, a new table will be created .

See Also

ContactListConfiguration Class
ContactListConfiguration Members
BulkImportAsync Overload


BulkMoveIn Method

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..BulkMoveIn Method
ContactListConfiguration Class See Also Send Feedback
Copies records from a database table (not necessarily a contact list) accessible via a Dialer connection into this contact list.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int BulkMoveIn(
    HttpRequestKey requestKey,
    ConnectionConfiguration connection,
    string table,
    IDictionary<DBColumn, DBColumn> columnMapping
)
Visual Basic
Public Function BulkMoveIn ( _
    requestKey As HttpRequestKey, _
    connection As ConnectionConfiguration, _
    table As String, _
    columnMapping As IDictionary(Of DBColumn, DBColumn) _
) As Integer

Parameters

requestKey
Type: ININ.IceLib.Configuration.Dialer..::..HttpRequestKey
The request key obtained by calling GetHttpRequestKey(ConfigurationId, ServerType).
connection
Type: ININ.IceLib.Configuration.Dialer..::..ConnectionConfiguration
The connection under which the source table resides.
table
Type: System..::..String
The source table name.
columnMapping
Type: System.Collections.Generic..::..IDictionary<(Of <(<' DBColumn, DBColumn >)>)>
A mapping between the source table's columns and the corresponding columns in the contact list.

See Also

ContactListConfiguration Class
ContactListConfiguration Members


BulkMoveInAsync Method

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..BulkMoveInAsync Method
ContactListConfiguration Class See Also Send Feedback
Asynchronously copies records from a database table (not necessarily a contact list) accessible via a Dialer connection into this contact list.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void BulkMoveInAsync(
    HttpRequestKey requestKey,
    ConnectionConfiguration connection,
    string table,
    IDictionary<DBColumn, DBColumn> columnMapping,
    EventHandler<AsyncCompletedEventArgs<int>> callback,
    Object userState
)
Visual Basic
Public Sub BulkMoveInAsync ( _
    requestKey As HttpRequestKey, _
    connection As ConnectionConfiguration, _
    table As String, _
    columnMapping As IDictionary(Of DBColumn, DBColumn), _
    callback As EventHandler(Of AsyncCompletedEventArgs(Of Integer)), _
    userState As Object _
)

Parameters

requestKey
Type: ININ.IceLib.Configuration.Dialer..::..HttpRequestKey
The request key obtained by calling GetHttpRequestKey(ConfigurationId, ServerType).
connection
Type: ININ.IceLib.Configuration.Dialer..::..ConnectionConfiguration
The connection under which the source table resides.
table
Type: System..::..String
The source table name.
columnMapping
Type: System.Collections.Generic..::..IDictionary<(Of <(<' DBColumn, DBColumn >)>)>
A mapping between the source table's columns and the corresponding columns in the contact list.
callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Int32>)>)>>)>)>
The event handler to call upon completion.
userState
Type: System..::..Object
The user state.

See Also

ContactListConfiguration Class
ContactListConfiguration Members


BulkMoveOut Method

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..BulkMoveOut Method
ContactListConfiguration Class See Also Send Feedback
Moves contacts from the contact list into a database table accessible from a Dialer connection.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int BulkMoveOut(
    HttpRequestKey requestKey,
    SelectCommand command,
    ConnectionConfiguration connection,
    string table,
    IDictionary<DBColumn, DBColumn> columnMapping,
    bool createNewTable,
    IList<DBColumn> extraFields
)
Visual Basic
Public Function BulkMoveOut ( _
    requestKey As HttpRequestKey, _
    command As SelectCommand, _
    connection As ConnectionConfiguration, _
    table As String, _
    columnMapping As IDictionary(Of DBColumn, DBColumn), _
    createNewTable As Boolean, _
    extraFields As IList(Of DBColumn) _
) As Integer

Parameters

requestKey
Type: ININ.IceLib.Configuration.Dialer..::..HttpRequestKey
The request key obtained by calling GetHttpRequestKey(ConfigurationId, ServerType).
command
Type: ININ.IceLib.Configuration.Dialer..::..SelectCommand
The command that determines which contacts are pulled from the contact list.
connection
Type: ININ.IceLib.Configuration.Dialer..::..ConnectionConfiguration
The connection under which the destination table resides.
table
Type: System..::..String
The destination table name.
columnMapping
Type: System.Collections.Generic..::..IDictionary<(Of <(<' DBColumn, DBColumn >)>)>
A mapping between the contact list columns and the corresponding columns in the destination table.
createNewTable
Type: System..::..Boolean
true if the destination table needs to be created, false if it already exists. The table's fields are defined by columnMapping.Values and extraFields
extraFields
Type: System.Collections.Generic..::..IList<(Of <(<' DBColumn >)>)>
Any extra fields that should be included in new table creation, but not included in the data transfer process.

See Also

ContactListConfiguration Class
ContactListConfiguration Members


BulkMoveOutAsync Method

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..BulkMoveOutAsync Method
ContactListConfiguration Class See Also Send Feedback
Asynchronously moves contacts from the contact list into a database table accessible from a Dialer connection.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void BulkMoveOutAsync(
    HttpRequestKey requestKey,
    SelectCommand command,
    ConnectionConfiguration connection,
    string table,
    IDictionary<DBColumn, DBColumn> columnMapping,
    bool createNewTable,
    IList<DBColumn> extraFields,
    EventHandler<AsyncCompletedEventArgs<int>> callback,
    Object userState
)
Visual Basic
Public Sub BulkMoveOutAsync ( _
    requestKey As HttpRequestKey, _
    command As SelectCommand, _
    connection As ConnectionConfiguration, _
    table As String, _
    columnMapping As IDictionary(Of DBColumn, DBColumn), _
    createNewTable As Boolean, _
    extraFields As IList(Of DBColumn), _
    callback As EventHandler(Of AsyncCompletedEventArgs(Of Integer)), _
    userState As Object _
)

Parameters

requestKey
Type: ININ.IceLib.Configuration.Dialer..::..HttpRequestKey
The request key obtained by calling GetHttpRequestKey(ConfigurationId, ServerType).
command
Type: ININ.IceLib.Configuration.Dialer..::..SelectCommand
The command that determines which contacts are pulled from the contact list.
connection
Type: ININ.IceLib.Configuration.Dialer..::..ConnectionConfiguration
The connection under which the destination table resides.
table
Type: System..::..String
The destination table name.
columnMapping
Type: System.Collections.Generic..::..IDictionary<(Of <(<' DBColumn, DBColumn >)>)>
A mapping between the contact list columns and the corresponding columns in the destination table.
createNewTable
Type: System..::..Boolean
true if the destination table needs to be created, false if it already exists. The table's fields are defined by columnMapping.Values and extraFields
extraFields
Type: System.Collections.Generic..::..IList<(Of <(<' DBColumn >)>)>
Any extra fields that should be included in new table creation, but not included in the data transfer process.
callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Int32>)>)>>)>)>
The event handler to call upon completion.
userState
Type: System..::..Object
The user state.

See Also

ContactListConfiguration Class
ContactListConfiguration Members


CreateTables Method

[image] [image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..CreateTables Method
ContactListConfiguration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CreateTables(TableType) | Create database tables and associate them with the contact list.
Public method | CreateTables(TableType, IEnumerable<(Of <<'(DBColumn>)>>)) | Create database tables and associate them with the contact list.

See Also

ContactListConfiguration Class
ContactListConfiguration Members


CreateTables Method (TableType)

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..CreateTables Method (TableType)
ContactListConfiguration Class See Also Send Feedback
Create database tables and associate them with the contact list.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void CreateTables(
    TableType tableMask
)
Visual Basic
Public Sub CreateTables ( _
    tableMask As TableType _
)

Parameters

tableMask
Type: ININ.IceLib.Configuration.Dialer..::..TableType
A bitmask of TableTypes specifying which tables to create.

Remarks

The name of the contact list table determines the name of the associated tables. If the contact list table does not exist yet, the name of the contact list object is used.

See Also

ContactListConfiguration Class
ContactListConfiguration Members
CreateTables Overload


CreateTables Method (TableType, IEnumerable(DBColumn))

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..CreateTables Method (TableType, IEnumerable<(Of <(<'DBColumn>)>)>)
ContactListConfiguration Class See Also Send Feedback
Create database tables and associate them with the contact list.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void CreateTables(
    TableType tableMask,
    IEnumerable<DBColumn> customColumns
)
Visual Basic
Public Sub CreateTables ( _
    tableMask As TableType, _
    customColumns As IEnumerable(Of DBColumn) _
)

Parameters

tableMask
Type: ININ.IceLib.Configuration.Dialer..::..TableType
A bitmask of TableTypes specifying which tables to create.
customColumns
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' DBColumn >)>)>
Custom columns to include in the contact list table, or null if not applicable.

Remarks

The name of the contact list table determines the name of the associated tables. If the contact list table does not exist yet, the name of the contact list object is used.

See Also

ContactListConfiguration Class
ContactListConfiguration Members
CreateTables Overload


CreateTablesAsync Method

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..CreateTablesAsync Method
ContactListConfiguration Class See Also Send Feedback
Asynchronously create database tables and associate them with the contact list.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void CreateTablesAsync(
    TableType tableMask,
    IEnumerable<DBColumn> customColumns,
    EventHandler<AsyncCompletedEventArgs<bool>> callback,
    Object userState
)
Visual Basic
Public Sub CreateTablesAsync ( _
    tableMask As TableType, _
    customColumns As IEnumerable(Of DBColumn), _
    callback As EventHandler(Of AsyncCompletedEventArgs(Of Boolean)), _
    userState As Object _
)

Parameters

tableMask
Type: ININ.IceLib.Configuration.Dialer..::..TableType
A bitmask of TableTypes specifying which tables to create.
customColumns
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' DBColumn >)>)>
Custom columns to include in the contact list table, or null if not applicable.
callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Boolean>)>)>>)>)>
userState
Type: System..::..Object

See Also

ContactListConfiguration Class
ContactListConfiguration Members


DropTables Method

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..DropTables Method
ContactListConfiguration Class See Also Send Feedback
Drops the database tables associated with the contact list. A bitmask of TableTypes specifying which tables to drop.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool DropTables(
    TableType tableMask
)
Visual Basic
Public Function DropTables ( _
    tableMask As TableType _
) As Boolean

Parameters

tableMask
Type: ININ.IceLib.Configuration.Dialer..::..TableType

See Also

ContactListConfiguration Class
ContactListConfiguration Members


DropTablesAsync Method

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..DropTablesAsync Method
ContactListConfiguration Class See Also Send Feedback
Asynchronously drops the database tables associated with the contact list.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void DropTablesAsync(
    TableType tableMask,
    EventHandler<AsyncCompletedEventArgs<bool>> callback,
    Object userState
)
Visual Basic
Public Sub DropTablesAsync ( _
    tableMask As TableType, _
    callback As EventHandler(Of AsyncCompletedEventArgs(Of Boolean)), _
    userState As Object _
)

Parameters

tableMask
Type: ININ.IceLib.Configuration.Dialer..::..TableType
A bitmask of TableTypes specifying which tables to drop.
callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Boolean>)>)>>)>)>
The event handler to call upon completion.
userState
Type: System..::..Object
The user state.

See Also

ContactListConfiguration Class
ContactListConfiguration Members


FlushContacts Method

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..FlushContacts Method
ContactListConfiguration Class See Also Send Feedback
Flush contact records from the dialing queue in order to prevent them from being dialed.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool FlushContacts(
    IEnumerable<KeyValuePair<string, ConfigurationId>> records
)
Visual Basic
Public Function FlushContacts ( _
    records As IEnumerable(Of KeyValuePair(Of String, ConfigurationId)) _
) As Boolean

Parameters

records
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'KeyValuePair<(Of <(<'String, ConfigurationId>)>)>>)>)>
A collection of KeyValuePairs containing the I3_Identity (key) of the contact and the Id of the campaign (value) in which it is active

See Also

ContactListConfiguration Class
ContactListConfiguration Members


FlushContactsAsync Method

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..FlushContactsAsync Method
ContactListConfiguration Class See Also Send Feedback
Asynchronously flushes contact records from the dialing queue in order to prevent them from being dialed.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void FlushContactsAsync(
    IEnumerable<KeyValuePair<string, ConfigurationId>> records,
    EventHandler<AsyncCompletedEventArgs<bool>> completionCallback,
    Object userState
)
Visual Basic
Public Sub FlushContactsAsync ( _
    records As IEnumerable(Of KeyValuePair(Of String, ConfigurationId)), _
    completionCallback As EventHandler(Of AsyncCompletedEventArgs(Of Boolean)), _
    userState As Object _
)

Parameters

records
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'KeyValuePair<(Of <(<'String, ConfigurationId>)>)>>)>)>
A collection of KeyValuePairs containing the I3_Identity of the contact (key) and the Id of the campaign (value) in which it is active
completionCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Boolean>)>)>>)>)>
The event handler to call upon completion
userState
Type: System..::..Object
The user state

See Also

ContactListConfiguration Class
ContactListConfiguration Members


GetColumns Method

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..GetColumns Method
ContactListConfiguration Class See Also Send Feedback
Retrieves the fields in this contact list.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DBColumn[] GetColumns()
Visual Basic
Public Function GetColumns As DBColumn()

Return Value

An array of DBColumn objects representing the fields in the contact list database table.

Remarks

An alternative (synchronous) method way to get this collection is to use the ValueCollection property of the ColumnMap.

See Also

ContactListConfiguration Class
ContactListConfiguration Members


GetColumnsAsync Method

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..GetColumnsAsync Method
ContactListConfiguration Class See Also Send Feedback
Asynchrously retrieves the fields in this contact list.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void GetColumnsAsync(
    EventHandler<AsyncCompletedEventArgs<DBColumn[]>> completionCallback,
    Object state
)
Visual Basic
Public Sub GetColumnsAsync ( _
    completionCallback As EventHandler(Of AsyncCompletedEventArgs(Of DBColumn())), _
    state As Object _
)

Parameters

completionCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'array< DBColumn >[]()[][]>)>)>>)>)>
state
Type: System..::..Object

Return Value

An array of DBColumn objects representing the fields in the contact list database table.

Remarks

An alternative (synchronous) way to get this collection is to use the ValueCollection property of the ColumnMap.

See Also

ContactListConfiguration Class
ContactListConfiguration Members


GetContacts Method

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..GetContacts Method
ContactListConfiguration Class See Also Send Feedback
Run a query to retrieve records from the contact list.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<Dictionary<string, Object>> GetContacts(
    HttpRequestKey requestKey,
    SelectCommand command
)
Visual Basic
Public Function GetContacts ( _
    requestKey As HttpRequestKey, _
    command As SelectCommand _
) As Collection(Of Dictionary(Of String, Object))

Parameters

requestKey
Type: ININ.IceLib.Configuration.Dialer..::..HttpRequestKey
The request key obtained by calling GetHttpRequestKey(ConfigurationId, ServerType)
command
Type: ININ.IceLib.Configuration.Dialer..::..SelectCommand
The query to run.

Return Value

A list of contact records.

See Also

ContactListConfiguration Class
ContactListConfiguration Members


GetContactsAsync Method

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..GetContactsAsync Method
ContactListConfiguration Class See Also Send Feedback
Run a query to retrieve records from the contact list.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void GetContactsAsync(
    HttpRequestKey requestKey,
    SelectCommand command,
    EventHandler<AsyncCompletedEventArgs<Collection<Dictionary<string, Object>>>> callback,
    Object userState
)
Visual Basic
Public Sub GetContactsAsync ( _
    requestKey As HttpRequestKey, _
    command As SelectCommand, _
    callback As EventHandler(Of AsyncCompletedEventArgs(Of Collection(Of Dictionary(Of String, Object)))), _
    userState As Object _
)

Parameters

requestKey
Type: ININ.IceLib.Configuration.Dialer..::..HttpRequestKey
The request key obtained by calling GetHttpRequestKey(ConfigurationId, ServerType)
command
Type: ININ.IceLib.Configuration.Dialer..::..SelectCommand
The query to run.
callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Collection<(Of <(<'Dictionary<(Of <(<'String, Object>)>)>>)>)>>)>)>>)>)>
The event handler to call upon completion.
userState
Type: System..::..Object
The user state.

Remarks

The total number of contacts in a paged query can be obtained by checking the RecordsAffected property on command after successful execution.

See Also

ContactListConfiguration Class
ContactListConfiguration Members


GetCustomPNDColumnMap Method

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..GetCustomPNDColumnMap Method
ContactListConfiguration Class See Also Send Feedback
Returns a list of custom columns that exist in the PND table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<DBColumn> GetCustomPNDColumnMap()
Visual Basic
Public Function GetCustomPNDColumnMap As Collection(Of DBColumn)

Return Value

See Also

ContactListConfiguration Class
ContactListConfiguration Members


GetDNCMetadata Method

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..GetDNCMetadata Method
ContactListConfiguration Class See Also Send Feedback
Run a query to retrieve records from the contact list DNC Metadata.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<Dictionary<string, Object>> GetDNCMetadata(
    HttpRequestKey requestKey,
    SelectCommand command
)
Visual Basic
Public Function GetDNCMetadata ( _
    requestKey As HttpRequestKey, _
    command As SelectCommand _
) As Collection(Of Dictionary(Of String, Object))

Parameters

requestKey
Type: ININ.IceLib.Configuration.Dialer..::..HttpRequestKey
The request key obtained by calling GetHttpRequestKey(ConfigurationId, ServerType)
command
Type: ININ.IceLib.Configuration.Dialer..::..SelectCommand
The query to run.

Return Value

A list of DNC metadata records.

See Also

ContactListConfiguration Class
ContactListConfiguration Members


GetDNCMetadataAsync Method

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..GetDNCMetadataAsync Method
ContactListConfiguration Class See Also Send Feedback
Run a query to retrieve records from the contact list DNC Metadata.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void GetDNCMetadataAsync(
    HttpRequestKey requestKey,
    SelectCommand command,
    EventHandler<AsyncCompletedEventArgs<Collection<Dictionary<string, Object>>>> callback,
    Object userState
)
Visual Basic
Public Sub GetDNCMetadataAsync ( _
    requestKey As HttpRequestKey, _
    command As SelectCommand, _
    callback As EventHandler(Of AsyncCompletedEventArgs(Of Collection(Of Dictionary(Of String, Object)))), _
    userState As Object _
)

Parameters

requestKey
Type: ININ.IceLib.Configuration.Dialer..::..HttpRequestKey
The request key obtained by calling GetHttpRequestKey(ConfigurationId, ServerType)
command
Type: ININ.IceLib.Configuration.Dialer..::..SelectCommand
The query to run.
callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Collection<(Of <(<'Dictionary<(Of <(<'String, Object>)>)>>)>)>>)>)>>)>)>
The event handler to call upon completion.
userState
Type: System..::..Object
The user state.

Remarks

The total number of metadata records in a paged query can be obtained by checking the RecordsAffected property on command after successful execution.

See Also

ContactListConfiguration Class
ContactListConfiguration Members


RunSmallQuery Method

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..RunSmallQuery Method
ContactListConfiguration Class See Also Send Feedback
Run a query to retrieve records from the contact list.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<Dictionary<string, Object>> RunSmallQuery(
    SelectCommand command
)
Visual Basic
Public Function RunSmallQuery ( _
    command As SelectCommand _
) As Collection(Of Dictionary(Of String, Object))

Parameters

command
Type: ININ.IceLib.Configuration.Dialer..::..SelectCommand
The query to run.

Return Value

A list of contact records.

Remarks

This method should only be used when the result set is known to be small (e.g. counts, sums, etc).

See Also

ContactListConfiguration Class
ContactListConfiguration Members


RunSmallQueryAsync Method

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..RunSmallQueryAsync Method
ContactListConfiguration Class See Also Send Feedback
Asynchronously runs a query to retrieve records from the contact list.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void RunSmallQueryAsync(
    SelectCommand command,
    EventHandler<AsyncCompletedEventArgs<Collection<Dictionary<string, Object>>>> callback,
    Object userState
)
Visual Basic
Public Sub RunSmallQueryAsync ( _
    command As SelectCommand, _
    callback As EventHandler(Of AsyncCompletedEventArgs(Of Collection(Of Dictionary(Of String, Object)))), _
    userState As Object _
)

Parameters

command
Type: ININ.IceLib.Configuration.Dialer..::..SelectCommand
The query to run.
callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Collection<(Of <(<'Dictionary<(Of <(<'String, Object>)>)>>)>)>>)>)>>)>)>
The event handler to call upon completion.
userState
Type: System..::..Object
The user state.

See Also

ContactListConfiguration Class
ContactListConfiguration Members


RunTransaction Method

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..RunTransaction Method
ContactListConfiguration Class See Also Send Feedback
Executes one or more commands against the contact list as a transaction.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int RunTransaction(
    ContactListTransaction transaction
)
Visual Basic
Public Function RunTransaction ( _
    transaction As ContactListTransaction _
) As Integer

Parameters

transaction
Type: ININ.IceLib.Configuration.Dialer..::..ContactListTransaction
The list of commands to execute.

Return Value

The sum of records affected by every command. Each command in transaction retains a count of the records it affected.

See Also

ContactListConfiguration Class
ContactListConfiguration Members


RunTransactionAsync Method

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..RunTransactionAsync Method
ContactListConfiguration Class See Also Send Feedback
Asynchronously executes one or more commands against the contact list as a transaction.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void RunTransactionAsync(
    ContactListTransaction transaction,
    EventHandler<AsyncCompletedEventArgs<int>> callback,
    Object userState
)
Visual Basic
Public Sub RunTransactionAsync ( _
    transaction As ContactListTransaction, _
    callback As EventHandler(Of AsyncCompletedEventArgs(Of Integer)), _
    userState As Object _
)

Parameters

transaction
Type: ININ.IceLib.Configuration.Dialer..::..ContactListTransaction
The list of commands to execute.
callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Int32>)>)>>)>)>
The event handler to call upon completion.
userState
Type: System..::..Object
The user state.

See Also

ContactListConfiguration Class
ContactListConfiguration Members


ContactListConfiguration Properties

[image] [image]

IceLib Dialer Technical Reference
ContactListConfiguration Properties
ContactListConfiguration Class See Also Send Feedback

The ContactListConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' ContactListConfiguration..::..Property >)>)>.)
Public property | ColumnMap | A case-insensitive mapping of all column names in the contact list to their column definitions.
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | Connection | The Id of the database connection used to access the contact list table.
Public property | ContactColumns | The columns in the contact list table that are marked as phone number columns.
Public property | DNCMetadataColumnMap | A case-insensitive mapping of all column names in the DNC Metadata table to their column definitions.
Public property | DurationOfOwnership | The number of hours a contact record is exclusively owned by a campaign.
Public property | EnableCampaignOwnership | Toggles whether or not the records in the contact list can be exclusively owned by a campaign.
Public property | EnableDncComMetaData | Toggles whether or not Dialer is recording DNC.Com meta data.
Public property | EnableMetaDataCleanup | Toggles whether or not Dialer automatically deletes records from the table older than then MetadataDuration period.
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsExporting | Tells whether the current object is being used for exporting
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | MetaDataDuration | The number of days dialer will wait before deleting a record from the meta data table.
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | PNDColumnMap | A case-insensitive mapping of all column names in the Phone Number Details table to their column definitions.
Public property | RevisionLevel | The current version of this object.
Public property | TableName | The name of the contact list table.

See Also

ContactListConfiguration Class


ColumnMap Property

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..ColumnMap Property
ContactListConfiguration Class See Also Send Feedback
A case-insensitive mapping of all column names in the contact list to their column definitions.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Dictionary<string, DBColumn> ColumnMap { get; }
Visual Basic
Public ReadOnly Property ColumnMap As Dictionary(Of String, DBColumn)
    Get

See Also

ContactListConfiguration Class
ContactListConfiguration Members


Connection Property

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..Connection Property
ContactListConfiguration Class See Also Send Feedback
The Id of the database connection used to access the contact list table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<ContactListConfiguration..::..Property, ConfigurationId> Connection { get; }
Visual Basic
Public ReadOnly Property Connection As GeneralConfigurationProperty(Of ContactListConfiguration..::..Property, ConfigurationId)
    Get

See Also

ContactListConfiguration Class
ContactListConfiguration Members


ContactColumns Property

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..ContactColumns Property
ContactListConfiguration Class See Also Send Feedback
The columns in the contact list table that are marked as phone number columns.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<ContactListConfiguration..::..Property, Collection<ConfigurationId>> ContactColumns { get; }
Visual Basic
Public ReadOnly Property ContactColumns As GeneralConfigurationProperty(Of ContactListConfiguration..::..Property, Collection(Of ConfigurationId))
    Get

See Also

ContactListConfiguration Class
ContactListConfiguration Members


DNCMetadataColumnMap Property

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..DNCMetadataColumnMap Property
ContactListConfiguration Class See Also Send Feedback
A case-insensitive mapping of all column names in the DNC Metadata table to their column definitions.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Dictionary<string, DBColumn> DNCMetadataColumnMap { get; }
Visual Basic
Public ReadOnly Property DNCMetadataColumnMap As Dictionary(Of String, DBColumn)
    Get

See Also

ContactListConfiguration Class
ContactListConfiguration Members


DurationOfOwnership Property

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..DurationOfOwnership Property
ContactListConfiguration Class See Also Send Feedback
The number of hours a contact record is exclusively owned by a campaign.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<ContactListConfiguration..::..Property, int> DurationOfOwnership { get; }
Visual Basic
Public ReadOnly Property DurationOfOwnership As GeneralConfigurationProperty(Of ContactListConfiguration..::..Property, Integer)
    Get

Remarks

a value of -1 indicates no experation time.

See Also

ContactListConfiguration Class
ContactListConfiguration Members


EnableCampaignOwnership Property

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..EnableCampaignOwnership Property
ContactListConfiguration Class See Also Send Feedback
Toggles whether or not the records in the contact list can be exclusively owned by a campaign.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<ContactListConfiguration..::..Property, bool> EnableCampaignOwnership { get; }
Visual Basic
Public ReadOnly Property EnableCampaignOwnership As GeneralConfigurationProperty(Of ContactListConfiguration..::..Property, Boolean)
    Get

See Also

ContactListConfiguration Class
ContactListConfiguration Members


EnableDncComMetaData Property

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..EnableDncComMetaData Property
ContactListConfiguration Class See Also Send Feedback
Toggles whether or not Dialer is recording DNC.Com meta data.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<ContactListConfiguration..::..Property, bool> EnableDncComMetaData { get; }
Visual Basic
Public ReadOnly Property EnableDncComMetaData As GeneralConfigurationProperty(Of ContactListConfiguration..::..Property, Boolean)
    Get

See Also

ContactListConfiguration Class
ContactListConfiguration Members


EnableMetaDataCleanup Property

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..EnableMetaDataCleanup Property
ContactListConfiguration Class See Also Send Feedback
Toggles whether or not Dialer automatically deletes records from the table older than then MetadataDuration period.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<ContactListConfiguration..::..Property, bool> EnableMetaDataCleanup { get; }
Visual Basic
Public ReadOnly Property EnableMetaDataCleanup As GeneralConfigurationProperty(Of ContactListConfiguration..::..Property, Boolean)
    Get

See Also

ContactListConfiguration Class
ContactListConfiguration Members


IsDefaultObject Property

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..IsDefaultObject Property
ContactListConfiguration Class See Also Send Feedback
Indicates whether this is the default instance of this object type.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsDefaultObject { get; }
Visual Basic
Public ReadOnly Property IsDefaultObject As Boolean
    Get

See Also

ContactListConfiguration Class
ContactListConfiguration Members


IsExporting Property

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..IsExporting Property
ContactListConfiguration Class See Also Send Feedback
Tells whether the current object is being used for exporting

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsExporting { get; private set; }
Visual Basic
Public Property IsExporting As Boolean
    Get
    Private Set

See Also

ContactListConfiguration Class
ContactListConfiguration Members


MetaDataDuration Property

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..MetaDataDuration Property
ContactListConfiguration Class See Also Send Feedback
The number of days dialer will wait before deleting a record from the meta data table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<ContactListConfiguration..::..Property, int> MetaDataDuration { get; }
Visual Basic
Public ReadOnly Property MetaDataDuration As GeneralConfigurationProperty(Of ContactListConfiguration..::..Property, Integer)
    Get

See Also

ContactListConfiguration Class
ContactListConfiguration Members


PNDColumnMap Property

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..PNDColumnMap Property
ContactListConfiguration Class See Also Send Feedback
A case-insensitive mapping of all column names in the Phone Number Details table to their column definitions.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Dictionary<string, DBColumn> PNDColumnMap { get; }
Visual Basic
Public ReadOnly Property PNDColumnMap As Dictionary(Of String, DBColumn)
    Get

See Also

ContactListConfiguration Class
ContactListConfiguration Members


RevisionLevel Property

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..RevisionLevel Property
ContactListConfiguration Class See Also Send Feedback
The current version of this object.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<ContactListConfiguration..::..Property, int> RevisionLevel { get; }
Visual Basic
Public ReadOnly Property RevisionLevel As GeneralConfigurationProperty(Of ContactListConfiguration..::..Property, Integer)
    Get

See Also

ContactListConfiguration Class
ContactListConfiguration Members


TableName Property

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..TableName Property
ContactListConfiguration Class See Also Send Feedback
The name of the contact list table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<ContactListConfiguration..::..Property, string> TableName { get; }
Visual Basic
Public ReadOnly Property TableName As GeneralConfigurationProperty(Of ContactListConfiguration..::..Property, String)
    Get

See Also

ContactListConfiguration Class
ContactListConfiguration Members


ContactListConfiguration.Property Enumeration

[image]

IceLib Dialer Technical Reference
ContactListConfiguration..::..Property Enumeration
ContactListConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Id | 0 | Represents the Id part of the ConfigurationId property.
DisplayName | 1 | Represents the DisplayName part of the ConfigurationId property.
Connection | 2 | Represents the Connection property.
ContactColumns | 3 | Represents the ContactColumns property.
TableName | 4 | Represents the TableName property.
RevisionLevel | 5 | Represents the RevisionLevel property.
DurationOfOwnership | 6 | Represents the DurationOfOwnership property.
EnableCampaignOwnership | 7 | Represents the EnableCampaignOwnership property.
EnableDncComMetaData | 8 | Represents the EnableDncComMetaData property.
EnableMetaDataCleanup | 9 | Represents the EnableMetaDataCleanup property.
MetaDataDuration | 10 | Represents the MetaDataDuration property.

See Also


ContactListConfigurationList Class

[image]

IceLib Dialer Technical Reference
ContactListConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing contact list configuration objects.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class ContactListConfigurationList : EditableConfigurationList<ContactListConfiguration, ContactListConfiguration..::..Property>
Visual Basic
Public Class ContactListConfigurationList _
    Inherits EditableConfigurationList(Of ContactListConfiguration, ContactListConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>
DynamicConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>
EditableConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..ContactListConfigurationList

See Also

ContactListConfigurationList Members


ContactListConfigurationList Members

[image] [image]

IceLib Dialer Technical Reference
ContactListConfigurationList Members
ContactListConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The ContactListConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | ContactListConfigurationList | Initializes a new instance of the ContactListConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)

See Also

ContactListConfigurationList Class


ContactListConfigurationList Constructor

[image]

IceLib Dialer Technical Reference
ContactListConfigurationList Constructor
ContactListConfigurationList Class See Also Send Feedback
Initializes a new instance of the ContactListConfigurationList class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ContactListConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

ContactListConfigurationList Class
ContactListConfigurationList Members


ContactListConfigurationList Methods

[image] [image]

IceLib Dialer Technical Reference
ContactListConfigurationList Methods
ContactListConfigurationList Class See Also Send Feedback

The ContactListConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContactListConfigurationList Class


ContactListConfigurationList Properties

[image] [image]

IceLib Dialer Technical Reference
ContactListConfigurationList Properties
ContactListConfigurationList Class See Also Send Feedback

The ContactListConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)

See Also

ContactListConfigurationList Class


ContactListConfigurationList Events

[image] [image]

IceLib Dialer Technical Reference
ContactListConfigurationList Events
ContactListConfigurationList Class See Also Send Feedback

The ContactListConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' ContactListConfiguration, ContactListConfiguration..::..Property >)>)>.)

See Also

ContactListConfigurationList Class


ContactListTransaction Class

[image]

IceLib Dialer Technical Reference
ContactListTransaction Class
Members See Also Send Feedback
Encapsulates one or more commands to run as one as transaction.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class ContactListTransaction : List<ContactListCommand>
Visual Basic
Public Class ContactListTransaction _
    Inherits List(Of ContactListCommand)

Remarks

The commands in a transaction may operate on different contact lists within the same transaction, but they must all use the same database connection.

Inheritance Hierarchy

System..::..Object
System.Collections.Generic..::..List<(Of <(<' ContactListCommand >)>)>
ININ.IceLib.Configuration.Dialer..::..ContactListTransaction

See Also

ContactListTransaction Members


ContactListTransaction Members

[image] [image]

IceLib Dialer Technical Reference
ContactListTransaction Members
ContactListTransaction Class Constructors Methods Properties See Also Send Feedback

The ContactListTransaction type exposes the following members.

Constructors

 | Name | Description
Public method | ContactListTransaction | Initializes a new instance of the ContactListTransaction class

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | AddRange | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)

See Also

ContactListTransaction Class


ContactListTransaction Constructor

[image]

IceLib Dialer Technical Reference
ContactListTransaction Constructor
ContactListTransaction Class See Also Send Feedback
Initializes a new instance of the ContactListTransaction class

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ContactListTransaction()
Visual Basic
Public Sub New

See Also

ContactListTransaction Class
ContactListTransaction Members


ContactListTransaction Methods

[image] [image]

IceLib Dialer Technical Reference
ContactListTransaction Methods
ContactListTransaction Class See Also Send Feedback

The ContactListTransaction type exposes the following members.

Methods

 | Name | Description
Public method | Add | Adds an object to the end of the List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | AddRange | Adds the elements of the specified collection to the end of the List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | AsReadOnly | Returns a read-only IList<(Of <(<'T>)>)> wrapper for the current collection. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | BinarySearch(T) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the default comparer and returns the zero-based index of the element. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | BinarySearch(T, IComparer<(Of <<'(T>)>>)) | Searches the entire sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | BinarySearch(Int32, Int32, T, IComparer<(Of <<'(T>)>>)) | Searches a range of elements in the sorted List<(Of <(<'T>)>)> for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | Clear | Removes all elements from the List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | Contains | Determines whether an element is in the List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | ConvertAll<(Of <<'(TOutput>)>>) | Converts the elements in the current List<(Of <(<'T>)>)> to another type, and returns a list containing the converted elements. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | CopyTo(array<T>[]()[][]) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | CopyTo(array<T>[]()[][], Int32) | Copies the entire List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | CopyTo(Int32, array<T>[]()[][], Int32, Int32) | Copies a range of elements from the List<(Of <(<'T>)>)> to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the List<(Of <(<'T>)>)> contains elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | FindIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | FindIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | FindIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | FindLastIndex(Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | FindLastIndex(Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | FindLastIndex(Int32, Int32, Predicate<(Of <<'(T>)>>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | ForEach | Performs the specified action on each element of the List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | GetEnumerator | Returns an enumerator that iterates through the List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the specified index to the last element. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(<'T>)>)> that starts at the specified index and contains the specified number of elements. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | Insert | Inserts an element into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | InsertRange | Inserts the elements of a collection into the List<(Of <(<'T>)>)> at the specified index. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that extends from the first element to the specified index. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(<'T>)>)> that contains the specified number of elements and ends at the specified index. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | RemoveAt | Removes the element at the specified index of the List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | RemoveRange | Removes a range of elements from the List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | Reverse()()()() | Reverses the order of the elements in the entire List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | Sort()()()() | Sorts the elements in the entire List<(Of <(<'T>)>)> using the default comparer. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | Sort(IComparer<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | Sort(Comparison<(Of <<'(T>)>>)) | Sorts the elements in the entire List<(Of <(<'T>)>)> using the specified Comparison<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | Sort(Int32, Int32, IComparer<(Of <<'(T>)>>)) | Sorts the elements in a range of elements in List<(Of <(<'T>)>)> using the specified comparer. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | ToArray | Copies the elements of the List<(Of <(<'T>)>)> to a new array. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(<'T>)>)>, if that number is less than a threshold value. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public method | TrueForAll | Determines whether every element in the List<(Of <(<'T>)>)> matches the conditions defined by the specified predicate. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)

See Also

ContactListTransaction Class


ContactListTransaction Properties

[image] [image]

IceLib Dialer Technical Reference
ContactListTransaction Properties
ContactListTransaction Class See Also Send Feedback

The ContactListTransaction type exposes the following members.

Properties

 | Name | Description
Public property | Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public property | Count | Gets the number of elements actually contained in the List<(Of <(<'T>)>)>. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from List<(Of <(<' ContactListCommand >)>)>.)

See Also

ContactListTransaction Class


CustomDataBehavior Class

[image]

IceLib Dialer Technical Reference
CustomDataBehavior Class
Members See Also Send Feedback
A PolicyBehavior which sets CustomData1 and CustomData2 attributes.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class CustomDataBehavior : PolicyBehavior
Visual Basic
Public NotInheritable Class CustomDataBehavior _
    Inherits PolicyBehavior

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyBehavior
ININ.IceLib.Configuration.Dialer..::..CustomDataBehavior

See Also

CustomDataBehavior Members


CustomDataBehavior Members

[image] [image]

IceLib Dialer Technical Reference
CustomDataBehavior Members
CustomDataBehavior Class Constructors Methods Properties See Also Send Feedback

The CustomDataBehavior type exposes the following members.

Constructors

 | Name | Description
Public method | CustomDataBehavior | Initializes a new instance of the CustomDataBehavior class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | CustomDataValue1 | Get or set the custom data property
Public property | CustomDataValue2 | Get or set the custom data property
Public property | Id | (Inherited from PolicyBehavior.)

See Also

CustomDataBehavior Class


CustomDataBehavior Constructor

[image]

IceLib Dialer Technical Reference
CustomDataBehavior Constructor
CustomDataBehavior Class See Also Send Feedback
Initializes a new instance of the CustomDataBehavior class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CustomDataBehavior()
Visual Basic
Public Sub New

See Also

CustomDataBehavior Class
CustomDataBehavior Members


CustomDataBehavior Methods

[image] [image]

IceLib Dialer Technical Reference
CustomDataBehavior Methods
CustomDataBehavior Class See Also Send Feedback

The CustomDataBehavior type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomDataBehavior Class


CustomDataBehavior Properties

[image] [image]

IceLib Dialer Technical Reference
CustomDataBehavior Properties
CustomDataBehavior Class See Also Send Feedback

The CustomDataBehavior type exposes the following members.

Properties

 | Name | Description
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | CustomDataValue1 | Get or set the custom data property
Public property | CustomDataValue2 | Get or set the custom data property
Public property | Id | (Inherited from PolicyBehavior.)

See Also

CustomDataBehavior Class


CustomDataValue1 Property

[image]

IceLib Dialer Technical Reference
CustomDataBehavior..::..CustomDataValue1 Property
CustomDataBehavior Class See Also Send Feedback
Get or set the custom data property

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string CustomDataValue1 { get; set; }
Visual Basic
Public Property CustomDataValue1 As String
    Get
    Set

See Also

CustomDataBehavior Class
CustomDataBehavior Members


CustomDataValue2 Property

[image]

IceLib Dialer Technical Reference
CustomDataBehavior..::..CustomDataValue2 Property
CustomDataBehavior Class See Also Send Feedback
Get or set the custom data property

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string CustomDataValue2 { get; set; }
Visual Basic
Public Property CustomDataValue2 As String
    Get
    Set

See Also

CustomDataBehavior Class
CustomDataBehavior Members


CustomStatRule Class

[image]

IceLib Dialer Technical Reference
CustomStatRule Class
Members See Also Send Feedback
A rule that evalutes statistics for a specific field in a contact list.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class CustomStatRule : StatRule
Visual Basic
Public Class CustomStatRule _
    Inherits StatRule

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..Rule
ININ.IceLib.Configuration.Dialer..::..StatRule
ININ.IceLib.Configuration.Dialer..::..CustomStatRule

See Also

CustomStatRule Members


CustomStatRule Members

[image] [image]

IceLib Dialer Technical Reference
CustomStatRule Members
CustomStatRule Class Constructors Methods Properties See Also Send Feedback

The CustomStatRule type exposes the following members.

Constructors

 | Name | Description
Public method | CustomStatRule | Creates a new instance of the CustomStatRule class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Actions | The collection of Actions to perform when this Rule's conditions are met (Inherited from Rule.)
Public property | ColumnName | The name of a contact list column whose values comprise a custom statistic.
Public property | ContactList | The Id of the contact list containing the column specified by ColumnName.
Public property | CountValue | In custom statistics that are tabulated using the Count function, only records that match this value are included in the statistic.
Public property | Enabled | Toggle evaluation/execution of this rule. (Inherited from Rule.)
Public property | Function | A mathematical function describing how values from the contact list should be tabulated into a custom statistic.
Public property | Groups | Named rule groups (within the parent RuleSetConfiguration) to which this rule belongs. (Inherited from Rule.)
Public property | Id | The Id of the Rule. (Inherited from Rule.)
Public property | IgnoreGroups | Specifies whether this rule should be evaluated no matter which group is active. (Inherited from Rule.)
Public property | InAllGroups | Specifies whether this rule is a member of all rule groups of the rule set it belongs to. (Inherited from Rule.)
Public property | Index | Specifies the order to display and execute this rule in relation to other rules in the parent rule set. (Inherited from Rule.)
Public property | InStartupGroup | Specifies whether this rule is a member of the unnamed group that the rule set evaluates first. (Inherited from Rule.)
Public property | IntervalMinutes | The minimum interval (in minutes) between evaluation of the statistic. (Inherited from StatRule.)
Public property | Parameters | Parameter values for the monitored statistic. The parameter keys are taken from the ParameterTypeId Id. Check the appropriate StatisticDefinition to see the required parameters. (Inherited from StatRule.)
Public property | Repetition | Specifies how often the rule should be re-evaluated. (Inherited from Rule.)
Public property | StatIdentifierURI | The URI string of the StatisticIdentifier. (Inherited from StatRule.)
Public property | StatOperation | The comparison operator used in evaluating the rule condition. (Inherited from StatRule.)
Public property | StatValue | The value of the statistic used in evaluating the rule condition. (Inherited from StatRule.)
Public property | TerminateOnAction | Specifies the manner in which rule evaluation should be stopped after this rule runs its actions. (Inherited from Rule.)

See Also

CustomStatRule Class


CustomStatRule Constructor

[image]

IceLib Dialer Technical Reference
CustomStatRule Constructor
CustomStatRule Class See Also Send Feedback
Creates a new instance of the CustomStatRule class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CustomStatRule()
Visual Basic
Public Sub New

See Also

CustomStatRule Class
CustomStatRule Members


CustomStatRule Methods

[image] [image]

IceLib Dialer Technical Reference
CustomStatRule Methods
CustomStatRule Class See Also Send Feedback

The CustomStatRule type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomStatRule Class


CustomStatRule Properties

[image] [image]

IceLib Dialer Technical Reference
CustomStatRule Properties
CustomStatRule Class See Also Send Feedback

The CustomStatRule type exposes the following members.

Properties

 | Name | Description
Public property | Actions | The collection of Actions to perform when this Rule's conditions are met (Inherited from Rule.)
Public property | ColumnName | The name of a contact list column whose values comprise a custom statistic.
Public property | ContactList | The Id of the contact list containing the column specified by ColumnName.
Public property | CountValue | In custom statistics that are tabulated using the Count function, only records that match this value are included in the statistic.
Public property | Enabled | Toggle evaluation/execution of this rule. (Inherited from Rule.)
Public property | Function | A mathematical function describing how values from the contact list should be tabulated into a custom statistic.
Public property | Groups | Named rule groups (within the parent RuleSetConfiguration) to which this rule belongs. (Inherited from Rule.)
Public property | Id | The Id of the Rule. (Inherited from Rule.)
Public property | IgnoreGroups | Specifies whether this rule should be evaluated no matter which group is active. (Inherited from Rule.)
Public property | InAllGroups | Specifies whether this rule is a member of all rule groups of the rule set it belongs to. (Inherited from Rule.)
Public property | Index | Specifies the order to display and execute this rule in relation to other rules in the parent rule set. (Inherited from Rule.)
Public property | InStartupGroup | Specifies whether this rule is a member of the unnamed group that the rule set evaluates first. (Inherited from Rule.)
Public property | IntervalMinutes | The minimum interval (in minutes) between evaluation of the statistic. (Inherited from StatRule.)
Public property | Parameters | Parameter values for the monitored statistic. The parameter keys are taken from the ParameterTypeId Id. Check the appropriate StatisticDefinition to see the required parameters. (Inherited from StatRule.)
Public property | Repetition | Specifies how often the rule should be re-evaluated. (Inherited from Rule.)
Public property | StatIdentifierURI | The URI string of the StatisticIdentifier. (Inherited from StatRule.)
Public property | StatOperation | The comparison operator used in evaluating the rule condition. (Inherited from StatRule.)
Public property | StatValue | The value of the statistic used in evaluating the rule condition. (Inherited from StatRule.)
Public property | TerminateOnAction | Specifies the manner in which rule evaluation should be stopped after this rule runs its actions. (Inherited from Rule.)

See Also

CustomStatRule Class


ColumnName Property

[image]

IceLib Dialer Technical Reference
CustomStatRule..::..ColumnName Property
CustomStatRule Class See Also Send Feedback
The name of a contact list column whose values comprise a custom statistic.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string ColumnName { get; set; }
Visual Basic
Public Property ColumnName As String
    Get
    Set

See Also

CustomStatRule Class
CustomStatRule Members


ContactList Property

[image]

IceLib Dialer Technical Reference
CustomStatRule..::..ContactList Property
CustomStatRule Class See Also Send Feedback
The Id of the contact list containing the column specified by ColumnName.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ConfigurationId ContactList { get; set; }
Visual Basic
Public Property ContactList As ConfigurationId
    Get
    Set

See Also

CustomStatRule Class
CustomStatRule Members


CountValue Property

[image]

IceLib Dialer Technical Reference
CustomStatRule..::..CountValue Property
CustomStatRule Class See Also Send Feedback
In custom statistics that are tabulated using the Count function, only records that match this value are included in the statistic.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string CountValue { get; set; }
Visual Basic
Public Property CountValue As String
    Get
    Set

See Also

CustomStatRule Class
CustomStatRule Members


Function Property

[image]

IceLib Dialer Technical Reference
CustomStatRule..::..Function Property
CustomStatRule Class See Also Send Feedback
A mathematical function describing how values from the contact list should be tabulated into a custom statistic.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public RuleFunction Function { get; set; }
Visual Basic
Public Property Function As RuleFunction
    Get
    Set

See Also

CustomStatRule Class
CustomStatRule Members


CustomStoredProcBehavior Class

[image]

IceLib Dialer Technical Reference
CustomStoredProcBehavior Class
Members See Also Send Feedback
A PolicyBehavior which sets CustomSprocValue1 and CustomSprocValue2 attributes.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class CustomStoredProcBehavior : PolicyBehavior
Visual Basic
Public NotInheritable Class CustomStoredProcBehavior _
    Inherits PolicyBehavior

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyBehavior
ININ.IceLib.Configuration.Dialer..::..CustomStoredProcBehavior

See Also

CustomStoredProcBehavior Members


CustomStoredProcBehavior Members

[image] [image]

IceLib Dialer Technical Reference
CustomStoredProcBehavior Members
CustomStoredProcBehavior Class Constructors Methods Properties See Also Send Feedback

The CustomStoredProcBehavior type exposes the following members.

Constructors

 | Name | Description
Public method | CustomStoredProcBehavior | Initializes a new instance of the CustomStoredProcBehavior class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | CustomSprocValue1 | Get or set the custom value that will be passed to the stored procedure
Public property | CustomSprocValue2 | Get or set the custom value that will be passed to the stored procedure
Public property | Id | (Inherited from PolicyBehavior.)

See Also

CustomStoredProcBehavior Class


CustomStoredProcBehavior Constructor

[image]

IceLib Dialer Technical Reference
CustomStoredProcBehavior Constructor
CustomStoredProcBehavior Class See Also Send Feedback
Initializes a new instance of the CustomStoredProcBehavior class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CustomStoredProcBehavior()
Visual Basic
Public Sub New

See Also

CustomStoredProcBehavior Class
CustomStoredProcBehavior Members


CustomStoredProcBehavior Methods

[image] [image]

IceLib Dialer Technical Reference
CustomStoredProcBehavior Methods
CustomStoredProcBehavior Class See Also Send Feedback

The CustomStoredProcBehavior type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CustomStoredProcBehavior Class


CustomStoredProcBehavior Properties

[image] [image]

IceLib Dialer Technical Reference
CustomStoredProcBehavior Properties
CustomStoredProcBehavior Class See Also Send Feedback

The CustomStoredProcBehavior type exposes the following members.

Properties

 | Name | Description
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | CustomSprocValue1 | Get or set the custom value that will be passed to the stored procedure
Public property | CustomSprocValue2 | Get or set the custom value that will be passed to the stored procedure
Public property | Id | (Inherited from PolicyBehavior.)

See Also

CustomStoredProcBehavior Class


CustomSprocValue1 Property

[image]

IceLib Dialer Technical Reference
CustomStoredProcBehavior..::..CustomSprocValue1 Property
CustomStoredProcBehavior Class See Also Send Feedback
Get or set the custom value that will be passed to the stored procedure

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string CustomSprocValue1 { get; set; }
Visual Basic
Public Property CustomSprocValue1 As String
    Get
    Set

See Also

CustomStoredProcBehavior Class
CustomStoredProcBehavior Members


CustomSprocValue2 Property

[image]

IceLib Dialer Technical Reference
CustomStoredProcBehavior..::..CustomSprocValue2 Property
CustomStoredProcBehavior Class See Also Send Feedback
Get or set the custom value that will be passed to the stored procedure

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string CustomSprocValue2 { get; set; }
Visual Basic
Public Property CustomSprocValue2 As String
    Get
    Set

See Also

CustomStoredProcBehavior Class
CustomStoredProcBehavior Members


DeleteCommand Class

[image]

IceLib Dialer Technical Reference
DeleteCommand Class
Members See Also Send Feedback
A command that deletes records from a contact list table or call schedule table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class DeleteCommand : ContactListCommand
Visual Basic
Public NotInheritable Class DeleteCommand _
    Inherits ContactListCommand

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..ContactListCommand
ININ.IceLib.Configuration.Dialer..::..DeleteCommand

See Also

DeleteCommand Members


DeleteCommand Members

[image] [image]

IceLib Dialer Technical Reference
DeleteCommand Members
DeleteCommand Class Constructors Methods Properties See Also Send Feedback

The DeleteCommand type exposes the following members.

Constructors

 | Name | Description
Public method | DeleteCommand | Initializes a new instance of the DeleteCommand class.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Overrides ContactListCommand..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetDatabaseType | Retrieves the type of database associated with the contact list's connection. (Inherited from ContactListCommand.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ContactList | The contact list to run this command against. (Inherited from ContactListCommand.)
Public property | Filters | The filter to use in the where predicate. (Inherited from ContactListCommand.)
Public property | RecordsAffected | The number of records affected by this command. If this is a paged SelectCommand, the value reflects the total number of records in the unpaged version. (Inherited from ContactListCommand.)
Public property | TableType | Specifies which database table the command applies to. (Overrides ContactListCommand..::..TableType.)
Public property | Where | An expression representing a logical predicate with which to filter records. (Inherited from ContactListCommand.)

See Also

DeleteCommand Class


DeleteCommand Constructor

[image]

IceLib Dialer Technical Reference
DeleteCommand Constructor
DeleteCommand Class See Also Send Feedback
Initializes a new instance of the DeleteCommand class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DeleteCommand(
    ContactListConfiguration contactList,
    IEnumerable<FilterConfiguration> filters
)
Visual Basic
Public Sub New ( _
    contactList As ContactListConfiguration, _
    filters As IEnumerable(Of FilterConfiguration) _
)

Parameters

contactList
Type: ININ.IceLib.Configuration.Dialer..::..ContactListConfiguration
The contact list to run this command against.
filters
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' FilterConfiguration >)>)>
The filters to apply to the where clause.

See Also

DeleteCommand Class
DeleteCommand Members


DeleteCommand Methods

[image] [image]

IceLib Dialer Technical Reference
DeleteCommand Methods
DeleteCommand Class See Also Send Feedback

The DeleteCommand type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Overrides ContactListCommand..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetDatabaseType | Retrieves the type of database associated with the contact list's connection. (Inherited from ContactListCommand.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DeleteCommand Class


Clone Method

[image]

IceLib Dialer Technical Reference
DeleteCommand..::..Clone Method
DeleteCommand Class See Also Send Feedback
Creates a new object that is a copy of the current instance.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object

Return Value

A new object that is a copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

DeleteCommand Class
DeleteCommand Members


DeleteCommand Properties

[image] [image]

IceLib Dialer Technical Reference
DeleteCommand Properties
DeleteCommand Class See Also Send Feedback

The DeleteCommand type exposes the following members.

Properties

 | Name | Description
Public property | ContactList | The contact list to run this command against. (Inherited from ContactListCommand.)
Public property | Filters | The filter to use in the where predicate. (Inherited from ContactListCommand.)
Public property | RecordsAffected | The number of records affected by this command. If this is a paged SelectCommand, the value reflects the total number of records in the unpaged version. (Inherited from ContactListCommand.)
Public property | TableType | Specifies which database table the command applies to. (Overrides ContactListCommand..::..TableType.)
Public property | Where | An expression representing a logical predicate with which to filter records. (Inherited from ContactListCommand.)

See Also

DeleteCommand Class


TableType Property

[image]

IceLib Dialer Technical Reference
DeleteCommand..::..TableType Property
DeleteCommand Class See Also Send Feedback
Specifies which database table the command applies to.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override TableType TableType { get; set; }
Visual Basic
Public Overrides Property TableType As TableType
    Get
    Set

See Also

DeleteCommand Class
DeleteCommand Members


DialerConfigurationManager Class

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager Class
Members See Also Send Feedback
A class that provides access to Dialer configuration and administration information.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class DialerConfigurationManager : IDisposable
Visual Basic
Public Class DialerConfigurationManager _
    Implements IDisposable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..DialerConfigurationManager

See Also

DialerConfigurationManager Members


DialerConfigurationManager Members

[image] [image]

IceLib Dialer Technical Reference
DialerConfigurationManager Members
DialerConfigurationManager Class Constructors Methods Properties Events See Also Send Feedback

The DialerConfigurationManager type exposes the following members.

Constructors

 | Name | Description
Public method | DialerConfigurationManager | Constructs a new instance of the DialerConfigurationManager class.

Methods

 | Name | Description
Public method | CleanMetaDataTable | Causes the cleanup routine for Meta Data Tables to fire immediatly.
Public method | CleanMetaDataTableAsync | Asynchronously requests a transition to a new Campaign Group in a sequence. .
Public method | DeactivateCCSSwitchover | Deactivate Centeral Campaign Switchover.
Public method | DeactivateCCSSwitchoverAsync | Asynchronously deactivate Centeral Campaign Switchover.
Public method | DeleteCampaignServerParameters | Delete Central Campaign Server parameters
Public method | DeleteCampaignServerParametersAsync | Asynchronously delete Central Campaign Server parameters
Public method | DeleteOrphanScriptPages | Obsolete. a method that deletes script pages from the config that no longer are part of a base script configuration.
Public method | DownloadFile | Downloads a file from the Central Campaign Server via the http server.
Public method | DownloadFileAsync | Asynchronously downloads a file from the Central Campaign Server via the http server.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExportXML | Exports Dialer configuration objects as an XML string.
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetCampaignServerParameters | Gets a list of Central Campaign server parameters
Public method | GetCampaignServerParametersAsync | Asynchronously retrieves a list of Central Campaign server parameters
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHttpRequestKey(ConfigurationId) | (Deprecated) Gets the information necessary to send an http request to the Central Campaign Server. Requires the core Dialer config admin right.
Public method | GetHttpRequestKey(ConfigurationId, ServerType) | Gets the information necessary to send an http request to either the Central Campaign Server or the Outbound Dialing Server. Requires the core Dialer config admin right.
Public method | GetHttpRequestKeyAsync(ConfigurationId, EventHandler<(Of <<'(AsyncCompletedEventArgs<(Of <<'(HttpRequestKey>)>>)>)>>), Object) | (Deprecated)Asynchronously retrieves the information necessary to send an http request to the Central Campaign Server. Requires the core Dialer config admin right.
Public method | GetHttpRequestKeyAsync(ConfigurationId, ServerType, EventHandler<(Of <<'(AsyncCompletedEventArgs<(Of <<'(HttpRequestKey>)>>)>)>>), Object) | Asynchronously retrieves the information necessary to send an http request to either the Central Campaign Server or the Outbound Dialing server. Requires the core Dialer config admin right.
Public method | GetLastTransitionTime | Look up the time the last campaign transitioned, and the name of the previous group.
Public method | GetLastTransitionTimeAsync | Asynchronously requests for the last transition time.
Public method | GetResourceList | Retrieves the list of files present on the Central Campaign Server.
Public method | GetResourceListAsync | Asynchronously retrieves a list of files present on the Central Campaign Server.
Public method | GetSwitchoverPair | Retrieves the names of the master and the switchover ODS servers
Public method | GetSwitchoverPairAsync | Asynchronously retrieves the names of the master and the switchover CCS servers.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUDLContents | Retrieve the connection string from a UDL file.
Public method | GetUDLContentsAsync | Asynchronously retrieve the connection string froma UDL file.
Public method | ImportXML | Imports non-default Dialer objects from an XML string into the active configuration.
Public method | InitiateSwitchover | Initiates a Switchover.
Public method | InitiateSwitchoverAsync | Asynchronously requests a Switchover.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetCampaignServerParameters | Set Central Campaign server parameters
Public method | SetCampaignServerParametersAsync | Asynchronously Set Central Campaign server parameters
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransitionRuleGroup | Transition to a new Campaign Group in a sequence.
Public method | TransitionRuleGroupAsync | Asynchronously requests a transition to a new Campaign Group in a sequence. .
Public method | UploadFile | Uploads a file to the Central Campaign Server via the http server.
Public method | UploadFileAsync | Asynchronously uploads a file to the Central Campaign Server via the http server.

Properties

 | Name | Description
Public property | ConfigurationManager | The manager object that provides configuration and administration information for IC objects outside of Dialer.

Events

 | Name | Description
Public event | ActiveRuleGroupChanged | Fires an event when the active rule group is changed.
Public event | CampaignStatusChanged | Fires an event when a campaign's status changes.
Public event | OnCampaignServerConnectionStateChanged | Raises an event when campaign server connection state changes

See Also

DialerConfigurationManager Class


DialerConfigurationManager Constructor

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager Constructor
DialerConfigurationManager Class See Also Send Feedback
Constructs a new instance of the DialerConfigurationManager class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DialerConfigurationManager(
    Session session
)
Visual Basic
Public Sub New ( _
    session As Session _
)

Parameters

session
Type: Session
An active session object connected to an outbound dialing server.

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


DialerConfigurationManager Methods

[image] [image]

IceLib Dialer Technical Reference
DialerConfigurationManager Methods
DialerConfigurationManager Class See Also Send Feedback

The DialerConfigurationManager type exposes the following members.

Methods

 | Name | Description
Public method | CleanMetaDataTable | Causes the cleanup routine for Meta Data Tables to fire immediatly.
Public method | CleanMetaDataTableAsync | Asynchronously requests a transition to a new Campaign Group in a sequence. .
Public method | DeactivateCCSSwitchover | Deactivate Centeral Campaign Switchover.
Public method | DeactivateCCSSwitchoverAsync | Asynchronously deactivate Centeral Campaign Switchover.
Public method | DeleteCampaignServerParameters | Delete Central Campaign Server parameters
Public method | DeleteCampaignServerParametersAsync | Asynchronously delete Central Campaign Server parameters
Public method | DeleteOrphanScriptPages | Obsolete. a method that deletes script pages from the config that no longer are part of a base script configuration.
Public method | DownloadFile | Downloads a file from the Central Campaign Server via the http server.
Public method | DownloadFileAsync | Asynchronously downloads a file from the Central Campaign Server via the http server.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExportXML | Exports Dialer configuration objects as an XML string.
Protected method | Finalize | (Overrides Object..::..Finalize()()()().)
Public method | GetCampaignServerParameters | Gets a list of Central Campaign server parameters
Public method | GetCampaignServerParametersAsync | Asynchronously retrieves a list of Central Campaign server parameters
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHttpRequestKey(ConfigurationId) | (Deprecated) Gets the information necessary to send an http request to the Central Campaign Server. Requires the core Dialer config admin right.
Public method | GetHttpRequestKey(ConfigurationId, ServerType) | Gets the information necessary to send an http request to either the Central Campaign Server or the Outbound Dialing Server. Requires the core Dialer config admin right.
Public method | GetHttpRequestKeyAsync(ConfigurationId, EventHandler<(Of <<'(AsyncCompletedEventArgs<(Of <<'(HttpRequestKey>)>>)>)>>), Object) | (Deprecated)Asynchronously retrieves the information necessary to send an http request to the Central Campaign Server. Requires the core Dialer config admin right.
Public method | GetHttpRequestKeyAsync(ConfigurationId, ServerType, EventHandler<(Of <<'(AsyncCompletedEventArgs<(Of <<'(HttpRequestKey>)>>)>)>>), Object) | Asynchronously retrieves the information necessary to send an http request to either the Central Campaign Server or the Outbound Dialing server. Requires the core Dialer config admin right.
Public method | GetLastTransitionTime | Look up the time the last campaign transitioned, and the name of the previous group.
Public method | GetLastTransitionTimeAsync | Asynchronously requests for the last transition time.
Public method | GetResourceList | Retrieves the list of files present on the Central Campaign Server.
Public method | GetResourceListAsync | Asynchronously retrieves a list of files present on the Central Campaign Server.
Public method | GetSwitchoverPair | Retrieves the names of the master and the switchover ODS servers
Public method | GetSwitchoverPairAsync | Asynchronously retrieves the names of the master and the switchover CCS servers.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUDLContents | Retrieve the connection string from a UDL file.
Public method | GetUDLContentsAsync | Asynchronously retrieve the connection string froma UDL file.
Public method | ImportXML | Imports non-default Dialer objects from an XML string into the active configuration.
Public method | InitiateSwitchover | Initiates a Switchover.
Public method | InitiateSwitchoverAsync | Asynchronously requests a Switchover.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetCampaignServerParameters | Set Central Campaign server parameters
Public method | SetCampaignServerParametersAsync | Asynchronously Set Central Campaign server parameters
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | TransitionRuleGroup | Transition to a new Campaign Group in a sequence.
Public method | TransitionRuleGroupAsync | Asynchronously requests a transition to a new Campaign Group in a sequence. .
Public method | UploadFile | Uploads a file to the Central Campaign Server via the http server.
Public method | UploadFileAsync | Asynchronously uploads a file to the Central Campaign Server via the http server.

See Also

DialerConfigurationManager Class


CleanMetaDataTable Method

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..CleanMetaDataTable Method
DialerConfigurationManager Class See Also Send Feedback
Causes the cleanup routine for Meta Data Tables to fire immediatly.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool CleanMetaDataTable(
    ConfigurationId contactListId
)
Visual Basic
Public Function CleanMetaDataTable ( _
    contactListId As ConfigurationId _
) As Boolean

Parameters

contactListId
Type: ConfigurationId

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


CleanMetaDataTableAsync Method

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..CleanMetaDataTableAsync Method
DialerConfigurationManager Class See Also Send Feedback
Asynchronously requests a transition to a new Campaign Group in a sequence. .

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void CleanMetaDataTableAsync(
    ConfigurationId contactListId,
    EventHandler<AsyncCompletedEventArgs<bool>> callback,
    Object userState
)
Visual Basic
Public Sub CleanMetaDataTableAsync ( _
    contactListId As ConfigurationId, _
    callback As EventHandler(Of AsyncCompletedEventArgs(Of Boolean)), _
    userState As Object _
)

Parameters

contactListId
Type: ConfigurationId
The configuration id of the campaign you are working with.
callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Boolean>)>)>>)>)>
The event handler to call upon completion.
userState
Type: System..::..Object

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


DeactivateCCSSwitchover Method

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..DeactivateCCSSwitchover Method
DialerConfigurationManager Class See Also Send Feedback
Deactivate Centeral Campaign Switchover.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool DeactivateCCSSwitchover()
Visual Basic
Public Function DeactivateCCSSwitchover As Boolean

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


DeactivateCCSSwitchoverAsync Method

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..DeactivateCCSSwitchoverAsync Method
DialerConfigurationManager Class See Also Send Feedback
Asynchronously deactivate Centeral Campaign Switchover.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void DeactivateCCSSwitchoverAsync(
    EventHandler<AsyncCompletedEventArgs<bool>> callback,
    Object userState
)
Visual Basic
Public Sub DeactivateCCSSwitchoverAsync ( _
    callback As EventHandler(Of AsyncCompletedEventArgs(Of Boolean)), _
    userState As Object _
)

Parameters

callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Boolean>)>)>>)>)>
userState
Type: System..::..Object

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


DeleteCampaignServerParameters Method

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..DeleteCampaignServerParameters Method
DialerConfigurationManager Class See Also Send Feedback
Delete Central Campaign Server parameters

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool DeleteCampaignServerParameters(
    IEnumerable<string> serverParameters
)
Visual Basic
Public Function DeleteCampaignServerParameters ( _
    serverParameters As IEnumerable(Of String) _
) As Boolean

Parameters

serverParameters
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'String>)>)>
a collection containing server parameter names

Return Value

Success/Failure

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


DeleteCampaignServerParametersAsync Method

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..DeleteCampaignServerParametersAsync Method
DialerConfigurationManager Class See Also Send Feedback
Asynchronously delete Central Campaign Server parameters

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void DeleteCampaignServerParametersAsync(
    IEnumerable<string> serverParameters,
    EventHandler<AsyncCompletedEventArgs<bool>> callback,
    Object userState
)
Visual Basic
Public Sub DeleteCampaignServerParametersAsync ( _
    serverParameters As IEnumerable(Of String), _
    callback As EventHandler(Of AsyncCompletedEventArgs(Of Boolean)), _
    userState As Object _
)

Parameters

serverParameters
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'String>)>)>
a collection containing server parameter names
callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Boolean>)>)>>)>)>
userState
Type: System..::..Object

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


DeleteOrphanScriptPages Method

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..DeleteOrphanScriptPages Method
DialerConfigurationManager Class See Also Send Feedback
a method that deletes script pages from the config that no longer are part of a base script configuration.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
[ObsoleteAttribute("This function is no longer supported")]
public void DeleteOrphanScriptPages()
Visual Basic
<ObsoleteAttribute("This function is no longer supported")> _
Public Sub DeleteOrphanScriptPages

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


DownloadFile Method

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..DownloadFile Method
DialerConfigurationManager Class See Also Send Feedback
Downloads a file from the Central Campaign Server via the http server.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool DownloadFile(
    HttpRequestKey key,
    ResourceType resourceType,
    string filePath
)
Visual Basic
Public Function DownloadFile ( _
    key As HttpRequestKey, _
    resourceType As ResourceType, _
    filePath As String _
) As Boolean

Parameters

key
Type: ININ.IceLib.Configuration.Dialer..::..HttpRequestKey
The request key that grants access to the http server.
resourceType
Type: ININ.IceLib.Configuration.Dialer..::..ResourceType
type of file to upload (Wave, UDL or TimezoneMap)
filePath
Type: System..::..String
The name of the file to download.

Return Value

true if succeessful

Exceptions

Exception | Condition
System..::..Exception | Thrown when the file cannot be downloaded from the server

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


DownloadFileAsync Method

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..DownloadFileAsync Method
DialerConfigurationManager Class See Also Send Feedback
Asynchronously downloads a file from the Central Campaign Server via the http server.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void DownloadFileAsync(
    HttpRequestKey key,
    ResourceType resourceType,
    string filePath,
    EventHandler<AsyncCompletedEventArgs<bool>> completionCallback,
    Object state
)
Visual Basic
Public Sub DownloadFileAsync ( _
    key As HttpRequestKey, _
    resourceType As ResourceType, _
    filePath As String, _
    completionCallback As EventHandler(Of AsyncCompletedEventArgs(Of Boolean)), _
    state As Object _
)

Parameters

key
Type: ININ.IceLib.Configuration.Dialer..::..HttpRequestKey
The request key that grants access to the http server.
resourceType
Type: ININ.IceLib.Configuration.Dialer..::..ResourceType
type of file to download (Wave, UDL or TimezoneMap)
filePath
Type: System..::..String
The name of the file to download.
completionCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Boolean>)>)>>)>)>
The method to call upon completion.
state
Type: System..::..Object

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


ExportXML Method

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..ExportXML Method
DialerConfigurationManager Class See Also Send Feedback
Exports Dialer configuration objects as an XML string.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string ExportXML(
    IEnumerable<ListConfigurationObject> objectsToExport
)
Visual Basic
Public Function ExportXML ( _
    objectsToExport As IEnumerable(Of ListConfigurationObject) _
) As String

Parameters

objectsToExport
Type: System.Collections.Generic..::..IEnumerable<(Of <(<'ListConfigurationObject>)>)>
The list of Dialer objects to export as XML.

Return Value

Remarks

Any Dialer objects referenced by objectsToExport will also be exported. Non-Dialer objects (workgroups, attendant profiles, etc.) are not exported.

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


Finalize Method

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..Finalize Method
DialerConfigurationManager Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
protected override void Finalize()
Visual Basic
Protected Overrides Sub Finalize

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


GetCampaignServerParameters Method

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..GetCampaignServerParameters Method
DialerConfigurationManager Class See Also Send Feedback
Gets a list of Central Campaign server parameters

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<ParameterNameValue> GetCampaignServerParameters()
Visual Basic
Public Function GetCampaignServerParameters As Collection(Of ParameterNameValue)

Return Value

An array of ParameterNameValue

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


GetCampaignServerParametersAsync Method

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..GetCampaignServerParametersAsync Method
DialerConfigurationManager Class See Also Send Feedback
Asynchronously retrieves a list of Central Campaign server parameters

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void GetCampaignServerParametersAsync(
    EventHandler<AsyncCompletedEventArgs<Collection<ParameterNameValue>>> callback,
    Object userState
)
Visual Basic
Public Sub GetCampaignServerParametersAsync ( _
    callback As EventHandler(Of AsyncCompletedEventArgs(Of Collection(Of ParameterNameValue))), _
    userState As Object _
)

Parameters

callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Collection<(Of <(<' ParameterNameValue >)>)>>)>)>>)>)>
userState
Type: System..::..Object

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


GetHttpRequestKey Method

[image] [image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..GetHttpRequestKey Method
DialerConfigurationManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetHttpRequestKey(ConfigurationId) | (Deprecated) Gets the information necessary to send an http request to the Central Campaign Server. Requires the core Dialer config admin right.
Public method | GetHttpRequestKey(ConfigurationId, ServerType) | Gets the information necessary to send an http request to either the Central Campaign Server or the Outbound Dialing Server. Requires the core Dialer config admin right.

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


GetHttpRequestKey Method (ConfigurationId)

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..GetHttpRequestKey Method (ConfigurationId)
DialerConfigurationManager Class See Also Send Feedback
(Deprecated) Gets the information necessary to send an http request to the Central Campaign Server. Requires the core Dialer config admin right.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public HttpRequestKey GetHttpRequestKey(
    ConfigurationId id
)
Visual Basic
Public Function GetHttpRequestKey ( _
    id As ConfigurationId _
) As HttpRequestKey

Parameters

id
Type: ConfigurationId
The id of the object that will use this key (e.g. contact list for export/import operations). Use ConfigurationId.None for uploading miscellaneous files.

Return Value

An HttpRequestKey object.

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members
GetHttpRequestKey Overload


GetHttpRequestKey Method (ConfigurationId, ServerType)

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..GetHttpRequestKey Method (ConfigurationId, ServerType)
DialerConfigurationManager Class See Also Send Feedback
Gets the information necessary to send an http request to either the Central Campaign Server or the Outbound Dialing Server. Requires the core Dialer config admin right.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public HttpRequestKey GetHttpRequestKey(
    ConfigurationId id,
    ServerType serverType
)
Visual Basic
Public Function GetHttpRequestKey ( _
    id As ConfigurationId, _
    serverType As ServerType _
) As HttpRequestKey

Parameters

id
Type: ConfigurationId
The id of the object that will use this key (e.g. contact list for export/import operations). Use ConfigurationId.None for uploading miscellaneous files.
serverType
Type: ININ.IceLib.Configuration.Dialer..::..ServerType
the ServerType enum representing the server type.

Return Value

An HttpRequestKey object.

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members
GetHttpRequestKey Overload


GetHttpRequestKeyAsync Method

[image] [image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..GetHttpRequestKeyAsync Method
DialerConfigurationManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetHttpRequestKeyAsync(ConfigurationId, EventHandler<(Of <<'(AsyncCompletedEventArgs<(Of <<'(HttpRequestKey>)>>)>)>>), Object) | (Deprecated)Asynchronously retrieves the information necessary to send an http request to the Central Campaign Server. Requires the core Dialer config admin right.
Public method | GetHttpRequestKeyAsync(ConfigurationId, ServerType, EventHandler<(Of <<'(AsyncCompletedEventArgs<(Of <<'(HttpRequestKey>)>>)>)>>), Object) | Asynchronously retrieves the information necessary to send an http request to either the Central Campaign Server or the Outbound Dialing server. Requires the core Dialer config admin right.

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


GetHttpRequestKeyAsync Method (ConfigurationId, EventHandler(AsyncCompletedEventArgs`1(HttpRequestKey)), Object)

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..GetHttpRequestKeyAsync Method (ConfigurationId, EventHandler<(Of <(<'AsyncCompletedEventArgs`1<(Of <(<'HttpRequestKey>)>)>>)>)>, Object)
DialerConfigurationManager Class See Also Send Feedback
(Deprecated)Asynchronously retrieves the information necessary to send an http request to the Central Campaign Server. Requires the core Dialer config admin right.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void GetHttpRequestKeyAsync(
    ConfigurationId id,
    EventHandler<AsyncCompletedEventArgs<HttpRequestKey>> completionCallback,
    Object state
)
Visual Basic
Public Sub GetHttpRequestKeyAsync ( _
    id As ConfigurationId, _
    completionCallback As EventHandler(Of AsyncCompletedEventArgs(Of HttpRequestKey)), _
    state As Object _
)

Parameters

id
Type: ConfigurationId
The id of the object that will use this key (e.g. contact list for export/import operations). Use ConfigurationId.None for uploading miscellaneous files.
completionCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<' HttpRequestKey >)>)>>)>)>
The method to call upon completion.
state
Type: System..::..Object

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members
GetHttpRequestKeyAsync Overload


GetHttpRequestKeyAsync Method (ConfigurationId, ServerType, EventHandler(AsyncCompletedEventArgs`1(HttpRequestKey)), Object)

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..GetHttpRequestKeyAsync Method (ConfigurationId, ServerType, EventHandler<(Of <(<'AsyncCompletedEventArgs`1<(Of <(<'HttpRequestKey>)>)>>)>)>, Object)
DialerConfigurationManager Class See Also Send Feedback
Asynchronously retrieves the information necessary to send an http request to either the Central Campaign Server or the Outbound Dialing server. Requires the core Dialer config admin right.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void GetHttpRequestKeyAsync(
    ConfigurationId id,
    ServerType serverType,
    EventHandler<AsyncCompletedEventArgs<HttpRequestKey>> completionCallback,
    Object state
)
Visual Basic
Public Sub GetHttpRequestKeyAsync ( _
    id As ConfigurationId, _
    serverType As ServerType, _
    completionCallback As EventHandler(Of AsyncCompletedEventArgs(Of HttpRequestKey)), _
    state As Object _
)

Parameters

id
Type: ConfigurationId
The id of the object that will use this key (e.g. contact list for export/import operations). Use ConfigurationId.None for uploading miscellaneous files.
serverType
Type: ININ.IceLib.Configuration.Dialer..::..ServerType
the ServerType enum representing the server type.
completionCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<' HttpRequestKey >)>)>>)>)>
The method to call upon completion.
state
Type: System..::..Object

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members
GetHttpRequestKeyAsync Overload


GetLastTransitionTime Method

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..GetLastTransitionTime Method
DialerConfigurationManager Class See Also Send Feedback
Look up the time the last campaign transitioned, and the name of the previous group.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public LastTransitionData GetLastTransitionTime(
    ConfigurationId campaignId
)
Visual Basic
Public Function GetLastTransitionTime ( _
    campaignId As ConfigurationId _
) As LastTransitionData

Parameters

campaignId
Type: ConfigurationId

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


GetLastTransitionTimeAsync Method

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..GetLastTransitionTimeAsync Method
DialerConfigurationManager Class See Also Send Feedback
Asynchronously requests for the last transition time.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void GetLastTransitionTimeAsync(
    ConfigurationId campaignId,
    EventHandler<AsyncCompletedEventArgs<LastTransitionData>> callback,
    Object userState
)
Visual Basic
Public Sub GetLastTransitionTimeAsync ( _
    campaignId As ConfigurationId, _
    callback As EventHandler(Of AsyncCompletedEventArgs(Of LastTransitionData)), _
    userState As Object _
)

Parameters

campaignId
Type: ConfigurationId
The configuration id of the campaign you are working with.
callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<' LastTransitionData >)>)>>)>)>
The event handler to call upon completion.
userState
Type: System..::..Object

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


GetResourceList Method

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..GetResourceList Method
DialerConfigurationManager Class See Also Send Feedback
Retrieves the list of files present on the Central Campaign Server.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string[] GetResourceList(
    ResourceType resourceType
)
Visual Basic
Public Function GetResourceList ( _
    resourceType As ResourceType _
) As String()

Parameters

resourceType
Type: ININ.IceLib.Configuration.Dialer..::..ResourceType
type of file to upload (Wave, UDL or TimezoneMap)

Return Value

An array of strings.

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


GetResourceListAsync Method

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..GetResourceListAsync Method
DialerConfigurationManager Class See Also Send Feedback
Asynchronously retrieves a list of files present on the Central Campaign Server.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void GetResourceListAsync(
    ResourceType resourceType,
    EventHandler<AsyncCompletedEventArgs<string[]>> completionCallback,
    Object state
)
Visual Basic
Public Sub GetResourceListAsync ( _
    resourceType As ResourceType, _
    completionCallback As EventHandler(Of AsyncCompletedEventArgs(Of String())), _
    state As Object _
)

Parameters

resourceType
Type: ININ.IceLib.Configuration.Dialer..::..ResourceType
type of file to upload (Wave, UDL or TimezoneMap)
completionCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'array<String>[]()[][]>)>)>>)>)>
The method to call upon completion.
state
Type: System..::..Object

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


GetSwitchoverPair Method

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..GetSwitchoverPair Method
DialerConfigurationManager Class See Also Send Feedback
Retrieves the names of the master and the switchover ODS servers

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public SwitchoverPair GetSwitchoverPair(
    ServerType serverType
)
Visual Basic
Public Function GetSwitchoverPair ( _
    serverType As ServerType _
) As SwitchoverPair

Parameters

serverType
Type: ININ.IceLib.Configuration.Dialer..::..ServerType
Outbound Dialer or Central Campaign server

Return Value

A SwitchoverPair object

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


GetSwitchoverPairAsync Method

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..GetSwitchoverPairAsync Method
DialerConfigurationManager Class See Also Send Feedback
Asynchronously retrieves the names of the master and the switchover CCS servers.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void GetSwitchoverPairAsync(
    ServerType serverType,
    EventHandler<AsyncCompletedEventArgs<SwitchoverPair>> callback,
    Object userState
)
Visual Basic
Public Sub GetSwitchoverPairAsync ( _
    serverType As ServerType, _
    callback As EventHandler(Of AsyncCompletedEventArgs(Of SwitchoverPair)), _
    userState As Object _
)

Parameters

serverType
Type: ININ.IceLib.Configuration.Dialer..::..ServerType
Outbound Dialer or Central Campaign server
callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<' SwitchoverPair >)>)>>)>)>
userState
Type: System..::..Object

Return Value

A SwitchoverPair object

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


GetUDLContents Method

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..GetUDLContents Method
DialerConfigurationManager Class See Also Send Feedback
Retrieve the connection string from a UDL file.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string GetUDLContents(
    string udlFile
)
Visual Basic
Public Function GetUDLContents ( _
    udlFile As String _
) As String

Parameters

udlFile
Type: System..::..String
The name of the UDL file.

Return Value

A database connection string.

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


GetUDLContentsAsync Method

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..GetUDLContentsAsync Method
DialerConfigurationManager Class See Also Send Feedback
Asynchronously retrieve the connection string froma UDL file.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void GetUDLContentsAsync(
    string udlFile,
    EventHandler<AsyncCompletedEventArgs<string>> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetUDLContentsAsync ( _
    udlFile As String, _
    completedCallback As EventHandler(Of AsyncCompletedEventArgs(Of String)), _
    userState As Object _
)

Parameters

udlFile
Type: System..::..String
The name of the UDL file.
completedCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'String>)>)>>)>)>
The event handler to call upon completion.
userState
Type: System..::..Object

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


ImportXML Method

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..ImportXML Method
DialerConfigurationManager Class See Also Send Feedback
Imports non-default Dialer objects from an XML string into the active configuration.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void ImportXML(
    string xml
)
Visual Basic
Public Sub ImportXML ( _
    xml As String _
)

Parameters

xml
Type: System..::..String
XML obtained from a call to ExportXML(IEnumerable<(Of <<'(ListConfigurationObject>)>>))

Remarks

Only XML obtained from ExportXML(IEnumerable<(Of <<'(ListConfigurationObject>)>>)) may be used.

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


InitiateSwitchover Method

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..InitiateSwitchover Method
DialerConfigurationManager Class See Also Send Feedback
Initiates a Switchover.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool InitiateSwitchover(
    ServerType serverType
)
Visual Basic
Public Function InitiateSwitchover ( _
    serverType As ServerType _
) As Boolean

Parameters

serverType
Type: ININ.IceLib.Configuration.Dialer..::..ServerType
Outbound Dialer or Central Campaign server

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


InitiateSwitchoverAsync Method

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..InitiateSwitchoverAsync Method
DialerConfigurationManager Class See Also Send Feedback
Asynchronously requests a Switchover.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void InitiateSwitchoverAsync(
    ServerType serverType,
    EventHandler<AsyncCompletedEventArgs<bool>> callback,
    Object userState
)
Visual Basic
Public Sub InitiateSwitchoverAsync ( _
    serverType As ServerType, _
    callback As EventHandler(Of AsyncCompletedEventArgs(Of Boolean)), _
    userState As Object _
)

Parameters

serverType
Type: ININ.IceLib.Configuration.Dialer..::..ServerType
Outbound Dialer or Central Campaign server
callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Boolean>)>)>>)>)>
userState
Type: System..::..Object

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


SetCampaignServerParameters Method

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..SetCampaignServerParameters Method
DialerConfigurationManager Class See Also Send Feedback
Set Central Campaign server parameters

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool SetCampaignServerParameters(
    IEnumerable<ParameterNameValue> serverParameters
)
Visual Basic
Public Function SetCampaignServerParameters ( _
    serverParameters As IEnumerable(Of ParameterNameValue) _
) As Boolean

Parameters

serverParameters
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' ParameterNameValue >)>)>
a collection of ParameterNameValue containing the parameter name and value

Return Value

Success/Failure

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


SetCampaignServerParametersAsync Method

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..SetCampaignServerParametersAsync Method
DialerConfigurationManager Class See Also Send Feedback
Asynchronously Set Central Campaign server parameters

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void SetCampaignServerParametersAsync(
    IEnumerable<ParameterNameValue> serverParameters,
    EventHandler<AsyncCompletedEventArgs<bool>> callback,
    Object userState
)
Visual Basic
Public Sub SetCampaignServerParametersAsync ( _
    serverParameters As IEnumerable(Of ParameterNameValue), _
    callback As EventHandler(Of AsyncCompletedEventArgs(Of Boolean)), _
    userState As Object _
)

Parameters

serverParameters
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' ParameterNameValue >)>)>
a collection of ParameterNameValue containing the parameter name and value
callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Boolean>)>)>>)>)>
userState
Type: System..::..Object

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


TransitionRuleGroup Method

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..TransitionRuleGroup Method
DialerConfigurationManager Class See Also Send Feedback
Transition to a new Campaign Group in a sequence.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool TransitionRuleGroup(
    ConfigurationId campaignId,
    string campaignGroupName
)
Visual Basic
Public Function TransitionRuleGroup ( _
    campaignId As ConfigurationId, _
    campaignGroupName As String _
) As Boolean

Parameters

campaignId
Type: ConfigurationId
campaignGroupName
Type: System..::..String

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


TransitionRuleGroupAsync Method

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..TransitionRuleGroupAsync Method
DialerConfigurationManager Class See Also Send Feedback
Asynchronously requests a transition to a new Campaign Group in a sequence. .

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void TransitionRuleGroupAsync(
    ConfigurationId campaignId,
    string campaignGroupName,
    EventHandler<AsyncCompletedEventArgs<bool>> callback,
    Object userState
)
Visual Basic
Public Sub TransitionRuleGroupAsync ( _
    campaignId As ConfigurationId, _
    campaignGroupName As String, _
    callback As EventHandler(Of AsyncCompletedEventArgs(Of Boolean)), _
    userState As Object _
)

Parameters

campaignId
Type: ConfigurationId
The configuration id of the campaign you are working with.
campaignGroupName
Type: System..::..String
The display name of the group you wish to transition to.
callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Boolean>)>)>>)>)>
The event handler to call upon completion.
userState
Type: System..::..Object

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


UploadFile Method

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..UploadFile Method
DialerConfigurationManager Class See Also Send Feedback
Uploads a file to the Central Campaign Server via the http server.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool UploadFile(
    HttpRequestKey key,
    ResourceType resourceType,
    string filePath
)
Visual Basic
Public Function UploadFile ( _
    key As HttpRequestKey, _
    resourceType As ResourceType, _
    filePath As String _
) As Boolean

Parameters

key
Type: ININ.IceLib.Configuration.Dialer..::..HttpRequestKey
The request key that grants access to the http server.
resourceType
Type: ININ.IceLib.Configuration.Dialer..::..ResourceType
type of file to upload (Wave, UDL or TimezoneMap)
filePath
Type: System..::..String
The full path to the file to upload.

Return Value

true if succeessful

Exceptions

Exception | Condition
System..::..Exception | Thrown when the file cannot be downloaded from the server

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


UploadFileAsync Method

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..UploadFileAsync Method
DialerConfigurationManager Class See Also Send Feedback
Asynchronously uploads a file to the Central Campaign Server via the http server.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void UploadFileAsync(
    HttpRequestKey key,
    ResourceType resourceType,
    string filePath,
    EventHandler<AsyncCompletedEventArgs<bool>> completionCallback,
    Object state
)
Visual Basic
Public Sub UploadFileAsync ( _
    key As HttpRequestKey, _
    resourceType As ResourceType, _
    filePath As String, _
    completionCallback As EventHandler(Of AsyncCompletedEventArgs(Of Boolean)), _
    state As Object _
)

Parameters

key
Type: ININ.IceLib.Configuration.Dialer..::..HttpRequestKey
The request key that grants access to the http server.
resourceType
Type: ININ.IceLib.Configuration.Dialer..::..ResourceType
type of file to upload (Wave, UDL or TimezoneMap)
filePath
Type: System..::..String
The full path to the file to upload.
completionCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Boolean>)>)>>)>)>
The method to call upon completion.
state
Type: System..::..Object

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


DialerConfigurationManager Properties

[image] [image]

IceLib Dialer Technical Reference
DialerConfigurationManager Properties
DialerConfigurationManager Class See Also Send Feedback

The DialerConfigurationManager type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | The manager object that provides configuration and administration information for IC objects outside of Dialer.

See Also

DialerConfigurationManager Class


ConfigurationManager Property

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..ConfigurationManager Property
DialerConfigurationManager Class See Also Send Feedback
The manager object that provides configuration and administration information for IC objects outside of Dialer.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ConfigurationManager ConfigurationManager { get; private set; }
Visual Basic
Public Property ConfigurationManager As ConfigurationManager
    Get
    Private Set

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


DialerConfigurationManager Events

[image] [image]

IceLib Dialer Technical Reference
DialerConfigurationManager Events
DialerConfigurationManager Class See Also Send Feedback

The DialerConfigurationManager type exposes the following members.

Events

 | Name | Description
Public event | ActiveRuleGroupChanged | Fires an event when the active rule group is changed.
Public event | CampaignStatusChanged | Fires an event when a campaign's status changes.
Public event | OnCampaignServerConnectionStateChanged | Raises an event when campaign server connection state changes

See Also

DialerConfigurationManager Class


ActiveRuleGroupChanged Event

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..ActiveRuleGroupChanged Event
DialerConfigurationManager Class See Also Send Feedback
Fires an event when the active rule group is changed.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public event EventHandler<ActiveRuleGroupChangedEventEventArgs> ActiveRuleGroupChanged
Visual Basic
Public Event ActiveRuleGroupChanged As EventHandler(Of ActiveRuleGroupChangedEventEventArgs)

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


CampaignStatusChanged Event

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..CampaignStatusChanged Event
DialerConfigurationManager Class See Also Send Feedback
Fires an event when a campaign's status changes.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public event EventHandler<CampaignStatusChangedEventArgs> CampaignStatusChanged
Visual Basic
Public Event CampaignStatusChanged As EventHandler(Of CampaignStatusChangedEventArgs)

Remarks

This event differs from the CampaignStarted and CampaignStopped events in that it provides full details of the campaign's status and does not require an active dialing session.

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


OnCampaignServerConnectionStateChanged Event

[image]

IceLib Dialer Technical Reference
DialerConfigurationManager..::..OnCampaignServerConnectionStateChanged Event
DialerConfigurationManager Class See Also Send Feedback
Raises an event when campaign server connection state changes

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public event EventHandler<CampaignServerConnectionStateEventArgs> OnCampaignServerConnectionStateChanged
Visual Basic
Public Event OnCampaignServerConnectionStateChanged As EventHandler(Of CampaignServerConnectionStateEventArgs)

See Also

DialerConfigurationManager Class
DialerConfigurationManager Members


DialerConnectionState Enumeration

[image]

IceLib Dialer Technical Reference
DialerConnectionState Enumeration
See Also Send Feedback
Campaign Server connection state

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum DialerConnectionState
Visual Basic
Public Enumeration DialerConnectionState

Members

Member name | Value | Description
Up | 0 | Connection Up
Down | 1 | Connection Down

See Also


DialerSkill Class

[image]

IceLib Dialer Technical Reference
DialerSkill Class
Members See Also Send Feedback
An skill held by an agent in a Dialer campaign.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class DialerSkill
Visual Basic
Public Class DialerSkill

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..DialerSkill

See Also

DialerSkill Members


DialerSkill Members

[image] [image]

IceLib Dialer Technical Reference
DialerSkill Members
DialerSkill Class Constructors Methods Properties See Also Send Feedback

The DialerSkill type exposes the following members.

Constructors

 | Name | Description
Public method | DialerSkill(String) | Creates a new instance of the DialerSkill class.
Public method | DialerSkill(String, String) | Creates a new instance of the DialerSkill class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | The ID of the object.
Public property | Ratio | The number of calls placed for this skill in relation to other skills in the skill set.
Public property | Value | The value in the contact record that indicates that the call must be handled by an agent with this skill.

See Also

DialerSkill Class


DialerSkill Constructor

[image] [image]

IceLib Dialer Technical Reference
DialerSkill Constructor
DialerSkill Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DialerSkill(String) | Creates a new instance of the DialerSkill class.
Public method | DialerSkill(String, String) | Creates a new instance of the DialerSkill class.

See Also

DialerSkill Class
DialerSkill Members


DialerSkill Constructor (String)

[image]

IceLib Dialer Technical Reference
DialerSkill Constructor (String)
DialerSkill Class See Also Send Feedback
Creates a new instance of the DialerSkill class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DialerSkill(
    string id
)
Visual Basic
Public Sub New ( _
    id As String _
)

Parameters

id
Type: System..::..String
The ID of this object

See Also

DialerSkill Class
DialerSkill Members
DialerSkill Overload


DialerSkill Constructor (String, String)

[image]

IceLib Dialer Technical Reference
DialerSkill Constructor (String, String)
DialerSkill Class See Also Send Feedback
Creates a new instance of the DialerSkill class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DialerSkill(
    string id,
    string displayName
)
Visual Basic
Public Sub New ( _
    id As String, _
    displayName As String _
)

Parameters

id
Type: System..::..String
the ID of this object.
displayName
Type: System..::..String
The user-friendly name of this object.

See Also

DialerSkill Class
DialerSkill Members
DialerSkill Overload


DialerSkill Methods

[image] [image]

IceLib Dialer Technical Reference
DialerSkill Methods
DialerSkill Class See Also Send Feedback

The DialerSkill type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DialerSkill Class


DialerSkill Properties

[image] [image]

IceLib Dialer Technical Reference
DialerSkill Properties
DialerSkill Class See Also Send Feedback

The DialerSkill type exposes the following members.

Properties

 | Name | Description
Public property | Id | The ID of the object.
Public property | Ratio | The number of calls placed for this skill in relation to other skills in the skill set.
Public property | Value | The value in the contact record that indicates that the call must be handled by an agent with this skill.

See Also

DialerSkill Class


Id Property

[image]

IceLib Dialer Technical Reference
DialerSkill..::..Id Property
DialerSkill Class See Also Send Feedback
The ID of the object.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ConfigurationId Id { get; private set; }
Visual Basic
Public Property Id As ConfigurationId
    Get
    Private Set

See Also

DialerSkill Class
DialerSkill Members


Ratio Property

[image]

IceLib Dialer Technical Reference
DialerSkill..::..Ratio Property
DialerSkill Class See Also Send Feedback
The number of calls placed for this skill in relation to other skills in the skill set.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int Ratio { get; set; }
Visual Basic
Public Property Ratio As Integer
    Get
    Set

See Also

DialerSkill Class
DialerSkill Members


Value Property

[image]

IceLib Dialer Technical Reference
DialerSkill..::..Value Property
DialerSkill Class See Also Send Feedback
The value in the contact record that indicates that the call must be handled by an agent with this skill.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Value { get; set; }
Visual Basic
Public Property Value As String
    Get
    Set

See Also

DialerSkill Class
DialerSkill Members
SkillSetConfiguration..::..ColumnName


DispositionBehavior Class

[image]

IceLib Dialer Technical Reference
DispositionBehavior Class
Members See Also Send Feedback
A PolicyBehavior which dispositions the call.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class DispositionBehavior : PolicyBehavior
Visual Basic
Public NotInheritable Class DispositionBehavior _
    Inherits PolicyBehavior

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyBehavior
ININ.IceLib.Configuration.Dialer..::..DispositionBehavior

See Also

DispositionBehavior Members


DispositionBehavior Members

[image] [image]

IceLib Dialer Technical Reference
DispositionBehavior Members
DispositionBehavior Class Constructors Methods Properties See Also Send Feedback

The DispositionBehavior type exposes the following members.

Constructors

 | Name | Description
Public method | DispositionBehavior | Initializes a new instance of the DispositionBehavior class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Abandon | Get or set whether this disposition will count as an abandon.
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | Id | (Inherited from PolicyBehavior.)
Public property | WrapUpCategory | Get or set the reason code that this behavior will set.
Public property | WrapUpCode | Get or set the finish code that this behavior will set.

See Also

DispositionBehavior Class


DispositionBehavior Constructor

[image]

IceLib Dialer Technical Reference
DispositionBehavior Constructor
DispositionBehavior Class See Also Send Feedback
Initializes a new instance of the DispositionBehavior class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DispositionBehavior()
Visual Basic
Public Sub New

See Also

DispositionBehavior Class
DispositionBehavior Members


DispositionBehavior Methods

[image] [image]

IceLib Dialer Technical Reference
DispositionBehavior Methods
DispositionBehavior Class See Also Send Feedback

The DispositionBehavior type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DispositionBehavior Class


DispositionBehavior Properties

[image] [image]

IceLib Dialer Technical Reference
DispositionBehavior Properties
DispositionBehavior Class See Also Send Feedback

The DispositionBehavior type exposes the following members.

Properties

 | Name | Description
Public property | Abandon | Get or set whether this disposition will count as an abandon.
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | Id | (Inherited from PolicyBehavior.)
Public property | WrapUpCategory | Get or set the reason code that this behavior will set.
Public property | WrapUpCode | Get or set the finish code that this behavior will set.

See Also

DispositionBehavior Class


Abandon Property

[image]

IceLib Dialer Technical Reference
DispositionBehavior..::..Abandon Property
DispositionBehavior Class See Also Send Feedback
Get or set whether this disposition will count as an abandon.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public AbandonControl Abandon { get; set; }
Visual Basic
Public Property Abandon As AbandonControl
    Get
    Set

See Also

DispositionBehavior Class
DispositionBehavior Members


WrapUpCategory Property

[image]

IceLib Dialer Technical Reference
DispositionBehavior..::..WrapUpCategory Property
DispositionBehavior Class See Also Send Feedback
Get or set the reason code that this behavior will set.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string WrapUpCategory { get; set; }
Visual Basic
Public Property WrapUpCategory As String
    Get
    Set

See Also

DispositionBehavior Class
DispositionBehavior Members


WrapUpCode Property

[image]

IceLib Dialer Technical Reference
DispositionBehavior..::..WrapUpCode Property
DispositionBehavior Class See Also Send Feedback
Get or set the finish code that this behavior will set.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string WrapUpCode { get; set; }
Visual Basic
Public Property WrapUpCode As String
    Get
    Set

See Also

DispositionBehavior Class
DispositionBehavior Members


DispositionCondition Class

[image]

IceLib Dialer Technical Reference
DispositionCondition Class
Members See Also Send Feedback
A policy condition that checks if the call's disposition is contained within a desired subset of dispositions.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class DispositionCondition : PolicyCondition
Visual Basic
Public NotInheritable Class DispositionCondition _
    Inherits PolicyCondition

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyCondition
ININ.IceLib.Configuration.Dialer..::..DispositionCondition

See Also

DispositionCondition Members


DispositionCondition Members

[image] [image]

IceLib Dialer Technical Reference
DispositionCondition Members
DispositionCondition Class Constructors Methods Properties See Also Send Feedback

The DispositionCondition type exposes the following members.

Constructors

 | Name | Description
Public method | DispositionCondition | Creates a new instance of the DispositionCondition class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConditionType | The type of condition. (Inherited from PolicyCondition.)
Public property | Dispositions | The desired subset of call dispositions.
Public property | Id | The Id of the condition. (Inherited from PolicyCondition.)
Public property | Negated | When true, the logical result of the condition evaluation is flipped. (Inherited from PolicyCondition.)

See Also

DispositionCondition Class


DispositionCondition Constructor

[image]

IceLib Dialer Technical Reference
DispositionCondition Constructor
DispositionCondition Class See Also Send Feedback
Creates a new instance of the DispositionCondition class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DispositionCondition()
Visual Basic
Public Sub New

See Also

DispositionCondition Class
DispositionCondition Members


DispositionCondition Methods

[image] [image]

IceLib Dialer Technical Reference
DispositionCondition Methods
DispositionCondition Class See Also Send Feedback

The DispositionCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DispositionCondition Class


DispositionCondition Properties

[image] [image]

IceLib Dialer Technical Reference
DispositionCondition Properties
DispositionCondition Class See Also Send Feedback

The DispositionCondition type exposes the following members.

Properties

 | Name | Description
Public property | ConditionType | The type of condition. (Inherited from PolicyCondition.)
Public property | Dispositions | The desired subset of call dispositions.
Public property | Id | The Id of the condition. (Inherited from PolicyCondition.)
Public property | Negated | When true, the logical result of the condition evaluation is flipped. (Inherited from PolicyCondition.)

See Also

DispositionCondition Class


Dispositions Property

[image]

IceLib Dialer Technical Reference
DispositionCondition..::..Dispositions Property
DispositionCondition Class See Also Send Feedback
The desired subset of call dispositions.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<BaseScriptDisposition> Dispositions { get; }
Visual Basic
Public ReadOnly Property Dispositions As Collection(Of BaseScriptDisposition)
    Get

See Also

DispositionCondition Class
DispositionCondition Members


DNCRecord Class

[image]

IceLib Dialer Technical Reference
DNCRecord Class
Members See Also Send Feedback
A class containing the information necessary to call one of the AddEntryToDNCTable functions in the DNCUpdate class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class DNCRecord
Visual Basic
Public Class DNCRecord

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..DNCRecord

See Also

DNCRecord Members


DNCRecord Members

[image] [image]

IceLib Dialer Technical Reference
DNCRecord Members
DNCRecord Class Constructors Methods Properties See Also Send Feedback

The DNCRecord type exposes the following members.

Constructors

 | Name | Description
Public method | DNCRecord()()()() | Constructs a DNC Record to be passed into one of the AddEntryToDNCTable functions. Prior to calling a DNCUpdate function, at least one of either the PhoneNumber or ExclusionIdentifier must be defined. DateTimeOffsetBeforeNextDial is optional.
Public method | DNCRecord(String) | Constructs a DNC Record to be passed into one of the AddEntryToDNCTable functions. The phone number will not be dialed in the future by a campaign referencing the DNC table.
Public method | DNCRecord(String, String) | Constructs a DNC Record to be passed into one of the AddEntryToDNCTable functions. The combination of the phone number/exclusion identifier will not be dialed in the future by a campaign referencing the DNC table.
Public method | DNCRecord(String, String, TimeSpan) | Constructs a DNC Record to be passed into one of the AddEntryToDNCTable functions. The combination of the phone number/exclusion identifier will not be dialed for the length of time passed into the dateTimeOffsetBeforeNextDial parameter. At least one of either the phoneNumber or exclusionIdentifier parameters are required and the dateTimeOffsetBeforeNextDial parameter is optional.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DateTimeOffsetBeforeNextDial | The amount of time in the future that the DNC record will be excluded from dialing.
Public property | ExclusionIdentifier | The Exclusion Identifier to add to the DNC table. This typically would be a value that would match up with a Call List column entry to exclude a record at that level, instead of the Phone Number level.
Public property | PhoneNumber | The phone number to add to the DNC table.

See Also

DNCRecord Class


DNCRecord Constructor

[image] [image]

IceLib Dialer Technical Reference
DNCRecord Constructor
DNCRecord Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DNCRecord()()()() | Constructs a DNC Record to be passed into one of the AddEntryToDNCTable functions. Prior to calling a DNCUpdate function, at least one of either the PhoneNumber or ExclusionIdentifier must be defined. DateTimeOffsetBeforeNextDial is optional.
Public method | DNCRecord(String) | Constructs a DNC Record to be passed into one of the AddEntryToDNCTable functions. The phone number will not be dialed in the future by a campaign referencing the DNC table.
Public method | DNCRecord(String, String) | Constructs a DNC Record to be passed into one of the AddEntryToDNCTable functions. The combination of the phone number/exclusion identifier will not be dialed in the future by a campaign referencing the DNC table.
Public method | DNCRecord(String, String, TimeSpan) | Constructs a DNC Record to be passed into one of the AddEntryToDNCTable functions. The combination of the phone number/exclusion identifier will not be dialed for the length of time passed into the dateTimeOffsetBeforeNextDial parameter. At least one of either the phoneNumber or exclusionIdentifier parameters are required and the dateTimeOffsetBeforeNextDial parameter is optional.

See Also

DNCRecord Class
DNCRecord Members


DNCRecord Constructor

[image]

IceLib Dialer Technical Reference
DNCRecord Constructor
DNCRecord Class See Also Send Feedback
Constructs a DNC Record to be passed into one of the AddEntryToDNCTable functions. Prior to calling a DNCUpdate function, at least one of either the PhoneNumber or ExclusionIdentifier must be defined. DateTimeOffsetBeforeNextDial is optional.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DNCRecord()
Visual Basic
Public Sub New

See Also

DNCRecord Class
DNCRecord Members
DNCRecord Overload


DNCRecord Constructor (String)

[image]

IceLib Dialer Technical Reference
DNCRecord Constructor (String)
DNCRecord Class See Also Send Feedback
Constructs a DNC Record to be passed into one of the AddEntryToDNCTable functions. The phone number will not be dialed in the future by a campaign referencing the DNC table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DNCRecord(
    string phoneNumber
)
Visual Basic
Public Sub New ( _
    phoneNumber As String _
)

Parameters

phoneNumber
Type: System..::..String
The phone number to add to the DNC table.

See Also

DNCRecord Class
DNCRecord Members
DNCRecord Overload


DNCRecord Constructor (String, String)

[image]

IceLib Dialer Technical Reference
DNCRecord Constructor (String, String)
DNCRecord Class See Also Send Feedback
Constructs a DNC Record to be passed into one of the AddEntryToDNCTable functions. The combination of the phone number/exclusion identifier will not be dialed in the future by a campaign referencing the DNC table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DNCRecord(
    string phoneNumber,
    string exclusionIdentifier
)
Visual Basic
Public Sub New ( _
    phoneNumber As String, _
    exclusionIdentifier As String _
)

Parameters

phoneNumber
Type: System..::..String
The phone number to add to the DNC table.
exclusionIdentifier
Type: System..::..String
The identifier to add to the DNC table. This field is meant to be used to identify the record at the account level, as opposed to the Phone Number level. When mixed, the DNC will apply to the combination of the account and phone number.

See Also

DNCRecord Class
DNCRecord Members
DNCRecord Overload


DNCRecord Constructor (String, String, TimeSpan)

[image]

IceLib Dialer Technical Reference
DNCRecord Constructor (String, String, TimeSpan)
DNCRecord Class See Also Send Feedback
Constructs a DNC Record to be passed into one of the AddEntryToDNCTable functions. The combination of the phone number/exclusion identifier will not be dialed for the length of time passed into the dateTimeOffsetBeforeNextDial parameter. At least one of either the phoneNumber or exclusionIdentifier parameters are required and the dateTimeOffsetBeforeNextDial parameter is optional.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DNCRecord(
    string phoneNumber,
    string exclusionIdentifier,
    TimeSpan dateTimeOffsetBeforeNextDial
)
Visual Basic
Public Sub New ( _
    phoneNumber As String, _
    exclusionIdentifier As String, _
    dateTimeOffsetBeforeNextDial As TimeSpan _
)

Parameters

phoneNumber
Type: System..::..String
The phone number to add to the DNC table.
exclusionIdentifier
Type: System..::..String
The identifier to add to the DNC table. This field is meant to be used to identify the record at the account level, as opposed to the Phone Number level. When mixed, the DNC will apply to the combination of the account and phone number.
dateTimeOffsetBeforeNextDial
Type: System..::..TimeSpan
The amount of time in the future before the associated phone/account numbers may be dialed.

See Also

DNCRecord Class
DNCRecord Members
DNCRecord Overload


DNCRecord Methods

[image] [image]

IceLib Dialer Technical Reference
DNCRecord Methods
DNCRecord Class See Also Send Feedback

The DNCRecord type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DNCRecord Class


DNCRecord Properties

[image] [image]

IceLib Dialer Technical Reference
DNCRecord Properties
DNCRecord Class See Also Send Feedback

The DNCRecord type exposes the following members.

Properties

 | Name | Description
Public property | DateTimeOffsetBeforeNextDial | The amount of time in the future that the DNC record will be excluded from dialing.
Public property | ExclusionIdentifier | The Exclusion Identifier to add to the DNC table. This typically would be a value that would match up with a Call List column entry to exclude a record at that level, instead of the Phone Number level.
Public property | PhoneNumber | The phone number to add to the DNC table.

See Also

DNCRecord Class


DateTimeOffsetBeforeNextDial Property

[image]

IceLib Dialer Technical Reference
DNCRecord..::..DateTimeOffsetBeforeNextDial Property
DNCRecord Class See Also Send Feedback
The amount of time in the future that the DNC record will be excluded from dialing.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public TimeSpan DateTimeOffsetBeforeNextDial { get; set; }
Visual Basic
Public Property DateTimeOffsetBeforeNextDial As TimeSpan
    Get
    Set

See Also

DNCRecord Class
DNCRecord Members


ExclusionIdentifier Property

[image]

IceLib Dialer Technical Reference
DNCRecord..::..ExclusionIdentifier Property
DNCRecord Class See Also Send Feedback
The Exclusion Identifier to add to the DNC table. This typically would be a value that would match up with a Call List column entry to exclude a record at that level, instead of the Phone Number level.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string ExclusionIdentifier { get; set; }
Visual Basic
Public Property ExclusionIdentifier As String
    Get
    Set

See Also

DNCRecord Class
DNCRecord Members


PhoneNumber Property

[image]

IceLib Dialer Technical Reference
DNCRecord..::..PhoneNumber Property
DNCRecord Class See Also Send Feedback
The phone number to add to the DNC table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string PhoneNumber { get; set; }
Visual Basic
Public Property PhoneNumber As String
    Get
    Set

See Also

DNCRecord Class
DNCRecord Members


DNCSourceConfiguration Class

[image]

IceLib Dialer Technical Reference
DNCSourceConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for a do-not-call source configuration object.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class DNCSourceConfiguration : EditableListConfigurationObject<DNCSourceConfiguration..::..Property>,
    IExportable
Visual Basic
Public Class DNCSourceConfiguration _
    Inherits EditableListConfigurationObject(Of DNCSourceConfiguration..::..Property) _
    Implements IExportable

Inheritance Hierarchy

System..::..Object
ConfigurationObject
ListConfigurationObject
EditableListConfigurationObject<(Of <(<' DNCSourceConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..DNCSourceConfiguration

See Also

DNCSourceConfiguration Members


DNCSourceConfiguration Members

[image] [image]

IceLib Dialer Technical Reference
DNCSourceConfiguration Members
DNCSourceConfiguration Class Methods Properties See Also Send Feedback

The DNCSourceConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' DNCSourceConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' DNCSourceConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' DNCSourceConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' DNCSourceConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' DNCSourceConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDNCCampaignsAsync | Asynchronously retrieves a list of campaigns from DNC.Com
Public method | GetDNCdotCOMCampaigns | Gets a list of campaigns from DNC.Com
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' DNCSourceConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' DNCSourceConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' DNCSourceConfiguration..::..Property >)>)>.)
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' DNCSourceConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' DNCSourceConfiguration..::..Property >)>)>.)
Public method | ToString | (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | AccountCode | The account code provided by DNC.com
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' DNCSourceConfiguration..::..Property >)>)>.)
Public property | ColumnName | The name of the column in the custom database table containing do-not-call numbers. Used only in custom DNC sources.
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | ConnectionId | The ID of the Dialer database connection containing the do-not-call table. Used only in custom DNC sources.
Public property | DialUnscrubbed | When using DNC.com for scrubbing, this specifices whether to continue dialing even if scrubbing is unable to complete.
Public property | DNCCampaignId | The ID of the DNC.com campaign to use for scrubbing numbers.
Public property | DNCCampaignName | The name of the DNC.com campaign to use for scrubbing numbers.
Public property | ExclusionIdColumnName | The name of the column in the custom database table containing an exclusion id that relates to do-not-call numbers. Used only in custom DNC sources.
Public property | ExpirationColumnName | The name of the column in the custom database table containing do-not-call expiration. Used only in custom DNC sources.
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsExporting | Tells whether the current object is being used for exporting
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | LoginId | The login ID provided by DNC.com
Public property | MarkWirelessAsUncallable | When using DNC.com for scrubbing, this specifies whether to block calls to wireless numbers.
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | ProjectId | The ID of the DNC.com project to pull scrub settings from.
Public property | RevisionLevel | The current version number of this object.
Public property | SourceType | The type of DNC source type. Use 0 for DNC.com and 1 for custom DNC source.
Public property | TableName | The name of the database table containing do-not-call numbers. Used only by custom DNC sources.
Public property | UseDialPlan | Specifies whether to run phone numbers through the dial plan before scrubbing.
Public property | UseSecureServer | Specifies whether to use HTTPS in the url for the DNC Source.

See Also

DNCSourceConfiguration Class


DNCSourceConfiguration Methods

[image] [image]

IceLib Dialer Technical Reference
DNCSourceConfiguration Methods
DNCSourceConfiguration Class See Also Send Feedback

The DNCSourceConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' DNCSourceConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' DNCSourceConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' DNCSourceConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' DNCSourceConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' DNCSourceConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDNCCampaignsAsync | Asynchronously retrieves a list of campaigns from DNC.Com
Public method | GetDNCdotCOMCampaigns | Gets a list of campaigns from DNC.Com
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' DNCSourceConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' DNCSourceConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' DNCSourceConfiguration..::..Property >)>)>.)
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' DNCSourceConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' DNCSourceConfiguration..::..Property >)>)>.)
Public method | ToString | (Inherited from ConfigurationObject.)

See Also

DNCSourceConfiguration Class


GetDNCCampaignsAsync Method

[image]

IceLib Dialer Technical Reference
DNCSourceConfiguration..::..GetDNCCampaignsAsync Method
DNCSourceConfiguration Class See Also Send Feedback
Asynchronously retrieves a list of campaigns from DNC.Com

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void GetDNCCampaignsAsync(
    string accountCode,
    string loginId,
    string projectId,
    EventHandler<AsyncCompletedEventArgs<DNCSourceCampaign[]>> completionCallback,
    Object state
)
Visual Basic
Public Sub GetDNCCampaignsAsync ( _
    accountCode As String, _
    loginId As String, _
    projectId As String, _
    completionCallback As EventHandler(Of AsyncCompletedEventArgs(Of DNCSourceCampaign())), _
    state As Object _
)

Parameters

accountCode
Type: System..::..String
The account code for DNC.Com authentication
loginId
Type: System..::..String
The login Id to use for for DNC.Com authentication
projectId
Type: System..::..String
The project Id to lookup when querying DNC.Com
completionCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'array< DNCSourceCampaign >[]()[][]>)>)>>)>)>
state
Type: System..::..Object

See Also

DNCSourceConfiguration Class
DNCSourceConfiguration Members


GetDNCdotCOMCampaigns Method

[image]

IceLib Dialer Technical Reference
DNCSourceConfiguration..::..GetDNCdotCOMCampaigns Method
DNCSourceConfiguration Class See Also Send Feedback
Gets a list of campaigns from DNC.Com

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DNCSourceCampaign[] GetDNCdotCOMCampaigns(
    string accountCode,
    string loginId,
    string projectId
)
Visual Basic
Public Function GetDNCdotCOMCampaigns ( _
    accountCode As String, _
    loginId As String, _
    projectId As String _
) As DNCSourceCampaign()

Parameters

accountCode
Type: System..::..String
The account code for DNC.Com authentication
loginId
Type: System..::..String
The login Id to use for for DNC.Com authentication
projectId
Type: System..::..String
The project Id to lookup when querying DNC.Com

Return Value

An array of DNCSourceCampaigns

See Also

DNCSourceConfiguration Class
DNCSourceConfiguration Members


DNCSourceConfiguration Properties

[image] [image]

IceLib Dialer Technical Reference
DNCSourceConfiguration Properties
DNCSourceConfiguration Class See Also Send Feedback

The DNCSourceConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | AccountCode | The account code provided by DNC.com
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' DNCSourceConfiguration..::..Property >)>)>.)
Public property | ColumnName | The name of the column in the custom database table containing do-not-call numbers. Used only in custom DNC sources.
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | ConnectionId | The ID of the Dialer database connection containing the do-not-call table. Used only in custom DNC sources.
Public property | DialUnscrubbed | When using DNC.com for scrubbing, this specifices whether to continue dialing even if scrubbing is unable to complete.
Public property | DNCCampaignId | The ID of the DNC.com campaign to use for scrubbing numbers.
Public property | DNCCampaignName | The name of the DNC.com campaign to use for scrubbing numbers.
Public property | ExclusionIdColumnName | The name of the column in the custom database table containing an exclusion id that relates to do-not-call numbers. Used only in custom DNC sources.
Public property | ExpirationColumnName | The name of the column in the custom database table containing do-not-call expiration. Used only in custom DNC sources.
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsExporting | Tells whether the current object is being used for exporting
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | LoginId | The login ID provided by DNC.com
Public property | MarkWirelessAsUncallable | When using DNC.com for scrubbing, this specifies whether to block calls to wireless numbers.
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | ProjectId | The ID of the DNC.com project to pull scrub settings from.
Public property | RevisionLevel | The current version number of this object.
Public property | SourceType | The type of DNC source type. Use 0 for DNC.com and 1 for custom DNC source.
Public property | TableName | The name of the database table containing do-not-call numbers. Used only by custom DNC sources.
Public property | UseDialPlan | Specifies whether to run phone numbers through the dial plan before scrubbing.
Public property | UseSecureServer | Specifies whether to use HTTPS in the url for the DNC Source.

See Also

DNCSourceConfiguration Class


AccountCode Property

[image]

IceLib Dialer Technical Reference
DNCSourceConfiguration..::..AccountCode Property
DNCSourceConfiguration Class See Also Send Feedback
The account code provided by DNC.com

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<DNCSourceConfiguration..::..Property, string> AccountCode { get; }
Visual Basic
Public ReadOnly Property AccountCode As GeneralConfigurationProperty(Of DNCSourceConfiguration..::..Property, String)
    Get

See Also

DNCSourceConfiguration Class
DNCSourceConfiguration Members


ColumnName Property

[image]

IceLib Dialer Technical Reference
DNCSourceConfiguration..::..ColumnName Property
DNCSourceConfiguration Class See Also Send Feedback
The name of the column in the custom database table containing do-not-call numbers. Used only in custom DNC sources.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<DNCSourceConfiguration..::..Property, string> ColumnName { get; }
Visual Basic
Public ReadOnly Property ColumnName As GeneralConfigurationProperty(Of DNCSourceConfiguration..::..Property, String)
    Get

See Also

DNCSourceConfiguration Class
DNCSourceConfiguration Members


ConnectionId Property

[image]

IceLib Dialer Technical Reference
DNCSourceConfiguration..::..ConnectionId Property
DNCSourceConfiguration Class See Also Send Feedback
The ID of the Dialer database connection containing the do-not-call table. Used only in custom DNC sources.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<DNCSourceConfiguration..::..Property, ConfigurationId> ConnectionId { get; }
Visual Basic
Public ReadOnly Property ConnectionId As GeneralConfigurationProperty(Of DNCSourceConfiguration..::..Property, ConfigurationId)
    Get

See Also

DNCSourceConfiguration Class
DNCSourceConfiguration Members


DialUnscrubbed Property

[image]

IceLib Dialer Technical Reference
DNCSourceConfiguration..::..DialUnscrubbed Property
DNCSourceConfiguration Class See Also Send Feedback
When using DNC.com for scrubbing, this specifices whether to continue dialing even if scrubbing is unable to complete.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<DNCSourceConfiguration..::..Property, bool> DialUnscrubbed { get; }
Visual Basic
Public ReadOnly Property DialUnscrubbed As GeneralConfigurationProperty(Of DNCSourceConfiguration..::..Property, Boolean)
    Get

See Also

DNCSourceConfiguration Class
DNCSourceConfiguration Members


DNCCampaignId Property

[image]

IceLib Dialer Technical Reference
DNCSourceConfiguration..::..DNCCampaignId Property
DNCSourceConfiguration Class See Also Send Feedback
The ID of the DNC.com campaign to use for scrubbing numbers.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<DNCSourceConfiguration..::..Property, string> DNCCampaignId { get; }
Visual Basic
Public ReadOnly Property DNCCampaignId As GeneralConfigurationProperty(Of DNCSourceConfiguration..::..Property, String)
    Get

See Also

DNCSourceConfiguration Class
DNCSourceConfiguration Members


DNCCampaignName Property

[image]

IceLib Dialer Technical Reference
DNCSourceConfiguration..::..DNCCampaignName Property
DNCSourceConfiguration Class See Also Send Feedback
The name of the DNC.com campaign to use for scrubbing numbers.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<DNCSourceConfiguration..::..Property, string> DNCCampaignName { get; }
Visual Basic
Public ReadOnly Property DNCCampaignName As GeneralConfigurationProperty(Of DNCSourceConfiguration..::..Property, String)
    Get

See Also

DNCSourceConfiguration Class
DNCSourceConfiguration Members


ExclusionIdColumnName Property

[image]

IceLib Dialer Technical Reference
DNCSourceConfiguration..::..ExclusionIdColumnName Property
DNCSourceConfiguration Class See Also Send Feedback
The name of the column in the custom database table containing an exclusion id that relates to do-not-call numbers. Used only in custom DNC sources.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<DNCSourceConfiguration..::..Property, string> ExclusionIdColumnName { get; }
Visual Basic
Public ReadOnly Property ExclusionIdColumnName As GeneralConfigurationProperty(Of DNCSourceConfiguration..::..Property, String)
    Get

See Also

DNCSourceConfiguration Class
DNCSourceConfiguration Members


ExpirationColumnName Property

[image]

IceLib Dialer Technical Reference
DNCSourceConfiguration..::..ExpirationColumnName Property
DNCSourceConfiguration Class See Also Send Feedback
The name of the column in the custom database table containing do-not-call expiration. Used only in custom DNC sources.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<DNCSourceConfiguration..::..Property, string> ExpirationColumnName { get; }
Visual Basic
Public ReadOnly Property ExpirationColumnName As GeneralConfigurationProperty(Of DNCSourceConfiguration..::..Property, String)
    Get

See Also

DNCSourceConfiguration Class
DNCSourceConfiguration Members


IsDefaultObject Property

[image]

IceLib Dialer Technical Reference
DNCSourceConfiguration..::..IsDefaultObject Property
DNCSourceConfiguration Class See Also Send Feedback
Indicates whether this is the default instance of this object type.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsDefaultObject { get; }
Visual Basic
Public ReadOnly Property IsDefaultObject As Boolean
    Get

See Also

DNCSourceConfiguration Class
DNCSourceConfiguration Members


IsExporting Property

[image]

IceLib Dialer Technical Reference
DNCSourceConfiguration..::..IsExporting Property
DNCSourceConfiguration Class See Also Send Feedback
Tells whether the current object is being used for exporting

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsExporting { get; private set; }
Visual Basic
Public Property IsExporting As Boolean
    Get
    Private Set

See Also

DNCSourceConfiguration Class
DNCSourceConfiguration Members


LoginId Property

[image]

IceLib Dialer Technical Reference
DNCSourceConfiguration..::..LoginId Property
DNCSourceConfiguration Class See Also Send Feedback
The login ID provided by DNC.com

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<DNCSourceConfiguration..::..Property, string> LoginId { get; }
Visual Basic
Public ReadOnly Property LoginId As GeneralConfigurationProperty(Of DNCSourceConfiguration..::..Property, String)
    Get

See Also

DNCSourceConfiguration Class
DNCSourceConfiguration Members


MarkWirelessAsUncallable Property

[image]

IceLib Dialer Technical Reference
DNCSourceConfiguration..::..MarkWirelessAsUncallable Property
DNCSourceConfiguration Class See Also Send Feedback
When using DNC.com for scrubbing, this specifies whether to block calls to wireless numbers.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<DNCSourceConfiguration..::..Property, bool> MarkWirelessAsUncallable { get; }
Visual Basic
Public ReadOnly Property MarkWirelessAsUncallable As GeneralConfigurationProperty(Of DNCSourceConfiguration..::..Property, Boolean)
    Get

See Also

DNCSourceConfiguration Class
DNCSourceConfiguration Members


ProjectId Property

[image]

IceLib Dialer Technical Reference
DNCSourceConfiguration..::..ProjectId Property
DNCSourceConfiguration Class See Also Send Feedback
The ID of the DNC.com project to pull scrub settings from.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<DNCSourceConfiguration..::..Property, string> ProjectId { get; }
Visual Basic
Public ReadOnly Property ProjectId As GeneralConfigurationProperty(Of DNCSourceConfiguration..::..Property, String)
    Get

See Also

DNCSourceConfiguration Class
DNCSourceConfiguration Members


RevisionLevel Property

[image]

IceLib Dialer Technical Reference
DNCSourceConfiguration..::..RevisionLevel Property
DNCSourceConfiguration Class See Also Send Feedback
The current version number of this object.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<DNCSourceConfiguration..::..Property, int> RevisionLevel { get; }
Visual Basic
Public ReadOnly Property RevisionLevel As GeneralConfigurationProperty(Of DNCSourceConfiguration..::..Property, Integer)
    Get

See Also

DNCSourceConfiguration Class
DNCSourceConfiguration Members


SourceType Property

[image]

IceLib Dialer Technical Reference
DNCSourceConfiguration..::..SourceType Property
DNCSourceConfiguration Class See Also Send Feedback
The type of DNC source type. Use 0 for DNC.com and 1 for custom DNC source.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<DNCSourceConfiguration..::..Property, int> SourceType { get; }
Visual Basic
Public ReadOnly Property SourceType As GeneralConfigurationProperty(Of DNCSourceConfiguration..::..Property, Integer)
    Get

See Also

DNCSourceConfiguration Class
DNCSourceConfiguration Members


TableName Property

[image]

IceLib Dialer Technical Reference
DNCSourceConfiguration..::..TableName Property
DNCSourceConfiguration Class See Also Send Feedback
The name of the database table containing do-not-call numbers. Used only by custom DNC sources.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<DNCSourceConfiguration..::..Property, string> TableName { get; }
Visual Basic
Public ReadOnly Property TableName As GeneralConfigurationProperty(Of DNCSourceConfiguration..::..Property, String)
    Get

See Also

DNCSourceConfiguration Class
DNCSourceConfiguration Members


UseDialPlan Property

[image]

IceLib Dialer Technical Reference
DNCSourceConfiguration..::..UseDialPlan Property
DNCSourceConfiguration Class See Also Send Feedback
Specifies whether to run phone numbers through the dial plan before scrubbing.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<DNCSourceConfiguration..::..Property, bool> UseDialPlan { get; }
Visual Basic
Public ReadOnly Property UseDialPlan As GeneralConfigurationProperty(Of DNCSourceConfiguration..::..Property, Boolean)
    Get

See Also

DNCSourceConfiguration Class
DNCSourceConfiguration Members


UseSecureServer Property

[image]

IceLib Dialer Technical Reference
DNCSourceConfiguration..::..UseSecureServer Property
DNCSourceConfiguration Class See Also Send Feedback
Specifies whether to use HTTPS in the url for the DNC Source.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<DNCSourceConfiguration..::..Property, bool> UseSecureServer { get; }
Visual Basic
Public ReadOnly Property UseSecureServer As GeneralConfigurationProperty(Of DNCSourceConfiguration..::..Property, Boolean)
    Get

See Also

DNCSourceConfiguration Class
DNCSourceConfiguration Members


DNCSourceConfiguration.Property Enumeration

[image]

IceLib Dialer Technical Reference
DNCSourceConfiguration..::..Property Enumeration
DNCSourceConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Id | 0 | Represents the Id part of the ConfigurationId property.
DisplayName | 1 | Represents the DisplayName part of the ConfigurationId property.
AccountCode | 2 | Represents the AccountCode property.
DNCCampaignId | 3 | Represents the DNCCampaignId property.
DNCCampaignName | 4 | Represents the DNCCampaignName property.
ColumnName | 5 | Represents the ColumnName property.
ConnectionId | 6 | Represents the ConnectionId property.
DialUnscrubbed | 7 | Represents the DialUnscrubbed property.
ExclusionIdColumnName | 8 | Represents the ExclusionIdColumnName property.
ExpirationColumnName | 9 | Represents the ExpirationColumnName property.
LoginId | 10 | Represents the LoginId property.
MarkWirelessAsUncallable | 11 | Represents the MarkWirelessAsUncallable property.
ProjectId | 12 | Represents the ProjectId property.
SourceType | 13 | Represents the SourceType property.
TableName | 14 | Represents the TableName property.
UseDialPlan | 15 | Represents the UseDialPlan property.
UseSecureServer | 16 | Represents the UseSecureServer property.
RevisionLevel | 17 | Represents the RevisionLevel property.

See Also


DNCSourceConfigurationList Class

[image]

IceLib Dialer Technical Reference
DNCSourceConfigurationList Class
Members See Also Send Feedback
Allows for querying DNCSource configuration objects.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class DNCSourceConfigurationList : EditableConfigurationList<DNCSourceConfiguration, DNCSourceConfiguration..::..Property>
Visual Basic
Public Class DNCSourceConfigurationList _
    Inherits EditableConfigurationList(Of DNCSourceConfiguration, DNCSourceConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>
DynamicConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>
EditableConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..DNCSourceConfigurationList

See Also

DNCSourceConfigurationList Members


DNCSourceConfigurationList Members

[image] [image]

IceLib Dialer Technical Reference
DNCSourceConfigurationList Members
DNCSourceConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The DNCSourceConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | DNCSourceConfigurationList | Initializes a new instance of the DNCSourceConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)

See Also

DNCSourceConfigurationList Class


DNCSourceConfigurationList Constructor

[image]

IceLib Dialer Technical Reference
DNCSourceConfigurationList Constructor
DNCSourceConfigurationList Class See Also Send Feedback
Initializes a new instance of the DNCSourceConfigurationList class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DNCSourceConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

DNCSourceConfigurationList Class
DNCSourceConfigurationList Members


DNCSourceConfigurationList Methods

[image] [image]

IceLib Dialer Technical Reference
DNCSourceConfigurationList Methods
DNCSourceConfigurationList Class See Also Send Feedback

The DNCSourceConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DNCSourceConfigurationList Class


DNCSourceConfigurationList Properties

[image] [image]

IceLib Dialer Technical Reference
DNCSourceConfigurationList Properties
DNCSourceConfigurationList Class See Also Send Feedback

The DNCSourceConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)

See Also

DNCSourceConfigurationList Class


DNCSourceConfigurationList Events

[image] [image]

IceLib Dialer Technical Reference
DNCSourceConfigurationList Events
DNCSourceConfigurationList Class See Also Send Feedback

The DNCSourceConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' DNCSourceConfiguration, DNCSourceConfiguration..::..Property >)>)>.)

See Also

DNCSourceConfigurationList Class


DNCUpdate Class

[image]

IceLib Dialer Technical Reference
DNCUpdate Class
Members See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class DNCUpdate
Visual Basic
Public Class DNCUpdate

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..DNCUpdate

See Also

DNCUpdate Members


DNCUpdate Members

[image] [image]

IceLib Dialer Technical Reference
DNCUpdate Members
DNCUpdate Class Constructors Methods Properties See Also Send Feedback

The DNCUpdate type exposes the following members.

Constructors

 | Name | Description
Public method | DNCUpdate | Initializes a new instance of the DNCUpdate class.

Methods

 | Name | Description
Public method | AddEntryToDNC | Adds an entry to the DNC table. This function will place the account identifier and phone number into the DNC table such that the combination of the two will be prohibited from being called by Campaigns which use the given dncSource until the expiration date/time occurs. This set of functions take a Do-Not-Call source as a basis for placing the information into the DNC table.
Public method | AddEntryToDNCTable | Adds an entry to the DNC table.
Public method | AddEntryToDNCTableByCampaign | Obsolete. Adds an entry to the DNC table. This function will place the account identifier and phone number into the DNC table such that the combination of the two will be prohibited from being called by Campaigns which use the given dncSource until the expiration date/time occurs. This set of functions take a Campaign's DNC source as a basis for placing the information into the DNC table.
Public method | AddEntryToDNCTableByDNCSource | Adds an entry to the DNC table. This function will place the account identifier and phone number into the DNC table such that the combination of the two will be prohibited from being called by Campaigns which use the given dncSource until the expiration date/time occurs. This set of functions take a DNC source as a basis for placing the information into the DNC table.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Session | Gets the Session used by the DNCUpdate.

See Also

DNCUpdate Class


DNCUpdate Constructor

[image]

IceLib Dialer Technical Reference
DNCUpdate Constructor
DNCUpdate Class See Also Send Feedback
Initializes a new instance of the DNCUpdate class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DNCUpdate(
    Session session
)
Visual Basic
Public Sub New ( _
    session As Session _
)

Parameters

session
Type: Session
The Session to be used. The session must already be initialized and connected.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).
IceLibException | The supplied Session is not valid or is not connected.

See Also

DNCUpdate Class
DNCUpdate Members


DNCUpdate Methods

[image] [image]

IceLib Dialer Technical Reference
DNCUpdate Methods
DNCUpdate Class See Also Send Feedback

The DNCUpdate type exposes the following members.

Methods

 | Name | Description
Public method | AddEntryToDNC | Adds an entry to the DNC table. This function will place the account identifier and phone number into the DNC table such that the combination of the two will be prohibited from being called by Campaigns which use the given dncSource until the expiration date/time occurs. This set of functions take a Do-Not-Call source as a basis for placing the information into the DNC table.
Public method | AddEntryToDNCTable | Adds an entry to the DNC table.
Public method | AddEntryToDNCTableByCampaign | Obsolete. Adds an entry to the DNC table. This function will place the account identifier and phone number into the DNC table such that the combination of the two will be prohibited from being called by Campaigns which use the given dncSource until the expiration date/time occurs. This set of functions take a Campaign's DNC source as a basis for placing the information into the DNC table.
Public method | AddEntryToDNCTableByDNCSource | Adds an entry to the DNC table. This function will place the account identifier and phone number into the DNC table such that the combination of the two will be prohibited from being called by Campaigns which use the given dncSource until the expiration date/time occurs. This set of functions take a DNC source as a basis for placing the information into the DNC table.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DNCUpdate Class


AddEntryToDNC Method

[image]

IceLib Dialer Technical Reference
DNCUpdate..::..AddEntryToDNC Method
DNCUpdate Class See Also Send Feedback
Adds an entry to the DNC table. This function will place the account identifier and phone number into the DNC table such that the combination of the two will be prohibited from being called by Campaigns which use the given dncSource until the expiration date/time occurs. This set of functions take a Do-Not-Call source as a basis for placing the information into the DNC table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool AddEntryToDNC(
    DNCSourceConfiguration dncConfiguration,
    DNCRecord dncRecord
)
Visual Basic
Public Function AddEntryToDNC ( _
    dncConfiguration As DNCSourceConfiguration, _
    dncRecord As DNCRecord _
) As Boolean

Parameters

dncConfiguration
Type: ININ.IceLib.Configuration.Dialer..::..DNCSourceConfiguration
dncRecord
Type: ININ.IceLib.Configuration.Dialer..::..DNCRecord
The DNC Record object which defines the values to add to the DNC table.

Return Value

Boolean representing the function's successful return.

See Also

DNCUpdate Class
DNCUpdate Members


AddEntryToDNCTable Method

[image]

IceLib Dialer Technical Reference
DNCUpdate..::..AddEntryToDNCTable Method
DNCUpdate Class See Also Send Feedback
Adds an entry to the DNC table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool AddEntryToDNCTable(
    ConfigurationId connectionId,
    string tableName,
    string phoneNumberColumnName,
    string phoneNumber,
    string exclusionIdentifierColumnName,
    string exclusionIdentifier,
    string expirationDateTimeColumnName,
    TimeSpan dateTimeOffsetBeforeNextDial
)
Visual Basic
Public Function AddEntryToDNCTable ( _
    connectionId As ConfigurationId, _
    tableName As String, _
    phoneNumberColumnName As String, _
    phoneNumber As String, _
    exclusionIdentifierColumnName As String, _
    exclusionIdentifier As String, _
    expirationDateTimeColumnName As String, _
    dateTimeOffsetBeforeNextDial As TimeSpan _
) As Boolean

Parameters

connectionId
Type: ConfigurationId
The Database Connection Id.
tableName
Type: System..::..String
The name of the Database table from the associated Connection Id for the Custom DNC.
phoneNumberColumnName
Type: System..::..String
The name of the Phone Number Column in the DNC table.
phoneNumber
Type: System..::..String
The phone number to add to the DNC table.
exclusionIdentifierColumnName
Type: System..::..String
The name of the Exclusion Column (account Identifier Column) in the DNC table.
exclusionIdentifier
Type: System..::..String
The identifier to add to the DNC table. This field is meant to be used to identify the record at the account level, as opposed to the Phone Number level. When mixed, the DNC will apply to the combination of the account and phone number.
expirationDateTimeColumnName
Type: System..::..String
The name of the Expiration Column in the DNC table.
dateTimeOffsetBeforeNextDial
Type: System..::..TimeSpan
The amount of time in the future before the associated phone/account numbers may be dialed.

Return Value

Boolean representing the function's successful return.

See Also

DNCUpdate Class
DNCUpdate Members


AddEntryToDNCTableByCampaign Method

[image]

IceLib Dialer Technical Reference
DNCUpdate..::..AddEntryToDNCTableByCampaign Method
DNCUpdate Class See Also Send Feedback
Adds an entry to the DNC table. This function will place the account identifier and phone number into the DNC table such that the combination of the two will be prohibited from being called by Campaigns which use the given dncSource until the expiration date/time occurs. This set of functions take a Campaign's DNC source as a basis for placing the information into the DNC table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
[ObsoleteAttribute("AddEntryToDNCTableByCampaign has been deprecated, use AddEntryToDNC instead.",
    true)]
public bool AddEntryToDNCTableByCampaign(
    ConfigurationId campaignId,
    DNCRecord dncRecord
)
Visual Basic
<ObsoleteAttribute("AddEntryToDNCTableByCampaign has been deprecated, use AddEntryToDNC instead.",  _
    True)> _
Public Function AddEntryToDNCTableByCampaign ( _
    campaignId As ConfigurationId, _
    dncRecord As DNCRecord _
) As Boolean

Parameters

campaignId
Type: ConfigurationId
The Campaign Configuration.
dncRecord
Type: ININ.IceLib.Configuration.Dialer..::..DNCRecord
The DNC Record object which defines the values to add to the DNC table.

Return Value

Boolean representing the function's successful return.

See Also

DNCUpdate Class
DNCUpdate Members


AddEntryToDNCTableByDNCSource Method

[image]

IceLib Dialer Technical Reference
DNCUpdate..::..AddEntryToDNCTableByDNCSource Method
DNCUpdate Class See Also Send Feedback
Adds an entry to the DNC table. This function will place the account identifier and phone number into the DNC table such that the combination of the two will be prohibited from being called by Campaigns which use the given dncSource until the expiration date/time occurs. This set of functions take a DNC source as a basis for placing the information into the DNC table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool AddEntryToDNCTableByDNCSource(
    ConfigurationId dncSource,
    DNCRecord dncRecord
)
Visual Basic
Public Function AddEntryToDNCTableByDNCSource ( _
    dncSource As ConfigurationId, _
    dncRecord As DNCRecord _
) As Boolean

Parameters

dncSource
Type: ConfigurationId
The DNC Source Configuration.
dncRecord
Type: ININ.IceLib.Configuration.Dialer..::..DNCRecord
The DNC Record object which defines the values to add to the DNC table.

Return Value

Boolean representing the function's successful return.

See Also

DNCUpdate Class
DNCUpdate Members


DNCUpdate Properties

[image] [image]

IceLib Dialer Technical Reference
DNCUpdate Properties
DNCUpdate Class See Also Send Feedback

The DNCUpdate type exposes the following members.

Properties

 | Name | Description
Public property | Session | Gets the Session used by the DNCUpdate.

See Also

DNCUpdate Class


Session Property

[image]

IceLib Dialer Technical Reference
DNCUpdate..::..Session Property
DNCUpdate Class See Also Send Feedback
Gets the Session used by the DNCUpdate.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Session Session { get; private set; }
Visual Basic
Public Property Session As Session
    Get
    Private Set

Field Value

The session.

See Also

DNCUpdate Class
DNCUpdate Members


DncUpdateBehavior Class

[image]

IceLib Dialer Technical Reference
DncUpdateBehavior Class
Members See Also Send Feedback
A PolicyBehavior which sets the DNC Source information for the call.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class DncUpdateBehavior : PolicyBehavior
Visual Basic
Public NotInheritable Class DncUpdateBehavior _
    Inherits PolicyBehavior

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyBehavior
ININ.IceLib.Configuration.Dialer..::..DncUpdateBehavior

See Also

DncUpdateBehavior Members


DncUpdateBehavior Members

[image] [image]

IceLib Dialer Technical Reference
DncUpdateBehavior Members
DncUpdateBehavior Class Constructors Methods Properties See Also Send Feedback

The DncUpdateBehavior type exposes the following members.

Constructors

 | Name | Description
Public method | DncUpdateBehavior | Initializes a new instance of the DncUpdateBehavior class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddExclusionIdColumn | Get or set whether the exclusion value associated with the contact will be added to the DNC table
Public property | AddPhoneNumberColumn | Get or set whether the dialed phone number will be added to the DNC table
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | ExpirationOffsetDays | Get or set the number of days in which this contact will be callable again.
Public property | ExpirationOffsetHours | Get or set the number of hours in which this contact will be callable again.
Public property | ExpirationOffsetMinutes | Get or set the number of minutes in which this contact will be callable again.
Public property | Id | (Inherited from PolicyBehavior.)

See Also

DncUpdateBehavior Class


DncUpdateBehavior Constructor

[image]

IceLib Dialer Technical Reference
DncUpdateBehavior Constructor
DncUpdateBehavior Class See Also Send Feedback
Initializes a new instance of the DncUpdateBehavior class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DncUpdateBehavior()
Visual Basic
Public Sub New

See Also

DncUpdateBehavior Class
DncUpdateBehavior Members


DncUpdateBehavior Methods

[image] [image]

IceLib Dialer Technical Reference
DncUpdateBehavior Methods
DncUpdateBehavior Class See Also Send Feedback

The DncUpdateBehavior type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DncUpdateBehavior Class


DncUpdateBehavior Properties

[image] [image]

IceLib Dialer Technical Reference
DncUpdateBehavior Properties
DncUpdateBehavior Class See Also Send Feedback

The DncUpdateBehavior type exposes the following members.

Properties

 | Name | Description
Public property | AddExclusionIdColumn | Get or set whether the exclusion value associated with the contact will be added to the DNC table
Public property | AddPhoneNumberColumn | Get or set whether the dialed phone number will be added to the DNC table
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | ExpirationOffsetDays | Get or set the number of days in which this contact will be callable again.
Public property | ExpirationOffsetHours | Get or set the number of hours in which this contact will be callable again.
Public property | ExpirationOffsetMinutes | Get or set the number of minutes in which this contact will be callable again.
Public property | Id | (Inherited from PolicyBehavior.)

See Also

DncUpdateBehavior Class


AddExclusionIdColumn Property

[image]

IceLib Dialer Technical Reference
DncUpdateBehavior..::..AddExclusionIdColumn Property
DncUpdateBehavior Class See Also Send Feedback
Get or set whether the exclusion value associated with the contact will be added to the DNC table

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool AddExclusionIdColumn { get; set; }
Visual Basic
Public Property AddExclusionIdColumn As Boolean
    Get
    Set

See Also

DncUpdateBehavior Class
DncUpdateBehavior Members


AddPhoneNumberColumn Property

[image]

IceLib Dialer Technical Reference
DncUpdateBehavior..::..AddPhoneNumberColumn Property
DncUpdateBehavior Class See Also Send Feedback
Get or set whether the dialed phone number will be added to the DNC table

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool AddPhoneNumberColumn { get; set; }
Visual Basic
Public Property AddPhoneNumberColumn As Boolean
    Get
    Set

See Also

DncUpdateBehavior Class
DncUpdateBehavior Members


ExpirationOffsetDays Property

[image]

IceLib Dialer Technical Reference
DncUpdateBehavior..::..ExpirationOffsetDays Property
DncUpdateBehavior Class See Also Send Feedback
Get or set the number of days in which this contact will be callable again.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int ExpirationOffsetDays { get; set; }
Visual Basic
Public Property ExpirationOffsetDays As Integer
    Get
    Set

Remarks

The expiration properties can be used to create temporary DNC entries. To specify no expiration, ExpirationOffsetDays, ExpirationOffsetDays and ExpirationOffsetDays should all be set to zero.

See Also

DncUpdateBehavior Class
DncUpdateBehavior Members


ExpirationOffsetHours Property

[image]

IceLib Dialer Technical Reference
DncUpdateBehavior..::..ExpirationOffsetHours Property
DncUpdateBehavior Class See Also Send Feedback
Get or set the number of hours in which this contact will be callable again.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int ExpirationOffsetHours { get; set; }
Visual Basic
Public Property ExpirationOffsetHours As Integer
    Get
    Set

Remarks

The expiration properties can be used to create temporary DNC entries. To specify no expiration, ExpirationOffsetDays, ExpirationOffsetDays and ExpirationOffsetDays should all be set to zero.

See Also

DncUpdateBehavior Class
DncUpdateBehavior Members


ExpirationOffsetMinutes Property

[image]

IceLib Dialer Technical Reference
DncUpdateBehavior..::..ExpirationOffsetMinutes Property
DncUpdateBehavior Class See Also Send Feedback
Get or set the number of minutes in which this contact will be callable again.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int ExpirationOffsetMinutes { get; set; }
Visual Basic
Public Property ExpirationOffsetMinutes As Integer
    Get
    Set

Remarks

The expiration properties can be used to create temporary DNC entries. To specify no expiration, ExpirationOffsetDays, ExpirationOffsetDays and ExpirationOffsetDays should all be set to zero.

See Also

DncUpdateBehavior Class
DncUpdateBehavior Members


EmailBehavior Class

[image]

IceLib Dialer Technical Reference
EmailBehavior Class
Members See Also Send Feedback
A PolicyBehavior which sends an email.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class EmailBehavior : PolicyBehavior
Visual Basic
Public NotInheritable Class EmailBehavior _
    Inherits PolicyBehavior

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyBehavior
ININ.IceLib.Configuration.Dialer..::..EmailBehavior

See Also

EmailBehavior Members


EmailBehavior Members

[image] [image]

IceLib Dialer Technical Reference
EmailBehavior Members
EmailBehavior Class Constructors Methods Properties See Also Send Feedback

The EmailBehavior type exposes the following members.

Constructors

 | Name | Description
Public method | EmailBehavior | Initializes a new instance of the EmailBehavior class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | From | Get or set the sender of the email.
Public property | Id | (Inherited from PolicyBehavior.)
Public property | Message | Get or set the content of the email.
Public property | Subject | Get or set the subject line of the email.
Public property | To | Get or set the addressee of the email.

See Also

EmailBehavior Class


EmailBehavior Constructor

[image]

IceLib Dialer Technical Reference
EmailBehavior Constructor
EmailBehavior Class See Also Send Feedback
Initializes a new instance of the EmailBehavior class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public EmailBehavior()
Visual Basic
Public Sub New

See Also

EmailBehavior Class
EmailBehavior Members


EmailBehavior Methods

[image] [image]

IceLib Dialer Technical Reference
EmailBehavior Methods
EmailBehavior Class See Also Send Feedback

The EmailBehavior type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmailBehavior Class


EmailBehavior Properties

[image] [image]

IceLib Dialer Technical Reference
EmailBehavior Properties
EmailBehavior Class See Also Send Feedback

The EmailBehavior type exposes the following members.

Properties

 | Name | Description
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | From | Get or set the sender of the email.
Public property | Id | (Inherited from PolicyBehavior.)
Public property | Message | Get or set the content of the email.
Public property | Subject | Get or set the subject line of the email.
Public property | To | Get or set the addressee of the email.

See Also

EmailBehavior Class


From Property

[image]

IceLib Dialer Technical Reference
EmailBehavior..::..From Property
EmailBehavior Class See Also Send Feedback
Get or set the sender of the email.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string From { get; set; }
Visual Basic
Public Property From As String
    Get
    Set

See Also

EmailBehavior Class
EmailBehavior Members


Message Property

[image]

IceLib Dialer Technical Reference
EmailBehavior..::..Message Property
EmailBehavior Class See Also Send Feedback
Get or set the content of the email.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Message { get; set; }
Visual Basic
Public Property Message As String
    Get
    Set

See Also

EmailBehavior Class
EmailBehavior Members


Subject Property

[image]

IceLib Dialer Technical Reference
EmailBehavior..::..Subject Property
EmailBehavior Class See Also Send Feedback
Get or set the subject line of the email.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Subject { get; set; }
Visual Basic
Public Property Subject As String
    Get
    Set

See Also

EmailBehavior Class
EmailBehavior Members


To Property

[image]

IceLib Dialer Technical Reference
EmailBehavior..::..To Property
EmailBehavior Class See Also Send Feedback
Get or set the addressee of the email.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string To { get; set; }
Visual Basic
Public Property To As String
    Get
    Set

See Also

EmailBehavior Class
EmailBehavior Members


EmailRuleAction Class

[image]

IceLib Dialer Technical Reference
EmailRuleAction Class
Members See Also Send Feedback
A RuleAction that sends an e-mail.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class EmailRuleAction : RuleAction
Visual Basic
Public NotInheritable Class EmailRuleAction _
    Inherits RuleAction

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..RuleAction
ININ.IceLib.Configuration.Dialer..::..EmailRuleAction

See Also

EmailRuleAction Members


EmailRuleAction Members

[image] [image]

IceLib Dialer Technical Reference
EmailRuleAction Members
EmailRuleAction Class Constructors Methods Properties See Also Send Feedback

The EmailRuleAction type exposes the following members.

Constructors

 | Name | Description
Public method | EmailRuleAction | Constructs a new instance of the EmailRuleAction

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActionType | The type of action to perform. (Inherited from RuleAction.)
Public property | From | The sender's email address.
Public property | Id | The Id of the action. (Inherited from RuleAction.)
Public property | Index | The ordinal number of this action in relation to other actions in a rule. (Inherited from RuleAction.)
Public property | Message | The content of the email. (Macros are allowed here)
Public property | Subject | The subject line of the email. (Macros are allowed here)
Public property | To | The recipient's email address.

See Also

EmailRuleAction Class


EmailRuleAction Constructor

[image]

IceLib Dialer Technical Reference
EmailRuleAction Constructor
EmailRuleAction Class See Also Send Feedback
Constructs a new instance of the EmailRuleAction

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public EmailRuleAction()
Visual Basic
Public Sub New

See Also

EmailRuleAction Class
EmailRuleAction Members


EmailRuleAction Methods

[image] [image]

IceLib Dialer Technical Reference
EmailRuleAction Methods
EmailRuleAction Class See Also Send Feedback

The EmailRuleAction type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EmailRuleAction Class


EmailRuleAction Properties

[image] [image]

IceLib Dialer Technical Reference
EmailRuleAction Properties
EmailRuleAction Class See Also Send Feedback

The EmailRuleAction type exposes the following members.

Properties

 | Name | Description
Public property | ActionType | The type of action to perform. (Inherited from RuleAction.)
Public property | From | The sender's email address.
Public property | Id | The Id of the action. (Inherited from RuleAction.)
Public property | Index | The ordinal number of this action in relation to other actions in a rule. (Inherited from RuleAction.)
Public property | Message | The content of the email. (Macros are allowed here)
Public property | Subject | The subject line of the email. (Macros are allowed here)
Public property | To | The recipient's email address.

See Also

EmailRuleAction Class


From Property

[image]

IceLib Dialer Technical Reference
EmailRuleAction..::..From Property
EmailRuleAction Class See Also Send Feedback
The sender's email address.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string From { get; set; }
Visual Basic
Public Property From As String
    Get
    Set

See Also

EmailRuleAction Class
EmailRuleAction Members


Message Property

[image]

IceLib Dialer Technical Reference
EmailRuleAction..::..Message Property
EmailRuleAction Class See Also Send Feedback
The content of the email. (Macros are allowed here)

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Message { get; set; }
Visual Basic
Public Property Message As String
    Get
    Set

See Also

EmailRuleAction Class
EmailRuleAction Members


Subject Property

[image]

IceLib Dialer Technical Reference
EmailRuleAction..::..Subject Property
EmailRuleAction Class See Also Send Feedback
The subject line of the email. (Macros are allowed here)

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Subject { get; set; }
Visual Basic
Public Property Subject As String
    Get
    Set

See Also

EmailRuleAction Class
EmailRuleAction Members


To Property

[image]

IceLib Dialer Technical Reference
EmailRuleAction..::..To Property
EmailRuleAction Class See Also Send Feedback
The recipient's email address.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string To { get; set; }
Visual Basic
Public Property To As String
    Get
    Set

See Also

EmailRuleAction Class
EmailRuleAction Members


EmptyExpression Class

[image]

IceLib Dialer Technical Reference
EmptyExpression Class
Members See Also Send Feedback
An empty expression used only as a placeholder.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class EmptyExpression : IInternalExpression,
    IExpression, ICloneable
Visual Basic
Public NotInheritable Class EmptyExpression _
    Implements IInternalExpression, IExpression, ICloneable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..EmptyExpression

See Also

EmptyExpression Members


EmptyExpression Members

[image] [image]

IceLib Dialer Technical Reference
EmptyExpression Members
EmptyExpression Class Methods Properties See Also Send Feedback

The EmptyExpression type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

Properties

Name | Description
Instance | The singleton instance of EmptyExpression.

See Also

EmptyExpression Class


EmptyExpression Methods

[image] [image]

IceLib Dialer Technical Reference
EmptyExpression Methods
EmptyExpression Class See Also Send Feedback

The EmptyExpression type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Overrides Object..::..ToString()()()().)

See Also

EmptyExpression Class


Clone Method

[image]

IceLib Dialer Technical Reference
EmptyExpression..::..Clone Method
EmptyExpression Class See Also Send Feedback
Creates a new object that is a copy of the current instance.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Object Clone()
Visual Basic
Public Function Clone As Object

Return Value

A new object that is a copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

EmptyExpression Class
EmptyExpression Members


ToString Method

[image]

IceLib Dialer Technical Reference
EmptyExpression..::..ToString Method
EmptyExpression Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

A String that represents the current Object.

See Also

EmptyExpression Class
EmptyExpression Members


EmptyExpression Properties

[image] [image]

IceLib Dialer Technical Reference
EmptyExpression Properties
EmptyExpression Class See Also Send Feedback

The EmptyExpression type exposes the following members.

Properties

Name | Description
Instance | The singleton instance of EmptyExpression.

See Also

EmptyExpression Class


Instance Property

[image]

IceLib Dialer Technical Reference
EmptyExpression..::..Instance Property
EmptyExpression Class See Also Send Feedback
The singleton instance of EmptyExpression.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static EmptyExpression Instance { get; }
Visual Basic
Public Shared ReadOnly Property Instance As EmptyExpression
    Get

See Also

EmptyExpression Class
EmptyExpression Members


EventLogBehavior Class

[image]

IceLib Dialer Technical Reference
EventLogBehavior Class
Members See Also Send Feedback
A PolicyBehavior which creates an entry in the Dialer server's event log.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class EventLogBehavior : PolicyBehavior
Visual Basic
Public NotInheritable Class EventLogBehavior _
    Inherits PolicyBehavior

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyBehavior
ININ.IceLib.Configuration.Dialer..::..EventLogBehavior

See Also

EventLogBehavior Members


EventLogBehavior Members

[image] [image]

IceLib Dialer Technical Reference
EventLogBehavior Members
EventLogBehavior Class Constructors Methods Properties See Also Send Feedback

The EventLogBehavior type exposes the following members.

Constructors

 | Name | Description
Public method | EventLogBehavior | Initializes a new instance of the EventLogBehavior class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | Id | (Inherited from PolicyBehavior.)
Public property | Message | Get or set the message to be logged.
Public property | Severity | Get or set the severity level at which to log the configured message.

See Also

EventLogBehavior Class


EventLogBehavior Constructor

[image]

IceLib Dialer Technical Reference
EventLogBehavior Constructor
EventLogBehavior Class See Also Send Feedback
Initializes a new instance of the EventLogBehavior class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public EventLogBehavior()
Visual Basic
Public Sub New

See Also

EventLogBehavior Class
EventLogBehavior Members


EventLogBehavior Methods

[image] [image]

IceLib Dialer Technical Reference
EventLogBehavior Methods
EventLogBehavior Class See Also Send Feedback

The EventLogBehavior type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EventLogBehavior Class


EventLogBehavior Properties

[image] [image]

IceLib Dialer Technical Reference
EventLogBehavior Properties
EventLogBehavior Class See Also Send Feedback

The EventLogBehavior type exposes the following members.

Properties

 | Name | Description
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | Id | (Inherited from PolicyBehavior.)
Public property | Message | Get or set the message to be logged.
Public property | Severity | Get or set the severity level at which to log the configured message.

See Also

EventLogBehavior Class


Message Property

[image]

IceLib Dialer Technical Reference
EventLogBehavior..::..Message Property
EventLogBehavior Class See Also Send Feedback
Get or set the message to be logged.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Message { get; set; }
Visual Basic
Public Property Message As String
    Get
    Set

See Also

EventLogBehavior Class
EventLogBehavior Members


Severity Property

[image]

IceLib Dialer Technical Reference
EventLogBehavior..::..Severity Property
EventLogBehavior Class See Also Send Feedback
Get or set the severity level at which to log the configured message.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public EventLogSeverity Severity { get; set; }
Visual Basic
Public Property Severity As EventLogSeverity
    Get
    Set

See Also

EventLogBehavior Class
EventLogBehavior Members


EventLogRuleAction Class

[image]

IceLib Dialer Technical Reference
EventLogRuleAction Class
Members See Also Send Feedback
A RuleAction that writes an entry to the event log.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class EventLogRuleAction : RuleAction
Visual Basic
Public NotInheritable Class EventLogRuleAction _
    Inherits RuleAction

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..RuleAction
ININ.IceLib.Configuration.Dialer..::..EventLogRuleAction

See Also

EventLogRuleAction Members


EventLogRuleAction Members

[image] [image]

IceLib Dialer Technical Reference
EventLogRuleAction Members
EventLogRuleAction Class Constructors Methods Properties See Also Send Feedback

The EventLogRuleAction type exposes the following members.

Constructors

 | Name | Description
Public method | EventLogRuleAction | Constructs a new instance of the EventLogRuleAction class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides RuleActionToString()()()().)

Properties

 | Name | Description
Public property | ActionType | The type of action to perform. (Inherited from RuleAction.)
Public property | Id | The Id of the action. (Inherited from RuleAction.)
Public property | Index | The ordinal number of this action in relation to other actions in a rule. (Inherited from RuleAction.)
Public property | Message | The description of the event.
Public property | Severity | The severity level of the event.

See Also

EventLogRuleAction Class


EventLogRuleAction Constructor

[image]

IceLib Dialer Technical Reference
EventLogRuleAction Constructor
EventLogRuleAction Class See Also Send Feedback
Constructs a new instance of the EventLogRuleAction class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public EventLogRuleAction()
Visual Basic
Public Sub New

See Also

EventLogRuleAction Class
EventLogRuleAction Members


EventLogRuleAction Methods

[image] [image]

IceLib Dialer Technical Reference
EventLogRuleAction Methods
EventLogRuleAction Class See Also Send Feedback

The EventLogRuleAction type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides RuleActionToString()()()().)

See Also

EventLogRuleAction Class


ToString Method

[image]

IceLib Dialer Technical Reference
EventLogRuleAction..::..ToString Method
EventLogRuleAction Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

EventLogRuleAction Class
EventLogRuleAction Members


EventLogRuleAction Properties

[image] [image]

IceLib Dialer Technical Reference
EventLogRuleAction Properties
EventLogRuleAction Class See Also Send Feedback

The EventLogRuleAction type exposes the following members.

Properties

 | Name | Description
Public property | ActionType | The type of action to perform. (Inherited from RuleAction.)
Public property | Id | The Id of the action. (Inherited from RuleAction.)
Public property | Index | The ordinal number of this action in relation to other actions in a rule. (Inherited from RuleAction.)
Public property | Message | The description of the event.
Public property | Severity | The severity level of the event.

See Also

EventLogRuleAction Class


Message Property

[image]

IceLib Dialer Technical Reference
EventLogRuleAction..::..Message Property
EventLogRuleAction Class See Also Send Feedback
The description of the event.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Message { get; set; }
Visual Basic
Public Property Message As String
    Get
    Set

See Also

EventLogRuleAction Class
EventLogRuleAction Members


Severity Property

[image]

IceLib Dialer Technical Reference
EventLogRuleAction..::..Severity Property
EventLogRuleAction Class See Also Send Feedback
The severity level of the event.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public EventLogSeverity Severity { get; set; }
Visual Basic
Public Property Severity As EventLogSeverity
    Get
    Set

See Also

EventLogRuleAction Class
EventLogRuleAction Members


EventRule Class

[image]

IceLib Dialer Technical Reference
EventRule Class
Members See Also Send Feedback
A rule with a event-based condition.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class EventRule : Rule
Visual Basic
Public Class EventRule _
    Inherits Rule

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..Rule
ININ.IceLib.Configuration.Dialer..::..EventRule

See Also

EventRule Members


EventRule Members

[image] [image]

IceLib Dialer Technical Reference
EventRule Members
EventRule Class Constructors Methods Properties See Also Send Feedback

The EventRule type exposes the following members.

Constructors

 | Name | Description
Public method | EventRule | Constructs a new instance of the EventRule class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Actions | The collection of Actions to perform when this Rule's conditions are met (Inherited from Rule.)
Public property | Enabled | Toggle evaluation/execution of this rule. (Inherited from Rule.)
Public property | Events | The set of system events which will trigger the rule's actions.
Public property | Groups | Named rule groups (within the parent RuleSetConfiguration) to which this rule belongs. (Inherited from Rule.)
Public property | Id | The Id of the Rule. (Inherited from Rule.)
Public property | IgnoreGroups | Specifies whether this rule should be evaluated no matter which group is active. (Inherited from Rule.)
Public property | InAllGroups | Specifies whether this rule is a member of all rule groups of the rule set it belongs to. (Inherited from Rule.)
Public property | Index | Specifies the order to display and execute this rule in relation to other rules in the parent rule set. (Inherited from Rule.)
Public property | InStartupGroup | Specifies whether this rule is a member of the unnamed group that the rule set evaluates first. (Inherited from Rule.)
Public property | Repetition | Specifies how often the rule should be re-evaluated. (Inherited from Rule.)
Public property | TerminateOnAction | Specifies the manner in which rule evaluation should be stopped after this rule runs its actions. (Inherited from Rule.)

See Also

EventRule Class


EventRule Constructor

[image]

IceLib Dialer Technical Reference
EventRule Constructor
EventRule Class See Also Send Feedback
Constructs a new instance of the EventRule class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public EventRule()
Visual Basic
Public Sub New

See Also

EventRule Class
EventRule Members


EventRule Methods

[image] [image]

IceLib Dialer Technical Reference
EventRule Methods
EventRule Class See Also Send Feedback

The EventRule type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EventRule Class


EventRule Properties

[image] [image]

IceLib Dialer Technical Reference
EventRule Properties
EventRule Class See Also Send Feedback

The EventRule type exposes the following members.

Properties

 | Name | Description
Public property | Actions | The collection of Actions to perform when this Rule's conditions are met (Inherited from Rule.)
Public property | Enabled | Toggle evaluation/execution of this rule. (Inherited from Rule.)
Public property | Events | The set of system events which will trigger the rule's actions.
Public property | Groups | Named rule groups (within the parent RuleSetConfiguration) to which this rule belongs. (Inherited from Rule.)
Public property | Id | The Id of the Rule. (Inherited from Rule.)
Public property | IgnoreGroups | Specifies whether this rule should be evaluated no matter which group is active. (Inherited from Rule.)
Public property | InAllGroups | Specifies whether this rule is a member of all rule groups of the rule set it belongs to. (Inherited from Rule.)
Public property | Index | Specifies the order to display and execute this rule in relation to other rules in the parent rule set. (Inherited from Rule.)
Public property | InStartupGroup | Specifies whether this rule is a member of the unnamed group that the rule set evaluates first. (Inherited from Rule.)
Public property | Repetition | Specifies how often the rule should be re-evaluated. (Inherited from Rule.)
Public property | TerminateOnAction | Specifies the manner in which rule evaluation should be stopped after this rule runs its actions. (Inherited from Rule.)

See Also

EventRule Class


Events Property

[image]

IceLib Dialer Technical Reference
EventRule..::..Events Property
EventRule Class See Also Send Feedback
The set of system events which will trigger the rule's actions.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<SystemEvent> Events { get; }
Visual Basic
Public ReadOnly Property Events As Collection(Of SystemEvent)
    Get

See Also

EventRule Class
EventRule Members


EventSequenceItem Class

[image]

IceLib Dialer Technical Reference
EventSequenceItem Class
Members See Also Send Feedback
A class that represents a sequence item that is triggered by a SystemEvent

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class EventSequenceItem : SequenceItem
Visual Basic
Public Class EventSequenceItem _
    Inherits SequenceItem

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..SequenceItem
ININ.IceLib.Configuration.Dialer..::..EventSequenceItem

See Also

EventSequenceItem Members


EventSequenceItem Members

[image] [image]

IceLib Dialer Technical Reference
EventSequenceItem Members
EventSequenceItem Class Constructors Methods Properties See Also Send Feedback

The EventSequenceItem type exposes the following members.

Constructors

 | Name | Description
Public method | EventSequenceItem(CampaignGroup) | Constructs a new instance of the EventSequenceItem
Public method | EventSequenceItem(ConfigurationId, CampaignGroup) | Constructs a new instance of the EventSequenceItem

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDisplayName | Public method to change the display name of a CampaignGroup (Inherited from SequenceItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CampaignGroup | The CampaignGroup that is triggered by this Sequence Item (Inherited from SequenceItem.)
Public property | ConditionType | Specifies the Type of Sequence Item this is: Event, Time or Stat. (Inherited from SequenceItem.)
Public property | Events | The set of system events which will trigger the rule's actions.
Public property | Id | The Id of the SequenceItem. (Inherited from SequenceItem.)
Public property | IgnoreGroups | Specifies whether this Sequence Item should be evaluated no matter which campaign group is active. (Inherited from SequenceItem.)
Public property | InAllGroups | Specifies whether this Sequence Item is a child of all campaign groups of the sequence definition that it belongs to. (Inherited from SequenceItem.)
Public property | Index | Specifies the order to display and execute Sequence Item in relation to other Sequence Items in the Sequence. (Inherited from SequenceItem.)
Public property | InStartupGroup | Specifies whether this rule is a member of the unnamed group that the rule set evaluates first. (Inherited from SequenceItem.)
Public property | ParentGroups | Named campaign groups (within the sequence Sequence) to which this sequence item represents. (Inherited from SequenceItem.)

See Also

EventSequenceItem Class


EventSequenceItem Constructor

[image] [image]

IceLib Dialer Technical Reference
EventSequenceItem Constructor
EventSequenceItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | EventSequenceItem(CampaignGroup) | Constructs a new instance of the EventSequenceItem
Public method | EventSequenceItem(ConfigurationId, CampaignGroup) | Constructs a new instance of the EventSequenceItem

See Also

EventSequenceItem Class
EventSequenceItem Members


EventSequenceItem Constructor (CampaignGroup)

[image]

IceLib Dialer Technical Reference
EventSequenceItem Constructor (CampaignGroup)
EventSequenceItem Class See Also Send Feedback
Constructs a new instance of the EventSequenceItem

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public EventSequenceItem(
    CampaignGroup group
)
Visual Basic
Public Sub New ( _
    group As CampaignGroup _
)

Parameters

group
Type: ININ.IceLib.Configuration.Dialer..::..CampaignGroup

See Also

EventSequenceItem Class
EventSequenceItem Members
EventSequenceItem Overload


EventSequenceItem Constructor (ConfigurationId, CampaignGroup)

[image]

IceLib Dialer Technical Reference
EventSequenceItem Constructor (ConfigurationId, CampaignGroup)
EventSequenceItem Class See Also Send Feedback
Constructs a new instance of the EventSequenceItem

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public EventSequenceItem(
    ConfigurationId id,
    CampaignGroup group
)
Visual Basic
Public Sub New ( _
    id As ConfigurationId, _
    group As CampaignGroup _
)

Parameters

id
Type: ConfigurationId
The Id ConfigurationId you wish to assign to the sequence item.
group
Type: ININ.IceLib.Configuration.Dialer..::..CampaignGroup

See Also

EventSequenceItem Class
EventSequenceItem Members
EventSequenceItem Overload


EventSequenceItem Methods

[image] [image]

IceLib Dialer Technical Reference
EventSequenceItem Methods
EventSequenceItem Class See Also Send Feedback

The EventSequenceItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDisplayName | Public method to change the display name of a CampaignGroup (Inherited from SequenceItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

EventSequenceItem Class


EventSequenceItem Properties

[image] [image]

IceLib Dialer Technical Reference
EventSequenceItem Properties
EventSequenceItem Class See Also Send Feedback

The EventSequenceItem type exposes the following members.

Properties

 | Name | Description
Public property | CampaignGroup | The CampaignGroup that is triggered by this Sequence Item (Inherited from SequenceItem.)
Public property | ConditionType | Specifies the Type of Sequence Item this is: Event, Time or Stat. (Inherited from SequenceItem.)
Public property | Events | The set of system events which will trigger the rule's actions.
Public property | Id | The Id of the SequenceItem. (Inherited from SequenceItem.)
Public property | IgnoreGroups | Specifies whether this Sequence Item should be evaluated no matter which campaign group is active. (Inherited from SequenceItem.)
Public property | InAllGroups | Specifies whether this Sequence Item is a child of all campaign groups of the sequence definition that it belongs to. (Inherited from SequenceItem.)
Public property | Index | Specifies the order to display and execute Sequence Item in relation to other Sequence Items in the Sequence. (Inherited from SequenceItem.)
Public property | InStartupGroup | Specifies whether this rule is a member of the unnamed group that the rule set evaluates first. (Inherited from SequenceItem.)
Public property | ParentGroups | Named campaign groups (within the sequence Sequence) to which this sequence item represents. (Inherited from SequenceItem.)

See Also

EventSequenceItem Class


Events Property

[image]

IceLib Dialer Technical Reference
EventSequenceItem..::..Events Property
EventSequenceItem Class See Also Send Feedback
The set of system events which will trigger the rule's actions.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<SystemEvent> Events { get; }
Visual Basic
Public ReadOnly Property Events As Collection(Of SystemEvent)
    Get

See Also

EventSequenceItem Class
EventSequenceItem Members


FilterConfiguration Class

[image]

IceLib Dialer Technical Reference
FilterConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for a Dialer filter.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class FilterConfiguration : EditableListConfigurationObject<FilterConfiguration..::..Property>,
    IExportable
Visual Basic
Public Class FilterConfiguration _
    Inherits EditableListConfigurationObject(Of FilterConfiguration..::..Property) _
    Implements IExportable

Inheritance Hierarchy

System..::..Object
ConfigurationObject
ListConfigurationObject
EditableListConfigurationObject<(Of <(<' FilterConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..FilterConfiguration

See Also

FilterConfiguration Members


FilterConfiguration Members

[image] [image]

IceLib Dialer Technical Reference
FilterConfiguration Members
FilterConfiguration Class Methods Properties See Also Send Feedback

The FilterConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' FilterConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' FilterConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' FilterConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' FilterConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' FilterConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' FilterConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' FilterConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' FilterConfiguration..::..Property >)>)>.)
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' FilterConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' FilterConfiguration..::..Property >)>)>.)
Public method | ToString | (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' FilterConfiguration..::..Property >)>)>.)
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | FilterSQL | A SQL clause used to filter a database query.
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsExporting | Tells whether the current object is being used for exporting
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | IsPNDFilter | Indicates whether this is a ContactList filter or PhoneNumberDetail filter.
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | RevisionLevel | The current version of this object.

See Also

FilterConfiguration Class


FilterConfiguration Methods

[image] [image]

IceLib Dialer Technical Reference
FilterConfiguration Methods
FilterConfiguration Class See Also Send Feedback

The FilterConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' FilterConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' FilterConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' FilterConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' FilterConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' FilterConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' FilterConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' FilterConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' FilterConfiguration..::..Property >)>)>.)
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' FilterConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' FilterConfiguration..::..Property >)>)>.)
Public method | ToString | (Inherited from ConfigurationObject.)

See Also

FilterConfiguration Class


FilterConfiguration Properties

[image] [image]

IceLib Dialer Technical Reference
FilterConfiguration Properties
FilterConfiguration Class See Also Send Feedback

The FilterConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' FilterConfiguration..::..Property >)>)>.)
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | FilterSQL | A SQL clause used to filter a database query.
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsExporting | Tells whether the current object is being used for exporting
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | IsPNDFilter | Indicates whether this is a ContactList filter or PhoneNumberDetail filter.
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | RevisionLevel | The current version of this object.

See Also

FilterConfiguration Class


FilterSQL Property

[image]

IceLib Dialer Technical Reference
FilterConfiguration..::..FilterSQL Property
FilterConfiguration Class See Also Send Feedback
A SQL clause used to filter a database query.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<FilterConfiguration..::..Property, string> FilterSQL { get; }
Visual Basic
Public ReadOnly Property FilterSQL As GeneralConfigurationProperty(Of FilterConfiguration..::..Property, String)
    Get

See Also

FilterConfiguration Class
FilterConfiguration Members


IsDefaultObject Property

[image]

IceLib Dialer Technical Reference
FilterConfiguration..::..IsDefaultObject Property
FilterConfiguration Class See Also Send Feedback
Indicates whether this is the default instance of this object type.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsDefaultObject { get; }
Visual Basic
Public ReadOnly Property IsDefaultObject As Boolean
    Get

See Also

FilterConfiguration Class
FilterConfiguration Members


IsExporting Property

[image]

IceLib Dialer Technical Reference
FilterConfiguration..::..IsExporting Property
FilterConfiguration Class See Also Send Feedback
Tells whether the current object is being used for exporting

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsExporting { get; private set; }
Visual Basic
Public Property IsExporting As Boolean
    Get
    Private Set

See Also

FilterConfiguration Class
FilterConfiguration Members


IsPNDFilter Property

[image]

IceLib Dialer Technical Reference
FilterConfiguration..::..IsPNDFilter Property
FilterConfiguration Class See Also Send Feedback
Indicates whether this is a ContactList filter or PhoneNumberDetail filter.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<FilterConfiguration..::..Property, bool> IsPNDFilter { get; }
Visual Basic
Public ReadOnly Property IsPNDFilter As GeneralConfigurationProperty(Of FilterConfiguration..::..Property, Boolean)
    Get

See Also

FilterConfiguration Class
FilterConfiguration Members


RevisionLevel Property

[image]

IceLib Dialer Technical Reference
FilterConfiguration..::..RevisionLevel Property
FilterConfiguration Class See Also Send Feedback
The current version of this object.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<FilterConfiguration..::..Property, int> RevisionLevel { get; }
Visual Basic
Public ReadOnly Property RevisionLevel As GeneralConfigurationProperty(Of FilterConfiguration..::..Property, Integer)
    Get

See Also

FilterConfiguration Class
FilterConfiguration Members


FilterConfiguration.Property Enumeration

[image]

IceLib Dialer Technical Reference
FilterConfiguration..::..Property Enumeration
FilterConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Id | 0 | Represents the Id part of the ConfigurationId property.
DisplayName | 1 | Represents the DisplayName part of the ConfigurationId property.
FilterSQL | 2 | Represents the FilterSQL property.
RevisionLevel | 3 | Represents the RevisionLevel property.
IsPNDFilter | 4 | Represents the IsPNDFilter property.

See Also


FilterConfigurationList Class

[image]

IceLib Dialer Technical Reference
FilterConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing filter configuration objects.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class FilterConfigurationList : EditableConfigurationList<FilterConfiguration, FilterConfiguration..::..Property>
Visual Basic
Public Class FilterConfigurationList _
    Inherits EditableConfigurationList(Of FilterConfiguration, FilterConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>
DynamicConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>
EditableConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..FilterConfigurationList

See Also

FilterConfigurationList Members


FilterConfigurationList Members

[image] [image]

IceLib Dialer Technical Reference
FilterConfigurationList Members
FilterConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The FilterConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | FilterConfigurationList | Initializes a new instance of the FilterConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)

See Also

FilterConfigurationList Class


FilterConfigurationList Constructor

[image]

IceLib Dialer Technical Reference
FilterConfigurationList Constructor
FilterConfigurationList Class See Also Send Feedback
Initializes a new instance of the FilterConfigurationList class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public FilterConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

FilterConfigurationList Class
FilterConfigurationList Members


FilterConfigurationList Methods

[image] [image]

IceLib Dialer Technical Reference
FilterConfigurationList Methods
FilterConfigurationList Class See Also Send Feedback

The FilterConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterConfigurationList Class


FilterConfigurationList Properties

[image] [image]

IceLib Dialer Technical Reference
FilterConfigurationList Properties
FilterConfigurationList Class See Also Send Feedback

The FilterConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)

See Also

FilterConfigurationList Class


FilterConfigurationList Events

[image] [image]

IceLib Dialer Technical Reference
FilterConfigurationList Events
FilterConfigurationList Class See Also Send Feedback

The FilterConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' FilterConfiguration, FilterConfiguration..::..Property >)>)>.)

See Also

FilterConfigurationList Class


FilterType Enumeration

[image]

IceLib Dialer Technical Reference
FilterType Enumeration
See Also Send Feedback
Filters types to apply to object queries.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum FilterType
Visual Basic
Public Enumeration FilterType

Members

Member name | Value | Description
Prefix | 0 | Searches for values that begin with the search parameter.
Contains | 2 | Searches for values that contain the search parameter.
Exact | 3 | Searches for values that match the search parameter exactly.

See Also


HandlerBehavior Class

[image]

IceLib Dialer Technical Reference
HandlerBehavior Class
Members See Also Send Feedback
A PolicyBehavior which runs the Dialer_RuleActionEvent handler on each Dialer server. It allows for configuration of user-defined EventID and EventData parameters which will be passed to the handler.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class HandlerBehavior : PolicyBehavior
Visual Basic
Public NotInheritable Class HandlerBehavior _
    Inherits PolicyBehavior

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyBehavior
ININ.IceLib.Configuration.Dialer..::..HandlerBehavior

See Also

HandlerBehavior Members


HandlerBehavior Members

[image] [image]

IceLib Dialer Technical Reference
HandlerBehavior Members
HandlerBehavior Class Constructors Methods Properties See Also Send Feedback

The HandlerBehavior type exposes the following members.

Constructors

 | Name | Description
Public method | HandlerBehavior | Initializes a new instance of the HandlerBehavior class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | EventData | Get or set the EventData parameter sent to the handler.
Public property | EventID | Get or set the EventID parameter sent to the handler.
Public property | Id | (Inherited from PolicyBehavior.)

See Also

HandlerBehavior Class


HandlerBehavior Constructor

[image]

IceLib Dialer Technical Reference
HandlerBehavior Constructor
HandlerBehavior Class See Also Send Feedback
Initializes a new instance of the HandlerBehavior class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public HandlerBehavior()
Visual Basic
Public Sub New

See Also

HandlerBehavior Class
HandlerBehavior Members


HandlerBehavior Methods

[image] [image]

IceLib Dialer Technical Reference
HandlerBehavior Methods
HandlerBehavior Class See Also Send Feedback

The HandlerBehavior type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HandlerBehavior Class


HandlerBehavior Properties

[image] [image]

IceLib Dialer Technical Reference
HandlerBehavior Properties
HandlerBehavior Class See Also Send Feedback

The HandlerBehavior type exposes the following members.

Properties

 | Name | Description
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | EventData | Get or set the EventData parameter sent to the handler.
Public property | EventID | Get or set the EventID parameter sent to the handler.
Public property | Id | (Inherited from PolicyBehavior.)

See Also

HandlerBehavior Class


EventData Property

[image]

IceLib Dialer Technical Reference
HandlerBehavior..::..EventData Property
HandlerBehavior Class See Also Send Feedback
Get or set the EventData parameter sent to the handler.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string EventData { get; set; }
Visual Basic
Public Property EventData As String
    Get
    Set

See Also

HandlerBehavior Class
HandlerBehavior Members


EventID Property

[image]

IceLib Dialer Technical Reference
HandlerBehavior..::..EventID Property
HandlerBehavior Class See Also Send Feedback
Get or set the EventID parameter sent to the handler.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string EventID { get; set; }
Visual Basic
Public Property EventID As String
    Get
    Set

See Also

HandlerBehavior Class
HandlerBehavior Members


HandlerRuleAction Class

[image]

IceLib Dialer Technical Reference
HandlerRuleAction Class
Members See Also Send Feedback
A RuleAction that executes a custom handler.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class HandlerRuleAction : RuleAction
Visual Basic
Public NotInheritable Class HandlerRuleAction _
    Inherits RuleAction

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..RuleAction
ININ.IceLib.Configuration.Dialer..::..HandlerRuleAction

See Also

HandlerRuleAction Members


HandlerRuleAction Members

[image] [image]

IceLib Dialer Technical Reference
HandlerRuleAction Members
HandlerRuleAction Class Constructors Methods Properties See Also Send Feedback

The HandlerRuleAction type exposes the following members.

Constructors

 | Name | Description
Public method | HandlerRuleAction | Constructs a new instance of the HandlerRuleAction class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides RuleActionToString()()()().)

Properties

 | Name | Description
Public property | ActionType | The type of action to perform. (Inherited from RuleAction.)
Public property | EventData | Argument data for the custom handler.
Public property | EventId | Argument data for the custom handler.
Public property | Id | The Id of the action. (Inherited from RuleAction.)
Public property | Index | The ordinal number of this action in relation to other actions in a rule. (Inherited from RuleAction.)

See Also

HandlerRuleAction Class


HandlerRuleAction Constructor

[image]

IceLib Dialer Technical Reference
HandlerRuleAction Constructor
HandlerRuleAction Class See Also Send Feedback
Constructs a new instance of the HandlerRuleAction class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public HandlerRuleAction()
Visual Basic
Public Sub New

See Also

HandlerRuleAction Class
HandlerRuleAction Members


HandlerRuleAction Methods

[image] [image]

IceLib Dialer Technical Reference
HandlerRuleAction Methods
HandlerRuleAction Class See Also Send Feedback

The HandlerRuleAction type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides RuleActionToString()()()().)

See Also

HandlerRuleAction Class


ToString Method

[image]

IceLib Dialer Technical Reference
HandlerRuleAction..::..ToString Method
HandlerRuleAction Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

HandlerRuleAction Class
HandlerRuleAction Members


HandlerRuleAction Properties

[image] [image]

IceLib Dialer Technical Reference
HandlerRuleAction Properties
HandlerRuleAction Class See Also Send Feedback

The HandlerRuleAction type exposes the following members.

Properties

 | Name | Description
Public property | ActionType | The type of action to perform. (Inherited from RuleAction.)
Public property | EventData | Argument data for the custom handler.
Public property | EventId | Argument data for the custom handler.
Public property | Id | The Id of the action. (Inherited from RuleAction.)
Public property | Index | The ordinal number of this action in relation to other actions in a rule. (Inherited from RuleAction.)

See Also

HandlerRuleAction Class


EventData Property

[image]

IceLib Dialer Technical Reference
HandlerRuleAction..::..EventData Property
HandlerRuleAction Class See Also Send Feedback
Argument data for the custom handler.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string EventData { get; set; }
Visual Basic
Public Property EventData As String
    Get
    Set

See Also

HandlerRuleAction Class
HandlerRuleAction Members


EventId Property

[image]

IceLib Dialer Technical Reference
HandlerRuleAction..::..EventId Property
HandlerRuleAction Class See Also Send Feedback
Argument data for the custom handler.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string EventId { get; set; }
Visual Basic
Public Property EventId As String
    Get
    Set

See Also

HandlerRuleAction Class
HandlerRuleAction Members


HtmlEmailBehavior Class

[image]

IceLib Dialer Technical Reference
HtmlEmailBehavior Class
Members See Also Send Feedback
A PolicyBehavior which sends an html email.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class HtmlEmailBehavior : PolicyBehavior
Visual Basic
Public NotInheritable Class HtmlEmailBehavior _
    Inherits PolicyBehavior

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyBehavior
ININ.IceLib.Configuration.Dialer..::..HtmlEmailBehavior

See Also

HtmlEmailBehavior Members


HtmlEmailBehavior Members

[image] [image]

IceLib Dialer Technical Reference
HtmlEmailBehavior Members
HtmlEmailBehavior Class Constructors Methods Properties See Also Send Feedback

The HtmlEmailBehavior type exposes the following members.

Constructors

 | Name | Description
Public method | HtmlEmailBehavior | Initializes a new instance of the EmailBehavior class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | From | Get or set the sender of the email.
Public property | Id | (Inherited from PolicyBehavior.)
Public property | Subject | Get or set the subject line of the email.
Public property | TemplateName | Get or set the name of the template for the email.
Public property | To | Get or set the addressee of the email.

See Also

HtmlEmailBehavior Class


HtmlEmailBehavior Constructor

[image]

IceLib Dialer Technical Reference
HtmlEmailBehavior Constructor
HtmlEmailBehavior Class See Also Send Feedback
Initializes a new instance of the EmailBehavior class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public HtmlEmailBehavior()
Visual Basic
Public Sub New

See Also

HtmlEmailBehavior Class
HtmlEmailBehavior Members


HtmlEmailBehavior Methods

[image] [image]

IceLib Dialer Technical Reference
HtmlEmailBehavior Methods
HtmlEmailBehavior Class See Also Send Feedback

The HtmlEmailBehavior type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HtmlEmailBehavior Class


HtmlEmailBehavior Properties

[image] [image]

IceLib Dialer Technical Reference
HtmlEmailBehavior Properties
HtmlEmailBehavior Class See Also Send Feedback

The HtmlEmailBehavior type exposes the following members.

Properties

 | Name | Description
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | From | Get or set the sender of the email.
Public property | Id | (Inherited from PolicyBehavior.)
Public property | Subject | Get or set the subject line of the email.
Public property | TemplateName | Get or set the name of the template for the email.
Public property | To | Get or set the addressee of the email.

See Also

HtmlEmailBehavior Class


From Property

[image]

IceLib Dialer Technical Reference
HtmlEmailBehavior..::..From Property
HtmlEmailBehavior Class See Also Send Feedback
Get or set the sender of the email.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string From { get; set; }
Visual Basic
Public Property From As String
    Get
    Set

See Also

HtmlEmailBehavior Class
HtmlEmailBehavior Members


Subject Property

[image]

IceLib Dialer Technical Reference
HtmlEmailBehavior..::..Subject Property
HtmlEmailBehavior Class See Also Send Feedback
Get or set the subject line of the email.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Subject { get; set; }
Visual Basic
Public Property Subject As String
    Get
    Set

See Also

HtmlEmailBehavior Class
HtmlEmailBehavior Members


TemplateName Property

[image]

IceLib Dialer Technical Reference
HtmlEmailBehavior..::..TemplateName Property
HtmlEmailBehavior Class See Also Send Feedback
Get or set the name of the template for the email.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string TemplateName { get; set; }
Visual Basic
Public Property TemplateName As String
    Get
    Set

See Also

HtmlEmailBehavior Class
HtmlEmailBehavior Members


To Property

[image]

IceLib Dialer Technical Reference
HtmlEmailBehavior..::..To Property
HtmlEmailBehavior Class See Also Send Feedback
Get or set the addressee of the email.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string To { get; set; }
Visual Basic
Public Property To As String
    Get
    Set

See Also

HtmlEmailBehavior Class
HtmlEmailBehavior Members


HttpRequestKey Class

[image]

IceLib Dialer Technical Reference
HttpRequestKey Class
Members See Also Send Feedback
A class containing all the information necessary to send a request to the Central Campaign Server's http server.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class HttpRequestKey
Visual Basic
Public NotInheritable Class HttpRequestKey

Remarks

Use the GetHttpRequestKey(ConfigurationId, ServerType) method to obtain an instance of this class.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..HttpRequestKey

See Also

HttpRequestKey Members


HttpRequestKey Members

[image] [image]

IceLib Dialer Technical Reference
HttpRequestKey Members
HttpRequestKey Class Methods Properties See Also Send Feedback

The HttpRequestKey type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AddressToUse | The address that the request should be sent to, protocol and port number included. (ex. http://127.0.0.1:8000)
Public property | Interfaces | The list of interfaces available for the HTTP server to bind to.
Public property | IsExpired | Determines if the key is older than five minutes and is no longer usable.

See Also

HttpRequestKey Class


HttpRequestKey Methods

[image] [image]

IceLib Dialer Technical Reference
HttpRequestKey Methods
HttpRequestKey Class See Also Send Feedback

The HttpRequestKey type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HttpRequestKey Class


HttpRequestKey Properties

[image] [image]

IceLib Dialer Technical Reference
HttpRequestKey Properties
HttpRequestKey Class See Also Send Feedback

The HttpRequestKey type exposes the following members.

Properties

 | Name | Description
Public property | AddressToUse | The address that the request should be sent to, protocol and port number included. (ex. http://127.0.0.1:8000)
Public property | Interfaces | The list of interfaces available for the HTTP server to bind to.
Public property | IsExpired | Determines if the key is older than five minutes and is no longer usable.

See Also

HttpRequestKey Class


AddressToUse Property

[image]

IceLib Dialer Technical Reference
HttpRequestKey..::..AddressToUse Property
HttpRequestKey Class See Also Send Feedback
The address that the request should be sent to, protocol and port number included. (ex. http://127.0.0.1:8000)

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string AddressToUse { get; set; }
Visual Basic
Public Property AddressToUse As String
    Get
    Set

Field Value

The address that the server is listening to. If the server is listening to all interfaces and no particular address has been manually specified, the first address in Interfaces is returned. If the server is not running, an empty string is returned.

See Also

HttpRequestKey Class
HttpRequestKey Members


Interfaces Property

[image]

IceLib Dialer Technical Reference
HttpRequestKey..::..Interfaces Property
HttpRequestKey Class See Also Send Feedback
The list of interfaces available for the HTTP server to bind to.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ReadOnlyCollection<HttpRequestKey..::..HttpInterface> Interfaces { get; private set; }
Visual Basic
Public Property Interfaces As ReadOnlyCollection(Of HttpRequestKey..::..HttpInterface)
    Get
    Private Set

See Also

HttpRequestKey Class
HttpRequestKey Members


IsExpired Property

[image]

IceLib Dialer Technical Reference
HttpRequestKey..::..IsExpired Property
HttpRequestKey Class See Also Send Feedback
Determines if the key is older than five minutes and is no longer usable.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsExpired { get; }
Visual Basic
Public ReadOnly Property IsExpired As Boolean
    Get

See Also

HttpRequestKey Class
HttpRequestKey Members


HttpRequestKey.HttpInterface Class

[image]

IceLib Dialer Technical Reference
HttpRequestKey..::..HttpInterface Class
HttpRequestKey Class Members See Also Send Feedback
A network interface on the Central Campaign Server.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class HttpInterface
Visual Basic
Public Class HttpInterface

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..HttpRequestKey..::..HttpInterface

See Also

HttpRequestKey..::..HttpInterface Members


HttpRequestKey.HttpInterface Members

[image] [image]

IceLib Dialer Technical Reference
HttpRequestKey..::..HttpInterface Members
HttpRequestKey..::..HttpInterface Class Methods Properties See Also Send Feedback

The HttpRequestKey..::..HttpInterface type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Address | The IP address of the interface with protocol and port number included. (ex. http://127.0.0.1:8000)
Public property | Name | The name of the interface. (ex. Local Area Connection)

See Also

HttpRequestKey..::..HttpInterface Class


HttpRequestKey.HttpInterface Methods

[image] [image]

IceLib Dialer Technical Reference
HttpRequestKey..::..HttpInterface Methods
HttpRequestKey..::..HttpInterface Class See Also Send Feedback

The HttpRequestKey..::..HttpInterface type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

HttpRequestKey..::..HttpInterface Class


HttpRequestKey.HttpInterface Properties

[image] [image]

IceLib Dialer Technical Reference
HttpRequestKey..::..HttpInterface Properties
HttpRequestKey..::..HttpInterface Class See Also Send Feedback

The HttpRequestKey..::..HttpInterface type exposes the following members.

Properties

 | Name | Description
Public property | Address | The IP address of the interface with protocol and port number included. (ex. http://127.0.0.1:8000)
Public property | Name | The name of the interface. (ex. Local Area Connection)

See Also

HttpRequestKey..::..HttpInterface Class


Address Property

[image]

IceLib Dialer Technical Reference
HttpRequestKey..::..HttpInterface..::..Address Property
HttpRequestKey..::..HttpInterface Class See Also Send Feedback
The IP address of the interface with protocol and port number included. (ex. http://127.0.0.1:8000)

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Address { get; private set; }
Visual Basic
Public Property Address As String
    Get
    Private Set

See Also

HttpRequestKey..::..HttpInterface Class
HttpRequestKey..::..HttpInterface Members


Name Property

[image]

IceLib Dialer Technical Reference
HttpRequestKey..::..HttpInterface..::..Name Property
HttpRequestKey..::..HttpInterface Class See Also Send Feedback
The name of the interface. (ex. Local Area Connection)

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Name { get; private set; }
Visual Basic
Public Property Name As String
    Get
    Private Set

See Also

HttpRequestKey..::..HttpInterface Class
HttpRequestKey..::..HttpInterface Members


IExpression Interface

[image]

IceLib Dialer Technical Reference
IExpression Interface
Members See Also Send Feedback
The base class of all expression classes used to construct expression trees by subclasses of ContactListCommand.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public interface IExpression : ICloneable
Visual Basic
Public Interface IExpression _
    Inherits ICloneable

See Also

IExpression Members


IExpression Members

[image] [image]

IceLib Dialer Technical Reference
IExpression Members
IExpression Interface Methods See Also Send Feedback

The IExpression type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)

See Also

IExpression Interface


IExpression Methods

[image] [image]

IceLib Dialer Technical Reference
IExpression Methods
IExpression Interface See Also Send Feedback

The IExpression type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Inherited from ICloneable.)

See Also

IExpression Interface


InsertCommand Class

[image]

IceLib Dialer Technical Reference
InsertCommand Class
Members See Also Send Feedback
A command that inserts a new contact into an existing contact list.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class InsertCommand : ContactListCommand
Visual Basic
Public NotInheritable Class InsertCommand _
    Inherits ContactListCommand

Remarks

The Where property is ignored in this type of command.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..ContactListCommand
ININ.IceLib.Configuration.Dialer..::..InsertCommand

See Also

InsertCommand Members


InsertCommand Members

[image] [image]

IceLib Dialer Technical Reference
InsertCommand Members
InsertCommand Class Constructors Methods Properties See Also Send Feedback

The InsertCommand type exposes the following members.

Constructors

 | Name | Description
Public method | InsertCommand | Initializes a new instance of the InsertCommand class.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Overrides ContactListCommand..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetDatabaseType | Retrieves the type of database associated with the contact list's connection. (Inherited from ContactListCommand.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Contact | The contact to insert into the contact list.
Public property | ContactList | The contact list to run this command against. (Inherited from ContactListCommand.)
Public property | Filters | The filter to use in the where predicate. (Inherited from ContactListCommand.)
Public property | RecordsAffected | The number of records affected by this command. If this is a paged SelectCommand, the value reflects the total number of records in the unpaged version. (Inherited from ContactListCommand.)
Public property | TableType | Specifies which database table the command applies to. (Inherited from ContactListCommand.)
Public property | Where | An expression representing a logical predicate with which to filter records. (Inherited from ContactListCommand.)

See Also

InsertCommand Class


InsertCommand Constructor

[image]

IceLib Dialer Technical Reference
InsertCommand Constructor
InsertCommand Class See Also Send Feedback
Initializes a new instance of the InsertCommand class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public InsertCommand(
    ContactListConfiguration contactList
)
Visual Basic
Public Sub New ( _
    contactList As ContactListConfiguration _
)

Parameters

contactList
Type: ININ.IceLib.Configuration.Dialer..::..ContactListConfiguration
The contact list to run this command against.

See Also

InsertCommand Class
InsertCommand Members


InsertCommand Methods

[image] [image]

IceLib Dialer Technical Reference
InsertCommand Methods
InsertCommand Class See Also Send Feedback

The InsertCommand type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Overrides ContactListCommand..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetDatabaseType | Retrieves the type of database associated with the contact list's connection. (Inherited from ContactListCommand.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InsertCommand Class


Clone Method

[image]

IceLib Dialer Technical Reference
InsertCommand..::..Clone Method
InsertCommand Class See Also Send Feedback
Creates a new object that is a copy of the current instance.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object

Return Value

A new object that is a copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

InsertCommand Class
InsertCommand Members


InsertCommand Properties

[image] [image]

IceLib Dialer Technical Reference
InsertCommand Properties
InsertCommand Class See Also Send Feedback

The InsertCommand type exposes the following members.

Properties

 | Name | Description
Public property | Contact | The contact to insert into the contact list.
Public property | ContactList | The contact list to run this command against. (Inherited from ContactListCommand.)
Public property | Filters | The filter to use in the where predicate. (Inherited from ContactListCommand.)
Public property | RecordsAffected | The number of records affected by this command. If this is a paged SelectCommand, the value reflects the total number of records in the unpaged version. (Inherited from ContactListCommand.)
Public property | TableType | Specifies which database table the command applies to. (Inherited from ContactListCommand.)
Public property | Where | An expression representing a logical predicate with which to filter records. (Inherited from ContactListCommand.)

See Also

InsertCommand Class


Contact Property

[image]

IceLib Dialer Technical Reference
InsertCommand..::..Contact Property
InsertCommand Class See Also Send Feedback
The contact to insert into the contact list.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Dictionary<DBColumn, Object> Contact { get; private set; }
Visual Basic
Public Property Contact As Dictionary(Of DBColumn, Object)
    Get
    Private Set

See Also

InsertCommand Class
InsertCommand Members


NumberToDialBehavior Class

[image]

IceLib Dialer Technical Reference
NumberToDialBehavior Class
Members See Also Send Feedback
A PolicyBehavior which sets a different (specific) phone number to be dialed.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class NumberToDialBehavior : PolicyBehavior
Visual Basic
Public NotInheritable Class NumberToDialBehavior _
    Inherits PolicyBehavior

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyBehavior
ININ.IceLib.Configuration.Dialer..::..NumberToDialBehavior

See Also

NumberToDialBehavior Members


NumberToDialBehavior Members

[image] [image]

IceLib Dialer Technical Reference
NumberToDialBehavior Members
NumberToDialBehavior Class Constructors Methods Properties See Also Send Feedback

The NumberToDialBehavior type exposes the following members.

Constructors

 | Name | Description
Public method | NumberToDialBehavior | Initializes a new instance of the NumberToDialBehavior class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | Id | (Inherited from PolicyBehavior.)
Public property | NumberToDial | Get or set the phone number to substitute in for dialing.

See Also

NumberToDialBehavior Class


NumberToDialBehavior Constructor

[image]

IceLib Dialer Technical Reference
NumberToDialBehavior Constructor
NumberToDialBehavior Class See Also Send Feedback
Initializes a new instance of the NumberToDialBehavior class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public NumberToDialBehavior()
Visual Basic
Public Sub New

See Also

NumberToDialBehavior Class
NumberToDialBehavior Members


NumberToDialBehavior Methods

[image] [image]

IceLib Dialer Technical Reference
NumberToDialBehavior Methods
NumberToDialBehavior Class See Also Send Feedback

The NumberToDialBehavior type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NumberToDialBehavior Class


NumberToDialBehavior Properties

[image] [image]

IceLib Dialer Technical Reference
NumberToDialBehavior Properties
NumberToDialBehavior Class See Also Send Feedback

The NumberToDialBehavior type exposes the following members.

Properties

 | Name | Description
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | Id | (Inherited from PolicyBehavior.)
Public property | NumberToDial | Get or set the phone number to substitute in for dialing.

See Also

NumberToDialBehavior Class


NumberToDial Property

[image]

IceLib Dialer Technical Reference
NumberToDialBehavior..::..NumberToDial Property
NumberToDialBehavior Class See Also Send Feedback
Get or set the phone number to substitute in for dialing.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string NumberToDial { get; set; }
Visual Basic
Public Property NumberToDial As String
    Get
    Set

See Also

NumberToDialBehavior Class
NumberToDialBehavior Members


ODSConfiguration Class

[image]

IceLib Dialer Technical Reference
ODSConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for an outbound dialing server.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class ODSConfiguration : EditableListConfigurationObject<ODSConfiguration..::..Property>
Visual Basic
Public Class ODSConfiguration _
    Inherits EditableListConfigurationObject(Of ODSConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ConfigurationObject
ListConfigurationObject
EditableListConfigurationObject<(Of <(<' ODSConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..ODSConfiguration

See Also

ODSConfiguration Members


ODSConfiguration Members

[image] [image]

IceLib Dialer Technical Reference
ODSConfiguration Members
ODSConfiguration Class Methods Properties See Also Send Feedback

The ODSConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' ODSConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' ODSConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ODSConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' ODSConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ODSConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetODSType | Get a list of Outbound Dialer Servers indicating Manual Only Call Server (MOCS) or not
Public method | GetODSTypeAsync | Asynchronously retrieves a list of Outbound Dialer Servers indicating Manual Only Call Server (MOCS) or not
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' ODSConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ODSConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' ODSConfiguration..::..Property >)>)>.)
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' ODSConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' ODSConfiguration..::..Property >)>)>.)
Public method | ToString | (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' ODSConfiguration..::..Property >)>)>.)
Public property | ConfigKey | Indicates whether the ODS is set for Manual Only mode
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | MaximumCallRate | The maximum number of calls that may be placed per second.
Public property | MaximumCalls | The maximum number of active calls allowable at any given time.
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | RevisionLevel | The version number of this object.

See Also

ODSConfiguration Class


ODSConfiguration Methods

[image] [image]

IceLib Dialer Technical Reference
ODSConfiguration Methods
ODSConfiguration Class See Also Send Feedback

The ODSConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' ODSConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' ODSConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ODSConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' ODSConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ODSConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetODSType | Get a list of Outbound Dialer Servers indicating Manual Only Call Server (MOCS) or not
Public method | GetODSTypeAsync | Asynchronously retrieves a list of Outbound Dialer Servers indicating Manual Only Call Server (MOCS) or not
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' ODSConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ODSConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' ODSConfiguration..::..Property >)>)>.)
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' ODSConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' ODSConfiguration..::..Property >)>)>.)
Public method | ToString | (Inherited from ConfigurationObject.)

See Also

ODSConfiguration Class


GetODSType Method

[image]

IceLib Dialer Technical Reference
ODSConfiguration..::..GetODSType Method
ODSConfiguration Class See Also Send Feedback
Get a list of Outbound Dialer Servers indicating Manual Only Call Server (MOCS) or not

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Dictionary<string, bool> GetODSType(
    Dictionary<string, string> ODSConfigurationCol
)
Visual Basic
Public Function GetODSType ( _
    ODSConfigurationCol As Dictionary(Of String, String) _
) As Dictionary(Of String, Boolean)

Parameters

ODSConfigurationCol
Type: System.Collections.Generic..::..Dictionary<(Of <(<'String, String>)>)>
A map of outbound dialer servers. Key=ID, Value=ODSEncryptedKey.

See Also

ODSConfiguration Class
ODSConfiguration Members


GetODSTypeAsync Method

[image]

IceLib Dialer Technical Reference
ODSConfiguration..::..GetODSTypeAsync Method
ODSConfiguration Class See Also Send Feedback
Asynchronously retrieves a list of Outbound Dialer Servers indicating Manual Only Call Server (MOCS) or not

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void GetODSTypeAsync(
    Dictionary<string, string> ODSConfigurationCol,
    EventHandler<AsyncCompletedEventArgs<Dictionary<string, bool>>> completionCallback,
    Object state
)
Visual Basic
Public Sub GetODSTypeAsync ( _
    ODSConfigurationCol As Dictionary(Of String, String), _
    completionCallback As EventHandler(Of AsyncCompletedEventArgs(Of Dictionary(Of String, Boolean))), _
    state As Object _
)

Parameters

ODSConfigurationCol
Type: System.Collections.Generic..::..Dictionary<(Of <(<'String, String>)>)>
A map of outbound dialer servers. Key=ID, Value=ODSEncryptedKey.
completionCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Dictionary<(Of <(<'String, Boolean>)>)>>)>)>>)>)>
completion event handler
state
Type: System..::..Object

See Also

ODSConfiguration Class
ODSConfiguration Members


ODSConfiguration Properties

[image] [image]

IceLib Dialer Technical Reference
ODSConfiguration Properties
ODSConfiguration Class See Also Send Feedback

The ODSConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' ODSConfiguration..::..Property >)>)>.)
Public property | ConfigKey | Indicates whether the ODS is set for Manual Only mode
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | MaximumCallRate | The maximum number of calls that may be placed per second.
Public property | MaximumCalls | The maximum number of active calls allowable at any given time.
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | RevisionLevel | The version number of this object.

See Also

ODSConfiguration Class


ConfigKey Property

[image]

IceLib Dialer Technical Reference
ODSConfiguration..::..ConfigKey Property
ODSConfiguration Class See Also Send Feedback
Indicates whether the ODS is set for Manual Only mode

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<ODSConfiguration..::..Property, string> ConfigKey { get; }
Visual Basic
Public ReadOnly Property ConfigKey As GeneralConfigurationProperty(Of ODSConfiguration..::..Property, String)
    Get

See Also

ODSConfiguration Class
ODSConfiguration Members


IsDefaultObject Property

[image]

IceLib Dialer Technical Reference
ODSConfiguration..::..IsDefaultObject Property
ODSConfiguration Class See Also Send Feedback
Indicates whether this is the default instance of this object type.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsDefaultObject { get; }
Visual Basic
Public ReadOnly Property IsDefaultObject As Boolean
    Get

See Also

ODSConfiguration Class
ODSConfiguration Members


MaximumCallRate Property

[image]

IceLib Dialer Technical Reference
ODSConfiguration..::..MaximumCallRate Property
ODSConfiguration Class See Also Send Feedback
The maximum number of calls that may be placed per second.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<ODSConfiguration..::..Property, int> MaximumCallRate { get; }
Visual Basic
Public ReadOnly Property MaximumCallRate As GeneralConfigurationProperty(Of ODSConfiguration..::..Property, Integer)
    Get

See Also

ODSConfiguration Class
ODSConfiguration Members


MaximumCalls Property

[image]

IceLib Dialer Technical Reference
ODSConfiguration..::..MaximumCalls Property
ODSConfiguration Class See Also Send Feedback
The maximum number of active calls allowable at any given time.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<ODSConfiguration..::..Property, int> MaximumCalls { get; }
Visual Basic
Public ReadOnly Property MaximumCalls As GeneralConfigurationProperty(Of ODSConfiguration..::..Property, Integer)
    Get

See Also

ODSConfiguration Class
ODSConfiguration Members


RevisionLevel Property

[image]

IceLib Dialer Technical Reference
ODSConfiguration..::..RevisionLevel Property
ODSConfiguration Class See Also Send Feedback
The version number of this object.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<ODSConfiguration..::..Property, int> RevisionLevel { get; }
Visual Basic
Public ReadOnly Property RevisionLevel As GeneralConfigurationProperty(Of ODSConfiguration..::..Property, Integer)
    Get

See Also

ODSConfiguration Class
ODSConfiguration Members


ODSConfiguration.Property Enumeration

[image]

IceLib Dialer Technical Reference
ODSConfiguration..::..Property Enumeration
ODSConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Id | 0 | Represents the Id part of the ConfigurationId property.
DisplayName | 1 | Represents the DisplayName part of the ConfigurationId property.
MaximumCallRate | 2 | Represents the MaximumCallRate property.
MaximumCalls | 3 | Represents the MaximumCalls property.
ConfigKey | 4 | Represents the ConfigKey property.
RevisionLevel | 5 | Represents the RevisionLevel property.

See Also


ODSConfigurationList Class

[image]

IceLib Dialer Technical Reference
ODSConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing outbound dialing servers.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class ODSConfigurationList : EditableConfigurationList<ODSConfiguration, ODSConfiguration..::..Property>
Visual Basic
Public Class ODSConfigurationList _
    Inherits EditableConfigurationList(Of ODSConfiguration, ODSConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>
DynamicConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>
EditableConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..ODSConfigurationList

See Also

ODSConfigurationList Members


ODSConfigurationList Members

[image] [image]

IceLib Dialer Technical Reference
ODSConfigurationList Members
ODSConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The ODSConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | ODSConfigurationList | Initializes a new instance of the ODSConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)

See Also

ODSConfigurationList Class


ODSConfigurationList Constructor

[image]

IceLib Dialer Technical Reference
ODSConfigurationList Constructor
ODSConfigurationList Class See Also Send Feedback
Initializes a new instance of the ODSConfigurationList class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ODSConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

ODSConfigurationList Class
ODSConfigurationList Members


ODSConfigurationList Methods

[image] [image]

IceLib Dialer Technical Reference
ODSConfigurationList Methods
ODSConfigurationList Class See Also Send Feedback

The ODSConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ODSConfigurationList Class


ODSConfigurationList Properties

[image] [image]

IceLib Dialer Technical Reference
ODSConfigurationList Properties
ODSConfigurationList Class See Also Send Feedback

The ODSConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)

See Also

ODSConfigurationList Class


ODSConfigurationList Events

[image] [image]

IceLib Dialer Technical Reference
ODSConfigurationList Events
ODSConfigurationList Class See Also Send Feedback

The ODSConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' ODSConfiguration, ODSConfiguration..::..Property >)>)>.)

See Also

ODSConfigurationList Class


ParameterNameValue Class

[image]

IceLib Dialer Technical Reference
ParameterNameValue Class
Members See Also Send Feedback
Parameter Name and Value

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class ParameterNameValue
Visual Basic
Public Class ParameterNameValue

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..ParameterNameValue

See Also

ParameterNameValue Members


ParameterNameValue Members

[image] [image]

IceLib Dialer Technical Reference
ParameterNameValue Members
ParameterNameValue Class Constructors Methods Properties See Also Send Feedback

The ParameterNameValue type exposes the following members.

Constructors

 | Name | Description
Public method | ParameterNameValue(String) | Creates a new instance of the ParameterNameValue class.
Public method | ParameterNameValue(String, String) | Creates a new instance of the ParameterNameValue class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | The Name of the parameter.
Public property | Value | The Value of the parameter.

See Also

ParameterNameValue Class


ParameterNameValue Constructor

[image] [image]

IceLib Dialer Technical Reference
ParameterNameValue Constructor
ParameterNameValue Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ParameterNameValue(String) | Creates a new instance of the ParameterNameValue class.
Public method | ParameterNameValue(String, String) | Creates a new instance of the ParameterNameValue class.

See Also

ParameterNameValue Class
ParameterNameValue Members


ParameterNameValue Constructor (String)

[image]

IceLib Dialer Technical Reference
ParameterNameValue Constructor (String)
ParameterNameValue Class See Also Send Feedback
Creates a new instance of the ParameterNameValue class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ParameterNameValue(
    string paramName
)
Visual Basic
Public Sub New ( _
    paramName As String _
)

Parameters

paramName
Type: System..::..String
The name of the paramter

See Also

ParameterNameValue Class
ParameterNameValue Members
ParameterNameValue Overload


ParameterNameValue Constructor (String, String)

[image]

IceLib Dialer Technical Reference
ParameterNameValue Constructor (String, String)
ParameterNameValue Class See Also Send Feedback
Creates a new instance of the ParameterNameValue class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ParameterNameValue(
    string paramName,
    string paramValue
)
Visual Basic
Public Sub New ( _
    paramName As String, _
    paramValue As String _
)

Parameters

paramName
Type: System..::..String
The name of the paramter
paramValue
Type: System..::..String
The value of the paramter

See Also

ParameterNameValue Class
ParameterNameValue Members
ParameterNameValue Overload


ParameterNameValue Methods

[image] [image]

IceLib Dialer Technical Reference
ParameterNameValue Methods
ParameterNameValue Class See Also Send Feedback

The ParameterNameValue type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterNameValue Class


ParameterNameValue Properties

[image] [image]

IceLib Dialer Technical Reference
ParameterNameValue Properties
ParameterNameValue Class See Also Send Feedback

The ParameterNameValue type exposes the following members.

Properties

 | Name | Description
Public property | Name | The Name of the parameter.
Public property | Value | The Value of the parameter.

See Also

ParameterNameValue Class


Name Property

[image]

IceLib Dialer Technical Reference
ParameterNameValue..::..Name Property
ParameterNameValue Class See Also Send Feedback
The Name of the parameter.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Name { get; private set; }
Visual Basic
Public Property Name As String
    Get
    Private Set

See Also

ParameterNameValue Class
ParameterNameValue Members


Value Property

[image]

IceLib Dialer Technical Reference
ParameterNameValue..::..Value Property
ParameterNameValue Class See Also Send Feedback
The Value of the parameter.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Value { get; private set; }
Visual Basic
Public Property Value As String
    Get
    Private Set

See Also

ParameterNameValue Class
ParameterNameValue Members


PhoneNumberDetailCondition Class

[image]

IceLib Dialer Technical Reference
PhoneNumberDetailCondition Class
Members See Also Send Feedback
A PolicyCondition which will check phone number detail counters of the number being dialed.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class PhoneNumberDetailCondition : PolicyCondition
Visual Basic
Public NotInheritable Class PhoneNumberDetailCondition _
    Inherits PolicyCondition

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyCondition
ININ.IceLib.Configuration.Dialer..::..PhoneNumberDetailCondition

See Also

PhoneNumberDetailCondition Members


PhoneNumberDetailCondition Members

[image] [image]

IceLib Dialer Technical Reference
PhoneNumberDetailCondition Members
PhoneNumberDetailCondition Class Constructors Methods Properties See Also Send Feedback

The PhoneNumberDetailCondition type exposes the following members.

Constructors

 | Name | Description
Public method | PhoneNumberDetailCondition | Initializes a new instance of the PhoneNumberDetailCondition class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConditionType | The type of condition. (Inherited from PolicyCondition.)
Public property | ContactList | The Id of the contact list containing the attribute. The campaign referencing this policy must be using this contact list.
Public property | CounterItem | Get or set which PND counter to check.
Public property | CustomPndName | The name of the custom column to be checked.
Public property | CustomPndType | The data type of the custom column
Public property | DateValue | The matching value for a date-based custom column
Public property | DetailValue | Get or set the value to check for.
Public property | Id | The Id of the condition. (Inherited from PolicyCondition.)
Public property | Negated | When true, the logical result of the condition evaluation is flipped. (Inherited from PolicyCondition.)
Public property | NumericValue | The matching value for a numeric custom column
Public property | Operation | Get or set how to check the counter value versus the condition value.
Public property | StringValue | The matching value for a string custom column
Public property | TimeValue | The matching value for a time-based custom column

See Also

PhoneNumberDetailCondition Class


PhoneNumberDetailCondition Constructor

[image]

IceLib Dialer Technical Reference
PhoneNumberDetailCondition Constructor
PhoneNumberDetailCondition Class See Also Send Feedback
Initializes a new instance of the PhoneNumberDetailCondition class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public PhoneNumberDetailCondition()
Visual Basic
Public Sub New

See Also

PhoneNumberDetailCondition Class
PhoneNumberDetailCondition Members


PhoneNumberDetailCondition Methods

[image] [image]

IceLib Dialer Technical Reference
PhoneNumberDetailCondition Methods
PhoneNumberDetailCondition Class See Also Send Feedback

The PhoneNumberDetailCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PhoneNumberDetailCondition Class


PhoneNumberDetailCondition Properties

[image] [image]

IceLib Dialer Technical Reference
PhoneNumberDetailCondition Properties
PhoneNumberDetailCondition Class See Also Send Feedback

The PhoneNumberDetailCondition type exposes the following members.

Properties

 | Name | Description
Public property | ConditionType | The type of condition. (Inherited from PolicyCondition.)
Public property | ContactList | The Id of the contact list containing the attribute. The campaign referencing this policy must be using this contact list.
Public property | CounterItem | Get or set which PND counter to check.
Public property | CustomPndName | The name of the custom column to be checked.
Public property | CustomPndType | The data type of the custom column
Public property | DateValue | The matching value for a date-based custom column
Public property | DetailValue | Get or set the value to check for.
Public property | Id | The Id of the condition. (Inherited from PolicyCondition.)
Public property | Negated | When true, the logical result of the condition evaluation is flipped. (Inherited from PolicyCondition.)
Public property | NumericValue | The matching value for a numeric custom column
Public property | Operation | Get or set how to check the counter value versus the condition value.
Public property | StringValue | The matching value for a string custom column
Public property | TimeValue | The matching value for a time-based custom column

See Also

PhoneNumberDetailCondition Class


ContactList Property

[image]

IceLib Dialer Technical Reference
PhoneNumberDetailCondition..::..ContactList Property
PhoneNumberDetailCondition Class See Also Send Feedback
The Id of the contact list containing the attribute. The campaign referencing this policy must be using this contact list.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ConfigurationId ContactList { get; set; }
Visual Basic
Public Property ContactList As ConfigurationId
    Get
    Set

See Also

PhoneNumberDetailCondition Class
PhoneNumberDetailCondition Members


CounterItem Property

[image]

IceLib Dialer Technical Reference
PhoneNumberDetailCondition..::..CounterItem Property
PhoneNumberDetailCondition Class See Also Send Feedback
Get or set which PND counter to check.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public PNDCounter CounterItem { get; set; }
Visual Basic
Public Property CounterItem As PNDCounter
    Get
    Set

See Also

PhoneNumberDetailCondition Class
PhoneNumberDetailCondition Members


CustomPndName Property

[image]

IceLib Dialer Technical Reference
PhoneNumberDetailCondition..::..CustomPndName Property
PhoneNumberDetailCondition Class See Also Send Feedback
The name of the custom column to be checked.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string CustomPndName { get; set; }
Visual Basic
Public Property CustomPndName As String
    Get
    Set

See Also

PhoneNumberDetailCondition Class
PhoneNumberDetailCondition Members


CustomPndType Property

[image]

IceLib Dialer Technical Reference
PhoneNumberDetailCondition..::..CustomPndType Property
PhoneNumberDetailCondition Class See Also Send Feedback
The data type of the custom column

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public RecordAttributeType CustomPndType { get; set; }
Visual Basic
Public Property CustomPndType As RecordAttributeType
    Get
    Set

See Also

PhoneNumberDetailCondition Class
PhoneNumberDetailCondition Members


DateValue Property

[image]

IceLib Dialer Technical Reference
PhoneNumberDetailCondition..::..DateValue Property
PhoneNumberDetailCondition Class See Also Send Feedback
The matching value for a date-based custom column

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DateTime DateValue { get; set; }
Visual Basic
Public Property DateValue As DateTime
    Get
    Set

See Also

PhoneNumberDetailCondition Class
PhoneNumberDetailCondition Members


DetailValue Property

[image]

IceLib Dialer Technical Reference
PhoneNumberDetailCondition..::..DetailValue Property
PhoneNumberDetailCondition Class See Also Send Feedback
Get or set the value to check for.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int DetailValue { get; set; }
Visual Basic
Public Property DetailValue As Integer
    Get
    Set

See Also

PhoneNumberDetailCondition Class
PhoneNumberDetailCondition Members


NumericValue Property

[image]

IceLib Dialer Technical Reference
PhoneNumberDetailCondition..::..NumericValue Property
PhoneNumberDetailCondition Class See Also Send Feedback
The matching value for a numeric custom column

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public double NumericValue { get; set; }
Visual Basic
Public Property NumericValue As Double
    Get
    Set

See Also

PhoneNumberDetailCondition Class
PhoneNumberDetailCondition Members


Operation Property

[image]

IceLib Dialer Technical Reference
PhoneNumberDetailCondition..::..Operation Property
PhoneNumberDetailCondition Class See Also Send Feedback
Get or set how to check the counter value versus the condition value.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ComparisonOperator Operation { get; set; }
Visual Basic
Public Property Operation As ComparisonOperator
    Get
    Set

See Also

PhoneNumberDetailCondition Class
PhoneNumberDetailCondition Members


StringValue Property

[image]

IceLib Dialer Technical Reference
PhoneNumberDetailCondition..::..StringValue Property
PhoneNumberDetailCondition Class See Also Send Feedback
The matching value for a string custom column

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string StringValue { get; set; }
Visual Basic
Public Property StringValue As String
    Get
    Set

See Also

PhoneNumberDetailCondition Class
PhoneNumberDetailCondition Members


TimeValue Property

[image]

IceLib Dialer Technical Reference
PhoneNumberDetailCondition..::..TimeValue Property
PhoneNumberDetailCondition Class See Also Send Feedback
The matching value for a time-based custom column

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DateTime TimeValue { get; set; }
Visual Basic
Public Property TimeValue As DateTime
    Get
    Set

See Also

PhoneNumberDetailCondition Class
PhoneNumberDetailCondition Members


PhoneNumberTypeCondition Class

[image]

IceLib Dialer Technical Reference
PhoneNumberTypeCondition Class
Members See Also Send Feedback
A PolicyCondition which will check the phone number type of the number being dialed.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class PhoneNumberTypeCondition : PolicyCondition
Visual Basic
Public NotInheritable Class PhoneNumberTypeCondition _
    Inherits PolicyCondition

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyCondition
ININ.IceLib.Configuration.Dialer..::..PhoneNumberTypeCondition

See Also

PhoneNumberTypeCondition Members


PhoneNumberTypeCondition Members

[image] [image]

IceLib Dialer Technical Reference
PhoneNumberTypeCondition Members
PhoneNumberTypeCondition Class Constructors Methods Properties See Also Send Feedback

The PhoneNumberTypeCondition type exposes the following members.

Constructors

 | Name | Description
Public method | PhoneNumberTypeCondition | Initializes a new instance of the PhoneNumberTypeCondition class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConditionType | The type of condition. (Inherited from PolicyCondition.)
Public property | Id | The Id of the condition. (Inherited from PolicyCondition.)
Public property | Negated | When true, the logical result of the condition evaluation is flipped. (Inherited from PolicyCondition.)
Public property | PhoneNumberTypes | The set of phone number type database Ids that this condition will look for.

See Also

PhoneNumberTypeCondition Class


PhoneNumberTypeCondition Constructor

[image]

IceLib Dialer Technical Reference
PhoneNumberTypeCondition Constructor
PhoneNumberTypeCondition Class See Also Send Feedback
Initializes a new instance of the PhoneNumberTypeCondition class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public PhoneNumberTypeCondition()
Visual Basic
Public Sub New

See Also

PhoneNumberTypeCondition Class
PhoneNumberTypeCondition Members


PhoneNumberTypeCondition Methods

[image] [image]

IceLib Dialer Technical Reference
PhoneNumberTypeCondition Methods
PhoneNumberTypeCondition Class See Also Send Feedback

The PhoneNumberTypeCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PhoneNumberTypeCondition Class


PhoneNumberTypeCondition Properties

[image] [image]

IceLib Dialer Technical Reference
PhoneNumberTypeCondition Properties
PhoneNumberTypeCondition Class See Also Send Feedback

The PhoneNumberTypeCondition type exposes the following members.

Properties

 | Name | Description
Public property | ConditionType | The type of condition. (Inherited from PolicyCondition.)
Public property | Id | The Id of the condition. (Inherited from PolicyCondition.)
Public property | Negated | When true, the logical result of the condition evaluation is flipped. (Inherited from PolicyCondition.)
Public property | PhoneNumberTypes | The set of phone number type database Ids that this condition will look for.

See Also

PhoneNumberTypeCondition Class


PhoneNumberTypes Property

[image]

IceLib Dialer Technical Reference
PhoneNumberTypeCondition..::..PhoneNumberTypes Property
PhoneNumberTypeCondition Class See Also Send Feedback
The set of phone number type database Ids that this condition will look for.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<long> PhoneNumberTypes { get; }
Visual Basic
Public ReadOnly Property PhoneNumberTypes As Collection(Of Long)
    Get

See Also

PhoneNumberTypeCondition Class
PhoneNumberTypeCondition Members
PhoneNumberTypeConfiguration..::..DatabaseId


PhoneNumberTypeConfiguration Class

[image]

IceLib Dialer Technical Reference
PhoneNumberTypeConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for a Dialer phone number type

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class PhoneNumberTypeConfiguration : EditableListConfigurationObject<PhoneNumberTypeConfiguration..::..Property>,
    IExportable
Visual Basic
Public Class PhoneNumberTypeConfiguration _
    Inherits EditableListConfigurationObject(Of PhoneNumberTypeConfiguration..::..Property) _
    Implements IExportable

Inheritance Hierarchy

System..::..Object
ConfigurationObject
ListConfigurationObject
EditableListConfigurationObject<(Of <(<' PhoneNumberTypeConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..PhoneNumberTypeConfiguration

See Also

PhoneNumberTypeConfiguration Members


PhoneNumberTypeConfiguration Members

[image] [image]

IceLib Dialer Technical Reference
PhoneNumberTypeConfiguration Members
PhoneNumberTypeConfiguration Class Methods Properties See Also Send Feedback

The PhoneNumberTypeConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' PhoneNumberTypeConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | ToString | (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | DatabaseId | An internally-maintained Id for use in the contact list database.
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsExporting | Tells whether the current object is being used for exporting
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | RevisionLevel | The current version of this object.

See Also

PhoneNumberTypeConfiguration Class


PhoneNumberTypeConfiguration Methods

[image] [image]

IceLib Dialer Technical Reference
PhoneNumberTypeConfiguration Methods
PhoneNumberTypeConfiguration Class See Also Send Feedback

The PhoneNumberTypeConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' PhoneNumberTypeConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | ToString | (Inherited from ConfigurationObject.)

See Also

PhoneNumberTypeConfiguration Class


PhoneNumberTypeConfiguration Properties

[image] [image]

IceLib Dialer Technical Reference
PhoneNumberTypeConfiguration Properties
PhoneNumberTypeConfiguration Class See Also Send Feedback

The PhoneNumberTypeConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | DatabaseId | An internally-maintained Id for use in the contact list database.
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsExporting | Tells whether the current object is being used for exporting
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | RevisionLevel | The current version of this object.

See Also

PhoneNumberTypeConfiguration Class


DatabaseId Property

[image]

IceLib Dialer Technical Reference
PhoneNumberTypeConfiguration..::..DatabaseId Property
PhoneNumberTypeConfiguration Class See Also Send Feedback
An internally-maintained Id for use in the contact list database.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<PhoneNumberTypeConfiguration..::..Property, long> DatabaseId { get; }
Visual Basic
Public ReadOnly Property DatabaseId As GeneralConfigurationProperty(Of PhoneNumberTypeConfiguration..::..Property, Long)
    Get

See Also

PhoneNumberTypeConfiguration Class
PhoneNumberTypeConfiguration Members


IsDefaultObject Property

[image]

IceLib Dialer Technical Reference
PhoneNumberTypeConfiguration..::..IsDefaultObject Property
PhoneNumberTypeConfiguration Class See Also Send Feedback
Indicates whether this is the default instance of this object type.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsDefaultObject { get; }
Visual Basic
Public ReadOnly Property IsDefaultObject As Boolean
    Get

See Also

PhoneNumberTypeConfiguration Class
PhoneNumberTypeConfiguration Members


IsExporting Property

[image]

IceLib Dialer Technical Reference
PhoneNumberTypeConfiguration..::..IsExporting Property
PhoneNumberTypeConfiguration Class See Also Send Feedback
Tells whether the current object is being used for exporting

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsExporting { get; private set; }
Visual Basic
Public Property IsExporting As Boolean
    Get
    Private Set

See Also

PhoneNumberTypeConfiguration Class
PhoneNumberTypeConfiguration Members


RevisionLevel Property

[image]

IceLib Dialer Technical Reference
PhoneNumberTypeConfiguration..::..RevisionLevel Property
PhoneNumberTypeConfiguration Class See Also Send Feedback
The current version of this object.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<PhoneNumberTypeConfiguration..::..Property, int> RevisionLevel { get; }
Visual Basic
Public ReadOnly Property RevisionLevel As GeneralConfigurationProperty(Of PhoneNumberTypeConfiguration..::..Property, Integer)
    Get

See Also

PhoneNumberTypeConfiguration Class
PhoneNumberTypeConfiguration Members


PhoneNumberTypeConfiguration.Property Enumeration

[image]

IceLib Dialer Technical Reference
PhoneNumberTypeConfiguration..::..Property Enumeration
PhoneNumberTypeConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Id | 0 | Represents the Id part of the ConfigurationId property.
DisplayName | 1 | Represents the DisplayName part of the ConfigurationId property.
DatabaseId | 2 | Represents the DatabaseId property.
RevisionLevel | 3 | Represents the RevisionLevel property.

See Also


PhoneNumberTypeConfigurationList Class

[image]

IceLib Dialer Technical Reference
PhoneNumberTypeConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing phone number types.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class PhoneNumberTypeConfigurationList : EditableConfigurationList<PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property>
Visual Basic
Public Class PhoneNumberTypeConfigurationList _
    Inherits EditableConfigurationList(Of PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>
DynamicConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>
EditableConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..PhoneNumberTypeConfigurationList

See Also

PhoneNumberTypeConfigurationList Members


PhoneNumberTypeConfigurationList Members

[image] [image]

IceLib Dialer Technical Reference
PhoneNumberTypeConfigurationList Members
PhoneNumberTypeConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The PhoneNumberTypeConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | PhoneNumberTypeConfigurationList | Creates a new instance of the PhoneNumberTypeConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)

See Also

PhoneNumberTypeConfigurationList Class


PhoneNumberTypeConfigurationList Constructor

[image]

IceLib Dialer Technical Reference
PhoneNumberTypeConfigurationList Constructor
PhoneNumberTypeConfigurationList Class See Also Send Feedback
Creates a new instance of the PhoneNumberTypeConfigurationList class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public PhoneNumberTypeConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ConfigurationManager
The configuration manager.

See Also

PhoneNumberTypeConfigurationList Class
PhoneNumberTypeConfigurationList Members


PhoneNumberTypeConfigurationList Methods

[image] [image]

IceLib Dialer Technical Reference
PhoneNumberTypeConfigurationList Methods
PhoneNumberTypeConfigurationList Class See Also Send Feedback

The PhoneNumberTypeConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PhoneNumberTypeConfigurationList Class


PhoneNumberTypeConfigurationList Properties

[image] [image]

IceLib Dialer Technical Reference
PhoneNumberTypeConfigurationList Properties
PhoneNumberTypeConfigurationList Class See Also Send Feedback

The PhoneNumberTypeConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)

See Also

PhoneNumberTypeConfigurationList Class


PhoneNumberTypeConfigurationList Events

[image] [image]

IceLib Dialer Technical Reference
PhoneNumberTypeConfigurationList Events
PhoneNumberTypeConfigurationList Class See Also Send Feedback

The PhoneNumberTypeConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' PhoneNumberTypeConfiguration, PhoneNumberTypeConfiguration..::..Property >)>)>.)

See Also

PhoneNumberTypeConfigurationList Class


Policy Class

[image]

IceLib Dialer Technical Reference
Policy Class
Members See Also Send Feedback
A rule that provides control over the processing of individual contact records.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class Policy : IDeepCloneable
Visual Basic
Public Class Policy _
    Implements IDeepCloneable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..Policy

See Also

Policy Members


Policy Members

[image] [image]

IceLib Dialer Technical Reference
Policy Members
Policy Class Constructors Methods Properties See Also Send Feedback

The Policy type exposes the following members.

Constructors

 | Name | Description
Public method | Policy | Creates a new instance of the Policy class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Behaviors | The list of behaviors to perform when conditions are satisfied.
Public property | Conditions | The list of conditions that must be satisfied in order to perform behaviors.
Public property | Enabled | Specifies whether the system will include this policy when evaluating the policy set.
Public property | EvaluationMode | Determines the extent of policy conditions that must be satisfied in order to perform behaviors.
Public property | Id | The ID of this policy.
Public property | Index | The policy's number in the order of policies contained in the policy set.
Public property | PolicyType | Determines at what point in the call the policy will be evaluated.

See Also

Policy Class


Policy Constructor

[image]

IceLib Dialer Technical Reference
Policy Constructor
Policy Class See Also Send Feedback
Creates a new instance of the Policy class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Policy()
Visual Basic
Public Sub New

See Also

Policy Class
Policy Members


Policy Methods

[image] [image]

IceLib Dialer Technical Reference
Policy Methods
Policy Class See Also Send Feedback

The Policy type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Policy Class


Policy Properties

[image] [image]

IceLib Dialer Technical Reference
Policy Properties
Policy Class See Also Send Feedback

The Policy type exposes the following members.

Properties

 | Name | Description
Public property | Behaviors | The list of behaviors to perform when conditions are satisfied.
Public property | Conditions | The list of conditions that must be satisfied in order to perform behaviors.
Public property | Enabled | Specifies whether the system will include this policy when evaluating the policy set.
Public property | EvaluationMode | Determines the extent of policy conditions that must be satisfied in order to perform behaviors.
Public property | Id | The ID of this policy.
Public property | Index | The policy's number in the order of policies contained in the policy set.
Public property | PolicyType | Determines at what point in the call the policy will be evaluated.

See Also

Policy Class


Behaviors Property

[image]

IceLib Dialer Technical Reference
Policy..::..Behaviors Property
Policy Class See Also Send Feedback
The list of behaviors to perform when conditions are satisfied.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<PolicyBehavior> Behaviors { get; private set; }
Visual Basic
Public Property Behaviors As Collection(Of PolicyBehavior)
    Get
    Private Set

See Also

Policy Class
Policy Members


Conditions Property

[image]

IceLib Dialer Technical Reference
Policy..::..Conditions Property
Policy Class See Also Send Feedback
The list of conditions that must be satisfied in order to perform behaviors.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<PolicyCondition> Conditions { get; private set; }
Visual Basic
Public Property Conditions As Collection(Of PolicyCondition)
    Get
    Private Set

See Also

Policy Class
Policy Members


Enabled Property

[image]

IceLib Dialer Technical Reference
Policy..::..Enabled Property
Policy Class See Also Send Feedback
Specifies whether the system will include this policy when evaluating the policy set.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set

See Also

Policy Class
Policy Members


EvaluationMode Property

[image]

IceLib Dialer Technical Reference
Policy..::..EvaluationMode Property
Policy Class See Also Send Feedback
Determines the extent of policy conditions that must be satisfied in order to perform behaviors.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public PolicyEvaluationMode EvaluationMode { get; set; }
Visual Basic
Public Property EvaluationMode As PolicyEvaluationMode
    Get
    Set

See Also

Policy Class
Policy Members


Id Property

[image]

IceLib Dialer Technical Reference
Policy..::..Id Property
Policy Class See Also Send Feedback
The ID of this policy.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ConfigurationId Id { get; set; }
Visual Basic
Public Property Id As ConfigurationId
    Get
    Set

See Also

Policy Class
Policy Members


Index Property

[image]

IceLib Dialer Technical Reference
Policy..::..Index Property
Policy Class See Also Send Feedback
The policy's number in the order of policies contained in the policy set.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int Index { get; set; }
Visual Basic
Public Property Index As Integer
    Get
    Set

See Also

Policy Class
Policy Members


PolicyType Property

[image]

IceLib Dialer Technical Reference
Policy..::..PolicyType Property
Policy Class See Also Send Feedback
Determines at what point in the call the policy will be evaluated.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public PolicyType PolicyType { get; set; }
Visual Basic
Public Property PolicyType As PolicyType
    Get
    Set

See Also

Policy Class
Policy Members


PolicyBehavior Class

[image]

IceLib Dialer Technical Reference
PolicyBehavior Class
Members See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public abstract class PolicyBehavior : IDeepCloneable
Visual Basic
Public MustInherit Class PolicyBehavior _
    Implements IDeepCloneable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyBehavior
ININ.IceLib.Configuration.Dialer..::..AgentlessActionBehavior
ININ.IceLib.Configuration.Dialer..::..AttributeBehavior
ININ.IceLib.Configuration.Dialer..::..CallAnalysisBehavior
ININ.IceLib.Configuration.Dialer..::..CallAttributeBehavior
ININ.IceLib.Configuration.Dialer..::..CallbackBehavior
ININ.IceLib.Configuration.Dialer..::..CallingPartyBehavior
ININ.IceLib.Configuration.Dialer..::..CallRoutingBehavior
ININ.IceLib.Configuration.Dialer..::..ContactColumnsBehavior
ININ.IceLib.Configuration.Dialer..::..CustomDataBehavior
ININ.IceLib.Configuration.Dialer..::..CustomStoredProcBehavior
ININ.IceLib.Configuration.Dialer..::..DispositionBehavior
ININ.IceLib.Configuration.Dialer..::..DncUpdateBehavior
ININ.IceLib.Configuration.Dialer..::..EmailBehavior
ININ.IceLib.Configuration.Dialer..::..EventLogBehavior
ININ.IceLib.Configuration.Dialer..::..HandlerBehavior
ININ.IceLib.Configuration.Dialer..::..HtmlEmailBehavior
ININ.IceLib.Configuration.Dialer..::..NumberToDialBehavior
ININ.IceLib.Configuration.Dialer..::..PreviewDialingBehavior
ININ.IceLib.Configuration.Dialer..::..SMSBehavior

See Also

PolicyBehavior Members


PolicyBehavior Members

[image] [image]

IceLib Dialer Technical Reference
PolicyBehavior Members
PolicyBehavior Class Constructors Methods Properties See Also Send Feedback

The PolicyBehavior type exposes the following members.

Constructors

 | Name | Description
Public method | PolicyBehavior | Initializes a new instance of the PolicyBehavior class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BehaviorType | The type of action the behavior performs.
Public property | Id |

See Also

PolicyBehavior Class


PolicyBehavior Constructor

[image]

IceLib Dialer Technical Reference
PolicyBehavior Constructor
PolicyBehavior Class See Also Send Feedback
Initializes a new instance of the PolicyBehavior class

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public PolicyBehavior(
    PolicyBehaviorType type
)
Visual Basic
Public Sub New ( _
    type As PolicyBehaviorType _
)

Parameters

type
Type: ININ.IceLib.Configuration.Dialer.DataTypes..::..PolicyBehaviorType

See Also

PolicyBehavior Class
PolicyBehavior Members


PolicyBehavior Methods

[image] [image]

IceLib Dialer Technical Reference
PolicyBehavior Methods
PolicyBehavior Class See Also Send Feedback

The PolicyBehavior type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PolicyBehavior Class


PolicyBehavior Properties

[image] [image]

IceLib Dialer Technical Reference
PolicyBehavior Properties
PolicyBehavior Class See Also Send Feedback

The PolicyBehavior type exposes the following members.

Properties

 | Name | Description
Public property | BehaviorType | The type of action the behavior performs.
Public property | Id |

See Also

PolicyBehavior Class


BehaviorType Property

[image]

IceLib Dialer Technical Reference
PolicyBehavior..::..BehaviorType Property
PolicyBehavior Class See Also Send Feedback
The type of action the behavior performs.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public PolicyBehaviorType BehaviorType { get; set; }
Visual Basic
Public Property BehaviorType As PolicyBehaviorType
    Get
    Set

See Also

PolicyBehavior Class
PolicyBehavior Members


Id Property

[image]

IceLib Dialer Technical Reference
PolicyBehavior..::..Id Property
PolicyBehavior Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ConfigurationId Id { get; set; }
Visual Basic
Public Property Id As ConfigurationId
    Get
    Set

See Also

PolicyBehavior Class
PolicyBehavior Members


PolicyCondition Class

[image]

IceLib Dialer Technical Reference
PolicyCondition Class
Members See Also Send Feedback
A logical condition evaluated as part of a policy.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public abstract class PolicyCondition : IDeepCloneable
Visual Basic
Public MustInherit Class PolicyCondition _
    Implements IDeepCloneable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyCondition
ININ.IceLib.Configuration.Dialer..::..AbandonCondition
ININ.IceLib.Configuration.Dialer..::..AttributeCondition
ININ.IceLib.Configuration.Dialer..::..CallAnalysisCondition
ININ.IceLib.Configuration.Dialer..::..CallAttributeCondition
ININ.IceLib.Configuration.Dialer..::..CallCategoryCondition
ININ.IceLib.Configuration.Dialer..::..CallDialingModeCondition
ININ.IceLib.Configuration.Dialer..::..CallDurationCondition
ININ.IceLib.Configuration.Dialer..::..DispositionCondition
ININ.IceLib.Configuration.Dialer..::..PhoneNumberDetailCondition
ININ.IceLib.Configuration.Dialer..::..PhoneNumberTypeCondition
ININ.IceLib.Configuration.Dialer..::..StatCondition
ININ.IceLib.Configuration.Dialer..::..TimeCondition

See Also

PolicyCondition Members


PolicyCondition Members

[image] [image]

IceLib Dialer Technical Reference
PolicyCondition Members
PolicyCondition Class Constructors Methods Properties See Also Send Feedback

The PolicyCondition type exposes the following members.

Constructors

 | Name | Description
Public method | PolicyCondition | Creates a new instance of the PolicyCondition class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConditionType | The type of condition.
Public property | Id | The Id of the condition.
Public property | Negated | When true, the logical result of the condition evaluation is flipped.

See Also

PolicyCondition Class


PolicyCondition Constructor

[image]

IceLib Dialer Technical Reference
PolicyCondition Constructor
PolicyCondition Class See Also Send Feedback
Creates a new instance of the PolicyCondition class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public PolicyCondition(
    PolicyConditionType type
)
Visual Basic
Public Sub New ( _
    type As PolicyConditionType _
)

Parameters

type
Type: ININ.IceLib.Configuration.Dialer.DataTypes..::..PolicyConditionType
The type of condition.

See Also

PolicyCondition Class
PolicyCondition Members


PolicyCondition Methods

[image] [image]

IceLib Dialer Technical Reference
PolicyCondition Methods
PolicyCondition Class See Also Send Feedback

The PolicyCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PolicyCondition Class


PolicyCondition Properties

[image] [image]

IceLib Dialer Technical Reference
PolicyCondition Properties
PolicyCondition Class See Also Send Feedback

The PolicyCondition type exposes the following members.

Properties

 | Name | Description
Public property | ConditionType | The type of condition.
Public property | Id | The Id of the condition.
Public property | Negated | When true, the logical result of the condition evaluation is flipped.

See Also

PolicyCondition Class


ConditionType Property

[image]

IceLib Dialer Technical Reference
PolicyCondition..::..ConditionType Property
PolicyCondition Class See Also Send Feedback
The type of condition.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public PolicyConditionType ConditionType { get; private set; }
Visual Basic
Public Property ConditionType As PolicyConditionType
    Get
    Private Set

See Also

PolicyCondition Class
PolicyCondition Members


Id Property

[image]

IceLib Dialer Technical Reference
PolicyCondition..::..Id Property
PolicyCondition Class See Also Send Feedback
The Id of the condition.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ConfigurationId Id { get; set; }
Visual Basic
Public Property Id As ConfigurationId
    Get
    Set

See Also

PolicyCondition Class
PolicyCondition Members


Negated Property

[image]

IceLib Dialer Technical Reference
PolicyCondition..::..Negated Property
PolicyCondition Class See Also Send Feedback
When true, the logical result of the condition evaluation is flipped.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool Negated { get; set; }
Visual Basic
Public Property Negated As Boolean
    Get
    Set

See Also

PolicyCondition Class
PolicyCondition Members


PolicySetConfiguration Class

[image]

IceLib Dialer Technical Reference
PolicySetConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for a Dialer Policy Set.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class PolicySetConfiguration : EditableListConfigurationObject<PolicySetConfiguration..::..Property>,
    IExportable
Visual Basic
Public Class PolicySetConfiguration _
    Inherits EditableListConfigurationObject(Of PolicySetConfiguration..::..Property) _
    Implements IExportable

Inheritance Hierarchy

System..::..Object
ConfigurationObject
ListConfigurationObject
EditableListConfigurationObject<(Of <(<' PolicySetConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..PolicySetConfiguration

See Also

PolicySetConfiguration Members


PolicySetConfiguration Members

[image] [image]

IceLib Dialer Technical Reference
PolicySetConfiguration Members
PolicySetConfiguration Class Methods Properties See Also Send Feedback

The PolicySetConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' PolicySetConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' PolicySetConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' PolicySetConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' PolicySetConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' PolicySetConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' PolicySetConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' PolicySetConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' PolicySetConfiguration..::..Property >)>)>.)
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' PolicySetConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' PolicySetConfiguration..::..Property >)>)>.)
Public method | ToString | (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' PolicySetConfiguration..::..Property >)>)>.)
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsExporting | Tells whether the current object is being used for exporting
Public property | IsLocked | Determines whether the policy set is locked from changes by a non-master administrator.
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | Policies | The list of policies contained in this policy set.
Public property | RevisionLevel | The current version of this object.

See Also

PolicySetConfiguration Class


PolicySetConfiguration Methods

[image] [image]

IceLib Dialer Technical Reference
PolicySetConfiguration Methods
PolicySetConfiguration Class See Also Send Feedback

The PolicySetConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' PolicySetConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' PolicySetConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' PolicySetConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' PolicySetConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' PolicySetConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' PolicySetConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' PolicySetConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' PolicySetConfiguration..::..Property >)>)>.)
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' PolicySetConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' PolicySetConfiguration..::..Property >)>)>.)
Public method | ToString | (Inherited from ConfigurationObject.)

See Also

PolicySetConfiguration Class


PolicySetConfiguration Properties

[image] [image]

IceLib Dialer Technical Reference
PolicySetConfiguration Properties
PolicySetConfiguration Class See Also Send Feedback

The PolicySetConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' PolicySetConfiguration..::..Property >)>)>.)
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsExporting | Tells whether the current object is being used for exporting
Public property | IsLocked | Determines whether the policy set is locked from changes by a non-master administrator.
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | Policies | The list of policies contained in this policy set.
Public property | RevisionLevel | The current version of this object.

See Also

PolicySetConfiguration Class


IsDefaultObject Property

[image]

IceLib Dialer Technical Reference
PolicySetConfiguration..::..IsDefaultObject Property
PolicySetConfiguration Class See Also Send Feedback
Indicates whether this is the default instance of this object type.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsDefaultObject { get; }
Visual Basic
Public ReadOnly Property IsDefaultObject As Boolean
    Get

See Also

PolicySetConfiguration Class
PolicySetConfiguration Members


IsExporting Property

[image]

IceLib Dialer Technical Reference
PolicySetConfiguration..::..IsExporting Property
PolicySetConfiguration Class See Also Send Feedback
Tells whether the current object is being used for exporting

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsExporting { get; private set; }
Visual Basic
Public Property IsExporting As Boolean
    Get
    Private Set

See Also

PolicySetConfiguration Class
PolicySetConfiguration Members


IsLocked Property

[image]

IceLib Dialer Technical Reference
PolicySetConfiguration..::..IsLocked Property
PolicySetConfiguration Class See Also Send Feedback
Determines whether the policy set is locked from changes by a non-master administrator.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<PolicySetConfiguration..::..Property, bool> IsLocked { get; }
Visual Basic
Public ReadOnly Property IsLocked As GeneralConfigurationProperty(Of PolicySetConfiguration..::..Property, Boolean)
    Get

See Also

PolicySetConfiguration Class
PolicySetConfiguration Members


Policies Property

[image]

IceLib Dialer Technical Reference
PolicySetConfiguration..::..Policies Property
PolicySetConfiguration Class See Also Send Feedback
The list of policies contained in this policy set.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<PolicySetConfiguration..::..Property, Collection<Policy>> Policies { get; }
Visual Basic
Public ReadOnly Property Policies As GeneralConfigurationProperty(Of PolicySetConfiguration..::..Property, Collection(Of Policy))
    Get

See Also

PolicySetConfiguration Class
PolicySetConfiguration Members


RevisionLevel Property

[image]

IceLib Dialer Technical Reference
PolicySetConfiguration..::..RevisionLevel Property
PolicySetConfiguration Class See Also Send Feedback
The current version of this object.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<PolicySetConfiguration..::..Property, int> RevisionLevel { get; }
Visual Basic
Public ReadOnly Property RevisionLevel As GeneralConfigurationProperty(Of PolicySetConfiguration..::..Property, Integer)
    Get

See Also

PolicySetConfiguration Class
PolicySetConfiguration Members


PolicySetConfiguration.Property Enumeration

[image]

IceLib Dialer Technical Reference
PolicySetConfiguration..::..Property Enumeration
PolicySetConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Id | 0 | Represents the Id part of the ConfigurationId property.
DisplayName | 1 | Represents the DisplayName part of the ConfigurationId property.
IsLocked | 2 | Represents the IsLocked property.
Policies | 3 | Represents the Policies property
RevisionLevel | 4 | Represents the RevisionLevel property.

See Also


PolicySetConfigurationList Class

[image]

IceLib Dialer Technical Reference
PolicySetConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing policy set configuration objects.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class PolicySetConfigurationList : EditableConfigurationList<PolicySetConfiguration, PolicySetConfiguration..::..Property>
Visual Basic
Public Class PolicySetConfigurationList _
    Inherits EditableConfigurationList(Of PolicySetConfiguration, PolicySetConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>
DynamicConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>
EditableConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..PolicySetConfigurationList

See Also

PolicySetConfigurationList Members


PolicySetConfigurationList Members

[image] [image]

IceLib Dialer Technical Reference
PolicySetConfigurationList Members
PolicySetConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The PolicySetConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | PolicySetConfigurationList | Initializes a new instance of the PolicySetConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)

See Also

PolicySetConfigurationList Class


PolicySetConfigurationList Constructor

[image]

IceLib Dialer Technical Reference
PolicySetConfigurationList Constructor
PolicySetConfigurationList Class See Also Send Feedback
Initializes a new instance of the PolicySetConfigurationList class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public PolicySetConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

PolicySetConfigurationList Class
PolicySetConfigurationList Members


PolicySetConfigurationList Methods

[image] [image]

IceLib Dialer Technical Reference
PolicySetConfigurationList Methods
PolicySetConfigurationList Class See Also Send Feedback

The PolicySetConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PolicySetConfigurationList Class


PolicySetConfigurationList Properties

[image] [image]

IceLib Dialer Technical Reference
PolicySetConfigurationList Properties
PolicySetConfigurationList Class See Also Send Feedback

The PolicySetConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)

See Also

PolicySetConfigurationList Class


PolicySetConfigurationList Events

[image] [image]

IceLib Dialer Technical Reference
PolicySetConfigurationList Events
PolicySetConfigurationList Class See Also Send Feedback

The PolicySetConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' PolicySetConfiguration, PolicySetConfiguration..::..Property >)>)>.)

See Also

PolicySetConfigurationList Class


PreviewDialingBehavior Class

[image]

IceLib Dialer Technical Reference
PreviewDialingBehavior Class
Members See Also Send Feedback
A PolicyBehavior which sets the Preview Dialing information for the call.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class PreviewDialingBehavior : PolicyBehavior
Visual Basic
Public NotInheritable Class PreviewDialingBehavior _
    Inherits PolicyBehavior

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyBehavior
ININ.IceLib.Configuration.Dialer..::..PreviewDialingBehavior

See Also

PreviewDialingBehavior Members


PreviewDialingBehavior Members

[image] [image]

IceLib Dialer Technical Reference
PreviewDialingBehavior Members
PreviewDialingBehavior Class Constructors Methods Properties See Also Send Feedback

The PreviewDialingBehavior type exposes the following members.

Constructors

 | Name | Description
Public method | PreviewDialingBehavior | Initializes a new instance of the PreviewDialingBehavior class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | EnableMaxPreviewTime | Gets or sets whether the interaction will enforce a maximum preview time.
Public property | Id | (Inherited from PolicyBehavior.)
Public property | MaxPreviewSeconds | Gets or sets the maximum number of seconds for which the interaction can be previewed.

See Also

PreviewDialingBehavior Class


PreviewDialingBehavior Constructor

[image]

IceLib Dialer Technical Reference
PreviewDialingBehavior Constructor
PreviewDialingBehavior Class See Also Send Feedback
Initializes a new instance of the PreviewDialingBehavior class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public PreviewDialingBehavior()
Visual Basic
Public Sub New

See Also

PreviewDialingBehavior Class
PreviewDialingBehavior Members


PreviewDialingBehavior Methods

[image] [image]

IceLib Dialer Technical Reference
PreviewDialingBehavior Methods
PreviewDialingBehavior Class See Also Send Feedback

The PreviewDialingBehavior type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PreviewDialingBehavior Class


PreviewDialingBehavior Properties

[image] [image]

IceLib Dialer Technical Reference
PreviewDialingBehavior Properties
PreviewDialingBehavior Class See Also Send Feedback

The PreviewDialingBehavior type exposes the following members.

Properties

 | Name | Description
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | EnableMaxPreviewTime | Gets or sets whether the interaction will enforce a maximum preview time.
Public property | Id | (Inherited from PolicyBehavior.)
Public property | MaxPreviewSeconds | Gets or sets the maximum number of seconds for which the interaction can be previewed.

See Also

PreviewDialingBehavior Class


EnableMaxPreviewTime Property

[image]

IceLib Dialer Technical Reference
PreviewDialingBehavior..::..EnableMaxPreviewTime Property
PreviewDialingBehavior Class See Also Send Feedback
Gets or sets whether the interaction will enforce a maximum preview time.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool EnableMaxPreviewTime { get; set; }
Visual Basic
Public Property EnableMaxPreviewTime As Boolean
    Get
    Set

See Also

PreviewDialingBehavior Class
PreviewDialingBehavior Members


MaxPreviewSeconds Property

[image]

IceLib Dialer Technical Reference
PreviewDialingBehavior..::..MaxPreviewSeconds Property
PreviewDialingBehavior Class See Also Send Feedback
Gets or sets the maximum number of seconds for which the interaction can be previewed.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int MaxPreviewSeconds { get; set; }
Visual Basic
Public Property MaxPreviewSeconds As Integer
    Get
    Set

Remarks

After MaxPreviewSeconds seconds have passed the preview interaction will be automatically placed.

See Also

PreviewDialingBehavior Class
PreviewDialingBehavior Members


PropertyDescriptionAttribute Class

[image]

IceLib Dialer Technical Reference
PropertyDescriptionAttribute Class
Members Example See Also Send Feedback
Attribute specifying names and descriptions for object properties

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class PropertyDescriptionAttribute : Attribute
Visual Basic
Public Class PropertyDescriptionAttribute _
    Inherits Attribute

Examples

This sample shows how to retrieve a description for a campaign property.
CopyC#
public string GetCampaignPropertyDescription(CampaignConfiguration.Property property)
{
    System.Reflection.FieldInfo targetField = typeof(CampaignConfiguration.Property).GetField(property.ToString());
    object[] attributes = targetField.GetCustomAttributes(typeof(PropertyDescriptionAttribute), false);

    //return an empty string if the property doesn't have a property description attribute
    if (attributes.Length == 0)
        return string.empty;

    PropertyDescriptionAttribute propertyDescription = (PropertyDescriptionAttribute)attributes[0];
    return propertyDescription.Description;
}

Inheritance Hierarchy

System..::..Object
System..::..Attribute
ININ.IceLib.Configuration.Dialer..::..PropertyDescriptionAttribute

See Also

PropertyDescriptionAttribute Members


PropertyDescriptionAttribute Members

[image] [image]

IceLib Dialer Technical Reference
PropertyDescriptionAttribute Members
PropertyDescriptionAttribute Class Methods Fields Properties See Also Send Feedback

The PropertyDescriptionAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

 | Name | Description
Public field | Description | The description of the property.
Public field | Name | The friendly display name of the property.
Public field | ValueType | The data type of the property's value.

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

PropertyDescriptionAttribute Class


PropertyDescriptionAttribute Fields

[image] [image]

IceLib Dialer Technical Reference
PropertyDescriptionAttribute Fields
PropertyDescriptionAttribute Class See Also Send Feedback

The PropertyDescriptionAttribute type exposes the following members.

Fields

 | Name | Description
Public field | Description | The description of the property.
Public field | Name | The friendly display name of the property.
Public field | ValueType | The data type of the property's value.

See Also

PropertyDescriptionAttribute Class


Description Field

[image]

IceLib Dialer Technical Reference
PropertyDescriptionAttribute..::..Description Field
PropertyDescriptionAttribute Class See Also Send Feedback
The description of the property.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly string Description
Visual Basic
Public ReadOnly Description As String

See Also

PropertyDescriptionAttribute Class
PropertyDescriptionAttribute Members


Name Field

[image]

IceLib Dialer Technical Reference
PropertyDescriptionAttribute..::..Name Field
PropertyDescriptionAttribute Class See Also Send Feedback
The friendly display name of the property.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly string Name
Visual Basic
Public ReadOnly Name As String

See Also

PropertyDescriptionAttribute Class
PropertyDescriptionAttribute Members


ValueType Field

[image]

IceLib Dialer Technical Reference
PropertyDescriptionAttribute..::..ValueType Field
PropertyDescriptionAttribute Class See Also Send Feedback
The data type of the property's value.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly Type ValueType
Visual Basic
Public ReadOnly ValueType As Type

See Also

PropertyDescriptionAttribute Class
PropertyDescriptionAttribute Members


PropertyDescriptionAttribute Methods

[image] [image]

IceLib Dialer Technical Reference
PropertyDescriptionAttribute Methods
PropertyDescriptionAttribute Class See Also Send Feedback

The PropertyDescriptionAttribute type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PropertyDescriptionAttribute Class


PropertyDescriptionAttribute Properties

[image] [image]

IceLib Dialer Technical Reference
PropertyDescriptionAttribute Properties
PropertyDescriptionAttribute Class See Also Send Feedback

The PropertyDescriptionAttribute type exposes the following members.

Properties

 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

PropertyDescriptionAttribute Class


ResourceType Enumeration

[image]

IceLib Dialer Technical Reference
ResourceType Enumeration
See Also Send Feedback
Types of files that can be uploaded to the central campaign server.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum ResourceType
Visual Basic
Public Enumeration ResourceType

Members

Member name | Value | Description
Wave | 0 | A .wav audio file
UDL | 1 | A .udl file containing a database connection string.
TimezoneMapping | 2 | A timezone map dataset file
Fax | 3 | A .i3f fax file
TemplateName | 4 | A html email template file

See Also


Rule Class

[image]

IceLib Dialer Technical Reference
Rule Class
Members See Also Send Feedback
A class representing a group of actions to be executed upon satisfaction of a specified condition.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public abstract class Rule : IDeepCloneable
Visual Basic
Public MustInherit Class Rule _
    Implements IDeepCloneable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..Rule
ININ.IceLib.Configuration.Dialer..::..EventRule
ININ.IceLib.Configuration.Dialer..::..StatRule
ININ.IceLib.Configuration.Dialer..::..TimeRule

See Also

Rule Members


Rule Members

[image] [image]

IceLib Dialer Technical Reference
Rule Members
Rule Class Methods Properties See Also Send Feedback

The Rule type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Actions | The collection of Actions to perform when this Rule's conditions are met
Public property | Enabled | Toggle evaluation/execution of this rule.
Public property | Groups | Named rule groups (within the parent RuleSetConfiguration) to which this rule belongs.
Public property | Id | The Id of the Rule.
Public property | IgnoreGroups | Specifies whether this rule should be evaluated no matter which group is active.
Public property | InAllGroups | Specifies whether this rule is a member of all rule groups of the rule set it belongs to.
Public property | Index | Specifies the order to display and execute this rule in relation to other rules in the parent rule set.
Public property | InStartupGroup | Specifies whether this rule is a member of the unnamed group that the rule set evaluates first.
Public property | Repetition | Specifies how often the rule should be re-evaluated.
Public property | TerminateOnAction | Specifies the manner in which rule evaluation should be stopped after this rule runs its actions.

See Also

Rule Class


Rule Methods

[image] [image]

IceLib Dialer Technical Reference
Rule Methods
Rule Class See Also Send Feedback

The Rule type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Rule Class


Rule Properties

[image] [image]

IceLib Dialer Technical Reference
Rule Properties
Rule Class See Also Send Feedback

The Rule type exposes the following members.

Properties

 | Name | Description
Public property | Actions | The collection of Actions to perform when this Rule's conditions are met
Public property | Enabled | Toggle evaluation/execution of this rule.
Public property | Groups | Named rule groups (within the parent RuleSetConfiguration) to which this rule belongs.
Public property | Id | The Id of the Rule.
Public property | IgnoreGroups | Specifies whether this rule should be evaluated no matter which group is active.
Public property | InAllGroups | Specifies whether this rule is a member of all rule groups of the rule set it belongs to.
Public property | Index | Specifies the order to display and execute this rule in relation to other rules in the parent rule set.
Public property | InStartupGroup | Specifies whether this rule is a member of the unnamed group that the rule set evaluates first.
Public property | Repetition | Specifies how often the rule should be re-evaluated.
Public property | TerminateOnAction | Specifies the manner in which rule evaluation should be stopped after this rule runs its actions.

See Also

Rule Class


Actions Property

[image]

IceLib Dialer Technical Reference
Rule..::..Actions Property
Rule Class See Also Send Feedback
The collection of Actions to perform when this Rule's conditions are met

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<RuleAction> Actions { get; private set; }
Visual Basic
Public Property Actions As Collection(Of RuleAction)
    Get
    Private Set

See Also

Rule Class
Rule Members


Enabled Property

[image]

IceLib Dialer Technical Reference
Rule..::..Enabled Property
Rule Class See Also Send Feedback
Toggle evaluation/execution of this rule.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool Enabled { get; set; }
Visual Basic
Public Property Enabled As Boolean
    Get
    Set

See Also

Rule Class
Rule Members


Groups Property

[image]

IceLib Dialer Technical Reference
Rule..::..Groups Property
Rule Class See Also Send Feedback
Named rule groups (within the parent RuleSetConfiguration) to which this rule belongs.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<string> Groups { get; private set; }
Visual Basic
Public Property Groups As Collection(Of String)
    Get
    Private Set

See Also

Rule Class
Rule Members


Id Property

[image]

IceLib Dialer Technical Reference
Rule..::..Id Property
Rule Class See Also Send Feedback
The Id of the Rule.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ConfigurationId Id { get; set; }
Visual Basic
Public Property Id As ConfigurationId
    Get
    Set

See Also

Rule Class
Rule Members


IgnoreGroups Property

[image]

IceLib Dialer Technical Reference
Rule..::..IgnoreGroups Property
Rule Class See Also Send Feedback
Specifies whether this rule should be evaluated no matter which group is active.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IgnoreGroups { get; set; }
Visual Basic
Public Property IgnoreGroups As Boolean
    Get
    Set

See Also

Rule Class
Rule Members


InAllGroups Property

[image]

IceLib Dialer Technical Reference
Rule..::..InAllGroups Property
Rule Class See Also Send Feedback
Specifies whether this rule is a member of all rule groups of the rule set it belongs to.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool InAllGroups { get; set; }
Visual Basic
Public Property InAllGroups As Boolean
    Get
    Set

See Also

Rule Class
Rule Members


Index Property

[image]

IceLib Dialer Technical Reference
Rule..::..Index Property
Rule Class See Also Send Feedback
Specifies the order to display and execute this rule in relation to other rules in the parent rule set.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int Index { get; set; }
Visual Basic
Public Property Index As Integer
    Get
    Set

See Also

Rule Class
Rule Members


InStartupGroup Property

[image]

IceLib Dialer Technical Reference
Rule..::..InStartupGroup Property
Rule Class See Also Send Feedback
Specifies whether this rule is a member of the unnamed group that the rule set evaluates first.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool InStartupGroup { get; set; }
Visual Basic
Public Property InStartupGroup As Boolean
    Get
    Set

See Also

Rule Class
Rule Members


Repetition Property

[image]

IceLib Dialer Technical Reference
Rule..::..Repetition Property
Rule Class See Also Send Feedback
Specifies how often the rule should be re-evaluated.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public RepetitionMode Repetition { get; set; }
Visual Basic
Public Property Repetition As RepetitionMode
    Get
    Set

See Also

Rule Class
Rule Members


TerminateOnAction Property

[image]

IceLib Dialer Technical Reference
Rule..::..TerminateOnAction Property
Rule Class See Also Send Feedback
Specifies the manner in which rule evaluation should be stopped after this rule runs its actions.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public RuleEngineTermination TerminateOnAction { get; set; }
Visual Basic
Public Property TerminateOnAction As RuleEngineTermination
    Get
    Set

See Also

Rule Class
Rule Members


RuleAction Class

[image]

IceLib Dialer Technical Reference
RuleAction Class
Members See Also Send Feedback
An action to perform upon satisfaction of a rule condition.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public abstract class RuleAction : IDeepCloneable
Visual Basic
Public MustInherit Class RuleAction _
    Implements IDeepCloneable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..RuleAction
ININ.IceLib.Configuration.Dialer..::..AgentRuleAction
ININ.IceLib.Configuration.Dialer..::..CampaignPropertyRuleAction
ININ.IceLib.Configuration.Dialer..::..CampaignRuleAction
ININ.IceLib.Configuration.Dialer..::..EmailRuleAction
ININ.IceLib.Configuration.Dialer..::..EventLogRuleAction
ININ.IceLib.Configuration.Dialer..::..HandlerRuleAction
ININ.IceLib.Configuration.Dialer..::..RuleGroupRuleAction
ININ.IceLib.Configuration.Dialer..::..SMSRuleAction

See Also

RuleAction Members


RuleAction Members

[image] [image]

IceLib Dialer Technical Reference
RuleAction Members
RuleAction Class Methods Properties See Also Send Feedback

The RuleAction type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActionType | The type of action to perform.
Public property | Id | The Id of the action.
Public property | Index | The ordinal number of this action in relation to other actions in a rule.

See Also

RuleAction Class


RuleAction Methods

[image] [image]

IceLib Dialer Technical Reference
RuleAction Methods
RuleAction Class See Also Send Feedback

The RuleAction type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RuleAction Class


RuleAction Properties

[image] [image]

IceLib Dialer Technical Reference
RuleAction Properties
RuleAction Class See Also Send Feedback

The RuleAction type exposes the following members.

Properties

 | Name | Description
Public property | ActionType | The type of action to perform.
Public property | Id | The Id of the action.
Public property | Index | The ordinal number of this action in relation to other actions in a rule.

See Also

RuleAction Class


ActionType Property

[image]

IceLib Dialer Technical Reference
RuleAction..::..ActionType Property
RuleAction Class See Also Send Feedback
The type of action to perform.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public RuleActionType ActionType { get; private set; }
Visual Basic
Public Property ActionType As RuleActionType
    Get
    Private Set

See Also

RuleAction Class
RuleAction Members


Id Property

[image]

IceLib Dialer Technical Reference
RuleAction..::..Id Property
RuleAction Class See Also Send Feedback
The Id of the action.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ConfigurationId Id { get; set; }
Visual Basic
Public Property Id As ConfigurationId
    Get
    Set

See Also

RuleAction Class
RuleAction Members


Index Property

[image]

IceLib Dialer Technical Reference
RuleAction..::..Index Property
RuleAction Class See Also Send Feedback
The ordinal number of this action in relation to other actions in a rule.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int Index { get; set; }
Visual Basic
Public Property Index As Integer
    Get
    Set

See Also

RuleAction Class
RuleAction Members


RuleGroupRuleAction Class

[image]

IceLib Dialer Technical Reference
RuleGroupRuleAction Class
Members See Also Send Feedback
A RuleAction that shifts rule evaluation to a different group of rules.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class RuleGroupRuleAction : RuleAction
Visual Basic
Public NotInheritable Class RuleGroupRuleAction _
    Inherits RuleAction

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..RuleAction
ININ.IceLib.Configuration.Dialer..::..RuleGroupRuleAction

See Also

RuleGroupRuleAction Members


RuleGroupRuleAction Members

[image] [image]

IceLib Dialer Technical Reference
RuleGroupRuleAction Members
RuleGroupRuleAction Class Constructors Methods Properties See Also Send Feedback

The RuleGroupRuleAction type exposes the following members.

Constructors

 | Name | Description
Public method | RuleGroupRuleAction | Constructs a new instance of the RuleGroupRuleAction

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides RuleActionToString()()()().)

Properties

 | Name | Description
Public property | ActionType | The type of action to perform. (Inherited from RuleAction.)
Public property | Group | The group to switch to.
Public property | Id | The Id of the action. (Inherited from RuleAction.)
Public property | Index | The ordinal number of this action in relation to other actions in a rule. (Inherited from RuleAction.)

See Also

RuleGroupRuleAction Class


RuleGroupRuleAction Constructor

[image]

IceLib Dialer Technical Reference
RuleGroupRuleAction Constructor
RuleGroupRuleAction Class See Also Send Feedback
Constructs a new instance of the RuleGroupRuleAction

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public RuleGroupRuleAction()
Visual Basic
Public Sub New

See Also

RuleGroupRuleAction Class
RuleGroupRuleAction Members


RuleGroupRuleAction Methods

[image] [image]

IceLib Dialer Technical Reference
RuleGroupRuleAction Methods
RuleGroupRuleAction Class See Also Send Feedback

The RuleGroupRuleAction type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | (Overrides RuleActionToString()()()().)

See Also

RuleGroupRuleAction Class


ToString Method

[image]

IceLib Dialer Technical Reference
RuleGroupRuleAction..::..ToString Method
RuleGroupRuleAction Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

See Also

RuleGroupRuleAction Class
RuleGroupRuleAction Members


RuleGroupRuleAction Properties

[image] [image]

IceLib Dialer Technical Reference
RuleGroupRuleAction Properties
RuleGroupRuleAction Class See Also Send Feedback

The RuleGroupRuleAction type exposes the following members.

Properties

 | Name | Description
Public property | ActionType | The type of action to perform. (Inherited from RuleAction.)
Public property | Group | The group to switch to.
Public property | Id | The Id of the action. (Inherited from RuleAction.)
Public property | Index | The ordinal number of this action in relation to other actions in a rule. (Inherited from RuleAction.)

See Also

RuleGroupRuleAction Class


Group Property

[image]

IceLib Dialer Technical Reference
RuleGroupRuleAction..::..Group Property
RuleGroupRuleAction Class See Also Send Feedback
The group to switch to.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Group { get; set; }
Visual Basic
Public Property Group As String
    Get
    Set

See Also

RuleGroupRuleAction Class
RuleGroupRuleAction Members


RuleSetConfiguration Class

[image]

IceLib Dialer Technical Reference
RuleSetConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for a Dialer Rule Set.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class RuleSetConfiguration : EditableListConfigurationObject<RuleSetConfiguration..::..Property>,
    IExportable
Visual Basic
Public Class RuleSetConfiguration _
    Inherits EditableListConfigurationObject(Of RuleSetConfiguration..::..Property) _
    Implements IExportable

Inheritance Hierarchy

System..::..Object
ConfigurationObject
ListConfigurationObject
EditableListConfigurationObject<(Of <(<' RuleSetConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..RuleSetConfiguration

See Also

RuleSetConfiguration Members


RuleSetConfiguration Members

[image] [image]

IceLib Dialer Technical Reference
RuleSetConfiguration Members
RuleSetConfiguration Class Methods Properties See Also Send Feedback

The RuleSetConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' RuleSetConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' RuleSetConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' RuleSetConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' RuleSetConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' RuleSetConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' RuleSetConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' RuleSetConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' RuleSetConfiguration..::..Property >)>)>.)
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' RuleSetConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' RuleSetConfiguration..::..Property >)>)>.)
Public method | ToString | (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' RuleSetConfiguration..::..Property >)>)>.)
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | Groups | The groups defined in this Rule Set.
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsExporting | Tells whether the current object is being used for exporting
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | RevisionLevel | The current version of this object.
Public property | Rules | The list of rules contained in this rule set.

See Also

RuleSetConfiguration Class


RuleSetConfiguration Methods

[image] [image]

IceLib Dialer Technical Reference
RuleSetConfiguration Methods
RuleSetConfiguration Class See Also Send Feedback

The RuleSetConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' RuleSetConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' RuleSetConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' RuleSetConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' RuleSetConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' RuleSetConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' RuleSetConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' RuleSetConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' RuleSetConfiguration..::..Property >)>)>.)
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' RuleSetConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' RuleSetConfiguration..::..Property >)>)>.)
Public method | ToString | (Inherited from ConfigurationObject.)

See Also

RuleSetConfiguration Class


RuleSetConfiguration Properties

[image] [image]

IceLib Dialer Technical Reference
RuleSetConfiguration Properties
RuleSetConfiguration Class See Also Send Feedback

The RuleSetConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' RuleSetConfiguration..::..Property >)>)>.)
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | Groups | The groups defined in this Rule Set.
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsExporting | Tells whether the current object is being used for exporting
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | RevisionLevel | The current version of this object.
Public property | Rules | The list of rules contained in this rule set.

See Also

RuleSetConfiguration Class


Groups Property

[image]

IceLib Dialer Technical Reference
RuleSetConfiguration..::..Groups Property
RuleSetConfiguration Class See Also Send Feedback
The groups defined in this Rule Set.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<RuleSetConfiguration..::..Property, Collection<string>> Groups { get; }
Visual Basic
Public ReadOnly Property Groups As GeneralConfigurationProperty(Of RuleSetConfiguration..::..Property, Collection(Of String))
    Get

See Also

RuleSetConfiguration Class
RuleSetConfiguration Members


IsDefaultObject Property

[image]

IceLib Dialer Technical Reference
RuleSetConfiguration..::..IsDefaultObject Property
RuleSetConfiguration Class See Also Send Feedback
Indicates whether this is the default instance of this object type.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsDefaultObject { get; }
Visual Basic
Public ReadOnly Property IsDefaultObject As Boolean
    Get

See Also

RuleSetConfiguration Class
RuleSetConfiguration Members


IsExporting Property

[image]

IceLib Dialer Technical Reference
RuleSetConfiguration..::..IsExporting Property
RuleSetConfiguration Class See Also Send Feedback
Tells whether the current object is being used for exporting

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsExporting { get; private set; }
Visual Basic
Public Property IsExporting As Boolean
    Get
    Private Set

See Also

RuleSetConfiguration Class
RuleSetConfiguration Members


RevisionLevel Property

[image]

IceLib Dialer Technical Reference
RuleSetConfiguration..::..RevisionLevel Property
RuleSetConfiguration Class See Also Send Feedback
The current version of this object.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<RuleSetConfiguration..::..Property, int> RevisionLevel { get; }
Visual Basic
Public ReadOnly Property RevisionLevel As GeneralConfigurationProperty(Of RuleSetConfiguration..::..Property, Integer)
    Get

See Also

RuleSetConfiguration Class
RuleSetConfiguration Members


Rules Property

[image]

IceLib Dialer Technical Reference
RuleSetConfiguration..::..Rules Property
RuleSetConfiguration Class See Also Send Feedback
The list of rules contained in this rule set.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<RuleSetConfiguration..::..Property, Collection<Rule>> Rules { get; }
Visual Basic
Public ReadOnly Property Rules As GeneralConfigurationProperty(Of RuleSetConfiguration..::..Property, Collection(Of Rule))
    Get

See Also

RuleSetConfiguration Class
RuleSetConfiguration Members


RuleSetConfiguration.Property Enumeration

[image]

IceLib Dialer Technical Reference
RuleSetConfiguration..::..Property Enumeration
RuleSetConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Id | 0 | Represents the Id part of the ConfigurationId property.
DisplayName | 1 | Represents the DisplayName part of the ConfigurationId property.
Groups | 2 | Represents the Groups property.
Rules | 3 | Rerpesents the Rules property.
RevisionLevel | 4 | Represents the RevisionLevel property.

See Also


RuleSetConfigurationList Class

[image]

IceLib Dialer Technical Reference
RuleSetConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing rule set configuration objects.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class RuleSetConfigurationList : EditableConfigurationList<RuleSetConfiguration, RuleSetConfiguration..::..Property>
Visual Basic
Public Class RuleSetConfigurationList _
    Inherits EditableConfigurationList(Of RuleSetConfiguration, RuleSetConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>
DynamicConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>
EditableConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..RuleSetConfigurationList

See Also

RuleSetConfigurationList Members


RuleSetConfigurationList Members

[image] [image]

IceLib Dialer Technical Reference
RuleSetConfigurationList Members
RuleSetConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The RuleSetConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | RuleSetConfigurationList | Initializes a new instance of the RuleSetConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)

See Also

RuleSetConfigurationList Class


RuleSetConfigurationList Constructor

[image]

IceLib Dialer Technical Reference
RuleSetConfigurationList Constructor
RuleSetConfigurationList Class See Also Send Feedback
Initializes a new instance of the RuleSetConfigurationList class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public RuleSetConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

RuleSetConfigurationList Class
RuleSetConfigurationList Members


RuleSetConfigurationList Methods

[image] [image]

IceLib Dialer Technical Reference
RuleSetConfigurationList Methods
RuleSetConfigurationList Class See Also Send Feedback

The RuleSetConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RuleSetConfigurationList Class


RuleSetConfigurationList Properties

[image] [image]

IceLib Dialer Technical Reference
RuleSetConfigurationList Properties
RuleSetConfigurationList Class See Also Send Feedback

The RuleSetConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)

See Also

RuleSetConfigurationList Class


RuleSetConfigurationList Events

[image] [image]

IceLib Dialer Technical Reference
RuleSetConfigurationList Events
RuleSetConfigurationList Class See Also Send Feedback

The RuleSetConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' RuleSetConfiguration, RuleSetConfiguration..::..Property >)>)>.)

See Also

RuleSetConfigurationList Class


ScheduleConfiguration Class

[image]

IceLib Dialer Technical Reference
ScheduleConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for a Dialer schedule.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class ScheduleConfiguration : EditableListConfigurationObject<ScheduleConfiguration..::..Property>,
    IExportable
Visual Basic
Public Class ScheduleConfiguration _
    Inherits EditableListConfigurationObject(Of ScheduleConfiguration..::..Property) _
    Implements IExportable

Inheritance Hierarchy

System..::..Object
ConfigurationObject
ListConfigurationObject
EditableListConfigurationObject<(Of <(<' ScheduleConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..ScheduleConfiguration

See Also

ScheduleConfiguration Members


ScheduleConfiguration Members

[image] [image]

IceLib Dialer Technical Reference
ScheduleConfiguration Members
ScheduleConfiguration Class Methods Properties See Also Send Feedback

The ScheduleConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' ScheduleConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' ScheduleConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ScheduleConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' ScheduleConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ScheduleConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' ScheduleConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ScheduleConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' ScheduleConfiguration..::..Property >)>)>.)
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' ScheduleConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' ScheduleConfiguration..::..Property >)>)>.)
Public method | ToString | (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' ScheduleConfiguration..::..Property >)>)>.)
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsExporting | Tells whether the current object is being used for exporting
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | RevisionLevel | The current version of this object.
Public property | TimeSlots | Specifies the state of a campaign during various ranges of times.

See Also

ScheduleConfiguration Class


ScheduleConfiguration Methods

[image] [image]

IceLib Dialer Technical Reference
ScheduleConfiguration Methods
ScheduleConfiguration Class See Also Send Feedback

The ScheduleConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' ScheduleConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' ScheduleConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ScheduleConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' ScheduleConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ScheduleConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' ScheduleConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ScheduleConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' ScheduleConfiguration..::..Property >)>)>.)
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' ScheduleConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' ScheduleConfiguration..::..Property >)>)>.)
Public method | ToString | (Inherited from ConfigurationObject.)

See Also

ScheduleConfiguration Class


ScheduleConfiguration Properties

[image] [image]

IceLib Dialer Technical Reference
ScheduleConfiguration Properties
ScheduleConfiguration Class See Also Send Feedback

The ScheduleConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' ScheduleConfiguration..::..Property >)>)>.)
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsExporting | Tells whether the current object is being used for exporting
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | RevisionLevel | The current version of this object.
Public property | TimeSlots | Specifies the state of a campaign during various ranges of times.

See Also

ScheduleConfiguration Class


IsDefaultObject Property

[image]

IceLib Dialer Technical Reference
ScheduleConfiguration..::..IsDefaultObject Property
ScheduleConfiguration Class See Also Send Feedback
Indicates whether this is the default instance of this object type.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsDefaultObject { get; }
Visual Basic
Public ReadOnly Property IsDefaultObject As Boolean
    Get

See Also

ScheduleConfiguration Class
ScheduleConfiguration Members


IsExporting Property

[image]

IceLib Dialer Technical Reference
ScheduleConfiguration..::..IsExporting Property
ScheduleConfiguration Class See Also Send Feedback
Tells whether the current object is being used for exporting

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsExporting { get; private set; }
Visual Basic
Public Property IsExporting As Boolean
    Get
    Private Set

See Also

ScheduleConfiguration Class
ScheduleConfiguration Members


RevisionLevel Property

[image]

IceLib Dialer Technical Reference
ScheduleConfiguration..::..RevisionLevel Property
ScheduleConfiguration Class See Also Send Feedback
The current version of this object.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<ScheduleConfiguration..::..Property, int> RevisionLevel { get; }
Visual Basic
Public ReadOnly Property RevisionLevel As GeneralConfigurationProperty(Of ScheduleConfiguration..::..Property, Integer)
    Get

See Also

ScheduleConfiguration Class
ScheduleConfiguration Members


TimeSlots Property

[image]

IceLib Dialer Technical Reference
ScheduleConfiguration..::..TimeSlots Property
ScheduleConfiguration Class See Also Send Feedback
Specifies the state of a campaign during various ranges of times.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<ScheduleConfiguration..::..Property, Collection<ScheduleTimeSlot>> TimeSlots { get; }
Visual Basic
Public ReadOnly Property TimeSlots As GeneralConfigurationProperty(Of ScheduleConfiguration..::..Property, Collection(Of ScheduleTimeSlot))
    Get

See Also

ScheduleConfiguration Class
ScheduleConfiguration Members


ScheduleConfiguration.Property Enumeration

[image]

IceLib Dialer Technical Reference
ScheduleConfiguration..::..Property Enumeration
ScheduleConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Id | 0 | Represents the Id part of the ConfigurationId property.
DisplayName | 1 | Represents the DisplayName part of the ConfigurationId property.
TimeSlots | 2 | Represents the TimeSlots property.
RevisionLevel | 3 | Represents the RevisionLevel property.

See Also


ScheduleConfigurationList Class

[image]

IceLib Dialer Technical Reference
ScheduleConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing schedule configuration objects.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class ScheduleConfigurationList : EditableConfigurationList<ScheduleConfiguration, ScheduleConfiguration..::..Property>
Visual Basic
Public Class ScheduleConfigurationList _
    Inherits EditableConfigurationList(Of ScheduleConfiguration, ScheduleConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>
DynamicConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>
EditableConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..ScheduleConfigurationList

See Also

ScheduleConfigurationList Members


ScheduleConfigurationList Members

[image] [image]

IceLib Dialer Technical Reference
ScheduleConfigurationList Members
ScheduleConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The ScheduleConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | ScheduleConfigurationList | Initializes a new instance of the ScheduleConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)

See Also

ScheduleConfigurationList Class


ScheduleConfigurationList Constructor

[image]

IceLib Dialer Technical Reference
ScheduleConfigurationList Constructor
ScheduleConfigurationList Class See Also Send Feedback
Initializes a new instance of the ScheduleConfigurationList class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ScheduleConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

ScheduleConfigurationList Class
ScheduleConfigurationList Members


ScheduleConfigurationList Methods

[image] [image]

IceLib Dialer Technical Reference
ScheduleConfigurationList Methods
ScheduleConfigurationList Class See Also Send Feedback

The ScheduleConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScheduleConfigurationList Class


ScheduleConfigurationList Properties

[image] [image]

IceLib Dialer Technical Reference
ScheduleConfigurationList Properties
ScheduleConfigurationList Class See Also Send Feedback

The ScheduleConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)

See Also

ScheduleConfigurationList Class


ScheduleConfigurationList Events

[image] [image]

IceLib Dialer Technical Reference
ScheduleConfigurationList Events
ScheduleConfigurationList Class See Also Send Feedback

The ScheduleConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' ScheduleConfiguration, ScheduleConfiguration..::..Property >)>)>.)

See Also

ScheduleConfigurationList Class


SelectCommand Class

[image]

IceLib Dialer Technical Reference
SelectCommand Class
Members See Also Send Feedback
A command that retrieves contact records from a database table associated with a contact list.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class SelectCommand : ContactListCommand
Visual Basic
Public NotInheritable Class SelectCommand _
    Inherits ContactListCommand

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..ContactListCommand
ININ.IceLib.Configuration.Dialer..::..SelectCommand

See Also

SelectCommand Members


SelectCommand Members

[image] [image]

IceLib Dialer Technical Reference
SelectCommand Members
SelectCommand Class Constructors Methods Properties See Also Send Feedback

The SelectCommand type exposes the following members.

Constructors

 | Name | Description
Public method | SelectCommand(ContactListConfiguration) | Creates a new instance of the SelectCommand class.
Public method | SelectCommand(ContactListConfiguration, IEnumerable<(Of <<'(FilterConfiguration>)>>)) | Creates a new instance of the SelectCommand class.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Overrides ContactListCommand..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetDatabaseType | Retrieves the type of database associated with the contact list's connection. (Inherited from ContactListCommand.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Restores default options, clears all lists, and resets all predicates expressions to EmptyExpression.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Aggregates | The columns composed of aggregate functions to return data for. Optional.
Public property | Columns | The columns to return data for. Optional.
Public property | ContactList | The contact list to run this command against. (Inherited from ContactListCommand.)
Public property | Distinct | Specifies whether to return only records which are distinct.
Public property | Filters | The filter to use in the where predicate. (Inherited from ContactListCommand.)
Public property | FirstRecord | The number of the first record to retrieve as part of a paged result.
Public property | GroupBy | The columns to group records by, in order.
Public property | Having | An expression representing a logical predicate with which to filter records.
Public property | LastRecord | The number of the last record to retrieve as part of a paged result.
Public property | OrderBy | A list of key/value pairs representing the sorting order of the results. The key is the column name, and the value is true for ascending and false for descending.
Public property | RecordsAffected | The number of records affected by this command. If this is a paged SelectCommand, the value reflects the total number of records in the unpaged version. (Inherited from ContactListCommand.)
Public property | TableType | Specifies which associated database table to run the command on. Defaults to the contact list table. (Overrides ContactListCommand..::..TableType.)
Public property | Where | An expression representing a logical predicate with which to filter records. (Inherited from ContactListCommand.)

See Also

SelectCommand Class


SelectCommand Constructor

[image] [image]

IceLib Dialer Technical Reference
SelectCommand Constructor
SelectCommand Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SelectCommand(ContactListConfiguration) | Creates a new instance of the SelectCommand class.
Public method | SelectCommand(ContactListConfiguration, IEnumerable<(Of <<'(FilterConfiguration>)>>)) | Creates a new instance of the SelectCommand class.

See Also

SelectCommand Class
SelectCommand Members


SelectCommand Constructor (ContactListConfiguration)

[image]

IceLib Dialer Technical Reference
SelectCommand Constructor (ContactListConfiguration)
SelectCommand Class See Also Send Feedback
Creates a new instance of the SelectCommand class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public SelectCommand(
    ContactListConfiguration contactList
)
Visual Basic
Public Sub New ( _
    contactList As ContactListConfiguration _
)

Parameters

contactList
Type: ININ.IceLib.Configuration.Dialer..::..ContactListConfiguration

See Also

SelectCommand Class
SelectCommand Members
SelectCommand Overload


SelectCommand Constructor (ContactListConfiguration, IEnumerable(FilterConfiguration))

[image]

IceLib Dialer Technical Reference
SelectCommand Constructor (ContactListConfiguration, IEnumerable<(Of <(<'FilterConfiguration>)>)>)
SelectCommand Class See Also Send Feedback
Creates a new instance of the SelectCommand class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public SelectCommand(
    ContactListConfiguration contactList,
    IEnumerable<FilterConfiguration> filters
)
Visual Basic
Public Sub New ( _
    contactList As ContactListConfiguration, _
    filters As IEnumerable(Of FilterConfiguration) _
)

Parameters

contactList
Type: ININ.IceLib.Configuration.Dialer..::..ContactListConfiguration
filters
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' FilterConfiguration >)>)>

See Also

SelectCommand Class
SelectCommand Members
SelectCommand Overload


SelectCommand Methods

[image] [image]

IceLib Dialer Technical Reference
SelectCommand Methods
SelectCommand Class See Also Send Feedback

The SelectCommand type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Overrides ContactListCommand..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetDatabaseType | Retrieves the type of database associated with the contact list's connection. (Inherited from ContactListCommand.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Restores default options, clears all lists, and resets all predicates expressions to EmptyExpression.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SelectCommand Class


Clone Method

[image]

IceLib Dialer Technical Reference
SelectCommand..::..Clone Method
SelectCommand Class See Also Send Feedback
Creates a new object that is a copy of the current instance.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object

Return Value

A new object that is a copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

SelectCommand Class
SelectCommand Members


Reset Method

[image]

IceLib Dialer Technical Reference
SelectCommand..::..Reset Method
SelectCommand Class See Also Send Feedback
Restores default options, clears all lists, and resets all predicates expressions to EmptyExpression.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

See Also

SelectCommand Class
SelectCommand Members


SelectCommand Properties

[image] [image]

IceLib Dialer Technical Reference
SelectCommand Properties
SelectCommand Class See Also Send Feedback

The SelectCommand type exposes the following members.

Properties

 | Name | Description
Public property | Aggregates | The columns composed of aggregate functions to return data for. Optional.
Public property | Columns | The columns to return data for. Optional.
Public property | ContactList | The contact list to run this command against. (Inherited from ContactListCommand.)
Public property | Distinct | Specifies whether to return only records which are distinct.
Public property | Filters | The filter to use in the where predicate. (Inherited from ContactListCommand.)
Public property | FirstRecord | The number of the first record to retrieve as part of a paged result.
Public property | GroupBy | The columns to group records by, in order.
Public property | Having | An expression representing a logical predicate with which to filter records.
Public property | LastRecord | The number of the last record to retrieve as part of a paged result.
Public property | OrderBy | A list of key/value pairs representing the sorting order of the results. The key is the column name, and the value is true for ascending and false for descending.
Public property | RecordsAffected | The number of records affected by this command. If this is a paged SelectCommand, the value reflects the total number of records in the unpaged version. (Inherited from ContactListCommand.)
Public property | TableType | Specifies which associated database table to run the command on. Defaults to the contact list table. (Overrides ContactListCommand..::..TableType.)
Public property | Where | An expression representing a logical predicate with which to filter records. (Inherited from ContactListCommand.)

See Also

SelectCommand Class


Aggregates Property

[image]

IceLib Dialer Technical Reference
SelectCommand..::..Aggregates Property
SelectCommand Class See Also Send Feedback
The columns composed of aggregate functions to return data for. Optional.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public IList<AggregateExpression> Aggregates { get; private set; }
Visual Basic
Public Property Aggregates As IList(Of AggregateExpression)
    Get
    Private Set

See Also

SelectCommand Class
SelectCommand Members


Columns Property

[image]

IceLib Dialer Technical Reference
SelectCommand..::..Columns Property
SelectCommand Class See Also Send Feedback
The columns to return data for. Optional.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public IList<DBColumn> Columns { get; private set; }
Visual Basic
Public Property Columns As IList(Of DBColumn)
    Get
    Private Set

See Also

SelectCommand Class
SelectCommand Members


Distinct Property

[image]

IceLib Dialer Technical Reference
SelectCommand..::..Distinct Property
SelectCommand Class See Also Send Feedback
Specifies whether to return only records which are distinct.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool Distinct { get; set; }
Visual Basic
Public Property Distinct As Boolean
    Get
    Set

Remarks

Defaults to false.

See Also

SelectCommand Class
SelectCommand Members


FirstRecord Property

[image]

IceLib Dialer Technical Reference
SelectCommand..::..FirstRecord Property
SelectCommand Class See Also Send Feedback
The number of the first record to retrieve as part of a paged result.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int FirstRecord { get; set; }
Visual Basic
Public Property FirstRecord As Integer
    Get
    Set

Remarks

This value is ignored if it is greater than LastRecord.

See Also

SelectCommand Class
SelectCommand Members


GroupBy Property

[image]

IceLib Dialer Technical Reference
SelectCommand..::..GroupBy Property
SelectCommand Class See Also Send Feedback
The columns to group records by, in order.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public IList<DBColumn> GroupBy { get; private set; }
Visual Basic
Public Property GroupBy As IList(Of DBColumn)
    Get
    Private Set

Remarks

Every database (non-aggregated) column in the Columns property must be present in this list. This property is ignored if the AggregateColumns" property is empty.

See Also

SelectCommand Class
SelectCommand Members


Having Property

[image]

IceLib Dialer Technical Reference
SelectCommand..::..Having Property
SelectCommand Class See Also Send Feedback
An expression representing a logical predicate with which to filter records.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public IExpression Having { get; set; }
Visual Basic
Public Property Having As IExpression
    Get
    Set

Remarks

This property is used when a predicate containing an aggregate function is needed, since the Where property does not allow such predicates.

See Also

SelectCommand Class
SelectCommand Members


LastRecord Property

[image]

IceLib Dialer Technical Reference
SelectCommand..::..LastRecord Property
SelectCommand Class See Also Send Feedback
The number of the last record to retrieve as part of a paged result.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int LastRecord { get; set; }
Visual Basic
Public Property LastRecord As Integer
    Get
    Set

Remarks

THis value is ignored if it is less than FirstRecord.

See Also

SelectCommand Class
SelectCommand Members


OrderBy Property

[image]

IceLib Dialer Technical Reference
SelectCommand..::..OrderBy Property
SelectCommand Class See Also Send Feedback
A list of key/value pairs representing the sorting order of the results. The key is the column name, and the value is true for ascending and false for descending.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public IList<KeyValuePair<DBColumn, bool>> OrderBy { get; private set; }
Visual Basic
Public Property OrderBy As IList(Of KeyValuePair(Of DBColumn, Boolean))
    Get
    Private Set

See Also

SelectCommand Class
SelectCommand Members


TableType Property

[image]

IceLib Dialer Technical Reference
SelectCommand..::..TableType Property
SelectCommand Class See Also Send Feedback
Specifies which associated database table to run the command on. Defaults to the contact list table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override TableType TableType { get; set; }
Visual Basic
Public Overrides Property TableType As TableType
    Get
    Set

See Also

SelectCommand Class
SelectCommand Members


Sequence Class

[image]

IceLib Dialer Technical Reference
Sequence Class
Members See Also Send Feedback
a class representing a group of CampaignGroup and CampaignSequence objects. Together these represent a series of triggers and property changes a campaign can undergo during execution.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class Sequence : IDeepCloneable
Visual Basic
Public Class Sequence _
    Implements IDeepCloneable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..Sequence

See Also

Sequence Members


Sequence Members

[image] [image]

IceLib Dialer Technical Reference
Sequence Members
Sequence Class Constructors Methods Properties See Also Send Feedback

The Sequence type exposes the following members.

Constructors

 | Name | Description
Public method | Sequence | Constructs a new instance of the Sequence class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CampaignGroups | A group of CampaignGroup objects.
Public property | CampaignSequence | A group of CampaignSequence objects.

See Also

Sequence Class


Sequence Constructor

[image]

IceLib Dialer Technical Reference
Sequence Constructor
Sequence Class See Also Send Feedback
Constructs a new instance of the Sequence class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Sequence()
Visual Basic
Public Sub New

See Also

Sequence Class
Sequence Members


Sequence Methods

[image] [image]

IceLib Dialer Technical Reference
Sequence Methods
Sequence Class See Also Send Feedback

The Sequence type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Sequence Class


Sequence Properties

[image] [image]

IceLib Dialer Technical Reference
Sequence Properties
Sequence Class See Also Send Feedback

The Sequence type exposes the following members.

Properties

 | Name | Description
Public property | CampaignGroups | A group of CampaignGroup objects.
Public property | CampaignSequence | A group of CampaignSequence objects.

See Also

Sequence Class


CampaignGroups Property

[image]

IceLib Dialer Technical Reference
Sequence..::..CampaignGroups Property
Sequence Class See Also Send Feedback
A group of CampaignGroup objects.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<CampaignGroup> CampaignGroups { get; set; }
Visual Basic
Public Property CampaignGroups As Collection(Of CampaignGroup)
    Get
    Set

See Also

Sequence Class
Sequence Members


CampaignSequence Property

[image]

IceLib Dialer Technical Reference
Sequence..::..CampaignSequence Property
Sequence Class See Also Send Feedback
A group of CampaignSequence objects.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<SequenceItem> CampaignSequence { get; set; }
Visual Basic
Public Property CampaignSequence As Collection(Of SequenceItem)
    Get
    Set

See Also

Sequence Class
Sequence Members


SequenceItem Class

[image]

IceLib Dialer Technical Reference
SequenceItem Class
Members See Also Send Feedback
A class representing a named member of a CampaignSequence

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public abstract class SequenceItem : IDeepCloneable
Visual Basic
Public MustInherit Class SequenceItem _
    Implements IDeepCloneable

Remarks

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..SequenceItem
ININ.IceLib.Configuration.Dialer..::..EventSequenceItem
ININ.IceLib.Configuration.Dialer..::..StatSequenceItem
ININ.IceLib.Configuration.Dialer..::..TimeSequenceItem

See Also

SequenceItem Members


SequenceItem Members

[image] [image]

IceLib Dialer Technical Reference
SequenceItem Members
SequenceItem Class Methods Properties See Also Send Feedback

The SequenceItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDisplayName | Public method to change the display name of a CampaignGroup
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CampaignGroup | The CampaignGroup that is triggered by this Sequence Item
Public property | ConditionType | Specifies the Type of Sequence Item this is: Event, Time or Stat.
Public property | Id | The Id of the SequenceItem.
Public property | IgnoreGroups | Specifies whether this Sequence Item should be evaluated no matter which campaign group is active.
Public property | InAllGroups | Specifies whether this Sequence Item is a child of all campaign groups of the sequence definition that it belongs to.
Public property | Index | Specifies the order to display and execute Sequence Item in relation to other Sequence Items in the Sequence.
Public property | InStartupGroup | Specifies whether this rule is a member of the unnamed group that the rule set evaluates first.
Public property | ParentGroups | Named campaign groups (within the sequence Sequence) to which this sequence item represents.

See Also

SequenceItem Class


SequenceItem Methods

[image] [image]

IceLib Dialer Technical Reference
SequenceItem Methods
SequenceItem Class See Also Send Feedback

The SequenceItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDisplayName | Public method to change the display name of a CampaignGroup
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SequenceItem Class


SetDisplayName Method

[image]

IceLib Dialer Technical Reference
SequenceItem..::..SetDisplayName Method
SequenceItem Class See Also Send Feedback
Public method to change the display name of a CampaignGroup

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void SetDisplayName(
    string displayName
)
Visual Basic
Public Sub SetDisplayName ( _
    displayName As String _
)

Parameters

displayName
Type: System..::..String

See Also

SequenceItem Class
SequenceItem Members


SequenceItem Properties

[image] [image]

IceLib Dialer Technical Reference
SequenceItem Properties
SequenceItem Class See Also Send Feedback

The SequenceItem type exposes the following members.

Properties

 | Name | Description
Public property | CampaignGroup | The CampaignGroup that is triggered by this Sequence Item
Public property | ConditionType | Specifies the Type of Sequence Item this is: Event, Time or Stat.
Public property | Id | The Id of the SequenceItem.
Public property | IgnoreGroups | Specifies whether this Sequence Item should be evaluated no matter which campaign group is active.
Public property | InAllGroups | Specifies whether this Sequence Item is a child of all campaign groups of the sequence definition that it belongs to.
Public property | Index | Specifies the order to display and execute Sequence Item in relation to other Sequence Items in the Sequence.
Public property | InStartupGroup | Specifies whether this rule is a member of the unnamed group that the rule set evaluates first.
Public property | ParentGroups | Named campaign groups (within the sequence Sequence) to which this sequence item represents.

See Also

SequenceItem Class


CampaignGroup Property

[image]

IceLib Dialer Technical Reference
SequenceItem..::..CampaignGroup Property
SequenceItem Class See Also Send Feedback
The CampaignGroup that is triggered by this Sequence Item

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CampaignGroup CampaignGroup { get; set; }
Visual Basic
Public Property CampaignGroup As CampaignGroup
    Get
    Set

See Also

SequenceItem Class
SequenceItem Members


ConditionType Property

[image]

IceLib Dialer Technical Reference
SequenceItem..::..ConditionType Property
SequenceItem Class See Also Send Feedback
Specifies the Type of Sequence Item this is: Event, Time or Stat.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public RuleType ConditionType { get; private set; }
Visual Basic
Public Property ConditionType As RuleType
    Get
    Private Set

See Also

SequenceItem Class
SequenceItem Members


Id Property

[image]

IceLib Dialer Technical Reference
SequenceItem..::..Id Property
SequenceItem Class See Also Send Feedback
The Id of the SequenceItem.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ConfigurationId Id { get; internal set; }
Visual Basic
Public Property Id As ConfigurationId
    Get
    Friend Set

See Also

SequenceItem Class
SequenceItem Members


IgnoreGroups Property

[image]

IceLib Dialer Technical Reference
SequenceItem..::..IgnoreGroups Property
SequenceItem Class See Also Send Feedback
Specifies whether this Sequence Item should be evaluated no matter which campaign group is active.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IgnoreGroups { get; set; }
Visual Basic
Public Property IgnoreGroups As Boolean
    Get
    Set

See Also

SequenceItem Class
SequenceItem Members


InAllGroups Property

[image]

IceLib Dialer Technical Reference
SequenceItem..::..InAllGroups Property
SequenceItem Class See Also Send Feedback
Specifies whether this Sequence Item is a child of all campaign groups of the sequence definition that it belongs to.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool InAllGroups { get; set; }
Visual Basic
Public Property InAllGroups As Boolean
    Get
    Set

Remarks

XMLName: allgroups

See Also

SequenceItem Class
SequenceItem Members


Index Property

[image]

IceLib Dialer Technical Reference
SequenceItem..::..Index Property
SequenceItem Class See Also Send Feedback
Specifies the order to display and execute Sequence Item in relation to other Sequence Items in the Sequence.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int Index { get; set; }
Visual Basic
Public Property Index As Integer
    Get
    Set

See Also

SequenceItem Class
SequenceItem Members


InStartupGroup Property

[image]

IceLib Dialer Technical Reference
SequenceItem..::..InStartupGroup Property
SequenceItem Class See Also Send Feedback
Specifies whether this rule is a member of the unnamed group that the rule set evaluates first.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool InStartupGroup { get; set; }
Visual Basic
Public Property InStartupGroup As Boolean
    Get
    Set

See Also

SequenceItem Class
SequenceItem Members


ParentGroups Property

[image]

IceLib Dialer Technical Reference
SequenceItem..::..ParentGroups Property
SequenceItem Class See Also Send Feedback
Named campaign groups (within the sequence Sequence) to which this sequence item represents.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<ConfigurationId> ParentGroups { get; set; }
Visual Basic
Public Property ParentGroups As Collection(Of ConfigurationId)
    Get
    Set

See Also

SequenceItem Class
SequenceItem Members


ServerType Enumeration

[image]

IceLib Dialer Technical Reference
ServerType Enumeration
See Also Send Feedback
Dialer Server Types

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum ServerType
Visual Basic
Public Enumeration ServerType

Members

Member name | Value | Description
CentralCampaign | 0 | Central Campaign Server
OutboundDialer | 1 | Outbound Dialing Server

See Also


SkillSetConfiguration Class

[image]

IceLib Dialer Technical Reference
SkillSetConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for a Dialer skill set.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class SkillSetConfiguration : EditableListConfigurationObject<SkillSetConfiguration..::..Property>,
    IExportable
Visual Basic
Public Class SkillSetConfiguration _
    Inherits EditableListConfigurationObject(Of SkillSetConfiguration..::..Property) _
    Implements IExportable

Inheritance Hierarchy

System..::..Object
ConfigurationObject
ListConfigurationObject
EditableListConfigurationObject<(Of <(<' SkillSetConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..SkillSetConfiguration

See Also

SkillSetConfiguration Members


SkillSetConfiguration Members

[image] [image]

IceLib Dialer Technical Reference
SkillSetConfiguration Members
SkillSetConfiguration Class Methods Properties See Also Send Feedback

The SkillSetConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' SkillSetConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' SkillSetConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' SkillSetConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' SkillSetConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' SkillSetConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' SkillSetConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' SkillSetConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' SkillSetConfiguration..::..Property >)>)>.)
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' SkillSetConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' SkillSetConfiguration..::..Property >)>)>.)
Public method | ToString | (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' SkillSetConfiguration..::..Property >)>)>.)
Public property | ColumnName | The name of the contact list column that contains skill values.
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsExporting | Tells whether the current object is being used for exporting
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | MinimumProficiency | The minimum skill proficiency required by an agent to process a call for that skill.
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | RevisionLevel | The current version number of this object.
Public property | Skills | The list of Dialer skills contained in this skill set.

See Also

SkillSetConfiguration Class


SkillSetConfiguration Methods

[image] [image]

IceLib Dialer Technical Reference
SkillSetConfiguration Methods
SkillSetConfiguration Class See Also Send Feedback

The SkillSetConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' SkillSetConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' SkillSetConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' SkillSetConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' SkillSetConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' SkillSetConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' SkillSetConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' SkillSetConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' SkillSetConfiguration..::..Property >)>)>.)
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' SkillSetConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' SkillSetConfiguration..::..Property >)>)>.)
Public method | ToString | (Inherited from ConfigurationObject.)

See Also

SkillSetConfiguration Class


SkillSetConfiguration Properties

[image] [image]

IceLib Dialer Technical Reference
SkillSetConfiguration Properties
SkillSetConfiguration Class See Also Send Feedback

The SkillSetConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' SkillSetConfiguration..::..Property >)>)>.)
Public property | ColumnName | The name of the contact list column that contains skill values.
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsExporting | Tells whether the current object is being used for exporting
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | MinimumProficiency | The minimum skill proficiency required by an agent to process a call for that skill.
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | RevisionLevel | The current version number of this object.
Public property | Skills | The list of Dialer skills contained in this skill set.

See Also

SkillSetConfiguration Class


ColumnName Property

[image]

IceLib Dialer Technical Reference
SkillSetConfiguration..::..ColumnName Property
SkillSetConfiguration Class See Also Send Feedback
The name of the contact list column that contains skill values.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<SkillSetConfiguration..::..Property, string> ColumnName { get; }
Visual Basic
Public ReadOnly Property ColumnName As GeneralConfigurationProperty(Of SkillSetConfiguration..::..Property, String)
    Get

See Also

SkillSetConfiguration Class
SkillSetConfiguration Members


IsDefaultObject Property

[image]

IceLib Dialer Technical Reference
SkillSetConfiguration..::..IsDefaultObject Property
SkillSetConfiguration Class See Also Send Feedback
Indicates whether this is the default instance of this object type.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsDefaultObject { get; }
Visual Basic
Public ReadOnly Property IsDefaultObject As Boolean
    Get

See Also

SkillSetConfiguration Class
SkillSetConfiguration Members


IsExporting Property

[image]

IceLib Dialer Technical Reference
SkillSetConfiguration..::..IsExporting Property
SkillSetConfiguration Class See Also Send Feedback
Tells whether the current object is being used for exporting

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsExporting { get; private set; }
Visual Basic
Public Property IsExporting As Boolean
    Get
    Private Set

See Also

SkillSetConfiguration Class
SkillSetConfiguration Members


MinimumProficiency Property

[image]

IceLib Dialer Technical Reference
SkillSetConfiguration..::..MinimumProficiency Property
SkillSetConfiguration Class See Also Send Feedback
The minimum skill proficiency required by an agent to process a call for that skill.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<SkillSetConfiguration..::..Property, int> MinimumProficiency { get; }
Visual Basic
Public ReadOnly Property MinimumProficiency As GeneralConfigurationProperty(Of SkillSetConfiguration..::..Property, Integer)
    Get

See Also

SkillSetConfiguration Class
SkillSetConfiguration Members


RevisionLevel Property

[image]

IceLib Dialer Technical Reference
SkillSetConfiguration..::..RevisionLevel Property
SkillSetConfiguration Class See Also Send Feedback
The current version number of this object.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<SkillSetConfiguration..::..Property, int> RevisionLevel { get; }
Visual Basic
Public ReadOnly Property RevisionLevel As GeneralConfigurationProperty(Of SkillSetConfiguration..::..Property, Integer)
    Get

See Also

SkillSetConfiguration Class
SkillSetConfiguration Members


Skills Property

[image]

IceLib Dialer Technical Reference
SkillSetConfiguration..::..Skills Property
SkillSetConfiguration Class See Also Send Feedback
The list of Dialer skills contained in this skill set.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<SkillSetConfiguration..::..Property, Collection<DialerSkill>> Skills { get; }
Visual Basic
Public ReadOnly Property Skills As GeneralConfigurationProperty(Of SkillSetConfiguration..::..Property, Collection(Of DialerSkill))
    Get

See Also

SkillSetConfiguration Class
SkillSetConfiguration Members


SkillSetConfiguration.Property Enumeration

[image]

IceLib Dialer Technical Reference
SkillSetConfiguration..::..Property Enumeration
SkillSetConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Id | 0 | Represents the Id part of the ConfigurationId property.
DisplayName | 1 | Represents the DisplayName part of the ConfigurationId property.
ColumnName | 2 | Represents the ColumnName property.
MinimumProficiency | 3 | Represents the MinimumProficiency property.
Skills | 4 | Represents the Skills property.
RevisionLevel | 5 | Represents the RevisionLevel property.

See Also


SkillSetConfigurationList Class

[image]

IceLib Dialer Technical Reference
SkillSetConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing skill set configuration objects.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class SkillSetConfigurationList : EditableConfigurationList<SkillSetConfiguration, SkillSetConfiguration..::..Property>
Visual Basic
Public Class SkillSetConfigurationList _
    Inherits EditableConfigurationList(Of SkillSetConfiguration, SkillSetConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>
DynamicConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>
EditableConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..SkillSetConfigurationList

See Also

SkillSetConfigurationList Members


SkillSetConfigurationList Members

[image] [image]

IceLib Dialer Technical Reference
SkillSetConfigurationList Members
SkillSetConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The SkillSetConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | SkillSetConfigurationList | Initializes a new instance of the SkillSetConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)

See Also

SkillSetConfigurationList Class


SkillSetConfigurationList Constructor

[image]

IceLib Dialer Technical Reference
SkillSetConfigurationList Constructor
SkillSetConfigurationList Class See Also Send Feedback
Initializes a new instance of the SkillSetConfigurationList class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public SkillSetConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

SkillSetConfigurationList Class
SkillSetConfigurationList Members


SkillSetConfigurationList Methods

[image] [image]

IceLib Dialer Technical Reference
SkillSetConfigurationList Methods
SkillSetConfigurationList Class See Also Send Feedback

The SkillSetConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SkillSetConfigurationList Class


SkillSetConfigurationList Properties

[image] [image]

IceLib Dialer Technical Reference
SkillSetConfigurationList Properties
SkillSetConfigurationList Class See Also Send Feedback

The SkillSetConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)

See Also

SkillSetConfigurationList Class


SkillSetConfigurationList Events

[image] [image]

IceLib Dialer Technical Reference
SkillSetConfigurationList Events
SkillSetConfigurationList Class See Also Send Feedback

The SkillSetConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' SkillSetConfiguration, SkillSetConfiguration..::..Property >)>)>.)

See Also

SkillSetConfigurationList Class


SMSBehavior Class

[image]

IceLib Dialer Technical Reference
SMSBehavior Class
Members See Also Send Feedback
A PolicyBehavior which sends an email.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class SMSBehavior : PolicyBehavior
Visual Basic
Public NotInheritable Class SMSBehavior _
    Inherits PolicyBehavior

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyBehavior
ININ.IceLib.Configuration.Dialer..::..SMSBehavior

See Also

SMSBehavior Members


SMSBehavior Members

[image] [image]

IceLib Dialer Technical Reference
SMSBehavior Members
SMSBehavior Class Constructors Methods Properties See Also Send Feedback

The SMSBehavior type exposes the following members.

Constructors

 | Name | Description
Public method | SMSBehavior | Initializes a new instance of the SMSBehavior class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | Id | (Inherited from PolicyBehavior.)
Public property | Message | Get or set the content of the SMS.
Public property | Recipient | Get or set the recipient of the SMS.

See Also

SMSBehavior Class


SMSBehavior Constructor

[image]

IceLib Dialer Technical Reference
SMSBehavior Constructor
SMSBehavior Class See Also Send Feedback
Initializes a new instance of the SMSBehavior class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public SMSBehavior()
Visual Basic
Public Sub New

See Also

SMSBehavior Class
SMSBehavior Members


SMSBehavior Methods

[image] [image]

IceLib Dialer Technical Reference
SMSBehavior Methods
SMSBehavior Class See Also Send Feedback

The SMSBehavior type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SMSBehavior Class


SMSBehavior Properties

[image] [image]

IceLib Dialer Technical Reference
SMSBehavior Properties
SMSBehavior Class See Also Send Feedback

The SMSBehavior type exposes the following members.

Properties

 | Name | Description
Public property | BehaviorType | The type of action the behavior performs. (Inherited from PolicyBehavior.)
Public property | Id | (Inherited from PolicyBehavior.)
Public property | Message | Get or set the content of the SMS.
Public property | Recipient | Get or set the recipient of the SMS.

See Also

SMSBehavior Class


Message Property

[image]

IceLib Dialer Technical Reference
SMSBehavior..::..Message Property
SMSBehavior Class See Also Send Feedback
Get or set the content of the SMS.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Message { get; set; }
Visual Basic
Public Property Message As String
    Get
    Set

See Also

SMSBehavior Class
SMSBehavior Members


Recipient Property

[image]

IceLib Dialer Technical Reference
SMSBehavior..::..Recipient Property
SMSBehavior Class See Also Send Feedback
Get or set the recipient of the SMS.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Recipient { get; set; }
Visual Basic
Public Property Recipient As String
    Get
    Set

See Also

SMSBehavior Class
SMSBehavior Members


SMSBrokerAccount Class

[image]

IceLib Dialer Technical Reference
SMSBrokerAccount Class
Members See Also Send Feedback
An SMS Broker Account belonging to an SMS Broker.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class SMSBrokerAccount
Visual Basic
Public Class SMSBrokerAccount

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..SMSBrokerAccount

See Also

SMSBrokerAccount Members


SMSBrokerAccount Members

[image] [image]

IceLib Dialer Technical Reference
SMSBrokerAccount Members
SMSBrokerAccount Class Constructors Methods Properties See Also Send Feedback

The SMSBrokerAccount type exposes the following members.

Constructors

 | Name | Description
Public method | SMSBrokerAccount | Creates a new instance of the SMSBrokerAccount class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | The ID of the object.
Public property | LocalAddress | The local address of the broker account.

See Also

SMSBrokerAccount Class


SMSBrokerAccount Constructor

[image]

IceLib Dialer Technical Reference
SMSBrokerAccount Constructor
SMSBrokerAccount Class See Also Send Feedback
Creates a new instance of the SMSBrokerAccount class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public SMSBrokerAccount(
    string id,
    string localAddress
)
Visual Basic
Public Sub New ( _
    id As String, _
    localAddress As String _
)

Parameters

id
Type: System..::..String
the ID of this object.
localAddress
Type: System..::..String

See Also

SMSBrokerAccount Class
SMSBrokerAccount Members


SMSBrokerAccount Methods

[image] [image]

IceLib Dialer Technical Reference
SMSBrokerAccount Methods
SMSBrokerAccount Class See Also Send Feedback

The SMSBrokerAccount type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SMSBrokerAccount Class


SMSBrokerAccount Properties

[image] [image]

IceLib Dialer Technical Reference
SMSBrokerAccount Properties
SMSBrokerAccount Class See Also Send Feedback

The SMSBrokerAccount type exposes the following members.

Properties

 | Name | Description
Public property | Id | The ID of the object.
Public property | LocalAddress | The local address of the broker account.

See Also

SMSBrokerAccount Class


Id Property

[image]

IceLib Dialer Technical Reference
SMSBrokerAccount..::..Id Property
SMSBrokerAccount Class See Also Send Feedback
The ID of the object.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ConfigurationId Id { get; private set; }
Visual Basic
Public Property Id As ConfigurationId
    Get
    Private Set

See Also

SMSBrokerAccount Class
SMSBrokerAccount Members


LocalAddress Property

[image]

IceLib Dialer Technical Reference
SMSBrokerAccount..::..LocalAddress Property
SMSBrokerAccount Class See Also Send Feedback
The local address of the broker account.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string LocalAddress { get; private set; }
Visual Basic
Public Property LocalAddress As String
    Get
    Private Set

See Also

SMSBrokerAccount Class
SMSBrokerAccount Members


SMSBrokerConfiguration Class

[image]

IceLib Dialer Technical Reference
SMSBrokerConfiguration Class
Members See Also Send Feedback
Contains configuration for a Dialer SMS Broker.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class SMSBrokerConfiguration
Visual Basic
Public Class SMSBrokerConfiguration

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..SMSBrokerConfiguration

See Also

SMSBrokerConfiguration Members


SMSBrokerConfiguration Members

[image] [image]

IceLib Dialer Technical Reference
SMSBrokerConfiguration Members
SMSBrokerConfiguration Class Constructors Methods Properties See Also Send Feedback

The SMSBrokerConfiguration type exposes the following members.

Constructors

 | Name | Description
Public method | SMSBrokerConfiguration | Creates a new instance of the SMSBrokerAccount class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | The ID of the object.
Public property | SMSBrokerAccounts |

See Also

SMSBrokerConfiguration Class


SMSBrokerConfiguration Constructor

[image]

IceLib Dialer Technical Reference
SMSBrokerConfiguration Constructor
SMSBrokerConfiguration Class See Also Send Feedback
Creates a new instance of the SMSBrokerAccount class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public SMSBrokerConfiguration(
    string id,
    string[] accounts
)
Visual Basic
Public Sub New ( _
    id As String, _
    accounts As String() _
)

Parameters

id
Type: System..::..String
the ID of this object.
accounts
Type: array<System..::..String>[]()[][]

See Also

SMSBrokerConfiguration Class
SMSBrokerConfiguration Members


SMSBrokerConfiguration Methods

[image] [image]

IceLib Dialer Technical Reference
SMSBrokerConfiguration Methods
SMSBrokerConfiguration Class See Also Send Feedback

The SMSBrokerConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SMSBrokerConfiguration Class


SMSBrokerConfiguration Properties

[image] [image]

IceLib Dialer Technical Reference
SMSBrokerConfiguration Properties
SMSBrokerConfiguration Class See Also Send Feedback

The SMSBrokerConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Id | The ID of the object.
Public property | SMSBrokerAccounts |

See Also

SMSBrokerConfiguration Class


Id Property

[image]

IceLib Dialer Technical Reference
SMSBrokerConfiguration..::..Id Property
SMSBrokerConfiguration Class See Also Send Feedback
The ID of the object.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ConfigurationId Id { get; private set; }
Visual Basic
Public Property Id As ConfigurationId
    Get
    Private Set

See Also

SMSBrokerConfiguration Class
SMSBrokerConfiguration Members


SMSBrokerAccounts Property

[image]

IceLib Dialer Technical Reference
SMSBrokerConfiguration..::..SMSBrokerAccounts Property
SMSBrokerConfiguration Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<SMSBrokerAccount> SMSBrokerAccounts { get; private set; }
Visual Basic
Public Property SMSBrokerAccounts As Collection(Of SMSBrokerAccount)
    Get
    Private Set

See Also

SMSBrokerConfiguration Class
SMSBrokerConfiguration Members


SMSBrokerConfigurationList Class

[image]

IceLib Dialer Technical Reference
SMSBrokerConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing SMS Broker configuration objects.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class SMSBrokerConfigurationList
Visual Basic
Public Class SMSBrokerConfigurationList

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..SMSBrokerConfigurationList

See Also

SMSBrokerConfigurationList Members


SMSBrokerConfigurationList Members

[image] [image]

IceLib Dialer Technical Reference
SMSBrokerConfigurationList Members
SMSBrokerConfigurationList Class Constructors Methods Properties See Also Send Feedback

The SMSBrokerConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | SMSBrokerConfigurationList | Initializes a new instance of the SMSBrokerConfigurationList class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSMSBrokerAccountIds |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | SmsBrokerList |

See Also

SMSBrokerConfigurationList Class


SMSBrokerConfigurationList Constructor

[image]

IceLib Dialer Technical Reference
SMSBrokerConfigurationList Constructor
SMSBrokerConfigurationList Class See Also Send Feedback
Initializes a new instance of the SMSBrokerConfigurationList class

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public SMSBrokerConfigurationList(
    Session session
)
Visual Basic
Public Sub New ( _
    session As Session _
)

Parameters

session
Type: Session

See Also

SMSBrokerConfigurationList Class
SMSBrokerConfigurationList Members


SMSBrokerConfigurationList Methods

[image] [image]

IceLib Dialer Technical Reference
SMSBrokerConfigurationList Methods
SMSBrokerConfigurationList Class See Also Send Feedback

The SMSBrokerConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSMSBrokerAccountIds |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SMSBrokerConfigurationList Class


GetSMSBrokerAccountIds Method

[image]

IceLib Dialer Technical Reference
SMSBrokerConfigurationList..::..GetSMSBrokerAccountIds Method
SMSBrokerConfigurationList Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<SMSBrokerAccount> GetSMSBrokerAccountIds(
    string smsBrokerId
)
Visual Basic
Public Function GetSMSBrokerAccountIds ( _
    smsBrokerId As String _
) As Collection(Of SMSBrokerAccount)

Parameters

smsBrokerId
Type: System..::..String

See Also

SMSBrokerConfigurationList Class
SMSBrokerConfigurationList Members


SMSBrokerConfigurationList Properties

[image] [image]

IceLib Dialer Technical Reference
SMSBrokerConfigurationList Properties
SMSBrokerConfigurationList Class See Also Send Feedback

The SMSBrokerConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | SmsBrokerList |

See Also

SMSBrokerConfigurationList Class


SmsBrokerList Property

[image]

IceLib Dialer Technical Reference
SMSBrokerConfigurationList..::..SmsBrokerList Property
SMSBrokerConfigurationList Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<SMSBrokerConfiguration> SmsBrokerList { get; private set; }
Visual Basic
Public Property SmsBrokerList As Collection(Of SMSBrokerConfiguration)
    Get
    Private Set

See Also

SMSBrokerConfigurationList Class
SMSBrokerConfigurationList Members


SMSRuleAction Class

[image]

IceLib Dialer Technical Reference
SMSRuleAction Class
Members See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class SMSRuleAction : RuleAction
Visual Basic
Public NotInheritable Class SMSRuleAction _
    Inherits RuleAction

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..RuleAction
ININ.IceLib.Configuration.Dialer..::..SMSRuleAction

See Also

SMSRuleAction Members


SMSRuleAction Members

[image] [image]

IceLib Dialer Technical Reference
SMSRuleAction Members
SMSRuleAction Class Constructors Methods Properties See Also Send Feedback

The SMSRuleAction type exposes the following members.

Constructors

 | Name | Description
Public method | SMSRuleAction | Creates a new instance of the SMSRuleAction class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActionType | The type of action to perform. (Inherited from RuleAction.)
Public property | Id | The Id of the action. (Inherited from RuleAction.)
Public property | Index | The ordinal number of this action in relation to other actions in a rule. (Inherited from RuleAction.)
Public property | Message | The content of the text message.
Public property | Recipient | The phone number to send the message to.

See Also

SMSRuleAction Class


SMSRuleAction Constructor

[image]

IceLib Dialer Technical Reference
SMSRuleAction Constructor
SMSRuleAction Class See Also Send Feedback
Creates a new instance of the SMSRuleAction class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public SMSRuleAction()
Visual Basic
Public Sub New

See Also

SMSRuleAction Class
SMSRuleAction Members


SMSRuleAction Methods

[image] [image]

IceLib Dialer Technical Reference
SMSRuleAction Methods
SMSRuleAction Class See Also Send Feedback

The SMSRuleAction type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SMSRuleAction Class


SMSRuleAction Properties

[image] [image]

IceLib Dialer Technical Reference
SMSRuleAction Properties
SMSRuleAction Class See Also Send Feedback

The SMSRuleAction type exposes the following members.

Properties

 | Name | Description
Public property | ActionType | The type of action to perform. (Inherited from RuleAction.)
Public property | Id | The Id of the action. (Inherited from RuleAction.)
Public property | Index | The ordinal number of this action in relation to other actions in a rule. (Inherited from RuleAction.)
Public property | Message | The content of the text message.
Public property | Recipient | The phone number to send the message to.

See Also

SMSRuleAction Class


Message Property

[image]

IceLib Dialer Technical Reference
SMSRuleAction..::..Message Property
SMSRuleAction Class See Also Send Feedback
The content of the text message.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Message { get; set; }
Visual Basic
Public Property Message As String
    Get
    Set

See Also

SMSRuleAction Class
SMSRuleAction Members


Recipient Property

[image]

IceLib Dialer Technical Reference
SMSRuleAction..::..Recipient Property
SMSRuleAction Class See Also Send Feedback
The phone number to send the message to.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Recipient { get; set; }
Visual Basic
Public Property Recipient As String
    Get
    Set

See Also

SMSRuleAction Class
SMSRuleAction Members


StageSetConfiguration Class

[image]

IceLib Dialer Technical Reference
StageSetConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for a Dialer Call Stage

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class StageSetConfiguration : EditableListConfigurationObject<StageSetConfiguration..::..Property>,
    IExportable
Visual Basic
Public Class StageSetConfiguration _
    Inherits EditableListConfigurationObject(Of StageSetConfiguration..::..Property) _
    Implements IExportable

Inheritance Hierarchy

System..::..Object
ConfigurationObject
ListConfigurationObject
EditableListConfigurationObject<(Of <(<' StageSetConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..StageSetConfiguration

See Also

StageSetConfiguration Members


StageSetConfiguration Members

[image] [image]

IceLib Dialer Technical Reference
StageSetConfiguration Members
StageSetConfiguration Class Methods Properties See Also Send Feedback

The StageSetConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' StageSetConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' StageSetConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' StageSetConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' StageSetConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' StageSetConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' StageSetConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' StageSetConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' StageSetConfiguration..::..Property >)>)>.)
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' StageSetConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' StageSetConfiguration..::..Property >)>)>.)
Public method | ToString | (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' StageSetConfiguration..::..Property >)>)>.)
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsExporting | Tells whether the current object is being used for exporting
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | RevisionLevel | The current version of this object.
Public property | StageSet | The call stages contained in this stage set.

See Also

StageSetConfiguration Class


StageSetConfiguration Methods

[image] [image]

IceLib Dialer Technical Reference
StageSetConfiguration Methods
StageSetConfiguration Class See Also Send Feedback

The StageSetConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' StageSetConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' StageSetConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' StageSetConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' StageSetConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' StageSetConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' StageSetConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' StageSetConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' StageSetConfiguration..::..Property >)>)>.)
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' StageSetConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' StageSetConfiguration..::..Property >)>)>.)
Public method | ToString | (Inherited from ConfigurationObject.)

See Also

StageSetConfiguration Class


StageSetConfiguration Properties

[image] [image]

IceLib Dialer Technical Reference
StageSetConfiguration Properties
StageSetConfiguration Class See Also Send Feedback

The StageSetConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' StageSetConfiguration..::..Property >)>)>.)
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsExporting | Tells whether the current object is being used for exporting
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | RevisionLevel | The current version of this object.
Public property | StageSet | The call stages contained in this stage set.

See Also

StageSetConfiguration Class


IsDefaultObject Property

[image]

IceLib Dialer Technical Reference
StageSetConfiguration..::..IsDefaultObject Property
StageSetConfiguration Class See Also Send Feedback
Indicates whether this is the default instance of this object type.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsDefaultObject { get; }
Visual Basic
Public ReadOnly Property IsDefaultObject As Boolean
    Get

See Also

StageSetConfiguration Class
StageSetConfiguration Members


IsExporting Property

[image]

IceLib Dialer Technical Reference
StageSetConfiguration..::..IsExporting Property
StageSetConfiguration Class See Also Send Feedback
Tells whether the current object is being used for exporting

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsExporting { get; private set; }
Visual Basic
Public Property IsExporting As Boolean
    Get
    Private Set

See Also

StageSetConfiguration Class
StageSetConfiguration Members


RevisionLevel Property

[image]

IceLib Dialer Technical Reference
StageSetConfiguration..::..RevisionLevel Property
StageSetConfiguration Class See Also Send Feedback
The current version of this object.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<StageSetConfiguration..::..Property, int> RevisionLevel { get; }
Visual Basic
Public ReadOnly Property RevisionLevel As GeneralConfigurationProperty(Of StageSetConfiguration..::..Property, Integer)
    Get

See Also

StageSetConfiguration Class
StageSetConfiguration Members


StageSet Property

[image]

IceLib Dialer Technical Reference
StageSetConfiguration..::..StageSet Property
StageSetConfiguration Class See Also Send Feedback
The call stages contained in this stage set.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<StageSetConfiguration..::..Property, Collection<CallStage>> StageSet { get; }
Visual Basic
Public ReadOnly Property StageSet As GeneralConfigurationProperty(Of StageSetConfiguration..::..Property, Collection(Of CallStage))
    Get

See Also

StageSetConfiguration Class
StageSetConfiguration Members


StageSetConfiguration.Property Enumeration

[image]

IceLib Dialer Technical Reference
StageSetConfiguration..::..Property Enumeration
StageSetConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Id | 0 | Represents the Id part of the ConfigurationId property.
DisplayName | 1 | Represents the DisplayName part of the ConfigurationId property.
RevisionLevel | 2 | Represents the RevisionLevel property.
StageSet | 3 | Represents the StageSet property.

See Also


StageSetConfigurationList Class

[image]

IceLib Dialer Technical Reference
StageSetConfigurationList Class
Members See Also Send Feedback
Allows for querying and management stage set objects.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class StageSetConfigurationList : EditableConfigurationList<StageSetConfiguration, StageSetConfiguration..::..Property>
Visual Basic
Public Class StageSetConfigurationList _
    Inherits EditableConfigurationList(Of StageSetConfiguration, StageSetConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>
DynamicConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>
EditableConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..StageSetConfigurationList

See Also

StageSetConfigurationList Members


StageSetConfigurationList Members

[image] [image]

IceLib Dialer Technical Reference
StageSetConfigurationList Members
StageSetConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The StageSetConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | StageSetConfigurationList | Creates a new instance of the StageSetConfigurationList object.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)

See Also

StageSetConfigurationList Class


StageSetConfigurationList Constructor

[image]

IceLib Dialer Technical Reference
StageSetConfigurationList Constructor
StageSetConfigurationList Class See Also Send Feedback
Creates a new instance of the StageSetConfigurationList object.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public StageSetConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ConfigurationManager
The configuration manager.

See Also

StageSetConfigurationList Class
StageSetConfigurationList Members


StageSetConfigurationList Methods

[image] [image]

IceLib Dialer Technical Reference
StageSetConfigurationList Methods
StageSetConfigurationList Class See Also Send Feedback

The StageSetConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StageSetConfigurationList Class


StageSetConfigurationList Properties

[image] [image]

IceLib Dialer Technical Reference
StageSetConfigurationList Properties
StageSetConfigurationList Class See Also Send Feedback

The StageSetConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)

See Also

StageSetConfigurationList Class


StageSetConfigurationList Events

[image] [image]

IceLib Dialer Technical Reference
StageSetConfigurationList Events
StageSetConfigurationList Class See Also Send Feedback

The StageSetConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' StageSetConfiguration, StageSetConfiguration..::..Property >)>)>.)

See Also

StageSetConfigurationList Class


StatCondition Class

[image]

IceLib Dialer Technical Reference
StatCondition Class
Members See Also Send Feedback
A policy condition that checks if a system statistic matches a certain value.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class StatCondition : PolicyCondition
Visual Basic
Public Class StatCondition _
    Inherits PolicyCondition

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyCondition
ININ.IceLib.Configuration.Dialer..::..StatCondition

See Also

StatCondition Members


StatCondition Members

[image] [image]

IceLib Dialer Technical Reference
StatCondition Members
StatCondition Class Constructors Methods Properties See Also Send Feedback

The StatCondition type exposes the following members.

Constructors

 | Name | Description
Public method | StatCondition | Creates a new instance of the StatCondition class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConditionType | The type of condition. (Inherited from PolicyCondition.)
Public property | Id | The Id of the condition. (Inherited from PolicyCondition.)
Public property | Negated | When true, the logical result of the condition evaluation is flipped. (Inherited from PolicyCondition.)
Public property | Operation | An conditional operator that compares the statistic value to the matching value.
Public property | Parameters | Parameter values for the monitored statistic. The parameter keys are taken from the ParameterTypeId Id. Check the appropriate StatisticDefinition to see the required parameters.
Public property | StatIdentifierURI | The URI of the StatisticIdentifier.
Public property | StatValue | The value to check against the statistic.

See Also

StatCondition Class


StatCondition Constructor

[image]

IceLib Dialer Technical Reference
StatCondition Constructor
StatCondition Class See Also Send Feedback
Creates a new instance of the StatCondition class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public StatCondition()
Visual Basic
Public Sub New

See Also

StatCondition Class
StatCondition Members


StatCondition Methods

[image] [image]

IceLib Dialer Technical Reference
StatCondition Methods
StatCondition Class See Also Send Feedback

The StatCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StatCondition Class


StatCondition Properties

[image] [image]

IceLib Dialer Technical Reference
StatCondition Properties
StatCondition Class See Also Send Feedback

The StatCondition type exposes the following members.

Properties

 | Name | Description
Public property | ConditionType | The type of condition. (Inherited from PolicyCondition.)
Public property | Id | The Id of the condition. (Inherited from PolicyCondition.)
Public property | Negated | When true, the logical result of the condition evaluation is flipped. (Inherited from PolicyCondition.)
Public property | Operation | An conditional operator that compares the statistic value to the matching value.
Public property | Parameters | Parameter values for the monitored statistic. The parameter keys are taken from the ParameterTypeId Id. Check the appropriate StatisticDefinition to see the required parameters.
Public property | StatIdentifierURI | The URI of the StatisticIdentifier.
Public property | StatValue | The value to check against the statistic.

See Also

StatCondition Class


Operation Property

[image]

IceLib Dialer Technical Reference
StatCondition..::..Operation Property
StatCondition Class See Also Send Feedback
An conditional operator that compares the statistic value to the matching value.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ComparisonOperator Operation { get; set; }
Visual Basic
Public Property Operation As ComparisonOperator
    Get
    Set

See Also

StatCondition Class
StatCondition Members


Parameters Property

[image]

IceLib Dialer Technical Reference
StatCondition..::..Parameters Property
StatCondition Class See Also Send Feedback
Parameter values for the monitored statistic. The parameter keys are taken from the ParameterTypeId Id. Check the appropriate StatisticDefinition to see the required parameters.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Dictionary<string, string> Parameters { get; }
Visual Basic
Public ReadOnly Property Parameters As Dictionary(Of String, String)
    Get

See Also

StatCondition Class
StatCondition Members


StatIdentifierURI Property

[image]

IceLib Dialer Technical Reference
StatCondition..::..StatIdentifierURI Property
StatCondition Class See Also Send Feedback
The URI of the StatisticIdentifier.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string StatIdentifierURI { get; set; }
Visual Basic
Public Property StatIdentifierURI As String
    Get
    Set

See Also

StatCondition Class
StatCondition Members


StatValue Property

[image]

IceLib Dialer Technical Reference
StatCondition..::..StatValue Property
StatCondition Class See Also Send Feedback
The value to check against the statistic.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string StatValue { get; set; }
Visual Basic
Public Property StatValue As String
    Get
    Set

See Also

StatCondition Class
StatCondition Members


StatRule Class

[image]

IceLib Dialer Technical Reference
StatRule Class
Members See Also Send Feedback
A rule with a statistics-based condition.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class StatRule : Rule
Visual Basic
Public Class StatRule _
    Inherits Rule

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..Rule
ININ.IceLib.Configuration.Dialer..::..StatRule
ININ.IceLib.Configuration.Dialer..::..CustomStatRule

See Also

StatRule Members


StatRule Members

[image] [image]

IceLib Dialer Technical Reference
StatRule Members
StatRule Class Constructors Methods Properties See Also Send Feedback

The StatRule type exposes the following members.

Constructors

 | Name | Description
Public method | StatRule | Constructs a new instance of the StatRule class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Actions | The collection of Actions to perform when this Rule's conditions are met (Inherited from Rule.)
Public property | Enabled | Toggle evaluation/execution of this rule. (Inherited from Rule.)
Public property | Groups | Named rule groups (within the parent RuleSetConfiguration) to which this rule belongs. (Inherited from Rule.)
Public property | Id | The Id of the Rule. (Inherited from Rule.)
Public property | IgnoreGroups | Specifies whether this rule should be evaluated no matter which group is active. (Inherited from Rule.)
Public property | InAllGroups | Specifies whether this rule is a member of all rule groups of the rule set it belongs to. (Inherited from Rule.)
Public property | Index | Specifies the order to display and execute this rule in relation to other rules in the parent rule set. (Inherited from Rule.)
Public property | InStartupGroup | Specifies whether this rule is a member of the unnamed group that the rule set evaluates first. (Inherited from Rule.)
Public property | IntervalMinutes | The minimum interval (in minutes) between evaluation of the statistic.
Public property | Parameters | Parameter values for the monitored statistic. The parameter keys are taken from the ParameterTypeId Id. Check the appropriate StatisticDefinition to see the required parameters.
Public property | Repetition | Specifies how often the rule should be re-evaluated. (Inherited from Rule.)
Public property | StatIdentifierURI | The URI string of the StatisticIdentifier.
Public property | StatOperation | The comparison operator used in evaluating the rule condition.
Public property | StatValue | The value of the statistic used in evaluating the rule condition.
Public property | TerminateOnAction | Specifies the manner in which rule evaluation should be stopped after this rule runs its actions. (Inherited from Rule.)

See Also

StatRule Class


StatRule Constructor

[image]

IceLib Dialer Technical Reference
StatRule Constructor
StatRule Class See Also Send Feedback
Constructs a new instance of the StatRule class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public StatRule()
Visual Basic
Public Sub New

See Also

StatRule Class
StatRule Members


StatRule Methods

[image] [image]

IceLib Dialer Technical Reference
StatRule Methods
StatRule Class See Also Send Feedback

The StatRule type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StatRule Class


StatRule Properties

[image] [image]

IceLib Dialer Technical Reference
StatRule Properties
StatRule Class See Also Send Feedback

The StatRule type exposes the following members.

Properties

 | Name | Description
Public property | Actions | The collection of Actions to perform when this Rule's conditions are met (Inherited from Rule.)
Public property | Enabled | Toggle evaluation/execution of this rule. (Inherited from Rule.)
Public property | Groups | Named rule groups (within the parent RuleSetConfiguration) to which this rule belongs. (Inherited from Rule.)
Public property | Id | The Id of the Rule. (Inherited from Rule.)
Public property | IgnoreGroups | Specifies whether this rule should be evaluated no matter which group is active. (Inherited from Rule.)
Public property | InAllGroups | Specifies whether this rule is a member of all rule groups of the rule set it belongs to. (Inherited from Rule.)
Public property | Index | Specifies the order to display and execute this rule in relation to other rules in the parent rule set. (Inherited from Rule.)
Public property | InStartupGroup | Specifies whether this rule is a member of the unnamed group that the rule set evaluates first. (Inherited from Rule.)
Public property | IntervalMinutes | The minimum interval (in minutes) between evaluation of the statistic.
Public property | Parameters | Parameter values for the monitored statistic. The parameter keys are taken from the ParameterTypeId Id. Check the appropriate StatisticDefinition to see the required parameters.
Public property | Repetition | Specifies how often the rule should be re-evaluated. (Inherited from Rule.)
Public property | StatIdentifierURI | The URI string of the StatisticIdentifier.
Public property | StatOperation | The comparison operator used in evaluating the rule condition.
Public property | StatValue | The value of the statistic used in evaluating the rule condition.
Public property | TerminateOnAction | Specifies the manner in which rule evaluation should be stopped after this rule runs its actions. (Inherited from Rule.)

See Also

StatRule Class


IntervalMinutes Property

[image]

IceLib Dialer Technical Reference
StatRule..::..IntervalMinutes Property
StatRule Class See Also Send Feedback
The minimum interval (in minutes) between evaluation of the statistic.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int IntervalMinutes { get; set; }
Visual Basic
Public Property IntervalMinutes As Integer
    Get
    Set

See Also

StatRule Class
StatRule Members


Parameters Property

[image]

IceLib Dialer Technical Reference
StatRule..::..Parameters Property
StatRule Class See Also Send Feedback
Parameter values for the monitored statistic. The parameter keys are taken from the ParameterTypeId Id. Check the appropriate StatisticDefinition to see the required parameters.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Dictionary<string, string> Parameters { get; }
Visual Basic
Public ReadOnly Property Parameters As Dictionary(Of String, String)
    Get

See Also

StatRule Class
StatRule Members


StatIdentifierURI Property

[image]

IceLib Dialer Technical Reference
StatRule..::..StatIdentifierURI Property
StatRule Class See Also Send Feedback
The URI string of the StatisticIdentifier.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string StatIdentifierURI { get; set; }
Visual Basic
Public Property StatIdentifierURI As String
    Get
    Set

See Also

StatRule Class
StatRule Members


StatOperation Property

[image]

IceLib Dialer Technical Reference
StatRule..::..StatOperation Property
StatRule Class See Also Send Feedback
The comparison operator used in evaluating the rule condition.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ComparisonOperator StatOperation { get; set; }
Visual Basic
Public Property StatOperation As ComparisonOperator
    Get
    Set

See Also

StatRule Class
StatRule Members


StatValue Property

[image]

IceLib Dialer Technical Reference
StatRule..::..StatValue Property
StatRule Class See Also Send Feedback
The value of the statistic used in evaluating the rule condition.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string StatValue { get; set; }
Visual Basic
Public Property StatValue As String
    Get
    Set

See Also

StatRule Class
StatRule Members


StatSequenceItem Class

[image]

IceLib Dialer Technical Reference
StatSequenceItem Class
Members See Also Send Feedback
A Class that represents a Sequence Item that is triggered when a Stat meets a specific condition.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class StatSequenceItem : SequenceItem
Visual Basic
Public Class StatSequenceItem _
    Inherits SequenceItem

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..SequenceItem
ININ.IceLib.Configuration.Dialer..::..StatSequenceItem

See Also

StatSequenceItem Members


StatSequenceItem Members

[image] [image]

IceLib Dialer Technical Reference
StatSequenceItem Members
StatSequenceItem Class Constructors Methods Properties See Also Send Feedback

The StatSequenceItem type exposes the following members.

Constructors

 | Name | Description
Public method | StatSequenceItem(CampaignGroup) | Constructs a new instance of the StatSequenceItem class.
Public method | StatSequenceItem(ConfigurationId, CampaignGroup) | Constructs a new instance of the StatSequenceItem

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDisplayName | Public method to change the display name of a CampaignGroup (Inherited from SequenceItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CampaignGroup | The CampaignGroup that is triggered by this Sequence Item (Inherited from SequenceItem.)
Public property | ConditionType | Specifies the Type of Sequence Item this is: Event, Time or Stat. (Inherited from SequenceItem.)
Public property | Id | The Id of the SequenceItem. (Inherited from SequenceItem.)
Public property | IgnoreGroups | Specifies whether this Sequence Item should be evaluated no matter which campaign group is active. (Inherited from SequenceItem.)
Public property | InAllGroups | Specifies whether this Sequence Item is a child of all campaign groups of the sequence definition that it belongs to. (Inherited from SequenceItem.)
Public property | Index | Specifies the order to display and execute Sequence Item in relation to other Sequence Items in the Sequence. (Inherited from SequenceItem.)
Public property | InStartupGroup | Specifies whether this rule is a member of the unnamed group that the rule set evaluates first. (Inherited from SequenceItem.)
Public property | IntervalMinutes | The minimum interval (in minutes) between evaluation of the statistic.
Public property | Parameters | Parameter values for the monitored statistic. The parameter keys are taken from the ParameterTypeId Id. Check the appropriate StatisticDefinition to see the required parameters.
Public property | ParentGroups | Named campaign groups (within the sequence Sequence) to which this sequence item represents. (Inherited from SequenceItem.)
Public property | StatIdentifierURI | The URI string of the StatisticIdentifier.
Public property | StatOperation | The comparison operator used in evaluating the rule condition.
Public property | StatValue | The value of the statistic used in evaluating the rule condition.

See Also

StatSequenceItem Class


StatSequenceItem Constructor

[image] [image]

IceLib Dialer Technical Reference
StatSequenceItem Constructor
StatSequenceItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StatSequenceItem(CampaignGroup) | Constructs a new instance of the StatSequenceItem class.
Public method | StatSequenceItem(ConfigurationId, CampaignGroup) | Constructs a new instance of the StatSequenceItem

See Also

StatSequenceItem Class
StatSequenceItem Members


StatSequenceItem Constructor (CampaignGroup)

[image]

IceLib Dialer Technical Reference
StatSequenceItem Constructor (CampaignGroup)
StatSequenceItem Class See Also Send Feedback
Constructs a new instance of the StatSequenceItem class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public StatSequenceItem(
    CampaignGroup group
)
Visual Basic
Public Sub New ( _
    group As CampaignGroup _
)

Parameters

group
Type: ININ.IceLib.Configuration.Dialer..::..CampaignGroup

See Also

StatSequenceItem Class
StatSequenceItem Members
StatSequenceItem Overload


StatSequenceItem Constructor (ConfigurationId, CampaignGroup)

[image]

IceLib Dialer Technical Reference
StatSequenceItem Constructor (ConfigurationId, CampaignGroup)
StatSequenceItem Class See Also Send Feedback
Constructs a new instance of the StatSequenceItem

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public StatSequenceItem(
    ConfigurationId id,
    CampaignGroup group
)
Visual Basic
Public Sub New ( _
    id As ConfigurationId, _
    group As CampaignGroup _
)

Parameters

id
Type: ConfigurationId
The Id ConfigurationId you wish to assign to the sequence item.
group
Type: ININ.IceLib.Configuration.Dialer..::..CampaignGroup

See Also

StatSequenceItem Class
StatSequenceItem Members
StatSequenceItem Overload


StatSequenceItem Methods

[image] [image]

IceLib Dialer Technical Reference
StatSequenceItem Methods
StatSequenceItem Class See Also Send Feedback

The StatSequenceItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDisplayName | Public method to change the display name of a CampaignGroup (Inherited from SequenceItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StatSequenceItem Class


StatSequenceItem Properties

[image] [image]

IceLib Dialer Technical Reference
StatSequenceItem Properties
StatSequenceItem Class See Also Send Feedback

The StatSequenceItem type exposes the following members.

Properties

 | Name | Description
Public property | CampaignGroup | The CampaignGroup that is triggered by this Sequence Item (Inherited from SequenceItem.)
Public property | ConditionType | Specifies the Type of Sequence Item this is: Event, Time or Stat. (Inherited from SequenceItem.)
Public property | Id | The Id of the SequenceItem. (Inherited from SequenceItem.)
Public property | IgnoreGroups | Specifies whether this Sequence Item should be evaluated no matter which campaign group is active. (Inherited from SequenceItem.)
Public property | InAllGroups | Specifies whether this Sequence Item is a child of all campaign groups of the sequence definition that it belongs to. (Inherited from SequenceItem.)
Public property | Index | Specifies the order to display and execute Sequence Item in relation to other Sequence Items in the Sequence. (Inherited from SequenceItem.)
Public property | InStartupGroup | Specifies whether this rule is a member of the unnamed group that the rule set evaluates first. (Inherited from SequenceItem.)
Public property | IntervalMinutes | The minimum interval (in minutes) between evaluation of the statistic.
Public property | Parameters | Parameter values for the monitored statistic. The parameter keys are taken from the ParameterTypeId Id. Check the appropriate StatisticDefinition to see the required parameters.
Public property | ParentGroups | Named campaign groups (within the sequence Sequence) to which this sequence item represents. (Inherited from SequenceItem.)
Public property | StatIdentifierURI | The URI string of the StatisticIdentifier.
Public property | StatOperation | The comparison operator used in evaluating the rule condition.
Public property | StatValue | The value of the statistic used in evaluating the rule condition.

See Also

StatSequenceItem Class


IntervalMinutes Property

[image]

IceLib Dialer Technical Reference
StatSequenceItem..::..IntervalMinutes Property
StatSequenceItem Class See Also Send Feedback
The minimum interval (in minutes) between evaluation of the statistic.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int IntervalMinutes { get; set; }
Visual Basic
Public Property IntervalMinutes As Integer
    Get
    Set

See Also

StatSequenceItem Class
StatSequenceItem Members


Parameters Property

[image]

IceLib Dialer Technical Reference
StatSequenceItem..::..Parameters Property
StatSequenceItem Class See Also Send Feedback
Parameter values for the monitored statistic. The parameter keys are taken from the ParameterTypeId Id. Check the appropriate StatisticDefinition to see the required parameters.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Dictionary<string, string> Parameters { get; }
Visual Basic
Public ReadOnly Property Parameters As Dictionary(Of String, String)
    Get

See Also

StatSequenceItem Class
StatSequenceItem Members


StatIdentifierURI Property

[image]

IceLib Dialer Technical Reference
StatSequenceItem..::..StatIdentifierURI Property
StatSequenceItem Class See Also Send Feedback
The URI string of the StatisticIdentifier.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string StatIdentifierURI { get; set; }
Visual Basic
Public Property StatIdentifierURI As String
    Get
    Set

See Also

StatSequenceItem Class
StatSequenceItem Members


StatOperation Property

[image]

IceLib Dialer Technical Reference
StatSequenceItem..::..StatOperation Property
StatSequenceItem Class See Also Send Feedback
The comparison operator used in evaluating the rule condition.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ComparisonOperator StatOperation { get; set; }
Visual Basic
Public Property StatOperation As ComparisonOperator
    Get
    Set

See Also

StatSequenceItem Class
StatSequenceItem Members


StatValue Property

[image]

IceLib Dialer Technical Reference
StatSequenceItem..::..StatValue Property
StatSequenceItem Class See Also Send Feedback
The value of the statistic used in evaluating the rule condition.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string StatValue { get; set; }
Visual Basic
Public Property StatValue As String
    Get
    Set

See Also

StatSequenceItem Class
StatSequenceItem Members


TableType Enumeration

[image]

IceLib Dialer Technical Reference
TableType Enumeration
See Also Send Feedback
The database tables associated with a contact list object.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
[FlagsAttribute]
public enum TableType
Visual Basic
<FlagsAttribute> _
Public Enumeration TableType

Members

Member name | Value | Description
ContactList | 1 | The contact list table.
CallSchedule | 8 | The call schedule table.
PhoneNumberDetails | 64 | The phone number details table.
JIT | 256 | The priority dialing (just-in-time) table.
DNCMetadata | 32768 | DNC Metadata for a contact list.

See Also


TimeAndDateCondition Class

[image]

IceLib Dialer Technical Reference
TimeAndDateCondition Class
Members See Also Send Feedback
A PolicyCondition which will check the current time and date.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class TimeAndDateCondition : TimeCondition
Visual Basic
Public Class TimeAndDateCondition _
    Inherits TimeCondition

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyCondition
ININ.IceLib.Configuration.Dialer..::..TimeCondition
ININ.IceLib.Configuration.Dialer..::..TimeAndDateCondition

See Also

TimeAndDateCondition Members


TimeAndDateCondition Members

[image] [image]

IceLib Dialer Technical Reference
TimeAndDateCondition Members
TimeAndDateCondition Class Constructors Methods Properties See Also Send Feedback

The TimeAndDateCondition type exposes the following members.

Constructors

 | Name | Description
Public method | TimeAndDateCondition | Initializes a new instance of the TimeAndDateCondition class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConditionType | The type of condition. (Inherited from PolicyCondition.)
Public property | EndDate | Get or set the last date on which to trigger this condition.
Public property | EndTime | Get or set the time of day to stop triggering this condition. (Inherited from TimeCondition.)
Public property | Id | The Id of the condition. (Inherited from PolicyCondition.)
Public property | Negated | When true, the logical result of the condition evaluation is flipped. (Inherited from PolicyCondition.)
Public property | StartDate | Get or set the first date on which to trigger this condition.
Public property | StartTime | Get or set the time of day to start triggering this condition. (Inherited from TimeCondition.)

See Also

TimeAndDateCondition Class


TimeAndDateCondition Constructor

[image]

IceLib Dialer Technical Reference
TimeAndDateCondition Constructor
TimeAndDateCondition Class See Also Send Feedback
Initializes a new instance of the TimeAndDateCondition class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public TimeAndDateCondition()
Visual Basic
Public Sub New

See Also

TimeAndDateCondition Class
TimeAndDateCondition Members


TimeAndDateCondition Methods

[image] [image]

IceLib Dialer Technical Reference
TimeAndDateCondition Methods
TimeAndDateCondition Class See Also Send Feedback

The TimeAndDateCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimeAndDateCondition Class


TimeAndDateCondition Properties

[image] [image]

IceLib Dialer Technical Reference
TimeAndDateCondition Properties
TimeAndDateCondition Class See Also Send Feedback

The TimeAndDateCondition type exposes the following members.

Properties

 | Name | Description
Public property | ConditionType | The type of condition. (Inherited from PolicyCondition.)
Public property | EndDate | Get or set the last date on which to trigger this condition.
Public property | EndTime | Get or set the time of day to stop triggering this condition. (Inherited from TimeCondition.)
Public property | Id | The Id of the condition. (Inherited from PolicyCondition.)
Public property | Negated | When true, the logical result of the condition evaluation is flipped. (Inherited from PolicyCondition.)
Public property | StartDate | Get or set the first date on which to trigger this condition.
Public property | StartTime | Get or set the time of day to start triggering this condition. (Inherited from TimeCondition.)

See Also

TimeAndDateCondition Class


EndDate Property

[image]

IceLib Dialer Technical Reference
TimeAndDateCondition..::..EndDate Property
TimeAndDateCondition Class See Also Send Feedback
Get or set the last date on which to trigger this condition.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DateTime EndDate { get; set; }
Visual Basic
Public Property EndDate As DateTime
    Get
    Set

See Also

TimeAndDateCondition Class
TimeAndDateCondition Members


StartDate Property

[image]

IceLib Dialer Technical Reference
TimeAndDateCondition..::..StartDate Property
TimeAndDateCondition Class See Also Send Feedback
Get or set the first date on which to trigger this condition.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DateTime StartDate { get; set; }
Visual Basic
Public Property StartDate As DateTime
    Get
    Set

See Also

TimeAndDateCondition Class
TimeAndDateCondition Members


TimeAndDayCondition Class

[image]

IceLib Dialer Technical Reference
TimeAndDayCondition Class
Members See Also Send Feedback
A PolicyCondition which will check the current time and day of the week.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class TimeAndDayCondition : TimeCondition
Visual Basic
Public Class TimeAndDayCondition _
    Inherits TimeCondition

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyCondition
ININ.IceLib.Configuration.Dialer..::..TimeCondition
ININ.IceLib.Configuration.Dialer..::..TimeAndDayCondition

See Also

TimeAndDayCondition Members


TimeAndDayCondition Members

[image] [image]

IceLib Dialer Technical Reference
TimeAndDayCondition Members
TimeAndDayCondition Class Constructors Methods Properties See Also Send Feedback

The TimeAndDayCondition type exposes the following members.

Constructors

 | Name | Description
Public method | TimeAndDayCondition | Initializes a new instance of the TimeAndDayCondition class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConditionType | The type of condition. (Inherited from PolicyCondition.)
Public property | Days | The days on which to trigger this condition each week.
Public property | EndTime | Get or set the time of day to stop triggering this condition. (Inherited from TimeCondition.)
Public property | Id | The Id of the condition. (Inherited from PolicyCondition.)
Public property | Negated | When true, the logical result of the condition evaluation is flipped. (Inherited from PolicyCondition.)
Public property | StartTime | Get or set the time of day to start triggering this condition. (Inherited from TimeCondition.)

See Also

TimeAndDayCondition Class


TimeAndDayCondition Constructor

[image]

IceLib Dialer Technical Reference
TimeAndDayCondition Constructor
TimeAndDayCondition Class See Also Send Feedback
Initializes a new instance of the TimeAndDayCondition class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public TimeAndDayCondition()
Visual Basic
Public Sub New

See Also

TimeAndDayCondition Class
TimeAndDayCondition Members


TimeAndDayCondition Methods

[image] [image]

IceLib Dialer Technical Reference
TimeAndDayCondition Methods
TimeAndDayCondition Class See Also Send Feedback

The TimeAndDayCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimeAndDayCondition Class


TimeAndDayCondition Properties

[image] [image]

IceLib Dialer Technical Reference
TimeAndDayCondition Properties
TimeAndDayCondition Class See Also Send Feedback

The TimeAndDayCondition type exposes the following members.

Properties

 | Name | Description
Public property | ConditionType | The type of condition. (Inherited from PolicyCondition.)
Public property | Days | The days on which to trigger this condition each week.
Public property | EndTime | Get or set the time of day to stop triggering this condition. (Inherited from TimeCondition.)
Public property | Id | The Id of the condition. (Inherited from PolicyCondition.)
Public property | Negated | When true, the logical result of the condition evaluation is flipped. (Inherited from PolicyCondition.)
Public property | StartTime | Get or set the time of day to start triggering this condition. (Inherited from TimeCondition.)

See Also

TimeAndDayCondition Class


Days Property

[image]

IceLib Dialer Technical Reference
TimeAndDayCondition..::..Days Property
TimeAndDayCondition Class See Also Send Feedback
The days on which to trigger this condition each week.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<DayOfWeek> Days { get; }
Visual Basic
Public ReadOnly Property Days As Collection(Of DayOfWeek)
    Get

See Also

TimeAndDayCondition Class
TimeAndDayCondition Members


TimeCondition Class

[image]

IceLib Dialer Technical Reference
TimeCondition Class
Members See Also Send Feedback
A PolicyCondition which will check the current time.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class TimeCondition : PolicyCondition
Visual Basic
Public Class TimeCondition _
    Inherits PolicyCondition

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..PolicyCondition
ININ.IceLib.Configuration.Dialer..::..TimeCondition
ININ.IceLib.Configuration.Dialer..::..TimeAndDateCondition
ININ.IceLib.Configuration.Dialer..::..TimeAndDayCondition

See Also

TimeCondition Members


TimeCondition Members

[image] [image]

IceLib Dialer Technical Reference
TimeCondition Members
TimeCondition Class Constructors Methods Properties See Also Send Feedback

The TimeCondition type exposes the following members.

Constructors

 | Name | Description
Public method | TimeCondition | Initializes a new instance of the TimeCondition class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConditionType | The type of condition. (Inherited from PolicyCondition.)
Public property | EndTime | Get or set the time of day to stop triggering this condition.
Public property | Id | The Id of the condition. (Inherited from PolicyCondition.)
Public property | Negated | When true, the logical result of the condition evaluation is flipped. (Inherited from PolicyCondition.)
Public property | StartTime | Get or set the time of day to start triggering this condition.

See Also

TimeCondition Class


TimeCondition Constructor

[image]

IceLib Dialer Technical Reference
TimeCondition Constructor
TimeCondition Class See Also Send Feedback
Initializes a new instance of the TimeCondition class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public TimeCondition()
Visual Basic
Public Sub New

See Also

TimeCondition Class
TimeCondition Members


TimeCondition Methods

[image] [image]

IceLib Dialer Technical Reference
TimeCondition Methods
TimeCondition Class See Also Send Feedback

The TimeCondition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimeCondition Class


TimeCondition Properties

[image] [image]

IceLib Dialer Technical Reference
TimeCondition Properties
TimeCondition Class See Also Send Feedback

The TimeCondition type exposes the following members.

Properties

 | Name | Description
Public property | ConditionType | The type of condition. (Inherited from PolicyCondition.)
Public property | EndTime | Get or set the time of day to stop triggering this condition.
Public property | Id | The Id of the condition. (Inherited from PolicyCondition.)
Public property | Negated | When true, the logical result of the condition evaluation is flipped. (Inherited from PolicyCondition.)
Public property | StartTime | Get or set the time of day to start triggering this condition.

See Also

TimeCondition Class


EndTime Property

[image]

IceLib Dialer Technical Reference
TimeCondition..::..EndTime Property
TimeCondition Class See Also Send Feedback
Get or set the time of day to stop triggering this condition.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DateTime EndTime { get; set; }
Visual Basic
Public Property EndTime As DateTime
    Get
    Set

See Also

TimeCondition Class
TimeCondition Members


StartTime Property

[image]

IceLib Dialer Technical Reference
TimeCondition..::..StartTime Property
TimeCondition Class See Also Send Feedback
Get or set the time of day to start triggering this condition.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DateTime StartTime { get; set; }
Visual Basic
Public Property StartTime As DateTime
    Get
    Set

See Also

TimeCondition Class
TimeCondition Members


TimeRule Class

[image]

IceLib Dialer Technical Reference
TimeRule Class
Members See Also Send Feedback
A rule with a time-based condition.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class TimeRule : Rule
Visual Basic
Public Class TimeRule _
    Inherits Rule

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..Rule
ININ.IceLib.Configuration.Dialer..::..TimeRule

See Also

TimeRule Members


TimeRule Members

[image] [image]

IceLib Dialer Technical Reference
TimeRule Members
TimeRule Class Constructors Methods Properties See Also Send Feedback

The TimeRule type exposes the following members.

Constructors

 | Name | Description
Public method | TimeRule | Constructs a new instance of the TimeRule class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Actions | The collection of Actions to perform when this Rule's conditions are met (Inherited from Rule.)
Public property | Date | The date on which this Rule will fire. (if TimeMode is ByDate)
Public property | Days | Which days of each week this Rule will fire on. (if TimeMode is ByDay)
Public property | Enabled | Toggle evaluation/execution of this rule. (Inherited from Rule.)
Public property | Groups | Named rule groups (within the parent RuleSetConfiguration) to which this rule belongs. (Inherited from Rule.)
Public property | Id | The Id of the Rule. (Inherited from Rule.)
Public property | IgnoreGroups | Specifies whether this rule should be evaluated no matter which group is active. (Inherited from Rule.)
Public property | InAllGroups | Specifies whether this rule is a member of all rule groups of the rule set it belongs to. (Inherited from Rule.)
Public property | Index | Specifies the order to display and execute this rule in relation to other rules in the parent rule set. (Inherited from Rule.)
Public property | InStartupGroup | Specifies whether this rule is a member of the unnamed group that the rule set evaluates first. (Inherited from Rule.)
Public property | Repetition | Specifies how often the rule should be re-evaluated. (Inherited from Rule.)
Public property | TerminateOnAction | Specifies the manner in which rule evaluation should be stopped after this rule runs its actions. (Inherited from Rule.)
Public property | Time | The time of day at which this Rule will fire on.
Public property | TimeMode | Determines how this rule will fire.

See Also

TimeRule Class


TimeRule Constructor

[image]

IceLib Dialer Technical Reference
TimeRule Constructor
TimeRule Class See Also Send Feedback
Constructs a new instance of the TimeRule class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public TimeRule()
Visual Basic
Public Sub New

See Also

TimeRule Class
TimeRule Members


TimeRule Methods

[image] [image]

IceLib Dialer Technical Reference
TimeRule Methods
TimeRule Class See Also Send Feedback

The TimeRule type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimeRule Class


TimeRule Properties

[image] [image]

IceLib Dialer Technical Reference
TimeRule Properties
TimeRule Class See Also Send Feedback

The TimeRule type exposes the following members.

Properties

 | Name | Description
Public property | Actions | The collection of Actions to perform when this Rule's conditions are met (Inherited from Rule.)
Public property | Date | The date on which this Rule will fire. (if TimeMode is ByDate)
Public property | Days | Which days of each week this Rule will fire on. (if TimeMode is ByDay)
Public property | Enabled | Toggle evaluation/execution of this rule. (Inherited from Rule.)
Public property | Groups | Named rule groups (within the parent RuleSetConfiguration) to which this rule belongs. (Inherited from Rule.)
Public property | Id | The Id of the Rule. (Inherited from Rule.)
Public property | IgnoreGroups | Specifies whether this rule should be evaluated no matter which group is active. (Inherited from Rule.)
Public property | InAllGroups | Specifies whether this rule is a member of all rule groups of the rule set it belongs to. (Inherited from Rule.)
Public property | Index | Specifies the order to display and execute this rule in relation to other rules in the parent rule set. (Inherited from Rule.)
Public property | InStartupGroup | Specifies whether this rule is a member of the unnamed group that the rule set evaluates first. (Inherited from Rule.)
Public property | Repetition | Specifies how often the rule should be re-evaluated. (Inherited from Rule.)
Public property | TerminateOnAction | Specifies the manner in which rule evaluation should be stopped after this rule runs its actions. (Inherited from Rule.)
Public property | Time | The time of day at which this Rule will fire on.
Public property | TimeMode | Determines how this rule will fire.

See Also

TimeRule Class


Date Property

[image]

IceLib Dialer Technical Reference
TimeRule..::..Date Property
TimeRule Class See Also Send Feedback
The date on which this Rule will fire. (if TimeMode is ByDate)

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DateTime Date { get; set; }
Visual Basic
Public Property Date As DateTime
    Get
    Set

See Also

TimeRule Class
TimeRule Members


Days Property

[image]

IceLib Dialer Technical Reference
TimeRule..::..Days Property
TimeRule Class See Also Send Feedback
Which days of each week this Rule will fire on. (if TimeMode is ByDay)

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<DayOfWeek> Days { get; }
Visual Basic
Public ReadOnly Property Days As Collection(Of DayOfWeek)
    Get

See Also

TimeRule Class
TimeRule Members


Time Property

[image]

IceLib Dialer Technical Reference
TimeRule..::..Time Property
TimeRule Class See Also Send Feedback
The time of day at which this Rule will fire on.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public TimeSpan Time { get; set; }
Visual Basic
Public Property Time As TimeSpan
    Get
    Set

See Also

TimeRule Class
TimeRule Members


TimeMode Property

[image]

IceLib Dialer Technical Reference
TimeRule..::..TimeMode Property
TimeRule Class See Also Send Feedback
Determines how this rule will fire.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public TimeRuleMode TimeMode { get; set; }
Visual Basic
Public Property TimeMode As TimeRuleMode
    Get
    Set

See Also

TimeRule Class
TimeRule Members


TimeSequenceItem Class

[image]

IceLib Dialer Technical Reference
TimeSequenceItem Class
Members See Also Send Feedback
A class that represents a sequence item that is triggered as a specific moment in time, or repeatedly at a specific interval of time.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class TimeSequenceItem : SequenceItem
Visual Basic
Public Class TimeSequenceItem _
    Inherits SequenceItem

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..SequenceItem
ININ.IceLib.Configuration.Dialer..::..TimeSequenceItem

See Also

TimeSequenceItem Members


TimeSequenceItem Members

[image] [image]

IceLib Dialer Technical Reference
TimeSequenceItem Members
TimeSequenceItem Class Constructors Methods Properties See Also Send Feedback

The TimeSequenceItem type exposes the following members.

Constructors

 | Name | Description
Public method | TimeSequenceItem(CampaignGroup) | Constructs a new instance of the TimeSequenceItem class.
Public method | TimeSequenceItem(ConfigurationId, CampaignGroup) | Constructs a new instance of the TimeSequenceItem

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDisplayName | Public method to change the display name of a CampaignGroup (Inherited from SequenceItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CampaignGroup | The CampaignGroup that is triggered by this Sequence Item (Inherited from SequenceItem.)
Public property | ConditionType | Specifies the Type of Sequence Item this is: Event, Time or Stat. (Inherited from SequenceItem.)
Public property | Date | The date on which this SequenceItem will activate. (if TimeMode is ByDate)
Public property | Days | Which days of each week this SequenceItem will activate. (if TimeMode is ByDay)
Public property | Id | The Id of the SequenceItem. (Inherited from SequenceItem.)
Public property | IgnoreGroups | Specifies whether this Sequence Item should be evaluated no matter which campaign group is active. (Inherited from SequenceItem.)
Public property | InAllGroups | Specifies whether this Sequence Item is a child of all campaign groups of the sequence definition that it belongs to. (Inherited from SequenceItem.)
Public property | Index | Specifies the order to display and execute Sequence Item in relation to other Sequence Items in the Sequence. (Inherited from SequenceItem.)
Public property | InStartupGroup | Specifies whether this rule is a member of the unnamed group that the rule set evaluates first. (Inherited from SequenceItem.)
Public property | ParentGroups | Named campaign groups (within the sequence Sequence) to which this sequence item represents. (Inherited from SequenceItem.)
Public property | Time | The time of day at which this SequenceItem will activate.
Public property | TimeInterval | The number of minutes until this SequenceItem will activate again.
Public property | TimeMode | Determines how this sequence will activate.

See Also

TimeSequenceItem Class


TimeSequenceItem Constructor

[image] [image]

IceLib Dialer Technical Reference
TimeSequenceItem Constructor
TimeSequenceItem Class See Also Send Feedback

Overload List

 | Name | Description
Public method | TimeSequenceItem(CampaignGroup) | Constructs a new instance of the TimeSequenceItem class.
Public method | TimeSequenceItem(ConfigurationId, CampaignGroup) | Constructs a new instance of the TimeSequenceItem

See Also

TimeSequenceItem Class
TimeSequenceItem Members


TimeSequenceItem Constructor (CampaignGroup)

[image]

IceLib Dialer Technical Reference
TimeSequenceItem Constructor (CampaignGroup)
TimeSequenceItem Class See Also Send Feedback
Constructs a new instance of the TimeSequenceItem class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public TimeSequenceItem(
    CampaignGroup group
)
Visual Basic
Public Sub New ( _
    group As CampaignGroup _
)

Parameters

group
Type: ININ.IceLib.Configuration.Dialer..::..CampaignGroup

See Also

TimeSequenceItem Class
TimeSequenceItem Members
TimeSequenceItem Overload


TimeSequenceItem Constructor (ConfigurationId, CampaignGroup)

[image]

IceLib Dialer Technical Reference
TimeSequenceItem Constructor (ConfigurationId, CampaignGroup)
TimeSequenceItem Class See Also Send Feedback
Constructs a new instance of the TimeSequenceItem

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public TimeSequenceItem(
    ConfigurationId id,
    CampaignGroup group
)
Visual Basic
Public Sub New ( _
    id As ConfigurationId, _
    group As CampaignGroup _
)

Parameters

id
Type: ConfigurationId
The Id ConfigurationId you wish to assign to the sequence item.
group
Type: ININ.IceLib.Configuration.Dialer..::..CampaignGroup

See Also

TimeSequenceItem Class
TimeSequenceItem Members
TimeSequenceItem Overload


TimeSequenceItem Methods

[image] [image]

IceLib Dialer Technical Reference
TimeSequenceItem Methods
TimeSequenceItem Class See Also Send Feedback

The TimeSequenceItem type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetDisplayName | Public method to change the display name of a CampaignGroup (Inherited from SequenceItem.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimeSequenceItem Class


TimeSequenceItem Properties

[image] [image]

IceLib Dialer Technical Reference
TimeSequenceItem Properties
TimeSequenceItem Class See Also Send Feedback

The TimeSequenceItem type exposes the following members.

Properties

 | Name | Description
Public property | CampaignGroup | The CampaignGroup that is triggered by this Sequence Item (Inherited from SequenceItem.)
Public property | ConditionType | Specifies the Type of Sequence Item this is: Event, Time or Stat. (Inherited from SequenceItem.)
Public property | Date | The date on which this SequenceItem will activate. (if TimeMode is ByDate)
Public property | Days | Which days of each week this SequenceItem will activate. (if TimeMode is ByDay)
Public property | Id | The Id of the SequenceItem. (Inherited from SequenceItem.)
Public property | IgnoreGroups | Specifies whether this Sequence Item should be evaluated no matter which campaign group is active. (Inherited from SequenceItem.)
Public property | InAllGroups | Specifies whether this Sequence Item is a child of all campaign groups of the sequence definition that it belongs to. (Inherited from SequenceItem.)
Public property | Index | Specifies the order to display and execute Sequence Item in relation to other Sequence Items in the Sequence. (Inherited from SequenceItem.)
Public property | InStartupGroup | Specifies whether this rule is a member of the unnamed group that the rule set evaluates first. (Inherited from SequenceItem.)
Public property | ParentGroups | Named campaign groups (within the sequence Sequence) to which this sequence item represents. (Inherited from SequenceItem.)
Public property | Time | The time of day at which this SequenceItem will activate.
Public property | TimeInterval | The number of minutes until this SequenceItem will activate again.
Public property | TimeMode | Determines how this sequence will activate.

See Also

TimeSequenceItem Class


Date Property

[image]

IceLib Dialer Technical Reference
TimeSequenceItem..::..Date Property
TimeSequenceItem Class See Also Send Feedback
The date on which this SequenceItem will activate. (if TimeMode is ByDate)

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DateTime Date { get; set; }
Visual Basic
Public Property Date As DateTime
    Get
    Set

See Also

TimeSequenceItem Class
TimeSequenceItem Members


Days Property

[image]

IceLib Dialer Technical Reference
TimeSequenceItem..::..Days Property
TimeSequenceItem Class See Also Send Feedback
Which days of each week this SequenceItem will activate. (if TimeMode is ByDay)

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<DayOfWeek> Days { get; }
Visual Basic
Public ReadOnly Property Days As Collection(Of DayOfWeek)
    Get

See Also

TimeSequenceItem Class
TimeSequenceItem Members


Time Property

[image]

IceLib Dialer Technical Reference
TimeSequenceItem..::..Time Property
TimeSequenceItem Class See Also Send Feedback
The time of day at which this SequenceItem will activate.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public TimeSpan Time { get; set; }
Visual Basic
Public Property Time As TimeSpan
    Get
    Set

See Also

TimeSequenceItem Class
TimeSequenceItem Members


TimeInterval Property

[image]

IceLib Dialer Technical Reference
TimeSequenceItem..::..TimeInterval Property
TimeSequenceItem Class See Also Send Feedback
The number of minutes until this SequenceItem will activate again.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int TimeInterval { get; set; }
Visual Basic
Public Property TimeInterval As Integer
    Get
    Set

See Also

TimeSequenceItem Class
TimeSequenceItem Members


TimeMode Property

[image]

IceLib Dialer Technical Reference
TimeSequenceItem..::..TimeMode Property
TimeSequenceItem Class See Also Send Feedback
Determines how this sequence will activate.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public TimeRuleMode TimeMode { get; set; }
Visual Basic
Public Property TimeMode As TimeRuleMode
    Get
    Set

See Also

TimeSequenceItem Class
TimeSequenceItem Members


TimezoneMapDatasetConfiguration Class

[image]

IceLib Dialer Technical Reference
TimezoneMapDatasetConfiguration Class
Members See Also Send Feedback
Contains configuration settings for a Dialer timezone map dataset.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class TimezoneMapDatasetConfiguration : EditableListConfigurationObject<TimezoneMapDatasetConfiguration..::..Property>,
    IExportable
Visual Basic
Public Class TimezoneMapDatasetConfiguration _
    Inherits EditableListConfigurationObject(Of TimezoneMapDatasetConfiguration..::..Property) _
    Implements IExportable

Inheritance Hierarchy

System..::..Object
ConfigurationObject
ListConfigurationObject
EditableListConfigurationObject<(Of <(<' TimezoneMapDatasetConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..TimezoneMapDatasetConfiguration

See Also

TimezoneMapDatasetConfiguration Members


TimezoneMapDatasetConfiguration Members

[image] [image]

IceLib Dialer Technical Reference
TimezoneMapDatasetConfiguration Members
TimezoneMapDatasetConfiguration Class Methods Properties See Also Send Feedback

The TimezoneMapDatasetConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | TimezoneMapDatasetTest | Perform Timezone mapping test
Public method | TimezoneMapDatasetTestAsync | Asynchronously perform timezone mapping test
Public method | ToString | (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | DataFile | The path of the timezone mapping data file this object represents.
Public property | Format | The format of this data file.
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsExporting | Tells whether the current object is being used for exporting
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | LastLoaded | A timestamp indicating when this file was last validated by dialer.
Public property | LastUpdated | A timestamp indicating when this file was last modified.
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | Priority | The order of precedence in relation to other time zone map data sets in the configuration.
Public property | RevisionLevel | The current version of this object.

See Also

TimezoneMapDatasetConfiguration Class


TimezoneMapDatasetConfiguration Methods

[image] [image]

IceLib Dialer Technical Reference
TimezoneMapDatasetConfiguration Methods
TimezoneMapDatasetConfiguration Class See Also Send Feedback

The TimezoneMapDatasetConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | TimezoneMapDatasetTest | Perform Timezone mapping test
Public method | TimezoneMapDatasetTestAsync | Asynchronously perform timezone mapping test
Public method | ToString | (Inherited from ConfigurationObject.)

See Also

TimezoneMapDatasetConfiguration Class


TimezoneMapDatasetTest Method

[image]

IceLib Dialer Technical Reference
TimezoneMapDatasetConfiguration..::..TimezoneMapDatasetTest Method
TimezoneMapDatasetConfiguration Class See Also Send Feedback
Perform Timezone mapping test

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public TimezoneMapDatasetTestResult TimezoneMapDatasetTest(
    TimezoneMapDatasetFormat format,
    string filePath
)
Visual Basic
Public Function TimezoneMapDatasetTest ( _
    format As TimezoneMapDatasetFormat, _
    filePath As String _
) As TimezoneMapDatasetTestResult

Parameters

format
Type: ININ.IceLib.Configuration.Dialer.DataTypes..::..TimezoneMapDatasetFormat
Timezone Map format TimezoneMapDatasetFormat when mapping
filePath
Type: System..::..String
Path to mapping file

Return Value

TimezoneMapDatasetTestResult

See Also

TimezoneMapDatasetConfiguration Class
TimezoneMapDatasetConfiguration Members


TimezoneMapDatasetTestAsync Method

[image]

IceLib Dialer Technical Reference
TimezoneMapDatasetConfiguration..::..TimezoneMapDatasetTestAsync Method
TimezoneMapDatasetConfiguration Class See Also Send Feedback
Asynchronously perform timezone mapping test

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void TimezoneMapDatasetTestAsync(
    TimezoneMapDatasetFormat format,
    string filePath,
    EventHandler<AsyncCompletedEventArgs<TimezoneMapDatasetTestResult>> completionCallback,
    Object state
)
Visual Basic
Public Sub TimezoneMapDatasetTestAsync ( _
    format As TimezoneMapDatasetFormat, _
    filePath As String, _
    completionCallback As EventHandler(Of AsyncCompletedEventArgs(Of TimezoneMapDatasetTestResult)), _
    state As Object _
)

Parameters

format
Type: ININ.IceLib.Configuration.Dialer.DataTypes..::..TimezoneMapDatasetFormat
Timezone Map format TimezoneMapDatasetFormat when mapping
filePath
Type: System..::..String
Path to mapping file
completionCallback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<' TimezoneMapDatasetTestResult >)>)>>)>)>
state
Type: System..::..Object

See Also

TimezoneMapDatasetConfiguration Class
TimezoneMapDatasetConfiguration Members


TimezoneMapDatasetConfiguration Properties

[image] [image]

IceLib Dialer Technical Reference
TimezoneMapDatasetConfiguration Properties
TimezoneMapDatasetConfiguration Class See Also Send Feedback

The TimezoneMapDatasetConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | DataFile | The path of the timezone mapping data file this object represents.
Public property | Format | The format of this data file.
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsExporting | Tells whether the current object is being used for exporting
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | LastLoaded | A timestamp indicating when this file was last validated by dialer.
Public property | LastUpdated | A timestamp indicating when this file was last modified.
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | Priority | The order of precedence in relation to other time zone map data sets in the configuration.
Public property | RevisionLevel | The current version of this object.

See Also

TimezoneMapDatasetConfiguration Class


DataFile Property

[image]

IceLib Dialer Technical Reference
TimezoneMapDatasetConfiguration..::..DataFile Property
TimezoneMapDatasetConfiguration Class See Also Send Feedback
The path of the timezone mapping data file this object represents.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<TimezoneMapDatasetConfiguration..::..Property, string> DataFile { get; }
Visual Basic
Public ReadOnly Property DataFile As GeneralConfigurationProperty(Of TimezoneMapDatasetConfiguration..::..Property, String)
    Get

See Also

TimezoneMapDatasetConfiguration Class
TimezoneMapDatasetConfiguration Members


Format Property

[image]

IceLib Dialer Technical Reference
TimezoneMapDatasetConfiguration..::..Format Property
TimezoneMapDatasetConfiguration Class See Also Send Feedback
The format of this data file.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<TimezoneMapDatasetConfiguration..::..Property, TimezoneMapDatasetFormat> Format { get; }
Visual Basic
Public ReadOnly Property Format As GeneralConfigurationProperty(Of TimezoneMapDatasetConfiguration..::..Property, TimezoneMapDatasetFormat)
    Get

See Also

TimezoneMapDatasetConfiguration Class
TimezoneMapDatasetConfiguration Members


IsDefaultObject Property

[image]

IceLib Dialer Technical Reference
TimezoneMapDatasetConfiguration..::..IsDefaultObject Property
TimezoneMapDatasetConfiguration Class See Also Send Feedback
Indicates whether this is the default instance of this object type.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsDefaultObject { get; }
Visual Basic
Public ReadOnly Property IsDefaultObject As Boolean
    Get

See Also

TimezoneMapDatasetConfiguration Class
TimezoneMapDatasetConfiguration Members


IsExporting Property

[image]

IceLib Dialer Technical Reference
TimezoneMapDatasetConfiguration..::..IsExporting Property
TimezoneMapDatasetConfiguration Class See Also Send Feedback
Tells whether the current object is being used for exporting

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsExporting { get; private set; }
Visual Basic
Public Property IsExporting As Boolean
    Get
    Private Set

See Also

TimezoneMapDatasetConfiguration Class
TimezoneMapDatasetConfiguration Members


LastLoaded Property

[image]

IceLib Dialer Technical Reference
TimezoneMapDatasetConfiguration..::..LastLoaded Property
TimezoneMapDatasetConfiguration Class See Also Send Feedback
A timestamp indicating when this file was last validated by dialer.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<TimezoneMapDatasetConfiguration..::..Property, DateTime> LastLoaded { get; }
Visual Basic
Public ReadOnly Property LastLoaded As GeneralConfigurationProperty(Of TimezoneMapDatasetConfiguration..::..Property, DateTime)
    Get

See Also

TimezoneMapDatasetConfiguration Class
TimezoneMapDatasetConfiguration Members


LastUpdated Property

[image]

IceLib Dialer Technical Reference
TimezoneMapDatasetConfiguration..::..LastUpdated Property
TimezoneMapDatasetConfiguration Class See Also Send Feedback
A timestamp indicating when this file was last modified.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<TimezoneMapDatasetConfiguration..::..Property, DateTime> LastUpdated { get; }
Visual Basic
Public ReadOnly Property LastUpdated As GeneralConfigurationProperty(Of TimezoneMapDatasetConfiguration..::..Property, DateTime)
    Get

See Also

TimezoneMapDatasetConfiguration Class
TimezoneMapDatasetConfiguration Members


Priority Property

[image]

IceLib Dialer Technical Reference
TimezoneMapDatasetConfiguration..::..Priority Property
TimezoneMapDatasetConfiguration Class See Also Send Feedback
The order of precedence in relation to other time zone map data sets in the configuration.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<TimezoneMapDatasetConfiguration..::..Property, int> Priority { get; }
Visual Basic
Public ReadOnly Property Priority As GeneralConfigurationProperty(Of TimezoneMapDatasetConfiguration..::..Property, Integer)
    Get

See Also

TimezoneMapDatasetConfiguration Class
TimezoneMapDatasetConfiguration Members


RevisionLevel Property

[image]

IceLib Dialer Technical Reference
TimezoneMapDatasetConfiguration..::..RevisionLevel Property
TimezoneMapDatasetConfiguration Class See Also Send Feedback
The current version of this object.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<TimezoneMapDatasetConfiguration..::..Property, int> RevisionLevel { get; }
Visual Basic
Public ReadOnly Property RevisionLevel As GeneralConfigurationProperty(Of TimezoneMapDatasetConfiguration..::..Property, Integer)
    Get

See Also

TimezoneMapDatasetConfiguration Class
TimezoneMapDatasetConfiguration Members


TimezoneMapDatasetConfiguration.Property Enumeration

[image]

IceLib Dialer Technical Reference
TimezoneMapDatasetConfiguration..::..Property Enumeration
TimezoneMapDatasetConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Id | 0 | Represents the Id part of the ConfigurationId property.
DisplayName | 1 | Represents the DisplayName part of the ConfigurationId property.
DataFile | 2 | Represents the DataFile property.
Format | 3 | Represents the Format property.
LastLoaded | 4 | Represents the LastLoaded property.
LastUpdated | 5 | Represents the LastUpdated property.
Priority | 6 | Represents the Priority property.
RevisionLevel | 7 | Represents the RevisionLevel property.

See Also


TimezoneMapDatasetConfigurationList Class

[image]

IceLib Dialer Technical Reference
TimezoneMapDatasetConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing timezone map dataset configuration objects.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class TimezoneMapDatasetConfigurationList : EditableConfigurationList<TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property>
Visual Basic
Public Class TimezoneMapDatasetConfigurationList _
    Inherits EditableConfigurationList(Of TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>
DynamicConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>
EditableConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..TimezoneMapDatasetConfigurationList

See Also

TimezoneMapDatasetConfigurationList Members


TimezoneMapDatasetConfigurationList Members

[image] [image]

IceLib Dialer Technical Reference
TimezoneMapDatasetConfigurationList Members
TimezoneMapDatasetConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The TimezoneMapDatasetConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | TimezoneMapDatasetConfigurationList | Initializes a new instance of the TimezoneMapDatasetConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)

See Also

TimezoneMapDatasetConfigurationList Class


TimezoneMapDatasetConfigurationList Constructor

[image]

IceLib Dialer Technical Reference
TimezoneMapDatasetConfigurationList Constructor
TimezoneMapDatasetConfigurationList Class See Also Send Feedback
Initializes a new instance of the TimezoneMapDatasetConfigurationList class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public TimezoneMapDatasetConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

TimezoneMapDatasetConfigurationList Class
TimezoneMapDatasetConfigurationList Members


TimezoneMapDatasetConfigurationList Methods

[image] [image]

IceLib Dialer Technical Reference
TimezoneMapDatasetConfigurationList Methods
TimezoneMapDatasetConfigurationList Class See Also Send Feedback

The TimezoneMapDatasetConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimezoneMapDatasetConfigurationList Class


TimezoneMapDatasetConfigurationList Properties

[image] [image]

IceLib Dialer Technical Reference
TimezoneMapDatasetConfigurationList Properties
TimezoneMapDatasetConfigurationList Class See Also Send Feedback

The TimezoneMapDatasetConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)

See Also

TimezoneMapDatasetConfigurationList Class


TimezoneMapDatasetConfigurationList Events

[image] [image]

IceLib Dialer Technical Reference
TimezoneMapDatasetConfigurationList Events
TimezoneMapDatasetConfigurationList Class See Also Send Feedback

The TimezoneMapDatasetConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' TimezoneMapDatasetConfiguration, TimezoneMapDatasetConfiguration..::..Property >)>)>.)

See Also

TimezoneMapDatasetConfigurationList Class


UpdateCommand Class

[image]

IceLib Dialer Technical Reference
UpdateCommand Class
Members See Also Send Feedback
A command that updates existing records in a contact list table.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class UpdateCommand : ContactListCommand
Visual Basic
Public NotInheritable Class UpdateCommand _
    Inherits ContactListCommand

Remarks

This method can only be used to update records in the contact list table. For scheduled calls, use AddScheduledCalls(IList<(Of <<'(ScheduledCall>)>>)).

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer..::..ContactListCommand
ININ.IceLib.Configuration.Dialer..::..UpdateCommand

See Also

UpdateCommand Members


UpdateCommand Members

[image] [image]

IceLib Dialer Technical Reference
UpdateCommand Members
UpdateCommand Class Constructors Methods Properties See Also Send Feedback

The UpdateCommand type exposes the following members.

Constructors

 | Name | Description
Public method | UpdateCommand | Initializes a new instance of the UpdateCommand class.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Overrides ContactListCommand..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetDatabaseType | Retrieves the type of database associated with the contact list's connection. (Inherited from ContactListCommand.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ContactList | The contact list to run this command against. (Inherited from ContactListCommand.)
Public property | Filters | The filter to use in the where predicate. (Inherited from ContactListCommand.)
Public property | RecordsAffected | The number of records affected by this command. If this is a paged SelectCommand, the value reflects the total number of records in the unpaged version. (Inherited from ContactListCommand.)
Public property | TableType | Specifies which database table the command applies to. (Inherited from ContactListCommand.)
Public property | UpdateData | Database fields mapped to their new values.
Public property | Where | An expression representing a logical predicate with which to filter records. (Inherited from ContactListCommand.)

See Also

UpdateCommand Class


UpdateCommand Constructor

[image]

IceLib Dialer Technical Reference
UpdateCommand Constructor
UpdateCommand Class See Also Send Feedback
Initializes a new instance of the UpdateCommand class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public UpdateCommand(
    ContactListConfiguration contactList,
    IEnumerable<FilterConfiguration> filters
)
Visual Basic
Public Sub New ( _
    contactList As ContactListConfiguration, _
    filters As IEnumerable(Of FilterConfiguration) _
)

Parameters

contactList
Type: ININ.IceLib.Configuration.Dialer..::..ContactListConfiguration
The contact list to run this command against.
filters
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' FilterConfiguration >)>)>
The filters to apply to the where clause.

See Also

UpdateCommand Class
UpdateCommand Members


UpdateCommand Methods

[image] [image]

IceLib Dialer Technical Reference
UpdateCommand Methods
UpdateCommand Class See Also Send Feedback

The UpdateCommand type exposes the following members.

Methods

 | Name | Description
Public method | Clone | Creates a new object that is a copy of the current instance. (Overrides ContactListCommand..::..Clone()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetDatabaseType | Retrieves the type of database associated with the contact list's connection. (Inherited from ContactListCommand.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UpdateCommand Class


Clone Method

[image]

IceLib Dialer Technical Reference
UpdateCommand..::..Clone Method
UpdateCommand Class See Also Send Feedback
Creates a new object that is a copy of the current instance.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override Object Clone()
Visual Basic
Public Overrides Function Clone As Object

Return Value

A new object that is a copy of this instance.

Implements

ICloneable..::..Clone()()()()

See Also

UpdateCommand Class
UpdateCommand Members


UpdateCommand Properties

[image] [image]

IceLib Dialer Technical Reference
UpdateCommand Properties
UpdateCommand Class See Also Send Feedback

The UpdateCommand type exposes the following members.

Properties

 | Name | Description
Public property | ContactList | The contact list to run this command against. (Inherited from ContactListCommand.)
Public property | Filters | The filter to use in the where predicate. (Inherited from ContactListCommand.)
Public property | RecordsAffected | The number of records affected by this command. If this is a paged SelectCommand, the value reflects the total number of records in the unpaged version. (Inherited from ContactListCommand.)
Public property | TableType | Specifies which database table the command applies to. (Inherited from ContactListCommand.)
Public property | UpdateData | Database fields mapped to their new values.
Public property | Where | An expression representing a logical predicate with which to filter records. (Inherited from ContactListCommand.)

See Also

UpdateCommand Class


UpdateData Property

[image]

IceLib Dialer Technical Reference
UpdateCommand..::..UpdateData Property
UpdateCommand Class See Also Send Feedback
Database fields mapped to their new values.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Dictionary<DBColumn, Object> UpdateData { get; private set; }
Visual Basic
Public Property UpdateData As Dictionary(Of DBColumn, Object)
    Get
    Private Set

See Also

UpdateCommand Class
UpdateCommand Members


ZoneSetConfiguration Class

[image]

IceLib Dialer Technical Reference
ZoneSetConfiguration Class
Members See Also Send Feedback
Contains configuration and administration settings for a Dialer zone set.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class ZoneSetConfiguration : EditableListConfigurationObject<ZoneSetConfiguration..::..Property>,
    IExportable
Visual Basic
Public Class ZoneSetConfiguration _
    Inherits EditableListConfigurationObject(Of ZoneSetConfiguration..::..Property) _
    Implements IExportable

Inheritance Hierarchy

System..::..Object
ConfigurationObject
ListConfigurationObject
EditableListConfigurationObject<(Of <(<' ZoneSetConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..ZoneSetConfiguration

See Also

ZoneSetConfiguration Members


ZoneSetConfiguration Members

[image] [image]

IceLib Dialer Technical Reference
ZoneSetConfiguration Members
ZoneSetConfiguration Class Methods Properties See Also Send Feedback

The ZoneSetConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' ZoneSetConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' ZoneSetConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ZoneSetConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' ZoneSetConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ZoneSetConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' ZoneSetConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ZoneSetConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' ZoneSetConfiguration..::..Property >)>)>.)
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' ZoneSetConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' ZoneSetConfiguration..::..Property >)>)>.)
Public method | ToString | (Inherited from ConfigurationObject.)

Properties

 | Name | Description
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' ZoneSetConfiguration..::..Property >)>)>.)
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsExporting | Tells whether the current object is being used for exporting
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | RevisionLevel | The current version of this object.
Public property | TimeZones | A list of time zone objects containing time ranges in which dialing is allowed.

See Also

ZoneSetConfiguration Class


ZoneSetConfiguration Methods

[image] [image]

IceLib Dialer Technical Reference
ZoneSetConfiguration Methods
ZoneSetConfiguration Class See Also Send Feedback

The ZoneSetConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | CancelEdit | (Inherited from EditableListConfigurationObject<(Of <(<' ZoneSetConfiguration..::..Property >)>)>.)
Public method | Commit | (Inherited from EditableListConfigurationObject<(Of <(<' ZoneSetConfiguration..::..Property >)>)>.)
Public method | CommitAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ZoneSetConfiguration..::..Property >)>)>.)
Public method | Delete | (Inherited from EditableListConfigurationObject<(Of <(<' ZoneSetConfiguration..::..Property >)>)>.)
Public method | DeleteAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ZoneSetConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValidators | (Inherited from EditableListConfigurationObject<(Of <(<' ZoneSetConfiguration..::..Property >)>)>.)
Public method | GetValidatorsAsync | (Inherited from EditableListConfigurationObject<(Of <(<' ZoneSetConfiguration..::..Property >)>)>.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PrepareForEdit | (Inherited from EditableListConfigurationObject<(Of <(<' ZoneSetConfiguration..::..Property >)>)>.)
Public method | SetConfigurationId | (Inherited from EditableListConfigurationObject<(Of <(<' ZoneSetConfiguration..::..Property >)>)>.)
Public method | SetDisplayName | (Inherited from EditableListConfigurationObject<(Of <(<' ZoneSetConfiguration..::..Property >)>)>.)
Public method | ToString | (Inherited from ConfigurationObject.)

See Also

ZoneSetConfiguration Class


ZoneSetConfiguration Properties

[image] [image]

IceLib Dialer Technical Reference
ZoneSetConfiguration Properties
ZoneSetConfiguration Class See Also Send Feedback

The ZoneSetConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | Changed | (Inherited from EditableListConfigurationObject<(Of <(<' ZoneSetConfiguration..::..Property >)>)>.)
Public property | ConfigurationId | (Inherited from ListConfigurationObject.)
Public property | IsDefaultObject | Indicates whether this is the default instance of this object type.
Public property | IsExporting | Tells whether the current object is being used for exporting
Public property | IsNewObject | (Inherited from ConfigurationObject.)
Public property | OriginalConfigurationId | (Inherited from ListConfigurationObject.)
Public property | RevisionLevel | The current version of this object.
Public property | TimeZones | A list of time zone objects containing time ranges in which dialing is allowed.

See Also

ZoneSetConfiguration Class


IsDefaultObject Property

[image]

IceLib Dialer Technical Reference
ZoneSetConfiguration..::..IsDefaultObject Property
ZoneSetConfiguration Class See Also Send Feedback
Indicates whether this is the default instance of this object type.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsDefaultObject { get; }
Visual Basic
Public ReadOnly Property IsDefaultObject As Boolean
    Get

See Also

ZoneSetConfiguration Class
ZoneSetConfiguration Members


IsExporting Property

[image]

IceLib Dialer Technical Reference
ZoneSetConfiguration..::..IsExporting Property
ZoneSetConfiguration Class See Also Send Feedback
Tells whether the current object is being used for exporting

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsExporting { get; private set; }
Visual Basic
Public Property IsExporting As Boolean
    Get
    Private Set

See Also

ZoneSetConfiguration Class
ZoneSetConfiguration Members


RevisionLevel Property

[image]

IceLib Dialer Technical Reference
ZoneSetConfiguration..::..RevisionLevel Property
ZoneSetConfiguration Class See Also Send Feedback
The current version of this object.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<ZoneSetConfiguration..::..Property, int> RevisionLevel { get; }
Visual Basic
Public ReadOnly Property RevisionLevel As GeneralConfigurationProperty(Of ZoneSetConfiguration..::..Property, Integer)
    Get

See Also

ZoneSetConfiguration Class
ZoneSetConfiguration Members


TimeZones Property

[image]

IceLib Dialer Technical Reference
ZoneSetConfiguration..::..TimeZones Property
ZoneSetConfiguration Class See Also Send Feedback
A list of time zone objects containing time ranges in which dialing is allowed.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GeneralConfigurationProperty<ZoneSetConfiguration..::..Property, Collection<Zone>> TimeZones { get; }
Visual Basic
Public ReadOnly Property TimeZones As GeneralConfigurationProperty(Of ZoneSetConfiguration..::..Property, Collection(Of Zone))
    Get

See Also

ZoneSetConfiguration Class
ZoneSetConfiguration Members


ZoneSetConfiguration.Property Enumeration

[image]

IceLib Dialer Technical Reference
ZoneSetConfiguration..::..Property Enumeration
ZoneSetConfiguration Class See Also Send Feedback
Specifies constants indicating what properties this configuration object supports.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum Property
Visual Basic
Public Enumeration Property

Members

Member name | Value | Description
Id | 0 | Represents the Id part of the ConfigurationId property.
DisplayName | 1 | Represents the DisplayName part of the ConfigurationId property.
TimeZones | 2 | Represents the TimeZones property.
RevisionLevel | 3 | Represents the RevisionLevel property.

See Also


ZoneSetConfigurationList Class

[image]

IceLib Dialer Technical Reference
ZoneSetConfigurationList Class
Members See Also Send Feedback
Allows for querying and managing zone set configuration objects.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class ZoneSetConfigurationList : EditableConfigurationList<ZoneSetConfiguration, ZoneSetConfiguration..::..Property>
Visual Basic
Public Class ZoneSetConfigurationList _
    Inherits EditableConfigurationList(Of ZoneSetConfiguration, ZoneSetConfiguration..::..Property)

Inheritance Hierarchy

System..::..Object
ConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>
DynamicConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>
EditableConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>
ININ.IceLib.Configuration.Dialer..::..ZoneSetConfigurationList

See Also

ZoneSetConfigurationList Members


ZoneSetConfigurationList Members

[image] [image]

IceLib Dialer Technical Reference
ZoneSetConfigurationList Members
ZoneSetConfigurationList Class Constructors Methods Properties Events See Also Send Feedback

The ZoneSetConfigurationList type exposes the following members.

Constructors

 | Name | Description
Public method | ZoneSetConfigurationList | Initializes a new instance of the ZoneSetConfigurationList class.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)

See Also

ZoneSetConfigurationList Class


ZoneSetConfigurationList Constructor

[image]

IceLib Dialer Technical Reference
ZoneSetConfigurationList Constructor
ZoneSetConfigurationList Class See Also Send Feedback
Initializes a new instance of the ZoneSetConfigurationList class.

Namespace: ININ.IceLib.Configuration.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ZoneSetConfigurationList(
    ConfigurationManager configurationManager
)
Visual Basic
Public Sub New ( _
    configurationManager As ConfigurationManager _
)

Parameters

configurationManager
Type: ConfigurationManager
The configuration manager.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is nullNothingnullptra null reference (Nothing in Visual Basic).

See Also

ZoneSetConfigurationList Class
ZoneSetConfigurationList Members


ZoneSetConfigurationList Methods

[image] [image]

IceLib Dialer Technical Reference
ZoneSetConfigurationList Methods
ZoneSetConfigurationList Class See Also Send Feedback

The ZoneSetConfigurationList type exposes the following members.

Methods

 | Name | Description
Public method | ChangeWatchQuerySettings | (Inherited from DynamicConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | ChangeWatchQuerySettingsAsync | (Inherited from DynamicConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | CreateObject | (Inherited from EditableConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | CreateObjectAsync | (Inherited from EditableConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | CreateQuerySettings | (Inherited from ConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetConfigurationList | (Inherited from ConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshWatch | (Inherited from DynamicConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | RefreshWatchAsync | (Inherited from DynamicConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | StartCaching()()()() | (Inherited from ConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | StartCaching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from ConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | StartCachingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from ConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | StartWatching()()()() | (Inherited from DynamicConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | StartWatching(QuerySettings<(Of <<'(UTP, UTP>)>>)) | (Inherited from DynamicConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | StartWatchingAsync(QuerySettings<(Of <<'(UTP, UTP>)>>), AsyncCompletedEventHandler, Object) | (Inherited from DynamicConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | StopCaching | (Inherited from ConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | StopWatching | (Inherited from DynamicConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | StopWatchingAsync | (Inherited from DynamicConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ZoneSetConfigurationList Class


ZoneSetConfigurationList Properties

[image] [image]

IceLib Dialer Technical Reference
ZoneSetConfigurationList Properties
ZoneSetConfigurationList Class See Also Send Feedback

The ZoneSetConfigurationList type exposes the following members.

Properties

 | Name | Description
Public property | ConfigurationManager | (Inherited from ConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public property | IsCaching | (Inherited from ConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public property | IsWatching | (Inherited from ConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public property | MoreResultsAvailable | (Inherited from ConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)

See Also

ZoneSetConfigurationList Class


ZoneSetConfigurationList Events

[image] [image]

IceLib Dialer Technical Reference
ZoneSetConfigurationList Events
ZoneSetConfigurationList Class See Also Send Feedback

The ZoneSetConfigurationList type exposes the following members.

Events

 | Name | Description
Public event | ConfigurationObjectsAdded | (Inherited from DynamicConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsChanged | (Inherited from DynamicConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)
Public event | ConfigurationObjectsRemoved | (Inherited from DynamicConfigurationList<(Of <(<' ZoneSetConfiguration, ZoneSetConfiguration..::..Property >)>)>.)

See Also

ZoneSetConfigurationList Class


ININ.IceLib.Configuration.Dialer.DataTypes Namespace

[image]

IceLib Dialer Technical Reference
ININ.IceLib.Configuration.Dialer.DataTypes Namespace
Send Feedback

Classes

 | Class | Description
Public class | AccessDataSet | An enumerable and appendable data source respresenting a table in a Microsoft Access database.
Public class | BaseScriptMiscellaneous | A collection of miscellaneous properties of a base script.
Public class | CallStage | A part of a campaign phone call, such as the sales pitch or collecting order information.
Public class | CSVDataSet | An enumerable and appendable data source representing a text file containing comma-separated values.
Public class | CSVDataSet..::..CSVDataSetEnumerator | Supports all classes in the .NET Framework class hierarchy and provides low-level services to derived classes. This is the ultimate base class of all classes in the .NET Framework; it is the root of the type hierarchy.
Public class | DBColumn | A class representing a column in a database table.
Public class | DNCScrubResult | A class representing DNC Scrubbing result
Public class | DNCSourceCampaign | A class representing DNC.Com campaign
Public class | ExcelDataSet | An enumerable and appendable data source representing a Microsoft Excel spreadsheet.
Public class | ExcelDataSet..::..ExcelDataSetEnumerator | Supports all classes in the .NET Framework class hierarchy and provides low-level services to derived classes. This is the ultimate base class of all classes in the .NET Framework; it is the root of the type hierarchy.
Public class | InboundWorkgroup | A class representing inbound call limits for a particular workgroup.
Public class | OleDbDataSet | An enumerable data source accessed using the .NET Framework Data Provider for OLE DB.
Public class | OleDbDataSet..::..OleDbDataSetEnumerator | Supports all classes in the .NET Framework class hierarchy and provides low-level services to derived classes. This is the ultimate base class of all classes in the .NET Framework; it is the root of the type hierarchy.
Public class | OracleDataSet | An enumerable and appendable data source representing a table in an Oracle database.
Public class | ScheduledCall | A scheduled call for an existing contact.
Public class | ScheduleTimeSlot | A time slot for use in Schedule objects. Specifies the state of a campaign in a given time range.
Public class | SortColumn | A class representing a sort clause in a SQL statement.
Public class | SQLServerDataSet | An enumerable and appendable data source representing a table in a SQL Server database.
Public class | TimeSlot | Represents a period of time.
Public class | Zone | A collection of time slots representing a time zone. The slots determine when dialing is blocked for this time zone.

Interfaces

 | Interface | Description
Public interface | IDataSet | Represents an enumerable and appendable data source not accessible from any Dialer connections.
Public interface | IDataSetEnumerator | Supports iteration of records in a dataset.

Enumerations

 | Enumeration | Description
Public enumeration | AbandonCalculationMode | Methods for calculating abandon rates.
Public enumeration | AbandonInclusionMode | Describes when a call should be abandoned for remote hangups, system hangups, and when no agent is available.
Public enumeration | ActionType | Possible actions performable by an agentless policy condition.
Public enumeration | AgentlessAction | Possible actions to perform on an agentless call.
Public enumeration | AllowedCampaignGroupProperty | Allowed Campaign Properties that can be used by Ruleset Actions or Sequence Campaign Groups.
Public enumeration | AttributeOperation | Operations that may be applied to an attribute value in a attribute policy behavior.
Public enumeration | CallAnalysisResult | Possible values of call analysis results for a call analysis policy condition.
Public enumeration | CallAttributeType | Accepted data types for call attribute policy conditions.
Public enumeration | CallbackTimeMode | Possible modes used in callback policy behaviors.
Public enumeration | CallCategory | Possible categories for a call category policy condition. Can be treated as bit field.
Public enumeration | CallRoutingMode | Possible modes used in call routing policy behaviors.
Public enumeration | CampaignAction | Possible actions that a rule may perform on a campaign.
Public enumeration | CampaignDialingMode | The available calling modes for a campaign.
Public enumeration | ComparisonOperator | Enumeration of basic comparison operators used in rule and policy conditions.
Public enumeration | DatabaseType | Supported database management systems.
Public enumeration | DNCScrubQueryResult | DNC Scrub Query Result Type
Public enumeration | DNCScrubSourceType | DNC Scrubbing Source
Public enumeration | EventLogSeverity | Possible severity levels used in event log policy behaviors.
Public enumeration | MaxDailyAttemptType | Determines How the Max Daily Attempts property should be implemented.
Public enumeration | OutboundLineType | Available methods for making calls in a campaign.
Public enumeration | PenetrationRateCalculationMode | Methods for calculating Penetration Rate.
Public enumeration | PNDCounter | Possible fields checked in phone number detail policy conditions.
Public enumeration | PolicyBehaviorType | Policy behavior categories that define what kind of behavior is performed.
Public enumeration | PolicyConditionType | Policy condition categories that define what kind of evaluation is performed.
Public enumeration | PolicyDialingMode | possible dialing modes for policy conditions.
Public enumeration | PolicyEvaluationMode | Modes of policy condition evaluation.
Public enumeration | PolicyType | Policy categories that define when the policy is evaluated.
Public enumeration | RecordAttributeType | Accepted data types for attribute policy conditions.
Public enumeration | RepetitionMode | Values for rule evaluation frequency.
Public enumeration | RuleActionType | Specific types of actions that a rule can execute.
Public enumeration | RuleEngineTermination | Specifies the scope of rule evaluation to terminate.
Public enumeration | RuleFunction | Mathematical functions used in evaluating conditions for custom StatRules
Public enumeration | RuleType | Types of conditions that a rule may evaluate.
Public enumeration | ScheduledCampaignState | Possible campaign states for a Schedule.
Public enumeration | StatPeriod | Possible start points for a rule or policy statistic condition.
Public enumeration | StatRuleType | Distinguishes between built-in and custom statistics.
Public enumeration | SystemEvent | Dialer system events that may be monitored by EventRules.
Public enumeration | TimeRuleMode | Settings for the frequency of time rule execution.
Public enumeration | TimeZoneAutoMapping | Describes how phone numbers should be mapped to time zones.
Public enumeration | TimezoneMapDatasetFormat | The set of timezone mapping data formats supported by Interaction Dialer.
Public enumeration | TimezoneMapDatasetTestResult | Possible results returned from TimezoneMapDatasetTest(TimezoneMapDatasetFormat, String)


AbandonCalculationMode Enumeration

[image]

IceLib Dialer Technical Reference
AbandonCalculationMode Enumeration
See Also Send Feedback
Methods for calculating abandon rates.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum AbandonCalculationMode
Visual Basic
Public Enumeration AbandonCalculationMode

Members

Member name | Value | Description
ByCalls | 0 | Calculate abandons by dividing the number of abandons by the total number of calls placed.
ByContacts | 1 | Calculates abandons by dividing the number of abandons by the total contacts made.
ByDetections | 2 | Calculates abandons by comparing the number of system-calculated abandons to the number of system-dtected live people.

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


AbandonInclusionMode Enumeration

[image]

IceLib Dialer Technical Reference
AbandonInclusionMode Enumeration
See Also Send Feedback
Describes when a call should be abandoned for remote hangups, system hangups, and when no agent is available.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum AbandonInclusionMode
Visual Basic
Public Enumeration AbandonInclusionMode

Members

Member name | Value | Description
Always | 0 | Always consider as an abandon.
AfterDelay | 1 | For remote hangups, calls are considered abandoned if the remote party disconnected after a configurable number of seconds. When no agent is available, the call is considered abandoned if no agent becomes available after a configurable number of seconds.
Never | 2 | Never consider as an abandon.

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


AccessDataSet Class

[image]

IceLib Dialer Technical Reference
AccessDataSet Class
Members See Also Send Feedback
An enumerable and appendable data source respresenting a table in a Microsoft Access database.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class AccessDataSet : OleDbDataSet
Visual Basic
Public Class AccessDataSet _
    Inherits OleDbDataSet

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer.DataTypes..::..OleDbDataSet
ININ.IceLib.Configuration.Dialer.DataTypes..::..AccessDataSet

See Also

AccessDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


AccessDataSet Members

[image] [image]

IceLib Dialer Technical Reference
AccessDataSet Members
AccessDataSet Class Constructors Methods Properties See Also Send Feedback

The AccessDataSet type exposes the following members.

Constructors

 | Name | Description
Public method | AccessDataSet(String, String) | Creates a new instance of the AccessDataSet class.
Public method | AccessDataSet(String, String, IEnumerable<(Of <<'(DBColumn>)>>)) | Creates a new instance of the AccessDataSet class representing a data set that does not yet exist.
Public method | AccessDataSet(String, String, String, String) | Creates a new instance of the AccessDataSet class.
Public method | AccessDataSet(String, String, String, String, IEnumerable<(Of <<'(DBColumn>)>>)) | Creates a new instance of the AccessDataSet class representing a data set that does not yet exist.

Methods

 | Name | Description
Public method | CloseConnection | Closes the connection to the database or, if the source is a file, closes the file. Ignored if connection is not open. (Inherited from OleDbDataSet.)
Public method | CommitTransaction | Ends a transaction by committing all changes. (Inherited from OleDbDataSet.)
Public method | CreateTable | Creates a new table in the database or a new file containing the fields in the Fields property. (Overrides OleDbDataSet..::..CreateTable()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from OleDbDataSet.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenConnection | Opens the connection to the database or, if the source is a file, opens the file. Ignored if connection is already open. (Inherited from OleDbDataSet.)
Protected method | PrepareForWrite | Prepares the data set for one or more calls to WriteRecord(IDictionary<(Of <<'(DBColumn, Object>)>>)). (Inherited from OleDbDataSet.)
Public method | RollbackTransaction | Ends a transaction by reverting all changes. (Inherited from OleDbDataSet.)
Public method | StartTransaction | Begins a transaction. Transactions must be ended by calling either CommitTransaction()()()() or RollbackTransaction()()()() (Inherited from OleDbDataSet.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteRecord | Writes a single record to the database. (Inherited from OleDbDataSet.)

Properties

 | Name | Description
Public property | ConnectionState | The state of the connection to the database or the source file. (Inherited from OleDbDataSet.)
Protected property | DBMS | (Inherited from OleDbDataSet.)
Public property | Fields | The columns in the data source. (Inherited from OleDbDataSet.)
Public property | FilePath | The full file path to the database file.
Public property | Password | The user's password, or an empty string if the database is not password-protected.
Public property | TableName | The database table or file path where the data resides. (Inherited from OleDbDataSet.)
Public property | User | The user that has access to the database. Defaults to the admin account if the database is not password-protected.

See Also

AccessDataSet Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


AccessDataSet Constructor

[image] [image]

IceLib Dialer Technical Reference
AccessDataSet Constructor
AccessDataSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AccessDataSet(String, String) | Creates a new instance of the AccessDataSet class.
Public method | AccessDataSet(String, String, IEnumerable<(Of <<'(DBColumn>)>>)) | Creates a new instance of the AccessDataSet class representing a data set that does not yet exist.
Public method | AccessDataSet(String, String, String, String) | Creates a new instance of the AccessDataSet class.
Public method | AccessDataSet(String, String, String, String, IEnumerable<(Of <<'(DBColumn>)>>)) | Creates a new instance of the AccessDataSet class representing a data set that does not yet exist.

See Also

AccessDataSet Class
AccessDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


AccessDataSet Constructor (String, String)

[image]

IceLib Dialer Technical Reference
AccessDataSet Constructor (String, String)
AccessDataSet Class See Also Send Feedback
Creates a new instance of the AccessDataSet class.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public AccessDataSet(
    string filePath,
    string table
)
Visual Basic
Public Sub New ( _
    filePath As String, _
    table As String _
)

Parameters

filePath
Type: System..::..String
The full file path of the database file
table
Type: System..::..String
The table in the database in which the data resides.

Remarks

This overload should be used for files that do not require authentication.

See Also

AccessDataSet Class
AccessDataSet Members
AccessDataSet Overload
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


AccessDataSet Constructor (String, String, IEnumerable(DBColumn))

[image]

IceLib Dialer Technical Reference
AccessDataSet Constructor (String, String, IEnumerable<(Of <(<'DBColumn>)>)>)
AccessDataSet Class See Also Send Feedback
Creates a new instance of the AccessDataSet class representing a data set that does not yet exist.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public AccessDataSet(
    string filepath,
    string table,
    IEnumerable<DBColumn> fields
)
Visual Basic
Public Sub New ( _
    filepath As String, _
    table As String, _
    fields As IEnumerable(Of DBColumn) _
)

Parameters

filepath
Type: System..::..String
The full file path of the database file
table
Type: System..::..String
The name to give the new table
fields
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' DBColumn >)>)>
The fields to create in the new table

Remarks

This overload should be used for files that do not require authentication

See Also

AccessDataSet Class
AccessDataSet Members
AccessDataSet Overload
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


AccessDataSet Constructor (String, String, String, String)

[image]

IceLib Dialer Technical Reference
AccessDataSet Constructor (String, String, String, String)
AccessDataSet Class See Also Send Feedback
Creates a new instance of the AccessDataSet class.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public AccessDataSet(
    string filePath,
    string table,
    string user,
    string password
)
Visual Basic
Public Sub New ( _
    filePath As String, _
    table As String, _
    user As String, _
    password As String _
)

Parameters

filePath
Type: System..::..String
The full file path of the database file
table
Type: System..::..String
The table in the database in which the data resides
user
Type: System..::..String
The user name that has access to the database file
password
Type: System..::..String
The user's password

See Also

AccessDataSet Class
AccessDataSet Members
AccessDataSet Overload
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


AccessDataSet Constructor (String, String, String, String, IEnumerable(DBColumn))

[image]

IceLib Dialer Technical Reference
AccessDataSet Constructor (String, String, String, String, IEnumerable<(Of <(<'DBColumn>)>)>)
AccessDataSet Class See Also Send Feedback
Creates a new instance of the AccessDataSet class representing a data set that does not yet exist.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public AccessDataSet(
    string filepath,
    string table,
    string user,
    string password,
    IEnumerable<DBColumn> fields
)
Visual Basic
Public Sub New ( _
    filepath As String, _
    table As String, _
    user As String, _
    password As String, _
    fields As IEnumerable(Of DBColumn) _
)

Parameters

filepath
Type: System..::..String
The full file path of the database file
table
Type: System..::..String
The name to give the new table
user
Type: System..::..String
The user name that has (or will have) access to the database file
password
Type: System..::..String
The user's password
fields
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' DBColumn >)>)>
The fields to create in the new table

See Also

AccessDataSet Class
AccessDataSet Members
AccessDataSet Overload
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


AccessDataSet Methods

[image] [image]

IceLib Dialer Technical Reference
AccessDataSet Methods
AccessDataSet Class See Also Send Feedback

The AccessDataSet type exposes the following members.

Methods

 | Name | Description
Public method | CloseConnection | Closes the connection to the database or, if the source is a file, closes the file. Ignored if connection is not open. (Inherited from OleDbDataSet.)
Public method | CommitTransaction | Ends a transaction by committing all changes. (Inherited from OleDbDataSet.)
Public method | CreateTable | Creates a new table in the database or a new file containing the fields in the Fields property. (Overrides OleDbDataSet..::..CreateTable()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from OleDbDataSet.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenConnection | Opens the connection to the database or, if the source is a file, opens the file. Ignored if connection is already open. (Inherited from OleDbDataSet.)
Protected method | PrepareForWrite | Prepares the data set for one or more calls to WriteRecord(IDictionary<(Of <<'(DBColumn, Object>)>>)). (Inherited from OleDbDataSet.)
Public method | RollbackTransaction | Ends a transaction by reverting all changes. (Inherited from OleDbDataSet.)
Public method | StartTransaction | Begins a transaction. Transactions must be ended by calling either CommitTransaction()()()() or RollbackTransaction()()()() (Inherited from OleDbDataSet.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteRecord | Writes a single record to the database. (Inherited from OleDbDataSet.)

See Also

AccessDataSet Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CreateTable Method

[image]

IceLib Dialer Technical Reference
AccessDataSet..::..CreateTable Method
AccessDataSet Class See Also Send Feedback
Creates a new table in the database or a new file containing the fields in the Fields property.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override void CreateTable()
Visual Basic
Public Overrides Sub CreateTable

Implements

IDataSet..::..CreateTable()()()()

See Also

AccessDataSet Class
AccessDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


AccessDataSet Properties

[image] [image]

IceLib Dialer Technical Reference
AccessDataSet Properties
AccessDataSet Class See Also Send Feedback

The AccessDataSet type exposes the following members.

Properties

 | Name | Description
Public property | ConnectionState | The state of the connection to the database or the source file. (Inherited from OleDbDataSet.)
Protected property | DBMS | (Inherited from OleDbDataSet.)
Public property | Fields | The columns in the data source. (Inherited from OleDbDataSet.)
Public property | FilePath | The full file path to the database file.
Public property | Password | The user's password, or an empty string if the database is not password-protected.
Public property | TableName | The database table or file path where the data resides. (Inherited from OleDbDataSet.)
Public property | User | The user that has access to the database. Defaults to the admin account if the database is not password-protected.

See Also

AccessDataSet Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


FilePath Property

[image]

IceLib Dialer Technical Reference
AccessDataSet..::..FilePath Property
AccessDataSet Class See Also Send Feedback
The full file path to the database file.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string FilePath { get; private set; }
Visual Basic
Public Property FilePath As String
    Get
    Private Set

See Also

AccessDataSet Class
AccessDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Password Property

[image]

IceLib Dialer Technical Reference
AccessDataSet..::..Password Property
AccessDataSet Class See Also Send Feedback
The user's password, or an empty string if the database is not password-protected.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Password { get; private set; }
Visual Basic
Public Property Password As String
    Get
    Private Set

See Also

AccessDataSet Class
AccessDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


User Property

[image]

IceLib Dialer Technical Reference
AccessDataSet..::..User Property
AccessDataSet Class See Also Send Feedback
The user that has access to the database. Defaults to the admin account if the database is not password-protected.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string User { get; private set; }
Visual Basic
Public Property User As String
    Get
    Private Set

See Also

AccessDataSet Class
AccessDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ActionType Enumeration

[image]

IceLib Dialer Technical Reference
ActionType Enumeration
See Also Send Feedback
Possible actions performable by an agentless policy condition.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum ActionType
Visual Basic
Public Enumeration ActionType

Members

Member name | Value | Description
PlayVoiceFile | 0 | Play a voice recording (wav file).
SendFaxFile | 1 | Play/send a recorded fax (wav file).
AttendantProfile | 2 | Redirect the call to an attendant profile.

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


AgentlessAction Enumeration

[image]

IceLib Dialer Technical Reference
AgentlessAction Enumeration
See Also Send Feedback
Possible actions to perform on an agentless call.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum AgentlessAction
Visual Basic
Public Enumeration AgentlessAction

Members

Member name | Value | Description
Hangup | 0 | Hang up the call.
RouteToAttendantProfile | 1 | Forward the call to an attendant profile.
PlayFile | 2 | Play a wave audio file.
ConnectToAgent | 3 | Connect to the call to an agent.

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


AllowedCampaignGroupProperty Enumeration

[image]

IceLib Dialer Technical Reference
AllowedCampaignGroupProperty Enumeration
See Also Send Feedback
Allowed Campaign Properties that can be used by Ruleset Actions or Sequence Campaign Groups.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum AllowedCampaignGroupProperty
Visual Basic
Public Enumeration AllowedCampaignGroupProperty

Members

Member name | Value | Description
AbandonRateCalculation | 0 |
AcdAgentAvailableTimeInterval | 1 |
AcdAgentAvailableTimeWeight | 2 |
AcdAgentCostWeight | 3 |
AcdAgentSkillWeight | 4 |
AcdPriorityLevel | 5 |
AcdPriorityWeight | 6 |
AcdSkillsWeight | 7 |
AcdTimeInQueueWeight | 8 |
AcdTimeInSystemWeight | 9 |
AgentlessAnsweringMachineAttendantProfile | 10 |
AgentlessAnsweringMachineFile | 11 |
AgentlessAnsweringMachineSecondsOfSilence | 12 |
AgentlessAnsweringMachineType | 13 |
AgentlessFaxAttendantProfile | 14 |
AgentlessFaxFile | 15 |
AgentlessFaxMaxRetries | 16 |
AgentlessFaxType | 17 |
AgentlessLiveAttendantProfile | 18 |
AgentlessLiveFile | 19 |
AgentlessLiveType | 20 |
AgentlessNoAgentAttendantProfile | 21 |
AgentlessNoAgentFile | 22 |
AgentlessNoAgentType | 23 |
AgentlessMaxLines | 24 |
AutomapTimeZone | 25 |
AutopacingMaxPace | 26 |
AutoscheduleAnsweringMachineRescheduleDelay | 27 |
AutoscheduleAnsweringMachineMaxAttempts | 28 |
AutoscheduleBusyRescheduleDelay | 29 |
AutoscheduleBusyMaxAttempts | 30 |
AutoscheduleFaxRescheduleDelay | 31 |
AutoscheduleFaxMaxAttempts | 32 |
AutoscheduleNoAnswerRescheduleDelay | 33 |
AutoscheduleNoAnswerMaxAttempts | 34 |
AutoscheduleRemoteHangupRescheduleDelay | 35 |
AutoscheduleRemoteHangupMaxAttempts | 36 |
AutoscheduleSystemHangupRescheduleDelay | 37 |
AutoscheduleSystemHangupMaxAttempts | 38 |
AutoscheduledCallsIgnoreRecycles | 39 |
BaseScript | 40 |
CallerIdDisplayName | 41 |
CallerIdDisplayNumber | 42 |
CallingMode | 43 |
CallStages | 44 |
CallTimeoutSeconds | 45 |
CampaignGroup | 46 |
CampaignStatInterval | 47 |
ContactColumns | 48 |
CopyDialerAttributesToCallAttributes | 49 |
CustomizeContactColumns | 50 |
CustomScriptURL | 51 |
DialingPace | 52 |
DialingPriority | 53 |
DialingSchedule | 54 |
DisplayTransitionAlerts | 55 |
EnableAnsweringMachineDetection | 56 |
EnableCallAnalysis | 57 |
EnableMaxPreviewTime | 58 |
Filters | 59 |
FilterAutoscheduledCallbacks | 60 |
FilterScheduledCallbacks | 61 |
FollowUpStatus | 62 |
InitialCallsPerRequest | 63 |
MaxAbandonRate | 64 |
MaxAttempts | 65 |
MaxLines | 66 |
MaxPreviewSeconds | 67 |
MaxRecycles | 68 |
OutboundLinegroup | 69 |
OverallInboundHighThreshold | 70 |
OverallInboundLowThreshold | 71 |
PolicySets | 72 |
RescheduleDelay | 73 |
RuleSet | 74 |
SortColumns | 75 |
TimeZoneAutoMappingMode | 76 |
TotalAttempts | 77 |
UseAutoScheduleSettingsForAgentCallbacks | 78 |
ZoneSet | 79 |
QueryTimeFilters | 80 |
UseCallingTimeRestrictions | 81 |
UseCallingTimeWindow | 82 |
UseDoNotCallToday | 83 |
UsePermissionEbr | 84 |
SMSBroker | 85 |
SMSBrokerAccount | 86 |
OutboundSMSEnabled | 87 |

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


AttributeOperation Enumeration

[image]

IceLib Dialer Technical Reference
AttributeOperation Enumeration
See Also Send Feedback
Operations that may be applied to an attribute value in a attribute policy behavior.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum AttributeOperation
Visual Basic
Public Enumeration AttributeOperation

Members

Member name | Value | Description
Add | 0 | A value is added to the attribute
Subtract | 1 | A number is subtracted from the attribute
None | 2 | No arithmetic operation is performed.

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


BaseScriptMiscellaneous Class

[image]

IceLib Dialer Technical Reference
BaseScriptMiscellaneous Class
Members See Also Send Feedback
A collection of miscellaneous properties of a base script.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class BaseScriptMiscellaneous
Visual Basic
Public Class BaseScriptMiscellaneous

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer.DataTypes..::..BaseScriptMiscellaneous

See Also

BaseScriptMiscellaneous Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


BaseScriptMiscellaneous Members

[image] [image]

IceLib Dialer Technical Reference
BaseScriptMiscellaneous Members
BaseScriptMiscellaneous Class Constructors Methods Properties See Also Send Feedback

The BaseScriptMiscellaneous type exposes the following members.

Constructors

 | Name | Description
Public method | BaseScriptMiscellaneous | Creates a new instance of the BaseScriptMiscellaneous class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowAgentOwnedCallbacks | Determines whether a scheduled callback is routed to a specific agent, or to any available agent in the participating ACD workgroup.
Public property | AllowAgentsAdditionalCalls | Determines whether agents can place calls to additional phone numbers
Public property | AllowEditingOfNumberToDial | Determines whether the number to dial can be edited for Preview campaigns
Public property | AllowEditingPhoneNumbers | Determines whether agents can edit additional phone numbers
Public property | AllowSchedulePhoneNumber | Allow agents to specify the callback number when scheduling a call
Public property | AutomaticallyDisconnectOnDisposition | Disconnect the call automatically once a call disposition button is clicked.
Public property | DisplayBreakButton | When true, Interaction Scripter client will display a button that agents can click to request a break.
Public property | DisplayPreviewSkipButton | When true, Interaction Scripter client will display a Skip button while in Preview calling mode.
Public property | PermitOverrideDailyLimitCheck | Determines whether agents can override the dialy limit check for additional numbers
Public property | PermitOverrideDNCCheck | Determines whether agents can override the DNC check for additional numbers
Public property | PermitOverrideSkillsCheck | Determines whether agents can override the skills check for additional numbers
Public property | PermitOverrideTimeZoneCheck | Determines whether agents can override the timezone check for additional numbers
Public property | PickupAlertingCalls | Specifies whether alerting calls should be automatically picked up by the Standard Form.
Public property | Use24HourTimeFormat | Specifies whether to use 24-hour (military) time.

See Also

BaseScriptMiscellaneous Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


BaseScriptMiscellaneous Constructor

[image]

IceLib Dialer Technical Reference
BaseScriptMiscellaneous Constructor
BaseScriptMiscellaneous Class See Also Send Feedback
Creates a new instance of the BaseScriptMiscellaneous class.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public BaseScriptMiscellaneous()
Visual Basic
Public Sub New

See Also

BaseScriptMiscellaneous Class
BaseScriptMiscellaneous Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


BaseScriptMiscellaneous Methods

[image] [image]

IceLib Dialer Technical Reference
BaseScriptMiscellaneous Methods
BaseScriptMiscellaneous Class See Also Send Feedback

The BaseScriptMiscellaneous type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseScriptMiscellaneous Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


BaseScriptMiscellaneous Properties

[image] [image]

IceLib Dialer Technical Reference
BaseScriptMiscellaneous Properties
BaseScriptMiscellaneous Class See Also Send Feedback

The BaseScriptMiscellaneous type exposes the following members.

Properties

 | Name | Description
Public property | AllowAgentOwnedCallbacks | Determines whether a scheduled callback is routed to a specific agent, or to any available agent in the participating ACD workgroup.
Public property | AllowAgentsAdditionalCalls | Determines whether agents can place calls to additional phone numbers
Public property | AllowEditingOfNumberToDial | Determines whether the number to dial can be edited for Preview campaigns
Public property | AllowEditingPhoneNumbers | Determines whether agents can edit additional phone numbers
Public property | AllowSchedulePhoneNumber | Allow agents to specify the callback number when scheduling a call
Public property | AutomaticallyDisconnectOnDisposition | Disconnect the call automatically once a call disposition button is clicked.
Public property | DisplayBreakButton | When true, Interaction Scripter client will display a button that agents can click to request a break.
Public property | DisplayPreviewSkipButton | When true, Interaction Scripter client will display a Skip button while in Preview calling mode.
Public property | PermitOverrideDailyLimitCheck | Determines whether agents can override the dialy limit check for additional numbers
Public property | PermitOverrideDNCCheck | Determines whether agents can override the DNC check for additional numbers
Public property | PermitOverrideSkillsCheck | Determines whether agents can override the skills check for additional numbers
Public property | PermitOverrideTimeZoneCheck | Determines whether agents can override the timezone check for additional numbers
Public property | PickupAlertingCalls | Specifies whether alerting calls should be automatically picked up by the Standard Form.
Public property | Use24HourTimeFormat | Specifies whether to use 24-hour (military) time.

See Also

BaseScriptMiscellaneous Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


AllowAgentOwnedCallbacks Property

[image]

IceLib Dialer Technical Reference
BaseScriptMiscellaneous..::..AllowAgentOwnedCallbacks Property
BaseScriptMiscellaneous Class See Also Send Feedback
Determines whether a scheduled callback is routed to a specific agent, or to any available agent in the participating ACD workgroup.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool AllowAgentOwnedCallbacks { get; set; }
Visual Basic
Public Property AllowAgentOwnedCallbacks As Boolean
    Get
    Set

See Also

BaseScriptMiscellaneous Class
BaseScriptMiscellaneous Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


AllowAgentsAdditionalCalls Property

[image]

IceLib Dialer Technical Reference
BaseScriptMiscellaneous..::..AllowAgentsAdditionalCalls Property
BaseScriptMiscellaneous Class See Also Send Feedback
Determines whether agents can place calls to additional phone numbers

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool AllowAgentsAdditionalCalls { get; set; }
Visual Basic
Public Property AllowAgentsAdditionalCalls As Boolean
    Get
    Set

See Also

BaseScriptMiscellaneous Class
BaseScriptMiscellaneous Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


AllowEditingOfNumberToDial Property

[image]

IceLib Dialer Technical Reference
BaseScriptMiscellaneous..::..AllowEditingOfNumberToDial Property
BaseScriptMiscellaneous Class See Also Send Feedback
Determines whether the number to dial can be edited for Preview campaigns

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool AllowEditingOfNumberToDial { get; set; }
Visual Basic
Public Property AllowEditingOfNumberToDial As Boolean
    Get
    Set

See Also

BaseScriptMiscellaneous Class
BaseScriptMiscellaneous Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


AllowEditingPhoneNumbers Property

[image]

IceLib Dialer Technical Reference
BaseScriptMiscellaneous..::..AllowEditingPhoneNumbers Property
BaseScriptMiscellaneous Class See Also Send Feedback
Determines whether agents can edit additional phone numbers

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool AllowEditingPhoneNumbers { get; set; }
Visual Basic
Public Property AllowEditingPhoneNumbers As Boolean
    Get
    Set

See Also

BaseScriptMiscellaneous Class
BaseScriptMiscellaneous Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


AllowSchedulePhoneNumber Property

[image]

IceLib Dialer Technical Reference
BaseScriptMiscellaneous..::..AllowSchedulePhoneNumber Property
BaseScriptMiscellaneous Class See Also Send Feedback
Allow agents to specify the callback number when scheduling a call

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool AllowSchedulePhoneNumber { get; set; }
Visual Basic
Public Property AllowSchedulePhoneNumber As Boolean
    Get
    Set

See Also

BaseScriptMiscellaneous Class
BaseScriptMiscellaneous Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


AutomaticallyDisconnectOnDisposition Property

[image]

IceLib Dialer Technical Reference
BaseScriptMiscellaneous..::..AutomaticallyDisconnectOnDisposition Property
BaseScriptMiscellaneous Class See Also Send Feedback
Disconnect the call automatically once a call disposition button is clicked.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool AutomaticallyDisconnectOnDisposition { get; set; }
Visual Basic
Public Property AutomaticallyDisconnectOnDisposition As Boolean
    Get
    Set

See Also

BaseScriptMiscellaneous Class
BaseScriptMiscellaneous Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


DisplayBreakButton Property

[image]

IceLib Dialer Technical Reference
BaseScriptMiscellaneous..::..DisplayBreakButton Property
BaseScriptMiscellaneous Class See Also Send Feedback
When true, Interaction Scripter client will display a button that agents can click to request a break.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool DisplayBreakButton { get; set; }
Visual Basic
Public Property DisplayBreakButton As Boolean
    Get
    Set

See Also

BaseScriptMiscellaneous Class
BaseScriptMiscellaneous Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


DisplayPreviewSkipButton Property

[image]

IceLib Dialer Technical Reference
BaseScriptMiscellaneous..::..DisplayPreviewSkipButton Property
BaseScriptMiscellaneous Class See Also Send Feedback
When true, Interaction Scripter client will display a Skip button while in Preview calling mode.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool DisplayPreviewSkipButton { get; set; }
Visual Basic
Public Property DisplayPreviewSkipButton As Boolean
    Get
    Set

See Also

BaseScriptMiscellaneous Class
BaseScriptMiscellaneous Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


PermitOverrideDailyLimitCheck Property

[image]

IceLib Dialer Technical Reference
BaseScriptMiscellaneous..::..PermitOverrideDailyLimitCheck Property
BaseScriptMiscellaneous Class See Also Send Feedback
Determines whether agents can override the dialy limit check for additional numbers

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool PermitOverrideDailyLimitCheck { get; set; }
Visual Basic
Public Property PermitOverrideDailyLimitCheck As Boolean
    Get
    Set

See Also

BaseScriptMiscellaneous Class
BaseScriptMiscellaneous Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


PermitOverrideDNCCheck Property

[image]

IceLib Dialer Technical Reference
BaseScriptMiscellaneous..::..PermitOverrideDNCCheck Property
BaseScriptMiscellaneous Class See Also Send Feedback
Determines whether agents can override the DNC check for additional numbers

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool PermitOverrideDNCCheck { get; set; }
Visual Basic
Public Property PermitOverrideDNCCheck As Boolean
    Get
    Set

See Also

BaseScriptMiscellaneous Class
BaseScriptMiscellaneous Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


PermitOverrideSkillsCheck Property

[image]

IceLib Dialer Technical Reference
BaseScriptMiscellaneous..::..PermitOverrideSkillsCheck Property
BaseScriptMiscellaneous Class See Also Send Feedback
Determines whether agents can override the skills check for additional numbers

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool PermitOverrideSkillsCheck { get; set; }
Visual Basic
Public Property PermitOverrideSkillsCheck As Boolean
    Get
    Set

See Also

BaseScriptMiscellaneous Class
BaseScriptMiscellaneous Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


PermitOverrideTimeZoneCheck Property

[image]

IceLib Dialer Technical Reference
BaseScriptMiscellaneous..::..PermitOverrideTimeZoneCheck Property
BaseScriptMiscellaneous Class See Also Send Feedback
Determines whether agents can override the timezone check for additional numbers

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool PermitOverrideTimeZoneCheck { get; set; }
Visual Basic
Public Property PermitOverrideTimeZoneCheck As Boolean
    Get
    Set

See Also

BaseScriptMiscellaneous Class
BaseScriptMiscellaneous Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


PickupAlertingCalls Property

[image]

IceLib Dialer Technical Reference
BaseScriptMiscellaneous..::..PickupAlertingCalls Property
BaseScriptMiscellaneous Class See Also Send Feedback
Specifies whether alerting calls should be automatically picked up by the Standard Form.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool PickupAlertingCalls { get; set; }
Visual Basic
Public Property PickupAlertingCalls As Boolean
    Get
    Set

See Also

BaseScriptMiscellaneous Class
BaseScriptMiscellaneous Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Use24HourTimeFormat Property

[image]

IceLib Dialer Technical Reference
BaseScriptMiscellaneous..::..Use24HourTimeFormat Property
BaseScriptMiscellaneous Class See Also Send Feedback
Specifies whether to use 24-hour (military) time.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool Use24HourTimeFormat { get; set; }
Visual Basic
Public Property Use24HourTimeFormat As Boolean
    Get
    Set

See Also

BaseScriptMiscellaneous Class
BaseScriptMiscellaneous Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CallAnalysisResult Enumeration

[image]

IceLib Dialer Technical Reference
CallAnalysisResult Enumeration
See Also Send Feedback
Possible values of call analysis results for a call analysis policy condition.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum CallAnalysisResult
Visual Basic
Public Enumeration CallAnalysisResult

Members

Member name | Value | Description
Busy | 0 | A busy signal was encountered.
NoAnswer | 1 | The call was not answered.
AnsweringMachine | 2 | The call was answered by a machine.
SIT | 3 | The call encountered a special information tone.
Fax | 4 | The call was answered by a fax machine.
NoLines | 5 | There were no available lines to place the call.
LivePerson | 6 | The call was answered by a human being.

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CallAttributeType Enumeration

[image]

IceLib Dialer Technical Reference
CallAttributeType Enumeration
See Also Send Feedback
Accepted data types for call attribute policy conditions.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum CallAttributeType
Visual Basic
Public Enumeration CallAttributeType

Members

Member name | Value | Description
DateTime | 0 | Date and/or time.
String | 1 | Text
Number | 2 | Numeric value (integer or decimal).

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CallbackTimeMode Enumeration

[image]

IceLib Dialer Technical Reference
CallbackTimeMode Enumeration
See Also Send Feedback
Possible modes used in callback policy behaviors.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum CallbackTimeMode
Visual Basic
Public Enumeration CallbackTimeMode

Members

Member name | Value | Description
AtSetTime | 0 | Call back at a configured specific time.
OffsetFromCallTime | 1 | Call back after the configured offset, relative to the current time.

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CallCategory Enumeration

[image]

IceLib Dialer Technical Reference
CallCategory Enumeration
See Also Send Feedback
Possible categories for a call category policy condition. Can be treated as bit field.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
[FlagsAttribute]
public enum CallCategory
Visual Basic
<FlagsAttribute> _
Public Enumeration CallCategory

Members

Member name | Value | Description
Normal | 0 | The call does not belong to any special category.
CampaignWideCallback | 1 | A scheduled callback that can be assigned to any agent.
AgentOwnedCallback | 2 | A scheduled callback that is owned by a specific agent.
CampaignWideReschedule | 3 | A rescheduled call that can be assigned to any agent.
AgentOwnedReschedule | 4 | A rescheduled call that is owned by a specific agent.
PriorityCall | 5 | A high-priority call that is pushed to the front of the dialing queue when its contact record is inserted into the contact list.

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CallRoutingMode Enumeration

[image]

IceLib Dialer Technical Reference
CallRoutingMode Enumeration
See Also Send Feedback
Possible modes used in call routing policy behaviors.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum CallRoutingMode
Visual Basic
Public Enumeration CallRoutingMode

Members

Member name | Value | Description
Normal | 0 | The call will be routed normally.
Precise | 1 | A specific agent will be reserved for the call before it is placed.
DoNotDial | 2 | The call will not be placed.
Preview | 3 | The call will be presented in preview mode.

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CallStage Class

[image]

IceLib Dialer Technical Reference
CallStage Class
Members See Also Send Feedback
A part of a campaign phone call, such as the sales pitch or collecting order information.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class CallStage
Visual Basic
Public Class CallStage

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer.DataTypes..::..CallStage

See Also

CallStage Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CallStage Members

[image] [image]

IceLib Dialer Technical Reference
CallStage Members
CallStage Class Constructors Methods Properties See Also Send Feedback

The CallStage type exposes the following members.

Constructors

 | Name | Description
Public method | CallStage | Creates a new instance of the CallStage object.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | The Id of this object.
Public property | MakePrediction | Specifies whether Dialer should collect statistics for predictive dialing while agents are in this stage.
Public property | StageId | The Id of the call stage.

See Also

CallStage Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CallStage Constructor

[image]

IceLib Dialer Technical Reference
CallStage Constructor
CallStage Class See Also Send Feedback
Creates a new instance of the CallStage object.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CallStage(
    string displayName
)
Visual Basic
Public Sub New ( _
    displayName As String _
)

Parameters

displayName
Type: System..::..String
The friendly display name of the object.

See Also

CallStage Class
CallStage Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CallStage Methods

[image] [image]

IceLib Dialer Technical Reference
CallStage Methods
CallStage Class See Also Send Feedback

The CallStage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CallStage Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CallStage Properties

[image] [image]

IceLib Dialer Technical Reference
CallStage Properties
CallStage Class See Also Send Feedback

The CallStage type exposes the following members.

Properties

 | Name | Description
Public property | Id | The Id of this object.
Public property | MakePrediction | Specifies whether Dialer should collect statistics for predictive dialing while agents are in this stage.
Public property | StageId | The Id of the call stage.

See Also

CallStage Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Id Property

[image]

IceLib Dialer Technical Reference
CallStage..::..Id Property
CallStage Class See Also Send Feedback
The Id of this object.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ConfigurationId Id { get; private set; }
Visual Basic
Public Property Id As ConfigurationId
    Get
    Private Set

See Also

CallStage Class
CallStage Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


MakePrediction Property

[image]

IceLib Dialer Technical Reference
CallStage..::..MakePrediction Property
CallStage Class See Also Send Feedback
Specifies whether Dialer should collect statistics for predictive dialing while agents are in this stage.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool MakePrediction { get; set; }
Visual Basic
Public Property MakePrediction As Boolean
    Get
    Set

See Also

CallStage Class
CallStage Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


StageId Property

[image]

IceLib Dialer Technical Reference
CallStage..::..StageId Property
CallStage Class See Also Send Feedback
The Id of the call stage.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int StageId { get; set; }
Visual Basic
Public Property StageId As Integer
    Get
    Set

See Also

CallStage Class
CallStage Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CampaignAction Enumeration

[image]

IceLib Dialer Technical Reference
CampaignAction Enumeration
See Also Send Feedback
Possible actions that a rule may perform on a campaign.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum CampaignAction
Visual Basic
Public Enumeration CampaignAction

Members

Member name | Value | Description
End | 0 | Stop the campaign.
Pause | 1 | Pause the campaign.
RecyleCallList | 2 | Recycle the campaign's contact list.
Reset | 3 | Reset the campaign.
Unpause | 4 | Unpause the campaign.
ScheduledCallsOnly | 5 | Scheduled calls only campaign

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CampaignDialingMode Enumeration

[image]

IceLib Dialer Technical Reference
CampaignDialingMode Enumeration
See Also Send Feedback
The available calling modes for a campaign.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum CampaignDialingMode
Visual Basic
Public Enumeration CampaignDialingMode

Members

Member name | Value | Description
Predictive | 1 | The system makes predictions regarding agent availibility and places calls accordingly.
Power | 2 | Calls are placed only when an agent is available to take the call.
Preview | 3 | Agents are presented with information about the targeted party before the call is placed, allowing the agent to place, reschedule or skip the call.
Agentless | 8 | Connected parties are not routed to agents and instead are responded to based on campaign settings.

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ComparisonOperator Enumeration

[image]

IceLib Dialer Technical Reference
ComparisonOperator Enumeration
See Also Send Feedback
Enumeration of basic comparison operators used in rule and policy conditions.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum ComparisonOperator
Visual Basic
Public Enumeration ComparisonOperator

Members

Member name | Value | Description
LessThan | 0 | The "<" operator.
LessThanOrEqual | 1 | The "<=" operator.
Equal | 2 | The "=" operator.
NotEqual | 3 | The "<>" operator.
GreaterThanOrEqual | 4 | The ">=" operator.
GreaterThan | 5 | The ">" operator.
Regex | 6 | The regular expression operator.

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CSVDataSet Class

[image]

IceLib Dialer Technical Reference
CSVDataSet Class
Members See Also Send Feedback
An enumerable and appendable data source representing a text file containing comma-separated values.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class CSVDataSet : IDataSet, IEnumerable<IDictionary<DBColumn, Object>>,
    IEnumerable, IDisposable
Visual Basic
Public Class CSVDataSet _
    Implements IDataSet, IEnumerable(Of IDictionary(Of DBColumn, Object)),  _
    IEnumerable, IDisposable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer.DataTypes..::..CSVDataSet

See Also

CSVDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CSVDataSet Members

[image] [image]

IceLib Dialer Technical Reference
CSVDataSet Members
CSVDataSet Class Constructors Methods Properties See Also Send Feedback

The CSVDataSet type exposes the following members.

Constructors

 | Name | Description
Public method | CSVDataSet(String) | Creates a new instance of the CSVDataSet class.
Public method | CSVDataSet(String, Char) | Creates a new instance of the CSVDataSet class.
Public method | CSVDataSet(String, IEnumerable<(Of <<'(DBColumn>)>>)) | Creates a new instance of the CSVDataSet class representing a file that does not yet exist.
Public method | CSVDataSet(String, IEnumerable<(Of <<'(DBColumn>)>>), Char) | Creates a new instance of the CSVDataSet class representing a file that does not yet exist.

Methods

 | Name | Description
Public method | CloseConnection | Closes the connection to the database or, if the source is a file, closes the file. Ignored if connection is not open.
Public method | CommitTransaction | Ends a transaction by committing all changes.
Public method | CreateTable | Creates a new table in the database or a new file containing the fields in the Fields property.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenConnection | Opens the connection to the database or, if the source is a file, opens the file. Ignored if connection is already open.
Public method | RollbackTransaction | Ends a transaction by reverting all changes.
Public method | StartTransaction | Begins a transaction. Transactions must be ended by calling either CommitTransaction()()()() or RollbackTransaction()()()()
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteRecord | Writes a single record to the database.

Properties

 | Name | Description
Public property | ConnectionState | The state of the connection to the database or the source file.
Public property | Delimiter |
Public property | Fields | The columns in the data source.
Public property | TableName | The database table or file path where the data resides.

See Also

CSVDataSet Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CSVDataSet Constructor

[image] [image]

IceLib Dialer Technical Reference
CSVDataSet Constructor
CSVDataSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CSVDataSet(String) | Creates a new instance of the CSVDataSet class.
Public method | CSVDataSet(String, Char) | Creates a new instance of the CSVDataSet class.
Public method | CSVDataSet(String, IEnumerable<(Of <<'(DBColumn>)>>)) | Creates a new instance of the CSVDataSet class representing a file that does not yet exist.
Public method | CSVDataSet(String, IEnumerable<(Of <<'(DBColumn>)>>), Char) | Creates a new instance of the CSVDataSet class representing a file that does not yet exist.

See Also

CSVDataSet Class
CSVDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CSVDataSet Constructor (String)

[image]

IceLib Dialer Technical Reference
CSVDataSet Constructor (String)
CSVDataSet Class See Also Send Feedback
Creates a new instance of the CSVDataSet class.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CSVDataSet(
    string filePath
)
Visual Basic
Public Sub New ( _
    filePath As String _
)

Parameters

filePath
Type: System..::..String
The full path to the file

See Also

CSVDataSet Class
CSVDataSet Members
CSVDataSet Overload
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CSVDataSet Constructor (String, Char)

[image]

IceLib Dialer Technical Reference
CSVDataSet Constructor (String, Char)
CSVDataSet Class See Also Send Feedback
Creates a new instance of the CSVDataSet class.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CSVDataSet(
    string filePath,
    char delimiter
)
Visual Basic
Public Sub New ( _
    filePath As String, _
    delimiter As Char _
)

Parameters

filePath
Type: System..::..String
The full path to the file
delimiter
Type: System..::..Char
character delimiter

See Also

CSVDataSet Class
CSVDataSet Members
CSVDataSet Overload
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CSVDataSet Constructor (String, IEnumerable(DBColumn))

[image]

IceLib Dialer Technical Reference
CSVDataSet Constructor (String, IEnumerable<(Of <(<'DBColumn>)>)>)
CSVDataSet Class See Also Send Feedback
Creates a new instance of the CSVDataSet class representing a file that does not yet exist.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CSVDataSet(
    string filePath,
    IEnumerable<DBColumn> fields
)
Visual Basic
Public Sub New ( _
    filePath As String, _
    fields As IEnumerable(Of DBColumn) _
)

Parameters

filePath
Type: System..::..String
The full path to the csv file.
fields
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' DBColumn >)>)>
The fields to create in the new file

See Also

CSVDataSet Class
CSVDataSet Members
CSVDataSet Overload
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CSVDataSet Constructor (String, IEnumerable(DBColumn), Char)

[image]

IceLib Dialer Technical Reference
CSVDataSet Constructor (String, IEnumerable<(Of <(<'DBColumn>)>)>, Char)
CSVDataSet Class See Also Send Feedback
Creates a new instance of the CSVDataSet class representing a file that does not yet exist.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CSVDataSet(
    string filePath,
    IEnumerable<DBColumn> fields,
    char delimiter
)
Visual Basic
Public Sub New ( _
    filePath As String, _
    fields As IEnumerable(Of DBColumn), _
    delimiter As Char _
)

Parameters

filePath
Type: System..::..String
The full path to the csv file.
fields
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' DBColumn >)>)>
The fields to create in the new file
delimiter
Type: System..::..Char
character delimiter

See Also

CSVDataSet Class
CSVDataSet Members
CSVDataSet Overload
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CSVDataSet Methods

[image] [image]

IceLib Dialer Technical Reference
CSVDataSet Methods
CSVDataSet Class See Also Send Feedback

The CSVDataSet type exposes the following members.

Methods

 | Name | Description
Public method | CloseConnection | Closes the connection to the database or, if the source is a file, closes the file. Ignored if connection is not open.
Public method | CommitTransaction | Ends a transaction by committing all changes.
Public method | CreateTable | Creates a new table in the database or a new file containing the fields in the Fields property.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenConnection | Opens the connection to the database or, if the source is a file, opens the file. Ignored if connection is already open.
Public method | RollbackTransaction | Ends a transaction by reverting all changes.
Public method | StartTransaction | Begins a transaction. Transactions must be ended by calling either CommitTransaction()()()() or RollbackTransaction()()()()
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteRecord | Writes a single record to the database.

See Also

CSVDataSet Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CloseConnection Method

[image]

IceLib Dialer Technical Reference
CSVDataSet..::..CloseConnection Method
CSVDataSet Class See Also Send Feedback
Closes the connection to the database or, if the source is a file, closes the file. Ignored if connection is not open.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void CloseConnection()
Visual Basic
Public Sub CloseConnection

Implements

IDataSet..::..CloseConnection()()()()

See Also

CSVDataSet Class
CSVDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CommitTransaction Method

[image]

IceLib Dialer Technical Reference
CSVDataSet..::..CommitTransaction Method
CSVDataSet Class See Also Send Feedback
Ends a transaction by committing all changes.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void CommitTransaction()
Visual Basic
Public Sub CommitTransaction

Implements

IDataSet..::..CommitTransaction()()()()

Exceptions

Exception | Condition
System..::..InvalidOperationException | The transaction has not started or the connection is broken.

See Also

CSVDataSet Class
CSVDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CreateTable Method

[image]

IceLib Dialer Technical Reference
CSVDataSet..::..CreateTable Method
CSVDataSet Class See Also Send Feedback
Creates a new table in the database or a new file containing the fields in the Fields property.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void CreateTable()
Visual Basic
Public Sub CreateTable

Implements

IDataSet..::..CreateTable()()()()

See Also

CSVDataSet Class
CSVDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


GetEnumerator Method

[image]

IceLib Dialer Technical Reference
CSVDataSet..::..GetEnumerator Method
CSVDataSet Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public IEnumerator<IDictionary<DBColumn, Object>> GetEnumerator()
Visual Basic
Public Function GetEnumerator As IEnumerator(Of IDictionary(Of DBColumn, Object))

Return Value

A IEnumerator<(Of <(<'T>)>)> that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

CSVDataSet Class
CSVDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


OpenConnection Method

[image]

IceLib Dialer Technical Reference
CSVDataSet..::..OpenConnection Method
CSVDataSet Class See Also Send Feedback
Opens the connection to the database or, if the source is a file, opens the file. Ignored if connection is already open.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void OpenConnection()
Visual Basic
Public Sub OpenConnection

Implements

IDataSet..::..OpenConnection()()()()

See Also

CSVDataSet Class
CSVDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


RollbackTransaction Method

[image]

IceLib Dialer Technical Reference
CSVDataSet..::..RollbackTransaction Method
CSVDataSet Class See Also Send Feedback
Ends a transaction by reverting all changes.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void RollbackTransaction()
Visual Basic
Public Sub RollbackTransaction

Implements

IDataSet..::..RollbackTransaction()()()()

Exceptions

Exception | Condition
System..::..InvalidOperationException | The transaction has not started or the connection is broken.

See Also

CSVDataSet Class
CSVDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


StartTransaction Method

[image]

IceLib Dialer Technical Reference
CSVDataSet..::..StartTransaction Method
CSVDataSet Class See Also Send Feedback
Begins a transaction. Transactions must be ended by calling either CommitTransaction()()()() or RollbackTransaction()()()()

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void StartTransaction()
Visual Basic
Public Sub StartTransaction

Implements

IDataSet..::..StartTransaction()()()()

Exceptions

Exception | Condition
System..::..InvalidOperationException | Nested transactions are not allowed.

See Also

CSVDataSet Class
CSVDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


WriteRecord Method

[image]

IceLib Dialer Technical Reference
CSVDataSet..::..WriteRecord Method
CSVDataSet Class See Also Send Feedback
Writes a single record to the database.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void WriteRecord(
    IDictionary<DBColumn, Object> record
)
Visual Basic
Public Sub WriteRecord ( _
    record As IDictionary(Of DBColumn, Object) _
)

Parameters

record
Type: System.Collections.Generic..::..IDictionary<(Of <(<' DBColumn, Object>)>)>
A record with fields mapped to values.

Implements

IDataSet..::..WriteRecord(IDictionary<(Of <<'(DBColumn, Object>)>>))

See Also

CSVDataSet Class
CSVDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CSVDataSet Properties

[image] [image]

IceLib Dialer Technical Reference
CSVDataSet Properties
CSVDataSet Class See Also Send Feedback

The CSVDataSet type exposes the following members.

Properties

 | Name | Description
Public property | ConnectionState | The state of the connection to the database or the source file.
Public property | Delimiter |
Public property | Fields | The columns in the data source.
Public property | TableName | The database table or file path where the data resides.

See Also

CSVDataSet Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ConnectionState Property

[image]

IceLib Dialer Technical Reference
CSVDataSet..::..ConnectionState Property
CSVDataSet Class See Also Send Feedback
The state of the connection to the database or the source file.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ConnectionState ConnectionState { get; }
Visual Basic
Public ReadOnly Property ConnectionState As ConnectionState
    Get

Implements

IDataSet..::..ConnectionState

See Also

CSVDataSet Class
CSVDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Delimiter Property

[image]

IceLib Dialer Technical Reference
CSVDataSet..::..Delimiter Property
CSVDataSet Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public char Delimiter { get; private set; }
Visual Basic
Public Property Delimiter As Char
    Get
    Private Set

See Also

CSVDataSet Class
CSVDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Fields Property

[image]

IceLib Dialer Technical Reference
CSVDataSet..::..Fields Property
CSVDataSet Class See Also Send Feedback
The columns in the data source.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public IList<DBColumn> Fields { get; private set; }
Visual Basic
Public Property Fields As IList(Of DBColumn)
    Get
    Private Set

Implements

IDataSet..::..Fields

See Also

CSVDataSet Class
CSVDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


TableName Property

[image]

IceLib Dialer Technical Reference
CSVDataSet..::..TableName Property
CSVDataSet Class See Also Send Feedback
The database table or file path where the data resides.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string TableName { get; private set; }
Visual Basic
Public Property TableName As String
    Get
    Private Set

Implements

IDataSet..::..TableName

See Also

CSVDataSet Class
CSVDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CSVDataSet.CSVDataSetEnumerator Class

[image]

IceLib Dialer Technical Reference
CSVDataSet..::..CSVDataSetEnumerator Class
CSVDataSet Class Members See Also Send Feedback
Supports all classes in the .NET Framework class hierarchy and provides low-level services to derived classes. This is the ultimate base class of all classes in the .NET Framework; it is the root of the type hierarchy.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class CSVDataSetEnumerator : IDataSetEnumerator,
    IEnumerator<IDictionary<DBColumn, Object>>, IDisposable,
    IEnumerator
Visual Basic
Public Class CSVDataSetEnumerator _
    Implements IDataSetEnumerator, IEnumerator(Of IDictionary(Of DBColumn, Object)),  _
    IDisposable, IEnumerator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer.DataTypes..::..CSVDataSet..::..CSVDataSetEnumerator

See Also

CSVDataSet..::..CSVDataSetEnumerator Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CSVDataSet.CSVDataSetEnumerator Members

[image] [image]

IceLib Dialer Technical Reference
CSVDataSet..::..CSVDataSetEnumerator Members
CSVDataSet..::..CSVDataSetEnumerator Class Constructors Methods Properties See Also Send Feedback

The CSVDataSet..::..CSVDataSetEnumerator type exposes the following members.

Constructors

 | Name | Description
Public method | CSVDataSet..::..CSVDataSetEnumerator | Initializes a new instance of the CSVDataSet..::..CSVDataSetEnumerator class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Advances the enumerator to the next element of the collection.
Public method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Gets the element in the collection at the current position of the enumerator.

See Also

CSVDataSet..::..CSVDataSetEnumerator Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CSVDataSet.CSVDataSetEnumerator Constructor

[image]

IceLib Dialer Technical Reference
CSVDataSet..::..CSVDataSetEnumerator Constructor
CSVDataSet..::..CSVDataSetEnumerator Class See Also Send Feedback
Initializes a new instance of the CSVDataSet..::..CSVDataSetEnumerator class

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CSVDataSetEnumerator(
    CSVDataSet dataSet
)
Visual Basic
Public Sub New ( _
    dataSet As CSVDataSet _
)

Parameters

dataSet
Type: ININ.IceLib.Configuration.Dialer.DataTypes..::..CSVDataSet

See Also

CSVDataSet..::..CSVDataSetEnumerator Class
CSVDataSet..::..CSVDataSetEnumerator Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CSVDataSet.CSVDataSetEnumerator Methods

[image] [image]

IceLib Dialer Technical Reference
CSVDataSet..::..CSVDataSetEnumerator Methods
CSVDataSet..::..CSVDataSetEnumerator Class See Also Send Feedback

The CSVDataSet..::..CSVDataSetEnumerator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Advances the enumerator to the next element of the collection.
Public method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CSVDataSet..::..CSVDataSetEnumerator Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


MoveNext Method

[image]

IceLib Dialer Technical Reference
CSVDataSet..::..CSVDataSetEnumerator..::..MoveNext Method
CSVDataSet..::..CSVDataSetEnumerator Class See Also Send Feedback
Advances the enumerator to the next element of the collection.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool MoveNext()
Visual Basic
Public Function MoveNext As Boolean

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Implements

IEnumerator..::..MoveNext()()()()

Exceptions

Exception | Condition
System..::..InvalidOperationException | The collection was modified after the enumerator was created.

See Also

CSVDataSet..::..CSVDataSetEnumerator Class
CSVDataSet..::..CSVDataSetEnumerator Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Reset Method

[image]

IceLib Dialer Technical Reference
CSVDataSet..::..CSVDataSetEnumerator..::..Reset Method
CSVDataSet..::..CSVDataSetEnumerator Class See Also Send Feedback
Sets the enumerator to its initial position, which is before the first element in the collection.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Implements

IEnumerator..::..Reset()()()()

Exceptions

Exception | Condition
System..::..InvalidOperationException | The collection was modified after the enumerator was created.

See Also

CSVDataSet..::..CSVDataSetEnumerator Class
CSVDataSet..::..CSVDataSetEnumerator Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CSVDataSet.CSVDataSetEnumerator Properties

[image] [image]

IceLib Dialer Technical Reference
CSVDataSet..::..CSVDataSetEnumerator Properties
CSVDataSet..::..CSVDataSetEnumerator Class See Also Send Feedback

The CSVDataSet..::..CSVDataSetEnumerator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Gets the element in the collection at the current position of the enumerator.

See Also

CSVDataSet..::..CSVDataSetEnumerator Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Current Property

[image]

IceLib Dialer Technical Reference
CSVDataSet..::..CSVDataSetEnumerator..::..Current Property
CSVDataSet..::..CSVDataSetEnumerator Class See Also Send Feedback
Gets the element in the collection at the current position of the enumerator.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public IDictionary<DBColumn, Object> Current { get; }
Visual Basic
Public ReadOnly Property Current As IDictionary(Of DBColumn, Object)
    Get

Return Value

The element in the collection at the current position of the enumerator.

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

See Also

CSVDataSet..::..CSVDataSetEnumerator Class
CSVDataSet..::..CSVDataSetEnumerator Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


DatabaseType Enumeration

[image]

IceLib Dialer Technical Reference
DatabaseType Enumeration
See Also Send Feedback
Supported database management systems.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum DatabaseType
Visual Basic
Public Enumeration DatabaseType

Members

Member name | Value | Description
MS_SQL_Server | 0 | Microsoft SQL Server
Oracle | 1 | Oracle

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


DBColumn Class

[image]

IceLib Dialer Technical Reference
DBColumn Class
Members See Also Send Feedback
A class representing a column in a database table.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class DBColumn
Visual Basic
Public NotInheritable Class DBColumn

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer.DataTypes..::..DBColumn

See Also

DBColumn Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


DBColumn Members

[image] [image]

IceLib Dialer Technical Reference
DBColumn Members
DBColumn Class Constructors Methods Properties See Also Send Feedback

The DBColumn type exposes the following members.

Constructors

 | Name | Description
Public method | DBColumn(String, OleDbType, Int32) | Creates a new instance of the DBColumn class. Scale and Precision are set to 0, so this overload is useful for string-type columns.
Public method | DBColumn(String, OleDbType, Int32, Int32, Int32) | Creates a new instance of the DBColumn class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DataType | The datatype of the column.
Public property | Name | The name of the column.
Public property | Precision | Numeric types only. The maximum number of digits.
Public property | Scale | Numeric types only. The maximum number of digits to the right of the decimal point.
Public property | Size | String and binary types only. The maximum number of characters/bytes.

See Also

DBColumn Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


DBColumn Constructor

[image] [image]

IceLib Dialer Technical Reference
DBColumn Constructor
DBColumn Class See Also Send Feedback

Overload List

 | Name | Description
Public method | DBColumn(String, OleDbType, Int32) | Creates a new instance of the DBColumn class. Scale and Precision are set to 0, so this overload is useful for string-type columns.
Public method | DBColumn(String, OleDbType, Int32, Int32, Int32) | Creates a new instance of the DBColumn class.

See Also

DBColumn Class
DBColumn Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


DBColumn Constructor (String, OleDbType, Int32)

[image]

IceLib Dialer Technical Reference
DBColumn Constructor (String, OleDbType, Int32)
DBColumn Class See Also Send Feedback
Creates a new instance of the DBColumn class. Scale and Precision are set to 0, so this overload is useful for string-type columns.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DBColumn(
    string _name,
    OleDbType _dataType,
    int _size
)
Visual Basic
Public Sub New ( _
    _name As String, _
    _dataType As OleDbType, _
    _size As Integer _
)

Parameters

_name
Type: System..::..String
_dataType
Type: System.Data.OleDb..::..OleDbType
_size
Type: System..::..Int32

See Also

DBColumn Class
DBColumn Members
DBColumn Overload
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


DBColumn Constructor (String, OleDbType, Int32, Int32, Int32)

[image]

IceLib Dialer Technical Reference
DBColumn Constructor (String, OleDbType, Int32, Int32, Int32)
DBColumn Class See Also Send Feedback
Creates a new instance of the DBColumn class.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DBColumn(
    string _name,
    OleDbType _dataType,
    int _size,
    int _scale,
    int _precision
)
Visual Basic
Public Sub New ( _
    _name As String, _
    _dataType As OleDbType, _
    _size As Integer, _
    _scale As Integer, _
    _precision As Integer _
)

Parameters

_name
Type: System..::..String
The name of the column.
_dataType
Type: System.Data.OleDb..::..OleDbType
The datatype of the column.
_size
Type: System..::..Int32
String and binary types only. The maximum number of characters/bytes.
_scale
Type: System..::..Int32
Numeric types only. The maximum number of digits to the right of the decimal point.
_precision
Type: System..::..Int32
Numeric types only. The maximum number of digits.

See Also

DBColumn Class
DBColumn Members
DBColumn Overload
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


DBColumn Methods

[image] [image]

IceLib Dialer Technical Reference
DBColumn Methods
DBColumn Class See Also Send Feedback

The DBColumn type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DBColumn Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


DBColumn Properties

[image] [image]

IceLib Dialer Technical Reference
DBColumn Properties
DBColumn Class See Also Send Feedback

The DBColumn type exposes the following members.

Properties

 | Name | Description
Public property | DataType | The datatype of the column.
Public property | Name | The name of the column.
Public property | Precision | Numeric types only. The maximum number of digits.
Public property | Scale | Numeric types only. The maximum number of digits to the right of the decimal point.
Public property | Size | String and binary types only. The maximum number of characters/bytes.

See Also

DBColumn Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


DataType Property

[image]

IceLib Dialer Technical Reference
DBColumn..::..DataType Property
DBColumn Class See Also Send Feedback
The datatype of the column.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public OleDbType DataType { get; private set; }
Visual Basic
Public Property DataType As OleDbType
    Get
    Private Set

See Also

DBColumn Class
DBColumn Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Name Property

[image]

IceLib Dialer Technical Reference
DBColumn..::..Name Property
DBColumn Class See Also Send Feedback
The name of the column.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Name { get; private set; }
Visual Basic
Public Property Name As String
    Get
    Private Set

See Also

DBColumn Class
DBColumn Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Precision Property

[image]

IceLib Dialer Technical Reference
DBColumn..::..Precision Property
DBColumn Class See Also Send Feedback
Numeric types only. The maximum number of digits.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int Precision { get; private set; }
Visual Basic
Public Property Precision As Integer
    Get
    Private Set

See Also

DBColumn Class
DBColumn Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Scale Property

[image]

IceLib Dialer Technical Reference
DBColumn..::..Scale Property
DBColumn Class See Also Send Feedback
Numeric types only. The maximum number of digits to the right of the decimal point.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int Scale { get; private set; }
Visual Basic
Public Property Scale As Integer
    Get
    Private Set

See Also

DBColumn Class
DBColumn Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Size Property

[image]

IceLib Dialer Technical Reference
DBColumn..::..Size Property
DBColumn Class See Also Send Feedback
String and binary types only. The maximum number of characters/bytes.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int Size { get; private set; }
Visual Basic
Public Property Size As Integer
    Get
    Private Set

See Also

DBColumn Class
DBColumn Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


DNCScrubQueryResult Enumeration

[image]

IceLib Dialer Technical Reference
DNCScrubQueryResult Enumeration
See Also Send Feedback
DNC Scrub Query Result Type

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum DNCScrubQueryResult
Visual Basic
Public Enumeration DNCScrubQueryResult

Members

Member name | Value | Description
UnknownFailure | -1 | Unknown Failure
Success | 0 | Success
DNCCOMNetworkFailure | 1 | DNC.Com Network Failure
DNCCOMAuthenticationFailure | 2 | DNC.Com Authentication Failure
DNCOMScrubbingFailure | 3 | DNC.Com Scrubbing Failure
DNCCOMFailure | 4 | DNC.Com Failure
DNCInternalFailure | 5 | Dialer Failure

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


DNCScrubResult Class

[image]

IceLib Dialer Technical Reference
DNCScrubResult Class
Members See Also Send Feedback
A class representing DNC Scrubbing result

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class DNCScrubResult
Visual Basic
Public Class DNCScrubResult

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer.DataTypes..::..DNCScrubResult

See Also

DNCScrubResult Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


DNCScrubResult Members

[image] [image]

IceLib Dialer Technical Reference
DNCScrubResult Members
DNCScrubResult Class Methods Properties See Also Send Feedback

The DNCScrubResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BlockedNumberCount | Blocked Number Count
Public property | CallingRestrictedNumberCount | Calling Restricted Number Count
Public property | DisconnectedNumberCount | Disconnected Number Count
Public property | DNCNumberCount | DNC Number Count
Public property | DNCQueryResult | DNC Scrubbing Query Result
Public property | DNCSourceType | DNC Scrubbing Source Type
Public property | InvalidNumberCount | Invalid Number Count
Public property | ProjectBlockedNumberCount | DNC Project Blocked Number Count
Public property | VoipNumberCount | Voip Number Count
Public property | WirelessNumberCount | Wireless Number Count

See Also

DNCScrubResult Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


DNCScrubResult Methods

[image] [image]

IceLib Dialer Technical Reference
DNCScrubResult Methods
DNCScrubResult Class See Also Send Feedback

The DNCScrubResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DNCScrubResult Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


DNCScrubResult Properties

[image] [image]

IceLib Dialer Technical Reference
DNCScrubResult Properties
DNCScrubResult Class See Also Send Feedback

The DNCScrubResult type exposes the following members.

Properties

 | Name | Description
Public property | BlockedNumberCount | Blocked Number Count
Public property | CallingRestrictedNumberCount | Calling Restricted Number Count
Public property | DisconnectedNumberCount | Disconnected Number Count
Public property | DNCNumberCount | DNC Number Count
Public property | DNCQueryResult | DNC Scrubbing Query Result
Public property | DNCSourceType | DNC Scrubbing Source Type
Public property | InvalidNumberCount | Invalid Number Count
Public property | ProjectBlockedNumberCount | DNC Project Blocked Number Count
Public property | VoipNumberCount | Voip Number Count
Public property | WirelessNumberCount | Wireless Number Count

See Also

DNCScrubResult Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


BlockedNumberCount Property

[image]

IceLib Dialer Technical Reference
DNCScrubResult..::..BlockedNumberCount Property
DNCScrubResult Class See Also Send Feedback
Blocked Number Count

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int BlockedNumberCount { get; private set; }
Visual Basic
Public Property BlockedNumberCount As Integer
    Get
    Private Set

See Also

DNCScrubResult Class
DNCScrubResult Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CallingRestrictedNumberCount Property

[image]

IceLib Dialer Technical Reference
DNCScrubResult..::..CallingRestrictedNumberCount Property
DNCScrubResult Class See Also Send Feedback
Calling Restricted Number Count

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int CallingRestrictedNumberCount { get; private set; }
Visual Basic
Public Property CallingRestrictedNumberCount As Integer
    Get
    Private Set

See Also

DNCScrubResult Class
DNCScrubResult Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


DisconnectedNumberCount Property

[image]

IceLib Dialer Technical Reference
DNCScrubResult..::..DisconnectedNumberCount Property
DNCScrubResult Class See Also Send Feedback
Disconnected Number Count

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int DisconnectedNumberCount { get; private set; }
Visual Basic
Public Property DisconnectedNumberCount As Integer
    Get
    Private Set

See Also

DNCScrubResult Class
DNCScrubResult Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


DNCNumberCount Property

[image]

IceLib Dialer Technical Reference
DNCScrubResult..::..DNCNumberCount Property
DNCScrubResult Class See Also Send Feedback
DNC Number Count

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int DNCNumberCount { get; private set; }
Visual Basic
Public Property DNCNumberCount As Integer
    Get
    Private Set

See Also

DNCScrubResult Class
DNCScrubResult Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


DNCQueryResult Property

[image]

IceLib Dialer Technical Reference
DNCScrubResult..::..DNCQueryResult Property
DNCScrubResult Class See Also Send Feedback
DNC Scrubbing Query Result

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DNCScrubQueryResult DNCQueryResult { get; private set; }
Visual Basic
Public Property DNCQueryResult As DNCScrubQueryResult
    Get
    Private Set

See Also

DNCScrubResult Class
DNCScrubResult Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


DNCSourceType Property

[image]

IceLib Dialer Technical Reference
DNCScrubResult..::..DNCSourceType Property
DNCScrubResult Class See Also Send Feedback
DNC Scrubbing Source Type

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DNCScrubSourceType DNCSourceType { get; private set; }
Visual Basic
Public Property DNCSourceType As DNCScrubSourceType
    Get
    Private Set

See Also

DNCScrubResult Class
DNCScrubResult Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


InvalidNumberCount Property

[image]

IceLib Dialer Technical Reference
DNCScrubResult..::..InvalidNumberCount Property
DNCScrubResult Class See Also Send Feedback
Invalid Number Count

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int InvalidNumberCount { get; private set; }
Visual Basic
Public Property InvalidNumberCount As Integer
    Get
    Private Set

See Also

DNCScrubResult Class
DNCScrubResult Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ProjectBlockedNumberCount Property

[image]

IceLib Dialer Technical Reference
DNCScrubResult..::..ProjectBlockedNumberCount Property
DNCScrubResult Class See Also Send Feedback
DNC Project Blocked Number Count

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int ProjectBlockedNumberCount { get; private set; }
Visual Basic
Public Property ProjectBlockedNumberCount As Integer
    Get
    Private Set

See Also

DNCScrubResult Class
DNCScrubResult Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


VoipNumberCount Property

[image]

IceLib Dialer Technical Reference
DNCScrubResult..::..VoipNumberCount Property
DNCScrubResult Class See Also Send Feedback
Voip Number Count

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int VoipNumberCount { get; private set; }
Visual Basic
Public Property VoipNumberCount As Integer
    Get
    Private Set

See Also

DNCScrubResult Class
DNCScrubResult Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


WirelessNumberCount Property

[image]

IceLib Dialer Technical Reference
DNCScrubResult..::..WirelessNumberCount Property
DNCScrubResult Class See Also Send Feedback
Wireless Number Count

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int WirelessNumberCount { get; private set; }
Visual Basic
Public Property WirelessNumberCount As Integer
    Get
    Private Set

See Also

DNCScrubResult Class
DNCScrubResult Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


DNCScrubSourceType Enumeration

[image]

IceLib Dialer Technical Reference
DNCScrubSourceType Enumeration
See Also Send Feedback
DNC Scrubbing Source

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum DNCScrubSourceType
Visual Basic
Public Enumeration DNCScrubSourceType

Members

Member name | Value | Description
DNCDOTCOM | 0 | DNC.Com Source
CUSTOM | 1 | Custom Source

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


DNCSourceCampaign Class

[image]

IceLib Dialer Technical Reference
DNCSourceCampaign Class
Members See Also Send Feedback
A class representing DNC.Com campaign

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class DNCSourceCampaign
Visual Basic
Public Class DNCSourceCampaign

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer.DataTypes..::..DNCSourceCampaign

See Also

DNCSourceCampaign Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


DNCSourceCampaign Members

[image] [image]

IceLib Dialer Technical Reference
DNCSourceCampaign Members
DNCSourceCampaign Class Constructors Methods Properties See Also Send Feedback

The DNCSourceCampaign type exposes the following members.

Constructors

 | Name | Description
Public method | DNCSourceCampaign | Creates a new instance of the DNCSourceCampaign class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CampaignId | The Id of the campaign.
Public property | CampaignName | The Name of the campaign.

See Also

DNCSourceCampaign Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


DNCSourceCampaign Constructor

[image]

IceLib Dialer Technical Reference
DNCSourceCampaign Constructor
DNCSourceCampaign Class See Also Send Feedback
Creates a new instance of the DNCSourceCampaign class.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DNCSourceCampaign(
    string campaignId,
    string campaignName
)
Visual Basic
Public Sub New ( _
    campaignId As String, _
    campaignName As String _
)

Parameters

campaignId
Type: System..::..String
campaignName
Type: System..::..String

See Also

DNCSourceCampaign Class
DNCSourceCampaign Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


DNCSourceCampaign Methods

[image] [image]

IceLib Dialer Technical Reference
DNCSourceCampaign Methods
DNCSourceCampaign Class See Also Send Feedback

The DNCSourceCampaign type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DNCSourceCampaign Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


DNCSourceCampaign Properties

[image] [image]

IceLib Dialer Technical Reference
DNCSourceCampaign Properties
DNCSourceCampaign Class See Also Send Feedback

The DNCSourceCampaign type exposes the following members.

Properties

 | Name | Description
Public property | CampaignId | The Id of the campaign.
Public property | CampaignName | The Name of the campaign.

See Also

DNCSourceCampaign Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CampaignId Property

[image]

IceLib Dialer Technical Reference
DNCSourceCampaign..::..CampaignId Property
DNCSourceCampaign Class See Also Send Feedback
The Id of the campaign.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string CampaignId { get; private set; }
Visual Basic
Public Property CampaignId As String
    Get
    Private Set

See Also

DNCSourceCampaign Class
DNCSourceCampaign Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CampaignName Property

[image]

IceLib Dialer Technical Reference
DNCSourceCampaign..::..CampaignName Property
DNCSourceCampaign Class See Also Send Feedback
The Name of the campaign.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string CampaignName { get; private set; }
Visual Basic
Public Property CampaignName As String
    Get
    Private Set

See Also

DNCSourceCampaign Class
DNCSourceCampaign Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


EventLogSeverity Enumeration

[image]

IceLib Dialer Technical Reference
EventLogSeverity Enumeration
See Also Send Feedback
Possible severity levels used in event log policy behaviors.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum EventLogSeverity
Visual Basic
Public Enumeration EventLogSeverity

Members

Member name | Value | Description
Error | 0 | Indicate that an error has occurred.
Warning | 1 | Indicate that a problematic condition has occurred.
Information | 2 | Offer some sort of important information.

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ExcelDataSet Class

[image]

IceLib Dialer Technical Reference
ExcelDataSet Class
Members See Also Send Feedback
An enumerable and appendable data source representing a Microsoft Excel spreadsheet.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class ExcelDataSet : OleDbDataSet
Visual Basic
Public Class ExcelDataSet _
    Inherits OleDbDataSet

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer.DataTypes..::..OleDbDataSet
ININ.IceLib.Configuration.Dialer.DataTypes..::..ExcelDataSet

See Also

ExcelDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ExcelDataSet Members

[image] [image]

IceLib Dialer Technical Reference
ExcelDataSet Members
ExcelDataSet Class Constructors Methods Properties See Also Send Feedback

The ExcelDataSet type exposes the following members.

Constructors

 | Name | Description
Public method | ExcelDataSet(String, String) | Creates a new instance of the ExcelDataSet class.
Public method | ExcelDataSet(String, String, IEnumerable<(Of <<'(DBColumn>)>>)) | Creates a new instance of the ExcelDataSet class representing a data set that does not yet exist

Methods

 | Name | Description
Public method | CloseConnection | Closes the connection to the database or, if the source is a file, closes the file. Ignored if connection is not open. (Inherited from OleDbDataSet.)
Public method | CommitTransaction | Ends a transaction by committing all changes. (Inherited from OleDbDataSet.)
Public method | CreateTable | Creates a new table in the database or a new file containing the fields in the Fields property. (Overrides OleDbDataSet..::..CreateTable()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Overrides OleDbDataSet..::..GetEnumerator()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenConnection | Opens the connection to the database or, if the source is a file, opens the file. Ignored if connection is already open. (Inherited from OleDbDataSet.)
Protected method | PrepareForWrite | Prepares the data set for one or more calls to WriteRecord(IDictionary<(Of <<'(DBColumn, Object>)>>)). (Inherited from OleDbDataSet.)
Public method | RollbackTransaction | Ends a transaction by reverting all changes. (Inherited from OleDbDataSet.)
Public method | StartTransaction | Begins a transaction. Transactions must be ended by calling either CommitTransaction()()()() or RollbackTransaction()()()() (Inherited from OleDbDataSet.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteRecord | Writes a single record to the database. (Inherited from OleDbDataSet.)

Properties

 | Name | Description
Public property | ConnectionState | The state of the connection to the database or the source file. (Inherited from OleDbDataSet.)
Protected property | DBMS | (Inherited from OleDbDataSet.)
Public property | Fields |
Public property | FilePath | The full file path to the spreadsheet.
Public property | TableName | The database table or file path where the data resides. (Inherited from OleDbDataSet.)

See Also

ExcelDataSet Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ExcelDataSet Constructor

[image] [image]

IceLib Dialer Technical Reference
ExcelDataSet Constructor
ExcelDataSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ExcelDataSet(String, String) | Creates a new instance of the ExcelDataSet class.
Public method | ExcelDataSet(String, String, IEnumerable<(Of <<'(DBColumn>)>>)) | Creates a new instance of the ExcelDataSet class representing a data set that does not yet exist

See Also

ExcelDataSet Class
ExcelDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ExcelDataSet Constructor (String, String)

[image]

IceLib Dialer Technical Reference
ExcelDataSet Constructor (String, String)
ExcelDataSet Class See Also Send Feedback
Creates a new instance of the ExcelDataSet class.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ExcelDataSet(
    string filePath,
    string worksheet
)
Visual Basic
Public Sub New ( _
    filePath As String, _
    worksheet As String _
)

Parameters

filePath
Type: System..::..String
The full file path to the spreadsheet
worksheet
Type: System..::..String
The worksheet containing the data

See Also

ExcelDataSet Class
ExcelDataSet Members
ExcelDataSet Overload
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ExcelDataSet Constructor (String, String, IEnumerable(DBColumn))

[image]

IceLib Dialer Technical Reference
ExcelDataSet Constructor (String, String, IEnumerable<(Of <(<'DBColumn>)>)>)
ExcelDataSet Class See Also Send Feedback
Creates a new instance of the ExcelDataSet class representing a data set that does not yet exist

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ExcelDataSet(
    string filePath,
    string worksheet,
    IEnumerable<DBColumn> fields
)
Visual Basic
Public Sub New ( _
    filePath As String, _
    worksheet As String, _
    fields As IEnumerable(Of DBColumn) _
)

Parameters

filePath
Type: System..::..String
The full file path of the spreadsheet
worksheet
Type: System..::..String
The name to give to the new worksheet
fields
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' DBColumn >)>)>
The fields to create in the new worksheet

See Also

ExcelDataSet Class
ExcelDataSet Members
ExcelDataSet Overload
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ExcelDataSet Methods

[image] [image]

IceLib Dialer Technical Reference
ExcelDataSet Methods
ExcelDataSet Class See Also Send Feedback

The ExcelDataSet type exposes the following members.

Methods

 | Name | Description
Public method | CloseConnection | Closes the connection to the database or, if the source is a file, closes the file. Ignored if connection is not open. (Inherited from OleDbDataSet.)
Public method | CommitTransaction | Ends a transaction by committing all changes. (Inherited from OleDbDataSet.)
Public method | CreateTable | Creates a new table in the database or a new file containing the fields in the Fields property. (Overrides OleDbDataSet..::..CreateTable()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Overrides OleDbDataSet..::..GetEnumerator()()()().)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenConnection | Opens the connection to the database or, if the source is a file, opens the file. Ignored if connection is already open. (Inherited from OleDbDataSet.)
Protected method | PrepareForWrite | Prepares the data set for one or more calls to WriteRecord(IDictionary<(Of <<'(DBColumn, Object>)>>)). (Inherited from OleDbDataSet.)
Public method | RollbackTransaction | Ends a transaction by reverting all changes. (Inherited from OleDbDataSet.)
Public method | StartTransaction | Begins a transaction. Transactions must be ended by calling either CommitTransaction()()()() or RollbackTransaction()()()() (Inherited from OleDbDataSet.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteRecord | Writes a single record to the database. (Inherited from OleDbDataSet.)

See Also

ExcelDataSet Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CreateTable Method

[image]

IceLib Dialer Technical Reference
ExcelDataSet..::..CreateTable Method
ExcelDataSet Class See Also Send Feedback
Creates a new table in the database or a new file containing the fields in the Fields property.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override void CreateTable()
Visual Basic
Public Overrides Sub CreateTable

Implements

IDataSet..::..CreateTable()()()()

See Also

ExcelDataSet Class
ExcelDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


GetEnumerator Method

[image]

IceLib Dialer Technical Reference
ExcelDataSet..::..GetEnumerator Method
ExcelDataSet Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override IEnumerator<IDictionary<DBColumn, Object>> GetEnumerator()
Visual Basic
Public Overrides Function GetEnumerator As IEnumerator(Of IDictionary(Of DBColumn, Object))

Return Value

A IEnumerator<(Of <(<'T>)>)> that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

ExcelDataSet Class
ExcelDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ExcelDataSet Properties

[image] [image]

IceLib Dialer Technical Reference
ExcelDataSet Properties
ExcelDataSet Class See Also Send Feedback

The ExcelDataSet type exposes the following members.

Properties

 | Name | Description
Public property | ConnectionState | The state of the connection to the database or the source file. (Inherited from OleDbDataSet.)
Protected property | DBMS | (Inherited from OleDbDataSet.)
Public property | Fields |
Public property | FilePath | The full file path to the spreadsheet.
Public property | TableName | The database table or file path where the data resides. (Inherited from OleDbDataSet.)

See Also

ExcelDataSet Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Fields Property

[image]

IceLib Dialer Technical Reference
ExcelDataSet..::..Fields Property
ExcelDataSet Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public IList<DBColumn> Fields { get; private set; }
Visual Basic
Public Property Fields As IList(Of DBColumn)
    Get
    Private Set

See Also

ExcelDataSet Class
ExcelDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


FilePath Property

[image]

IceLib Dialer Technical Reference
ExcelDataSet..::..FilePath Property
ExcelDataSet Class See Also Send Feedback
The full file path to the spreadsheet.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string FilePath { get; private set; }
Visual Basic
Public Property FilePath As String
    Get
    Private Set

See Also

ExcelDataSet Class
ExcelDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ExcelDataSet.ExcelDataSetEnumerator Class

[image]

IceLib Dialer Technical Reference
ExcelDataSet..::..ExcelDataSetEnumerator Class
ExcelDataSet Class Members See Also Send Feedback
Supports all classes in the .NET Framework class hierarchy and provides low-level services to derived classes. This is the ultimate base class of all classes in the .NET Framework; it is the root of the type hierarchy.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class ExcelDataSetEnumerator : IDataSetEnumerator,
    IEnumerator<IDictionary<DBColumn, Object>>, IDisposable,
    IEnumerator
Visual Basic
Public Class ExcelDataSetEnumerator _
    Implements IDataSetEnumerator, IEnumerator(Of IDictionary(Of DBColumn, Object)),  _
    IDisposable, IEnumerator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer.DataTypes..::..ExcelDataSet..::..ExcelDataSetEnumerator

See Also

ExcelDataSet..::..ExcelDataSetEnumerator Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ExcelDataSet.ExcelDataSetEnumerator Members

[image] [image]

IceLib Dialer Technical Reference
ExcelDataSet..::..ExcelDataSetEnumerator Members
ExcelDataSet..::..ExcelDataSetEnumerator Class Constructors Methods Properties See Also Send Feedback

The ExcelDataSet..::..ExcelDataSetEnumerator type exposes the following members.

Constructors

 | Name | Description
Public method | ExcelDataSet..::..ExcelDataSetEnumerator | Initializes a new instance of the ExcelDataSet..::..ExcelDataSetEnumerator class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Advances the enumerator to the next element of the collection.
Public method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Gets the element in the collection at the current position of the enumerator.

See Also

ExcelDataSet..::..ExcelDataSetEnumerator Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ExcelDataSet.ExcelDataSetEnumerator Constructor

[image]

IceLib Dialer Technical Reference
ExcelDataSet..::..ExcelDataSetEnumerator Constructor
ExcelDataSet..::..ExcelDataSetEnumerator Class See Also Send Feedback
Initializes a new instance of the ExcelDataSet..::..ExcelDataSetEnumerator class

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ExcelDataSetEnumerator(
    ExcelDataSet dataSet
)
Visual Basic
Public Sub New ( _
    dataSet As ExcelDataSet _
)

Parameters

dataSet
Type: ININ.IceLib.Configuration.Dialer.DataTypes..::..ExcelDataSet

See Also

ExcelDataSet..::..ExcelDataSetEnumerator Class
ExcelDataSet..::..ExcelDataSetEnumerator Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ExcelDataSet.ExcelDataSetEnumerator Methods

[image] [image]

IceLib Dialer Technical Reference
ExcelDataSet..::..ExcelDataSetEnumerator Methods
ExcelDataSet..::..ExcelDataSetEnumerator Class See Also Send Feedback

The ExcelDataSet..::..ExcelDataSetEnumerator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Advances the enumerator to the next element of the collection.
Public method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ExcelDataSet..::..ExcelDataSetEnumerator Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


MoveNext Method

[image]

IceLib Dialer Technical Reference
ExcelDataSet..::..ExcelDataSetEnumerator..::..MoveNext Method
ExcelDataSet..::..ExcelDataSetEnumerator Class See Also Send Feedback
Advances the enumerator to the next element of the collection.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool MoveNext()
Visual Basic
Public Function MoveNext As Boolean

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Implements

IEnumerator..::..MoveNext()()()()

Exceptions

Exception | Condition
System..::..InvalidOperationException | The collection was modified after the enumerator was created.

See Also

ExcelDataSet..::..ExcelDataSetEnumerator Class
ExcelDataSet..::..ExcelDataSetEnumerator Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Reset Method

[image]

IceLib Dialer Technical Reference
ExcelDataSet..::..ExcelDataSetEnumerator..::..Reset Method
ExcelDataSet..::..ExcelDataSetEnumerator Class See Also Send Feedback
Sets the enumerator to its initial position, which is before the first element in the collection.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Implements

IEnumerator..::..Reset()()()()

Exceptions

Exception | Condition
System..::..InvalidOperationException | The collection was modified after the enumerator was created.

See Also

ExcelDataSet..::..ExcelDataSetEnumerator Class
ExcelDataSet..::..ExcelDataSetEnumerator Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ExcelDataSet.ExcelDataSetEnumerator Properties

[image] [image]

IceLib Dialer Technical Reference
ExcelDataSet..::..ExcelDataSetEnumerator Properties
ExcelDataSet..::..ExcelDataSetEnumerator Class See Also Send Feedback

The ExcelDataSet..::..ExcelDataSetEnumerator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Gets the element in the collection at the current position of the enumerator.

See Also

ExcelDataSet..::..ExcelDataSetEnumerator Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Current Property

[image]

IceLib Dialer Technical Reference
ExcelDataSet..::..ExcelDataSetEnumerator..::..Current Property
ExcelDataSet..::..ExcelDataSetEnumerator Class See Also Send Feedback
Gets the element in the collection at the current position of the enumerator.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public IDictionary<DBColumn, Object> Current { get; }
Visual Basic
Public ReadOnly Property Current As IDictionary(Of DBColumn, Object)
    Get

Return Value

The element in the collection at the current position of the enumerator.

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

See Also

ExcelDataSet..::..ExcelDataSetEnumerator Class
ExcelDataSet..::..ExcelDataSetEnumerator Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


IDataSet Interface

[image]

IceLib Dialer Technical Reference
IDataSet Interface
Members See Also Send Feedback
Represents an enumerable and appendable data source not accessible from any Dialer connections.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public interface IDataSet : IEnumerable<IDictionary<DBColumn, Object>>,
    IEnumerable, IDisposable
Visual Basic
Public Interface IDataSet _
    Inherits IEnumerable(Of IDictionary(Of DBColumn, Object)),  _
    IEnumerable, IDisposable

See Also

IDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


IDataSet Members

[image] [image]

IceLib Dialer Technical Reference
IDataSet Members
IDataSet Interface Methods Properties See Also Send Feedback

The IDataSet type exposes the following members.

Methods

 | Name | Description
Public method | CloseConnection | Closes the connection to the database or, if the source is a file, closes the file. Ignored if connection is not open.
Public method | CommitTransaction | Ends a transaction by committing all changes.
Public method | CreateTable | Creates a new table in the database or a new file containing the fields in the Fields property.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetEnumerator()()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <(<'IDictionary<(Of <(<' DBColumn, Object>)>)>>)>)>.)
Public method | GetEnumerator()()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | OpenConnection | Opens the connection to the database or, if the source is a file, opens the file. Ignored if connection is already open.
Public method | RollbackTransaction | Ends a transaction by reverting all changes.
Public method | StartTransaction | Begins a transaction. Transactions must be ended by calling either CommitTransaction()()()() or RollbackTransaction()()()()
Public method | WriteRecord | Writes a single record to the database.

Properties

 | Name | Description
Public property | ConnectionState | The state of the connection to the database or the source file.
Public property | Fields | The columns in the data source.
Public property | TableName | The database table or file path where the data resides.

See Also

IDataSet Interface
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


IDataSet Methods

[image] [image]

IceLib Dialer Technical Reference
IDataSet Methods
IDataSet Interface See Also Send Feedback

The IDataSet type exposes the following members.

Methods

 | Name | Description
Public method | CloseConnection | Closes the connection to the database or, if the source is a file, closes the file. Ignored if connection is not open.
Public method | CommitTransaction | Ends a transaction by committing all changes.
Public method | CreateTable | Creates a new table in the database or a new file containing the fields in the Fields property.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetEnumerator()()()() | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable<(Of <(<'IDictionary<(Of <(<' DBColumn, Object>)>)>>)>)>.)
Public method | GetEnumerator()()()() | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | OpenConnection | Opens the connection to the database or, if the source is a file, opens the file. Ignored if connection is already open.
Public method | RollbackTransaction | Ends a transaction by reverting all changes.
Public method | StartTransaction | Begins a transaction. Transactions must be ended by calling either CommitTransaction()()()() or RollbackTransaction()()()()
Public method | WriteRecord | Writes a single record to the database.

See Also

IDataSet Interface
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CloseConnection Method

[image]

IceLib Dialer Technical Reference
IDataSet..::..CloseConnection Method
IDataSet Interface See Also Send Feedback
Closes the connection to the database or, if the source is a file, closes the file. Ignored if connection is not open.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
void CloseConnection()
Visual Basic
Sub CloseConnection

See Also

IDataSet Interface
IDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CommitTransaction Method

[image]

IceLib Dialer Technical Reference
IDataSet..::..CommitTransaction Method
IDataSet Interface See Also Send Feedback
Ends a transaction by committing all changes.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
void CommitTransaction()
Visual Basic
Sub CommitTransaction

Exceptions

Exception | Condition
System..::..InvalidOperationException | The transaction has not started or the connection is broken.

See Also

IDataSet Interface
IDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CreateTable Method

[image]

IceLib Dialer Technical Reference
IDataSet..::..CreateTable Method
IDataSet Interface See Also Send Feedback
Creates a new table in the database or a new file containing the fields in the Fields property.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
void CreateTable()
Visual Basic
Sub CreateTable

See Also

IDataSet Interface
IDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


OpenConnection Method

[image]

IceLib Dialer Technical Reference
IDataSet..::..OpenConnection Method
IDataSet Interface See Also Send Feedback
Opens the connection to the database or, if the source is a file, opens the file. Ignored if connection is already open.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
void OpenConnection()
Visual Basic
Sub OpenConnection

See Also

IDataSet Interface
IDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


RollbackTransaction Method

[image]

IceLib Dialer Technical Reference
IDataSet..::..RollbackTransaction Method
IDataSet Interface See Also Send Feedback
Ends a transaction by reverting all changes.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
void RollbackTransaction()
Visual Basic
Sub RollbackTransaction

Exceptions

Exception | Condition
System..::..InvalidOperationException | The transaction has not started or the connection is broken.

See Also

IDataSet Interface
IDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


StartTransaction Method

[image]

IceLib Dialer Technical Reference
IDataSet..::..StartTransaction Method
IDataSet Interface See Also Send Feedback
Begins a transaction. Transactions must be ended by calling either CommitTransaction()()()() or RollbackTransaction()()()()

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
void StartTransaction()
Visual Basic
Sub StartTransaction

Exceptions

Exception | Condition
System..::..InvalidOperationException | Nested transactions are not allowed.

See Also

IDataSet Interface
IDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


WriteRecord Method

[image]

IceLib Dialer Technical Reference
IDataSet..::..WriteRecord Method
IDataSet Interface See Also Send Feedback
Writes a single record to the database.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
void WriteRecord(
    IDictionary<DBColumn, Object> record
)
Visual Basic
Sub WriteRecord ( _
    record As IDictionary(Of DBColumn, Object) _
)

Parameters

record
Type: System.Collections.Generic..::..IDictionary<(Of <(<' DBColumn, Object>)>)>
A record with fields mapped to values.

See Also

IDataSet Interface
IDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


IDataSet Properties

[image] [image]

IceLib Dialer Technical Reference
IDataSet Properties
IDataSet Interface See Also Send Feedback

The IDataSet type exposes the following members.

Properties

 | Name | Description
Public property | ConnectionState | The state of the connection to the database or the source file.
Public property | Fields | The columns in the data source.
Public property | TableName | The database table or file path where the data resides.

See Also

IDataSet Interface
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ConnectionState Property

[image]

IceLib Dialer Technical Reference
IDataSet..::..ConnectionState Property
IDataSet Interface See Also Send Feedback
The state of the connection to the database or the source file.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
ConnectionState ConnectionState { get; }
Visual Basic
ReadOnly Property ConnectionState As ConnectionState
    Get

See Also

IDataSet Interface
IDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Fields Property

[image]

IceLib Dialer Technical Reference
IDataSet..::..Fields Property
IDataSet Interface See Also Send Feedback
The columns in the data source.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
IList<DBColumn> Fields { get; }
Visual Basic
ReadOnly Property Fields As IList(Of DBColumn)
    Get

See Also

IDataSet Interface
IDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


TableName Property

[image]

IceLib Dialer Technical Reference
IDataSet..::..TableName Property
IDataSet Interface See Also Send Feedback
The database table or file path where the data resides.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
string TableName { get; }
Visual Basic
ReadOnly Property TableName As String
    Get

See Also

IDataSet Interface
IDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


IDataSetEnumerator Interface

[image]

IceLib Dialer Technical Reference
IDataSetEnumerator Interface
Members See Also Send Feedback
Supports iteration of records in a dataset.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public interface IDataSetEnumerator : IEnumerator<IDictionary<DBColumn, Object>>,
    IDisposable, IEnumerator
Visual Basic
Public Interface IDataSetEnumerator _
    Inherits IEnumerator(Of IDictionary(Of DBColumn, Object)),  _
    IDisposable, IEnumerator

See Also

IDataSetEnumerator Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


IDataSetEnumerator Members

[image] [image]

IceLib Dialer Technical Reference
IDataSetEnumerator Members
IDataSetEnumerator Interface Methods See Also Send Feedback

The IDataSetEnumerator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | MoveNext | Advances the enumerator to the next element of the collection. (Inherited from IEnumerator.)
Public method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection. (Inherited from IEnumerator.)

Properties

 | Name | Description
Public property | Current | Gets the element in the collection at the current position of the enumerator. (Inherited from IEnumerator<(Of <(<'IDictionary<(Of <(<' DBColumn, Object>)>)>>)>)>.)
Public property | Current | Gets the current element in the collection. (Inherited from IEnumerator.)

See Also

IDataSetEnumerator Interface
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


IDataSetEnumerator Methods

[image] [image]

IceLib Dialer Technical Reference
IDataSetEnumerator Methods
IDataSetEnumerator Interface See Also Send Feedback

The IDataSetEnumerator type exposes the following members.

Methods

 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | MoveNext | Advances the enumerator to the next element of the collection. (Inherited from IEnumerator.)
Public method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection. (Inherited from IEnumerator.)

See Also

IDataSetEnumerator Interface
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


IDataSetEnumerator Properties

[image] [image]

IceLib Dialer Technical Reference
IDataSetEnumerator Properties
IDataSetEnumerator Interface See Also Send Feedback

Properties

 | Name | Description
Public property | Current | Gets the element in the collection at the current position of the enumerator. (Inherited from IEnumerator<(Of <(<'IDictionary<(Of <(<' DBColumn, Object>)>)>>)>)>.)
Public property | Current | Gets the current element in the collection. (Inherited from IEnumerator.)

See Also

IDataSetEnumerator Interface
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


InboundWorkgroup Class

[image]

IceLib Dialer Technical Reference
InboundWorkgroup Class
Members See Also Send Feedback
A class representing inbound call limits for a particular workgroup.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class InboundWorkgroup : IDeepCloneable
Visual Basic
Public Class InboundWorkgroup _
    Implements IDeepCloneable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer.DataTypes..::..InboundWorkgroup

See Also

InboundWorkgroup Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


InboundWorkgroup Members

[image] [image]

IceLib Dialer Technical Reference
InboundWorkgroup Members
InboundWorkgroup Class Constructors Methods Properties See Also Send Feedback

The InboundWorkgroup type exposes the following members.

Constructors

 | Name | Description
Public method | InboundWorkgroup | Creates a new instance of the InboundWorkgroup class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | LowerLimit | When the total number of inbound waiting calls drops below this value, the server will resume making predictions.
Public property | UpperLimit | When the number of inbound waiting calls exceeds this value, the server will stop making predictions.
Public property | Workgroup | The Id of the Workgroup.

See Also

InboundWorkgroup Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


InboundWorkgroup Constructor

[image]

IceLib Dialer Technical Reference
InboundWorkgroup Constructor
InboundWorkgroup Class See Also Send Feedback
Creates a new instance of the InboundWorkgroup class.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public InboundWorkgroup(
    ConfigurationId workgroup,
    uint lowerLimit,
    uint upperLimit
)
Visual Basic
Public Sub New ( _
    workgroup As ConfigurationId, _
    lowerLimit As UInteger, _
    upperLimit As UInteger _
)

Parameters

workgroup
Type: ConfigurationId
The Id of the workgroup.
lowerLimit
Type: System..::..UInt32
The lower threshold for waiting calls.
upperLimit
Type: System..::..UInt32
The upper threshold for waiting calls.

See Also

InboundWorkgroup Class
InboundWorkgroup Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


InboundWorkgroup Methods

[image] [image]

IceLib Dialer Technical Reference
InboundWorkgroup Methods
InboundWorkgroup Class See Also Send Feedback

The InboundWorkgroup type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

InboundWorkgroup Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


InboundWorkgroup Properties

[image] [image]

IceLib Dialer Technical Reference
InboundWorkgroup Properties
InboundWorkgroup Class See Also Send Feedback

The InboundWorkgroup type exposes the following members.

Properties

 | Name | Description
Public property | LowerLimit | When the total number of inbound waiting calls drops below this value, the server will resume making predictions.
Public property | UpperLimit | When the number of inbound waiting calls exceeds this value, the server will stop making predictions.
Public property | Workgroup | The Id of the Workgroup.

See Also

InboundWorkgroup Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


LowerLimit Property

[image]

IceLib Dialer Technical Reference
InboundWorkgroup..::..LowerLimit Property
InboundWorkgroup Class See Also Send Feedback
When the total number of inbound waiting calls drops below this value, the server will resume making predictions.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public uint LowerLimit { get; set; }
Visual Basic
Public Property LowerLimit As UInteger
    Get
    Set

See Also

InboundWorkgroup Class
InboundWorkgroup Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


UpperLimit Property

[image]

IceLib Dialer Technical Reference
InboundWorkgroup..::..UpperLimit Property
InboundWorkgroup Class See Also Send Feedback
When the number of inbound waiting calls exceeds this value, the server will stop making predictions.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public uint UpperLimit { get; set; }
Visual Basic
Public Property UpperLimit As UInteger
    Get
    Set

See Also

InboundWorkgroup Class
InboundWorkgroup Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Workgroup Property

[image]

IceLib Dialer Technical Reference
InboundWorkgroup..::..Workgroup Property
InboundWorkgroup Class See Also Send Feedback
The Id of the Workgroup.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ConfigurationId Workgroup { get; set; }
Visual Basic
Public Property Workgroup As ConfigurationId
    Get
    Set

See Also

InboundWorkgroup Class
InboundWorkgroup Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


MaxDailyAttemptType Enumeration

[image]

IceLib Dialer Technical Reference
MaxDailyAttemptType Enumeration
See Also Send Feedback
Determines How the Max Daily Attempts property should be implemented.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum MaxDailyAttemptType
Visual Basic
Public Enumeration MaxDailyAttemptType

Members

Member name | Value | Description
ByRecord | 0 |
ByNumber | 1 |

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


OleDbDataSet Class

[image]

IceLib Dialer Technical Reference
OleDbDataSet Class
Members See Also Send Feedback
An enumerable data source accessed using the .NET Framework Data Provider for OLE DB.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public abstract class OleDbDataSet : IDataSet,
    IEnumerable<IDictionary<DBColumn, Object>>, IEnumerable,
    IDisposable
Visual Basic
Public MustInherit Class OleDbDataSet _
    Implements IDataSet, IEnumerable(Of IDictionary(Of DBColumn, Object)),  _
    IEnumerable, IDisposable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer.DataTypes..::..OleDbDataSet
ININ.IceLib.Configuration.Dialer.DataTypes..::..AccessDataSet
ININ.IceLib.Configuration.Dialer.DataTypes..::..ExcelDataSet
ININ.IceLib.Configuration.Dialer.DataTypes..::..OracleDataSet
ININ.IceLib.Configuration.Dialer.DataTypes..::..SQLServerDataSet

See Also

OleDbDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


OleDbDataSet Members

[image] [image]

IceLib Dialer Technical Reference
OleDbDataSet Members
OleDbDataSet Class Constructors Methods Properties See Also Send Feedback

The OleDbDataSet type exposes the following members.

Constructors

 | Name | Description
Public method | OleDbDataSet | Constructs a new instance of the OleDbDataSet class.

Methods

 | Name | Description
Public method | CloseConnection | Closes the connection to the database or, if the source is a file, closes the file. Ignored if connection is not open.
Public method | CommitTransaction | Ends a transaction by committing all changes.
Public method | CreateTable | Creates a new table in the database or a new file containing the fields in the Fields property.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenConnection | Opens the connection to the database or, if the source is a file, opens the file. Ignored if connection is already open.
Protected method | PrepareForWrite | Prepares the data set for one or more calls to WriteRecord(IDictionary<(Of <<'(DBColumn, Object>)>>)).
Public method | RollbackTransaction | Ends a transaction by reverting all changes.
Public method | StartTransaction | Begins a transaction. Transactions must be ended by calling either CommitTransaction()()()() or RollbackTransaction()()()()
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteRecord | Writes a single record to the database.

Properties

 | Name | Description
Public property | ConnectionState | The state of the connection to the database or the source file.
Protected property | DBMS |
Public property | Fields | The columns in the data source.
Public property | TableName | The database table or file path where the data resides.

See Also

OleDbDataSet Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


OleDbDataSet Constructor

[image]

IceLib Dialer Technical Reference
OleDbDataSet Constructor
OleDbDataSet Class See Also Send Feedback
Constructs a new instance of the OleDbDataSet class.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public OleDbDataSet()
Visual Basic
Public Sub New

See Also

OleDbDataSet Class
OleDbDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


OleDbDataSet Methods

[image] [image]

IceLib Dialer Technical Reference
OleDbDataSet Methods
OleDbDataSet Class See Also Send Feedback

The OleDbDataSet type exposes the following members.

Methods

 | Name | Description
Public method | CloseConnection | Closes the connection to the database or, if the source is a file, closes the file. Ignored if connection is not open.
Public method | CommitTransaction | Ends a transaction by committing all changes.
Public method | CreateTable | Creates a new table in the database or a new file containing the fields in the Fields property.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenConnection | Opens the connection to the database or, if the source is a file, opens the file. Ignored if connection is already open.
Protected method | PrepareForWrite | Prepares the data set for one or more calls to WriteRecord(IDictionary<(Of <<'(DBColumn, Object>)>>)).
Public method | RollbackTransaction | Ends a transaction by reverting all changes.
Public method | StartTransaction | Begins a transaction. Transactions must be ended by calling either CommitTransaction()()()() or RollbackTransaction()()()()
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteRecord | Writes a single record to the database.

See Also

OleDbDataSet Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CloseConnection Method

[image]

IceLib Dialer Technical Reference
OleDbDataSet..::..CloseConnection Method
OleDbDataSet Class See Also Send Feedback
Closes the connection to the database or, if the source is a file, closes the file. Ignored if connection is not open.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void CloseConnection()
Visual Basic
Public Sub CloseConnection

Implements

IDataSet..::..CloseConnection()()()()

See Also

OleDbDataSet Class
OleDbDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CommitTransaction Method

[image]

IceLib Dialer Technical Reference
OleDbDataSet..::..CommitTransaction Method
OleDbDataSet Class See Also Send Feedback
Ends a transaction by committing all changes.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void CommitTransaction()
Visual Basic
Public Sub CommitTransaction

Implements

IDataSet..::..CommitTransaction()()()()

Exceptions

Exception | Condition
System..::..InvalidOperationException | The transaction has not started or the connection is broken.

See Also

OleDbDataSet Class
OleDbDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CreateTable Method

[image]

IceLib Dialer Technical Reference
OleDbDataSet..::..CreateTable Method
OleDbDataSet Class See Also Send Feedback
Creates a new table in the database or a new file containing the fields in the Fields property.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public virtual void CreateTable()
Visual Basic
Public Overridable Sub CreateTable

Implements

IDataSet..::..CreateTable()()()()

See Also

OleDbDataSet Class
OleDbDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


GetEnumerator Method

[image]

IceLib Dialer Technical Reference
OleDbDataSet..::..GetEnumerator Method
OleDbDataSet Class See Also Send Feedback
Returns an enumerator that iterates through the collection.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public virtual IEnumerator<IDictionary<DBColumn, Object>> GetEnumerator()
Visual Basic
Public Overridable Function GetEnumerator As IEnumerator(Of IDictionary(Of DBColumn, Object))

Return Value

A IEnumerator<(Of <(<'T>)>)> that can be used to iterate through the collection.

Implements

IEnumerable<(Of <(<'T>)>)>..::..GetEnumerator()()()()

See Also

OleDbDataSet Class
OleDbDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


OpenConnection Method

[image]

IceLib Dialer Technical Reference
OleDbDataSet..::..OpenConnection Method
OleDbDataSet Class See Also Send Feedback
Opens the connection to the database or, if the source is a file, opens the file. Ignored if connection is already open.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void OpenConnection()
Visual Basic
Public Sub OpenConnection

Implements

IDataSet..::..OpenConnection()()()()

See Also

OleDbDataSet Class
OleDbDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


PrepareForWrite Method

[image]

IceLib Dialer Technical Reference
OleDbDataSet..::..PrepareForWrite Method
OleDbDataSet Class See Also Send Feedback
Prepares the data set for one or more calls to WriteRecord(IDictionary<(Of <<'(DBColumn, Object>)>>)).

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
protected virtual void PrepareForWrite()
Visual Basic
Protected Overridable Sub PrepareForWrite

See Also

OleDbDataSet Class
OleDbDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


RollbackTransaction Method

[image]

IceLib Dialer Technical Reference
OleDbDataSet..::..RollbackTransaction Method
OleDbDataSet Class See Also Send Feedback
Ends a transaction by reverting all changes.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void RollbackTransaction()
Visual Basic
Public Sub RollbackTransaction

Implements

IDataSet..::..RollbackTransaction()()()()

Exceptions

Exception | Condition
System..::..InvalidOperationException | The transaction has not started or the connection is broken.

See Also

OleDbDataSet Class
OleDbDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


StartTransaction Method

[image]

IceLib Dialer Technical Reference
OleDbDataSet..::..StartTransaction Method
OleDbDataSet Class See Also Send Feedback
Begins a transaction. Transactions must be ended by calling either CommitTransaction()()()() or RollbackTransaction()()()()

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void StartTransaction()
Visual Basic
Public Sub StartTransaction

Implements

IDataSet..::..StartTransaction()()()()

Exceptions

Exception | Condition
System..::..InvalidOperationException | Nested transactions are not allowed.

See Also

OleDbDataSet Class
OleDbDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


WriteRecord Method

[image]

IceLib Dialer Technical Reference
OleDbDataSet..::..WriteRecord Method
OleDbDataSet Class See Also Send Feedback
Writes a single record to the database.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void WriteRecord(
    IDictionary<DBColumn, Object> record
)
Visual Basic
Public Sub WriteRecord ( _
    record As IDictionary(Of DBColumn, Object) _
)

Parameters

record
Type: System.Collections.Generic..::..IDictionary<(Of <(<' DBColumn, Object>)>)>
A record with fields mapped to values.

Implements

IDataSet..::..WriteRecord(IDictionary<(Of <<'(DBColumn, Object>)>>))

See Also

OleDbDataSet Class
OleDbDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


OleDbDataSet Properties

[image] [image]

IceLib Dialer Technical Reference
OleDbDataSet Properties
OleDbDataSet Class See Also Send Feedback

The OleDbDataSet type exposes the following members.

Properties

 | Name | Description
Public property | ConnectionState | The state of the connection to the database or the source file.
Protected property | DBMS |
Public property | Fields | The columns in the data source.
Public property | TableName | The database table or file path where the data resides.

See Also

OleDbDataSet Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ConnectionState Property

[image]

IceLib Dialer Technical Reference
OleDbDataSet..::..ConnectionState Property
OleDbDataSet Class See Also Send Feedback
The state of the connection to the database or the source file.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ConnectionState ConnectionState { get; }
Visual Basic
Public ReadOnly Property ConnectionState As ConnectionState
    Get

Implements

IDataSet..::..ConnectionState

See Also

OleDbDataSet Class
OleDbDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


DBMS Property

[image]

IceLib Dialer Technical Reference
OleDbDataSet..::..DBMS Property
OleDbDataSet Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
protected virtual DatabaseType DBMS { get; }
Visual Basic
Protected Overridable ReadOnly Property DBMS As DatabaseType
    Get

See Also

OleDbDataSet Class
OleDbDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Fields Property

[image]

IceLib Dialer Technical Reference
OleDbDataSet..::..Fields Property
OleDbDataSet Class See Also Send Feedback
The columns in the data source.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public IList<DBColumn> Fields { get; protected set; }
Visual Basic
Public Property Fields As IList(Of DBColumn)
    Get
    Protected Set

Implements

IDataSet..::..Fields

See Also

OleDbDataSet Class
OleDbDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


TableName Property

[image]

IceLib Dialer Technical Reference
OleDbDataSet..::..TableName Property
OleDbDataSet Class See Also Send Feedback
The database table or file path where the data resides.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string TableName { get; protected set; }
Visual Basic
Public Property TableName As String
    Get
    Protected Set

Implements

IDataSet..::..TableName

See Also

OleDbDataSet Class
OleDbDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


OleDbDataSet.OleDbDataSetEnumerator Class

[image]

IceLib Dialer Technical Reference
OleDbDataSet..::..OleDbDataSetEnumerator Class
OleDbDataSet Class Members See Also Send Feedback
Supports all classes in the .NET Framework class hierarchy and provides low-level services to derived classes. This is the ultimate base class of all classes in the .NET Framework; it is the root of the type hierarchy.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class OleDbDataSetEnumerator : IDataSetEnumerator,
    IEnumerator<IDictionary<DBColumn, Object>>, IDisposable,
    IEnumerator
Visual Basic
Public Class OleDbDataSetEnumerator _
    Implements IDataSetEnumerator, IEnumerator(Of IDictionary(Of DBColumn, Object)),  _
    IDisposable, IEnumerator

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer.DataTypes..::..OleDbDataSet..::..OleDbDataSetEnumerator

See Also

OleDbDataSet..::..OleDbDataSetEnumerator Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


OleDbDataSet.OleDbDataSetEnumerator Members

[image] [image]

IceLib Dialer Technical Reference
OleDbDataSet..::..OleDbDataSetEnumerator Members
OleDbDataSet..::..OleDbDataSetEnumerator Class Constructors Methods Properties See Also Send Feedback

The OleDbDataSet..::..OleDbDataSetEnumerator type exposes the following members.

Constructors

 | Name | Description
Public method | OleDbDataSet..::..OleDbDataSetEnumerator | Initializes a new instance of the OleDbDataSet..::..OleDbDataSetEnumerator class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Advances the enumerator to the next element of the collection.
Public method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Current | Gets the element in the collection at the current position of the enumerator.

See Also

OleDbDataSet..::..OleDbDataSetEnumerator Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


OleDbDataSet.OleDbDataSetEnumerator Constructor

[image]

IceLib Dialer Technical Reference
OleDbDataSet..::..OleDbDataSetEnumerator Constructor
OleDbDataSet..::..OleDbDataSetEnumerator Class See Also Send Feedback
Initializes a new instance of the OleDbDataSet..::..OleDbDataSetEnumerator class

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public OleDbDataSetEnumerator(
    OleDbDataSet dataSet
)
Visual Basic
Public Sub New ( _
    dataSet As OleDbDataSet _
)

Parameters

dataSet
Type: ININ.IceLib.Configuration.Dialer.DataTypes..::..OleDbDataSet

See Also

OleDbDataSet..::..OleDbDataSetEnumerator Class
OleDbDataSet..::..OleDbDataSetEnumerator Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


OleDbDataSet.OleDbDataSetEnumerator Methods

[image] [image]

IceLib Dialer Technical Reference
OleDbDataSet..::..OleDbDataSetEnumerator Methods
OleDbDataSet..::..OleDbDataSetEnumerator Class See Also Send Feedback

The OleDbDataSet..::..OleDbDataSetEnumerator type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveNext | Advances the enumerator to the next element of the collection.
Public method | Reset | Sets the enumerator to its initial position, which is before the first element in the collection.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

OleDbDataSet..::..OleDbDataSetEnumerator Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


MoveNext Method

[image]

IceLib Dialer Technical Reference
OleDbDataSet..::..OleDbDataSetEnumerator..::..MoveNext Method
OleDbDataSet..::..OleDbDataSetEnumerator Class See Also Send Feedback
Advances the enumerator to the next element of the collection.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool MoveNext()
Visual Basic
Public Function MoveNext As Boolean

Return Value

true if the enumerator was successfully advanced to the next element; false if the enumerator has passed the end of the collection.

Implements

IEnumerator..::..MoveNext()()()()

Exceptions

Exception | Condition
System..::..InvalidOperationException | The collection was modified after the enumerator was created.

See Also

OleDbDataSet..::..OleDbDataSetEnumerator Class
OleDbDataSet..::..OleDbDataSetEnumerator Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Reset Method

[image]

IceLib Dialer Technical Reference
OleDbDataSet..::..OleDbDataSetEnumerator..::..Reset Method
OleDbDataSet..::..OleDbDataSetEnumerator Class See Also Send Feedback
Sets the enumerator to its initial position, which is before the first element in the collection.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void Reset()
Visual Basic
Public Sub Reset

Implements

IEnumerator..::..Reset()()()()

Exceptions

Exception | Condition
System..::..InvalidOperationException | The collection was modified after the enumerator was created.

See Also

OleDbDataSet..::..OleDbDataSetEnumerator Class
OleDbDataSet..::..OleDbDataSetEnumerator Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


OleDbDataSet.OleDbDataSetEnumerator Properties

[image] [image]

IceLib Dialer Technical Reference
OleDbDataSet..::..OleDbDataSetEnumerator Properties
OleDbDataSet..::..OleDbDataSetEnumerator Class See Also Send Feedback

The OleDbDataSet..::..OleDbDataSetEnumerator type exposes the following members.

Properties

 | Name | Description
Public property | Current | Gets the element in the collection at the current position of the enumerator.

See Also

OleDbDataSet..::..OleDbDataSetEnumerator Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Current Property

[image]

IceLib Dialer Technical Reference
OleDbDataSet..::..OleDbDataSetEnumerator..::..Current Property
OleDbDataSet..::..OleDbDataSetEnumerator Class See Also Send Feedback
Gets the element in the collection at the current position of the enumerator.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public IDictionary<DBColumn, Object> Current { get; }
Visual Basic
Public ReadOnly Property Current As IDictionary(Of DBColumn, Object)
    Get

Return Value

The element in the collection at the current position of the enumerator.

Implements

IEnumerator<(Of <(<'T>)>)>..::..Current

See Also

OleDbDataSet..::..OleDbDataSetEnumerator Class
OleDbDataSet..::..OleDbDataSetEnumerator Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


OracleDataSet Class

[image]

IceLib Dialer Technical Reference
OracleDataSet Class
Members See Also Send Feedback
An enumerable and appendable data source representing a table in an Oracle database.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class OracleDataSet : OleDbDataSet
Visual Basic
Public Class OracleDataSet _
    Inherits OleDbDataSet

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer.DataTypes..::..OleDbDataSet
ININ.IceLib.Configuration.Dialer.DataTypes..::..OracleDataSet

See Also

OracleDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


OracleDataSet Members

[image] [image]

IceLib Dialer Technical Reference
OracleDataSet Members
OracleDataSet Class Constructors Methods Properties See Also Send Feedback

The OracleDataSet type exposes the following members.

Constructors

 | Name | Description
Public method | OracleDataSet(String, String, String, String) | Creates a new instance of the OracleDataSet class.
Public method | OracleDataSet(String, String, String, String, IEnumerable<(Of <<'(DBColumn>)>>)) | Creates a new instance of the OracleDataSet class representing a table that does not yet exist.

Methods

 | Name | Description
Public method | CloseConnection | Closes the connection to the database or, if the source is a file, closes the file. Ignored if connection is not open. (Inherited from OleDbDataSet.)
Public method | CommitTransaction | Ends a transaction by committing all changes. (Inherited from OleDbDataSet.)
Public method | CreateTable | Creates a new table in the database or a new file containing the fields in the Fields property. (Overrides OleDbDataSet..::..CreateTable()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from OleDbDataSet.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenConnection | Opens the connection to the database or, if the source is a file, opens the file. Ignored if connection is already open. (Inherited from OleDbDataSet.)
Protected method | PrepareForWrite | Prepares the data set for one or more calls to WriteRecord(IDictionary<(Of <<'(DBColumn, Object>)>>)). (Inherited from OleDbDataSet.)
Public method | RollbackTransaction | Ends a transaction by reverting all changes. (Inherited from OleDbDataSet.)
Public method | StartTransaction | Begins a transaction. Transactions must be ended by calling either CommitTransaction()()()() or RollbackTransaction()()()() (Inherited from OleDbDataSet.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteRecord | Writes a single record to the database. (Inherited from OleDbDataSet.)

Properties

 | Name | Description
Public property | ConnectionState | The state of the connection to the database or the source file. (Inherited from OleDbDataSet.)
Protected property | DBMS | Specifies the type of database (Overrides OleDbDataSet..::..DBMS.)
Public property | Fields | The columns in the data source. (Inherited from OleDbDataSet.)
Public property | Password | The user's password.
Public property | Service | The TNS service to connect to.
Public property | TableName | The database table or file path where the data resides. (Inherited from OleDbDataSet.)
Public property | User | The user that has access to the table.

See Also

OracleDataSet Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


OracleDataSet Constructor

[image] [image]

IceLib Dialer Technical Reference
OracleDataSet Constructor
OracleDataSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | OracleDataSet(String, String, String, String) | Creates a new instance of the OracleDataSet class.
Public method | OracleDataSet(String, String, String, String, IEnumerable<(Of <<'(DBColumn>)>>)) | Creates a new instance of the OracleDataSet class representing a table that does not yet exist.

See Also

OracleDataSet Class
OracleDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


OracleDataSet Constructor (String, String, String, String)

[image]

IceLib Dialer Technical Reference
OracleDataSet Constructor (String, String, String, String)
OracleDataSet Class See Also Send Feedback
Creates a new instance of the OracleDataSet class.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public OracleDataSet(
    string tnsService,
    string table,
    string user,
    string password
)
Visual Basic
Public Sub New ( _
    tnsService As String, _
    table As String, _
    user As String, _
    password As String _
)

Parameters

tnsService
Type: System..::..String
table
Type: System..::..String
user
Type: System..::..String
password
Type: System..::..String

See Also

OracleDataSet Class
OracleDataSet Members
OracleDataSet Overload
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


OracleDataSet Constructor (String, String, String, String, IEnumerable(DBColumn))

[image]

IceLib Dialer Technical Reference
OracleDataSet Constructor (String, String, String, String, IEnumerable<(Of <(<'DBColumn>)>)>)
OracleDataSet Class See Also Send Feedback
Creates a new instance of the OracleDataSet class representing a table that does not yet exist.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public OracleDataSet(
    string tnsService,
    string table,
    string user,
    string password,
    IEnumerable<DBColumn> fields
)
Visual Basic
Public Sub New ( _
    tnsService As String, _
    table As String, _
    user As String, _
    password As String, _
    fields As IEnumerable(Of DBColumn) _
)

Parameters

tnsService
Type: System..::..String
table
Type: System..::..String
user
Type: System..::..String
password
Type: System..::..String
fields
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' DBColumn >)>)>

See Also

OracleDataSet Class
OracleDataSet Members
OracleDataSet Overload
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


OracleDataSet Methods

[image] [image]

IceLib Dialer Technical Reference
OracleDataSet Methods
OracleDataSet Class See Also Send Feedback

The OracleDataSet type exposes the following members.

Methods

 | Name | Description
Public method | CloseConnection | Closes the connection to the database or, if the source is a file, closes the file. Ignored if connection is not open. (Inherited from OleDbDataSet.)
Public method | CommitTransaction | Ends a transaction by committing all changes. (Inherited from OleDbDataSet.)
Public method | CreateTable | Creates a new table in the database or a new file containing the fields in the Fields property. (Overrides OleDbDataSet..::..CreateTable()()()().)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from OleDbDataSet.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenConnection | Opens the connection to the database or, if the source is a file, opens the file. Ignored if connection is already open. (Inherited from OleDbDataSet.)
Protected method | PrepareForWrite | Prepares the data set for one or more calls to WriteRecord(IDictionary<(Of <<'(DBColumn, Object>)>>)). (Inherited from OleDbDataSet.)
Public method | RollbackTransaction | Ends a transaction by reverting all changes. (Inherited from OleDbDataSet.)
Public method | StartTransaction | Begins a transaction. Transactions must be ended by calling either CommitTransaction()()()() or RollbackTransaction()()()() (Inherited from OleDbDataSet.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteRecord | Writes a single record to the database. (Inherited from OleDbDataSet.)

See Also

OracleDataSet Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CreateTable Method

[image]

IceLib Dialer Technical Reference
OracleDataSet..::..CreateTable Method
OracleDataSet Class See Also Send Feedback
Creates a new table in the database or a new file containing the fields in the Fields property.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override void CreateTable()
Visual Basic
Public Overrides Sub CreateTable

Implements

IDataSet..::..CreateTable()()()()

See Also

OracleDataSet Class
OracleDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


OracleDataSet Properties

[image] [image]

IceLib Dialer Technical Reference
OracleDataSet Properties
OracleDataSet Class See Also Send Feedback

The OracleDataSet type exposes the following members.

Properties

 | Name | Description
Public property | ConnectionState | The state of the connection to the database or the source file. (Inherited from OleDbDataSet.)
Protected property | DBMS | Specifies the type of database (Overrides OleDbDataSet..::..DBMS.)
Public property | Fields | The columns in the data source. (Inherited from OleDbDataSet.)
Public property | Password | The user's password.
Public property | Service | The TNS service to connect to.
Public property | TableName | The database table or file path where the data resides. (Inherited from OleDbDataSet.)
Public property | User | The user that has access to the table.

See Also

OracleDataSet Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


DBMS Property

[image]

IceLib Dialer Technical Reference
OracleDataSet..::..DBMS Property
OracleDataSet Class See Also Send Feedback
Specifies the type of database

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
protected override DatabaseType DBMS { get; }
Visual Basic
Protected Overrides ReadOnly Property DBMS As DatabaseType
    Get

See Also

OracleDataSet Class
OracleDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Password Property

[image]

IceLib Dialer Technical Reference
OracleDataSet..::..Password Property
OracleDataSet Class See Also Send Feedback
The user's password.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Password { get; set; }
Visual Basic
Public Property Password As String
    Get
    Set

See Also

OracleDataSet Class
OracleDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Service Property

[image]

IceLib Dialer Technical Reference
OracleDataSet..::..Service Property
OracleDataSet Class See Also Send Feedback
The TNS service to connect to.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Service { get; set; }
Visual Basic
Public Property Service As String
    Get
    Set

See Also

OracleDataSet Class
OracleDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


User Property

[image]

IceLib Dialer Technical Reference
OracleDataSet..::..User Property
OracleDataSet Class See Also Send Feedback
The user that has access to the table.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string User { get; set; }
Visual Basic
Public Property User As String
    Get
    Set

See Also

OracleDataSet Class
OracleDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


OutboundLineType Enumeration

[image]

IceLib Dialer Technical Reference
OutboundLineType Enumeration
See Also Send Feedback
Available methods for making calls in a campaign.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum OutboundLineType
Visual Basic
Public Enumeration OutboundLineType

Members

Member name | Value | Description
DialPlan | 0 | Adhere strictly to the configured Dial Plan.
LineGroup | 1 | Dialer calls go through a specific line group.

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


PenetrationRateCalculationMode Enumeration

[image]

IceLib Dialer Technical Reference
PenetrationRateCalculationMode Enumeration
See Also Send Feedback
Methods for calculating Penetration Rate.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum PenetrationRateCalculationMode
Visual Basic
Public Enumeration PenetrationRateCalculationMode

Members

Member name | Value | Description
CallListPenetration | 1 | Contact list records penetrated at least once divided by the number of contact list records.
PhoneNumberPenetration | 2 | Phone number column records penetrated at least once divided by the number of records in the same phone number column.
CallListSaturation | 3 | Total penetrated contact lists records divided by the number of contact list records.
PhoneNumberSaturation | 4 | Total penetrated contact list records by phone number column divided by the number of records in the phone number column.

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


PNDCounter Enumeration

[image]

IceLib Dialer Technical Reference
PNDCounter Enumeration
See Also Send Feedback
Possible fields checked in phone number detail policy conditions.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum PNDCounter
Visual Basic
Public Enumeration PNDCounter

Members

Member name | Value | Description
TotalAttempts | 0 | The total number of previous attempts made to call this contact.
AttemptsAbandoned | 1 | The number of previous attempts to this contact that were classified as abandoned.
AttemptsBusy | 2 | The number of previous attempts to this contact with a result of "busy".
AttemptsFax | 3 | The number of previous attempts to this contact with a result of "fax".
AttemptsAnsweringMachine | 4 | The number of previous attempts to this contact with a result of "answering machine".
AttemptsNoAnswer | 5 | The number of previous attempts to this contact with a result of "no answer".
AttemptsRemoteHangup | 6 | The number of previous attempts to this contact with a result of "remote hang up".
AttemptsRescheduled | 7 | The number of previous attempts to this contact with a result of "rescheduled".
AttemptsSystemHangup | 8 | The number of previous attempts to this contact with a result of "system hang up".
AttemptsSitCallable | 9 | The number of previous attempts to this contact with a result of "SIT callable".

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


PolicyBehaviorType Enumeration

[image]

IceLib Dialer Technical Reference
PolicyBehaviorType Enumeration
See Also Send Feedback
Policy behavior categories that define what kind of behavior is performed.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum PolicyBehaviorType
Visual Basic
Public Enumeration PolicyBehaviorType

Members

Member name | Value | Description
Attribute | 0 | A contact record attribute is modified. Valid in all policy types.
CallAttribute | 1 | A call attribute is modified. Valid in all policy types.
CallAnalysis | 2 | Toggles call analysis on or off. Valid only in pre-call policies.
Callback | 3 | Schedules a callback for the contact record. Valid in all policy types.
CallingParty | 4 | Modifies the name and number that appears on a caller id device. Valid only in pre-call policies.
CallRouting | 5 | Modifies parameters that determine which agent receives the call. Valid only in pre-call policies.
ContactColumns | 6 | Modifies the subset of phone numbers that may be called for the contact record. Valid only in pre-call policies.
CustomData | 7 | CustomData1 and CustomData2 attributes are modified. Valid in all policy types.
CustomStoredProc | 8 | CustomSprocParam1 and CustomSprocParam2 attributes are modified. Valid in all policy types.
Disposition | 9 | Specifies the wrap up code and category for the call. Valid in all policy types.
DncUpdate | 10 | Updates the DNC Source information for the call. Valid only in disposition policies.
EMail | 11 | Composes and sends an email. Valid in all policy types.
HtmlEMail | 12 | Composes and sends an html email. Valid in all policy types.
EventLog | 13 | Posts an entry to the event log. Valid in all policy types.
Handler | 14 | Calls a custom handler. Valid in all policy types.
Agentless | 15 | Performs an action that does not require an agent (send a fax, play an audio file, etc). Invalid in pre-call policies.
NumberToDial | 16 | Provides a customized number to call instead of the numbers contained in the contact record. Valid only in pre-call policies.
PreviewDialing | 17 | Allows the preview settings to be changed for a call in a preview campaign. Valid only in pre-call policies.
SMS | 18 | Composes and sends an SMS. Valid in all policy types.

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


PolicyConditionType Enumeration

[image]

IceLib Dialer Technical Reference
PolicyConditionType Enumeration
See Also Send Feedback
Policy condition categories that define what kind of evaluation is performed.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum PolicyConditionType
Visual Basic
Public Enumeration PolicyConditionType

Members

Member name | Value | Description
Attribute | 0 | An attribute of the contact record is checked. Valid in all policy types.
CallAnalysis | 1 | The results of call analysis are checked. Invalid in pre-call policies.
CallAttribute | 2 | An attirbute of the call is checked. Invalid in pre-call policies.
Duration | 3 | The duration of the call is checked. Invalid in pre-call policies.
CallCategory | 4 | The type of the call is checked. Valid in all policy types.
CallDialingMode | 5 | The dialing mode of the call is checked. Valid only in pre-call policies.
Disposition | 6 | The disposition of the call is checked. Valid only in disposition policy types.
Abandon | 7 | The abandoned status of the call is checked. Valid only in disposition policy types.
Stat | 8 | A system statistic is checked. Valid in all policy types.
Time | 9 | The current time is checked. Valid in all policy types.
PhoneNumberType | 10 | The type of the phone number is checked. Valid in all policy types.
PhoneNumberDetails | 11 | The details of the phone number are checked. Valid only in pre-call policies.

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


PolicyDialingMode Enumeration

[image]

IceLib Dialer Technical Reference
PolicyDialingMode Enumeration
See Also Send Feedback
possible dialing modes for policy conditions.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum PolicyDialingMode
Visual Basic
Public Enumeration PolicyDialingMode

Members

Member name | Value | Description
Regular | 0 | Normal
Preview | 1 | Preview
AgentOwnCallback | 3 | Agent-owned Callback
AgentOwnCallbackPreview | 4 | Agent-owned Callback(Preview)
Agentless | 7 | Agentless
Precise | 8 | Precice
Manual | 9 | Manual

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


PolicyEvaluationMode Enumeration

[image]

IceLib Dialer Technical Reference
PolicyEvaluationMode Enumeration
See Also Send Feedback
Modes of policy condition evaluation.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum PolicyEvaluationMode
Visual Basic
Public Enumeration PolicyEvaluationMode

Members

Member name | Value | Description
All | 0 | All conditions must be satisfied in order to trigger behaviors.
Any | 1 | Any one condition can be satisfied in order to trigger behaviors.

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


PolicyType Enumeration

[image]

IceLib Dialer Technical Reference
PolicyType Enumeration
See Also Send Feedback
Policy categories that define when the policy is evaluated.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum PolicyType
Visual Basic
Public Enumeration PolicyType

Members

Member name | Value | Description
PreCall | 0 | The policy is evaluated prior to placing the call.
CallAnalysis | 1 | The policy is evaluated after placing the call and performing call analysis.
Disposition | 2 | The policy is evaluated after the call is dispositioned.

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


RecordAttributeType Enumeration

[image]

IceLib Dialer Technical Reference
RecordAttributeType Enumeration
See Also Send Feedback
Accepted data types for attribute policy conditions.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum RecordAttributeType
Visual Basic
Public Enumeration RecordAttributeType

Members

Member name | Value | Description
DateTime | 0 | Date and/or time.
String | 1 | Text
Number | 2 | Numeric value (integer or decimal).
TimeOffset | 3 | A special data type that adds an offset to the current date/time and compares the resulting sum to the attribute.

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


RepetitionMode Enumeration

[image]

IceLib Dialer Technical Reference
RepetitionMode Enumeration
See Also Send Feedback
Values for rule evaluation frequency.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum RepetitionMode
Visual Basic
Public Enumeration RepetitionMode

Members

Member name | Value | Description
Always | 0 | Always evaluate a rule regardless of campaign resets/recycles.
OncePerCampaign | 1 | Evaluate a rule once per campaign reset.
OncePerRecycle | 2 | Evaluate a rule once per campaign/contact List recycle.

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


RuleActionType Enumeration

[image]

IceLib Dialer Technical Reference
RuleActionType Enumeration
See Also Send Feedback
Specific types of actions that a rule can execute.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum RuleActionType
Visual Basic
Public Enumeration RuleActionType

Members

Member name | Value | Description
Campaign | 0 | Changes the execution state of a campaign.
CampaignProperty | 1 | Changes the value of a campaign property.
Email | 2 | Sends an email.
EventLog | 3 | Writes an entry to the event log.
Group | 4 | Switches rule evaluation to a different rule group.
Handler | 5 | Executes a custom handler.
SMS | 6 |
Agent | 7 | Logs one or more agents and/or workgroups in or out of a campaign

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


RuleEngineTermination Enumeration

[image]

IceLib Dialer Technical Reference
RuleEngineTermination Enumeration
See Also Send Feedback
Specifies the scope of rule evaluation to terminate.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum RuleEngineTermination
Visual Basic
Public Enumeration RuleEngineTermination

Members

Member name | Value | Description
ContinueEvaluation | 0 | Continue evaluating rules normally.
StopAllRules | 1 | Stop evaluating all rules for this evaluation pass.
StopThisRuleset | 2 | Stop evaluating rules in the current rule set.

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


RuleFunction Enumeration

[image]

IceLib Dialer Technical Reference
RuleFunction Enumeration
See Also Send Feedback
Mathematical functions used in evaluating conditions for custom StatRules

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum RuleFunction
Visual Basic
Public Enumeration RuleFunction

Members

Member name | Value | Description
Average | 0 | Calculates the average value of the given contact record attribute.
Count | 1 | Calculates the number of contact records with a given attribute matching a given value.
Sum | 2 | Calculates the sum of the values of a given column across multiple contact records.

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


RuleType Enumeration

[image]

IceLib Dialer Technical Reference
RuleType Enumeration
See Also Send Feedback
Types of conditions that a rule may evaluate.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum RuleType
Visual Basic
Public Enumeration RuleType

Members

Member name | Value | Description
SystemEvent | 0 | Watches for a certain SystemEvent to occur.
Stat | 1 | Evaluates the value of a statistic.
Time | 2 | Specifies a schedule for executing rule actions.

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ScheduledCall Class

[image]

IceLib Dialer Technical Reference
ScheduledCall Class
Members See Also Send Feedback
A scheduled call for an existing contact.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class ScheduledCall
Visual Basic
Public Class ScheduledCall

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer.DataTypes..::..ScheduledCall

See Also

ScheduledCall Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ScheduledCall Members

[image] [image]

IceLib Dialer Technical Reference
ScheduledCall Members
ScheduledCall Class Constructors Methods Properties See Also Send Feedback

The ScheduledCall type exposes the following members.

Constructors

 | Name | Description
Public method | ScheduledCall(String, String, ContactColumnConfiguration, String, String, DateTime) | Initializes a new instance of the ScheduledCall class. This constructor allows the use of a custom callback number.
Public method | ScheduledCall(String, String, String, String, String, DateTime) | Initializes a new instance of the ScheduledCall class. This constructor allows the use of a custom callback number.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AgentID | The agent to route the call to.
Public property | Campaign | The display name of the campaign to associate the call with.
Public property | ContactColumn | The contact column to dial. This can be overriden by supplying a value for CustomPhoneNumber
Public property | CustomPhoneNumber | The custom phone number to dial. Overrides the phone number represented by ContactColumn
Public property | Identity | The i3_identity of the contact to call.
Public property | SiteID | The name of the ODS that should make the call.
Public property | TimeToCall | The date and time at which to place the call.

See Also

ScheduledCall Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ScheduledCall Constructor

[image] [image]

IceLib Dialer Technical Reference
ScheduledCall Constructor
ScheduledCall Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ScheduledCall(String, String, ContactColumnConfiguration, String, String, DateTime) | Initializes a new instance of the ScheduledCall class. This constructor allows the use of a custom callback number.
Public method | ScheduledCall(String, String, String, String, String, DateTime) | Initializes a new instance of the ScheduledCall class. This constructor allows the use of a custom callback number.

See Also

ScheduledCall Class
ScheduledCall Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ScheduledCall Constructor (String, String, ContactColumnConfiguration, String, String, DateTime)

[image]

IceLib Dialer Technical Reference
ScheduledCall Constructor (String, String, ContactColumnConfiguration, String, String, DateTime)
ScheduledCall Class See Also Send Feedback
Initializes a new instance of the ScheduledCall class. This constructor allows the use of a custom callback number.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ScheduledCall(
    string identity,
    string campaign,
    ContactColumnConfiguration contactColumn,
    string agentId,
    string siteId,
    DateTime timetoCall
)
Visual Basic
Public Sub New ( _
    identity As String, _
    campaign As String, _
    contactColumn As ContactColumnConfiguration, _
    agentId As String, _
    siteId As String, _
    timetoCall As DateTime _
)

Parameters

identity
Type: System..::..String
The i3_identity of the contact to call.
campaign
Type: System..::..String
The display name of the campaign to associate the call with.
contactColumn
Type: ININ.IceLib.Configuration.Dialer..::..ContactColumnConfiguration
The contact column to dial.
agentId
Type: System..::..String
The agent to route the call to. An empty string indicates this is a campaign-wide callback.
siteId
Type: System..::..String
The name of the ODS that should make the call.
timetoCall
Type: System..::..DateTime
The date and time at which to place the call.

See Also

ScheduledCall Class
ScheduledCall Members
ScheduledCall Overload
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ScheduledCall Constructor (String, String, String, String, String, DateTime)

[image]

IceLib Dialer Technical Reference
ScheduledCall Constructor (String, String, String, String, String, DateTime)
ScheduledCall Class See Also Send Feedback
Initializes a new instance of the ScheduledCall class. This constructor allows the use of a custom callback number.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ScheduledCall(
    string identity,
    string campaign,
    string phoneNumber,
    string agentId,
    string siteId,
    DateTime timeToCall
)
Visual Basic
Public Sub New ( _
    identity As String, _
    campaign As String, _
    phoneNumber As String, _
    agentId As String, _
    siteId As String, _
    timeToCall As DateTime _
)

Parameters

identity
Type: System..::..String
The i3_identity of the contact to call.
campaign
Type: System..::..String
The display name of the campaign to associate the call with.
phoneNumber
Type: System..::..String
The custom phone number to dial.
agentId
Type: System..::..String
The agent to route the call to. An empty string indicates this is a campaign-wide callback.
siteId
Type: System..::..String
The name of the ODS that should make the call.
timeToCall
Type: System..::..DateTime
The date and time at which to place the call.

See Also

ScheduledCall Class
ScheduledCall Members
ScheduledCall Overload
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ScheduledCall Methods

[image] [image]

IceLib Dialer Technical Reference
ScheduledCall Methods
ScheduledCall Class See Also Send Feedback

The ScheduledCall type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScheduledCall Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ScheduledCall Properties

[image] [image]

IceLib Dialer Technical Reference
ScheduledCall Properties
ScheduledCall Class See Also Send Feedback

The ScheduledCall type exposes the following members.

Properties

 | Name | Description
Public property | AgentID | The agent to route the call to.
Public property | Campaign | The display name of the campaign to associate the call with.
Public property | ContactColumn | The contact column to dial. This can be overriden by supplying a value for CustomPhoneNumber
Public property | CustomPhoneNumber | The custom phone number to dial. Overrides the phone number represented by ContactColumn
Public property | Identity | The i3_identity of the contact to call.
Public property | SiteID | The name of the ODS that should make the call.
Public property | TimeToCall | The date and time at which to place the call.

See Also

ScheduledCall Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


AgentID Property

[image]

IceLib Dialer Technical Reference
ScheduledCall..::..AgentID Property
ScheduledCall Class See Also Send Feedback
The agent to route the call to.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string AgentID { get; set; }
Visual Basic
Public Property AgentID As String
    Get
    Set

Remarks

An empty string denotes a campaign-wide callback.

See Also

ScheduledCall Class
ScheduledCall Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Campaign Property

[image]

IceLib Dialer Technical Reference
ScheduledCall..::..Campaign Property
ScheduledCall Class See Also Send Feedback
The display name of the campaign to associate the call with.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Campaign { get; set; }
Visual Basic
Public Property Campaign As String
    Get
    Set

See Also

ScheduledCall Class
ScheduledCall Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ContactColumn Property

[image]

IceLib Dialer Technical Reference
ScheduledCall..::..ContactColumn Property
ScheduledCall Class See Also Send Feedback
The contact column to dial. This can be overriden by supplying a value for CustomPhoneNumber

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ContactColumnConfiguration ContactColumn { get; set; }
Visual Basic
Public Property ContactColumn As ContactColumnConfiguration
    Get
    Set

See Also

ScheduledCall Class
ScheduledCall Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CustomPhoneNumber Property

[image]

IceLib Dialer Technical Reference
ScheduledCall..::..CustomPhoneNumber Property
ScheduledCall Class See Also Send Feedback
The custom phone number to dial. Overrides the phone number represented by ContactColumn

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string CustomPhoneNumber { get; set; }
Visual Basic
Public Property CustomPhoneNumber As String
    Get
    Set

See Also

ScheduledCall Class
ScheduledCall Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Identity Property

[image]

IceLib Dialer Technical Reference
ScheduledCall..::..Identity Property
ScheduledCall Class See Also Send Feedback
The i3_identity of the contact to call.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Identity { get; set; }
Visual Basic
Public Property Identity As String
    Get
    Set

See Also

ScheduledCall Class
ScheduledCall Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


SiteID Property

[image]

IceLib Dialer Technical Reference
ScheduledCall..::..SiteID Property
ScheduledCall Class See Also Send Feedback
The name of the ODS that should make the call.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string SiteID { get; set; }
Visual Basic
Public Property SiteID As String
    Get
    Set

See Also

ScheduledCall Class
ScheduledCall Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


TimeToCall Property

[image]

IceLib Dialer Technical Reference
ScheduledCall..::..TimeToCall Property
ScheduledCall Class See Also Send Feedback
The date and time at which to place the call.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DateTime TimeToCall { get; set; }
Visual Basic
Public Property TimeToCall As DateTime
    Get
    Set

See Also

ScheduledCall Class
ScheduledCall Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ScheduledCampaignState Enumeration

[image]

IceLib Dialer Technical Reference
ScheduledCampaignState Enumeration
See Also Send Feedback
Possible campaign states for a Schedule.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum ScheduledCampaignState
Visual Basic
Public Enumeration ScheduledCampaignState

Members

Member name | Value | Description
On | 0 | Campaign should be running
Off | 1 | Campaign should not be running
ScheduledCallsOnly | 2 | Campaign should be running, but only dialing scheduled calls

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ScheduleTimeSlot Class

[image]

IceLib Dialer Technical Reference
ScheduleTimeSlot Class
Members See Also Send Feedback
A time slot for use in Schedule objects. Specifies the state of a campaign in a given time range.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class ScheduleTimeSlot : TimeSlot
Visual Basic
Public Class ScheduleTimeSlot _
    Inherits TimeSlot

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer.DataTypes..::..TimeSlot
ININ.IceLib.Configuration.Dialer.DataTypes..::..ScheduleTimeSlot

See Also

ScheduleTimeSlot Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ScheduleTimeSlot Members

[image] [image]

IceLib Dialer Technical Reference
ScheduleTimeSlot Members
ScheduleTimeSlot Class Constructors Methods Properties See Also Send Feedback

The ScheduleTimeSlot type exposes the following members.

Constructors

 | Name | Description
Public method | ScheduleTimeSlot | Initializes a new instance of the ScheduleTimeSlot class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CampaignState | The state of the campaign when this time slot is active.
Public property | EndDate | The date on which this slot ends. Value is null for weekly recurrences.
Public property | EndDay | The day of the week on which this slot ends. (Inherited from TimeSlot.)
Public property | EndTime | A time of day of when this slot ends. (Inherited from TimeSlot.)
Public property | StartDate | The date on which this slot begins. Value is null for weekly recurrences.
Public property | StartDay | The day of the week on which this slot begins. (Inherited from TimeSlot.)
Public property | StartTime | A time of day of when this slot begins. (Inherited from TimeSlot.)

See Also

ScheduleTimeSlot Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ScheduleTimeSlot Constructor

[image]

IceLib Dialer Technical Reference
ScheduleTimeSlot Constructor
ScheduleTimeSlot Class See Also Send Feedback
Initializes a new instance of the ScheduleTimeSlot class

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ScheduleTimeSlot()
Visual Basic
Public Sub New

See Also

ScheduleTimeSlot Class
ScheduleTimeSlot Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ScheduleTimeSlot Methods

[image] [image]

IceLib Dialer Technical Reference
ScheduleTimeSlot Methods
ScheduleTimeSlot Class See Also Send Feedback

The ScheduleTimeSlot type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScheduleTimeSlot Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ScheduleTimeSlot Properties

[image] [image]

IceLib Dialer Technical Reference
ScheduleTimeSlot Properties
ScheduleTimeSlot Class See Also Send Feedback

The ScheduleTimeSlot type exposes the following members.

Properties

 | Name | Description
Public property | CampaignState | The state of the campaign when this time slot is active.
Public property | EndDate | The date on which this slot ends. Value is null for weekly recurrences.
Public property | EndDay | The day of the week on which this slot ends. (Inherited from TimeSlot.)
Public property | EndTime | A time of day of when this slot ends. (Inherited from TimeSlot.)
Public property | StartDate | The date on which this slot begins. Value is null for weekly recurrences.
Public property | StartDay | The day of the week on which this slot begins. (Inherited from TimeSlot.)
Public property | StartTime | A time of day of when this slot begins. (Inherited from TimeSlot.)

See Also

ScheduleTimeSlot Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


CampaignState Property

[image]

IceLib Dialer Technical Reference
ScheduleTimeSlot..::..CampaignState Property
ScheduleTimeSlot Class See Also Send Feedback
The state of the campaign when this time slot is active.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ScheduledCampaignState CampaignState { get; set; }
Visual Basic
Public Property CampaignState As ScheduledCampaignState
    Get
    Set

See Also

ScheduleTimeSlot Class
ScheduleTimeSlot Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


EndDate Property

[image]

IceLib Dialer Technical Reference
ScheduleTimeSlot..::..EndDate Property
ScheduleTimeSlot Class See Also Send Feedback
The date on which this slot ends. Value is null for weekly recurrences.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Nullable<DateTime> EndDate { get; set; }
Visual Basic
Public Property EndDate As Nullable(Of DateTime)
    Get
    Set

See Also

ScheduleTimeSlot Class
ScheduleTimeSlot Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


StartDate Property

[image]

IceLib Dialer Technical Reference
ScheduleTimeSlot..::..StartDate Property
ScheduleTimeSlot Class See Also Send Feedback
The date on which this slot begins. Value is null for weekly recurrences.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Nullable<DateTime> StartDate { get; set; }
Visual Basic
Public Property StartDate As Nullable(Of DateTime)
    Get
    Set

See Also

ScheduleTimeSlot Class
ScheduleTimeSlot Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


SortColumn Class

[image]

IceLib Dialer Technical Reference
SortColumn Class
Members See Also Send Feedback
A class representing a sort clause in a SQL statement.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class SortColumn : IDeepCloneable
Visual Basic
Public Class SortColumn _
    Implements IDeepCloneable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer.DataTypes..::..SortColumn

See Also

SortColumn Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


SortColumn Members

[image] [image]

IceLib Dialer Technical Reference
SortColumn Members
SortColumn Class Constructors Methods Properties See Also Send Feedback

The SortColumn type exposes the following members.

Constructors

 | Name | Description
Public method | SortColumn | Creates a new instance of the SortColumn class.

Methods

 | Name | Description
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ColumnName | The name of the column to sort by.
Public property | Descending | true to sort in descending order, false to sort in ascending order

See Also

SortColumn Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


SortColumn Constructor

[image]

IceLib Dialer Technical Reference
SortColumn Constructor
SortColumn Class See Also Send Feedback
Creates a new instance of the SortColumn class.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public SortColumn(
    DBColumn column,
    bool descending
)
Visual Basic
Public Sub New ( _
    column As DBColumn, _
    descending As Boolean _
)

Parameters

column
Type: ININ.IceLib.Configuration.Dialer.DataTypes..::..DBColumn
The column to sort by.
descending
Type: System..::..Boolean
true to sort in descending order, false to sort in ascending order

See Also

SortColumn Class
SortColumn Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


SortColumn Methods

[image] [image]

IceLib Dialer Technical Reference
SortColumn Methods
SortColumn Class See Also Send Feedback

The SortColumn type exposes the following members.

Methods

 | Name | Description
Public method | Equals | (Overrides Object..::..Equals(Object).)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides Object..::..GetHashCode()()()().)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SortColumn Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Equals Method

[image]

IceLib Dialer Technical Reference
SortColumn..::..Equals Method
SortColumn Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::..Object

See Also

SortColumn Class
SortColumn Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


GetHashCode Method

[image]

IceLib Dialer Technical Reference
SortColumn..::..GetHashCode Method
SortColumn Class See Also Send Feedback

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override int GetHashCode()
Visual Basic
Public Overrides Function GetHashCode As Integer

See Also

SortColumn Class
SortColumn Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


SortColumn Properties

[image] [image]

IceLib Dialer Technical Reference
SortColumn Properties
SortColumn Class See Also Send Feedback

The SortColumn type exposes the following members.

Properties

 | Name | Description
Public property | ColumnName | The name of the column to sort by.
Public property | Descending | true to sort in descending order, false to sort in ascending order

See Also

SortColumn Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ColumnName Property

[image]

IceLib Dialer Technical Reference
SortColumn..::..ColumnName Property
SortColumn Class See Also Send Feedback
The name of the column to sort by.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string ColumnName { get; private set; }
Visual Basic
Public Property ColumnName As String
    Get
    Private Set

See Also

SortColumn Class
SortColumn Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Descending Property

[image]

IceLib Dialer Technical Reference
SortColumn..::..Descending Property
SortColumn Class See Also Send Feedback
true to sort in descending order, false to sort in ascending order

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool Descending { get; set; }
Visual Basic
Public Property Descending As Boolean
    Get
    Set

See Also

SortColumn Class
SortColumn Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


SQLServerDataSet Class

[image]

IceLib Dialer Technical Reference
SQLServerDataSet Class
Members See Also Send Feedback
An enumerable and appendable data source representing a table in a SQL Server database.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class SQLServerDataSet : OleDbDataSet
Visual Basic
Public Class SQLServerDataSet _
    Inherits OleDbDataSet

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer.DataTypes..::..OleDbDataSet
ININ.IceLib.Configuration.Dialer.DataTypes..::..SQLServerDataSet

See Also

SQLServerDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


SQLServerDataSet Members

[image] [image]

IceLib Dialer Technical Reference
SQLServerDataSet Members
SQLServerDataSet Class Constructors Methods Properties See Also Send Feedback

The SQLServerDataSet type exposes the following members.

Constructors

 | Name | Description
Public method | SQLServerDataSet(String, String, String, String, String) | Creates a new instance of the SQLServerDataSet representing an existing table.
Public method | SQLServerDataSet(String, String, String, String, String, IEnumerable<(Of <<'(DBColumn>)>>)) | Creates a new instance of the SQLServerDataSet representing a table that does not yet exist.

Methods

 | Name | Description
Public method | CloseConnection | Closes the connection to the database or, if the source is a file, closes the file. Ignored if connection is not open. (Inherited from OleDbDataSet.)
Public method | CommitTransaction | Ends a transaction by committing all changes. (Inherited from OleDbDataSet.)
Public method | CreateTable | Creates a new table in the database or a new file containing the fields in the Fields property. (Inherited from OleDbDataSet.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from OleDbDataSet.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenConnection | Opens the connection to the database or, if the source is a file, opens the file. Ignored if connection is already open. (Inherited from OleDbDataSet.)
Protected method | PrepareForWrite | Prepares the data set for one or more calls to WriteRecord(IDictionary<(Of <<'(DBColumn, Object>)>>)). (Inherited from OleDbDataSet.)
Public method | RollbackTransaction | Ends a transaction by reverting all changes. (Inherited from OleDbDataSet.)
Public method | StartTransaction | Begins a transaction. Transactions must be ended by calling either CommitTransaction()()()() or RollbackTransaction()()()() (Inherited from OleDbDataSet.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteRecord | Writes a single record to the database. (Inherited from OleDbDataSet.)

Properties

 | Name | Description
Public property | ConnectionState | The state of the connection to the database or the source file. (Inherited from OleDbDataSet.)
Public property | Database | The name of the database where the table is located.
Protected property | DBMS | (Inherited from OleDbDataSet.)
Public property | Fields | The columns in the data source. (Inherited from OleDbDataSet.)
Public property | Password | The user's password.
Public property | Server | The name of the server where the database is located.
Public property | TableName | The database table or file path where the data resides. (Inherited from OleDbDataSet.)
Public property | User | The user that has access to the table.

See Also

SQLServerDataSet Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


SQLServerDataSet Constructor

[image] [image]

IceLib Dialer Technical Reference
SQLServerDataSet Constructor
SQLServerDataSet Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SQLServerDataSet(String, String, String, String, String) | Creates a new instance of the SQLServerDataSet representing an existing table.
Public method | SQLServerDataSet(String, String, String, String, String, IEnumerable<(Of <<'(DBColumn>)>>)) | Creates a new instance of the SQLServerDataSet representing a table that does not yet exist.

See Also

SQLServerDataSet Class
SQLServerDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


SQLServerDataSet Constructor (String, String, String, String, String)

[image]

IceLib Dialer Technical Reference
SQLServerDataSet Constructor (String, String, String, String, String)
SQLServerDataSet Class See Also Send Feedback
Creates a new instance of the SQLServerDataSet representing an existing table.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public SQLServerDataSet(
    string server,
    string database,
    string table,
    string user,
    string password
)
Visual Basic
Public Sub New ( _
    server As String, _
    database As String, _
    table As String, _
    user As String, _
    password As String _
)

Parameters

server
Type: System..::..String
The name of the server hosting the database.
database
Type: System..::..String
The name of the database hosting the table.
table
Type: System..::..String
The name of the table containing the data.
user
Type: System..::..String
The user name that has access to the table.
password
Type: System..::..String
The user's password.

See Also

SQLServerDataSet Class
SQLServerDataSet Members
SQLServerDataSet Overload
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


SQLServerDataSet Constructor (String, String, String, String, String, IEnumerable(DBColumn))

[image]

IceLib Dialer Technical Reference
SQLServerDataSet Constructor (String, String, String, String, String, IEnumerable<(Of <(<'DBColumn>)>)>)
SQLServerDataSet Class See Also Send Feedback
Creates a new instance of the SQLServerDataSet representing a table that does not yet exist.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public SQLServerDataSet(
    string server,
    string database,
    string table,
    string user,
    string password,
    IEnumerable<DBColumn> fields
)
Visual Basic
Public Sub New ( _
    server As String, _
    database As String, _
    table As String, _
    user As String, _
    password As String, _
    fields As IEnumerable(Of DBColumn) _
)

Parameters

server
Type: System..::..String
The name of the server hosting the database.
database
Type: System..::..String
The name of the database hosting the table.
table
Type: System..::..String
The name of the table containing the data.
user
Type: System..::..String
The user name that has access to the table.
password
Type: System..::..String
The user's password.
fields
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' DBColumn >)>)>

See Also

SQLServerDataSet Class
SQLServerDataSet Members
SQLServerDataSet Overload
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


SQLServerDataSet Methods

[image] [image]

IceLib Dialer Technical Reference
SQLServerDataSet Methods
SQLServerDataSet Class See Also Send Feedback

The SQLServerDataSet type exposes the following members.

Methods

 | Name | Description
Public method | CloseConnection | Closes the connection to the database or, if the source is a file, closes the file. Ignored if connection is not open. (Inherited from OleDbDataSet.)
Public method | CommitTransaction | Ends a transaction by committing all changes. (Inherited from OleDbDataSet.)
Public method | CreateTable | Creates a new table in the database or a new file containing the fields in the Fields property. (Inherited from OleDbDataSet.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from OleDbDataSet.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenConnection | Opens the connection to the database or, if the source is a file, opens the file. Ignored if connection is already open. (Inherited from OleDbDataSet.)
Protected method | PrepareForWrite | Prepares the data set for one or more calls to WriteRecord(IDictionary<(Of <<'(DBColumn, Object>)>>)). (Inherited from OleDbDataSet.)
Public method | RollbackTransaction | Ends a transaction by reverting all changes. (Inherited from OleDbDataSet.)
Public method | StartTransaction | Begins a transaction. Transactions must be ended by calling either CommitTransaction()()()() or RollbackTransaction()()()() (Inherited from OleDbDataSet.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)
Public method | WriteRecord | Writes a single record to the database. (Inherited from OleDbDataSet.)

See Also

SQLServerDataSet Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


SQLServerDataSet Properties

[image] [image]

IceLib Dialer Technical Reference
SQLServerDataSet Properties
SQLServerDataSet Class See Also Send Feedback

The SQLServerDataSet type exposes the following members.

Properties

 | Name | Description
Public property | ConnectionState | The state of the connection to the database or the source file. (Inherited from OleDbDataSet.)
Public property | Database | The name of the database where the table is located.
Protected property | DBMS | (Inherited from OleDbDataSet.)
Public property | Fields | The columns in the data source. (Inherited from OleDbDataSet.)
Public property | Password | The user's password.
Public property | Server | The name of the server where the database is located.
Public property | TableName | The database table or file path where the data resides. (Inherited from OleDbDataSet.)
Public property | User | The user that has access to the table.

See Also

SQLServerDataSet Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Database Property

[image]

IceLib Dialer Technical Reference
SQLServerDataSet..::..Database Property
SQLServerDataSet Class See Also Send Feedback
The name of the database where the table is located.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Database { get; private set; }
Visual Basic
Public Property Database As String
    Get
    Private Set

See Also

SQLServerDataSet Class
SQLServerDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Password Property

[image]

IceLib Dialer Technical Reference
SQLServerDataSet..::..Password Property
SQLServerDataSet Class See Also Send Feedback
The user's password.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Password { get; private set; }
Visual Basic
Public Property Password As String
    Get
    Private Set

See Also

SQLServerDataSet Class
SQLServerDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Server Property

[image]

IceLib Dialer Technical Reference
SQLServerDataSet..::..Server Property
SQLServerDataSet Class See Also Send Feedback
The name of the server where the database is located.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Server { get; private set; }
Visual Basic
Public Property Server As String
    Get
    Private Set

See Also

SQLServerDataSet Class
SQLServerDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


User Property

[image]

IceLib Dialer Technical Reference
SQLServerDataSet..::..User Property
SQLServerDataSet Class See Also Send Feedback
The user that has access to the table.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string User { get; private set; }
Visual Basic
Public Property User As String
    Get
    Private Set

See Also

SQLServerDataSet Class
SQLServerDataSet Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


StatPeriod Enumeration

[image]

IceLib Dialer Technical Reference
StatPeriod Enumeration
See Also Send Feedback
Possible start points for a rule or policy statistic condition.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum StatPeriod
Visual Basic
Public Enumeration StatPeriod

Members

Member name | Value | Description
Campaign | 2 | Readings taken since the start of the campaign are evaluated.
Recycle | 1 | Readings taken since the last contact list recycle are evaluated.

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


StatRuleType Enumeration

[image]

IceLib Dialer Technical Reference
StatRuleType Enumeration
See Also Send Feedback
Distinguishes between built-in and custom statistics.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum StatRuleType
Visual Basic
Public Enumeration StatRuleType

Members

Member name | Value | Description
Standard | 0 | Standard Dialer Statistic
Custom | 1 | Custom User Statistic

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


SystemEvent Enumeration

[image]

IceLib Dialer Technical Reference
SystemEvent Enumeration
See Also Send Feedback
Dialer system events that may be monitored by EventRules.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum SystemEvent
Visual Basic
Public Enumeration SystemEvent

Members

Member name | Value | Description
CampaignStart | 0 | The campaign started.
CampaignStop | 1 | The campaign stopped.
CampaignReset | 2 | The campaign was reset.
ContactListRecycle | 3 | The contact list referenced by the campaign was restarted.
CampaignPause | 4 | The contact list referenced by the campaign was paused.
CampaignUnpause | 5 | The contact list referenced by the campaign was unpaused.
Custom | 6 | Campaign custom event.

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


TimeRuleMode Enumeration

[image]

IceLib Dialer Technical Reference
TimeRuleMode Enumeration
See Also Send Feedback
Settings for the frequency of time rule execution.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum TimeRuleMode
Visual Basic
Public Enumeration TimeRuleMode

Members

Member name | Value | Description
Daily | 0 | Run the rule daily.
ByDay | 1 | Run the rule on certain days of the week.
ByDate | 2 | Run the rule once on a specific date.
Interval | 3 | Run the rule at specific time intervals.
ByTimer | 4 | Run the sequence after the interval has passed.

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


TimeSlot Class

[image]

IceLib Dialer Technical Reference
TimeSlot Class
Members See Also Send Feedback
Represents a period of time.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class TimeSlot : IDeepCloneable
Visual Basic
Public Class TimeSlot _
    Implements IDeepCloneable

Remarks

When spanning multiple days, a time slot represents a block of time each day as opposed to one continuous slot. For example, Monday 10am to Wednesday 12pm consists of a total of 6 hours (2 each day), as opposed to one 50 hour slot.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer.DataTypes..::..TimeSlot
ININ.IceLib.Configuration.Dialer.DataTypes..::..ScheduleTimeSlot

See Also

TimeSlot Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


TimeSlot Members

[image] [image]

IceLib Dialer Technical Reference
TimeSlot Members
TimeSlot Class Constructors Methods Properties See Also Send Feedback

The TimeSlot type exposes the following members.

Constructors

 | Name | Description
Public method | TimeSlot | Initializes a new instance of the TimeSlot class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | EndDay | The day of the week on which this slot ends.
Public property | EndTime | A time of day of when this slot ends.
Public property | StartDay | The day of the week on which this slot begins.
Public property | StartTime | A time of day of when this slot begins.

See Also

TimeSlot Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


TimeSlot Constructor

[image]

IceLib Dialer Technical Reference
TimeSlot Constructor
TimeSlot Class See Also Send Feedback
Initializes a new instance of the TimeSlot class

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public TimeSlot()
Visual Basic
Public Sub New

See Also

TimeSlot Class
TimeSlot Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


TimeSlot Methods

[image] [image]

IceLib Dialer Technical Reference
TimeSlot Methods
TimeSlot Class See Also Send Feedback

The TimeSlot type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TimeSlot Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


TimeSlot Properties

[image] [image]

IceLib Dialer Technical Reference
TimeSlot Properties
TimeSlot Class See Also Send Feedback

The TimeSlot type exposes the following members.

Properties

 | Name | Description
Public property | EndDay | The day of the week on which this slot ends.
Public property | EndTime | A time of day of when this slot ends.
Public property | StartDay | The day of the week on which this slot begins.
Public property | StartTime | A time of day of when this slot begins.

See Also

TimeSlot Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


EndDay Property

[image]

IceLib Dialer Technical Reference
TimeSlot..::..EndDay Property
TimeSlot Class See Also Send Feedback
The day of the week on which this slot ends.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Nullable<DayOfWeek> EndDay { get; set; }
Visual Basic
Public Property EndDay As Nullable(Of DayOfWeek)
    Get
    Set

See Also

TimeSlot Class
TimeSlot Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


EndTime Property

[image]

IceLib Dialer Technical Reference
TimeSlot..::..EndTime Property
TimeSlot Class See Also Send Feedback
A time of day of when this slot ends.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public TimeSpan EndTime { get; set; }
Visual Basic
Public Property EndTime As TimeSpan
    Get
    Set

Exceptions

Exception | Condition
System..::..FormatException | Time value is outside of the acceptable range (00:00:00 - 23:59:59), or start time is greater than end time.

See Also

TimeSlot Class
TimeSlot Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


StartDay Property

[image]

IceLib Dialer Technical Reference
TimeSlot..::..StartDay Property
TimeSlot Class See Also Send Feedback
The day of the week on which this slot begins.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Nullable<DayOfWeek> StartDay { get; set; }
Visual Basic
Public Property StartDay As Nullable(Of DayOfWeek)
    Get
    Set

See Also

TimeSlot Class
TimeSlot Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


StartTime Property

[image]

IceLib Dialer Technical Reference
TimeSlot..::..StartTime Property
TimeSlot Class See Also Send Feedback
A time of day of when this slot begins.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public TimeSpan StartTime { get; set; }
Visual Basic
Public Property StartTime As TimeSpan
    Get
    Set

Exceptions

Exception | Condition
System..::..FormatException | Time value is outside of the acceptable range (00:00:00 - 23:59:59), or start time is greater than end time.

See Also

TimeSlot Class
TimeSlot Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


TimeZoneAutoMapping Enumeration

[image]

IceLib Dialer Technical Reference
TimeZoneAutoMapping Enumeration
See Also Send Feedback
Describes how phone numbers should be mapped to time zones.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum TimeZoneAutoMapping
Visual Basic
Public Enumeration TimeZoneAutoMapping

Members

Member name | Value | Description
NoAutoMapping | 0 | Do not perform any automatic mapping.
MapNotSetToZone | 1 | Map only phone numbers that have no zone information.
MapNotSetToZoneOrPredefinedZone | 2 | Map phone numbers that have no zone information and numbers that have previously been auto-mapped.
MapAll | 3 | Map all phone numbers regardless of their current zone settings.

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


TimezoneMapDatasetFormat Enumeration

[image]

IceLib Dialer Technical Reference
TimezoneMapDatasetFormat Enumeration
See Also Send Feedback
The set of timezone mapping data formats supported by Interaction Dialer.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum TimezoneMapDatasetFormat
Visual Basic
Public Enumeration TimezoneMapDatasetFormat

Members

Member name | Value | Description
Invalid | 0 | Unsupported or invalid format
Custom | 1 | Interactive Intelligence's open timezone mapping format. See Interaction Dialer help for format details.
TelcordiaTPM | 10 | Telecordia TPM
TelcordiaTDS | 11 | Telecordia TDS
QuentinSager_Platinum | 13 | Quentin Sager Consulting (Platinum)
AreaCodesDotCom_Deluxe | 14 | areacodes.com Deluxe Area Codes Database
ZipcodeWorld_Premium | 15 | Zipcode World NPANXX data (Premium)
ZipcodeWorld_Gold | 16 | Zipcode World NPANXX data (Gold)

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


TimezoneMapDatasetTestResult Enumeration

[image]

IceLib Dialer Technical Reference
TimezoneMapDatasetTestResult Enumeration
See Also Send Feedback
Possible results returned from TimezoneMapDatasetTest(TimezoneMapDatasetFormat, String)

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum TimezoneMapDatasetTestResult
Visual Basic
Public Enumeration TimezoneMapDatasetTestResult

Members

Member name | Value | Description
Success | 0 | Mapping successful
UnknownError | 1 | Unknown Error
FileNotFound | 2 | File not found
FileUnreadable | 3 | File unreadable
BadFormat | 4 | Bad file format

See Also

ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Zone Class

[image]

IceLib Dialer Technical Reference
Zone Class
Members See Also Send Feedback
A collection of time slots representing a time zone. The slots determine when dialing is blocked for this time zone.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class Zone : IDeepCloneable
Visual Basic
Public Class Zone _
    Implements IDeepCloneable

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Configuration.Dialer.DataTypes..::..Zone

See Also

Zone Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Zone Members

[image] [image]

IceLib Dialer Technical Reference
Zone Members
Zone Class Constructors Methods Properties See Also Send Feedback

The Zone type exposes the following members.

Constructors

 | Name | Description
Public method | Zone | Creates a new instance of the Zone class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Name | The name of the time zone.
Public property | TimeSlots | The periods of time in which dialing is blocked for this zone.

See Also

Zone Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Zone Constructor

[image]

IceLib Dialer Technical Reference
Zone Constructor
Zone Class See Also Send Feedback
Creates a new instance of the Zone class.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Zone(
    string name
)
Visual Basic
Public Sub New ( _
    name As String _
)

Parameters

name
Type: System..::..String

See Also

Zone Class
Zone Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Zone Methods

[image] [image]

IceLib Dialer Technical Reference
Zone Methods
Zone Class See Also Send Feedback

The Zone type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Zone Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Zone Properties

[image] [image]

IceLib Dialer Technical Reference
Zone Properties
Zone Class See Also Send Feedback

The Zone type exposes the following members.

Properties

 | Name | Description
Public property | Name | The name of the time zone.
Public property | TimeSlots | The periods of time in which dialing is blocked for this zone.

See Also

Zone Class
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


Name Property

[image]

IceLib Dialer Technical Reference
Zone..::..Name Property
Zone Class See Also Send Feedback
The name of the time zone.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

See Also

Zone Class
Zone Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


TimeSlots Property

[image]

IceLib Dialer Technical Reference
Zone..::..TimeSlots Property
Zone Class See Also Send Feedback
The periods of time in which dialing is blocked for this zone.

Namespace: ININ.IceLib.Configuration.Dialer.DataTypes
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<TimeSlot> TimeSlots { get; private set; }
Visual Basic
Public Property TimeSlots As Collection(Of TimeSlot)
    Get
    Private Set

See Also

Zone Class
Zone Members
ININ.IceLib.Configuration.Dialer.DataTypes Namespace


ININ.IceLib.Dialer Namespace

[image]

IceLib Dialer Technical Reference
ININ.IceLib.Dialer Namespace
Send Feedback

The ININ.IceLib.Dialer namespace contains classes for accessing Interaction Center outbound dialing functionality.

There are a number of classes within the ININ.IceLib.Dialer namespace that provide support to the classes mentioned in the preceding summary. Examples of the supporting classes are enumerations, event argument classes, and delegates used by events within classes.

Campaign Monitoring. The DialingManager class has support for getting the list of available campaigns and for monitoring when campaigns start and stop. The DialerSession class also allows for receipt of Campaign transition events.

Dialer Agent Session Management. The DialingManager class allows for a Dialer Agent to be logged on to a DialerSession. The DialerSession class also allows for an Agent to request and receive events for going on Break or for logging out of their Dialer session or for setting them as Finishing Agents.

Dialer Call Handling. The DialerSession class allows for receipt of preview or predictive Dialer Interactions and for data pop events on those Interactions. The DialerCallInteraction class allows for Dialer Interactions to be updated with Stage information, updated with new Call Data, marked for Finishing work, and marked as completed. It also allows for the placement of Preview calls after data has been reviewed.

Note: This is supported for IC Server version 3.0 SU 1 and beyond.

Classes

 | Class | Description
Public class | AgentlessCallCompletionParameters | The parameters for an agentless call completion. Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | AutoLoginEventArgs | Provides data for the AutoLogin event. Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | AutoLogoutEventArgs | Provides data for the AutoLogout event. Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | BaseScriptDefinition | Contains configuration data for a base script. Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | BaseScriptPageDefinition | Contains configuration data for a single page in a base script. Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | BindRecordParameters | The parameters for binding an existing interaction to a Dialer contact record Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | BreakGrantedEventArgs | Provides data for the BreakGranted event. Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | CallCompletionParameters | The parameters for a call completion. Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | CampaignData | A container for several campaign properties. Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | CampaignId | Represents a unique identifier for a campaign, along with its display name. Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | CampaignScriptConfiguration | Contains configuration data for a campaign and its base script. Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | CampaignStartedEventArgs | Provides data for campaign started events. Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | CampaignStatLookup | Provides a mechanism for retrieving localized versions of values appearing in campaign statistic database entries. Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | CampaignStoppedEventArgs | Provides data for campaign stopped events. Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | CampaignTransistionEventArgs | Obsolete. Provides data for the CampaignTransition event. Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | ContactDataLoadedEventArgs | Provides data related to the ContactDataLoaded event Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | DataPopEventArgs | Provides data for the DataPop event. Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | DialerCallInteraction | Represents a Dialer call interaction. Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | DialerLogonFailedException | The exception that is thrown when a Dialer logon attempt fails Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | DialerSession | Represents an agent's login session to Dialer Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | DialingManager | Provides access to outbound dialing functionality. Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | GetAvailableCampaignsCompletedEventArgs | Provides data for the asynchronous completed events of DialingManager. Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | GetAvailableWorkflowsCompletedEventArgs | Obsolete. Provides data for the asynchronous completed events of DialingManager. Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | InvalidDialerCallInteractionException | The exception that is thrown when a dialing action is attempted on an invalid DialerCallInteraction Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | InvalidDialerSessionException | The exception that is thrown when an action is attempted on an invalid DialerSession. Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | LastTransitionData | An object to encapsulate the time of the last Active Rule group Transition and the name of the previous group. Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | LogonCompletedEventArgs | Provides data for the asynchronous completed events of DialingManager. Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | LogonParameters | The parameters for a logon request. Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | LogonResult | The result of a logon request. Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | LogoutGrantedEventArgs | Provides data for the LogoutGranted event. Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | ManualOutboundCallParameters | The parameters for manually initiating an outbound call Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | ManualOutboundCallStatusEventArgs | Provides data related to the ManualOutboundCallStatus event Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | PreviewCallAddedEventArgs | Provides data for the PreviewCallAdded event. Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | PreviewTimeoutExpiredEventArgs | Provides data related to the PreviewTimeoutExpired event Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | PreviewTimeoutStartedEventArgs | Provides data related to the PreviewTimeoutStarted event Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | PreviewTimeoutStoppedEventArgs | Provides data related to the PreviewTimeoutStopped event Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | SwitchoverPair | The names of the primary and backup servers Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | TransitionParameters | Obsolete. The parameters for a campaign transition. Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | WorkflowStartedEventArgs | Obsolete. Provides data for the WorkflowStarted event. Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public class | WorkflowStoppedEventArgs | Obsolete. Provides data for the WorkflowStopped event. Note: This is supported for IC Server version 3.0 SU 1 and beyond.

Enumerations

 | Enumeration | Description
Public enumeration | AgentType | Specifies constants indicating the type of agent. Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public enumeration | BreakStatus | Possible break statuses. Note: This is supported for IC Server version 3.0 SU 1 and beyond.
Public enumeration | DialingMode | Specifies constants indicating the dialing mode for a DialerCallInteraction. Note: This is supported for IC Server version 3.0 SU 1 and beyond.


AgentlessCallCompletionParameters Class

[image]

IceLib Dialer Technical Reference
AgentlessCallCompletionParameters Class
Members See Also Send Feedback
The parameters for an agentless call completion.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class AgentlessCallCompletionParameters
Visual Basic
Public Class AgentlessCallCompletionParameters

Remarks

These parameters are used when calling the AgentlessCallComplete(AgentlessCallCompletionParameters) method.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Dialer..::..AgentlessCallCompletionParameters

See Also

AgentlessCallCompletionParameters Members
ININ.IceLib.Dialer Namespace


AgentlessCallCompletionParameters Members

[image] [image]

IceLib Dialer Technical Reference
AgentlessCallCompletionParameters Members
AgentlessCallCompletionParameters Class Methods Properties See Also Send Feedback

The AgentlessCallCompletionParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Renders this object to a string using the default format. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CampaignName | Gets or sets the campaign name for the call.
Public property | interactionId | Gets or sets the interaction for the call.
Public property | WorkflowName | Obsolete. Gets or sets the workflow name for the call.
Public property | WrapupCode | Gets or sets the wrapup code for the call.

See Also

AgentlessCallCompletionParameters Class
ININ.IceLib.Dialer Namespace


AgentlessCallCompletionParameters Methods

[image] [image]

IceLib Dialer Technical Reference
AgentlessCallCompletionParameters Methods
AgentlessCallCompletionParameters Class See Also Send Feedback

The AgentlessCallCompletionParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Renders this object to a string using the default format. (Overrides Object..::..ToString()()()().)

See Also

AgentlessCallCompletionParameters Class
ININ.IceLib.Dialer Namespace


ToString Method

[image]

IceLib Dialer Technical Reference
AgentlessCallCompletionParameters..::..ToString Method
AgentlessCallCompletionParameters Class See Also Send Feedback
Renders this object to a string using the default format.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

the string representation

See Also

AgentlessCallCompletionParameters Class
AgentlessCallCompletionParameters Members
ININ.IceLib.Dialer Namespace


AgentlessCallCompletionParameters Properties

[image] [image]

IceLib Dialer Technical Reference
AgentlessCallCompletionParameters Properties
AgentlessCallCompletionParameters Class See Also Send Feedback

The AgentlessCallCompletionParameters type exposes the following members.

Properties

 | Name | Description
Public property | CampaignName | Gets or sets the campaign name for the call.
Public property | interactionId | Gets or sets the interaction for the call.
Public property | WorkflowName | Obsolete. Gets or sets the workflow name for the call.
Public property | WrapupCode | Gets or sets the wrapup code for the call.

See Also

AgentlessCallCompletionParameters Class
ININ.IceLib.Dialer Namespace


CampaignName Property

[image]

IceLib Dialer Technical Reference
AgentlessCallCompletionParameters..::..CampaignName Property
AgentlessCallCompletionParameters Class See Also Send Feedback
Gets or sets the campaign name for the call.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string CampaignName { get; set; }
Visual Basic
Public Property CampaignName As String
    Get
    Set

Field Value

The campaign name.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

See Also

AgentlessCallCompletionParameters Class
AgentlessCallCompletionParameters Members
ININ.IceLib.Dialer Namespace


interactionId Property

[image]

IceLib Dialer Technical Reference
AgentlessCallCompletionParameters..::..interactionId Property
AgentlessCallCompletionParameters Class See Also Send Feedback
Gets or sets the interaction for the call.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public InteractionId interactionId { get; set; }
Visual Basic
Public Property interactionId As InteractionId
    Get
    Set

Field Value

The interaction.

See Also

AgentlessCallCompletionParameters Class
AgentlessCallCompletionParameters Members
ININ.IceLib.Dialer Namespace


WorkflowName Property

[image]

IceLib Dialer Technical Reference
AgentlessCallCompletionParameters..::..WorkflowName Property
AgentlessCallCompletionParameters Class See Also Send Feedback
Gets or sets the workflow name for the call.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
[ObsoleteAttribute("Worklfows no longer exist")]
public string WorkflowName { get; set; }
Visual Basic
<ObsoleteAttribute("Worklfows no longer exist")> _
Public Property WorkflowName As String
    Get
    Set

Field Value

The workflow name.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

See Also

AgentlessCallCompletionParameters Class
AgentlessCallCompletionParameters Members
ININ.IceLib.Dialer Namespace


WrapupCode Property

[image]

IceLib Dialer Technical Reference
AgentlessCallCompletionParameters..::..WrapupCode Property
AgentlessCallCompletionParameters Class See Also Send Feedback
Gets or sets the wrapup code for the call.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string WrapupCode { get; set; }
Visual Basic
Public Property WrapupCode As String
    Get
    Set

Field Value

The wrapup code.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

See Also

AgentlessCallCompletionParameters Class
AgentlessCallCompletionParameters Members
ININ.IceLib.Dialer Namespace


AgentType Enumeration

[image]

IceLib Dialer Technical Reference
AgentType Enumeration
See Also Send Feedback
Specifies constants indicating the type of agent.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum AgentType
Visual Basic
Public Enumeration AgentType

Members

Member name | Value | Description
Regular | 1 | A regular agent.
Finishing | 2 | A finishing agent.
Composite | 3 | A regular agent that is also a finishing agent.

See Also

ININ.IceLib.Dialer Namespace


AutoLoginEventArgs Class

[image]

IceLib Dialer Technical Reference
AutoLoginEventArgs Class
Members See Also Send Feedback
Provides data for the AutoLogin event.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class AutoLoginEventArgs : EventArgs
Visual Basic
Public Class AutoLoginEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Dialer..::..AutoLoginEventArgs

See Also

AutoLoginEventArgs Members
ININ.IceLib.Dialer Namespace


AutoLoginEventArgs Members

[image] [image]

IceLib Dialer Technical Reference
AutoLoginEventArgs Members
AutoLoginEventArgs Class Methods Properties See Also Send Feedback

The AutoLoginEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | LogonResult | The result of the automatic login.

See Also

AutoLoginEventArgs Class
ININ.IceLib.Dialer Namespace


AutoLoginEventArgs Methods

[image] [image]

IceLib Dialer Technical Reference
AutoLoginEventArgs Methods
AutoLoginEventArgs Class See Also Send Feedback

The AutoLoginEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AutoLoginEventArgs Class
ININ.IceLib.Dialer Namespace


AutoLoginEventArgs Properties

[image] [image]

IceLib Dialer Technical Reference
AutoLoginEventArgs Properties
AutoLoginEventArgs Class See Also Send Feedback

The AutoLoginEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | LogonResult | The result of the automatic login.

See Also

AutoLoginEventArgs Class
ININ.IceLib.Dialer Namespace


LogonResult Property

[image]

IceLib Dialer Technical Reference
AutoLoginEventArgs..::..LogonResult Property
AutoLoginEventArgs Class See Also Send Feedback
The result of the automatic login.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public LogonResult LogonResult { get; private set; }
Visual Basic
Public Property LogonResult As LogonResult
    Get
    Private Set

See Also

AutoLoginEventArgs Class
AutoLoginEventArgs Members
ININ.IceLib.Dialer Namespace


AutoLogoutEventArgs Class

[image]

IceLib Dialer Technical Reference
AutoLogoutEventArgs Class
Members See Also Send Feedback
Provides data for the AutoLogout event.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class AutoLogoutEventArgs : EventArgs
Visual Basic
Public Class AutoLogoutEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Dialer..::..AutoLogoutEventArgs

See Also

AutoLogoutEventArgs Members
ININ.IceLib.Dialer Namespace


AutoLogoutEventArgs Members

[image] [image]

IceLib Dialer Technical Reference
AutoLogoutEventArgs Members
AutoLogoutEventArgs Class Methods Properties See Also Send Feedback

The AutoLogoutEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Campaigns | The campaigns that the agent was logged out of.
Public property | Initiator | The name of the user or rule that initiated the logout(s).

See Also

AutoLogoutEventArgs Class
ININ.IceLib.Dialer Namespace


AutoLogoutEventArgs Methods

[image] [image]

IceLib Dialer Technical Reference
AutoLogoutEventArgs Methods
AutoLogoutEventArgs Class See Also Send Feedback

The AutoLogoutEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AutoLogoutEventArgs Class
ININ.IceLib.Dialer Namespace


AutoLogoutEventArgs Properties

[image] [image]

IceLib Dialer Technical Reference
AutoLogoutEventArgs Properties
AutoLogoutEventArgs Class See Also Send Feedback

The AutoLogoutEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Campaigns | The campaigns that the agent was logged out of.
Public property | Initiator | The name of the user or rule that initiated the logout(s).

See Also

AutoLogoutEventArgs Class
ININ.IceLib.Dialer Namespace


Campaigns Property

[image]

IceLib Dialer Technical Reference
AutoLogoutEventArgs..::..Campaigns Property
AutoLogoutEventArgs Class See Also Send Feedback
The campaigns that the agent was logged out of.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public IEnumerable<CampaignId> Campaigns { get; private set; }
Visual Basic
Public Property Campaigns As IEnumerable(Of CampaignId)
    Get
    Private Set

See Also

AutoLogoutEventArgs Class
AutoLogoutEventArgs Members
ININ.IceLib.Dialer Namespace


Initiator Property

[image]

IceLib Dialer Technical Reference
AutoLogoutEventArgs..::..Initiator Property
AutoLogoutEventArgs Class See Also Send Feedback
The name of the user or rule that initiated the logout(s).

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Initiator { get; private set; }
Visual Basic
Public Property Initiator As String
    Get
    Private Set

See Also

AutoLogoutEventArgs Class
AutoLogoutEventArgs Members
ININ.IceLib.Dialer Namespace


BaseScriptDefinition Class

[image]

IceLib Dialer Technical Reference
BaseScriptDefinition Class
Members See Also Send Feedback
Contains configuration data for a base script.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class BaseScriptDefinition
Visual Basic
Public Class BaseScriptDefinition

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Dialer..::..BaseScriptDefinition

See Also

BaseScriptDefinition Members
ININ.IceLib.Dialer Namespace


BaseScriptDefinition Members

[image] [image]

IceLib Dialer Technical Reference
BaseScriptDefinition Members
BaseScriptDefinition Class Methods Properties See Also Send Feedback

The BaseScriptDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AllowAgentOwnedCallbacks | Determines whether agents have the option to schedule calls as agent-owned callbacks.
Public property | AllowAgentsAdditionalCalls | Determines whether agents can place calls to additional phone numbers
Public property | AllowEditingOfNumberToDial | Allow agents to edit the phone number of a Preview call before it is dialed.
Public property | AllowEditingPhoneNumbers | Determines whether agents can edit additional phone numbers
Public property | AllowSchedulePhoneNumber | Allow agents to specify the callback number when scheduling a call
Public property | AutomaticallyDisconnectOnDisposition | Disconnect the call automatically once a call disposition button is clicked.
Public property | DisplayBreakButton | Show a button that allows agents to take a break.
Public property | DisplayPreviewSkipButton | Show a button that allows agents to skip a preview call.
Public property | Pages | The list of pages contained in the script.
Public property | PermitOverrideDailyLimitCheck | Determines whether agents can override the dialy limit check for additional numbers
Public property | PermitOverrideDNCCheck | Determines whether agents can override the DNC check for additional numbers
Public property | PermitOverrideSkillsCheck | Determines whether agents can override the skills check for additional numbers
Public property | PermitOverrideTimeZoneCheck | Determines whether agents can override the timezone check for additional numbers
Public property | PickupAlertingCalls | Specifies whether alerting calls will be automatically picked up.
Public property | Use24HourTimeFormat | Specifies whether to use 24-hour (military) time.

See Also

BaseScriptDefinition Class
ININ.IceLib.Dialer Namespace


BaseScriptDefinition Methods

[image] [image]

IceLib Dialer Technical Reference
BaseScriptDefinition Methods
BaseScriptDefinition Class See Also Send Feedback

The BaseScriptDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseScriptDefinition Class
ININ.IceLib.Dialer Namespace


BaseScriptDefinition Properties

[image] [image]

IceLib Dialer Technical Reference
BaseScriptDefinition Properties
BaseScriptDefinition Class See Also Send Feedback

The BaseScriptDefinition type exposes the following members.

Properties

 | Name | Description
Public property | AllowAgentOwnedCallbacks | Determines whether agents have the option to schedule calls as agent-owned callbacks.
Public property | AllowAgentsAdditionalCalls | Determines whether agents can place calls to additional phone numbers
Public property | AllowEditingOfNumberToDial | Allow agents to edit the phone number of a Preview call before it is dialed.
Public property | AllowEditingPhoneNumbers | Determines whether agents can edit additional phone numbers
Public property | AllowSchedulePhoneNumber | Allow agents to specify the callback number when scheduling a call
Public property | AutomaticallyDisconnectOnDisposition | Disconnect the call automatically once a call disposition button is clicked.
Public property | DisplayBreakButton | Show a button that allows agents to take a break.
Public property | DisplayPreviewSkipButton | Show a button that allows agents to skip a preview call.
Public property | Pages | The list of pages contained in the script.
Public property | PermitOverrideDailyLimitCheck | Determines whether agents can override the dialy limit check for additional numbers
Public property | PermitOverrideDNCCheck | Determines whether agents can override the DNC check for additional numbers
Public property | PermitOverrideSkillsCheck | Determines whether agents can override the skills check for additional numbers
Public property | PermitOverrideTimeZoneCheck | Determines whether agents can override the timezone check for additional numbers
Public property | PickupAlertingCalls | Specifies whether alerting calls will be automatically picked up.
Public property | Use24HourTimeFormat | Specifies whether to use 24-hour (military) time.

See Also

BaseScriptDefinition Class
ININ.IceLib.Dialer Namespace


AllowAgentOwnedCallbacks Property

[image]

IceLib Dialer Technical Reference
BaseScriptDefinition..::..AllowAgentOwnedCallbacks Property
BaseScriptDefinition Class See Also Send Feedback
Determines whether agents have the option to schedule calls as agent-owned callbacks.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool AllowAgentOwnedCallbacks { get; private set; }
Visual Basic
Public Property AllowAgentOwnedCallbacks As Boolean
    Get
    Private Set

See Also

BaseScriptDefinition Class
BaseScriptDefinition Members
ININ.IceLib.Dialer Namespace


AllowAgentsAdditionalCalls Property

[image]

IceLib Dialer Technical Reference
BaseScriptDefinition..::..AllowAgentsAdditionalCalls Property
BaseScriptDefinition Class See Also Send Feedback
Determines whether agents can place calls to additional phone numbers

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool AllowAgentsAdditionalCalls { get; set; }
Visual Basic
Public Property AllowAgentsAdditionalCalls As Boolean
    Get
    Set

See Also

BaseScriptDefinition Class
BaseScriptDefinition Members
ININ.IceLib.Dialer Namespace


AllowEditingOfNumberToDial Property

[image]

IceLib Dialer Technical Reference
BaseScriptDefinition..::..AllowEditingOfNumberToDial Property
BaseScriptDefinition Class See Also Send Feedback
Allow agents to edit the phone number of a Preview call before it is dialed.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool AllowEditingOfNumberToDial { get; private set; }
Visual Basic
Public Property AllowEditingOfNumberToDial As Boolean
    Get
    Private Set

See Also

BaseScriptDefinition Class
BaseScriptDefinition Members
ININ.IceLib.Dialer Namespace


AllowEditingPhoneNumbers Property

[image]

IceLib Dialer Technical Reference
BaseScriptDefinition..::..AllowEditingPhoneNumbers Property
BaseScriptDefinition Class See Also Send Feedback
Determines whether agents can edit additional phone numbers

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool AllowEditingPhoneNumbers { get; set; }
Visual Basic
Public Property AllowEditingPhoneNumbers As Boolean
    Get
    Set

See Also

BaseScriptDefinition Class
BaseScriptDefinition Members
ININ.IceLib.Dialer Namespace


AllowSchedulePhoneNumber Property

[image]

IceLib Dialer Technical Reference
BaseScriptDefinition..::..AllowSchedulePhoneNumber Property
BaseScriptDefinition Class See Also Send Feedback
Allow agents to specify the callback number when scheduling a call

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool AllowSchedulePhoneNumber { get; private set; }
Visual Basic
Public Property AllowSchedulePhoneNumber As Boolean
    Get
    Private Set

See Also

BaseScriptDefinition Class
BaseScriptDefinition Members
ININ.IceLib.Dialer Namespace


AutomaticallyDisconnectOnDisposition Property

[image]

IceLib Dialer Technical Reference
BaseScriptDefinition..::..AutomaticallyDisconnectOnDisposition Property
BaseScriptDefinition Class See Also Send Feedback
Disconnect the call automatically once a call disposition button is clicked.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool AutomaticallyDisconnectOnDisposition { get; private set; }
Visual Basic
Public Property AutomaticallyDisconnectOnDisposition As Boolean
    Get
    Private Set

See Also

BaseScriptDefinition Class
BaseScriptDefinition Members
ININ.IceLib.Dialer Namespace


DisplayBreakButton Property

[image]

IceLib Dialer Technical Reference
BaseScriptDefinition..::..DisplayBreakButton Property
BaseScriptDefinition Class See Also Send Feedback
Show a button that allows agents to take a break.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool DisplayBreakButton { get; private set; }
Visual Basic
Public Property DisplayBreakButton As Boolean
    Get
    Private Set

See Also

BaseScriptDefinition Class
BaseScriptDefinition Members
ININ.IceLib.Dialer Namespace


DisplayPreviewSkipButton Property

[image]

IceLib Dialer Technical Reference
BaseScriptDefinition..::..DisplayPreviewSkipButton Property
BaseScriptDefinition Class See Also Send Feedback
Show a button that allows agents to skip a preview call.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool DisplayPreviewSkipButton { get; private set; }
Visual Basic
Public Property DisplayPreviewSkipButton As Boolean
    Get
    Private Set

See Also

BaseScriptDefinition Class
BaseScriptDefinition Members
ININ.IceLib.Dialer Namespace


Pages Property

[image]

IceLib Dialer Technical Reference
BaseScriptDefinition..::..Pages Property
BaseScriptDefinition Class See Also Send Feedback
The list of pages contained in the script.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ReadOnlyCollection<BaseScriptPageDefinition> Pages { get; }
Visual Basic
Public ReadOnly Property Pages As ReadOnlyCollection(Of BaseScriptPageDefinition)
    Get

See Also

BaseScriptDefinition Class
BaseScriptDefinition Members
ININ.IceLib.Dialer Namespace


PermitOverrideDailyLimitCheck Property

[image]

IceLib Dialer Technical Reference
BaseScriptDefinition..::..PermitOverrideDailyLimitCheck Property
BaseScriptDefinition Class See Also Send Feedback
Determines whether agents can override the dialy limit check for additional numbers

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool PermitOverrideDailyLimitCheck { get; set; }
Visual Basic
Public Property PermitOverrideDailyLimitCheck As Boolean
    Get
    Set

See Also

BaseScriptDefinition Class
BaseScriptDefinition Members
ININ.IceLib.Dialer Namespace


PermitOverrideDNCCheck Property

[image]

IceLib Dialer Technical Reference
BaseScriptDefinition..::..PermitOverrideDNCCheck Property
BaseScriptDefinition Class See Also Send Feedback
Determines whether agents can override the DNC check for additional numbers

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool PermitOverrideDNCCheck { get; set; }
Visual Basic
Public Property PermitOverrideDNCCheck As Boolean
    Get
    Set

See Also

BaseScriptDefinition Class
BaseScriptDefinition Members
ININ.IceLib.Dialer Namespace


PermitOverrideSkillsCheck Property

[image]

IceLib Dialer Technical Reference
BaseScriptDefinition..::..PermitOverrideSkillsCheck Property
BaseScriptDefinition Class See Also Send Feedback
Determines whether agents can override the skills check for additional numbers

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool PermitOverrideSkillsCheck { get; set; }
Visual Basic
Public Property PermitOverrideSkillsCheck As Boolean
    Get
    Set

See Also

BaseScriptDefinition Class
BaseScriptDefinition Members
ININ.IceLib.Dialer Namespace


PermitOverrideTimeZoneCheck Property

[image]

IceLib Dialer Technical Reference
BaseScriptDefinition..::..PermitOverrideTimeZoneCheck Property
BaseScriptDefinition Class See Also Send Feedback
Determines whether agents can override the timezone check for additional numbers

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool PermitOverrideTimeZoneCheck { get; set; }
Visual Basic
Public Property PermitOverrideTimeZoneCheck As Boolean
    Get
    Set

See Also

BaseScriptDefinition Class
BaseScriptDefinition Members
ININ.IceLib.Dialer Namespace


PickupAlertingCalls Property

[image]

IceLib Dialer Technical Reference
BaseScriptDefinition..::..PickupAlertingCalls Property
BaseScriptDefinition Class See Also Send Feedback
Specifies whether alerting calls will be automatically picked up.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool PickupAlertingCalls { get; private set; }
Visual Basic
Public Property PickupAlertingCalls As Boolean
    Get
    Private Set

See Also

BaseScriptDefinition Class
BaseScriptDefinition Members
ININ.IceLib.Dialer Namespace


Use24HourTimeFormat Property

[image]

IceLib Dialer Technical Reference
BaseScriptDefinition..::..Use24HourTimeFormat Property
BaseScriptDefinition Class See Also Send Feedback
Specifies whether to use 24-hour (military) time.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool Use24HourTimeFormat { get; private set; }
Visual Basic
Public Property Use24HourTimeFormat As Boolean
    Get
    Private Set

See Also

BaseScriptDefinition Class
BaseScriptDefinition Members
ININ.IceLib.Dialer Namespace


BaseScriptPageDefinition Class

[image]

IceLib Dialer Technical Reference
BaseScriptPageDefinition Class
Members See Also Send Feedback
Contains configuration data for a single page in a base script.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class BaseScriptPageDefinition
Visual Basic
Public Class BaseScriptPageDefinition

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Dialer..::..BaseScriptPageDefinition

See Also

BaseScriptPageDefinition Members
ININ.IceLib.Dialer Namespace


BaseScriptPageDefinition Members

[image] [image]

IceLib Dialer Technical Reference
BaseScriptPageDefinition Members
BaseScriptPageDefinition Class Methods Properties See Also Send Feedback

The BaseScriptPageDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BackgroundColor | The page's background color.
Public property | Controls | The collection of user interface controls displayed on the page.
Public property | Dispositions | The collection of dispositions that may be applied to the call.
Public property | ForegroundColor | The page's foreground color.
Public property | Name | The name of the page.
Public property | Stage | The number of the call stage corresponding to this script page.
Public property | StaticText | Read-only text appearing on the page, typically used to assist the agent. May contain plain text, macros, and/or HTML tags.

See Also

BaseScriptPageDefinition Class
ININ.IceLib.Dialer Namespace


BaseScriptPageDefinition Methods

[image] [image]

IceLib Dialer Technical Reference
BaseScriptPageDefinition Methods
BaseScriptPageDefinition Class See Also Send Feedback

The BaseScriptPageDefinition type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseScriptPageDefinition Class
ININ.IceLib.Dialer Namespace


BaseScriptPageDefinition Properties

[image] [image]

IceLib Dialer Technical Reference
BaseScriptPageDefinition Properties
BaseScriptPageDefinition Class See Also Send Feedback

The BaseScriptPageDefinition type exposes the following members.

Properties

 | Name | Description
Public property | BackgroundColor | The page's background color.
Public property | Controls | The collection of user interface controls displayed on the page.
Public property | Dispositions | The collection of dispositions that may be applied to the call.
Public property | ForegroundColor | The page's foreground color.
Public property | Name | The name of the page.
Public property | Stage | The number of the call stage corresponding to this script page.
Public property | StaticText | Read-only text appearing on the page, typically used to assist the agent. May contain plain text, macros, and/or HTML tags.

See Also

BaseScriptPageDefinition Class
ININ.IceLib.Dialer Namespace


BackgroundColor Property

[image]

IceLib Dialer Technical Reference
BaseScriptPageDefinition..::..BackgroundColor Property
BaseScriptPageDefinition Class See Also Send Feedback
The page's background color.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Color BackgroundColor { get; private set; }
Visual Basic
Public Property BackgroundColor As Color
    Get
    Private Set

See Also

BaseScriptPageDefinition Class
BaseScriptPageDefinition Members
ININ.IceLib.Dialer Namespace


Controls Property

[image]

IceLib Dialer Technical Reference
BaseScriptPageDefinition..::..Controls Property
BaseScriptPageDefinition Class See Also Send Feedback
The collection of user interface controls displayed on the page.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ReadOnlyCollection<BaseScriptControl> Controls { get; private set; }
Visual Basic
Public Property Controls As ReadOnlyCollection(Of BaseScriptControl)
    Get
    Private Set

See Also

BaseScriptPageDefinition Class
BaseScriptPageDefinition Members
ININ.IceLib.Dialer Namespace


Dispositions Property

[image]

IceLib Dialer Technical Reference
BaseScriptPageDefinition..::..Dispositions Property
BaseScriptPageDefinition Class See Also Send Feedback
The collection of dispositions that may be applied to the call.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ReadOnlyCollection<BaseScriptDispositionBase> Dispositions { get; private set; }
Visual Basic
Public Property Dispositions As ReadOnlyCollection(Of BaseScriptDispositionBase)
    Get
    Private Set

See Also

BaseScriptPageDefinition Class
BaseScriptPageDefinition Members
ININ.IceLib.Dialer Namespace


ForegroundColor Property

[image]

IceLib Dialer Technical Reference
BaseScriptPageDefinition..::..ForegroundColor Property
BaseScriptPageDefinition Class See Also Send Feedback
The page's foreground color.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Color ForegroundColor { get; private set; }
Visual Basic
Public Property ForegroundColor As Color
    Get
    Private Set

See Also

BaseScriptPageDefinition Class
BaseScriptPageDefinition Members
ININ.IceLib.Dialer Namespace


Name Property

[image]

IceLib Dialer Technical Reference
BaseScriptPageDefinition..::..Name Property
BaseScriptPageDefinition Class See Also Send Feedback
The name of the page.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Name { get; private set; }
Visual Basic
Public Property Name As String
    Get
    Private Set

See Also

BaseScriptPageDefinition Class
BaseScriptPageDefinition Members
ININ.IceLib.Dialer Namespace


Stage Property

[image]

IceLib Dialer Technical Reference
BaseScriptPageDefinition..::..Stage Property
BaseScriptPageDefinition Class See Also Send Feedback
The number of the call stage corresponding to this script page.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int Stage { get; private set; }
Visual Basic
Public Property Stage As Integer
    Get
    Private Set

See Also

BaseScriptPageDefinition Class
BaseScriptPageDefinition Members
ININ.IceLib.Dialer Namespace


StaticText Property

[image]

IceLib Dialer Technical Reference
BaseScriptPageDefinition..::..StaticText Property
BaseScriptPageDefinition Class See Also Send Feedback
Read-only text appearing on the page, typically used to assist the agent. May contain plain text, macros, and/or HTML tags.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string StaticText { get; private set; }
Visual Basic
Public Property StaticText As String
    Get
    Private Set

See Also

BaseScriptPageDefinition Class
BaseScriptPageDefinition Members
ININ.IceLib.Dialer Namespace


BindRecordParameters Class

[image]

IceLib Dialer Technical Reference
BindRecordParameters Class
Members See Also Send Feedback
The parameters for binding an existing interaction to a Dialer contact record

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class BindRecordParameters
Visual Basic
Public Class BindRecordParameters

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Dialer..::..BindRecordParameters

See Also

BindRecordParameters Members
ININ.IceLib.Dialer Namespace
DialerSession..::..BindRecord(BindRecordParameters)


BindRecordParameters Members

[image] [image]

IceLib Dialer Technical Reference
BindRecordParameters Members
BindRecordParameters Class Constructors Methods Properties See Also Send Feedback

The BindRecordParameters type exposes the following members.

Constructors

 | Name | Description
Public method | BindRecordParameters | Initializes a new instance of the BindRecordParameters class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Call | The existing, connected interaction that will attempt to be bound to a Dialer contact record
Public property | Campaign | The campaign to which the contact record belongs
Public property | ContactColumnId | An optional contact column id to associate with the bound contact
Public property | Identity | The I3_Identity of the contact record

See Also

BindRecordParameters Class
ININ.IceLib.Dialer Namespace


BindRecordParameters Constructor

[image]

IceLib Dialer Technical Reference
BindRecordParameters Constructor
BindRecordParameters Class See Also Send Feedback
Initializes a new instance of the BindRecordParameters class

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public BindRecordParameters()
Visual Basic
Public Sub New

See Also

BindRecordParameters Class
BindRecordParameters Members
ININ.IceLib.Dialer Namespace


BindRecordParameters Methods

[image] [image]

IceLib Dialer Technical Reference
BindRecordParameters Methods
BindRecordParameters Class See Also Send Feedback

The BindRecordParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BindRecordParameters Class
ININ.IceLib.Dialer Namespace


BindRecordParameters Properties

[image] [image]

IceLib Dialer Technical Reference
BindRecordParameters Properties
BindRecordParameters Class See Also Send Feedback

The BindRecordParameters type exposes the following members.

Properties

 | Name | Description
Public property | Call | The existing, connected interaction that will attempt to be bound to a Dialer contact record
Public property | Campaign | The campaign to which the contact record belongs
Public property | ContactColumnId | An optional contact column id to associate with the bound contact
Public property | Identity | The I3_Identity of the contact record

See Also

BindRecordParameters Class
ININ.IceLib.Dialer Namespace


Call Property

[image]

IceLib Dialer Technical Reference
BindRecordParameters..::..Call Property
BindRecordParameters Class See Also Send Feedback
The existing, connected interaction that will attempt to be bound to a Dialer contact record

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CallInteraction Call { get; set; }
Visual Basic
Public Property Call As CallInteraction
    Get
    Set

See Also

BindRecordParameters Class
BindRecordParameters Members
ININ.IceLib.Dialer Namespace


Campaign Property

[image]

IceLib Dialer Technical Reference
BindRecordParameters..::..Campaign Property
BindRecordParameters Class See Also Send Feedback
The campaign to which the contact record belongs

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CampaignId Campaign { get; set; }
Visual Basic
Public Property Campaign As CampaignId
    Get
    Set

See Also

BindRecordParameters Class
BindRecordParameters Members
ININ.IceLib.Dialer Namespace


ContactColumnId Property

[image]

IceLib Dialer Technical Reference
BindRecordParameters..::..ContactColumnId Property
BindRecordParameters Class See Also Send Feedback
An optional contact column id to associate with the bound contact

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Nullable<long> ContactColumnId { get; set; }
Visual Basic
Public Property ContactColumnId As Nullable(Of Long)
    Get
    Set

See Also

BindRecordParameters Class
BindRecordParameters Members
ININ.IceLib.Dialer Namespace


Identity Property

[image]

IceLib Dialer Technical Reference
BindRecordParameters..::..Identity Property
BindRecordParameters Class See Also Send Feedback
The I3_Identity of the contact record

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public long Identity { get; set; }
Visual Basic
Public Property Identity As Long
    Get
    Set

See Also

BindRecordParameters Class
BindRecordParameters Members
ININ.IceLib.Dialer Namespace


BreakGrantedEventArgs Class

[image]

IceLib Dialer Technical Reference
BreakGrantedEventArgs Class
Members See Also Send Feedback
Provides data for the BreakGranted event.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class BreakGrantedEventArgs : EventArgs
Visual Basic
Public Class BreakGrantedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Dialer..::..BreakGrantedEventArgs

See Also

BreakGrantedEventArgs Members
ININ.IceLib.Dialer Namespace


BreakGrantedEventArgs Members

[image] [image]

IceLib Dialer Technical Reference
BreakGrantedEventArgs Members
BreakGrantedEventArgs Class Methods Properties See Also Send Feedback

The BreakGrantedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Campaign | The campaign for which the break was granted.

See Also

BreakGrantedEventArgs Class
ININ.IceLib.Dialer Namespace


BreakGrantedEventArgs Methods

[image] [image]

IceLib Dialer Technical Reference
BreakGrantedEventArgs Methods
BreakGrantedEventArgs Class See Also Send Feedback

The BreakGrantedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BreakGrantedEventArgs Class
ININ.IceLib.Dialer Namespace


BreakGrantedEventArgs Properties

[image] [image]

IceLib Dialer Technical Reference
BreakGrantedEventArgs Properties
BreakGrantedEventArgs Class See Also Send Feedback

The BreakGrantedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Campaign | The campaign for which the break was granted.

See Also

BreakGrantedEventArgs Class
ININ.IceLib.Dialer Namespace


Campaign Property

[image]

IceLib Dialer Technical Reference
BreakGrantedEventArgs..::..Campaign Property
BreakGrantedEventArgs Class See Also Send Feedback
The campaign for which the break was granted.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CampaignId Campaign { get; private set; }
Visual Basic
Public Property Campaign As CampaignId
    Get
    Private Set

See Also

BreakGrantedEventArgs Class
BreakGrantedEventArgs Members
ININ.IceLib.Dialer Namespace


BreakStatus Enumeration

[image]

IceLib Dialer Technical Reference
BreakStatus Enumeration
See Also Send Feedback
Possible break statuses.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum BreakStatus
Visual Basic
Public Enumeration BreakStatus

Members

Member name | Value | Description
NotOnBreak | 0 | Agent is not on break.
BreakPending | 1 | Agent has requested a break and is waiting for the system to approve.
OnBreak | 2 | Agent is on break
NotLoggedIn | 3 | Agent is not Logged into a campaign

See Also

ININ.IceLib.Dialer Namespace


CallCompletionParameters Class

[image]

IceLib Dialer Technical Reference
CallCompletionParameters Class
Members See Also Send Feedback
The parameters for a call completion.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class CallCompletionParameters
Visual Basic
Public Class CallCompletionParameters

Remarks

These parameters are used when calling the CallComplete(CallCompletionParameters) method.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Dialer..::..CallCompletionParameters

See Also

CallCompletionParameters Members
ININ.IceLib.Dialer Namespace


CallCompletionParameters Members

[image] [image]

IceLib Dialer Technical Reference
CallCompletionParameters Members
CallCompletionParameters Class Constructors Methods Properties See Also Send Feedback

The CallCompletionParameters type exposes the following members.

Constructors

 | Name | Description
Public method | CallCompletionParameters(String) | Initializes a new instance of the CallCompletionParameters class.
Public method | CallCompletionParameters(String, Boolean) | Initializes a new instance of the CallCompletionParameters class.
Public method | CallCompletionParameters(String, DateTime, String, Boolean) | Initializes a new instance of the CallCompletionParameters class.
Public method | CallCompletionParameters(String, DateTime, String, Boolean, TimeReference) | Initializes a new instance of the CallCompletionParameters class.
Public method | CallCompletionParameters(String, DateTime, String, Boolean, Boolean) | Initializes a new instance of the CallCompletionParameters class.
Public method | CallCompletionParameters(String, DateTime, String, Boolean, TimeReference, Boolean) | Initializes a new instance of the CallCompletionParameters class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current CallCompletionParameters. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | IsCallAbandoned | Gets or sets a value indicating whether the call was abandoned.
Public property | MakeFollowUpCall | Determines if the user wanted to make a follow up call after dispositioning the current call.
Public property | RelativeTo | Determines how ScheduledTime is interpreted.
Public property | ScheduledAgent | Gets or sets the agent who should receive the call, for agent-owned callbacks.
Public property | ScheduledTime | Gets or sets the time of the callback, for scheduled calls.
Public property | WrapupCode | Gets or sets the wrapup code for the call.

See Also

CallCompletionParameters Class
ININ.IceLib.Dialer Namespace


CallCompletionParameters Constructor

[image] [image]

IceLib Dialer Technical Reference
CallCompletionParameters Constructor
CallCompletionParameters Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CallCompletionParameters(String) | Initializes a new instance of the CallCompletionParameters class.
Public method | CallCompletionParameters(String, Boolean) | Initializes a new instance of the CallCompletionParameters class.
Public method | CallCompletionParameters(String, DateTime, String, Boolean) | Initializes a new instance of the CallCompletionParameters class.
Public method | CallCompletionParameters(String, DateTime, String, Boolean, TimeReference) | Initializes a new instance of the CallCompletionParameters class.
Public method | CallCompletionParameters(String, DateTime, String, Boolean, Boolean) | Initializes a new instance of the CallCompletionParameters class.
Public method | CallCompletionParameters(String, DateTime, String, Boolean, TimeReference, Boolean) | Initializes a new instance of the CallCompletionParameters class.

See Also

CallCompletionParameters Class
CallCompletionParameters Members
ININ.IceLib.Dialer Namespace


CallCompletionParameters Constructor (String)

[image]

IceLib Dialer Technical Reference
CallCompletionParameters Constructor (String)
CallCompletionParameters Class See Also Send Feedback
Initializes a new instance of the CallCompletionParameters class.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CallCompletionParameters(
    string wrapupCode
)
Visual Basic
Public Sub New ( _
    wrapupCode As String _
)

Parameters

wrapupCode
Type: System..::..String
The wrapup code for the call.

Remarks

This convenience constructor for CallCompletionParameters is an easier way to disposition calls which were not scheduled and not abandoned.

See Also

CallCompletionParameters Class
CallCompletionParameters Members
CallCompletionParameters Overload
ININ.IceLib.Dialer Namespace


CallCompletionParameters Constructor (String, Boolean)

[image]

IceLib Dialer Technical Reference
CallCompletionParameters Constructor (String, Boolean)
CallCompletionParameters Class See Also Send Feedback
Initializes a new instance of the CallCompletionParameters class.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CallCompletionParameters(
    string wrapupCode,
    bool makeFollowUpCall
)
Visual Basic
Public Sub New ( _
    wrapupCode As String, _
    makeFollowUpCall As Boolean _
)

Parameters

wrapupCode
Type: System..::..String
The wrapup code for the call.
makeFollowUpCall
Type: System..::..Boolean

Remarks

This convenience constructor for CallCompletionParameters is an easier way to disposition calls which were not scheduled and not abandoned.

See Also

CallCompletionParameters Class
CallCompletionParameters Members
CallCompletionParameters Overload
ININ.IceLib.Dialer Namespace


CallCompletionParameters Constructor (String, DateTime, String, Boolean)

[image]

IceLib Dialer Technical Reference
CallCompletionParameters Constructor (String, DateTime, String, Boolean)
CallCompletionParameters Class See Also Send Feedback
Initializes a new instance of the CallCompletionParameters class.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CallCompletionParameters(
    string wrapupCode,
    DateTime scheduledTime,
    string scheduledAgent,
    bool callAbandoned
)
Visual Basic
Public Sub New ( _
    wrapupCode As String, _
    scheduledTime As DateTime, _
    scheduledAgent As String, _
    callAbandoned As Boolean _
)

Parameters

wrapupCode
Type: System..::..String
The wrapup code for the call.
scheduledTime
Type: System..::..DateTime
For scheduled calls, the time of the callback.
scheduledAgent
Type: System..::..String
For agent-owned callbacks, the agent who should receive the call.
callAbandoned
Type: System..::..Boolean

See Also

CallCompletionParameters Class
CallCompletionParameters Members
CallCompletionParameters Overload
ININ.IceLib.Dialer Namespace


CallCompletionParameters Constructor (String, DateTime, String, Boolean, TimeReference)

[image]

IceLib Dialer Technical Reference
CallCompletionParameters Constructor (String, DateTime, String, Boolean, TimeReference)
CallCompletionParameters Class See Also Send Feedback
Initializes a new instance of the CallCompletionParameters class.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CallCompletionParameters(
    string wrapupCode,
    DateTime scheduledTime,
    string scheduledAgent,
    bool callAbandoned,
    TimeReference relativeTo
)
Visual Basic
Public Sub New ( _
    wrapupCode As String, _
    scheduledTime As DateTime, _
    scheduledAgent As String, _
    callAbandoned As Boolean, _
    relativeTo As TimeReference _
)

Parameters

wrapupCode
Type: System..::..String
The wrapup code for the call.
scheduledTime
Type: System..::..DateTime
For scheduled calls, the time of the callback.
scheduledAgent
Type: System..::..String
For agent-owned callbacks, the agent who should receive the call.
callAbandoned
Type: System..::..Boolean
Indicates whether the call was abandoned.
relativeTo
Type: ININ.IceLib.Dialer.Enums..::..TimeReference
Determines how scheduledTime is interpreted.

See Also

CallCompletionParameters Class
CallCompletionParameters Members
CallCompletionParameters Overload
ININ.IceLib.Dialer Namespace


CallCompletionParameters Constructor (String, DateTime, String, Boolean, Boolean)

[image]

IceLib Dialer Technical Reference
CallCompletionParameters Constructor (String, DateTime, String, Boolean, Boolean)
CallCompletionParameters Class See Also Send Feedback
Initializes a new instance of the CallCompletionParameters class.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CallCompletionParameters(
    string wrapupCode,
    DateTime scheduledTime,
    string scheduledAgent,
    bool callAbandoned,
    bool makeFollowUpCall
)
Visual Basic
Public Sub New ( _
    wrapupCode As String, _
    scheduledTime As DateTime, _
    scheduledAgent As String, _
    callAbandoned As Boolean, _
    makeFollowUpCall As Boolean _
)

Parameters

wrapupCode
Type: System..::..String
The wrapup code for the call.
scheduledTime
Type: System..::..DateTime
For scheduled calls, the time of the callback.
scheduledAgent
Type: System..::..String
For agent-owned callbacks, the agent who should receive the call.
callAbandoned
Type: System..::..Boolean
Indicates whether the call was abandoned.
makeFollowUpCall
Type: System..::..Boolean

See Also

CallCompletionParameters Class
CallCompletionParameters Members
CallCompletionParameters Overload
ININ.IceLib.Dialer Namespace


CallCompletionParameters Constructor (String, DateTime, String, Boolean, TimeReference, Boolean)

[image]

IceLib Dialer Technical Reference
CallCompletionParameters Constructor (String, DateTime, String, Boolean, TimeReference, Boolean)
CallCompletionParameters Class See Also Send Feedback
Initializes a new instance of the CallCompletionParameters class.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CallCompletionParameters(
    string wrapupCode,
    DateTime scheduledTime,
    string scheduledAgent,
    bool callAbandoned,
    TimeReference relativeTo,
    bool makeFollowUpCall
)
Visual Basic
Public Sub New ( _
    wrapupCode As String, _
    scheduledTime As DateTime, _
    scheduledAgent As String, _
    callAbandoned As Boolean, _
    relativeTo As TimeReference, _
    makeFollowUpCall As Boolean _
)

Parameters

wrapupCode
Type: System..::..String
The wrapup code for the call.
scheduledTime
Type: System..::..DateTime
For scheduled calls, the time of the callback.
scheduledAgent
Type: System..::..String
For agent-owned callbacks, the agent who should receive the call.
callAbandoned
Type: System..::..Boolean
Indicates whether the call was abandoned.
relativeTo
Type: ININ.IceLib.Dialer.Enums..::..TimeReference
Determines how scheduledTime is interpreted.
makeFollowUpCall
Type: System..::..Boolean

See Also

CallCompletionParameters Class
CallCompletionParameters Members
CallCompletionParameters Overload
ININ.IceLib.Dialer Namespace


CallCompletionParameters Methods

[image] [image]

IceLib Dialer Technical Reference
CallCompletionParameters Methods
CallCompletionParameters Class See Also Send Feedback

The CallCompletionParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current CallCompletionParameters. (Overrides Object..::..ToString()()()().)

See Also

CallCompletionParameters Class
ININ.IceLib.Dialer Namespace


ToString Method

[image]

IceLib Dialer Technical Reference
CallCompletionParameters..::..ToString Method
CallCompletionParameters Class See Also Send Feedback
Returns a String that represents the current CallCompletionParameters.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

See Also

CallCompletionParameters Class
CallCompletionParameters Members
ININ.IceLib.Dialer Namespace


CallCompletionParameters Properties

[image] [image]

IceLib Dialer Technical Reference
CallCompletionParameters Properties
CallCompletionParameters Class See Also Send Feedback

The CallCompletionParameters type exposes the following members.

Properties

 | Name | Description
Public property | IsCallAbandoned | Gets or sets a value indicating whether the call was abandoned.
Public property | MakeFollowUpCall | Determines if the user wanted to make a follow up call after dispositioning the current call.
Public property | RelativeTo | Determines how ScheduledTime is interpreted.
Public property | ScheduledAgent | Gets or sets the agent who should receive the call, for agent-owned callbacks.
Public property | ScheduledTime | Gets or sets the time of the callback, for scheduled calls.
Public property | WrapupCode | Gets or sets the wrapup code for the call.

See Also

CallCompletionParameters Class
ININ.IceLib.Dialer Namespace


IsCallAbandoned Property

[image]

IceLib Dialer Technical Reference
CallCompletionParameters..::..IsCallAbandoned Property
CallCompletionParameters Class See Also Send Feedback
Gets or sets a value indicating whether the call was abandoned.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsCallAbandoned { get; set; }
Visual Basic
Public Property IsCallAbandoned As Boolean
    Get
    Set

Field Value

true if the call was abandoned; otherwise, false.

See Also

CallCompletionParameters Class
CallCompletionParameters Members
ININ.IceLib.Dialer Namespace


MakeFollowUpCall Property

[image]

IceLib Dialer Technical Reference
CallCompletionParameters..::..MakeFollowUpCall Property
CallCompletionParameters Class See Also Send Feedback
Determines if the user wanted to make a follow up call after dispositioning the current call.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool MakeFollowUpCall { get; private set; }
Visual Basic
Public Property MakeFollowUpCall As Boolean
    Get
    Private Set

See Also

CallCompletionParameters Class
CallCompletionParameters Members
ININ.IceLib.Dialer Namespace


RelativeTo Property

[image]

IceLib Dialer Technical Reference
CallCompletionParameters..::..RelativeTo Property
CallCompletionParameters Class See Also Send Feedback
Determines how ScheduledTime is interpreted.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public TimeReference RelativeTo { get; set; }
Visual Basic
Public Property RelativeTo As TimeReference
    Get
    Set

See Also

CallCompletionParameters Class
CallCompletionParameters Members
ININ.IceLib.Dialer Namespace


ScheduledAgent Property

[image]

IceLib Dialer Technical Reference
CallCompletionParameters..::..ScheduledAgent Property
CallCompletionParameters Class See Also Send Feedback
Gets or sets the agent who should receive the call, for agent-owned callbacks.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string ScheduledAgent { get; set; }
Visual Basic
Public Property ScheduledAgent As String
    Get
    Set

Field Value

The scheduled agent.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

See Also

CallCompletionParameters Class
CallCompletionParameters Members
ININ.IceLib.Dialer Namespace


ScheduledTime Property

[image]

IceLib Dialer Technical Reference
CallCompletionParameters..::..ScheduledTime Property
CallCompletionParameters Class See Also Send Feedback
Gets or sets the time of the callback, for scheduled calls.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DateTime ScheduledTime { get; set; }
Visual Basic
Public Property ScheduledTime As DateTime
    Get
    Set

Field Value

The scheduled time.

Remarks

The value of ScheduledTime is influenced by the value of RelativeTo

The maximum time that can be scheduled is 03:14:07 UTC, 19 January 2038.

See Also

CallCompletionParameters Class
CallCompletionParameters Members
ININ.IceLib.Dialer Namespace


WrapupCode Property

[image]

IceLib Dialer Technical Reference
CallCompletionParameters..::..WrapupCode Property
CallCompletionParameters Class See Also Send Feedback
Gets or sets the wrapup code for the call.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string WrapupCode { get; set; }
Visual Basic
Public Property WrapupCode As String
    Get
    Set

Field Value

The wrapup code.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

See Also

CallCompletionParameters Class
CallCompletionParameters Members
ININ.IceLib.Dialer Namespace


CampaignData Class

[image]

IceLib Dialer Technical Reference
CampaignData Class
Members See Also Send Feedback
A container for several campaign properties.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class CampaignData
Visual Basic
Public Class CampaignData

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Dialer..::..CampaignData

See Also

CampaignData Members
ININ.IceLib.Dialer Namespace


CampaignData Members

[image] [image]

IceLib Dialer Technical Reference
CampaignData Members
CampaignData Class Methods Properties See Also Send Feedback

The CampaignData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | KeepOpen | Keeps the campaign's script open between calls.
Public property | ScriptUrl | The URL of the script used by the campaign.

See Also

CampaignData Class
ININ.IceLib.Dialer Namespace


CampaignData Methods

[image] [image]

IceLib Dialer Technical Reference
CampaignData Methods
CampaignData Class See Also Send Feedback

The CampaignData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CampaignData Class
ININ.IceLib.Dialer Namespace


CampaignData Properties

[image] [image]

IceLib Dialer Technical Reference
CampaignData Properties
CampaignData Class See Also Send Feedback

The CampaignData type exposes the following members.

Properties

 | Name | Description
Public property | KeepOpen | Keeps the campaign's script open between calls.
Public property | ScriptUrl | The URL of the script used by the campaign.

See Also

CampaignData Class
ININ.IceLib.Dialer Namespace


KeepOpen Property

[image]

IceLib Dialer Technical Reference
CampaignData..::..KeepOpen Property
CampaignData Class See Also Send Feedback
Keeps the campaign's script open between calls.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool KeepOpen { get; set; }
Visual Basic
Public Property KeepOpen As Boolean
    Get
    Set

See Also

CampaignData Class
CampaignData Members
ININ.IceLib.Dialer Namespace


ScriptUrl Property

[image]

IceLib Dialer Technical Reference
CampaignData..::..ScriptUrl Property
CampaignData Class See Also Send Feedback
The URL of the script used by the campaign.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string ScriptUrl { get; set; }
Visual Basic
Public Property ScriptUrl As String
    Get
    Set

See Also

CampaignData Class
CampaignData Members
ININ.IceLib.Dialer Namespace


CampaignId Class

[image]

IceLib Dialer Technical Reference
CampaignId Class
Members See Also Send Feedback
Represents a unique identifier for a campaign, along with its display name.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class CampaignId
Visual Basic
Public Class CampaignId

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Dialer..::..CampaignId

See Also

CampaignId Members
ININ.IceLib.Dialer Namespace


CampaignId Members

[image] [image]

IceLib Dialer Technical Reference
CampaignId Members
CampaignId Class Methods Properties See Also Send Feedback

The CampaignId type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Id | The campaign's Id.
Public property | Name | The campaign's display name.

See Also

CampaignId Class
ININ.IceLib.Dialer Namespace


CampaignId Methods

[image] [image]

IceLib Dialer Technical Reference
CampaignId Methods
CampaignId Class See Also Send Feedback

The CampaignId type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CampaignId Class
ININ.IceLib.Dialer Namespace


CampaignId Properties

[image] [image]

IceLib Dialer Technical Reference
CampaignId Properties
CampaignId Class See Also Send Feedback

The CampaignId type exposes the following members.

Properties

 | Name | Description
Public property | Id | The campaign's Id.
Public property | Name | The campaign's display name.

See Also

CampaignId Class
ININ.IceLib.Dialer Namespace


Id Property

[image]

IceLib Dialer Technical Reference
CampaignId..::..Id Property
CampaignId Class See Also Send Feedback
The campaign's Id.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Id { get; set; }
Visual Basic
Public Property Id As String
    Get
    Set

See Also

CampaignId Class
CampaignId Members
ININ.IceLib.Dialer Namespace


Name Property

[image]

IceLib Dialer Technical Reference
CampaignId..::..Name Property
CampaignId Class See Also Send Feedback
The campaign's display name.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Name { get; set; }
Visual Basic
Public Property Name As String
    Get
    Set

See Also

CampaignId Class
CampaignId Members
ININ.IceLib.Dialer Namespace


CampaignScriptConfiguration Class

[image]

IceLib Dialer Technical Reference
CampaignScriptConfiguration Class
Members See Also Send Feedback
Contains configuration data for a campaign and its base script.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class CampaignScriptConfiguration
Visual Basic
Public Class CampaignScriptConfiguration

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Dialer..::..CampaignScriptConfiguration

See Also

CampaignScriptConfiguration Members
ININ.IceLib.Dialer Namespace


CampaignScriptConfiguration Members

[image] [image]

IceLib Dialer Technical Reference
CampaignScriptConfiguration Members
CampaignScriptConfiguration Class Methods Properties See Also Send Feedback

The CampaignScriptConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CampaignId | The Id and display name of the campaign.
Public property | Script | The configuration data for the campaign's base script.
Public property | Workgroup | The workgroup assigned to the campaign.

See Also

CampaignScriptConfiguration Class
ININ.IceLib.Dialer Namespace


CampaignScriptConfiguration Methods

[image] [image]

IceLib Dialer Technical Reference
CampaignScriptConfiguration Methods
CampaignScriptConfiguration Class See Also Send Feedback

The CampaignScriptConfiguration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CampaignScriptConfiguration Class
ININ.IceLib.Dialer Namespace


CampaignScriptConfiguration Properties

[image] [image]

IceLib Dialer Technical Reference
CampaignScriptConfiguration Properties
CampaignScriptConfiguration Class See Also Send Feedback

The CampaignScriptConfiguration type exposes the following members.

Properties

 | Name | Description
Public property | CampaignId | The Id and display name of the campaign.
Public property | Script | The configuration data for the campaign's base script.
Public property | Workgroup | The workgroup assigned to the campaign.

See Also

CampaignScriptConfiguration Class
ININ.IceLib.Dialer Namespace


CampaignId Property

[image]

IceLib Dialer Technical Reference
CampaignScriptConfiguration..::..CampaignId Property
CampaignScriptConfiguration Class See Also Send Feedback
The Id and display name of the campaign.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CampaignId CampaignId { get; private set; }
Visual Basic
Public Property CampaignId As CampaignId
    Get
    Private Set

See Also

CampaignScriptConfiguration Class
CampaignScriptConfiguration Members
ININ.IceLib.Dialer Namespace


Script Property

[image]

IceLib Dialer Technical Reference
CampaignScriptConfiguration..::..Script Property
CampaignScriptConfiguration Class See Also Send Feedback
The configuration data for the campaign's base script.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public BaseScriptDefinition Script { get; private set; }
Visual Basic
Public Property Script As BaseScriptDefinition
    Get
    Private Set

See Also

CampaignScriptConfiguration Class
CampaignScriptConfiguration Members
ININ.IceLib.Dialer Namespace


Workgroup Property

[image]

IceLib Dialer Technical Reference
CampaignScriptConfiguration..::..Workgroup Property
CampaignScriptConfiguration Class See Also Send Feedback
The workgroup assigned to the campaign.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Workgroup { get; private set; }
Visual Basic
Public Property Workgroup As String
    Get
    Private Set

See Also

CampaignScriptConfiguration Class
CampaignScriptConfiguration Members
ININ.IceLib.Dialer Namespace


CampaignStartedEventArgs Class

[image]

IceLib Dialer Technical Reference
CampaignStartedEventArgs Class
Members See Also Send Feedback
Provides data for campaign started events.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class CampaignStartedEventArgs : EventArgs
Visual Basic
Public Class CampaignStartedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Dialer..::..CampaignStartedEventArgs

See Also

CampaignStartedEventArgs Members
ININ.IceLib.Dialer Namespace


CampaignStartedEventArgs Members

[image] [image]

IceLib Dialer Technical Reference
CampaignStartedEventArgs Members
CampaignStartedEventArgs Class Methods Properties See Also Send Feedback

The CampaignStartedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CampaignName | Gets the campaign that was started.
Public property | CampaignType | Gets the CampaignType associated with the campaign that started.
Public property | WorkgroupName | Gets the workgroup associated with the campaign that started.

See Also

CampaignStartedEventArgs Class
ININ.IceLib.Dialer Namespace


CampaignStartedEventArgs Methods

[image] [image]

IceLib Dialer Technical Reference
CampaignStartedEventArgs Methods
CampaignStartedEventArgs Class See Also Send Feedback

The CampaignStartedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CampaignStartedEventArgs Class
ININ.IceLib.Dialer Namespace


CampaignStartedEventArgs Properties

[image] [image]

IceLib Dialer Technical Reference
CampaignStartedEventArgs Properties
CampaignStartedEventArgs Class See Also Send Feedback

The CampaignStartedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | CampaignName | Gets the campaign that was started.
Public property | CampaignType | Gets the CampaignType associated with the campaign that started.
Public property | WorkgroupName | Gets the workgroup associated with the campaign that started.

See Also

CampaignStartedEventArgs Class
ININ.IceLib.Dialer Namespace


CampaignName Property

[image]

IceLib Dialer Technical Reference
CampaignStartedEventArgs..::..CampaignName Property
CampaignStartedEventArgs Class See Also Send Feedback
Gets the campaign that was started.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string CampaignName { get; }
Visual Basic
Public ReadOnly Property CampaignName As String
    Get

Field Value

The name of the campaign.

See Also

CampaignStartedEventArgs Class
CampaignStartedEventArgs Members
ININ.IceLib.Dialer Namespace


CampaignType Property

[image]

IceLib Dialer Technical Reference
CampaignStartedEventArgs..::..CampaignType Property
CampaignStartedEventArgs Class See Also Send Feedback
Gets the CampaignType associated with the campaign that started.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public int CampaignType { get; }
Visual Basic
Public ReadOnly Property CampaignType As Integer
    Get

Field Value

The name of the campaign.

See Also

CampaignStartedEventArgs Class
CampaignStartedEventArgs Members
ININ.IceLib.Dialer Namespace


WorkgroupName Property

[image]

IceLib Dialer Technical Reference
CampaignStartedEventArgs..::..WorkgroupName Property
CampaignStartedEventArgs Class See Also Send Feedback
Gets the workgroup associated with the campaign that started.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string WorkgroupName { get; }
Visual Basic
Public ReadOnly Property WorkgroupName As String
    Get

Field Value

The name of the workgroup.

See Also

CampaignStartedEventArgs Class
CampaignStartedEventArgs Members
ININ.IceLib.Dialer Namespace


CampaignStatLookup Class

[image]

IceLib Dialer Technical Reference
CampaignStatLookup Class
Members See Also Send Feedback
Provides a mechanism for retrieving localized versions of values appearing in campaign statistic database entries.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static class CampaignStatLookup
Visual Basic
Public NotInheritable Class CampaignStatLookup

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Dialer..::..CampaignStatLookup

See Also

CampaignStatLookup Members
ININ.IceLib.Dialer Namespace


CampaignStatLookup Members

[image] [image]

IceLib Dialer Technical Reference
CampaignStatLookup Members
CampaignStatLookup Class Methods See Also Send Feedback

The CampaignStatLookup type exposes the following members.

Methods

Name | Description
GetLocalizedString | Retrieves the localized version of a value appearing in a campaign statistic database entry.

See Also

CampaignStatLookup Class
ININ.IceLib.Dialer Namespace


CampaignStatLookup Methods

[image] [image]

IceLib Dialer Technical Reference
CampaignStatLookup Methods
CampaignStatLookup Class See Also Send Feedback

The CampaignStatLookup type exposes the following members.

Methods

Name | Description
GetLocalizedString | Retrieves the localized version of a value appearing in a campaign statistic database entry.

See Also

CampaignStatLookup Class
ININ.IceLib.Dialer Namespace


GetLocalizedString Method

[image]

IceLib Dialer Technical Reference
CampaignStatLookup..::..GetLocalizedString Method
CampaignStatLookup Class See Also Send Feedback
Retrieves the localized version of a value appearing in a campaign statistic database entry.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public static string GetLocalizedString(
    string value
)
Visual Basic
Public Shared Function GetLocalizedString ( _
    value As String _
) As String

Parameters

value
Type: System..::..String
The value from the database entry. This is typically the campaign status or an event.

Return Value

The localized string, or String.Empty if the value cannot be found.

See Also

CampaignStatLookup Class
CampaignStatLookup Members
ININ.IceLib.Dialer Namespace


CampaignStoppedEventArgs Class

[image]

IceLib Dialer Technical Reference
CampaignStoppedEventArgs Class
Members See Also Send Feedback
Provides data for campaign stopped events.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class CampaignStoppedEventArgs : EventArgs
Visual Basic
Public Class CampaignStoppedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Dialer..::..CampaignStoppedEventArgs

See Also

CampaignStoppedEventArgs Members
ININ.IceLib.Dialer Namespace


CampaignStoppedEventArgs Members

[image] [image]

IceLib Dialer Technical Reference
CampaignStoppedEventArgs Members
CampaignStoppedEventArgs Class Methods Properties See Also Send Feedback

The CampaignStoppedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CampaignName | Gets the campaign that was stopped.

See Also

CampaignStoppedEventArgs Class
ININ.IceLib.Dialer Namespace


CampaignStoppedEventArgs Methods

[image] [image]

IceLib Dialer Technical Reference
CampaignStoppedEventArgs Methods
CampaignStoppedEventArgs Class See Also Send Feedback

The CampaignStoppedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CampaignStoppedEventArgs Class
ININ.IceLib.Dialer Namespace


CampaignStoppedEventArgs Properties

[image] [image]

IceLib Dialer Technical Reference
CampaignStoppedEventArgs Properties
CampaignStoppedEventArgs Class See Also Send Feedback

The CampaignStoppedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | CampaignName | Gets the campaign that was stopped.

See Also

CampaignStoppedEventArgs Class
ININ.IceLib.Dialer Namespace


CampaignName Property

[image]

IceLib Dialer Technical Reference
CampaignStoppedEventArgs..::..CampaignName Property
CampaignStoppedEventArgs Class See Also Send Feedback
Gets the campaign that was stopped.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string CampaignName { get; }
Visual Basic
Public ReadOnly Property CampaignName As String
    Get

Field Value

The name of the campaign.

See Also

CampaignStoppedEventArgs Class
CampaignStoppedEventArgs Members
ININ.IceLib.Dialer Namespace


CampaignTransistionEventArgs Class

[image]

IceLib Dialer Technical Reference
CampaignTransistionEventArgs Class
Members See Also Send Feedback
Provides data for the CampaignTransition event.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
[ObsoleteAttribute("Campaign transitions no longer exist")]
public class CampaignTransistionEventArgs : EventArgs
Visual Basic
<ObsoleteAttribute("Campaign transitions no longer exist")> _
Public Class CampaignTransistionEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Dialer..::..CampaignTransistionEventArgs

See Also

CampaignTransistionEventArgs Members
ININ.IceLib.Dialer Namespace


CampaignTransistionEventArgs Members

[image] [image]

IceLib Dialer Technical Reference
CampaignTransistionEventArgs Members
CampaignTransistionEventArgs Class Methods See Also Send Feedback

The CampaignTransistionEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CampaignTransistionEventArgs Class
ININ.IceLib.Dialer Namespace


CampaignTransistionEventArgs Methods

[image] [image]

IceLib Dialer Technical Reference
CampaignTransistionEventArgs Methods
CampaignTransistionEventArgs Class See Also Send Feedback

The CampaignTransistionEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CampaignTransistionEventArgs Class
ININ.IceLib.Dialer Namespace


ContactDataLoadedEventArgs Class

[image]

IceLib Dialer Technical Reference
ContactDataLoadedEventArgs Class
Members See Also Send Feedback
Provides data related to the ContactDataLoaded event

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class ContactDataLoadedEventArgs : EventArgs
Visual Basic
Public Class ContactDataLoadedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Dialer..::..ContactDataLoadedEventArgs

See Also

ContactDataLoadedEventArgs Members
ININ.IceLib.Dialer Namespace


ContactDataLoadedEventArgs Members

[image] [image]

IceLib Dialer Technical Reference
ContactDataLoadedEventArgs Members
ContactDataLoadedEventArgs Class Methods Properties See Also Send Feedback

The ContactDataLoadedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ContactListData | The JSON string returned from the server.

See Also

ContactDataLoadedEventArgs Class
ININ.IceLib.Dialer Namespace


ContactDataLoadedEventArgs Methods

[image] [image]

IceLib Dialer Technical Reference
ContactDataLoadedEventArgs Methods
ContactDataLoadedEventArgs Class See Also Send Feedback

The ContactDataLoadedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContactDataLoadedEventArgs Class
ININ.IceLib.Dialer Namespace


ContactDataLoadedEventArgs Properties

[image] [image]

IceLib Dialer Technical Reference
ContactDataLoadedEventArgs Properties
ContactDataLoadedEventArgs Class See Also Send Feedback

The ContactDataLoadedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | ContactListData | The JSON string returned from the server.

See Also

ContactDataLoadedEventArgs Class
ININ.IceLib.Dialer Namespace


ContactListData Property

[image]

IceLib Dialer Technical Reference
ContactDataLoadedEventArgs..::..ContactListData Property
ContactDataLoadedEventArgs Class See Also Send Feedback
The JSON string returned from the server.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string ContactListData { get; set; }
Visual Basic
Public Property ContactListData As String
    Get
    Set

See Also

ContactDataLoadedEventArgs Class
ContactDataLoadedEventArgs Members
ININ.IceLib.Dialer Namespace


DataPopEventArgs Class

[image]

IceLib Dialer Technical Reference
DataPopEventArgs Class
Members See Also Send Feedback
Provides data for the DataPop event.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class DataPopEventArgs : EventArgs
Visual Basic
Public Class DataPopEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Dialer..::..DataPopEventArgs

See Also

DataPopEventArgs Members
ININ.IceLib.Dialer Namespace


DataPopEventArgs Members

[image] [image]

IceLib Dialer Technical Reference
DataPopEventArgs Members
DataPopEventArgs Class Methods Properties See Also Send Feedback

The DataPopEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Interaction | Gets the DialerCallInteraction representing the call being popped.

See Also

DataPopEventArgs Class
ININ.IceLib.Dialer Namespace


DataPopEventArgs Methods

[image] [image]

IceLib Dialer Technical Reference
DataPopEventArgs Methods
DataPopEventArgs Class See Also Send Feedback

The DataPopEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataPopEventArgs Class
ININ.IceLib.Dialer Namespace


DataPopEventArgs Properties

[image] [image]

IceLib Dialer Technical Reference
DataPopEventArgs Properties
DataPopEventArgs Class See Also Send Feedback

The DataPopEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Interaction | Gets the DialerCallInteraction representing the call being popped.

See Also

DataPopEventArgs Class
ININ.IceLib.Dialer Namespace


Interaction Property

[image]

IceLib Dialer Technical Reference
DataPopEventArgs..::..Interaction Property
DataPopEventArgs Class See Also Send Feedback
Gets the DialerCallInteraction representing the call being popped.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DialerCallInteraction Interaction { get; }
Visual Basic
Public ReadOnly Property Interaction As DialerCallInteraction
    Get

Field Value

The interaction.

See Also

DataPopEventArgs Class
DataPopEventArgs Members
ININ.IceLib.Dialer Namespace


DialerCallInteraction Class

[image]

IceLib Dialer Technical Reference
DialerCallInteraction Class
Members See Also Send Feedback
Represents a Dialer call interaction.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class DialerCallInteraction : CallInteraction
Visual Basic
Public Class DialerCallInteraction _
    Inherits CallInteraction

Inheritance Hierarchy

System..::..Object
Interaction
CallInteraction
ININ.IceLib.Dialer..::..DialerCallInteraction

See Also

DialerCallInteraction Members
ININ.IceLib.Dialer Namespace


DialerCallInteraction Members

[image] [image]

IceLib Dialer Technical Reference
DialerCallInteraction Members
DialerCallInteraction Class Methods Properties Events See Also Send Feedback

The DialerCallInteraction type exposes the following members.

Methods

 | Name | Description
Public method | AppendNote | (Inherited from Interaction.)
Public method | AppendNoteAsync | (Inherited from Interaction.)
Public method | AppendStringAttribute | (Inherited from Interaction.)
Public method | AppendStringAttributeAsync | (Inherited from Interaction.)
Public method | BlindTransfer(String) | (Inherited from Interaction.)
Public method | BlindTransfer(QueueId) | (Inherited from Interaction.)
Public method | BlindTransferAsync(String, AsyncCompletedEventHandler, Object) | (Inherited from Interaction.)
Public method | BlindTransferAsync(QueueId, AsyncCompletedEventHandler, Object) | (Inherited from Interaction.)
Public method | CallComplete | Dispositions this call.
Public method | CallCompleteAsync | Asynchronously dispositions this call.
Public method | ChangeWatchedAttributes | (Inherited from Interaction.)
Public method | ChangeWatchedAttributesAsync | (Inherited from Interaction.)
Public method | Coach | (Inherited from Interaction.)
Public method | CoachAsync | (Inherited from Interaction.)
Public method | ConsultTransfer | (Inherited from Interaction.)
Public method | ConsultTransferAsync | (Inherited from Interaction.)
Public method | Disconnect | (Inherited from Interaction.)
Public method | DisconnectAsync | (Inherited from Interaction.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBooleanAttribute | (Inherited from Interaction.)
Public method | GetBooleanAttributeAsync | (Inherited from Interaction.)
Public method | GetDateTimeAttribute | (Inherited from Interaction.)
Public method | GetDateTimeAttributeAsync | (Inherited from Interaction.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerAttribute | (Inherited from Interaction.)
Public method | GetIntegerAttributeAsync | (Inherited from Interaction.)
Public method | GetStringAttribute | (Inherited from Interaction.)
Public method | GetStringAttributeAsync | (Inherited from Interaction.)
Public method | GetStringAttributes | (Inherited from Interaction.)
Public method | GetStringAttributesAsync | (Inherited from Interaction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedBooleanAttribute | (Inherited from Interaction.)
Public method | GetWatchedDateTimeAttribute | (Inherited from Interaction.)
Public method | GetWatchedIntegerAttribute | (Inherited from Interaction.)
Public method | GetWatchedStringAttribute | (Inherited from Interaction.)
Public method | GetWatchedStringsAttribute | (Inherited from Interaction.)
Public method | Hold | (Inherited from Interaction.)
Public method | HoldAsync | (Inherited from Interaction.)
Public method | InitiateRecordingSnip | (Inherited from Interaction.)
Public method | InitiateRecordingSnipAsync | (Inherited from Interaction.)
Public method | InitiateSecureInput | (Inherited from Interaction.)
Public method | InitiateSecureInputAsync | (Inherited from Interaction.)
Public method | IsValidCapability | (Inherited from Interaction.)
Public method | IsWatching()()()() | (Inherited from Interaction.)
Public method | IsWatching(String) | (Inherited from Interaction.)
Public method | Join | (Inherited from Interaction.)
Public method | JoinAsync | (Inherited from Interaction.)
Public method | Listen | (Inherited from Interaction.)
Public method | ListenAsync | (Inherited from Interaction.)
Public method | MarkCallForFinishing | Marks this call for finishing, preparing it to be handled by a finishing agent.
Public method | MarkCallForFinishingAsync | Asynchronously marks this call for finishing, preparing it to be handled by a finishing agent.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mute | (Inherited from Interaction.)
Public method | MuteAsync | (Inherited from Interaction.)
Public method | Park(String) | (Inherited from Interaction.)
Public method | Park(QueueId) | (Inherited from Interaction.)
Public method | ParkAsync(String, AsyncCompletedEventHandler, Object) | (Inherited from Interaction.)
Public method | ParkAsync(QueueId, AsyncCompletedEventHandler, Object) | (Inherited from Interaction.)
Public method | Pause | (Inherited from Interaction.)
Public method | PauseAsync | (Inherited from Interaction.)
Public method | Pickup | (Inherited from Interaction.)
Public method | PickupAsync | (Inherited from Interaction.)
Public method | PlacePreviewCall | Places this preview call.
Public method | PlacePreviewCallAsync | Asynchronously places this preview call.
Public method | PlayDigits | (Inherited from CallInteraction.)
Public method | PlayDigitsAsync | (Inherited from CallInteraction.)
Public method | PlayWaveAudio | (Inherited from CallInteraction.)
Public method | PlayWaveAudioAsync | (Inherited from CallInteraction.)
Public method | Private | (Inherited from Interaction.)
Public method | PrivateAsync | (Inherited from Interaction.)
Public method | Record | (Inherited from Interaction.)
Public method | RecordAsync | (Inherited from Interaction.)
Public method | RequestHelp | Obsolete. (Inherited from Interaction.)
Public method | RequestHelpAsync | Obsolete. (Inherited from Interaction.)
Public method | SecureRecordingPause(SecureRecordingPauseParameters) | (Inherited from Interaction.)
Public method | SecureRecordingPause(Boolean) | Obsolete. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(Boolean, AsyncCompletedEventHandler, Object) | Obsolete. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object) | (Inherited from Interaction.)
Public method | SetAccountCodeId | (Inherited from Interaction.)
Public method | SetAccountCodeIdAsync | (Inherited from Interaction.)
Public method | SetDateTimeAttribute | (Inherited from Interaction.)
Public method | SetDateTimeAttributeAsync | (Inherited from Interaction.)
Public method | SetRemoteName | (Inherited from Interaction.)
Public method | SetRemoteNameAsync | (Inherited from Interaction.)
Public method | SetStateDescription | (Inherited from Interaction.)
Public method | SetStateDescriptionAsync | (Inherited from Interaction.)
Public method | SetStringAttribute | (Inherited from Interaction.)
Public method | SetStringAttributeAsync | (Inherited from Interaction.)
Public method | SetStringAttributes | (Inherited from Interaction.)
Public method | SetStringAttributesAsync | (Inherited from Interaction.)
Public method | SetWrapUpCodeId | Obsolete. (Inherited from Interaction.)
Public method | SetWrapUpCodeIdAsync | Obsolete. (Inherited from Interaction.)
Public method | StartWatching | (Inherited from Interaction.)
Public method | StartWatchingAsync | (Inherited from Interaction.)
Public method | StopAllWaveAudio | (Inherited from CallInteraction.)
Public method | StopAllWaveAudioAsync | (Inherited from CallInteraction.)
Public method | StopWatching | (Inherited from Interaction.)
Public method | StopWatchingAsync | (Inherited from Interaction.)
Public method | ToString | (Inherited from Interaction.)
Public method | TransferToAttendant | Transfers this call to an outbound Attendant profile
Public method | TransferToAttendantAsync | Asynchronously transfers this call to an outbound Attendant profile
Public method | TransferToVoicemail(String) | (Inherited from Interaction.)
Public method | TransferToVoicemail(QueueId) | (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(String, AsyncCompletedEventHandler, Object) | (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(QueueId, AsyncCompletedEventHandler, Object) | (Inherited from Interaction.)
Public method | TryGetWatchedBooleanAttribute | (Inherited from Interaction.)
Public method | TryGetWatchedDateTimeAttribute | (Inherited from Interaction.)
Public method | TryGetWatchedIntegerAttribute | (Inherited from Interaction.)
Public method | TryGetWatchedStringAttribute | (Inherited from Interaction.)
Public method | TryGetWatchedStringsAttribute | (Inherited from Interaction.)
Public method | UpdateCallData | Updates the call data, pushing any changes out to Dialer.
Public method | UpdateCallDataAsync | Asynchronously updates the call data, pushing any changes out to Dialer.
Public method | UpdateStage | Moves the agent to a new stage in the call.
Public method | UpdateStageAsync | Asynchronously moves the agent to a new stage in the call.
Public method | Voicemail | (Inherited from Interaction.)
Public method | VoicemailAsync | (Inherited from Interaction.)

Properties

 | Name | Description
Public property | AccountCodeId | (Inherited from Interaction.)
Public property | AlertSound | (Inherited from Interaction.)
Public property | AssociatedProcessDisplayName | (Inherited from Interaction.)
Public property | AssociatedProcessInstanceId | (Inherited from Interaction.)
Public property | CallIdKey | (Inherited from Interaction.)
Public property | CallType | (Inherited from Interaction.)
Public property | Campaign | The campaign that the call is associated with.
Public property | Capabilities | (Inherited from Interaction.)
Public property | ClientMessage | (Inherited from Interaction.)
Public property | ConferenceId | (Inherited from Interaction.)
Public property | ConsultCallId | (Inherited from Interaction.)
Public property | ContactData | Gets the contact data for this Dialer call.
Public property | DeallocationSeconds | (Inherited from Interaction.)
Public property | DeallocationTime | Obsolete. (Inherited from Interaction.)
Public property | DialerSession | Gets the DialerSession this Dialer call is associated with.
Public property | DialingMode | Gets the dialing mode of this Dialer call.
Public property | Direction | (Inherited from Interaction.)
Public property | DisconnectionTime | (Inherited from Interaction.)
Public property | DisconnectRingNoAnswer | (Inherited from Interaction.)
Public property | Duration | (Inherited from Interaction.)
Public property | HasSnippetRecording | (Inherited from Interaction.)
Public property | ImmediateAccess | (Inherited from Interaction.)
Public property | InitiationTime | (Inherited from Interaction.)
Public property | InteractionId | (Inherited from Interaction.)
Public property | InteractionsManager | (Inherited from Interaction.)
Public property | InteractionType | (Inherited from Interaction.)
Public property | IsConnected | (Inherited from Interaction.)
Public property | IsDisconnected | (Inherited from Interaction.)
Public property | IsHeld | (Inherited from Interaction.)
Public property | IsMonitored | (Inherited from Interaction.)
Public property | IsMuted | (Inherited from Interaction.)
Public property | IsOnMyInteractionsQueue | (Inherited from Interaction.)
Public property | IsPaused | (Inherited from Interaction.)
Public property | IsPrivate | (Inherited from Interaction.)
Public property | IsRecording | (Inherited from Interaction.)
Public property | IsShared | (Inherited from Interaction.)
Public property | Language | (Inherited from Interaction.)
Public property | LastSegment | (Inherited from Interaction.)
Public property | LastSegmentForCurrentUser | (Inherited from Interaction.)
Public property | LineName | (Inherited from Interaction.)
Public property | LocalAddress | (Inherited from Interaction.)
Public property | LocalId | (Inherited from Interaction.)
Public property | LocalName | (Inherited from Interaction.)
Public property | LocalPartyType | (Inherited from Interaction.)
Public property | LocalSecurityLevelRequested | (Inherited from Interaction.)
Public property | Log | (Inherited from Interaction.)
Public property | Monitors | (Inherited from Interaction.)
Public property | MonitorsCombinedCount | (Inherited from Interaction.)
Public property | MonitorType | (Inherited from Interaction.)
Public property | Notes | (Inherited from Interaction.)
Public property | OrbitQueueName | (Inherited from Interaction.)
Public property | PopApplication | (Inherited from Interaction.)
Public property | Recorders | (Inherited from Interaction.)
Public property | RecordersCombinedCount | (Inherited from Interaction.)
Public property | RelatedSnippetRecordings | (Inherited from Interaction.)
Public property | RemoteAddress | (Inherited from Interaction.)
Public property | RemoteDisplay | (Inherited from Interaction.)
Public property | RemoteId | (Inherited from Interaction.)
Public property | RemoteName | (Inherited from Interaction.)
Public property | RemotePartyType | (Inherited from Interaction.)
Public property | RemoteSecurityLevelRequested | (Inherited from Interaction.)
Public property | SecurityLevelActual | (Inherited from Interaction.)
Public property | SecurityLevelViolation | (Inherited from Interaction.)
Public property | Segments | (Inherited from Interaction.)
Public property | State | (Inherited from Interaction.)
Public property | StateDescription | (Inherited from Interaction.)
Public property | StationQueueNames | (Inherited from Interaction.)
Public property | SupervisorMonitors | (Inherited from Interaction.)
Public property | SupervisorRecorders | (Inherited from Interaction.)
Public property | TimeInWorkgroupQueue | (Inherited from Interaction.)
Public property | UserQueueNames | (Inherited from Interaction.)
Public property | WorkgroupQueueDisplayName | (Inherited from Interaction.)
Public property | WorkgroupQueueName | (Inherited from Interaction.)
Public property | WrapUpAssignments | (Inherited from Interaction.)
Public property | WrapUpCodeId | Obsolete. (Inherited from Interaction.)

Events

 | Name | Description
Public event | AttributesChanged | (Inherited from Interaction.)
Public event | Deallocated | (Inherited from Interaction.)
Public event | LostRights | (Inherited from Interaction.)
Public event | Morphed | (Inherited from Interaction.)
Public event | PlayWaveAudioComplete | (Inherited from CallInteraction.)
Public event | RecordingSnippetCreated | (Inherited from Interaction.)

See Also

DialerCallInteraction Class
ININ.IceLib.Dialer Namespace


DialerCallInteraction Methods

[image] [image]

IceLib Dialer Technical Reference
DialerCallInteraction Methods
DialerCallInteraction Class See Also Send Feedback

The DialerCallInteraction type exposes the following members.

Methods

 | Name | Description
Public method | AppendNote | (Inherited from Interaction.)
Public method | AppendNoteAsync | (Inherited from Interaction.)
Public method | AppendStringAttribute | (Inherited from Interaction.)
Public method | AppendStringAttributeAsync | (Inherited from Interaction.)
Public method | BlindTransfer(String) | (Inherited from Interaction.)
Public method | BlindTransfer(QueueId) | (Inherited from Interaction.)
Public method | BlindTransferAsync(String, AsyncCompletedEventHandler, Object) | (Inherited from Interaction.)
Public method | BlindTransferAsync(QueueId, AsyncCompletedEventHandler, Object) | (Inherited from Interaction.)
Public method | CallComplete | Dispositions this call.
Public method | CallCompleteAsync | Asynchronously dispositions this call.
Public method | ChangeWatchedAttributes | (Inherited from Interaction.)
Public method | ChangeWatchedAttributesAsync | (Inherited from Interaction.)
Public method | Coach | (Inherited from Interaction.)
Public method | CoachAsync | (Inherited from Interaction.)
Public method | ConsultTransfer | (Inherited from Interaction.)
Public method | ConsultTransferAsync | (Inherited from Interaction.)
Public method | Disconnect | (Inherited from Interaction.)
Public method | DisconnectAsync | (Inherited from Interaction.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBooleanAttribute | (Inherited from Interaction.)
Public method | GetBooleanAttributeAsync | (Inherited from Interaction.)
Public method | GetDateTimeAttribute | (Inherited from Interaction.)
Public method | GetDateTimeAttributeAsync | (Inherited from Interaction.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetIntegerAttribute | (Inherited from Interaction.)
Public method | GetIntegerAttributeAsync | (Inherited from Interaction.)
Public method | GetStringAttribute | (Inherited from Interaction.)
Public method | GetStringAttributeAsync | (Inherited from Interaction.)
Public method | GetStringAttributes | (Inherited from Interaction.)
Public method | GetStringAttributesAsync | (Inherited from Interaction.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetWatchedBooleanAttribute | (Inherited from Interaction.)
Public method | GetWatchedDateTimeAttribute | (Inherited from Interaction.)
Public method | GetWatchedIntegerAttribute | (Inherited from Interaction.)
Public method | GetWatchedStringAttribute | (Inherited from Interaction.)
Public method | GetWatchedStringsAttribute | (Inherited from Interaction.)
Public method | Hold | (Inherited from Interaction.)
Public method | HoldAsync | (Inherited from Interaction.)
Public method | InitiateRecordingSnip | (Inherited from Interaction.)
Public method | InitiateRecordingSnipAsync | (Inherited from Interaction.)
Public method | InitiateSecureInput | (Inherited from Interaction.)
Public method | InitiateSecureInputAsync | (Inherited from Interaction.)
Public method | IsValidCapability | (Inherited from Interaction.)
Public method | IsWatching()()()() | (Inherited from Interaction.)
Public method | IsWatching(String) | (Inherited from Interaction.)
Public method | Join | (Inherited from Interaction.)
Public method | JoinAsync | (Inherited from Interaction.)
Public method | Listen | (Inherited from Interaction.)
Public method | ListenAsync | (Inherited from Interaction.)
Public method | MarkCallForFinishing | Marks this call for finishing, preparing it to be handled by a finishing agent.
Public method | MarkCallForFinishingAsync | Asynchronously marks this call for finishing, preparing it to be handled by a finishing agent.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Mute | (Inherited from Interaction.)
Public method | MuteAsync | (Inherited from Interaction.)
Public method | Park(String) | (Inherited from Interaction.)
Public method | Park(QueueId) | (Inherited from Interaction.)
Public method | ParkAsync(String, AsyncCompletedEventHandler, Object) | (Inherited from Interaction.)
Public method | ParkAsync(QueueId, AsyncCompletedEventHandler, Object) | (Inherited from Interaction.)
Public method | Pause | (Inherited from Interaction.)
Public method | PauseAsync | (Inherited from Interaction.)
Public method | Pickup | (Inherited from Interaction.)
Public method | PickupAsync | (Inherited from Interaction.)
Public method | PlacePreviewCall | Places this preview call.
Public method | PlacePreviewCallAsync | Asynchronously places this preview call.
Public method | PlayDigits | (Inherited from CallInteraction.)
Public method | PlayDigitsAsync | (Inherited from CallInteraction.)
Public method | PlayWaveAudio | (Inherited from CallInteraction.)
Public method | PlayWaveAudioAsync | (Inherited from CallInteraction.)
Public method | Private | (Inherited from Interaction.)
Public method | PrivateAsync | (Inherited from Interaction.)
Public method | Record | (Inherited from Interaction.)
Public method | RecordAsync | (Inherited from Interaction.)
Public method | RequestHelp | Obsolete. (Inherited from Interaction.)
Public method | RequestHelpAsync | Obsolete. (Inherited from Interaction.)
Public method | SecureRecordingPause(SecureRecordingPauseParameters) | (Inherited from Interaction.)
Public method | SecureRecordingPause(Boolean) | Obsolete. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(Boolean, AsyncCompletedEventHandler, Object) | Obsolete. (Inherited from Interaction.)
Public method | SecureRecordingPauseAsync(SecureRecordingPauseParameters, AsyncCompletedEventHandler, Object) | (Inherited from Interaction.)
Public method | SetAccountCodeId | (Inherited from Interaction.)
Public method | SetAccountCodeIdAsync | (Inherited from Interaction.)
Public method | SetDateTimeAttribute | (Inherited from Interaction.)
Public method | SetDateTimeAttributeAsync | (Inherited from Interaction.)
Public method | SetRemoteName | (Inherited from Interaction.)
Public method | SetRemoteNameAsync | (Inherited from Interaction.)
Public method | SetStateDescription | (Inherited from Interaction.)
Public method | SetStateDescriptionAsync | (Inherited from Interaction.)
Public method | SetStringAttribute | (Inherited from Interaction.)
Public method | SetStringAttributeAsync | (Inherited from Interaction.)
Public method | SetStringAttributes | (Inherited from Interaction.)
Public method | SetStringAttributesAsync | (Inherited from Interaction.)
Public method | SetWrapUpCodeId | Obsolete. (Inherited from Interaction.)
Public method | SetWrapUpCodeIdAsync | Obsolete. (Inherited from Interaction.)
Public method | StartWatching | (Inherited from Interaction.)
Public method | StartWatchingAsync | (Inherited from Interaction.)
Public method | StopAllWaveAudio | (Inherited from CallInteraction.)
Public method | StopAllWaveAudioAsync | (Inherited from CallInteraction.)
Public method | StopWatching | (Inherited from Interaction.)
Public method | StopWatchingAsync | (Inherited from Interaction.)
Public method | ToString | (Inherited from Interaction.)
Public method | TransferToAttendant | Transfers this call to an outbound Attendant profile
Public method | TransferToAttendantAsync | Asynchronously transfers this call to an outbound Attendant profile
Public method | TransferToVoicemail(String) | (Inherited from Interaction.)
Public method | TransferToVoicemail(QueueId) | (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(String, AsyncCompletedEventHandler, Object) | (Inherited from Interaction.)
Public method | TransferToVoicemailAsync(QueueId, AsyncCompletedEventHandler, Object) | (Inherited from Interaction.)
Public method | TryGetWatchedBooleanAttribute | (Inherited from Interaction.)
Public method | TryGetWatchedDateTimeAttribute | (Inherited from Interaction.)
Public method | TryGetWatchedIntegerAttribute | (Inherited from Interaction.)
Public method | TryGetWatchedStringAttribute | (Inherited from Interaction.)
Public method | TryGetWatchedStringsAttribute | (Inherited from Interaction.)
Public method | UpdateCallData | Updates the call data, pushing any changes out to Dialer.
Public method | UpdateCallDataAsync | Asynchronously updates the call data, pushing any changes out to Dialer.
Public method | UpdateStage | Moves the agent to a new stage in the call.
Public method | UpdateStageAsync | Asynchronously moves the agent to a new stage in the call.
Public method | Voicemail | (Inherited from Interaction.)
Public method | VoicemailAsync | (Inherited from Interaction.)

See Also

DialerCallInteraction Class
ININ.IceLib.Dialer Namespace


CallComplete Method

[image]

IceLib Dialer Technical Reference
DialerCallInteraction..::..CallComplete Method
DialerCallInteraction Class See Also Send Feedback
Dispositions this call.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void CallComplete(
    CallCompletionParameters callCompletionParameters
)
Visual Basic
Public Sub CallComplete ( _
    callCompletionParameters As CallCompletionParameters _
)

Parameters

callCompletionParameters
Type: ININ.IceLib.Dialer..::..CallCompletionParameters
The parameters specifying how this call should be dispositioned.

Remarks

Use this member to complete the call and send the result back to Dialer.

After CallComplete(CallCompletionParameters) has been called, no further Dialer actions can be used on it.

Exceptions

Exception | Condition
ININ.IceLib.Dialer..::..InvalidDialerCallInteractionException | This DialerCallInteraction is no longer valid.
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

See Also

DialerCallInteraction Class
DialerCallInteraction Members
ININ.IceLib.Dialer Namespace


CallCompleteAsync Method

[image]

IceLib Dialer Technical Reference
DialerCallInteraction..::..CallCompleteAsync Method
DialerCallInteraction Class See Also Send Feedback
Asynchronously dispositions this call.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void CallCompleteAsync(
    CallCompletionParameters callCompletionParameters,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub CallCompleteAsync ( _
    callCompletionParameters As CallCompletionParameters, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

callCompletionParameters
Type: ININ.IceLib.Dialer..::..CallCompletionParameters
The parameters specifying how this call should be dispositioned.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

Use this member to complete the call and send the result back to Dialer.

After CallComplete(CallCompletionParameters) has been called, no further Dialer actions can be used on it.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

See Also

DialerCallInteraction Class
DialerCallInteraction Members
ININ.IceLib.Dialer Namespace


MarkCallForFinishing Method

[image]

IceLib Dialer Technical Reference
DialerCallInteraction..::..MarkCallForFinishing Method
DialerCallInteraction Class See Also Send Feedback
Marks this call for finishing, preparing it to be handled by a finishing agent.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void MarkCallForFinishing()
Visual Basic
Public Sub MarkCallForFinishing

Remarks

After calling MarkCallForFinishing()()()() the call should be transferred to an ACD workgroup that will route it to a finishing agent.

Exceptions

Exception | Condition
ININ.IceLib.Dialer..::..InvalidDialerCallInteractionException | This DialerCallInteraction is no longer valid.

See Also

DialerCallInteraction Class
DialerCallInteraction Members
ININ.IceLib.Dialer Namespace


MarkCallForFinishingAsync Method

[image]

IceLib Dialer Technical Reference
DialerCallInteraction..::..MarkCallForFinishingAsync Method
DialerCallInteraction Class See Also Send Feedback
Asynchronously marks this call for finishing, preparing it to be handled by a finishing agent.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void MarkCallForFinishingAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub MarkCallForFinishingAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

After calling MarkCallForFinishing()()()() the call should be transferred to an ACD workgroup that will route it to a finishing agent.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

See Also

DialerCallInteraction Class
DialerCallInteraction Members
ININ.IceLib.Dialer Namespace


PlacePreviewCall Method

[image]

IceLib Dialer Technical Reference
DialerCallInteraction..::..PlacePreviewCall Method
DialerCallInteraction Class See Also Send Feedback
Places this preview call.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void PlacePreviewCall()
Visual Basic
Public Sub PlacePreviewCall

Exceptions

Exception | Condition
ININ.IceLib.Dialer..::..InvalidDialerCallInteractionException | This DialerCallInteraction is no longer valid.

See Also

DialerCallInteraction Class
DialerCallInteraction Members
ININ.IceLib.Dialer Namespace


PlacePreviewCallAsync Method

[image]

IceLib Dialer Technical Reference
DialerCallInteraction..::..PlacePreviewCallAsync Method
DialerCallInteraction Class See Also Send Feedback
Asynchronously places this preview call.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void PlacePreviewCallAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub PlacePreviewCallAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

See Also

DialerCallInteraction Class
DialerCallInteraction Members
ININ.IceLib.Dialer Namespace


TransferToAttendant Method

[image]

IceLib Dialer Technical Reference
DialerCallInteraction..::..TransferToAttendant Method
DialerCallInteraction Class See Also Send Feedback
Transfers this call to an outbound Attendant profile

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void TransferToAttendant(
    string profileName
)
Visual Basic
Public Sub TransferToAttendant ( _
    profileName As String _
)

Parameters

profileName
Type: System..::..String
The name of the outbound Attedant profile to which the call should be transferred

Exceptions

Exception | Condition
System..::..ArgumentNullException | profileName is a null reference (Nothing in Visual Basic).
System..::..ArgumentException | profileName is an empty string.

See Also

DialerCallInteraction Class
DialerCallInteraction Members
ININ.IceLib.Dialer Namespace


TransferToAttendantAsync Method

[image]

IceLib Dialer Technical Reference
DialerCallInteraction..::..TransferToAttendantAsync Method
DialerCallInteraction Class See Also Send Feedback
Asynchronously transfers this call to an outbound Attendant profile

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void TransferToAttendantAsync(
    string profileName,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub TransferToAttendantAsync ( _
    profileName As String, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

profileName
Type: System..::..String
The name of the outbound Attedant profile to which the call should be transferred
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | profileName is a null reference (Nothing in Visual Basic).
System..::..ArgumentException | profileName is an empty string.

See Also

DialerCallInteraction Class
DialerCallInteraction Members
ININ.IceLib.Dialer Namespace


UpdateCallData Method

[image]

IceLib Dialer Technical Reference
DialerCallInteraction..::..UpdateCallData Method
DialerCallInteraction Class See Also Send Feedback
Updates the call data, pushing any changes out to Dialer.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void UpdateCallData()
Visual Basic
Public Sub UpdateCallData

Exceptions

Exception | Condition
ININ.IceLib.Dialer..::..InvalidDialerCallInteractionException | This DialerCallInteraction is no longer valid.

See Also

DialerCallInteraction Class
DialerCallInteraction Members
ININ.IceLib.Dialer Namespace


UpdateCallDataAsync Method

[image]

IceLib Dialer Technical Reference
DialerCallInteraction..::..UpdateCallDataAsync Method
DialerCallInteraction Class See Also Send Feedback
Asynchronously updates the call data, pushing any changes out to Dialer.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void UpdateCallDataAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UpdateCallDataAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

See Also

DialerCallInteraction Class
DialerCallInteraction Members
ININ.IceLib.Dialer Namespace


UpdateStage Method

[image]

IceLib Dialer Technical Reference
DialerCallInteraction..::..UpdateStage Method
DialerCallInteraction Class See Also Send Feedback
Moves the agent to a new stage in the call.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void UpdateStage(
    int newStageId
)
Visual Basic
Public Sub UpdateStage ( _
    newStageId As Integer _
)

Parameters

newStageId
Type: System..::..Int32
The ID of the stage the agent is moving into.

Exceptions

Exception | Condition
ININ.IceLib.Dialer..::..InvalidDialerCallInteractionException | This DialerCallInteraction is no longer valid.
System..::..ArgumentOutOfRangeException | The specified newStageId is not in the range 0 to 1000.

See Also

DialerCallInteraction Class
DialerCallInteraction Members
ININ.IceLib.Dialer Namespace


UpdateStageAsync Method

[image]

IceLib Dialer Technical Reference
DialerCallInteraction..::..UpdateStageAsync Method
DialerCallInteraction Class See Also Send Feedback
Asynchronously moves the agent to a new stage in the call.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void UpdateStageAsync(
    int newStageId,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub UpdateStageAsync ( _
    newStageId As Integer, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

newStageId
Type: System..::..Int32
The ID of the stage the agent is moving into.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified newStageId is not in the range 0 to 1000.

See Also

DialerCallInteraction Class
DialerCallInteraction Members
ININ.IceLib.Dialer Namespace


DialerCallInteraction Properties

[image] [image]

IceLib Dialer Technical Reference
DialerCallInteraction Properties
DialerCallInteraction Class See Also Send Feedback

The DialerCallInteraction type exposes the following members.

Properties

 | Name | Description
Public property | AccountCodeId | (Inherited from Interaction.)
Public property | AlertSound | (Inherited from Interaction.)
Public property | AssociatedProcessDisplayName | (Inherited from Interaction.)
Public property | AssociatedProcessInstanceId | (Inherited from Interaction.)
Public property | CallIdKey | (Inherited from Interaction.)
Public property | CallType | (Inherited from Interaction.)
Public property | Campaign | The campaign that the call is associated with.
Public property | Capabilities | (Inherited from Interaction.)
Public property | ClientMessage | (Inherited from Interaction.)
Public property | ConferenceId | (Inherited from Interaction.)
Public property | ConsultCallId | (Inherited from Interaction.)
Public property | ContactData | Gets the contact data for this Dialer call.
Public property | DeallocationSeconds | (Inherited from Interaction.)
Public property | DeallocationTime | Obsolete. (Inherited from Interaction.)
Public property | DialerSession | Gets the DialerSession this Dialer call is associated with.
Public property | DialingMode | Gets the dialing mode of this Dialer call.
Public property | Direction | (Inherited from Interaction.)
Public property | DisconnectionTime | (Inherited from Interaction.)
Public property | DisconnectRingNoAnswer | (Inherited from Interaction.)
Public property | Duration | (Inherited from Interaction.)
Public property | HasSnippetRecording | (Inherited from Interaction.)
Public property | ImmediateAccess | (Inherited from Interaction.)
Public property | InitiationTime | (Inherited from Interaction.)
Public property | InteractionId | (Inherited from Interaction.)
Public property | InteractionsManager | (Inherited from Interaction.)
Public property | InteractionType | (Inherited from Interaction.)
Public property | IsConnected | (Inherited from Interaction.)
Public property | IsDisconnected | (Inherited from Interaction.)
Public property | IsHeld | (Inherited from Interaction.)
Public property | IsMonitored | (Inherited from Interaction.)
Public property | IsMuted | (Inherited from Interaction.)
Public property | IsOnMyInteractionsQueue | (Inherited from Interaction.)
Public property | IsPaused | (Inherited from Interaction.)
Public property | IsPrivate | (Inherited from Interaction.)
Public property | IsRecording | (Inherited from Interaction.)
Public property | IsShared | (Inherited from Interaction.)
Public property | Language | (Inherited from Interaction.)
Public property | LastSegment | (Inherited from Interaction.)
Public property | LastSegmentForCurrentUser | (Inherited from Interaction.)
Public property | LineName | (Inherited from Interaction.)
Public property | LocalAddress | (Inherited from Interaction.)
Public property | LocalId | (Inherited from Interaction.)
Public property | LocalName | (Inherited from Interaction.)
Public property | LocalPartyType | (Inherited from Interaction.)
Public property | LocalSecurityLevelRequested | (Inherited from Interaction.)
Public property | Log | (Inherited from Interaction.)
Public property | Monitors | (Inherited from Interaction.)
Public property | MonitorsCombinedCount | (Inherited from Interaction.)
Public property | MonitorType | (Inherited from Interaction.)
Public property | Notes | (Inherited from Interaction.)
Public property | OrbitQueueName | (Inherited from Interaction.)
Public property | PopApplication | (Inherited from Interaction.)
Public property | Recorders | (Inherited from Interaction.)
Public property | RecordersCombinedCount | (Inherited from Interaction.)
Public property | RelatedSnippetRecordings | (Inherited from Interaction.)
Public property | RemoteAddress | (Inherited from Interaction.)
Public property | RemoteDisplay | (Inherited from Interaction.)
Public property | RemoteId | (Inherited from Interaction.)
Public property | RemoteName | (Inherited from Interaction.)
Public property | RemotePartyType | (Inherited from Interaction.)
Public property | RemoteSecurityLevelRequested | (Inherited from Interaction.)
Public property | SecurityLevelActual | (Inherited from Interaction.)
Public property | SecurityLevelViolation | (Inherited from Interaction.)
Public property | Segments | (Inherited from Interaction.)
Public property | State | (Inherited from Interaction.)
Public property | StateDescription | (Inherited from Interaction.)
Public property | StationQueueNames | (Inherited from Interaction.)
Public property | SupervisorMonitors | (Inherited from Interaction.)
Public property | SupervisorRecorders | (Inherited from Interaction.)
Public property | TimeInWorkgroupQueue | (Inherited from Interaction.)
Public property | UserQueueNames | (Inherited from Interaction.)
Public property | WorkgroupQueueDisplayName | (Inherited from Interaction.)
Public property | WorkgroupQueueName | (Inherited from Interaction.)
Public property | WrapUpAssignments | (Inherited from Interaction.)
Public property | WrapUpCodeId | Obsolete. (Inherited from Interaction.)

See Also

DialerCallInteraction Class
ININ.IceLib.Dialer Namespace


Campaign Property

[image]

IceLib Dialer Technical Reference
DialerCallInteraction..::..Campaign Property
DialerCallInteraction Class See Also Send Feedback
The campaign that the call is associated with.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CampaignId Campaign { get; }
Visual Basic
Public ReadOnly Property Campaign As CampaignId
    Get

See Also

DialerCallInteraction Class
DialerCallInteraction Members
ININ.IceLib.Dialer Namespace


ContactData Property

[image]

IceLib Dialer Technical Reference
DialerCallInteraction..::..ContactData Property
DialerCallInteraction Class See Also Send Feedback
Gets the contact data for this Dialer call.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Dictionary<string, string> ContactData { get; }
Visual Basic
Public ReadOnly Property ContactData As Dictionary(Of String, String)
    Get

Field Value

The contact data.

Remarks

To update the contact data, assign new values to the existing Dictionary entries:
CopyC#
// This assumes there is an existing DialerCallInteraction instance named
//  DialerCall and that its contact data contains an Address value that
//  is to be updated
DialerCall.ContactData["Address"] = "(new address)";

See Also

DialerCallInteraction Class
DialerCallInteraction Members
ININ.IceLib.Dialer Namespace


DialerSession Property

[image]

IceLib Dialer Technical Reference
DialerCallInteraction..::..DialerSession Property
DialerCallInteraction Class See Also Send Feedback
Gets the DialerSession this Dialer call is associated with.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DialerSession DialerSession { get; }
Visual Basic
Public ReadOnly Property DialerSession As DialerSession
    Get

Field Value

The dialer session.

See Also

DialerCallInteraction Class
DialerCallInteraction Members
ININ.IceLib.Dialer Namespace


DialingMode Property

[image]

IceLib Dialer Technical Reference
DialerCallInteraction..::..DialingMode Property
DialerCallInteraction Class See Also Send Feedback
Gets the dialing mode of this Dialer call.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DialingMode DialingMode { get; }
Visual Basic
Public ReadOnly Property DialingMode As DialingMode
    Get

Field Value

The dialing mode.

See Also

DialerCallInteraction Class
DialerCallInteraction Members
ININ.IceLib.Dialer Namespace


DialerCallInteraction Events

[image] [image]

IceLib Dialer Technical Reference
DialerCallInteraction Events
DialerCallInteraction Class See Also Send Feedback

The DialerCallInteraction type exposes the following members.

Events

 | Name | Description
Public event | AttributesChanged | (Inherited from Interaction.)
Public event | Deallocated | (Inherited from Interaction.)
Public event | LostRights | (Inherited from Interaction.)
Public event | Morphed | (Inherited from Interaction.)
Public event | PlayWaveAudioComplete | (Inherited from CallInteraction.)
Public event | RecordingSnippetCreated | (Inherited from Interaction.)

See Also

DialerCallInteraction Class
ININ.IceLib.Dialer Namespace


DialerLogonFailedException Class

[image]

IceLib Dialer Technical Reference
DialerLogonFailedException Class
Members See Also Send Feedback
The exception that is thrown when a Dialer logon attempt fails

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
[SerializableAttribute]
public class DialerLogonFailedException : IceLibException
Visual Basic
<SerializableAttribute> _
Public Class DialerLogonFailedException _
    Inherits IceLibException

Remarks

Like all IceLib-specific exceptions, this object derives from IceLibException, allowing consistent exception handling for all such exceptions.

Inheritance Hierarchy

System..::..Object
System..::..Exception
IceLibException
ININ.IceLib.Dialer..::..DialerLogonFailedException

See Also

DialerLogonFailedException Members
ININ.IceLib.Dialer Namespace


DialerLogonFailedException Members

[image] [image]

IceLib Dialer Technical Reference
DialerLogonFailedException Members
DialerLogonFailedException Class Constructors Methods Properties Events See Also Send Feedback

The DialerLogonFailedException type exposes the following members.

Constructors

 | Name | Description
Public method | DialerLogonFailedException()()()() | Initializes a new instance of the DialerLogonFailedException class with default settings.
Public method | DialerLogonFailedException(String) | Initializes a new instance of the DialerLogonFailedException class with a specific error message.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | (Inherited from IceLibException.)
Public property | ErrorType | (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DialerLogonFailedException Class
ININ.IceLib.Dialer Namespace


DialerLogonFailedException Constructor

[image] [image]

IceLib Dialer Technical Reference
DialerLogonFailedException Constructor
DialerLogonFailedException Class See Also Send Feedback
Initializes a new instance of the DialerLogonFailedException class.

Overload List

 | Name | Description
Public method | DialerLogonFailedException()()()() | Initializes a new instance of the DialerLogonFailedException class with default settings.
Public method | DialerLogonFailedException(String) | Initializes a new instance of the DialerLogonFailedException class with a specific error message.

See Also

DialerLogonFailedException Class
DialerLogonFailedException Members
ININ.IceLib.Dialer Namespace


DialerLogonFailedException Constructor

[image]

IceLib Dialer Technical Reference
DialerLogonFailedException Constructor
DialerLogonFailedException Class See Also Send Feedback
Initializes a new instance of the DialerLogonFailedException class with default settings.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DialerLogonFailedException()
Visual Basic
Public Sub New

See Also

DialerLogonFailedException Class
DialerLogonFailedException Members
DialerLogonFailedException Overload
ININ.IceLib.Dialer Namespace


DialerLogonFailedException Constructor (String)

[image]

IceLib Dialer Technical Reference
DialerLogonFailedException Constructor (String)
DialerLogonFailedException Class See Also Send Feedback
Initializes a new instance of the DialerLogonFailedException class with a specific error message.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DialerLogonFailedException(
    string error
)
Visual Basic
Public Sub New ( _
    error As String _
)

Parameters

error
Type: System..::..String
The error message

See Also

DialerLogonFailedException Class
DialerLogonFailedException Members
DialerLogonFailedException Overload
ININ.IceLib.Dialer Namespace


DialerLogonFailedException Methods

[image] [image]

IceLib Dialer Technical Reference
DialerLogonFailedException Methods
DialerLogonFailedException Class See Also Send Feedback

The DialerLogonFailedException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

DialerLogonFailedException Class
ININ.IceLib.Dialer Namespace


DialerLogonFailedException Properties

[image] [image]

IceLib Dialer Technical Reference
DialerLogonFailedException Properties
DialerLogonFailedException Class See Also Send Feedback

The DialerLogonFailedException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | (Inherited from IceLibException.)
Public property | ErrorType | (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

DialerLogonFailedException Class
ININ.IceLib.Dialer Namespace


DialerLogonFailedException Events

[image] [image]

IceLib Dialer Technical Reference
DialerLogonFailedException Events
DialerLogonFailedException Class See Also Send Feedback

The DialerLogonFailedException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

DialerLogonFailedException Class
ININ.IceLib.Dialer Namespace


DialerSession Class

[image]

IceLib Dialer Technical Reference
DialerSession Class
Members See Also Send Feedback
Represents an agent's login session to Dialer

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class DialerSession
Visual Basic
Public Class DialerSession

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Dialer..::..DialerSession

See Also

DialerSession Members
ININ.IceLib.Dialer Namespace


DialerSession Members

[image] [image]

IceLib Dialer Technical Reference
DialerSession Members
DialerSession Class Methods Properties Events See Also Send Feedback

The DialerSession type exposes the following members.

Methods

 | Name | Description
Public method | BindRecord | Attempts to bind an existing interaction to a Dialer contact record
Public method | BindRecordAsync | Asynchronously attempts to bind an existing interaction to a Dialer contact record
Public method | EndBreak | Notifies Dialer that this agent has completed their break and is ready to receive more calls.
Public method | EndBreakAsync | Asynchronously notifies Dialer that this agent has completed their break and is ready to receive more calls.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EstablishPersistentConnection | Establishes a persistent connection to the Outbound Dialer Server.
Public method | EstablishPersistentConnectionAsync | Asynchronously establishes a persistent connection to the Outbound Dialer Server.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitiateManualOutboundCall | Initiates a manual outbound call using the supplied parameters
Public method | InitiateManualOutboundCallAsync | Asynchronously initiates a manual outbound call using the supplied parameters
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RequestBreak | Requests a break for this agent.
Public method | RequestBreakAsync | Asynchronously requests a break for this agent.
Public method | RequestContactData | Sends a request to the ODS HTTP server to get data from the pnd table for a follow up call
Public method | RequestContactDataAsync | Sends an asynchronous request to the ODS HTTP plugin to get data from the pnd table for a follow up call
Public method | RequestLogout()()()() | Requests a logout for this agent for all campaigns he/she is logged into in addition to Dialer itself.
Public method | RequestLogout(IEnumerable<(Of <<'(CampaignId>)>>)) | Requests a logout for this agent for certain campaigns.
Public method | RequestLogoutAsync(AsyncCompletedEventHandler, Object) | Asynchronously requests a logout for this agent for all campaigns he/she is logged into in addition to Dialer itself.
Public method | RequestLogoutAsync(IEnumerable<(Of <<'(CampaignId>)>>), AsyncCompletedEventHandler, Object) | Asynchronously requests a logout for this agent for certain campaigns.
Public method | SetAgentType(AgentType) | Sets the AgentType for this agent in every campaign he/she is logged into.
Public method | SetAgentType(AgentType, IEnumerable<(Of <<'(CampaignId>)>>)) | Sets the AgentType for this agent for certain campaign..
Public method | SetAgentTypeAsync(AgentType, AsyncCompletedEventHandler, Object) | Asynchronously sets the AgentType for this agent for every campaign he/she is logged into.
Public method | SetAgentTypeAsync(AgentType, IEnumerable<(Of <<'(CampaignId>)>>), AsyncCompletedEventHandler, Object) | Asynchronously sets the AgentType for this agent for certain campaigns.
Public method | StartReceivingCalls()()()() | Notifies Dialer that this agent is ready to start receiving calls for every campaign he/she is logged into.
Public method | StartReceivingCalls(IEnumerable<(Of <<'(CampaignId>)>>)) | Notifies Dialer that this agent is ready to start receiving calls for certain campaigns.
Public method | StartReceivingCallsAsync(AsyncCompletedEventHandler, Object) | Asynchronously notifies Dialer that this agent is ready to start receiving calls for every campaign he/she is logged into.
Public method | StartReceivingCallsAsync(IEnumerable<(Of <<'(CampaignId>)>>), AsyncCompletedEventHandler, Object) | Asynchrously notifies Dialer that this agent is ready to start receiving calls for certain campaigns.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | BreakStatus | Gets the break status for the agent
Public property | CampaignName | Obsolete. Gets the campaign the agent is logged into.
Public property | Campaigns | Gets the campaigns the agent is logged into.
Public property | GlobalSession | True if the user logged on to Dialer without specifying any campaigns. When true, the user can receive auto login/logout notifications.
Public property | UseRecordSnippet |
Public property | UserID | Gets the ID of the user that the session belongs to.
Public property | WorkflowName | Obsolete. Gets the workflow the agent is logged into.

Events

 | Name | Description
Public event | AutoLogin | Occurs when one is automatically logged into a campaign via rule or supervisor.
Public event | AutoLogout | Occurs when one is automatically logged out of a campaign via rule or supervisor.
Public event | AutomaticBreakEnded | Occurs when an automatic break has ended.
Public event | BreakGranted | Occurs when a requested break has been granted.
Public event | CampaignTransition | Obsolete. Occurs when a campaign transition occurs for the workflow this DialerSession is associated with.
Public event | ContactDataLoaded | Occurs when the contact data for a follow up call has been loaded.
Public event | DataPop | Occurs when a Dialer call is added to the agent's queue.
Public event | DialerServerRestarted | Occurs when the dialing server restarted. Agents should logout from all campaigns and re-login to resume calling.
Public event | LogoutGranted | Occurs when a requested logout has been granted.
Public event | ManualOutboundCallStatus | Occurs when the status of a manually-initiated outbound call changes.
Public event | PreviewCallAdded | Occurs when a Preview call is added to the agent's queue.
Public event | PreviewTimeoutExpired | Occurs when the timeout associated with a preview call has elapsed and the preview call is about to be automatically dialed.
Public event | PreviewTimeoutStarted | Occurs when the timeout associated with a preview call has started.
Public event | PreviewTimeoutStopped | Occurs when the timeout associated with a preview call has stopped.

See Also

DialerSession Class
ININ.IceLib.Dialer Namespace


DialerSession Methods

[image] [image]

IceLib Dialer Technical Reference
DialerSession Methods
DialerSession Class See Also Send Feedback

The DialerSession type exposes the following members.

Methods

 | Name | Description
Public method | BindRecord | Attempts to bind an existing interaction to a Dialer contact record
Public method | BindRecordAsync | Asynchronously attempts to bind an existing interaction to a Dialer contact record
Public method | EndBreak | Notifies Dialer that this agent has completed their break and is ready to receive more calls.
Public method | EndBreakAsync | Asynchronously notifies Dialer that this agent has completed their break and is ready to receive more calls.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | EstablishPersistentConnection | Establishes a persistent connection to the Outbound Dialer Server.
Public method | EstablishPersistentConnectionAsync | Asynchronously establishes a persistent connection to the Outbound Dialer Server.
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitiateManualOutboundCall | Initiates a manual outbound call using the supplied parameters
Public method | InitiateManualOutboundCallAsync | Asynchronously initiates a manual outbound call using the supplied parameters
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RequestBreak | Requests a break for this agent.
Public method | RequestBreakAsync | Asynchronously requests a break for this agent.
Public method | RequestContactData | Sends a request to the ODS HTTP server to get data from the pnd table for a follow up call
Public method | RequestContactDataAsync | Sends an asynchronous request to the ODS HTTP plugin to get data from the pnd table for a follow up call
Public method | RequestLogout()()()() | Requests a logout for this agent for all campaigns he/she is logged into in addition to Dialer itself.
Public method | RequestLogout(IEnumerable<(Of <<'(CampaignId>)>>)) | Requests a logout for this agent for certain campaigns.
Public method | RequestLogoutAsync(AsyncCompletedEventHandler, Object) | Asynchronously requests a logout for this agent for all campaigns he/she is logged into in addition to Dialer itself.
Public method | RequestLogoutAsync(IEnumerable<(Of <<'(CampaignId>)>>), AsyncCompletedEventHandler, Object) | Asynchronously requests a logout for this agent for certain campaigns.
Public method | SetAgentType(AgentType) | Sets the AgentType for this agent in every campaign he/she is logged into.
Public method | SetAgentType(AgentType, IEnumerable<(Of <<'(CampaignId>)>>)) | Sets the AgentType for this agent for certain campaign..
Public method | SetAgentTypeAsync(AgentType, AsyncCompletedEventHandler, Object) | Asynchronously sets the AgentType for this agent for every campaign he/she is logged into.
Public method | SetAgentTypeAsync(AgentType, IEnumerable<(Of <<'(CampaignId>)>>), AsyncCompletedEventHandler, Object) | Asynchronously sets the AgentType for this agent for certain campaigns.
Public method | StartReceivingCalls()()()() | Notifies Dialer that this agent is ready to start receiving calls for every campaign he/she is logged into.
Public method | StartReceivingCalls(IEnumerable<(Of <<'(CampaignId>)>>)) | Notifies Dialer that this agent is ready to start receiving calls for certain campaigns.
Public method | StartReceivingCallsAsync(AsyncCompletedEventHandler, Object) | Asynchronously notifies Dialer that this agent is ready to start receiving calls for every campaign he/she is logged into.
Public method | StartReceivingCallsAsync(IEnumerable<(Of <<'(CampaignId>)>>), AsyncCompletedEventHandler, Object) | Asynchrously notifies Dialer that this agent is ready to start receiving calls for certain campaigns.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DialerSession Class
ININ.IceLib.Dialer Namespace


BindRecord Method

[image]

IceLib Dialer Technical Reference
DialerSession..::..BindRecord Method
DialerSession Class See Also Send Feedback
Attempts to bind an existing interaction to a Dialer contact record

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void BindRecord(
    BindRecordParameters bindingParameters
)
Visual Basic
Public Sub BindRecord ( _
    bindingParameters As BindRecordParameters _
)

Parameters

bindingParameters
Type: ININ.IceLib.Dialer..::..BindRecordParameters
The parameters for the binding, including the campaign, interaction, and contact record identifier

Remarks

This method can be used to associate an inbound call with a corresponding Dialer contact record so that the wrap-up code assigned to the interaction will apply to the Dialer contact.

Exceptions

Exception | Condition
ININ.IceLib.Dialer..::..InvalidDialerSessionException | This DialerSession is no longer valid.

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


BindRecordAsync Method

[image]

IceLib Dialer Technical Reference
DialerSession..::..BindRecordAsync Method
DialerSession Class See Also Send Feedback
Asynchronously attempts to bind an existing interaction to a Dialer contact record

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void BindRecordAsync(
    BindRecordParameters bindingParameters,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub BindRecordAsync ( _
    bindingParameters As BindRecordParameters, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

bindingParameters
Type: ININ.IceLib.Dialer..::..BindRecordParameters
The parameters for the binding, including the campaign, interaction, and contact record identifier
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

This method can be used to associate an inbound call with a corresponding Dialer contact record so that the wrap-up code assigned to the interaction will apply to the Dialer contact.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


EndBreak Method

[image]

IceLib Dialer Technical Reference
DialerSession..::..EndBreak Method
DialerSession Class See Also Send Feedback
Notifies Dialer that this agent has completed their break and is ready to receive more calls.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void EndBreak()
Visual Basic
Public Sub EndBreak

Remarks

Calling EndBreak()()()() will cause Dialer to begin making calls for this agent, so the client should set the agent to an ACD-available status before calling this method.

Exceptions

Exception | Condition
ININ.IceLib.Dialer..::..InvalidDialerSessionException | This DialerSession is no longer valid.

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


EndBreakAsync Method

[image]

IceLib Dialer Technical Reference
DialerSession..::..EndBreakAsync Method
DialerSession Class See Also Send Feedback
Asynchronously notifies Dialer that this agent has completed their break and is ready to receive more calls.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void EndBreakAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub EndBreakAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

Calling EndBreak()()()() will cause Dialer to begin making calls for this agent, so the client should set the agent to an ACD-available status before calling this method.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


EstablishPersistentConnection Method

[image]

IceLib Dialer Technical Reference
DialerSession..::..EstablishPersistentConnection Method
DialerSession Class See Also Send Feedback
Establishes a persistent connection to the Outbound Dialer Server.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void EstablishPersistentConnection()
Visual Basic
Public Sub EstablishPersistentConnection

Remarks

This method can only be used by agents logging into a remote station configured to maintain a persistent connection.

This method should be called before calling StartReceivingCalls()()()() to ensure the remote agent's audio connection is established before they receive any Dialer calls.

Exceptions

Exception | Condition
ININ.IceLib.Dialer..::..InvalidDialerSessionException | This DialerSession is no longer valid.

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


EstablishPersistentConnectionAsync Method

[image]

IceLib Dialer Technical Reference
DialerSession..::..EstablishPersistentConnectionAsync Method
DialerSession Class See Also Send Feedback
Asynchronously establishes a persistent connection to the Outbound Dialer Server.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void EstablishPersistentConnectionAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub EstablishPersistentConnectionAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

This method can only be used by agents logging into a remote station configured to maintain a persistent connection.

This method should be called before calling StartReceivingCalls()()()() to ensure the remote agent's audio connection is established before they receive any Dialer calls.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


InitiateManualOutboundCall Method

[image]

IceLib Dialer Technical Reference
DialerSession..::..InitiateManualOutboundCall Method
DialerSession Class See Also Send Feedback
Initiates a manual outbound call using the supplied parameters

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void InitiateManualOutboundCall(
    ManualOutboundCallParameters callParameters
)
Visual Basic
Public Sub InitiateManualOutboundCall ( _
    callParameters As ManualOutboundCallParameters _
)

Parameters

callParameters
Type: ININ.IceLib.Dialer..::..ManualOutboundCallParameters
The parameters for the manual call, including the campaign, contact, and what phone number to call

Exceptions

Exception | Condition
ININ.IceLib.Dialer..::..InvalidDialerSessionException | This DialerSession is no longer valid.

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


InitiateManualOutboundCallAsync Method

[image]

IceLib Dialer Technical Reference
DialerSession..::..InitiateManualOutboundCallAsync Method
DialerSession Class See Also Send Feedback
Asynchronously initiates a manual outbound call using the supplied parameters

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void InitiateManualOutboundCallAsync(
    ManualOutboundCallParameters callParameters,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub InitiateManualOutboundCallAsync ( _
    callParameters As ManualOutboundCallParameters, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

callParameters
Type: ININ.IceLib.Dialer..::..ManualOutboundCallParameters
The parameters for the manual call, including the campaign, contact, and what phone number to call
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


RequestBreak Method

[image]

IceLib Dialer Technical Reference
DialerSession..::..RequestBreak Method
DialerSession Class See Also Send Feedback
Requests a break for this agent.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void RequestBreak()
Visual Basic
Public Sub RequestBreak

Remarks

When the break is granted, the BreakGranted event will be fired.

Exceptions

Exception | Condition
ININ.IceLib.Dialer..::..InvalidDialerSessionException | This DialerSession is no longer valid.

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


RequestBreakAsync Method

[image]

IceLib Dialer Technical Reference
DialerSession..::..RequestBreakAsync Method
DialerSession Class See Also Send Feedback
Asynchronously requests a break for this agent.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void RequestBreakAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub RequestBreakAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When the break is granted, the BreakGranted event will be fired.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


RequestContactData Method

[image]

IceLib Dialer Technical Reference
DialerSession..::..RequestContactData Method
DialerSession Class See Also Send Feedback
Sends a request to the ODS HTTP server to get data from the pnd table for a follow up call

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void RequestContactData(
    string identity,
    string campaignGuid,
    HttpRequestKey requestInfo
)
Visual Basic
Public Sub RequestContactData ( _
    identity As String, _
    campaignGuid As String, _
    requestInfo As HttpRequestKey _
)

Parameters

identity
Type: System..::..String
campaignGuid
Type: System..::..String
requestInfo
Type: ININ.IceLib.Configuration.Dialer..::..HttpRequestKey

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


RequestContactDataAsync Method

[image]

IceLib Dialer Technical Reference
DialerSession..::..RequestContactDataAsync Method
DialerSession Class See Also Send Feedback
Sends an asynchronous request to the ODS HTTP plugin to get data from the pnd table for a follow up call

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void RequestContactDataAsync(
    string identity,
    string campaignGuid,
    HttpRequestKey requestInfo,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub RequestContactDataAsync ( _
    identity As String, _
    campaignGuid As String, _
    requestInfo As HttpRequestKey, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

identity
Type: System..::..String
campaignGuid
Type: System..::..String
requestInfo
Type: ININ.IceLib.Configuration.Dialer..::..HttpRequestKey
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
userState
Type: System..::..Object

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


RequestLogout Method

[image] [image]

IceLib Dialer Technical Reference
DialerSession..::..RequestLogout Method
DialerSession Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RequestLogout()()()() | Requests a logout for this agent for all campaigns he/she is logged into in addition to Dialer itself.
Public method | RequestLogout(IEnumerable<(Of <<'(CampaignId>)>>)) | Requests a logout for this agent for certain campaigns.

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


RequestLogout Method

[image]

IceLib Dialer Technical Reference
DialerSession..::..RequestLogout Method
DialerSession Class See Also Send Feedback
Requests a logout for this agent for all campaigns he/she is logged into in addition to Dialer itself.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void RequestLogout()
Visual Basic
Public Sub RequestLogout

Remarks

When the logout is granted, the LogoutGranted event will be fired and the agent will have been logged out of the campaign.

Exceptions

Exception | Condition
ININ.IceLib.Dialer..::..InvalidDialerSessionException | This DialerSession is no longer valid.

See Also

DialerSession Class
DialerSession Members
RequestLogout Overload
ININ.IceLib.Dialer Namespace


RequestLogout Method (IEnumerable(CampaignId))

[image]

IceLib Dialer Technical Reference
DialerSession..::..RequestLogout Method (IEnumerable<(Of <(<'CampaignId>)>)>)
DialerSession Class See Also Send Feedback
Requests a logout for this agent for certain campaigns.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void RequestLogout(
    IEnumerable<CampaignId> campaigns
)
Visual Basic
Public Sub RequestLogout ( _
    campaigns As IEnumerable(Of CampaignId) _
)

Parameters

campaigns
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' CampaignId >)>)>
The campaigns to log out of.

See Also

DialerSession Class
DialerSession Members
RequestLogout Overload
ININ.IceLib.Dialer Namespace


RequestLogoutAsync Method

[image] [image]

IceLib Dialer Technical Reference
DialerSession..::..RequestLogoutAsync Method
DialerSession Class See Also Send Feedback

Overload List

 | Name | Description
Public method | RequestLogoutAsync(AsyncCompletedEventHandler, Object) | Asynchronously requests a logout for this agent for all campaigns he/she is logged into in addition to Dialer itself.
Public method | RequestLogoutAsync(IEnumerable<(Of <<'(CampaignId>)>>), AsyncCompletedEventHandler, Object) | Asynchronously requests a logout for this agent for certain campaigns.

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


RequestLogoutAsync Method (AsyncCompletedEventHandler, Object)

[image]

IceLib Dialer Technical Reference
DialerSession..::..RequestLogoutAsync Method (AsyncCompletedEventHandler, Object)
DialerSession Class See Also Send Feedback
Asynchronously requests a logout for this agent for all campaigns he/she is logged into in addition to Dialer itself.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void RequestLogoutAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub RequestLogoutAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When the logout is granted, the LogoutGranted event will be fired and the agent will have been logged out of the campaign.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

See Also

DialerSession Class
DialerSession Members
RequestLogoutAsync Overload
ININ.IceLib.Dialer Namespace


RequestLogoutAsync Method (IEnumerable(CampaignId), AsyncCompletedEventHandler, Object)

[image]

IceLib Dialer Technical Reference
DialerSession..::..RequestLogoutAsync Method (IEnumerable<(Of <(<'CampaignId>)>)>, AsyncCompletedEventHandler, Object)
DialerSession Class See Also Send Feedback
Asynchronously requests a logout for this agent for certain campaigns.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void RequestLogoutAsync(
    IEnumerable<CampaignId> campaigns,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub RequestLogoutAsync ( _
    campaigns As IEnumerable(Of CampaignId), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

campaigns
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' CampaignId >)>)>
The capaigns to log out of.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
userState
Type: System..::..Object

See Also

DialerSession Class
DialerSession Members
RequestLogoutAsync Overload
ININ.IceLib.Dialer Namespace


SetAgentType Method

[image] [image]

IceLib Dialer Technical Reference
DialerSession..::..SetAgentType Method
DialerSession Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetAgentType(AgentType) | Sets the AgentType for this agent in every campaign he/she is logged into.
Public method | SetAgentType(AgentType, IEnumerable<(Of <<'(CampaignId>)>>)) | Sets the AgentType for this agent for certain campaign..

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


SetAgentType Method (AgentType)

[image]

IceLib Dialer Technical Reference
DialerSession..::..SetAgentType Method (AgentType)
DialerSession Class See Also Send Feedback
Sets the AgentType for this agent in every campaign he/she is logged into.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void SetAgentType(
    AgentType agentType
)
Visual Basic
Public Sub SetAgentType ( _
    agentType As AgentType _
)

Parameters

agentType
Type: ININ.IceLib.Dialer..::..AgentType
The type of agent

Exceptions

Exception | Condition
ININ.IceLib.Dialer..::..InvalidDialerSessionException | This DialerSession is no longer valid.
System..::..ArgumentOutOfRangeException | The specified agentType is not from the AgentType enumeration.

See Also

DialerSession Class
DialerSession Members
SetAgentType Overload
ININ.IceLib.Dialer Namespace


SetAgentType Method (AgentType, IEnumerable(CampaignId))

[image]

IceLib Dialer Technical Reference
DialerSession..::..SetAgentType Method (AgentType, IEnumerable<(Of <(<'CampaignId>)>)>)
DialerSession Class See Also Send Feedback
Sets the AgentType for this agent for certain campaign..

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void SetAgentType(
    AgentType agentType,
    IEnumerable<CampaignId> campaigns
)
Visual Basic
Public Sub SetAgentType ( _
    agentType As AgentType, _
    campaigns As IEnumerable(Of CampaignId) _
)

Parameters

agentType
Type: ININ.IceLib.Dialer..::..AgentType
The type of agent.
campaigns
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' CampaignId >)>)>
The campaigns in which to set the agent type.

Exceptions

Exception | Condition
ININ.IceLib.Dialer..::..InvalidDialerSessionException | This DialerSession is no longer valid.
System..::..ArgumentOutOfRangeException | The specified agentType is not from the AgentType enumeration.

See Also

DialerSession Class
DialerSession Members
SetAgentType Overload
ININ.IceLib.Dialer Namespace


SetAgentTypeAsync Method

[image] [image]

IceLib Dialer Technical Reference
DialerSession..::..SetAgentTypeAsync Method
DialerSession Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetAgentTypeAsync(AgentType, AsyncCompletedEventHandler, Object) | Asynchronously sets the AgentType for this agent for every campaign he/she is logged into.
Public method | SetAgentTypeAsync(AgentType, IEnumerable<(Of <<'(CampaignId>)>>), AsyncCompletedEventHandler, Object) | Asynchronously sets the AgentType for this agent for certain campaigns.

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


SetAgentTypeAsync Method (AgentType, AsyncCompletedEventHandler, Object)

[image]

IceLib Dialer Technical Reference
DialerSession..::..SetAgentTypeAsync Method (AgentType, AsyncCompletedEventHandler, Object)
DialerSession Class See Also Send Feedback
Asynchronously sets the AgentType for this agent for every campaign he/she is logged into.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void SetAgentTypeAsync(
    AgentType agentType,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SetAgentTypeAsync ( _
    agentType As AgentType, _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

agentType
Type: ININ.IceLib.Dialer..::..AgentType
The type of agent
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified agentType is not from the AgentType enumeration.

See Also

DialerSession Class
DialerSession Members
SetAgentTypeAsync Overload
ININ.IceLib.Dialer Namespace


SetAgentTypeAsync Method (AgentType, IEnumerable(CampaignId), AsyncCompletedEventHandler, Object)

[image]

IceLib Dialer Technical Reference
DialerSession..::..SetAgentTypeAsync Method (AgentType, IEnumerable<(Of <(<'CampaignId>)>)>, AsyncCompletedEventHandler, Object)
DialerSession Class See Also Send Feedback
Asynchronously sets the AgentType for this agent for certain campaigns.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void SetAgentTypeAsync(
    AgentType agentType,
    IEnumerable<CampaignId> campaigns,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub SetAgentTypeAsync ( _
    agentType As AgentType, _
    campaigns As IEnumerable(Of CampaignId), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

agentType
Type: ININ.IceLib.Dialer..::..AgentType
The type of agent
campaigns
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' CampaignId >)>)>
The campaigns in which to set the agent type.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

Exceptions

Exception | Condition
System..::..ArgumentOutOfRangeException | The specified agentType is not from the AgentType enumeration.

See Also

DialerSession Class
DialerSession Members
SetAgentTypeAsync Overload
ININ.IceLib.Dialer Namespace


StartReceivingCalls Method

[image] [image]

IceLib Dialer Technical Reference
DialerSession..::..StartReceivingCalls Method
DialerSession Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StartReceivingCalls()()()() | Notifies Dialer that this agent is ready to start receiving calls for every campaign he/she is logged into.
Public method | StartReceivingCalls(IEnumerable<(Of <<'(CampaignId>)>>)) | Notifies Dialer that this agent is ready to start receiving calls for certain campaigns.

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


StartReceivingCalls Method

[image]

IceLib Dialer Technical Reference
DialerSession..::..StartReceivingCalls Method
DialerSession Class See Also Send Feedback
Notifies Dialer that this agent is ready to start receiving calls for every campaign he/she is logged into.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void StartReceivingCalls()
Visual Basic
Public Sub StartReceivingCalls

Remarks

After logging into a campaign, StartReceivingCalls()()()() must be called before the agent will begin receiving calls.

StartReceivingCalls()()()() should be called only once, when the agent is first ready to begin receiving calls.

Exceptions

Exception | Condition
ININ.IceLib.Dialer..::..InvalidDialerSessionException | This DialerSession is no longer valid.

See Also

DialerSession Class
DialerSession Members
StartReceivingCalls Overload
ININ.IceLib.Dialer Namespace


StartReceivingCalls Method (IEnumerable(CampaignId))

[image]

IceLib Dialer Technical Reference
DialerSession..::..StartReceivingCalls Method (IEnumerable<(Of <(<'CampaignId>)>)>)
DialerSession Class See Also Send Feedback
Notifies Dialer that this agent is ready to start receiving calls for certain campaigns.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void StartReceivingCalls(
    IEnumerable<CampaignId> campaigns
)
Visual Basic
Public Sub StartReceivingCalls ( _
    campaigns As IEnumerable(Of CampaignId) _
)

Parameters

campaigns
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' CampaignId >)>)>
The campaigns that the agent is logged into and ready to receive calls for.

See Also

DialerSession Class
DialerSession Members
StartReceivingCalls Overload
ININ.IceLib.Dialer Namespace


StartReceivingCallsAsync Method

[image] [image]

IceLib Dialer Technical Reference
DialerSession..::..StartReceivingCallsAsync Method
DialerSession Class See Also Send Feedback

Overload List

 | Name | Description
Public method | StartReceivingCallsAsync(AsyncCompletedEventHandler, Object) | Asynchronously notifies Dialer that this agent is ready to start receiving calls for every campaign he/she is logged into.
Public method | StartReceivingCallsAsync(IEnumerable<(Of <<'(CampaignId>)>>), AsyncCompletedEventHandler, Object) | Asynchrously notifies Dialer that this agent is ready to start receiving calls for certain campaigns.

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


StartReceivingCallsAsync Method (AsyncCompletedEventHandler, Object)

[image]

IceLib Dialer Technical Reference
DialerSession..::..StartReceivingCallsAsync Method (AsyncCompletedEventHandler, Object)
DialerSession Class See Also Send Feedback
Asynchronously notifies Dialer that this agent is ready to start receiving calls for every campaign he/she is logged into.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void StartReceivingCallsAsync(
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartReceivingCallsAsync ( _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

After logging into a campaign, StartReceivingCalls()()()() must be called before the agent will begin receiving calls.

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

See Also

DialerSession Class
DialerSession Members
StartReceivingCallsAsync Overload
ININ.IceLib.Dialer Namespace


StartReceivingCallsAsync Method (IEnumerable(CampaignId), AsyncCompletedEventHandler, Object)

[image]

IceLib Dialer Technical Reference
DialerSession..::..StartReceivingCallsAsync Method (IEnumerable<(Of <(<'CampaignId>)>)>, AsyncCompletedEventHandler, Object)
DialerSession Class See Also Send Feedback
Asynchrously notifies Dialer that this agent is ready to start receiving calls for certain campaigns.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void StartReceivingCallsAsync(
    IEnumerable<CampaignId> campaigns,
    AsyncCompletedEventHandler completedCallback,
    Object userState
)
Visual Basic
Public Sub StartReceivingCallsAsync ( _
    campaigns As IEnumerable(Of CampaignId), _
    completedCallback As AsyncCompletedEventHandler, _
    userState As Object _
)

Parameters

campaigns
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' CampaignId >)>)>
The campaigns that the agent is logged into and ready to receive calls from.
completedCallback
Type: System.ComponentModel..::..AsyncCompletedEventHandler
userState
Type: System..::..Object

See Also

DialerSession Class
DialerSession Members
StartReceivingCallsAsync Overload
ININ.IceLib.Dialer Namespace


DialerSession Properties

[image] [image]

IceLib Dialer Technical Reference
DialerSession Properties
DialerSession Class See Also Send Feedback

The DialerSession type exposes the following members.

Properties

 | Name | Description
Public property | BreakStatus | Gets the break status for the agent
Public property | CampaignName | Obsolete. Gets the campaign the agent is logged into.
Public property | Campaigns | Gets the campaigns the agent is logged into.
Public property | GlobalSession | True if the user logged on to Dialer without specifying any campaigns. When true, the user can receive auto login/logout notifications.
Public property | UseRecordSnippet |
Public property | UserID | Gets the ID of the user that the session belongs to.
Public property | WorkflowName | Obsolete. Gets the workflow the agent is logged into.

See Also

DialerSession Class
ININ.IceLib.Dialer Namespace


BreakStatus Property

[image]

IceLib Dialer Technical Reference
DialerSession..::..BreakStatus Property
DialerSession Class See Also Send Feedback
Gets the break status for the agent

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public BreakStatus BreakStatus { get; internal set; }
Visual Basic
Public Property BreakStatus As BreakStatus
    Get
    Friend Set

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


CampaignName Property

[image]

IceLib Dialer Technical Reference
DialerSession..::..CampaignName Property
DialerSession Class See Also Send Feedback
Gets the campaign the agent is logged into.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
[ObsoleteAttribute("Agents can now be logged into more than one campaign.  Use the Campaigns property instead.")]
public string CampaignName { get; }
Visual Basic
<ObsoleteAttribute("Agents can now be logged into more than one campaign.  Use the Campaigns property instead.")> _
Public ReadOnly Property CampaignName As String
    Get

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


Campaigns Property

[image]

IceLib Dialer Technical Reference
DialerSession..::..Campaigns Property
DialerSession Class See Also Send Feedback
Gets the campaigns the agent is logged into.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ReadOnlyCollection<CampaignId> Campaigns { get; }
Visual Basic
Public ReadOnly Property Campaigns As ReadOnlyCollection(Of CampaignId)
    Get

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


GlobalSession Property

[image]

IceLib Dialer Technical Reference
DialerSession..::..GlobalSession Property
DialerSession Class See Also Send Feedback
True if the user logged on to Dialer without specifying any campaigns. When true, the user can receive auto login/logout notifications.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool GlobalSession { get; internal set; }
Visual Basic
Public Property GlobalSession As Boolean
    Get
    Friend Set

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


UseRecordSnippet Property

[image]

IceLib Dialer Technical Reference
DialerSession..::..UseRecordSnippet Property
DialerSession Class See Also Send Feedback

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool UseRecordSnippet { get; }
Visual Basic
Public ReadOnly Property UseRecordSnippet As Boolean
    Get

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


UserID Property

[image]

IceLib Dialer Technical Reference
DialerSession..::..UserID Property
DialerSession Class See Also Send Feedback
Gets the ID of the user that the session belongs to.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string UserID { get; }
Visual Basic
Public ReadOnly Property UserID As String
    Get

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


WorkflowName Property

[image]

IceLib Dialer Technical Reference
DialerSession..::..WorkflowName Property
DialerSession Class See Also Send Feedback
Gets the workflow the agent is logged into.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
[ObsoleteAttribute("Workflows no longer exist.")]
public string WorkflowName { get; }
Visual Basic
<ObsoleteAttribute("Workflows no longer exist.")> _
Public ReadOnly Property WorkflowName As String
    Get

Field Value

The name of the workflow.

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


DialerSession Events

[image] [image]

IceLib Dialer Technical Reference
DialerSession Events
DialerSession Class See Also Send Feedback

The DialerSession type exposes the following members.

Events

 | Name | Description
Public event | AutoLogin | Occurs when one is automatically logged into a campaign via rule or supervisor.
Public event | AutoLogout | Occurs when one is automatically logged out of a campaign via rule or supervisor.
Public event | AutomaticBreakEnded | Occurs when an automatic break has ended.
Public event | BreakGranted | Occurs when a requested break has been granted.
Public event | CampaignTransition | Obsolete. Occurs when a campaign transition occurs for the workflow this DialerSession is associated with.
Public event | ContactDataLoaded | Occurs when the contact data for a follow up call has been loaded.
Public event | DataPop | Occurs when a Dialer call is added to the agent's queue.
Public event | DialerServerRestarted | Occurs when the dialing server restarted. Agents should logout from all campaigns and re-login to resume calling.
Public event | LogoutGranted | Occurs when a requested logout has been granted.
Public event | ManualOutboundCallStatus | Occurs when the status of a manually-initiated outbound call changes.
Public event | PreviewCallAdded | Occurs when a Preview call is added to the agent's queue.
Public event | PreviewTimeoutExpired | Occurs when the timeout associated with a preview call has elapsed and the preview call is about to be automatically dialed.
Public event | PreviewTimeoutStarted | Occurs when the timeout associated with a preview call has started.
Public event | PreviewTimeoutStopped | Occurs when the timeout associated with a preview call has stopped.

See Also

DialerSession Class
ININ.IceLib.Dialer Namespace


AutoLogin Event

[image]

IceLib Dialer Technical Reference
DialerSession..::..AutoLogin Event
DialerSession Class See Also Send Feedback
Occurs when one is automatically logged into a campaign via rule or supervisor.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public event EventHandler<AutoLoginEventArgs> AutoLogin
Visual Basic
Public Event AutoLogin As EventHandler(Of AutoLoginEventArgs)

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


AutoLogout Event

[image]

IceLib Dialer Technical Reference
DialerSession..::..AutoLogout Event
DialerSession Class See Also Send Feedback
Occurs when one is automatically logged out of a campaign via rule or supervisor.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public event EventHandler<AutoLogoutEventArgs> AutoLogout
Visual Basic
Public Event AutoLogout As EventHandler(Of AutoLogoutEventArgs)

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


AutomaticBreakEnded Event

[image]

IceLib Dialer Technical Reference
DialerSession..::..AutomaticBreakEnded Event
DialerSession Class See Also Send Feedback
Occurs when an automatic break has ended.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public event EventHandler AutomaticBreakEnded
Visual Basic
Public Event AutomaticBreakEnded As EventHandler

Remarks

An automatic break is one initiated by Dialer itself when an agent goes into a non-ACD status while idle within Dialer.

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


BreakGranted Event

[image]

IceLib Dialer Technical Reference
DialerSession..::..BreakGranted Event
DialerSession Class See Also Send Feedback
Occurs when a requested break has been granted.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public event EventHandler<BreakGrantedEventArgs> BreakGranted
Visual Basic
Public Event BreakGranted As EventHandler(Of BreakGrantedEventArgs)

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


CampaignTransition Event

[image]

IceLib Dialer Technical Reference
DialerSession..::..CampaignTransition Event
DialerSession Class See Also Send Feedback
Occurs when a campaign transition occurs for the workflow this DialerSession is associated with.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
[ObsoleteAttribute("Transitions no longer exist as campaigns are no longer associated with workflows")]
public event EventHandler<CampaignTransistionEventArgs> CampaignTransition
Visual Basic
<ObsoleteAttribute("Transitions no longer exist as campaigns are no longer associated with workflows")> _
Public Event CampaignTransition As EventHandler(Of CampaignTransistionEventArgs)

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


ContactDataLoaded Event

[image]

IceLib Dialer Technical Reference
DialerSession..::..ContactDataLoaded Event
DialerSession Class See Also Send Feedback
Occurs when the contact data for a follow up call has been loaded.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public event EventHandler<ContactDataLoadedEventArgs> ContactDataLoaded
Visual Basic
Public Event ContactDataLoaded As EventHandler(Of ContactDataLoadedEventArgs)

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


DataPop Event

[image]

IceLib Dialer Technical Reference
DialerSession..::..DataPop Event
DialerSession Class See Also Send Feedback
Occurs when a Dialer call is added to the agent's queue.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public event EventHandler<DataPopEventArgs> DataPop
Visual Basic
Public Event DataPop As EventHandler(Of DataPopEventArgs)

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


DialerServerRestarted Event

[image]

IceLib Dialer Technical Reference
DialerSession..::..DialerServerRestarted Event
DialerSession Class See Also Send Feedback
Occurs when the dialing server restarted. Agents should logout from all campaigns and re-login to resume calling.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public event EventHandler DialerServerRestarted
Visual Basic
Public Event DialerServerRestarted As EventHandler

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


LogoutGranted Event

[image]

IceLib Dialer Technical Reference
DialerSession..::..LogoutGranted Event
DialerSession Class See Also Send Feedback
Occurs when a requested logout has been granted.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public event EventHandler<LogoutGrantedEventArgs> LogoutGranted
Visual Basic
Public Event LogoutGranted As EventHandler(Of LogoutGrantedEventArgs)

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


ManualOutboundCallStatus Event

[image]

IceLib Dialer Technical Reference
DialerSession..::..ManualOutboundCallStatus Event
DialerSession Class See Also Send Feedback
Occurs when the status of a manually-initiated outbound call changes.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public event EventHandler<ManualOutboundCallStatusEventArgs> ManualOutboundCallStatus
Visual Basic
Public Event ManualOutboundCallStatus As EventHandler(Of ManualOutboundCallStatusEventArgs)

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


PreviewCallAdded Event

[image]

IceLib Dialer Technical Reference
DialerSession..::..PreviewCallAdded Event
DialerSession Class See Also Send Feedback
Occurs when a Preview call is added to the agent's queue.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public event EventHandler<PreviewCallAddedEventArgs> PreviewCallAdded
Visual Basic
Public Event PreviewCallAdded As EventHandler(Of PreviewCallAddedEventArgs)

Remarks

When this event is fired, the Preview call has not yet been placed.

Once the Preview call is placed using PlacePreviewCall()()()(), it will cause the DataPop event to be fired.

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


PreviewTimeoutExpired Event

[image]

IceLib Dialer Technical Reference
DialerSession..::..PreviewTimeoutExpired Event
DialerSession Class See Also Send Feedback
Occurs when the timeout associated with a preview call has elapsed and the preview call is about to be automatically dialed.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public event EventHandler<PreviewTimeoutExpiredEventArgs> PreviewTimeoutExpired
Visual Basic
Public Event PreviewTimeoutExpired As EventHandler(Of PreviewTimeoutExpiredEventArgs)

Remarks

The automatic dial can be cancelled by setting the Cancel member of the CancelEventArgs argument to true.

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


PreviewTimeoutStarted Event

[image]

IceLib Dialer Technical Reference
DialerSession..::..PreviewTimeoutStarted Event
DialerSession Class See Also Send Feedback
Occurs when the timeout associated with a preview call has started.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public event EventHandler<PreviewTimeoutStartedEventArgs> PreviewTimeoutStarted
Visual Basic
Public Event PreviewTimeoutStarted As EventHandler(Of PreviewTimeoutStartedEventArgs)

Remarks

This event will be fired just after the PreviewCallAdded event.

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


PreviewTimeoutStopped Event

[image]

IceLib Dialer Technical Reference
DialerSession..::..PreviewTimeoutStopped Event
DialerSession Class See Also Send Feedback
Occurs when the timeout associated with a preview call has stopped.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public event EventHandler<PreviewTimeoutStoppedEventArgs> PreviewTimeoutStopped
Visual Basic
Public Event PreviewTimeoutStopped As EventHandler(Of PreviewTimeoutStoppedEventArgs)

Remarks

This event will be fired if the preview timer is stopped before it has expired, typically due to the call being placed or skipped.

See Also

DialerSession Class
DialerSession Members
ININ.IceLib.Dialer Namespace


DialingManager Class

[image]

IceLib Dialer Technical Reference
DialingManager Class
Members See Also Send Feedback
Provides access to outbound dialing functionality.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class DialingManager
Visual Basic
Public Class DialingManager

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Dialer..::..DialingManager

See Also

DialingManager Members
ININ.IceLib.Dialer Namespace


DialingManager Members

[image] [image]

IceLib Dialer Technical Reference
DialingManager Members
DialingManager Class Constructors Methods Properties Events See Also Send Feedback

The DialingManager type exposes the following members.

Constructors

 | Name | Description
Public method | DialingManager | Initializes a new instance of the DialingManager class.

Methods

 | Name | Description
Public method | AgentlessCallComplete | Dispositions a call that is not owned by a specific agent.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAvailableCampaigns | Gets the list of campaigns the agent can log into.
Public method | GetAvailableCampaignsAsync | Asynchronously gets the list of campaigns an agent can log into.
Public method | GetAvailableWorkflows | Obsolete. Gets the list of workflows the agent can log into.
Public method | GetAvailableWorkflowsAsync | Obsolete. Asynchronously gets the list of workflows an agent can log into.
Public method | GetCampaignScriptConfiguration | Retrieve configuration data for an active campaign and its base script.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Logon()()()() | Logs an agent into Dialer without logging in to any campaigns.
Public method | Logon(LogonParameters) | Logs an agent into a Dialer campaign.
Public method | LogonAsync(EventHandler<(Of <<'(LogonCompletedEventArgs>)>>), Object) | Asynchronously logs an agent into Dialer without logging in to any campaigns.
Public method | LogonAsync(LogonParameters, EventHandler<(Of <<'(LogonCompletedEventArgs>)>>), Object) | Asynchronously logs an agent into a Dialer campaign.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | DialerSession | Gets the DialerSession for this agent, if one exists.
Public property | Session | Gets the Session used by the DialingManager.

Events

 | Name | Description
Public event | CampaignStarted | Occurs when a Dialer campaign is started.
Public event | CampaignStopped | Occurs when a Dialer campaign is stopped.
Public event | WorkflowStarted | Obsolete. Occurs when a Dialer workflow is started.
Public event | WorkflowStopped | Obsolete. Occurs when a Dialer workflow is stopped.

See Also

DialingManager Class
ININ.IceLib.Dialer Namespace


DialingManager Constructor

[image]

IceLib Dialer Technical Reference
DialingManager Constructor
DialingManager Class See Also Send Feedback
Initializes a new instance of the DialingManager class.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DialingManager(
    Session session
)
Visual Basic
Public Sub New ( _
    session As Session _
)

Parameters

session
Type: Session
The Session to be used. The session must already be initialized and connected.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).
IceLibException | The supplied Session is not valid or is not connected.

See Also

DialingManager Class
DialingManager Members
ININ.IceLib.Dialer Namespace


DialingManager Methods

[image] [image]

IceLib Dialer Technical Reference
DialingManager Methods
DialingManager Class See Also Send Feedback

The DialingManager type exposes the following members.

Methods

 | Name | Description
Public method | AgentlessCallComplete | Dispositions a call that is not owned by a specific agent.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAvailableCampaigns | Gets the list of campaigns the agent can log into.
Public method | GetAvailableCampaignsAsync | Asynchronously gets the list of campaigns an agent can log into.
Public method | GetAvailableWorkflows | Obsolete. Gets the list of workflows the agent can log into.
Public method | GetAvailableWorkflowsAsync | Obsolete. Asynchronously gets the list of workflows an agent can log into.
Public method | GetCampaignScriptConfiguration | Retrieve configuration data for an active campaign and its base script.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Logon()()()() | Logs an agent into Dialer without logging in to any campaigns.
Public method | Logon(LogonParameters) | Logs an agent into a Dialer campaign.
Public method | LogonAsync(EventHandler<(Of <<'(LogonCompletedEventArgs>)>>), Object) | Asynchronously logs an agent into Dialer without logging in to any campaigns.
Public method | LogonAsync(LogonParameters, EventHandler<(Of <<'(LogonCompletedEventArgs>)>>), Object) | Asynchronously logs an agent into a Dialer campaign.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DialingManager Class
ININ.IceLib.Dialer Namespace


AgentlessCallComplete Method

[image]

IceLib Dialer Technical Reference
DialingManager..::..AgentlessCallComplete Method
DialingManager Class See Also Send Feedback
Dispositions a call that is not owned by a specific agent.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void AgentlessCallComplete(
    AgentlessCallCompletionParameters callCompletionParameters
)
Visual Basic
Public Sub AgentlessCallComplete ( _
    callCompletionParameters As AgentlessCallCompletionParameters _
)

Parameters

callCompletionParameters
Type: ININ.IceLib.Dialer..::..AgentlessCallCompletionParameters
The parameters specifying how this call should be dispositioned.

Remarks

Use this member to complete the call that isn't owned by an agent and send the result back to Dialer.

After CallComplete(CallCompletionParameters) has been called, no further Dialer actions can be used on it.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

See Also

DialingManager Class
DialingManager Members
ININ.IceLib.Dialer Namespace


GetAvailableCampaigns Method

[image]

IceLib Dialer Technical Reference
DialingManager..::..GetAvailableCampaigns Method
DialingManager Class See Also Send Feedback
Gets the list of campaigns the agent can log into.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string[] GetAvailableCampaigns()
Visual Basic
Public Function GetAvailableCampaigns As String()

Return Value

An array of campaign names.

See Also

DialingManager Class
DialingManager Members
ININ.IceLib.Dialer Namespace


GetAvailableCampaignsAsync Method

[image]

IceLib Dialer Technical Reference
DialingManager..::..GetAvailableCampaignsAsync Method
DialingManager Class See Also Send Feedback
Asynchronously gets the list of campaigns an agent can log into.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void GetAvailableCampaignsAsync(
    EventHandler<GetAvailableCampaignsCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub GetAvailableCampaignsAsync ( _
    completedCallback As EventHandler(Of GetAvailableCampaignsCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<' GetAvailableCampaignsCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

See Also

DialingManager Class
DialingManager Members
ININ.IceLib.Dialer Namespace


GetAvailableWorkflows Method

[image]

IceLib Dialer Technical Reference
DialingManager..::..GetAvailableWorkflows Method
DialingManager Class See Also Send Feedback
Gets the list of workflows the agent can log into.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
[ObsoleteAttribute("Workflows no longer exist.  Use GetAvailableCampaigns.")]
public string[] GetAvailableWorkflows()
Visual Basic
<ObsoleteAttribute("Workflows no longer exist.  Use GetAvailableCampaigns.")> _
Public Function GetAvailableWorkflows As String()

Return Value

An array of workflow names.

See Also

DialingManager Class
DialingManager Members
ININ.IceLib.Dialer Namespace


GetAvailableWorkflowsAsync Method

[image]

IceLib Dialer Technical Reference
DialingManager..::..GetAvailableWorkflowsAsync Method
DialingManager Class See Also Send Feedback
Asynchronously gets the list of workflows an agent can log into.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
[ObsoleteAttribute("Workflows no longer exist.  Use GetAvailableCampaignsAsync.")]
public void GetAvailableWorkflowsAsync(
    EventHandler<GetAvailableWorkflowsCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
<ObsoleteAttribute("Workflows no longer exist.  Use GetAvailableCampaignsAsync.")> _
Public Sub GetAvailableWorkflowsAsync ( _
    completedCallback As EventHandler(Of GetAvailableWorkflowsCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<' GetAvailableWorkflowsCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

See Also

DialingManager Class
DialingManager Members
ININ.IceLib.Dialer Namespace


GetCampaignScriptConfiguration Method

[image]

IceLib Dialer Technical Reference
DialingManager..::..GetCampaignScriptConfiguration Method
DialingManager Class See Also Send Feedback
Retrieve configuration data for an active campaign and its base script.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CampaignScriptConfiguration GetCampaignScriptConfiguration(
    string campaignName
)
Visual Basic
Public Function GetCampaignScriptConfiguration ( _
    campaignName As String _
) As CampaignScriptConfiguration

Parameters

campaignName
Type: System..::..String
The name of the campaign.

Return Value

A CampaignScriptConfiguration object containing configuration data for the campaign and its base script.

Exceptions

Exception | Condition
System..::..ArgumentException | The campaign does not exist, is not active, or is not configured to use a base script.
System..::..ArgumentNullException | campaignName is empty or a null reference (Nothing in Visual Basic).

See Also

DialingManager Class
DialingManager Members
ININ.IceLib.Dialer Namespace


Logon Method

[image] [image]

IceLib Dialer Technical Reference
DialingManager..::..Logon Method
DialingManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Logon()()()() | Logs an agent into Dialer without logging in to any campaigns.
Public method | Logon(LogonParameters) | Logs an agent into a Dialer campaign.

See Also

DialingManager Class
DialingManager Members
ININ.IceLib.Dialer Namespace


Logon Method

[image]

IceLib Dialer Technical Reference
DialingManager..::..Logon Method
DialingManager Class See Also Send Feedback
Logs an agent into Dialer without logging in to any campaigns.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public LogonResult Logon()
Visual Basic
Public Function Logon As LogonResult

Return Value

A LogonResult containing the results of the logon attempt.

Remarks

Agents need not call this method before logging in to a campaign, as they will be automatically logged in to Dialer when using Logon(LogonParameters)

Exceptions

Exception | Condition
System..::..InvalidOperationException | There is already an active DialerSession. The active DialerSession must be logged off before a new logon can be performed.
ININ.IceLib.Dialer..::..DialerLogonFailedException | The logon attempt failed. The exception message will give more information about the failure.

See Also

DialingManager Class
DialingManager Members
Logon Overload
ININ.IceLib.Dialer Namespace


Logon Method (LogonParameters)

[image]

IceLib Dialer Technical Reference
DialingManager..::..Logon Method (LogonParameters)
DialingManager Class See Also Send Feedback
Logs an agent into a Dialer campaign.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public LogonResult Logon(
    LogonParameters logonParameters
)
Visual Basic
Public Function Logon ( _
    logonParameters As LogonParameters _
) As LogonResult

Parameters

logonParameters
Type: ININ.IceLib.Dialer..::..LogonParameters
A LogonParameters instance specifying the parameters to use when logging in.

Return Value

A LogonResult containing the results of the logon attempt.

Exceptions

Exception | Condition
System..::..InvalidOperationException | There is already an active DialerSession. The active DialerSession must be logged off before a new logon can be performed.
ININ.IceLib.Dialer..::..DialerLogonFailedException | The logon attempt failed. The exception message will give more information about the failure.
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

See Also

DialingManager Class
DialingManager Members
Logon Overload
ININ.IceLib.Dialer Namespace


LogonAsync Method

[image] [image]

IceLib Dialer Technical Reference
DialingManager..::..LogonAsync Method
DialingManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | LogonAsync(EventHandler<(Of <<'(LogonCompletedEventArgs>)>>), Object) | Asynchronously logs an agent into Dialer without logging in to any campaigns.
Public method | LogonAsync(LogonParameters, EventHandler<(Of <<'(LogonCompletedEventArgs>)>>), Object) | Asynchronously logs an agent into a Dialer campaign.

See Also

DialingManager Class
DialingManager Members
ININ.IceLib.Dialer Namespace


LogonAsync Method (EventHandler(LogonCompletedEventArgs), Object)

[image]

IceLib Dialer Technical Reference
DialingManager..::..LogonAsync Method (EventHandler<(Of <(<'LogonCompletedEventArgs>)>)>, Object)
DialingManager Class See Also Send Feedback
Asynchronously logs an agent into Dialer without logging in to any campaigns.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void LogonAsync(
    EventHandler<LogonCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub LogonAsync ( _
    completedCallback As EventHandler(Of LogonCompletedEventArgs), _
    userState As Object _
)

Parameters

completedCallback
Type: System..::..EventHandler<(Of <(<' LogonCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

See Also

DialingManager Class
DialingManager Members
LogonAsync Overload
ININ.IceLib.Dialer Namespace


LogonAsync Method (LogonParameters, EventHandler(LogonCompletedEventArgs), Object)

[image]

IceLib Dialer Technical Reference
DialingManager..::..LogonAsync Method (LogonParameters, EventHandler<(Of <(<'LogonCompletedEventArgs>)>)>, Object)
DialingManager Class See Also Send Feedback
Asynchronously logs an agent into a Dialer campaign.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void LogonAsync(
    LogonParameters logonParameters,
    EventHandler<LogonCompletedEventArgs> completedCallback,
    Object userState
)
Visual Basic
Public Sub LogonAsync ( _
    logonParameters As LogonParameters, _
    completedCallback As EventHandler(Of LogonCompletedEventArgs), _
    userState As Object _
)

Parameters

logonParameters
Type: ININ.IceLib.Dialer..::..LogonParameters
A LogonParameters instance specifying the parameters to use when logging in
completedCallback
Type: System..::..EventHandler<(Of <(<' LogonCompletedEventArgs >)>)>
The callback to invoke when the asynchronous operation completes.
userState
Type: System..::..Object
An object that contains state information for this request.

Remarks

When completed, the completedCallback delegate is invoked on a thread appropriate to the application-model, such as the GUI thread in a UI application. The Error property of the AsyncCompletedEventArgs-derived object passed to the delegate will contain any exceptions thrown while executing the asynchronous task. See the synchronous version of this method for more detailed error information.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

See Also

DialingManager Class
DialingManager Members
LogonAsync Overload
ININ.IceLib.Dialer Namespace


DialingManager Properties

[image] [image]

IceLib Dialer Technical Reference
DialingManager Properties
DialingManager Class See Also Send Feedback

The DialingManager type exposes the following members.

Properties

 | Name | Description
Public property | DialerSession | Gets the DialerSession for this agent, if one exists.
Public property | Session | Gets the Session used by the DialingManager.

See Also

DialingManager Class
ININ.IceLib.Dialer Namespace


DialerSession Property

[image]

IceLib Dialer Technical Reference
DialingManager..::..DialerSession Property
DialingManager Class See Also Send Feedback
Gets the DialerSession for this agent, if one exists.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DialerSession DialerSession { get; set; }
Visual Basic
Public Property DialerSession As DialerSession
    Get
    Set

Field Value

The DialerSession if the agent is currently logged into any Dialer campaigns, nullNothingnullptra null reference (Nothing in Visual Basic) otherwise.

See Also

DialingManager Class
DialingManager Members
ININ.IceLib.Dialer Namespace


Session Property

[image]

IceLib Dialer Technical Reference
DialingManager..::..Session Property
DialingManager Class See Also Send Feedback
Gets the Session used by the DialingManager.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Session Session { get; }
Visual Basic
Public ReadOnly Property Session As Session
    Get

Field Value

The session.

See Also

DialingManager Class
DialingManager Members
ININ.IceLib.Dialer Namespace


DialingManager Events

[image] [image]

IceLib Dialer Technical Reference
DialingManager Events
DialingManager Class See Also Send Feedback

The DialingManager type exposes the following members.

Events

 | Name | Description
Public event | CampaignStarted | Occurs when a Dialer campaign is started.
Public event | CampaignStopped | Occurs when a Dialer campaign is stopped.
Public event | WorkflowStarted | Obsolete. Occurs when a Dialer workflow is started.
Public event | WorkflowStopped | Obsolete. Occurs when a Dialer workflow is stopped.

See Also

DialingManager Class
ININ.IceLib.Dialer Namespace


CampaignStarted Event

[image]

IceLib Dialer Technical Reference
DialingManager..::..CampaignStarted Event
DialingManager Class See Also Send Feedback
Occurs when a Dialer campaign is started.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public event EventHandler<CampaignStartedEventArgs> CampaignStarted
Visual Basic
Public Event CampaignStarted As EventHandler(Of CampaignStartedEventArgs)

See Also

DialingManager Class
DialingManager Members
ININ.IceLib.Dialer Namespace


CampaignStopped Event

[image]

IceLib Dialer Technical Reference
DialingManager..::..CampaignStopped Event
DialingManager Class See Also Send Feedback
Occurs when a Dialer campaign is stopped.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public event EventHandler<CampaignStoppedEventArgs> CampaignStopped
Visual Basic
Public Event CampaignStopped As EventHandler(Of CampaignStoppedEventArgs)

See Also

DialingManager Class
DialingManager Members
ININ.IceLib.Dialer Namespace


WorkflowStarted Event

[image]

IceLib Dialer Technical Reference
DialingManager..::..WorkflowStarted Event
DialingManager Class See Also Send Feedback
Occurs when a Dialer workflow is started.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
[ObsoleteAttribute("Workflows no longer exist.  Use CampaignStarted instead.")]
public event EventHandler<WorkflowStartedEventArgs> WorkflowStarted
Visual Basic
<ObsoleteAttribute("Workflows no longer exist.  Use CampaignStarted instead.")> _
Public Event WorkflowStarted As EventHandler(Of WorkflowStartedEventArgs)

See Also

DialingManager Class
DialingManager Members
ININ.IceLib.Dialer Namespace


WorkflowStopped Event

[image]

IceLib Dialer Technical Reference
DialingManager..::..WorkflowStopped Event
DialingManager Class See Also Send Feedback
Occurs when a Dialer workflow is stopped.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
[ObsoleteAttribute("Workflows no longer exist.  Use CampaignStopped instead.")]
public event EventHandler<WorkflowStoppedEventArgs> WorkflowStopped
Visual Basic
<ObsoleteAttribute("Workflows no longer exist.  Use CampaignStopped instead.")> _
Public Event WorkflowStopped As EventHandler(Of WorkflowStoppedEventArgs)

See Also

DialingManager Class
DialingManager Members
ININ.IceLib.Dialer Namespace


DialingMode Enumeration

[image]

IceLib Dialer Technical Reference
DialingMode Enumeration
See Also Send Feedback
Specifies constants indicating the dialing mode for a DialerCallInteraction.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum DialingMode
Visual Basic
Public Enumeration DialingMode

Members

Member name | Value | Description
Regular | 0 | This is a regularly-dialed call.
Preview | 1 | This is a Preview call.
OwnAgentCallback | 3 | This is an agent-owned callback from a non-preview campaign.
OwnAgentCallback_Preview | 4 | This is an agent-owned callback from a preview campaign.
Agentless | 7 | This is an agentless call.
Precise | 8 | This is a precisely-dialed call.
Manual | 9 | This is a manually-dialed outbound call.

See Also

ININ.IceLib.Dialer Namespace


GetAvailableCampaignsCompletedEventArgs Class

[image]

IceLib Dialer Technical Reference
GetAvailableCampaignsCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the asynchronous completed events of DialingManager.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class GetAvailableCampaignsCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class GetAvailableCampaignsCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Dialer..::..GetAvailableCampaignsCompletedEventArgs

See Also

GetAvailableCampaignsCompletedEventArgs Members
ININ.IceLib.Dialer Namespace


GetAvailableCampaignsCompletedEventArgs Members

[image] [image]

IceLib Dialer Technical Reference
GetAvailableCampaignsCompletedEventArgs Members
GetAvailableCampaignsCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The GetAvailableCampaignsCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | GetAvailableCampaignsCompletedEventArgs | Initializes a new instance of the GetAvailableCampaignsCompletedEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | AvailableCampaigns | Gets the available campaigns associated with the event.
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetAvailableCampaignsCompletedEventArgs Class
ININ.IceLib.Dialer Namespace


GetAvailableCampaignsCompletedEventArgs Constructor

[image]

IceLib Dialer Technical Reference
GetAvailableCampaignsCompletedEventArgs Constructor
GetAvailableCampaignsCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the GetAvailableCampaignsCompletedEventArgs class with the specified values.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public GetAvailableCampaignsCompletedEventArgs(
    string[] availableCampaigns,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    availableCampaigns As String(), _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

availableCampaigns
Type: array<System..::..String>[]()[][]
The list of campaigns an agent can log into.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to true the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

See Also

GetAvailableCampaignsCompletedEventArgs Class
GetAvailableCampaignsCompletedEventArgs Members
ININ.IceLib.Dialer Namespace


GetAvailableCampaignsCompletedEventArgs Methods

[image] [image]

IceLib Dialer Technical Reference
GetAvailableCampaignsCompletedEventArgs Methods
GetAvailableCampaignsCompletedEventArgs Class See Also Send Feedback

The GetAvailableCampaignsCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetAvailableCampaignsCompletedEventArgs Class
ININ.IceLib.Dialer Namespace


GetAvailableCampaignsCompletedEventArgs Properties

[image] [image]

IceLib Dialer Technical Reference
GetAvailableCampaignsCompletedEventArgs Properties
GetAvailableCampaignsCompletedEventArgs Class See Also Send Feedback

The GetAvailableCampaignsCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | AvailableCampaigns | Gets the available campaigns associated with the event.
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetAvailableCampaignsCompletedEventArgs Class
ININ.IceLib.Dialer Namespace


AvailableCampaigns Property

[image]

IceLib Dialer Technical Reference
GetAvailableCampaignsCompletedEventArgs..::..AvailableCampaigns Property
GetAvailableCampaignsCompletedEventArgs Class See Also Send Feedback
Gets the available campaigns associated with the event.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string[] AvailableCampaigns { get; }
Visual Basic
Public ReadOnly Property AvailableCampaigns As String()
    Get

Field Value

the list of campaigns an agent can log into.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

See Also

GetAvailableCampaignsCompletedEventArgs Class
GetAvailableCampaignsCompletedEventArgs Members
ININ.IceLib.Dialer Namespace


GetAvailableWorkflowsCompletedEventArgs Class

[image]

IceLib Dialer Technical Reference
GetAvailableWorkflowsCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the asynchronous completed events of DialingManager.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
[ObsoleteAttribute("Workflows no longer exist.  Use GetAvailableCampaigns instead.")]
public class GetAvailableWorkflowsCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
<ObsoleteAttribute("Workflows no longer exist.  Use GetAvailableCampaigns instead.")> _
Public Class GetAvailableWorkflowsCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Dialer..::..GetAvailableWorkflowsCompletedEventArgs

See Also

GetAvailableWorkflowsCompletedEventArgs Members
ININ.IceLib.Dialer Namespace


GetAvailableWorkflowsCompletedEventArgs Members

[image] [image]

IceLib Dialer Technical Reference
GetAvailableWorkflowsCompletedEventArgs Members
GetAvailableWorkflowsCompletedEventArgs Class Methods Properties See Also Send Feedback

The GetAvailableWorkflowsCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetAvailableWorkflowsCompletedEventArgs Class
ININ.IceLib.Dialer Namespace


GetAvailableWorkflowsCompletedEventArgs Methods

[image] [image]

IceLib Dialer Technical Reference
GetAvailableWorkflowsCompletedEventArgs Methods
GetAvailableWorkflowsCompletedEventArgs Class See Also Send Feedback

The GetAvailableWorkflowsCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GetAvailableWorkflowsCompletedEventArgs Class
ININ.IceLib.Dialer Namespace


GetAvailableWorkflowsCompletedEventArgs Properties

[image] [image]

IceLib Dialer Technical Reference
GetAvailableWorkflowsCompletedEventArgs Properties
GetAvailableWorkflowsCompletedEventArgs Class See Also Send Feedback

The GetAvailableWorkflowsCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

GetAvailableWorkflowsCompletedEventArgs Class
ININ.IceLib.Dialer Namespace


InvalidDialerCallInteractionException Class

[image]

IceLib Dialer Technical Reference
InvalidDialerCallInteractionException Class
Members See Also Send Feedback
The exception that is thrown when a dialing action is attempted on an invalid DialerCallInteraction

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
[SerializableAttribute]
public class InvalidDialerCallInteractionException : IceLibException
Visual Basic
<SerializableAttribute> _
Public Class InvalidDialerCallInteractionException _
    Inherits IceLibException

Remarks

This exception is thrown when an invalid DialerCallInteraction is used. This is often caused by trying to use dialing actions on an interaction that has already been dispositioned.

Like all IceLib-specific exceptions, this object derives from IceLibException, allowing consistent exception handling for all such exceptions.

Inheritance Hierarchy

System..::..Object
System..::..Exception
IceLibException
ININ.IceLib.Dialer..::..InvalidDialerCallInteractionException

See Also

InvalidDialerCallInteractionException Members
ININ.IceLib.Dialer Namespace


InvalidDialerCallInteractionException Members

[image] [image]

IceLib Dialer Technical Reference
InvalidDialerCallInteractionException Members
InvalidDialerCallInteractionException Class Constructors Methods Properties Events See Also Send Feedback

The InvalidDialerCallInteractionException type exposes the following members.

Constructors

 | Name | Description
Public method | InvalidDialerCallInteractionException()()()() | Initializes a new instance of the InvalidDialerCallInteractionException class with default settings.
Public method | InvalidDialerCallInteractionException(DialerCallInteraction) | Initializes a new instance of the InvalidDialerCallInteractionException class for a specific DialerCallInteraction.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | (Inherited from IceLibException.)
Public property | ErrorType | (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidDialerCallInteractionException Class
ININ.IceLib.Dialer Namespace


InvalidDialerCallInteractionException Constructor

[image] [image]

IceLib Dialer Technical Reference
InvalidDialerCallInteractionException Constructor
InvalidDialerCallInteractionException Class See Also Send Feedback
Initializes a new instance of the InvalidDialerCallInteractionException class.

Overload List

 | Name | Description
Public method | InvalidDialerCallInteractionException()()()() | Initializes a new instance of the InvalidDialerCallInteractionException class with default settings.
Public method | InvalidDialerCallInteractionException(DialerCallInteraction) | Initializes a new instance of the InvalidDialerCallInteractionException class for a specific DialerCallInteraction.

See Also

InvalidDialerCallInteractionException Class
InvalidDialerCallInteractionException Members
ININ.IceLib.Dialer Namespace


InvalidDialerCallInteractionException Constructor

[image]

IceLib Dialer Technical Reference
InvalidDialerCallInteractionException Constructor
InvalidDialerCallInteractionException Class See Also Send Feedback
Initializes a new instance of the InvalidDialerCallInteractionException class with default settings.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public InvalidDialerCallInteractionException()
Visual Basic
Public Sub New

See Also

InvalidDialerCallInteractionException Class
InvalidDialerCallInteractionException Members
InvalidDialerCallInteractionException Overload
ININ.IceLib.Dialer Namespace


InvalidDialerCallInteractionException Constructor (DialerCallInteraction)

[image]

IceLib Dialer Technical Reference
InvalidDialerCallInteractionException Constructor (DialerCallInteraction)
InvalidDialerCallInteractionException Class See Also Send Feedback
Initializes a new instance of the InvalidDialerCallInteractionException class for a specific DialerCallInteraction.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public InvalidDialerCallInteractionException(
    DialerCallInteraction dialerCallInteraction
)
Visual Basic
Public Sub New ( _
    dialerCallInteraction As DialerCallInteraction _
)

Parameters

dialerCallInteraction
Type: ININ.IceLib.Dialer..::..DialerCallInteraction
The invalid DialerCallInteraction

See Also

InvalidDialerCallInteractionException Class
InvalidDialerCallInteractionException Members
InvalidDialerCallInteractionException Overload
ININ.IceLib.Dialer Namespace


InvalidDialerCallInteractionException Methods

[image] [image]

IceLib Dialer Technical Reference
InvalidDialerCallInteractionException Methods
InvalidDialerCallInteractionException Class See Also Send Feedback

The InvalidDialerCallInteractionException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidDialerCallInteractionException Class
ININ.IceLib.Dialer Namespace


InvalidDialerCallInteractionException Properties

[image] [image]

IceLib Dialer Technical Reference
InvalidDialerCallInteractionException Properties
InvalidDialerCallInteractionException Class See Also Send Feedback

The InvalidDialerCallInteractionException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | (Inherited from IceLibException.)
Public property | ErrorType | (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidDialerCallInteractionException Class
ININ.IceLib.Dialer Namespace


InvalidDialerCallInteractionException Events

[image] [image]

IceLib Dialer Technical Reference
InvalidDialerCallInteractionException Events
InvalidDialerCallInteractionException Class See Also Send Feedback

The InvalidDialerCallInteractionException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidDialerCallInteractionException Class
ININ.IceLib.Dialer Namespace


InvalidDialerSessionException Class

[image]

IceLib Dialer Technical Reference
InvalidDialerSessionException Class
Members See Also Send Feedback
The exception that is thrown when an action is attempted on an invalid DialerSession.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
[SerializableAttribute]
public class InvalidDialerSessionException : IceLibException
Visual Basic
<SerializableAttribute> _
Public Class InvalidDialerSessionException _
    Inherits IceLibException

Remarks

This exception is thrown when an invalid DialerSession is used. This is often caused by trying to use a DialerSession after the agent has logged out.

Like all IceLib-specific exceptions, this object derives from IceLibException, allowing consistent exception handling for all such exceptions.

Inheritance Hierarchy

System..::..Object
System..::..Exception
IceLibException
ININ.IceLib.Dialer..::..InvalidDialerSessionException

See Also

InvalidDialerSessionException Members
ININ.IceLib.Dialer Namespace


InvalidDialerSessionException Members

[image] [image]

IceLib Dialer Technical Reference
InvalidDialerSessionException Members
InvalidDialerSessionException Class Constructors Methods Properties Events See Also Send Feedback

The InvalidDialerSessionException type exposes the following members.

Constructors

 | Name | Description
Public method | InvalidDialerSessionException()()()() | Initializes a new instance of the InvalidDialerSessionException class with default settings.
Public method | InvalidDialerSessionException(DialerSession) | Initializes a new instance of the InvalidDialerSessionException class for a specific DialerSession.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | (Inherited from IceLibException.)
Public property | ErrorType | (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidDialerSessionException Class
ININ.IceLib.Dialer Namespace


InvalidDialerSessionException Constructor

[image] [image]

IceLib Dialer Technical Reference
InvalidDialerSessionException Constructor
InvalidDialerSessionException Class See Also Send Feedback
Initializes a new instance of the InvalidDialerSessionException class.

Overload List

 | Name | Description
Public method | InvalidDialerSessionException()()()() | Initializes a new instance of the InvalidDialerSessionException class with default settings.
Public method | InvalidDialerSessionException(DialerSession) | Initializes a new instance of the InvalidDialerSessionException class for a specific DialerSession.

See Also

InvalidDialerSessionException Class
InvalidDialerSessionException Members
ININ.IceLib.Dialer Namespace


InvalidDialerSessionException Constructor

[image]

IceLib Dialer Technical Reference
InvalidDialerSessionException Constructor
InvalidDialerSessionException Class See Also Send Feedback
Initializes a new instance of the InvalidDialerSessionException class with default settings.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public InvalidDialerSessionException()
Visual Basic
Public Sub New

See Also

InvalidDialerSessionException Class
InvalidDialerSessionException Members
InvalidDialerSessionException Overload
ININ.IceLib.Dialer Namespace


InvalidDialerSessionException Constructor (DialerSession)

[image]

IceLib Dialer Technical Reference
InvalidDialerSessionException Constructor (DialerSession)
InvalidDialerSessionException Class See Also Send Feedback
Initializes a new instance of the InvalidDialerSessionException class for a specific DialerSession.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public InvalidDialerSessionException(
    DialerSession session
)
Visual Basic
Public Sub New ( _
    session As DialerSession _
)

Parameters

session
Type: ININ.IceLib.Dialer..::..DialerSession
The invalid DialerSession

See Also

InvalidDialerSessionException Class
InvalidDialerSessionException Members
InvalidDialerSessionException Overload
ININ.IceLib.Dialer Namespace


InvalidDialerSessionException Methods

[image] [image]

IceLib Dialer Technical Reference
InvalidDialerSessionException Methods
InvalidDialerSessionException Class See Also Send Feedback

The InvalidDialerSessionException type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidDialerSessionException Class
ININ.IceLib.Dialer Namespace


InvalidDialerSessionException Properties

[image] [image]

IceLib Dialer Technical Reference
InvalidDialerSessionException Properties
InvalidDialerSessionException Class See Also Send Feedback

The InvalidDialerSessionException type exposes the following members.

Properties

 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ErrorCode | (Inherited from IceLibException.)
Public property | ErrorType | (Inherited from IceLibException.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidDialerSessionException Class
ININ.IceLib.Dialer Namespace


InvalidDialerSessionException Events

[image] [image]

IceLib Dialer Technical Reference
InvalidDialerSessionException Events
InvalidDialerSessionException Class See Also Send Feedback

The InvalidDialerSessionException type exposes the following members.

Events

 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)

See Also

InvalidDialerSessionException Class
ININ.IceLib.Dialer Namespace


LastTransitionData Class

[image]

IceLib Dialer Technical Reference
LastTransitionData Class
Members See Also Send Feedback
An object to encapsulate the time of the last Active Rule group Transition and the name of the previous group.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class LastTransitionData
Visual Basic
Public Class LastTransitionData

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Dialer..::..LastTransitionData

See Also

LastTransitionData Members
ININ.IceLib.Dialer Namespace


LastTransitionData Members

[image] [image]

IceLib Dialer Technical Reference
LastTransitionData Members
LastTransitionData Class Constructors Methods Properties See Also Send Feedback

The LastTransitionData type exposes the following members.

Constructors

 | Name | Description
Public method | LastTransitionData | /// Initializes a new instance of the LastTransitionData class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActiveGroupName | The name of the current Active Rule Group
Public property | LastGroupName | The name of the previous Active Rule Group
Public property | Offset | The offset between the UTC time and the CCS time in minutes.
Public property | UTCTime | The Universal time of the last transition

See Also

LastTransitionData Class
ININ.IceLib.Dialer Namespace


LastTransitionData Constructor

[image]

IceLib Dialer Technical Reference
LastTransitionData Constructor
LastTransitionData Class See Also Send Feedback
/// Initializes a new instance of the LastTransitionData class.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public LastTransitionData(
    long time,
    long offset,
    string lastGroupName,
    string activeGroupName
)
Visual Basic
Public Sub New ( _
    time As Long, _
    offset As Long, _
    lastGroupName As String, _
    activeGroupName As String _
)

Parameters

time
Type: System..::..Int64
number of seconds between the time of the last transition, and 1970.
offset
Type: System..::..Int64
Number of seconds between the CCS time and the UTC time.
lastGroupName
Type: System..::..String
activeGroupName
Type: System..::..String

See Also

LastTransitionData Class
LastTransitionData Members
ININ.IceLib.Dialer Namespace


LastTransitionData Methods

[image] [image]

IceLib Dialer Technical Reference
LastTransitionData Methods
LastTransitionData Class See Also Send Feedback

The LastTransitionData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LastTransitionData Class
ININ.IceLib.Dialer Namespace


LastTransitionData Properties

[image] [image]

IceLib Dialer Technical Reference
LastTransitionData Properties
LastTransitionData Class See Also Send Feedback

The LastTransitionData type exposes the following members.

Properties

 | Name | Description
Public property | ActiveGroupName | The name of the current Active Rule Group
Public property | LastGroupName | The name of the previous Active Rule Group
Public property | Offset | The offset between the UTC time and the CCS time in minutes.
Public property | UTCTime | The Universal time of the last transition

See Also

LastTransitionData Class
ININ.IceLib.Dialer Namespace


ActiveGroupName Property

[image]

IceLib Dialer Technical Reference
LastTransitionData..::..ActiveGroupName Property
LastTransitionData Class See Also Send Feedback
The name of the current Active Rule Group

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string ActiveGroupName { get; private set; }
Visual Basic
Public Property ActiveGroupName As String
    Get
    Private Set

See Also

LastTransitionData Class
LastTransitionData Members
ININ.IceLib.Dialer Namespace


LastGroupName Property

[image]

IceLib Dialer Technical Reference
LastTransitionData..::..LastGroupName Property
LastTransitionData Class See Also Send Feedback
The name of the previous Active Rule Group

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string LastGroupName { get; private set; }
Visual Basic
Public Property LastGroupName As String
    Get
    Private Set

See Also

LastTransitionData Class
LastTransitionData Members
ININ.IceLib.Dialer Namespace


Offset Property

[image]

IceLib Dialer Technical Reference
LastTransitionData..::..Offset Property
LastTransitionData Class See Also Send Feedback
The offset between the UTC time and the CCS time in minutes.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public TimeSpan Offset { get; private set; }
Visual Basic
Public Property Offset As TimeSpan
    Get
    Private Set

See Also

LastTransitionData Class
LastTransitionData Members
ININ.IceLib.Dialer Namespace


UTCTime Property

[image]

IceLib Dialer Technical Reference
LastTransitionData..::..UTCTime Property
LastTransitionData Class See Also Send Feedback
The Universal time of the last transition

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DateTime UTCTime { get; private set; }
Visual Basic
Public Property UTCTime As DateTime
    Get
    Private Set

See Also

LastTransitionData Class
LastTransitionData Members
ININ.IceLib.Dialer Namespace


LogonCompletedEventArgs Class

[image]

IceLib Dialer Technical Reference
LogonCompletedEventArgs Class
Members See Also Send Feedback
Provides data for the asynchronous completed events of DialingManager.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class LogonCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class LogonCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Dialer..::..LogonCompletedEventArgs

See Also

LogonCompletedEventArgs Members
ININ.IceLib.Dialer Namespace


LogonCompletedEventArgs Members

[image] [image]

IceLib Dialer Technical Reference
LogonCompletedEventArgs Members
LogonCompletedEventArgs Class Constructors Methods Properties See Also Send Feedback

The LogonCompletedEventArgs type exposes the following members.

Constructors

 | Name | Description
Public method | LogonCompletedEventArgs | Initializes a new instance of the LogonCompletedEventArgs class with the specified values.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | LogonResult | Gets the LogonResult associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

LogonCompletedEventArgs Class
ININ.IceLib.Dialer Namespace


LogonCompletedEventArgs Constructor

[image]

IceLib Dialer Technical Reference
LogonCompletedEventArgs Constructor
LogonCompletedEventArgs Class See Also Send Feedback
Initializes a new instance of the LogonCompletedEventArgs class with the specified values.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public LogonCompletedEventArgs(
    LogonResult logonResult,
    Exception error,
    bool cancelled,
    Object userState
)
Visual Basic
Public Sub New ( _
    logonResult As LogonResult, _
    error As Exception, _
    cancelled As Boolean, _
    userState As Object _
)

Parameters

logonResult
Type: ININ.IceLib.Dialer..::..LogonResult
A LogonResult containing the results of the logon attempt.
error
Type: System..::..Exception
The error, if one occurred.
cancelled
Type: System..::..Boolean
If set to true the operation was cancelled.
userState
Type: System..::..Object
An object that contains state information for this request.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).

See Also

LogonCompletedEventArgs Class
LogonCompletedEventArgs Members
ININ.IceLib.Dialer Namespace


LogonCompletedEventArgs Methods

[image] [image]

IceLib Dialer Technical Reference
LogonCompletedEventArgs Methods
LogonCompletedEventArgs Class See Also Send Feedback

The LogonCompletedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LogonCompletedEventArgs Class
ININ.IceLib.Dialer Namespace


LogonCompletedEventArgs Properties

[image] [image]

IceLib Dialer Technical Reference
LogonCompletedEventArgs Properties
LogonCompletedEventArgs Class See Also Send Feedback

The LogonCompletedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | LogonResult | Gets the LogonResult associated with the event.
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

LogonCompletedEventArgs Class
ININ.IceLib.Dialer Namespace


LogonResult Property

[image]

IceLib Dialer Technical Reference
LogonCompletedEventArgs..::..LogonResult Property
LogonCompletedEventArgs Class See Also Send Feedback
Gets the LogonResult associated with the event.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public LogonResult LogonResult { get; }
Visual Basic
Public ReadOnly Property LogonResult As LogonResult
    Get

Field Value

A LogonResult containing the results of the logon attempt.

Exceptions

Exception | Condition
System.Reflection..::..TargetInvocationException | The Error property has been set by the asynchronous operation. The InnerException property holds a reference to Error.

See Also

LogonCompletedEventArgs Class
LogonCompletedEventArgs Members
ININ.IceLib.Dialer Namespace


LogonParameters Class

[image]

IceLib Dialer Technical Reference
LogonParameters Class
Members See Also Send Feedback
The parameters for a logon request.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class LogonParameters
Visual Basic
Public Class LogonParameters

Remarks

These parameters are used when calling the Logon(LogonParameters) method.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Dialer..::..LogonParameters

See Also

LogonParameters Members
ININ.IceLib.Dialer Namespace


LogonParameters Members

[image] [image]

IceLib Dialer Technical Reference
LogonParameters Members
LogonParameters Class Constructors Methods Properties See Also Send Feedback

The LogonParameters type exposes the following members.

Constructors

 | Name | Description
Public method | LogonParameters | Initializes a new instance of the LogonParameters class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string representation of this object. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | CampaignName | Gets the name of the campaign.

See Also

LogonParameters Class
ININ.IceLib.Dialer Namespace


LogonParameters Constructor

[image]

IceLib Dialer Technical Reference
LogonParameters Constructor
LogonParameters Class See Also Send Feedback
Initializes a new instance of the LogonParameters class.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public LogonParameters(
    string campaignName
)
Visual Basic
Public Sub New ( _
    campaignName As String _
)

Parameters

campaignName
Type: System..::..String
The campaign to log the agent into.

See Also

LogonParameters Class
LogonParameters Members
ININ.IceLib.Dialer Namespace


LogonParameters Methods

[image] [image]

IceLib Dialer Technical Reference
LogonParameters Methods
LogonParameters Class See Also Send Feedback

The LogonParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string representation of this object. (Overrides Object..::..ToString()()()().)

See Also

LogonParameters Class
ININ.IceLib.Dialer Namespace


ToString Method

[image]

IceLib Dialer Technical Reference
LogonParameters..::..ToString Method
LogonParameters Class See Also Send Feedback
Returns a string representation of this object.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String

Return Value

This object as a string

See Also

LogonParameters Class
LogonParameters Members
ININ.IceLib.Dialer Namespace


LogonParameters Properties

[image] [image]

IceLib Dialer Technical Reference
LogonParameters Properties
LogonParameters Class See Also Send Feedback

The LogonParameters type exposes the following members.

Properties

 | Name | Description
Public property | CampaignName | Gets the name of the campaign.

See Also

LogonParameters Class
ININ.IceLib.Dialer Namespace


CampaignName Property

[image]

IceLib Dialer Technical Reference
LogonParameters..::..CampaignName Property
LogonParameters Class See Also Send Feedback
Gets the name of the campaign.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string CampaignName { get; }
Visual Basic
Public ReadOnly Property CampaignName As String
    Get

Field Value

The name of the campaign.

See Also

LogonParameters Class
LogonParameters Members
ININ.IceLib.Dialer Namespace


LogonResult Class

[image]

IceLib Dialer Technical Reference
LogonResult Class
Members See Also Send Feedback
The result of a logon request.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class LogonResult
Visual Basic
Public Class LogonResult

Remarks

These results are returned from the Logon()()()() method.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Dialer..::..LogonResult

See Also

LogonResult Members
ININ.IceLib.Dialer Namespace


LogonResult Members

[image] [image]

IceLib Dialer Technical Reference
LogonResult Members
LogonResult Class Methods Properties See Also Send Feedback

The LogonResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name Description
Public property Campaign
The campaign that the agent attempted to log in to.
Public property DialerSession
Gets the DialerSession associated with this agent login.
Public property InitiatorName
Identifies the rule or supervisor that initiated the login, if applicable.
Public property OnBreak
Indicates whether the agent is currently on break.

Remarks

This property will not be updated when the agent's break status changes, so it should only be relied upon immediately after a login

See Also

LogonResult Class
ININ.IceLib.Dialer Namespace


LogonResult Methods

[image] [image]

IceLib Dialer Technical Reference
LogonResult Methods
LogonResult Class See Also Send Feedback

The LogonResult type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LogonResult Class
ININ.IceLib.Dialer Namespace


LogonResult Properties

[image] [image]

IceLib Dialer Technical Reference
LogonResult Properties
LogonResult Class See Also Send Feedback

The LogonResult type exposes the following members.

Properties

Name Description
Public property Campaign
The campaign that the agent attempted to log in to.
Public property DialerSession
Gets the DialerSession associated with this agent login.
Public property InitiatorName
Identifies the rule or supervisor that initiated the login, if applicable.
Public property OnBreak
Indicates whether the agent is currently on break.

Remarks

This property will not be updated when the agent's break status changes, so it should only be relied upon immediately after a login

See Also

LogonResult Class
ININ.IceLib.Dialer Namespace


Campaign Property

[image]

IceLib Dialer Technical Reference
LogonResult..::..Campaign Property
LogonResult Class See Also Send Feedback
The campaign that the agent attempted to log in to.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CampaignId Campaign { get; set; }
Visual Basic
Public Property Campaign As CampaignId
    Get
    Set

See Also

LogonResult Class
LogonResult Members
ININ.IceLib.Dialer Namespace


DialerSession Property

[image]

IceLib Dialer Technical Reference
LogonResult..::..DialerSession Property
LogonResult Class See Also Send Feedback
Gets the DialerSession associated with this agent login.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DialerSession DialerSession { get; }
Visual Basic
Public ReadOnly Property DialerSession As DialerSession
    Get

Field Value

The dialer session.

See Also

LogonResult Class
LogonResult Members
ININ.IceLib.Dialer Namespace


InitiatorName Property

[image]

IceLib Dialer Technical Reference
LogonResult..::..InitiatorName Property
LogonResult Class See Also Send Feedback
Identifies the rule or supervisor that initiated the login, if applicable.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string InitiatorName { get; set; }
Visual Basic
Public Property InitiatorName As String
    Get
    Set

See Also

LogonResult Class
LogonResult Members
ININ.IceLib.Dialer Namespace


OnBreak Property

[image]

IceLib Dialer Technical Reference
LogonResult..::..OnBreak Property
LogonResult Class See Also Send Feedback
Indicates whether the agent is currently on break.

Remarks

This property will not be updated when the agent's break status changes, so it should only be relied upon immediately after a login

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool OnBreak { get; private set; }
Visual Basic
Public Property OnBreak As Boolean
    Get
    Private Set

See Also

LogonResult Class
LogonResult Members
ININ.IceLib.Dialer Namespace


LogoutGrantedEventArgs Class

[image]

IceLib Dialer Technical Reference
LogoutGrantedEventArgs Class
Members See Also Send Feedback
Provides data for the LogoutGranted event.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class LogoutGrantedEventArgs : EventArgs
Visual Basic
Public Class LogoutGrantedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Dialer..::..LogoutGrantedEventArgs

See Also

LogoutGrantedEventArgs Members
ININ.IceLib.Dialer Namespace


LogoutGrantedEventArgs Members

[image] [image]

IceLib Dialer Technical Reference
LogoutGrantedEventArgs Members
LogoutGrantedEventArgs Class Methods Properties See Also Send Feedback

The LogoutGrantedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Campaign | The campaign for which the logout was granted.

See Also

LogoutGrantedEventArgs Class
ININ.IceLib.Dialer Namespace


LogoutGrantedEventArgs Methods

[image] [image]

IceLib Dialer Technical Reference
LogoutGrantedEventArgs Methods
LogoutGrantedEventArgs Class See Also Send Feedback

The LogoutGrantedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LogoutGrantedEventArgs Class
ININ.IceLib.Dialer Namespace


LogoutGrantedEventArgs Properties

[image] [image]

IceLib Dialer Technical Reference
LogoutGrantedEventArgs Properties
LogoutGrantedEventArgs Class See Also Send Feedback

The LogoutGrantedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Campaign | The campaign for which the logout was granted.

See Also

LogoutGrantedEventArgs Class
ININ.IceLib.Dialer Namespace


Campaign Property

[image]

IceLib Dialer Technical Reference
LogoutGrantedEventArgs..::..Campaign Property
LogoutGrantedEventArgs Class See Also Send Feedback
The campaign for which the logout was granted.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CampaignId Campaign { get; private set; }
Visual Basic
Public Property Campaign As CampaignId
    Get
    Private Set

See Also

LogoutGrantedEventArgs Class
LogoutGrantedEventArgs Members
ININ.IceLib.Dialer Namespace


ManualOutboundCallParameters Class

[image]

IceLib Dialer Technical Reference
ManualOutboundCallParameters Class
Members See Also Send Feedback
The parameters for manually initiating an outbound call

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class ManualOutboundCallParameters
Visual Basic
Public Class ManualOutboundCallParameters

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Dialer..::..ManualOutboundCallParameters

See Also

ManualOutboundCallParameters Members
ININ.IceLib.Dialer Namespace
DialerSession..::..InitiateManualOutboundCall(ManualOutboundCallParameters)


ManualOutboundCallParameters Members

[image] [image]

IceLib Dialer Technical Reference
ManualOutboundCallParameters Members
ManualOutboundCallParameters Class Constructors Methods Properties See Also Send Feedback

The ManualOutboundCallParameters type exposes the following members.

Constructors

 | Name | Description
Public method | ManualOutboundCallParameters | Initializes a new instance of the ManualOutboundCallParameters class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetContactColumn(Int64) | This utility method can be used when the call should placed to an existing contact column and you know the contact column id
Public method | SetContactColumn(String) | This utility method can be used when the call should placed to an existing contact column and you know the contact column's name
Public method | SetPhoneNumber | This utility method can be used when the call should placed to a custom phone number not already associated with the contact
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Campaign | The campaign for which the call should be initiated
Public property | Identity | The I3_Identity of the contact to which the call should be placed
Public property | IgnoreCampaignOwnership | Ignore campaign ownership on the campaign when attempting to place the call
Public property | IgnoreDailyLimit | Ignore any daily limit configuration on the campaign when attempting to place the call
Public property | IgnoreDNC | Ignore DNC on the campaign when attempting to place the call
Public property | IgnoreFilter | Ignore any filter associated with the campaign when attempting to locate the contact record
Public property | IgnoreMinimumSpacing | Ignore the minimum time between dials configuration on the campaign when attempting to place the call
Public property | IgnoreQueryTimeFilter | Ignore the query-time (PND) filter associated with the campaign when attempting to locate the contact's phone number data
Public property | IgnoreSkills | Ignore any skill configuration on the campaign when attempting to load the contact record
Public property | IgnoreZoneBlocking | Ignore the time zone configuration on the campaign when attempting to load the contact record
Public property | NumberType | How NumberValue should be interpreted
Public property | NumberValue | A value that determines which phone number will be called, depending on NumberType

See Also

ManualOutboundCallParameters Class
ININ.IceLib.Dialer Namespace


ManualOutboundCallParameters Constructor

[image]

IceLib Dialer Technical Reference
ManualOutboundCallParameters Constructor
ManualOutboundCallParameters Class See Also Send Feedback
Initializes a new instance of the ManualOutboundCallParameters class

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ManualOutboundCallParameters()
Visual Basic
Public Sub New

See Also

ManualOutboundCallParameters Class
ManualOutboundCallParameters Members
ININ.IceLib.Dialer Namespace


ManualOutboundCallParameters Methods

[image] [image]

IceLib Dialer Technical Reference
ManualOutboundCallParameters Methods
ManualOutboundCallParameters Class See Also Send Feedback

The ManualOutboundCallParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetContactColumn(Int64) | This utility method can be used when the call should placed to an existing contact column and you know the contact column id
Public method | SetContactColumn(String) | This utility method can be used when the call should placed to an existing contact column and you know the contact column's name
Public method | SetPhoneNumber | This utility method can be used when the call should placed to a custom phone number not already associated with the contact
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ManualOutboundCallParameters Class
ININ.IceLib.Dialer Namespace


SetContactColumn Method

[image] [image]

IceLib Dialer Technical Reference
ManualOutboundCallParameters..::..SetContactColumn Method
ManualOutboundCallParameters Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SetContactColumn(Int64) | This utility method can be used when the call should placed to an existing contact column and you know the contact column id
Public method | SetContactColumn(String) | This utility method can be used when the call should placed to an existing contact column and you know the contact column's name

See Also

ManualOutboundCallParameters Class
ManualOutboundCallParameters Members
ININ.IceLib.Dialer Namespace


SetContactColumn Method (Int64)

[image]

IceLib Dialer Technical Reference
ManualOutboundCallParameters..::..SetContactColumn Method (Int64)
ManualOutboundCallParameters Class See Also Send Feedback
This utility method can be used when the call should placed to an existing contact column and you know the contact column id

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void SetContactColumn(
    long contactColumnId
)
Visual Basic
Public Sub SetContactColumn ( _
    contactColumnId As Long _
)

Parameters

contactColumnId
Type: System..::..Int64

See Also

ManualOutboundCallParameters Class
ManualOutboundCallParameters Members
SetContactColumn Overload
ININ.IceLib.Dialer Namespace


SetContactColumn Method (String)

[image]

IceLib Dialer Technical Reference
ManualOutboundCallParameters..::..SetContactColumn Method (String)
ManualOutboundCallParameters Class See Also Send Feedback
This utility method can be used when the call should placed to an existing contact column and you know the contact column's name

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void SetContactColumn(
    string contactColumnName
)
Visual Basic
Public Sub SetContactColumn ( _
    contactColumnName As String _
)

Parameters

contactColumnName
Type: System..::..String

See Also

ManualOutboundCallParameters Class
ManualOutboundCallParameters Members
SetContactColumn Overload
ININ.IceLib.Dialer Namespace


SetPhoneNumber Method

[image]

IceLib Dialer Technical Reference
ManualOutboundCallParameters..::..SetPhoneNumber Method
ManualOutboundCallParameters Class See Also Send Feedback
This utility method can be used when the call should placed to a custom phone number not already associated with the contact

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void SetPhoneNumber(
    string phoneNumber
)
Visual Basic
Public Sub SetPhoneNumber ( _
    phoneNumber As String _
)

Parameters

phoneNumber
Type: System..::..String

See Also

ManualOutboundCallParameters Class
ManualOutboundCallParameters Members
ININ.IceLib.Dialer Namespace


ManualOutboundCallParameters Properties

[image] [image]

IceLib Dialer Technical Reference
ManualOutboundCallParameters Properties
ManualOutboundCallParameters Class See Also Send Feedback

The ManualOutboundCallParameters type exposes the following members.

Properties

 | Name | Description
Public property | Campaign | The campaign for which the call should be initiated
Public property | Identity | The I3_Identity of the contact to which the call should be placed
Public property | IgnoreCampaignOwnership | Ignore campaign ownership on the campaign when attempting to place the call
Public property | IgnoreDailyLimit | Ignore any daily limit configuration on the campaign when attempting to place the call
Public property | IgnoreDNC | Ignore DNC on the campaign when attempting to place the call
Public property | IgnoreFilter | Ignore any filter associated with the campaign when attempting to locate the contact record
Public property | IgnoreMinimumSpacing | Ignore the minimum time between dials configuration on the campaign when attempting to place the call
Public property | IgnoreQueryTimeFilter | Ignore the query-time (PND) filter associated with the campaign when attempting to locate the contact's phone number data
Public property | IgnoreSkills | Ignore any skill configuration on the campaign when attempting to load the contact record
Public property | IgnoreZoneBlocking | Ignore the time zone configuration on the campaign when attempting to load the contact record
Public property | NumberType | How NumberValue should be interpreted
Public property | NumberValue | A value that determines which phone number will be called, depending on NumberType

See Also

ManualOutboundCallParameters Class
ININ.IceLib.Dialer Namespace


Campaign Property

[image]

IceLib Dialer Technical Reference
ManualOutboundCallParameters..::..Campaign Property
ManualOutboundCallParameters Class See Also Send Feedback
The campaign for which the call should be initiated

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public CampaignId Campaign { get; set; }
Visual Basic
Public Property Campaign As CampaignId
    Get
    Set

See Also

ManualOutboundCallParameters Class
ManualOutboundCallParameters Members
ININ.IceLib.Dialer Namespace


Identity Property

[image]

IceLib Dialer Technical Reference
ManualOutboundCallParameters..::..Identity Property
ManualOutboundCallParameters Class See Also Send Feedback
The I3_Identity of the contact to which the call should be placed

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public long Identity { get; set; }
Visual Basic
Public Property Identity As Long
    Get
    Set

See Also

ManualOutboundCallParameters Class
ManualOutboundCallParameters Members
ININ.IceLib.Dialer Namespace


IgnoreCampaignOwnership Property

[image]

IceLib Dialer Technical Reference
ManualOutboundCallParameters..::..IgnoreCampaignOwnership Property
ManualOutboundCallParameters Class See Also Send Feedback
Ignore campaign ownership on the campaign when attempting to place the call

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IgnoreCampaignOwnership { get; set; }
Visual Basic
Public Property IgnoreCampaignOwnership As Boolean
    Get
    Set

See Also

ManualOutboundCallParameters Class
ManualOutboundCallParameters Members
ININ.IceLib.Dialer Namespace


IgnoreDailyLimit Property

[image]

IceLib Dialer Technical Reference
ManualOutboundCallParameters..::..IgnoreDailyLimit Property
ManualOutboundCallParameters Class See Also Send Feedback
Ignore any daily limit configuration on the campaign when attempting to place the call

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IgnoreDailyLimit { get; set; }
Visual Basic
Public Property IgnoreDailyLimit As Boolean
    Get
    Set

See Also

ManualOutboundCallParameters Class
ManualOutboundCallParameters Members
ININ.IceLib.Dialer Namespace


IgnoreDNC Property

[image]

IceLib Dialer Technical Reference
ManualOutboundCallParameters..::..IgnoreDNC Property
ManualOutboundCallParameters Class See Also Send Feedback
Ignore DNC on the campaign when attempting to place the call

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IgnoreDNC { get; set; }
Visual Basic
Public Property IgnoreDNC As Boolean
    Get
    Set

See Also

ManualOutboundCallParameters Class
ManualOutboundCallParameters Members
ININ.IceLib.Dialer Namespace


IgnoreFilter Property

[image]

IceLib Dialer Technical Reference
ManualOutboundCallParameters..::..IgnoreFilter Property
ManualOutboundCallParameters Class See Also Send Feedback
Ignore any filter associated with the campaign when attempting to locate the contact record

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IgnoreFilter { get; set; }
Visual Basic
Public Property IgnoreFilter As Boolean
    Get
    Set

See Also

ManualOutboundCallParameters Class
ManualOutboundCallParameters Members
ININ.IceLib.Dialer Namespace


IgnoreMinimumSpacing Property

[image]

IceLib Dialer Technical Reference
ManualOutboundCallParameters..::..IgnoreMinimumSpacing Property
ManualOutboundCallParameters Class See Also Send Feedback
Ignore the minimum time between dials configuration on the campaign when attempting to place the call

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IgnoreMinimumSpacing { get; set; }
Visual Basic
Public Property IgnoreMinimumSpacing As Boolean
    Get
    Set

See Also

ManualOutboundCallParameters Class
ManualOutboundCallParameters Members
ININ.IceLib.Dialer Namespace


IgnoreQueryTimeFilter Property

[image]

IceLib Dialer Technical Reference
ManualOutboundCallParameters..::..IgnoreQueryTimeFilter Property
ManualOutboundCallParameters Class See Also Send Feedback
Ignore the query-time (PND) filter associated with the campaign when attempting to locate the contact's phone number data

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IgnoreQueryTimeFilter { get; set; }
Visual Basic
Public Property IgnoreQueryTimeFilter As Boolean
    Get
    Set

See Also

ManualOutboundCallParameters Class
ManualOutboundCallParameters Members
ININ.IceLib.Dialer Namespace


IgnoreSkills Property

[image]

IceLib Dialer Technical Reference
ManualOutboundCallParameters..::..IgnoreSkills Property
ManualOutboundCallParameters Class See Also Send Feedback
Ignore any skill configuration on the campaign when attempting to load the contact record

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IgnoreSkills { get; set; }
Visual Basic
Public Property IgnoreSkills As Boolean
    Get
    Set

See Also

ManualOutboundCallParameters Class
ManualOutboundCallParameters Members
ININ.IceLib.Dialer Namespace


IgnoreZoneBlocking Property

[image]

IceLib Dialer Technical Reference
ManualOutboundCallParameters..::..IgnoreZoneBlocking Property
ManualOutboundCallParameters Class See Also Send Feedback
Ignore the time zone configuration on the campaign when attempting to load the contact record

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IgnoreZoneBlocking { get; set; }
Visual Basic
Public Property IgnoreZoneBlocking As Boolean
    Get
    Set

See Also

ManualOutboundCallParameters Class
ManualOutboundCallParameters Members
ININ.IceLib.Dialer Namespace


NumberType Property

[image]

IceLib Dialer Technical Reference
ManualOutboundCallParameters..::..NumberType Property
ManualOutboundCallParameters Class See Also Send Feedback
How NumberValue should be interpreted

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ManualCallNumberType NumberType { get; set; }
Visual Basic
Public Property NumberType As ManualCallNumberType
    Get
    Set

See Also

ManualOutboundCallParameters Class
ManualOutboundCallParameters Members
ININ.IceLib.Dialer Namespace


NumberValue Property

[image]

IceLib Dialer Technical Reference
ManualOutboundCallParameters..::..NumberValue Property
ManualOutboundCallParameters Class See Also Send Feedback
A value that determines which phone number will be called, depending on NumberType

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string NumberValue { get; set; }
Visual Basic
Public Property NumberValue As String
    Get
    Set

See Also

ManualOutboundCallParameters Class
ManualOutboundCallParameters Members
ININ.IceLib.Dialer Namespace


ManualOutboundCallStatusEventArgs Class

[image]

IceLib Dialer Technical Reference
ManualOutboundCallStatusEventArgs Class
Members See Also Send Feedback
Provides data related to the ManualOutboundCallStatus event

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class ManualOutboundCallStatusEventArgs : AsyncCompletedEventArgs
Visual Basic
Public Class ManualOutboundCallStatusEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..AsyncCompletedEventArgs
ININ.IceLib.Dialer..::..ManualOutboundCallStatusEventArgs

See Also

ManualOutboundCallStatusEventArgs Members
ININ.IceLib.Dialer Namespace


ManualOutboundCallStatusEventArgs Members

[image] [image]

IceLib Dialer Technical Reference
ManualOutboundCallStatusEventArgs Members
ManualOutboundCallStatusEventArgs Class Methods Properties See Also Send Feedback

The ManualOutboundCallStatusEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | CampaignOwnershipBlocked | Whether or not the contact was blocked by the Campaign Ownership setting. This property only applies if Status is ContactBlocked
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | DailyLimitBlocked | Whether or not the contact was blocked by the daily limits. This property only applies if Status is ContactBlocked
Public property | DNCBlocked | Whether or not the contact was blocked by DNC setting. This property only applies if Status is ContactBlocked
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | FilterBlocked | Whether or not the contact was blocked by the filter. This property only applies if Status is ContactBlocked
Public property | Identity | The i3_identity of the contact for which the call was initiated
Public property | MinimumSpacingBlocked | Whether or not the contact was blocked by the minimum time between dials setting. This property only applies if Status is ContactBlocked
Public property | PreviouslyDialed | Whether or not the call was previously dialed since the last call list recycle. This property only applies if Status is ContactBlocked
Public property | QueryTimeFilterBlocked | Whether or not the contact was blocked by the QueryTimeFilter. This property only applies if Status is ContactBlocked
Public property | SkillBlocked | Whether or not the contact was blocked due to skills. This property only applies if Status is ContactBlocked
Public property | Status | The status of the call
Public property | UncallableStatus | Uncallable contact status. This property only applies if Status is ContactUncallable
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Public property | ZoneBlocked | Whether or not the contact was blocked due to time zone settings. This property only applies if Status is ContactBlocked

See Also

ManualOutboundCallStatusEventArgs Class
ININ.IceLib.Dialer Namespace


ManualOutboundCallStatusEventArgs Methods

[image] [image]

IceLib Dialer Technical Reference
ManualOutboundCallStatusEventArgs Methods
ManualOutboundCallStatusEventArgs Class See Also Send Feedback

The ManualOutboundCallStatusEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ManualOutboundCallStatusEventArgs Class
ININ.IceLib.Dialer Namespace


ManualOutboundCallStatusEventArgs Properties

[image] [image]

IceLib Dialer Technical Reference
ManualOutboundCallStatusEventArgs Properties
ManualOutboundCallStatusEventArgs Class See Also Send Feedback

The ManualOutboundCallStatusEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | CampaignOwnershipBlocked | Whether or not the contact was blocked by the Campaign Ownership setting. This property only applies if Status is ContactBlocked
Public property | Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Public property | DailyLimitBlocked | Whether or not the contact was blocked by the daily limits. This property only applies if Status is ContactBlocked
Public property | DNCBlocked | Whether or not the contact was blocked by DNC setting. This property only applies if Status is ContactBlocked
Public property | Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Public property | FilterBlocked | Whether or not the contact was blocked by the filter. This property only applies if Status is ContactBlocked
Public property | Identity | The i3_identity of the contact for which the call was initiated
Public property | MinimumSpacingBlocked | Whether or not the contact was blocked by the minimum time between dials setting. This property only applies if Status is ContactBlocked
Public property | PreviouslyDialed | Whether or not the call was previously dialed since the last call list recycle. This property only applies if Status is ContactBlocked
Public property | QueryTimeFilterBlocked | Whether or not the contact was blocked by the QueryTimeFilter. This property only applies if Status is ContactBlocked
Public property | SkillBlocked | Whether or not the contact was blocked due to skills. This property only applies if Status is ContactBlocked
Public property | Status | The status of the call
Public property | UncallableStatus | Uncallable contact status. This property only applies if Status is ContactUncallable
Public property | UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)
Public property | ZoneBlocked | Whether or not the contact was blocked due to time zone settings. This property only applies if Status is ContactBlocked

See Also

ManualOutboundCallStatusEventArgs Class
ININ.IceLib.Dialer Namespace


CampaignOwnershipBlocked Property

[image]

IceLib Dialer Technical Reference
ManualOutboundCallStatusEventArgs..::..CampaignOwnershipBlocked Property
ManualOutboundCallStatusEventArgs Class See Also Send Feedback
Whether or not the contact was blocked by the Campaign Ownership setting. This property only applies if Status is ContactBlocked

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool CampaignOwnershipBlocked { get; internal set; }
Visual Basic
Public Property CampaignOwnershipBlocked As Boolean
    Get
    Friend Set

See Also

ManualOutboundCallStatusEventArgs Class
ManualOutboundCallStatusEventArgs Members
ININ.IceLib.Dialer Namespace


DailyLimitBlocked Property

[image]

IceLib Dialer Technical Reference
ManualOutboundCallStatusEventArgs..::..DailyLimitBlocked Property
ManualOutboundCallStatusEventArgs Class See Also Send Feedback
Whether or not the contact was blocked by the daily limits. This property only applies if Status is ContactBlocked

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool DailyLimitBlocked { get; internal set; }
Visual Basic
Public Property DailyLimitBlocked As Boolean
    Get
    Friend Set

See Also

ManualOutboundCallStatusEventArgs Class
ManualOutboundCallStatusEventArgs Members
ININ.IceLib.Dialer Namespace


DNCBlocked Property

[image]

IceLib Dialer Technical Reference
ManualOutboundCallStatusEventArgs..::..DNCBlocked Property
ManualOutboundCallStatusEventArgs Class See Also Send Feedback
Whether or not the contact was blocked by DNC setting. This property only applies if Status is ContactBlocked

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool DNCBlocked { get; internal set; }
Visual Basic
Public Property DNCBlocked As Boolean
    Get
    Friend Set

See Also

ManualOutboundCallStatusEventArgs Class
ManualOutboundCallStatusEventArgs Members
ININ.IceLib.Dialer Namespace


FilterBlocked Property

[image]

IceLib Dialer Technical Reference
ManualOutboundCallStatusEventArgs..::..FilterBlocked Property
ManualOutboundCallStatusEventArgs Class See Also Send Feedback
Whether or not the contact was blocked by the filter. This property only applies if Status is ContactBlocked

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool FilterBlocked { get; internal set; }
Visual Basic
Public Property FilterBlocked As Boolean
    Get
    Friend Set

See Also

ManualOutboundCallStatusEventArgs Class
ManualOutboundCallStatusEventArgs Members
ININ.IceLib.Dialer Namespace


Identity Property

[image]

IceLib Dialer Technical Reference
ManualOutboundCallStatusEventArgs..::..Identity Property
ManualOutboundCallStatusEventArgs Class See Also Send Feedback
The i3_identity of the contact for which the call was initiated

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public long Identity { get; internal set; }
Visual Basic
Public Property Identity As Long
    Get
    Friend Set

See Also

ManualOutboundCallStatusEventArgs Class
ManualOutboundCallStatusEventArgs Members
ININ.IceLib.Dialer Namespace


MinimumSpacingBlocked Property

[image]

IceLib Dialer Technical Reference
ManualOutboundCallStatusEventArgs..::..MinimumSpacingBlocked Property
ManualOutboundCallStatusEventArgs Class See Also Send Feedback
Whether or not the contact was blocked by the minimum time between dials setting. This property only applies if Status is ContactBlocked

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool MinimumSpacingBlocked { get; internal set; }
Visual Basic
Public Property MinimumSpacingBlocked As Boolean
    Get
    Friend Set

See Also

ManualOutboundCallStatusEventArgs Class
ManualOutboundCallStatusEventArgs Members
ININ.IceLib.Dialer Namespace


PreviouslyDialed Property

[image]

IceLib Dialer Technical Reference
ManualOutboundCallStatusEventArgs..::..PreviouslyDialed Property
ManualOutboundCallStatusEventArgs Class See Also Send Feedback
Whether or not the call was previously dialed since the last call list recycle. This property only applies if Status is ContactBlocked

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool PreviouslyDialed { get; internal set; }
Visual Basic
Public Property PreviouslyDialed As Boolean
    Get
    Friend Set

See Also

ManualOutboundCallStatusEventArgs Class
ManualOutboundCallStatusEventArgs Members
ININ.IceLib.Dialer Namespace


QueryTimeFilterBlocked Property

[image]

IceLib Dialer Technical Reference
ManualOutboundCallStatusEventArgs..::..QueryTimeFilterBlocked Property
ManualOutboundCallStatusEventArgs Class See Also Send Feedback
Whether or not the contact was blocked by the QueryTimeFilter. This property only applies if Status is ContactBlocked

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool QueryTimeFilterBlocked { get; internal set; }
Visual Basic
Public Property QueryTimeFilterBlocked As Boolean
    Get
    Friend Set

See Also

ManualOutboundCallStatusEventArgs Class
ManualOutboundCallStatusEventArgs Members
ININ.IceLib.Dialer Namespace


SkillBlocked Property

[image]

IceLib Dialer Technical Reference
ManualOutboundCallStatusEventArgs..::..SkillBlocked Property
ManualOutboundCallStatusEventArgs Class See Also Send Feedback
Whether or not the contact was blocked due to skills. This property only applies if Status is ContactBlocked

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool SkillBlocked { get; internal set; }
Visual Basic
Public Property SkillBlocked As Boolean
    Get
    Friend Set

See Also

ManualOutboundCallStatusEventArgs Class
ManualOutboundCallStatusEventArgs Members
ININ.IceLib.Dialer Namespace


Status Property

[image]

IceLib Dialer Technical Reference
ManualOutboundCallStatusEventArgs..::..Status Property
ManualOutboundCallStatusEventArgs Class See Also Send Feedback
The status of the call

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ManualOutboundCallStatus Status { get; internal set; }
Visual Basic
Public Property Status As ManualOutboundCallStatus
    Get
    Friend Set

See Also

ManualOutboundCallStatusEventArgs Class
ManualOutboundCallStatusEventArgs Members
ININ.IceLib.Dialer Namespace


UncallableStatus Property

[image]

IceLib Dialer Technical Reference
ManualOutboundCallStatusEventArgs..::..UncallableStatus Property
ManualOutboundCallStatusEventArgs Class See Also Send Feedback
Uncallable contact status. This property only applies if Status is ContactUncallable

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string UncallableStatus { get; internal set; }
Visual Basic
Public Property UncallableStatus As String
    Get
    Friend Set

See Also

ManualOutboundCallStatusEventArgs Class
ManualOutboundCallStatusEventArgs Members
ININ.IceLib.Dialer Namespace


ZoneBlocked Property

[image]

IceLib Dialer Technical Reference
ManualOutboundCallStatusEventArgs..::..ZoneBlocked Property
ManualOutboundCallStatusEventArgs Class See Also Send Feedback
Whether or not the contact was blocked due to time zone settings. This property only applies if Status is ContactBlocked

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool ZoneBlocked { get; internal set; }
Visual Basic
Public Property ZoneBlocked As Boolean
    Get
    Friend Set

See Also

ManualOutboundCallStatusEventArgs Class
ManualOutboundCallStatusEventArgs Members
ININ.IceLib.Dialer Namespace


PreviewCallAddedEventArgs Class

[image]

IceLib Dialer Technical Reference
PreviewCallAddedEventArgs Class
Members See Also Send Feedback
Provides data for the PreviewCallAdded event.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class PreviewCallAddedEventArgs : EventArgs
Visual Basic
Public Class PreviewCallAddedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Dialer..::..PreviewCallAddedEventArgs

See Also

PreviewCallAddedEventArgs Members
ININ.IceLib.Dialer Namespace


PreviewCallAddedEventArgs Members

[image] [image]

IceLib Dialer Technical Reference
PreviewCallAddedEventArgs Members
PreviewCallAddedEventArgs Class Methods Properties See Also Send Feedback

The PreviewCallAddedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Interaction | Gets the DialerCallInteraction representing the preview call that was added.

See Also

PreviewCallAddedEventArgs Class
ININ.IceLib.Dialer Namespace


PreviewCallAddedEventArgs Methods

[image] [image]

IceLib Dialer Technical Reference
PreviewCallAddedEventArgs Methods
PreviewCallAddedEventArgs Class See Also Send Feedback

The PreviewCallAddedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PreviewCallAddedEventArgs Class
ININ.IceLib.Dialer Namespace


PreviewCallAddedEventArgs Properties

[image] [image]

IceLib Dialer Technical Reference
PreviewCallAddedEventArgs Properties
PreviewCallAddedEventArgs Class See Also Send Feedback

The PreviewCallAddedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Interaction | Gets the DialerCallInteraction representing the preview call that was added.

See Also

PreviewCallAddedEventArgs Class
ININ.IceLib.Dialer Namespace


Interaction Property

[image]

IceLib Dialer Technical Reference
PreviewCallAddedEventArgs..::..Interaction Property
PreviewCallAddedEventArgs Class See Also Send Feedback
Gets the DialerCallInteraction representing the preview call that was added.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DialerCallInteraction Interaction { get; }
Visual Basic
Public ReadOnly Property Interaction As DialerCallInteraction
    Get

Field Value

The interaction.

See Also

PreviewCallAddedEventArgs Class
PreviewCallAddedEventArgs Members
ININ.IceLib.Dialer Namespace


PreviewTimeoutExpiredEventArgs Class

[image]

IceLib Dialer Technical Reference
PreviewTimeoutExpiredEventArgs Class
Members See Also Send Feedback
Provides data related to the PreviewTimeoutExpired event

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class PreviewTimeoutExpiredEventArgs : CancelEventArgs
Visual Basic
Public Class PreviewTimeoutExpiredEventArgs _
    Inherits CancelEventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
System.ComponentModel..::..CancelEventArgs
ININ.IceLib.Dialer..::..PreviewTimeoutExpiredEventArgs

See Also

PreviewTimeoutExpiredEventArgs Members
ININ.IceLib.Dialer Namespace


PreviewTimeoutExpiredEventArgs Members

[image] [image]

IceLib Dialer Technical Reference
PreviewTimeoutExpiredEventArgs Members
PreviewTimeoutExpiredEventArgs Class Methods Properties See Also Send Feedback

The PreviewTimeoutExpiredEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | Interaction | The preview interaction for which the timeout has expired.

See Also

PreviewTimeoutExpiredEventArgs Class
ININ.IceLib.Dialer Namespace


PreviewTimeoutExpiredEventArgs Methods

[image] [image]

IceLib Dialer Technical Reference
PreviewTimeoutExpiredEventArgs Methods
PreviewTimeoutExpiredEventArgs Class See Also Send Feedback

The PreviewTimeoutExpiredEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PreviewTimeoutExpiredEventArgs Class
ININ.IceLib.Dialer Namespace


PreviewTimeoutExpiredEventArgs Properties

[image] [image]

IceLib Dialer Technical Reference
PreviewTimeoutExpiredEventArgs Properties
PreviewTimeoutExpiredEventArgs Class See Also Send Feedback

The PreviewTimeoutExpiredEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Cancel | Gets or sets a value indicating whether the event should be canceled. (Inherited from CancelEventArgs.)
Public property | Interaction | The preview interaction for which the timeout has expired.

See Also

PreviewTimeoutExpiredEventArgs Class
ININ.IceLib.Dialer Namespace


Interaction Property

[image]

IceLib Dialer Technical Reference
PreviewTimeoutExpiredEventArgs..::..Interaction Property
PreviewTimeoutExpiredEventArgs Class See Also Send Feedback
The preview interaction for which the timeout has expired.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DialerCallInteraction Interaction { get; set; }
Visual Basic
Public Property Interaction As DialerCallInteraction
    Get
    Set

See Also

PreviewTimeoutExpiredEventArgs Class
PreviewTimeoutExpiredEventArgs Members
ININ.IceLib.Dialer Namespace


PreviewTimeoutStartedEventArgs Class

[image]

IceLib Dialer Technical Reference
PreviewTimeoutStartedEventArgs Class
Members See Also Send Feedback
Provides data related to the PreviewTimeoutStarted event

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class PreviewTimeoutStartedEventArgs : EventArgs
Visual Basic
Public Class PreviewTimeoutStartedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Dialer..::..PreviewTimeoutStartedEventArgs

See Also

PreviewTimeoutStartedEventArgs Members
ININ.IceLib.Dialer Namespace


PreviewTimeoutStartedEventArgs Members

[image] [image]

IceLib Dialer Technical Reference
PreviewTimeoutStartedEventArgs Members
PreviewTimeoutStartedEventArgs Class Methods Properties See Also Send Feedback

The PreviewTimeoutStartedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Interaction | The preview interaction for which the timeout has started.
Public property | Timeout | The length of time until the preview timeout will expire.

See Also

PreviewTimeoutStartedEventArgs Class
ININ.IceLib.Dialer Namespace


PreviewTimeoutStartedEventArgs Methods

[image] [image]

IceLib Dialer Technical Reference
PreviewTimeoutStartedEventArgs Methods
PreviewTimeoutStartedEventArgs Class See Also Send Feedback

The PreviewTimeoutStartedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PreviewTimeoutStartedEventArgs Class
ININ.IceLib.Dialer Namespace


PreviewTimeoutStartedEventArgs Properties

[image] [image]

IceLib Dialer Technical Reference
PreviewTimeoutStartedEventArgs Properties
PreviewTimeoutStartedEventArgs Class See Also Send Feedback

The PreviewTimeoutStartedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Interaction | The preview interaction for which the timeout has started.
Public property | Timeout | The length of time until the preview timeout will expire.

See Also

PreviewTimeoutStartedEventArgs Class
ININ.IceLib.Dialer Namespace


Interaction Property

[image]

IceLib Dialer Technical Reference
PreviewTimeoutStartedEventArgs..::..Interaction Property
PreviewTimeoutStartedEventArgs Class See Also Send Feedback
The preview interaction for which the timeout has started.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Interaction Interaction { get; internal set; }
Visual Basic
Public Property Interaction As Interaction
    Get
    Friend Set

See Also

PreviewTimeoutStartedEventArgs Class
PreviewTimeoutStartedEventArgs Members
ININ.IceLib.Dialer Namespace


Timeout Property

[image]

IceLib Dialer Technical Reference
PreviewTimeoutStartedEventArgs..::..Timeout Property
PreviewTimeoutStartedEventArgs Class See Also Send Feedback
The length of time until the preview timeout will expire.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public TimeSpan Timeout { get; internal set; }
Visual Basic
Public Property Timeout As TimeSpan
    Get
    Friend Set

See Also

PreviewTimeoutStartedEventArgs Class
PreviewTimeoutStartedEventArgs Members
ININ.IceLib.Dialer Namespace


PreviewTimeoutStoppedEventArgs Class

[image]

IceLib Dialer Technical Reference
PreviewTimeoutStoppedEventArgs Class
Members See Also Send Feedback
Provides data related to the PreviewTimeoutStopped event

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class PreviewTimeoutStoppedEventArgs : EventArgs
Visual Basic
Public Class PreviewTimeoutStoppedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Dialer..::..PreviewTimeoutStoppedEventArgs

See Also

PreviewTimeoutStoppedEventArgs Members
ININ.IceLib.Dialer Namespace


PreviewTimeoutStoppedEventArgs Members

[image] [image]

IceLib Dialer Technical Reference
PreviewTimeoutStoppedEventArgs Members
PreviewTimeoutStoppedEventArgs Class Methods Properties See Also Send Feedback

The PreviewTimeoutStoppedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Interaction | The preview interaction for which the timeout has stopped.

See Also

PreviewTimeoutStoppedEventArgs Class
ININ.IceLib.Dialer Namespace


PreviewTimeoutStoppedEventArgs Methods

[image] [image]

IceLib Dialer Technical Reference
PreviewTimeoutStoppedEventArgs Methods
PreviewTimeoutStoppedEventArgs Class See Also Send Feedback

The PreviewTimeoutStoppedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PreviewTimeoutStoppedEventArgs Class
ININ.IceLib.Dialer Namespace


PreviewTimeoutStoppedEventArgs Properties

[image] [image]

IceLib Dialer Technical Reference
PreviewTimeoutStoppedEventArgs Properties
PreviewTimeoutStoppedEventArgs Class See Also Send Feedback

The PreviewTimeoutStoppedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Interaction | The preview interaction for which the timeout has stopped.

See Also

PreviewTimeoutStoppedEventArgs Class
ININ.IceLib.Dialer Namespace


Interaction Property

[image]

IceLib Dialer Technical Reference
PreviewTimeoutStoppedEventArgs..::..Interaction Property
PreviewTimeoutStoppedEventArgs Class See Also Send Feedback
The preview interaction for which the timeout has stopped.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Interaction Interaction { get; internal set; }
Visual Basic
Public Property Interaction As Interaction
    Get
    Friend Set

See Also

PreviewTimeoutStoppedEventArgs Class
PreviewTimeoutStoppedEventArgs Members
ININ.IceLib.Dialer Namespace


SwitchoverPair Class

[image]

IceLib Dialer Technical Reference
SwitchoverPair Class
Members See Also Send Feedback
The names of the primary and backup servers

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class SwitchoverPair
Visual Basic
Public Class SwitchoverPair

Remarks

These results are returned from the GetSwitchoverPair(ServerType) method.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Dialer..::..SwitchoverPair

See Also

SwitchoverPair Members
ININ.IceLib.Dialer Namespace


SwitchoverPair Members

[image] [image]

IceLib Dialer Technical Reference
SwitchoverPair Members
SwitchoverPair Class Constructors Methods Properties See Also Send Feedback

The SwitchoverPair type exposes the following members.

Constructors

 | Name | Description
Public method | SwitchoverPair()()()() | Initializes a new instance of the SwitchoverPair class.
Public method | SwitchoverPair(String, String) | Initializes a new instance of the SwitchoverPair class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Backup | The name of the backup server
Public property | IsSwitchoverInstalled | Returns whether switchover is installed or not.
Public property | Primary | The name of the primary server

See Also

SwitchoverPair Class
ININ.IceLib.Dialer Namespace


SwitchoverPair Constructor

[image] [image]

IceLib Dialer Technical Reference
SwitchoverPair Constructor
SwitchoverPair Class See Also Send Feedback

Overload List

 | Name | Description
Public method | SwitchoverPair()()()() | Initializes a new instance of the SwitchoverPair class.
Public method | SwitchoverPair(String, String) | Initializes a new instance of the SwitchoverPair class.

See Also

SwitchoverPair Class
SwitchoverPair Members
ININ.IceLib.Dialer Namespace


SwitchoverPair Constructor

[image]

IceLib Dialer Technical Reference
SwitchoverPair Constructor
SwitchoverPair Class See Also Send Feedback
Initializes a new instance of the SwitchoverPair class.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public SwitchoverPair()
Visual Basic
Public Sub New

See Also

SwitchoverPair Class
SwitchoverPair Members
SwitchoverPair Overload
ININ.IceLib.Dialer Namespace


SwitchoverPair Constructor (String, String)

[image]

IceLib Dialer Technical Reference
SwitchoverPair Constructor (String, String)
SwitchoverPair Class See Also Send Feedback
Initializes a new instance of the SwitchoverPair class.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public SwitchoverPair(
    string backup,
    string primary
)
Visual Basic
Public Sub New ( _
    backup As String, _
    primary As String _
)

Parameters

backup
Type: System..::..String
primary
Type: System..::..String

See Also

SwitchoverPair Class
SwitchoverPair Members
SwitchoverPair Overload
ININ.IceLib.Dialer Namespace


SwitchoverPair Methods

[image] [image]

IceLib Dialer Technical Reference
SwitchoverPair Methods
SwitchoverPair Class See Also Send Feedback

The SwitchoverPair type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SwitchoverPair Class
ININ.IceLib.Dialer Namespace


SwitchoverPair Properties

[image] [image]

IceLib Dialer Technical Reference
SwitchoverPair Properties
SwitchoverPair Class See Also Send Feedback

The SwitchoverPair type exposes the following members.

Properties

 | Name | Description
Public property | Backup | The name of the backup server
Public property | IsSwitchoverInstalled | Returns whether switchover is installed or not.
Public property | Primary | The name of the primary server

See Also

SwitchoverPair Class
ININ.IceLib.Dialer Namespace


Backup Property

[image]

IceLib Dialer Technical Reference
SwitchoverPair..::..Backup Property
SwitchoverPair Class See Also Send Feedback
The name of the backup server

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Backup { get; private set; }
Visual Basic
Public Property Backup As String
    Get
    Private Set

Return Value

a string representing the name of the back server in a switchover pair

See Also

SwitchoverPair Class
SwitchoverPair Members
ININ.IceLib.Dialer Namespace


IsSwitchoverInstalled Property

[image]

IceLib Dialer Technical Reference
SwitchoverPair..::..IsSwitchoverInstalled Property
SwitchoverPair Class See Also Send Feedback
Returns whether switchover is installed or not.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public bool IsSwitchoverInstalled { get; }
Visual Basic
Public ReadOnly Property IsSwitchoverInstalled As Boolean
    Get

See Also

SwitchoverPair Class
SwitchoverPair Members
ININ.IceLib.Dialer Namespace


Primary Property

[image]

IceLib Dialer Technical Reference
SwitchoverPair..::..Primary Property
SwitchoverPair Class See Also Send Feedback
The name of the primary server

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Primary { get; private set; }
Visual Basic
Public Property Primary As String
    Get
    Private Set

Return Value

a string representing the name of the primary server in a switchover pair

See Also

SwitchoverPair Class
SwitchoverPair Members
ININ.IceLib.Dialer Namespace


TransitionParameters Class

[image]

IceLib Dialer Technical Reference
TransitionParameters Class
Members See Also Send Feedback
The parameters for a campaign transition.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
[ObsoleteAttribute("Since workflows no longer exist, the concept of transitioning no longer exists either.")]
public class TransitionParameters
Visual Basic
<ObsoleteAttribute("Since workflows no longer exist, the concept of transitioning no longer exists either.")> _
Public Class TransitionParameters

Remarks

These parameters are used by the CampaignTransition event.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Dialer..::..TransitionParameters

See Also

TransitionParameters Members
ININ.IceLib.Dialer Namespace


TransitionParameters Members

[image] [image]

IceLib Dialer Technical Reference
TransitionParameters Members
TransitionParameters Class Methods See Also Send Feedback

The TransitionParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TransitionParameters Class
ININ.IceLib.Dialer Namespace


TransitionParameters Methods

[image] [image]

IceLib Dialer Technical Reference
TransitionParameters Methods
TransitionParameters Class See Also Send Feedback

The TransitionParameters type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TransitionParameters Class
ININ.IceLib.Dialer Namespace


WorkflowStartedEventArgs Class

[image]

IceLib Dialer Technical Reference
WorkflowStartedEventArgs Class
Members See Also Send Feedback
Provides data for the WorkflowStarted event.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
[ObsoleteAttribute("Workflows no longer exist.")]
public class WorkflowStartedEventArgs : EventArgs
Visual Basic
<ObsoleteAttribute("Workflows no longer exist.")> _
Public Class WorkflowStartedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Dialer..::..WorkflowStartedEventArgs

See Also

WorkflowStartedEventArgs Members
ININ.IceLib.Dialer Namespace


WorkflowStartedEventArgs Members

[image] [image]

IceLib Dialer Technical Reference
WorkflowStartedEventArgs Members
WorkflowStartedEventArgs Class Methods See Also Send Feedback

The WorkflowStartedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorkflowStartedEventArgs Class
ININ.IceLib.Dialer Namespace


WorkflowStartedEventArgs Methods

[image] [image]

IceLib Dialer Technical Reference
WorkflowStartedEventArgs Methods
WorkflowStartedEventArgs Class See Also Send Feedback

The WorkflowStartedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorkflowStartedEventArgs Class
ININ.IceLib.Dialer Namespace


WorkflowStoppedEventArgs Class

[image]

IceLib Dialer Technical Reference
WorkflowStoppedEventArgs Class
Members See Also Send Feedback
Provides data for the WorkflowStopped event.

Namespace: ININ.IceLib.Dialer
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
[ObsoleteAttribute("Workflows no longer exist.")]
public class WorkflowStoppedEventArgs : EventArgs
Visual Basic
<ObsoleteAttribute("Workflows no longer exist.")> _
Public Class WorkflowStoppedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Dialer..::..WorkflowStoppedEventArgs

See Also

WorkflowStoppedEventArgs Members
ININ.IceLib.Dialer Namespace


WorkflowStoppedEventArgs Members

[image] [image]

IceLib Dialer Technical Reference
WorkflowStoppedEventArgs Members
WorkflowStoppedEventArgs Class Methods See Also Send Feedback

The WorkflowStoppedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorkflowStoppedEventArgs Class
ININ.IceLib.Dialer Namespace


WorkflowStoppedEventArgs Methods

[image] [image]

IceLib Dialer Technical Reference
WorkflowStoppedEventArgs Methods
WorkflowStoppedEventArgs Class See Also Send Feedback

The WorkflowStoppedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WorkflowStoppedEventArgs Class
ININ.IceLib.Dialer Namespace


ININ.IceLib.Dialer.Enums Namespace

[image]

IceLib Dialer Technical Reference
ININ.IceLib.Dialer.Enums Namespace
Send Feedback

Enumerations

 | Enumeration | Description
Public enumeration | ManualCallNumberType | The type of number to be dialed when initiating a manual outbound call to a contact
Public enumeration | ManualOutboundCallStatus | The status of an outbound call that was manually initiated
Public enumeration | TimeReference | Frame of reference for a time


ManualCallNumberType Enumeration

[image]

IceLib Dialer Technical Reference
ManualCallNumberType Enumeration
See Also Send Feedback
The type of number to be dialed when initiating a manual outbound call to a contact

Namespace: ININ.IceLib.Dialer.Enums
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum ManualCallNumberType
Visual Basic
Public Enumeration ManualCallNumberType

Members

Member name | Value | Description
Unknown | 0 | A valid number type has not been assigned
ContactColumnName | 1 | The call should be placed to a specific contact column, identified by name
ContactColumnId | 2 | The call should be placed to a specific contact column, identified by contact column id
PhoneNumber | 3 | The call should be placed to a custom phone number, not one of the existing contact columns

See Also

ININ.IceLib.Dialer.Enums Namespace


ManualOutboundCallStatus Enumeration

[image]

IceLib Dialer Technical Reference
ManualOutboundCallStatus Enumeration
See Also Send Feedback
The status of an outbound call that was manually initiated

Namespace: ININ.IceLib.Dialer.Enums
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum ManualOutboundCallStatus
Visual Basic
Public Enumeration ManualOutboundCallStatus

Members

Member name | Value | Description
Unknown | 0 | The status cannot be determined
None | 1 | No status has been assigned
InvalidCampaign | 2 | The call could not be initiated because the specified campaign is invalid
InvalidAgent | 3 | The call could not be initiated because the initiating agent is invalid
InternalError | 4 | The call could not be initiated due to an internal error
AgentNotIdle | 5 | The call could not be initiated because the initiating agent is not ready to receive a new Dialer call
ContactNotFound | 6 | The call could not be initiated because the specified contact could not be found in the contact list
ContactUncallable | 7 | The call could not be initiated because the specified contact has an uncallable status
ContactBlocked | 8 | The call could not be initiated because the specified contact has blocked by one or more dialing restrictions
PlaceCallFailed | 9 | The call was initiated but could not be placed due to an internal restriction
InvalidPhoneNumber | 10 | The call was initiated but could not be placed because the specified phone number is not valid
CallBlocked | 11 | The call was initiated but could not be placed
CallPlaced | 12 | The call has been placed
CallComplete | 13 | The call has been completed and a disposition has been entered
PolicyCompleted | 14 | The call has been dispositioned or transferred by a policy behavior.
PreviouslyDialed | 15 | The call was initiated but could not be placed because it had been previously dialed since the last campaign recyle.

See Also

ININ.IceLib.Dialer.Enums Namespace


TimeReference Enumeration

[image]

IceLib Dialer Technical Reference
TimeReference Enumeration
See Also Send Feedback
Frame of reference for a time

Namespace: ININ.IceLib.Dialer.Enums
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum TimeReference
Visual Basic
Public Enumeration TimeReference

Members

Member name | Value | Description
UTC | 0 | Relative to UTC time
Contact | 1 | Relative to a contact's local time

See Also

ININ.IceLib.Dialer.Enums Namespace


ININ.IceLib.Dialer.Supervisor Namespace

[image]

IceLib Dialer Technical Reference
ININ.IceLib.Dialer.Supervisor Namespace
Send Feedback

Classes

 | Class | Description
Public class | AgentManager |
Public class | ContactListPenetration | Overview: The penetration rate is a new Dialer 4.0 feature. It allows a customer to run reports that show the number of contacts that were contacted (the numerator) versus a number of records in a contact list (the denominator).
Public class | DialerHealthMonitor | Provides capabilities to monitor the current status and history of active campaigns and Dialer in general.
Public class | DialerHistoryMessage | A brief summary of an event that occurred within some Dialer-related process.
Public class | DialerStatusMessage | A brief diagnostic summary of Dialer-related processes that can be useful for troubleshooting issues.
Public class | RuleManager | A class that exposes methods that can be applied directly to rules.
Public class | StatusMessageReceivedEventArgs | Provides data for the StatusMessageReceived event of the DialerHealthMonitor class.

Structures

 | Structure | Description
Public structure | ContactListPenetration..::..ContactListPenetrationData | Structure that defines a segment of an upload. For any given upload, it will contain two rows per contact column (one for all values and one for unique values) + one row per contact list to account for all contacts.
Public structure | ContactListPenetration..::..ContactListPenetrationRate | This structure holds the number of records returned by the GetPenetrationRate for the numerator, denominator and the Penetration Rate.
Public structure | ContactListPenetration..::..ContactListPenetrationUpload | This structure gives all of the information necessary to compute the denominator for the penetration rate per upload Id.

Delegates

 | Delegate | Description
Public delegate | StatusMessageReceivedEventHandler | Handles a StatusMessageReceived event.

Enumerations

 | Enumeration | Description
Public enumeration | DialerHistoryErrorType | Possible types of errors that may occur.
Public enumeration | DialerHistoryInformationType | Possible types of informational events that may occur.
Public enumeration | DialerHistoryMessageSeverity | Possible levels of severity for a message.
Public enumeration | DialerHistoryWarningType | Possible types of warnings that may occur.
Public enumeration | DialerStatusMessageSeverity | The level of seriousness of a status message.
Public enumeration | DialerStatusMessageType | Possible types of status messages.
Public enumeration | DialerStatusMessageUpdateType | Possible types of updates that a status message may undergo.


AgentManager Class

[image]

IceLib Dialer Technical Reference
AgentManager Class
Members See Also Send Feedback

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class AgentManager
Visual Basic
Public Class AgentManager

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Dialer.Supervisor..::..AgentManager

See Also

AgentManager Members
ININ.IceLib.Dialer.Supervisor Namespace


AgentManager Members

[image] [image]

IceLib Dialer Technical Reference
AgentManager Members
AgentManager Class Constructors Methods Properties See Also Send Feedback

The AgentManager type exposes the following members.

Constructors

 | Name | Description
Public method | AgentManager | Initializes a new instance of the AgentManager class.

Methods

 | Name | Description
Public method | AllocateAgents(Collection<(Of <<'(String>)>>), Collection<(Of <<'(ConfigurationId>)>>), Collection<(Of <<'(ConfigurationId>)>>)) | Request that one or more agents be automatically logged in or out of campaigns.
Public method | AllocateAgents(Collection<(Of <<'(String>)>>), Collection<(Of <<'(CampaignId>)>>), Collection<(Of <<'(CampaignId>)>>)) | Request that one or more agents be automatically logged in or out of campaigns.
Public method | AllocateAgentsAsync | Asynchronously request that one or more agents be automatically logged in or out of campaigns.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetActiveAgentsForCampaign(ConfigurationId) | Gets the list of agents active in a given campaign.
Public method | GetActiveAgentsForCampaign(CampaignId) | Gets the list of agents active in a given campaign.
Public method | GetActiveAgentsForCampaignAsync | Asynchronously gets the list of agents active in a given campaign.
Public method | GetActiveCampaignsForAgent | Gets the IDs of all campaigns that a given agent is active in.
Public method | GetActiveCampaignsForAgentAsync | Asynchronously gets the IDs of all campaigns that a given agent is active in.
Public method | GetEligibleAgentsForCampaign(ConfigurationId) | Gets the list of agents that are logged in and eligible to participate in a given campaign.
Public method | GetEligibleAgentsForCampaign(CampaignId) | Gets the list of agents that are logged in and eligible to participate in a given campaign.
Public method | GetEligibleAgentsForCampaignAsync | Asynchronously gets the IDs of all campaigns that a given agent is active in.
Public method | GetEligibleCampaignsForAgent | Gets the IDs of all active campaigns that a given agent is eligible to participate in.
Public method | GetEligibleCampaignsForAgentAsync | Gets the IDs of all active campaigns that a given agent is eligible to participate in.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshActiveAgentList | Refreshes ActiveAgents.
Public method | RefreshActiveAgentListAsync | Asynchronously refreshes ActiveAgents.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActiveAgents | The list of agents logged into Dialer a.k.a. agents that may be managed via the AgentManager class. This does not include agents logged directly into campaigns, which cannot be managed by this class.
Public property | Session | Gets the Session used by the AgentManager.

See Also

AgentManager Class
ININ.IceLib.Dialer.Supervisor Namespace


AgentManager Constructor

[image]

IceLib Dialer Technical Reference
AgentManager Constructor
AgentManager Class See Also Send Feedback
Initializes a new instance of the AgentManager class.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public AgentManager(
    Session session
)
Visual Basic
Public Sub New ( _
    session As Session _
)

Parameters

session
Type: Session
The Session to be used. The session must already be initialized and connected.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).
IceLibException | The supplied Session is not valid or is not connected.

See Also

AgentManager Class
AgentManager Members
ININ.IceLib.Dialer.Supervisor Namespace


AgentManager Methods

[image] [image]

IceLib Dialer Technical Reference
AgentManager Methods
AgentManager Class See Also Send Feedback

The AgentManager type exposes the following members.

Methods

 | Name | Description
Public method | AllocateAgents(Collection<(Of <<'(String>)>>), Collection<(Of <<'(ConfigurationId>)>>), Collection<(Of <<'(ConfigurationId>)>>)) | Request that one or more agents be automatically logged in or out of campaigns.
Public method | AllocateAgents(Collection<(Of <<'(String>)>>), Collection<(Of <<'(CampaignId>)>>), Collection<(Of <<'(CampaignId>)>>)) | Request that one or more agents be automatically logged in or out of campaigns.
Public method | AllocateAgentsAsync | Asynchronously request that one or more agents be automatically logged in or out of campaigns.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetActiveAgentsForCampaign(ConfigurationId) | Gets the list of agents active in a given campaign.
Public method | GetActiveAgentsForCampaign(CampaignId) | Gets the list of agents active in a given campaign.
Public method | GetActiveAgentsForCampaignAsync | Asynchronously gets the list of agents active in a given campaign.
Public method | GetActiveCampaignsForAgent | Gets the IDs of all campaigns that a given agent is active in.
Public method | GetActiveCampaignsForAgentAsync | Asynchronously gets the IDs of all campaigns that a given agent is active in.
Public method | GetEligibleAgentsForCampaign(ConfigurationId) | Gets the list of agents that are logged in and eligible to participate in a given campaign.
Public method | GetEligibleAgentsForCampaign(CampaignId) | Gets the list of agents that are logged in and eligible to participate in a given campaign.
Public method | GetEligibleAgentsForCampaignAsync | Asynchronously gets the IDs of all campaigns that a given agent is active in.
Public method | GetEligibleCampaignsForAgent | Gets the IDs of all active campaigns that a given agent is eligible to participate in.
Public method | GetEligibleCampaignsForAgentAsync | Gets the IDs of all active campaigns that a given agent is eligible to participate in.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshActiveAgentList | Refreshes ActiveAgents.
Public method | RefreshActiveAgentListAsync | Asynchronously refreshes ActiveAgents.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AgentManager Class
ININ.IceLib.Dialer.Supervisor Namespace


AllocateAgents Method

[image] [image]

IceLib Dialer Technical Reference
AgentManager..::..AllocateAgents Method
AgentManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AllocateAgents(Collection<(Of <<'(String>)>>), Collection<(Of <<'(ConfigurationId>)>>), Collection<(Of <<'(ConfigurationId>)>>)) | Request that one or more agents be automatically logged in or out of campaigns.
Public method | AllocateAgents(Collection<(Of <<'(String>)>>), Collection<(Of <<'(CampaignId>)>>), Collection<(Of <<'(CampaignId>)>>)) | Request that one or more agents be automatically logged in or out of campaigns.

See Also

AgentManager Class
AgentManager Members
ININ.IceLib.Dialer.Supervisor Namespace


AllocateAgents Method (Collection(String), Collection(ConfigurationId), Collection(ConfigurationId))

[image]

IceLib Dialer Technical Reference
AgentManager..::..AllocateAgents Method (Collection<(Of <(<'String>)>)>, Collection<(Of <(<'ConfigurationId>)>)>, Collection<(Of <(<'ConfigurationId>)>)>)
AgentManager Class See Also Send Feedback
Request that one or more agents be automatically logged in or out of campaigns.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void AllocateAgents(
    Collection<string> agents,
    Collection<ConfigurationId> campaignsOut,
    Collection<ConfigurationId> campaignsIn
)
Visual Basic
Public Sub AllocateAgents ( _
    agents As Collection(Of String), _
    campaignsOut As Collection(Of ConfigurationId), _
    campaignsIn As Collection(Of ConfigurationId) _
)

Parameters

agents
Type: System.Collections.ObjectModel..::..Collection<(Of <(<'String>)>)>
campaignsOut
Type: System.Collections.ObjectModel..::..Collection<(Of <(<'ConfigurationId>)>)>
The list of campaigns the agents should be logged out of.
campaignsIn
Type: System.Collections.ObjectModel..::..Collection<(Of <(<'ConfigurationId>)>)>
The list of campaigns the agents should be logged into.

See Also

AgentManager Class
AgentManager Members
AllocateAgents Overload
ININ.IceLib.Dialer.Supervisor Namespace


AllocateAgents Method (Collection(String), Collection(CampaignId), Collection(CampaignId))

[image]

IceLib Dialer Technical Reference
AgentManager..::..AllocateAgents Method (Collection<(Of <(<'String>)>)>, Collection<(Of <(<'CampaignId>)>)>, Collection<(Of <(<'CampaignId>)>)>)
AgentManager Class See Also Send Feedback
Request that one or more agents be automatically logged in or out of campaigns.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void AllocateAgents(
    Collection<string> agents,
    Collection<CampaignId> campaignsOut,
    Collection<CampaignId> campaignsIn
)
Visual Basic
Public Sub AllocateAgents ( _
    agents As Collection(Of String), _
    campaignsOut As Collection(Of CampaignId), _
    campaignsIn As Collection(Of CampaignId) _
)

Parameters

agents
Type: System.Collections.ObjectModel..::..Collection<(Of <(<'String>)>)>
campaignsOut
Type: System.Collections.ObjectModel..::..Collection<(Of <(<' CampaignId >)>)>
The list of campaigns the agents should be logged out of.
campaignsIn
Type: System.Collections.ObjectModel..::..Collection<(Of <(<' CampaignId >)>)>
The list of campaigns the agents should be logged into.

See Also

AgentManager Class
AgentManager Members
AllocateAgents Overload
ININ.IceLib.Dialer.Supervisor Namespace


AllocateAgentsAsync Method

[image]

IceLib Dialer Technical Reference
AgentManager..::..AllocateAgentsAsync Method
AgentManager Class See Also Send Feedback
Asynchronously request that one or more agents be automatically logged in or out of campaigns.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void AllocateAgentsAsync(
    Collection<string> agents,
    Collection<CampaignId> campaignsOut,
    Collection<CampaignId> campaignsIn,
    EventHandler<AsyncCompletedEventArgs> callback,
    Object userState
)
Visual Basic
Public Sub AllocateAgentsAsync ( _
    agents As Collection(Of String), _
    campaignsOut As Collection(Of CampaignId), _
    campaignsIn As Collection(Of CampaignId), _
    callback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

agents
Type: System.Collections.ObjectModel..::..Collection<(Of <(<'String>)>)>
campaignsOut
Type: System.Collections.ObjectModel..::..Collection<(Of <(<' CampaignId >)>)>
The list of campaigns the agents should be logged out of.
campaignsIn
Type: System.Collections.ObjectModel..::..Collection<(Of <(<' CampaignId >)>)>
The list of campaigns the agents should be logged into.
callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
userState
Type: System..::..Object

See Also

AgentManager Class
AgentManager Members
ININ.IceLib.Dialer.Supervisor Namespace


GetActiveAgentsForCampaign Method

[image] [image]

IceLib Dialer Technical Reference
AgentManager..::..GetActiveAgentsForCampaign Method
AgentManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetActiveAgentsForCampaign(ConfigurationId) | Gets the list of agents active in a given campaign.
Public method | GetActiveAgentsForCampaign(CampaignId) | Gets the list of agents active in a given campaign.

See Also

AgentManager Class
AgentManager Members
ININ.IceLib.Dialer.Supervisor Namespace


GetActiveAgentsForCampaign Method (ConfigurationId)

[image]

IceLib Dialer Technical Reference
AgentManager..::..GetActiveAgentsForCampaign Method (ConfigurationId)
AgentManager Class See Also Send Feedback
Gets the list of agents active in a given campaign.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<string> GetActiveAgentsForCampaign(
    ConfigurationId campaignId
)
Visual Basic
Public Function GetActiveAgentsForCampaign ( _
    campaignId As ConfigurationId _
) As Collection(Of String)

Parameters

campaignId
Type: ConfigurationId
The campaign ID

Return Value

A collection of agent IDs

See Also

AgentManager Class
AgentManager Members
GetActiveAgentsForCampaign Overload
ININ.IceLib.Dialer.Supervisor Namespace


GetActiveAgentsForCampaign Method (CampaignId)

[image]

IceLib Dialer Technical Reference
AgentManager..::..GetActiveAgentsForCampaign Method (CampaignId)
AgentManager Class See Also Send Feedback
Gets the list of agents active in a given campaign.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<string> GetActiveAgentsForCampaign(
    CampaignId campaignId
)
Visual Basic
Public Function GetActiveAgentsForCampaign ( _
    campaignId As CampaignId _
) As Collection(Of String)

Parameters

campaignId
Type: ININ.IceLib.Dialer..::..CampaignId
The campaign ID

Return Value

A collection of agent IDs

See Also

AgentManager Class
AgentManager Members
GetActiveAgentsForCampaign Overload
ININ.IceLib.Dialer.Supervisor Namespace


GetActiveAgentsForCampaignAsync Method

[image]

IceLib Dialer Technical Reference
AgentManager..::..GetActiveAgentsForCampaignAsync Method
AgentManager Class See Also Send Feedback
Asynchronously gets the list of agents active in a given campaign.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void GetActiveAgentsForCampaignAsync(
    CampaignId campaignId,
    EventHandler<AsyncCompletedEventArgs<Collection<string>>> callback,
    Object userState
)
Visual Basic
Public Sub GetActiveAgentsForCampaignAsync ( _
    campaignId As CampaignId, _
    callback As EventHandler(Of AsyncCompletedEventArgs(Of Collection(Of String))), _
    userState As Object _
)

Parameters

campaignId
Type: ININ.IceLib.Dialer..::..CampaignId
The campaign ID
callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Collection<(Of <(<'String>)>)>>)>)>>)>)>
userState
Type: System..::..Object

Return Value

A list of CampaignIds

See Also

AgentManager Class
AgentManager Members
ININ.IceLib.Dialer.Supervisor Namespace


GetActiveCampaignsForAgent Method

[image]

IceLib Dialer Technical Reference
AgentManager..::..GetActiveCampaignsForAgent Method
AgentManager Class See Also Send Feedback
Gets the IDs of all campaigns that a given agent is active in.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<CampaignId> GetActiveCampaignsForAgent(
    string agentId
)
Visual Basic
Public Function GetActiveCampaignsForAgent ( _
    agentId As String _
) As Collection(Of CampaignId)

Parameters

agentId
Type: System..::..String
The agent ID

Return Value

A list of CampaignIds

See Also

AgentManager Class
AgentManager Members
ININ.IceLib.Dialer.Supervisor Namespace


GetActiveCampaignsForAgentAsync Method

[image]

IceLib Dialer Technical Reference
AgentManager..::..GetActiveCampaignsForAgentAsync Method
AgentManager Class See Also Send Feedback
Asynchronously gets the IDs of all campaigns that a given agent is active in.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void GetActiveCampaignsForAgentAsync(
    string agentId,
    EventHandler<AsyncCompletedEventArgs<Collection<CampaignId>>> callback,
    Object userState
)
Visual Basic
Public Sub GetActiveCampaignsForAgentAsync ( _
    agentId As String, _
    callback As EventHandler(Of AsyncCompletedEventArgs(Of Collection(Of CampaignId))), _
    userState As Object _
)

Parameters

agentId
Type: System..::..String
The agent ID
callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Collection<(Of <(<' CampaignId >)>)>>)>)>>)>)>
userState
Type: System..::..Object

Return Value

A list of CampaignIds

See Also

AgentManager Class
AgentManager Members
ININ.IceLib.Dialer.Supervisor Namespace


GetEligibleAgentsForCampaign Method

[image] [image]

IceLib Dialer Technical Reference
AgentManager..::..GetEligibleAgentsForCampaign Method
AgentManager Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetEligibleAgentsForCampaign(ConfigurationId) | Gets the list of agents that are logged in and eligible to participate in a given campaign.
Public method | GetEligibleAgentsForCampaign(CampaignId) | Gets the list of agents that are logged in and eligible to participate in a given campaign.

See Also

AgentManager Class
AgentManager Members
ININ.IceLib.Dialer.Supervisor Namespace


GetEligibleAgentsForCampaign Method (ConfigurationId)

[image]

IceLib Dialer Technical Reference
AgentManager..::..GetEligibleAgentsForCampaign Method (ConfigurationId)
AgentManager Class See Also Send Feedback
Gets the list of agents that are logged in and eligible to participate in a given campaign.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<string> GetEligibleAgentsForCampaign(
    ConfigurationId campaignId
)
Visual Basic
Public Function GetEligibleAgentsForCampaign ( _
    campaignId As ConfigurationId _
) As Collection(Of String)

Parameters

campaignId
Type: ConfigurationId
The campaign ID

Return Value

A collection of agent IDs

See Also

AgentManager Class
AgentManager Members
GetEligibleAgentsForCampaign Overload
ININ.IceLib.Dialer.Supervisor Namespace


GetEligibleAgentsForCampaign Method (CampaignId)

[image]

IceLib Dialer Technical Reference
AgentManager..::..GetEligibleAgentsForCampaign Method (CampaignId)
AgentManager Class See Also Send Feedback
Gets the list of agents that are logged in and eligible to participate in a given campaign.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<string> GetEligibleAgentsForCampaign(
    CampaignId campaignId
)
Visual Basic
Public Function GetEligibleAgentsForCampaign ( _
    campaignId As CampaignId _
) As Collection(Of String)

Parameters

campaignId
Type: ININ.IceLib.Dialer..::..CampaignId
The campaign ID

Return Value

A collection of agent IDs

See Also

AgentManager Class
AgentManager Members
GetEligibleAgentsForCampaign Overload
ININ.IceLib.Dialer.Supervisor Namespace


GetEligibleAgentsForCampaignAsync Method

[image]

IceLib Dialer Technical Reference
AgentManager..::..GetEligibleAgentsForCampaignAsync Method
AgentManager Class See Also Send Feedback
Asynchronously gets the IDs of all campaigns that a given agent is active in.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void GetEligibleAgentsForCampaignAsync(
    CampaignId campaignId,
    EventHandler<AsyncCompletedEventArgs<Collection<string>>> callback,
    Object userState
)
Visual Basic
Public Sub GetEligibleAgentsForCampaignAsync ( _
    campaignId As CampaignId, _
    callback As EventHandler(Of AsyncCompletedEventArgs(Of Collection(Of String))), _
    userState As Object _
)

Parameters

campaignId
Type: ININ.IceLib.Dialer..::..CampaignId
The campaign ID
callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Collection<(Of <(<'String>)>)>>)>)>>)>)>
userState
Type: System..::..Object

Return Value

A list of CampaignIds

See Also

AgentManager Class
AgentManager Members
ININ.IceLib.Dialer.Supervisor Namespace


GetEligibleCampaignsForAgent Method

[image]

IceLib Dialer Technical Reference
AgentManager..::..GetEligibleCampaignsForAgent Method
AgentManager Class See Also Send Feedback
Gets the IDs of all active campaigns that a given agent is eligible to participate in.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<CampaignId> GetEligibleCampaignsForAgent(
    string agentId
)
Visual Basic
Public Function GetEligibleCampaignsForAgent ( _
    agentId As String _
) As Collection(Of CampaignId)

Parameters

agentId
Type: System..::..String
The agent ID

Return Value

A list of CampaignId/>s

See Also

AgentManager Class
AgentManager Members
ININ.IceLib.Dialer.Supervisor Namespace


GetEligibleCampaignsForAgentAsync Method

[image]

IceLib Dialer Technical Reference
AgentManager..::..GetEligibleCampaignsForAgentAsync Method
AgentManager Class See Also Send Feedback
Gets the IDs of all active campaigns that a given agent is eligible to participate in.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void GetEligibleCampaignsForAgentAsync(
    string agentId,
    EventHandler<AsyncCompletedEventArgs<Collection<CampaignId>>> callback,
    Object userState
)
Visual Basic
Public Sub GetEligibleCampaignsForAgentAsync ( _
    agentId As String, _
    callback As EventHandler(Of AsyncCompletedEventArgs(Of Collection(Of CampaignId))), _
    userState As Object _
)

Parameters

agentId
Type: System..::..String
The agent ID
callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs<(Of <(<'Collection<(Of <(<' CampaignId >)>)>>)>)>>)>)>
userState
Type: System..::..Object

Return Value

A list of CampaignIds

See Also

AgentManager Class
AgentManager Members
ININ.IceLib.Dialer.Supervisor Namespace


RefreshActiveAgentList Method

[image]

IceLib Dialer Technical Reference
AgentManager..::..RefreshActiveAgentList Method
AgentManager Class See Also Send Feedback
Refreshes ActiveAgents.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void RefreshActiveAgentList()
Visual Basic
Public Sub RefreshActiveAgentList

See Also

AgentManager Class
AgentManager Members
ININ.IceLib.Dialer.Supervisor Namespace


RefreshActiveAgentListAsync Method

[image]

IceLib Dialer Technical Reference
AgentManager..::..RefreshActiveAgentListAsync Method
AgentManager Class See Also Send Feedback
Asynchronously refreshes ActiveAgents.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void RefreshActiveAgentListAsync(
    EventHandler<AsyncCompletedEventArgs> callback,
    Object userState
)
Visual Basic
Public Sub RefreshActiveAgentListAsync ( _
    callback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
userState
Type: System..::..Object

See Also

AgentManager Class
AgentManager Members
ININ.IceLib.Dialer.Supervisor Namespace


AgentManager Properties

[image] [image]

IceLib Dialer Technical Reference
AgentManager Properties
AgentManager Class See Also Send Feedback

The AgentManager type exposes the following members.

Properties

 | Name | Description
Public property | ActiveAgents | The list of agents logged into Dialer a.k.a. agents that may be managed via the AgentManager class. This does not include agents logged directly into campaigns, which cannot be managed by this class.
Public property | Session | Gets the Session used by the AgentManager.

See Also

AgentManager Class
ININ.IceLib.Dialer.Supervisor Namespace


ActiveAgents Property

[image]

IceLib Dialer Technical Reference
AgentManager..::..ActiveAgents Property
AgentManager Class See Also Send Feedback
The list of agents logged into Dialer a.k.a. agents that may be managed via the AgentManager class. This does not include agents logged directly into campaigns, which cannot be managed by this class.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<string> ActiveAgents { get; private set; }
Visual Basic
Public Property ActiveAgents As Collection(Of String)
    Get
    Private Set

See Also

AgentManager Class
AgentManager Members
ININ.IceLib.Dialer.Supervisor Namespace


Session Property

[image]

IceLib Dialer Technical Reference
AgentManager..::..Session Property
AgentManager Class See Also Send Feedback
Gets the Session used by the AgentManager.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Session Session { get; private set; }
Visual Basic
Public Property Session As Session
    Get
    Private Set

Field Value

The session.

See Also

AgentManager Class
AgentManager Members
ININ.IceLib.Dialer.Supervisor Namespace


ContactListPenetration Class

[image]

IceLib Dialer Technical Reference
ContactListPenetration Class
Members See Also Send Feedback
Overview: The penetration rate is a new Dialer 4.0 feature. It allows a customer to run reports that show the number of contacts that were contacted (the numerator) versus a number of records in a contact list (the denominator).

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class ContactListPenetration
Visual Basic
Public Class ContactListPenetration

Remarks

The upload ID is a sequential number that is created every time a new contact list is uploaded or contacts are added to an existing contact list via the Import Contact List Wizard. This new Upload ID is then assigned to the new contacts. This assignment is done through a new column "I3_UPLOAD_ID" in the contact list. In parallel, a new row is added in the Upload table.

I3_<ContactListName>_PEN: This table contains the information that will figure into the numerator. It contains one row for each completed call of the corresponding contact list table.

para>

I3PenetrationUpload: A new row is added in this table every time contacts added to a contact list. That's where the UploadID is stored. It is an integer that gets incremented every time a new row is added in this table.

para>

I3PenetrationRange: This table will support value ranges of arbitrary contact list columns. There will be one row per range per column per upload ID.

I3PenetrationData: Table that stores the actual penetration data. It will contain two rows per contact column (one for all values and one for unique values) + one row per contact list to account for all contacts.

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Dialer.Supervisor..::..ContactListPenetration

See Also

ContactListPenetration Members
ININ.IceLib.Dialer.Supervisor Namespace


ContactListPenetration Members

[image] [image]

IceLib Dialer Technical Reference
ContactListPenetration Members
ContactListPenetration Class Constructors Methods Properties See Also Send Feedback

The ContactListPenetration type exposes the following members.

Constructors

 | Name | Description
Public method | ContactListPenetration | Initializes a new instance of the ContactListPenetration class.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPenetrationRate(ContactListConfiguration, String, String) | Gets the penetration rate of a given contact list, given a set of criteria defining the method of defining a penetrated record.
Public method | GetPenetrationRate(ConfigurationId, String, String, String) | Gets the penetration rate of a given contact list, given a set of criteria defining the method of defining a penetrated record.
Public method | GetPenetrationRate(ContactListConfiguration, DateTime, DateTime, List<(Of <<'(String>)>>), List<(Of <<'(CampaignDialingMode>)>>), String, List<(Of <<'(String>)>>), PenetrationRateCalculationMode, List<(Of <<'(Int32>)>>)) | Gets the penetration rate of a given contact list, given a set of criteria defining the method of defining a penetrated record.
Public method | GetPenetrationRate(ConfigurationId, String, DateTime, DateTime, List<(Of <<'(String>)>>), List<(Of <<'(CampaignDialingMode>)>>), String, List<(Of <<'(String>)>>), PenetrationRateCalculationMode, List<(Of <<'(Int32>)>>)) | Gets the penetration rate of a given contact list, given a set of criteria defining the method of defining a penetrated record.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUploadIdsForContactList(ContactListConfiguration) | Gets the list of upload IDs in a given contact list.
Public method | GetUploadIdsForContactList(ConfigurationId, ConfigurationId, String) | Gets the list of upload IDs in a given contact list.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Session | Gets the Session used by the ContactListPenetration.

See Also

ContactListPenetration Class
ININ.IceLib.Dialer.Supervisor Namespace


ContactListPenetration Constructor

[image]

IceLib Dialer Technical Reference
ContactListPenetration Constructor
ContactListPenetration Class See Also Send Feedback
Initializes a new instance of the ContactListPenetration class.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ContactListPenetration(
    Session session
)
Visual Basic
Public Sub New ( _
    session As Session _
)

Parameters

session
Type: Session
The Session to be used. The session must already be initialized and connected.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).
IceLibException | The supplied Session is not valid or is not connected.

See Also

ContactListPenetration Class
ContactListPenetration Members
ININ.IceLib.Dialer.Supervisor Namespace


ContactListPenetration Methods

[image] [image]

IceLib Dialer Technical Reference
ContactListPenetration Methods
ContactListPenetration Class See Also Send Feedback

The ContactListPenetration type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPenetrationRate(ContactListConfiguration, String, String) | Gets the penetration rate of a given contact list, given a set of criteria defining the method of defining a penetrated record.
Public method | GetPenetrationRate(ConfigurationId, String, String, String) | Gets the penetration rate of a given contact list, given a set of criteria defining the method of defining a penetrated record.
Public method | GetPenetrationRate(ContactListConfiguration, DateTime, DateTime, List<(Of <<'(String>)>>), List<(Of <<'(CampaignDialingMode>)>>), String, List<(Of <<'(String>)>>), PenetrationRateCalculationMode, List<(Of <<'(Int32>)>>)) | Gets the penetration rate of a given contact list, given a set of criteria defining the method of defining a penetrated record.
Public method | GetPenetrationRate(ConfigurationId, String, DateTime, DateTime, List<(Of <<'(String>)>>), List<(Of <<'(CampaignDialingMode>)>>), String, List<(Of <<'(String>)>>), PenetrationRateCalculationMode, List<(Of <<'(Int32>)>>)) | Gets the penetration rate of a given contact list, given a set of criteria defining the method of defining a penetrated record.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUploadIdsForContactList(ContactListConfiguration) | Gets the list of upload IDs in a given contact list.
Public method | GetUploadIdsForContactList(ConfigurationId, ConfigurationId, String) | Gets the list of upload IDs in a given contact list.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ContactListPenetration Class
ININ.IceLib.Dialer.Supervisor Namespace


GetPenetrationRate Method

[image] [image]

IceLib Dialer Technical Reference
ContactListPenetration..::..GetPenetrationRate Method
ContactListPenetration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetPenetrationRate(ContactListConfiguration, String, String) | Gets the penetration rate of a given contact list, given a set of criteria defining the method of defining a penetrated record.
Public method | GetPenetrationRate(ConfigurationId, String, String, String) | Gets the penetration rate of a given contact list, given a set of criteria defining the method of defining a penetrated record.
Public method | GetPenetrationRate(ContactListConfiguration, DateTime, DateTime, List<(Of <<'(String>)>>), List<(Of <<'(CampaignDialingMode>)>>), String, List<(Of <<'(String>)>>), PenetrationRateCalculationMode, List<(Of <<'(Int32>)>>)) | Gets the penetration rate of a given contact list, given a set of criteria defining the method of defining a penetrated record.
Public method | GetPenetrationRate(ConfigurationId, String, DateTime, DateTime, List<(Of <<'(String>)>>), List<(Of <<'(CampaignDialingMode>)>>), String, List<(Of <<'(String>)>>), PenetrationRateCalculationMode, List<(Of <<'(Int32>)>>)) | Gets the penetration rate of a given contact list, given a set of criteria defining the method of defining a penetrated record.

See Also

ContactListPenetration Class
ContactListPenetration Members
ININ.IceLib.Dialer.Supervisor Namespace


GetPenetrationRate Method (ContactListConfiguration, String, String)

[image]

IceLib Dialer Technical Reference
ContactListPenetration..::..GetPenetrationRate Method (ContactListConfiguration, String, String)
ContactListPenetration Class See Also Send Feedback
Gets the penetration rate of a given contact list, given a set of criteria defining the method of defining a penetrated record.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ContactListPenetration..::..ContactListPenetrationRate GetPenetrationRate(
    ContactListConfiguration contactListConfiguration,
    string numeratorFilter,
    string denominatorFilter
)
Visual Basic
Public Function GetPenetrationRate ( _
    contactListConfiguration As ContactListConfiguration, _
    numeratorFilter As String, _
    denominatorFilter As String _
) As ContactListPenetration..::..ContactListPenetrationRate

Parameters

contactListConfiguration
Type: ININ.IceLib.Configuration.Dialer..::..ContactListConfiguration
The contact list
numeratorFilter
Type: System..::..String
The numerator filter
denominatorFilter
Type: System..::..String
The denominator filter

Return Value

The contact list penetration rate, the number of records penetrated and the total number of records available for the calculation.

See Also

ContactListPenetration Class
ContactListPenetration Members
GetPenetrationRate Overload
ININ.IceLib.Dialer.Supervisor Namespace


GetPenetrationRate Method (ConfigurationId, String, String, String)

[image]

IceLib Dialer Technical Reference
ContactListPenetration..::..GetPenetrationRate Method (ConfigurationId, String, String, String)
ContactListPenetration Class See Also Send Feedback
Gets the penetration rate of a given contact list, given a set of criteria defining the method of defining a penetrated record.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ContactListPenetration..::..ContactListPenetrationRate GetPenetrationRate(
    ConfigurationId connectionId,
    string table,
    string numeratorFilter,
    string denominatorFilter
)
Visual Basic
Public Function GetPenetrationRate ( _
    connectionId As ConfigurationId, _
    table As String, _
    numeratorFilter As String, _
    denominatorFilter As String _
) As ContactListPenetration..::..ContactListPenetrationRate

Parameters

connectionId
Type: ConfigurationId
The connection ID
table
Type: System..::..String
The name of an existing contact list table in the database pointed to by connectionId.
numeratorFilter
Type: System..::..String
The numerator filter
denominatorFilter
Type: System..::..String
The denominator filter

Return Value

The contact list penetration rate, the number of records penetrated and the total number of records available for the calculation.

See Also

ContactListPenetration Class
ContactListPenetration Members
GetPenetrationRate Overload
ININ.IceLib.Dialer.Supervisor Namespace


GetPenetrationRate Method (ContactListConfiguration, DateTime, DateTime, List(String), List(CampaignDialingMode), String, List(String), PenetrationRateCalculationMode, List(Int32))

[image]

IceLib Dialer Technical Reference
ContactListPenetration..::..GetPenetrationRate Method (ContactListConfiguration, DateTime, DateTime, List<(Of <(<'String>)>)>, List<(Of <(<'CampaignDialingMode>)>)>, String, List<(Of <(<'String>)>)>, PenetrationRateCalculationMode, List<(Of <(<'Int32>)>)>)
ContactListPenetration Class See Also Send Feedback
Gets the penetration rate of a given contact list, given a set of criteria defining the method of defining a penetrated record.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ContactListPenetration..::..ContactListPenetrationRate GetPenetrationRate(
    ContactListConfiguration contactListConfiguration,
    DateTime startDateTime,
    DateTime endDateTime,
    List<string> campaigns,
    List<CampaignDialingMode> callingModes,
    string phoneNumberColumn,
    List<string> wrapupCodes,
    PenetrationRateCalculationMode penetrationCountType,
    List<int> uploadIds
)
Visual Basic
Public Function GetPenetrationRate ( _
    contactListConfiguration As ContactListConfiguration, _
    startDateTime As DateTime, _
    endDateTime As DateTime, _
    campaigns As List(Of String), _
    callingModes As List(Of CampaignDialingMode), _
    phoneNumberColumn As String, _
    wrapupCodes As List(Of String), _
    penetrationCountType As PenetrationRateCalculationMode, _
    uploadIds As List(Of Integer) _
) As ContactListPenetration..::..ContactListPenetrationRate

Parameters

contactListConfiguration
Type: ININ.IceLib.Configuration.Dialer..::..ContactListConfiguration
The contact list
startDateTime
Type: System..::..DateTime
The starting DateTime value that will be used as a filter.
endDateTime
Type: System..::..DateTime
The ending DateTime value that will be used as a filter.
campaigns
Type: System.Collections.Generic..::..List<(Of <(<'String>)>)>
A list of campaigns to restrict the penetration count based on attempts done with these campaigns. If the list is empty or null, then it will take all attempts from any campaign into account.
callingModes
Type: System.Collections.Generic..::..List<(Of <(<' CampaignDialingMode >)>)>
A list of calling modes to restrict the penetration count based on attempts done with these calling modes. If the list is empty or null, then it will take all attempts from any calling mode into account.
phoneNumberColumn
Type: System..::..String
The phone number column to use to determine the penetration of the contact list. If the string is empty or null, then it will use the total contacts instead of restricting per Phone Number Column.
wrapupCodes
Type: System.Collections.Generic..::..List<(Of <(<'String>)>)>
A list of wrapup codes to restrict the penetration count based on dispositions made on attempts with these wrapup codes. If the list is empty or null, then it will take all attempts from any wrapup code into account.
penetrationCountType
Type: ININ.IceLib.Configuration.Dialer.DataTypes..::..PenetrationRateCalculationMode
The type of calculation used to determine the penetration rate.
uploadIds
Type: System.Collections.Generic..::..List<(Of <(<'Int32>)>)>
A list of penetration upload IDs. This is a required parameter and may not be null.

Return Value

The contact list penetration rate, the number of records penetrated and the total number of records available for the calculation.

See Also

ContactListPenetration Class
ContactListPenetration Members
GetPenetrationRate Overload
ININ.IceLib.Dialer.Supervisor Namespace


GetPenetrationRate Method (ConfigurationId, String, DateTime, DateTime, List(String), List(CampaignDialingMode), String, List(String), PenetrationRateCalculationMode, List(Int32))

[image]

IceLib Dialer Technical Reference
ContactListPenetration..::..GetPenetrationRate Method (ConfigurationId, String, DateTime, DateTime, List<(Of <(<'String>)>)>, List<(Of <(<'CampaignDialingMode>)>)>, String, List<(Of <(<'String>)>)>, PenetrationRateCalculationMode, List<(Of <(<'Int32>)>)>)
ContactListPenetration Class See Also Send Feedback
Gets the penetration rate of a given contact list, given a set of criteria defining the method of defining a penetrated record.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ContactListPenetration..::..ContactListPenetrationRate GetPenetrationRate(
    ConfigurationId connectionId,
    string table,
    DateTime startDateTime,
    DateTime endDateTime,
    List<string> campaigns,
    List<CampaignDialingMode> callingModes,
    string phoneNumberColumn,
    List<string> wrapupCodes,
    PenetrationRateCalculationMode penetrationCountType,
    List<int> uploadIds
)
Visual Basic
Public Function GetPenetrationRate ( _
    connectionId As ConfigurationId, _
    table As String, _
    startDateTime As DateTime, _
    endDateTime As DateTime, _
    campaigns As List(Of String), _
    callingModes As List(Of CampaignDialingMode), _
    phoneNumberColumn As String, _
    wrapupCodes As List(Of String), _
    penetrationCountType As PenetrationRateCalculationMode, _
    uploadIds As List(Of Integer) _
) As ContactListPenetration..::..ContactListPenetrationRate

Parameters

connectionId
Type: ConfigurationId
The connection ID
table
Type: System..::..String
The name of an existing contact list table in the database pointed to by connectionId.
startDateTime
Type: System..::..DateTime
The starting DateTime value that will be used as a filter.
endDateTime
Type: System..::..DateTime
The ending DateTime value that will be used as a filter.
campaigns
Type: System.Collections.Generic..::..List<(Of <(<'String>)>)>
A list of campaigns to restrict the penetration count based on attempts done with these campaigns. If the list is empty or null, then it will take all attempts from any campaign into account.
callingModes
Type: System.Collections.Generic..::..List<(Of <(<' CampaignDialingMode >)>)>
A list of calling modes to restrict the penetration count based on attempts done with these calling modes. If the list is empty or null, then it will take all attempts from any calling mode into account.
phoneNumberColumn
Type: System..::..String
The phone number column to use to determine the penetration of the contact list. If the string is empty or null, then it will use the total contacts instead of restricting per Phone Number Column.
wrapupCodes
Type: System.Collections.Generic..::..List<(Of <(<'String>)>)>
A list of wrapup codes to restrict the penetration count based on dispositions made on attempts with these wrapup codes. If the list is empty or null, then it will take all attempts from any wrapup code into account.
penetrationCountType
Type: ININ.IceLib.Configuration.Dialer.DataTypes..::..PenetrationRateCalculationMode
The type of calculation used to determine the penetration rate.
uploadIds
Type: System.Collections.Generic..::..List<(Of <(<'Int32>)>)>
A list of penetration upload IDs. This is a required parameter and may not be null.

Return Value

The contact list penetration rate, the number of records penetrated and the total number of records available for the calculation.

See Also

ContactListPenetration Class
ContactListPenetration Members
GetPenetrationRate Overload
ININ.IceLib.Dialer.Supervisor Namespace


GetUploadIdsForContactList Method

[image] [image]

IceLib Dialer Technical Reference
ContactListPenetration..::..GetUploadIdsForContactList Method
ContactListPenetration Class See Also Send Feedback

Overload List

 | Name | Description
Public method | GetUploadIdsForContactList(ContactListConfiguration) | Gets the list of upload IDs in a given contact list.
Public method | GetUploadIdsForContactList(ConfigurationId, ConfigurationId, String) | Gets the list of upload IDs in a given contact list.

See Also

ContactListPenetration Class
ContactListPenetration Members
ININ.IceLib.Dialer.Supervisor Namespace


GetUploadIdsForContactList Method (ContactListConfiguration)

[image]

IceLib Dialer Technical Reference
ContactListPenetration..::..GetUploadIdsForContactList Method (ContactListConfiguration)
ContactListPenetration Class See Also Send Feedback
Gets the list of upload IDs in a given contact list.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<ContactListPenetration..::..ContactListPenetrationUpload> GetUploadIdsForContactList(
    ContactListConfiguration contactListConfiguration
)
Visual Basic
Public Function GetUploadIdsForContactList ( _
    contactListConfiguration As ContactListConfiguration _
) As Collection(Of ContactListPenetration..::..ContactListPenetrationUpload)

Parameters

contactListConfiguration
Type: ININ.IceLib.Configuration.Dialer..::..ContactListConfiguration
The contact list

Return Value

A collection of upload IDs

See Also

ContactListPenetration Class
ContactListPenetration Members
GetUploadIdsForContactList Overload
ININ.IceLib.Dialer.Supervisor Namespace


GetUploadIdsForContactList Method (ConfigurationId, ConfigurationId, String)

[image]

IceLib Dialer Technical Reference
ContactListPenetration..::..GetUploadIdsForContactList Method (ConfigurationId, ConfigurationId, String)
ContactListPenetration Class See Also Send Feedback
Gets the list of upload IDs in a given contact list.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<ContactListPenetration..::..ContactListPenetrationUpload> GetUploadIdsForContactList(
    ConfigurationId connectionId,
    ConfigurationId contactListId,
    string tableName
)
Visual Basic
Public Function GetUploadIdsForContactList ( _
    connectionId As ConfigurationId, _
    contactListId As ConfigurationId, _
    tableName As String _
) As Collection(Of ContactListPenetration..::..ContactListPenetrationUpload)

Parameters

connectionId
Type: ConfigurationId
The connection ID
contactListId
Type: ConfigurationId
The contact list ID
tableName
Type: System..::..String
The name of an existing contact list table in the database pointed to by connectionid.

Return Value

A collection of upload IDs

See Also

ContactListPenetration Class
ContactListPenetration Members
GetUploadIdsForContactList Overload
ININ.IceLib.Dialer.Supervisor Namespace


ContactListPenetration Properties

[image] [image]

IceLib Dialer Technical Reference
ContactListPenetration Properties
ContactListPenetration Class See Also Send Feedback

The ContactListPenetration type exposes the following members.

Properties

 | Name | Description
Public property | Session | Gets the Session used by the ContactListPenetration.

See Also

ContactListPenetration Class
ININ.IceLib.Dialer.Supervisor Namespace


Session Property

[image]

IceLib Dialer Technical Reference
ContactListPenetration..::..Session Property
ContactListPenetration Class See Also Send Feedback
Gets the Session used by the ContactListPenetration.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Session Session { get; private set; }
Visual Basic
Public Property Session As Session
    Get
    Private Set

Field Value

The session.

See Also

ContactListPenetration Class
ContactListPenetration Members
ININ.IceLib.Dialer.Supervisor Namespace


ContactListPenetration.ContactListPenetrationData Structure

[image]

IceLib Dialer Technical Reference
ContactListPenetration..::..ContactListPenetrationData Structure
ContactListPenetration Class Members See Also Send Feedback
Structure that defines a segment of an upload. For any given upload, it will contain two rows per contact column (one for all values and one for unique values) + one row per contact list to account for all contacts.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public struct ContactListPenetrationData
Visual Basic
Public Structure ContactListPenetrationData

See Also

ContactListPenetration..::..ContactListPenetrationData Members
ININ.IceLib.Dialer.Supervisor Namespace


ContactListPenetration.ContactListPenetrationData Members

[image] [image]

IceLib Dialer Technical Reference
ContactListPenetration..::..ContactListPenetrationData Members
ContactListPenetration..::..ContactListPenetrationData Structure Methods Fields See Also Send Feedback

The ContactListPenetration..::..ContactListPenetrationData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | NumberItems | Represents the number of contacts that were uploaded with the combination of the Upload Id and the type/subtype.
Public field | Range | Id that represents the ContactList Penetration Data with the relationship between the Types and subTypes.
Public field | SubType | String that represents the phone number column type.
Public field | Type | String that represents a given contact column or a given unique contact column. Possible values include: Contacts, Phone Number, Unique Phone Number

See Also

ContactListPenetration..::..ContactListPenetrationData Structure
ININ.IceLib.Dialer.Supervisor Namespace


ContactListPenetration.ContactListPenetrationData Fields

[image] [image]

IceLib Dialer Technical Reference
ContactListPenetration..::..ContactListPenetrationData Fields
ContactListPenetration..::..ContactListPenetrationData Structure See Also Send Feedback

The ContactListPenetration..::..ContactListPenetrationData type exposes the following members.

Fields

 | Name | Description
Public field | NumberItems | Represents the number of contacts that were uploaded with the combination of the Upload Id and the type/subtype.
Public field | Range | Id that represents the ContactList Penetration Data with the relationship between the Types and subTypes.
Public field | SubType | String that represents the phone number column type.
Public field | Type | String that represents a given contact column or a given unique contact column. Possible values include: Contacts, Phone Number, Unique Phone Number

See Also

ContactListPenetration..::..ContactListPenetrationData Structure
ININ.IceLib.Dialer.Supervisor Namespace


NumberItems Field

[image]

IceLib Dialer Technical Reference
ContactListPenetration..::..ContactListPenetrationData..::..NumberItems Field
ContactListPenetration..::..ContactListPenetrationData Structure See Also Send Feedback
Represents the number of contacts that were uploaded with the combination of the Upload Id and the type/subtype.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly long NumberItems
Visual Basic
Public ReadOnly NumberItems As Long

See Also

ContactListPenetration..::..ContactListPenetrationData Structure
ContactListPenetration..::..ContactListPenetrationData Members
ININ.IceLib.Dialer.Supervisor Namespace


Range Field

[image]

IceLib Dialer Technical Reference
ContactListPenetration..::..ContactListPenetrationData..::..Range Field
ContactListPenetration..::..ContactListPenetrationData Structure See Also Send Feedback
Id that represents the ContactList Penetration Data with the relationship between the Types and subTypes.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly long Range
Visual Basic
Public ReadOnly Range As Long

See Also

ContactListPenetration..::..ContactListPenetrationData Structure
ContactListPenetration..::..ContactListPenetrationData Members
ININ.IceLib.Dialer.Supervisor Namespace


SubType Field

[image]

IceLib Dialer Technical Reference
ContactListPenetration..::..ContactListPenetrationData..::..SubType Field
ContactListPenetration..::..ContactListPenetrationData Structure See Also Send Feedback
String that represents the phone number column type.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly string SubType
Visual Basic
Public ReadOnly SubType As String

See Also

ContactListPenetration..::..ContactListPenetrationData Structure
ContactListPenetration..::..ContactListPenetrationData Members
ININ.IceLib.Dialer.Supervisor Namespace


Type Field

[image]

IceLib Dialer Technical Reference
ContactListPenetration..::..ContactListPenetrationData..::..Type Field
ContactListPenetration..::..ContactListPenetrationData Structure See Also Send Feedback
String that represents a given contact column or a given unique contact column. Possible values include: Contacts, Phone Number, Unique Phone Number

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly string Type
Visual Basic
Public ReadOnly Type As String

See Also

ContactListPenetration..::..ContactListPenetrationData Structure
ContactListPenetration..::..ContactListPenetrationData Members
ININ.IceLib.Dialer.Supervisor Namespace


ContactListPenetration.ContactListPenetrationData Methods

[image] [image]

IceLib Dialer Technical Reference
ContactListPenetration..::..ContactListPenetrationData Methods
ContactListPenetration..::..ContactListPenetrationData Structure See Also Send Feedback

The ContactListPenetration..::..ContactListPenetrationData type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

ContactListPenetration..::..ContactListPenetrationData Structure
ININ.IceLib.Dialer.Supervisor Namespace


ContactListPenetration.ContactListPenetrationRate Structure

[image]

IceLib Dialer Technical Reference
ContactListPenetration..::..ContactListPenetrationRate Structure
ContactListPenetration Class Members See Also Send Feedback
This structure holds the number of records returned by the GetPenetrationRate for the numerator, denominator and the Penetration Rate.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public struct ContactListPenetrationRate
Visual Basic
Public Structure ContactListPenetrationRate

See Also

ContactListPenetration..::..ContactListPenetrationRate Members
ININ.IceLib.Dialer.Supervisor Namespace


ContactListPenetration.ContactListPenetrationRate Members

[image] [image]

IceLib Dialer Technical Reference
ContactListPenetration..::..ContactListPenetrationRate Members
ContactListPenetration..::..ContactListPenetrationRate Structure Methods Fields See Also Send Feedback

The ContactListPenetration..::..ContactListPenetrationRate type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | Denominator | The number of records in the contact list defined by the denominator filter passed into the GetPenetrationRate function.
Public field | Numerator | The number of penetrated records defined by the numerator filter passed into the GetPenetrationRate function.
Public field | Rate | The percentage of contact list penetration as defined by the filters passed into the GetPenetrationRate function.

See Also

ContactListPenetration..::..ContactListPenetrationRate Structure
ININ.IceLib.Dialer.Supervisor Namespace


ContactListPenetration.ContactListPenetrationRate Fields

[image] [image]

IceLib Dialer Technical Reference
ContactListPenetration..::..ContactListPenetrationRate Fields
ContactListPenetration..::..ContactListPenetrationRate Structure See Also Send Feedback

The ContactListPenetration..::..ContactListPenetrationRate type exposes the following members.

Fields

 | Name | Description
Public field | Denominator | The number of records in the contact list defined by the denominator filter passed into the GetPenetrationRate function.
Public field | Numerator | The number of penetrated records defined by the numerator filter passed into the GetPenetrationRate function.
Public field | Rate | The percentage of contact list penetration as defined by the filters passed into the GetPenetrationRate function.

See Also

ContactListPenetration..::..ContactListPenetrationRate Structure
ININ.IceLib.Dialer.Supervisor Namespace


Denominator Field

[image]

IceLib Dialer Technical Reference
ContactListPenetration..::..ContactListPenetrationRate..::..Denominator Field
ContactListPenetration..::..ContactListPenetrationRate Structure See Also Send Feedback
The number of records in the contact list defined by the denominator filter passed into the GetPenetrationRate function.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly int Denominator
Visual Basic
Public ReadOnly Denominator As Integer

See Also

ContactListPenetration..::..ContactListPenetrationRate Structure
ContactListPenetration..::..ContactListPenetrationRate Members
ININ.IceLib.Dialer.Supervisor Namespace


Numerator Field

[image]

IceLib Dialer Technical Reference
ContactListPenetration..::..ContactListPenetrationRate..::..Numerator Field
ContactListPenetration..::..ContactListPenetrationRate Structure See Also Send Feedback
The number of penetrated records defined by the numerator filter passed into the GetPenetrationRate function.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly int Numerator
Visual Basic
Public ReadOnly Numerator As Integer

See Also

ContactListPenetration..::..ContactListPenetrationRate Structure
ContactListPenetration..::..ContactListPenetrationRate Members
ININ.IceLib.Dialer.Supervisor Namespace


Rate Field

[image]

IceLib Dialer Technical Reference
ContactListPenetration..::..ContactListPenetrationRate..::..Rate Field
ContactListPenetration..::..ContactListPenetrationRate Structure See Also Send Feedback
The percentage of contact list penetration as defined by the filters passed into the GetPenetrationRate function.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly double Rate
Visual Basic
Public ReadOnly Rate As Double

See Also

ContactListPenetration..::..ContactListPenetrationRate Structure
ContactListPenetration..::..ContactListPenetrationRate Members
ININ.IceLib.Dialer.Supervisor Namespace


ContactListPenetration.ContactListPenetrationRate Methods

[image] [image]

IceLib Dialer Technical Reference
ContactListPenetration..::..ContactListPenetrationRate Methods
ContactListPenetration..::..ContactListPenetrationRate Structure See Also Send Feedback

The ContactListPenetration..::..ContactListPenetrationRate type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

ContactListPenetration..::..ContactListPenetrationRate Structure
ININ.IceLib.Dialer.Supervisor Namespace


ContactListPenetration.ContactListPenetrationUpload Structure

[image]

IceLib Dialer Technical Reference
ContactListPenetration..::..ContactListPenetrationUpload Structure
ContactListPenetration Class Members See Also Send Feedback
This structure gives all of the information necessary to compute the denominator for the penetration rate per upload Id.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public struct ContactListPenetrationUpload
Visual Basic
Public Structure ContactListPenetrationUpload

See Also

ContactListPenetration..::..ContactListPenetrationUpload Members
ININ.IceLib.Dialer.Supervisor Namespace


ContactListPenetration.ContactListPenetrationUpload Members

[image] [image]

IceLib Dialer Technical Reference
ContactListPenetration..::..ContactListPenetrationUpload Members
ContactListPenetration..::..ContactListPenetrationUpload Structure Methods Fields See Also Send Feedback

The ContactListPenetration..::..ContactListPenetrationUpload type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Fields

 | Name | Description
Public field | PenetrationDataCollection | Collection of Penetration Data for the given upload ID.
Public field | UploadDate | The date of the contact list upload.
Public field | UploadId | The Id assigned to a contact list upload.

See Also

ContactListPenetration..::..ContactListPenetrationUpload Structure
ININ.IceLib.Dialer.Supervisor Namespace


ContactListPenetration.ContactListPenetrationUpload Fields

[image] [image]

IceLib Dialer Technical Reference
ContactListPenetration..::..ContactListPenetrationUpload Fields
ContactListPenetration..::..ContactListPenetrationUpload Structure See Also Send Feedback

The ContactListPenetration..::..ContactListPenetrationUpload type exposes the following members.

Fields

 | Name | Description
Public field | PenetrationDataCollection | Collection of Penetration Data for the given upload ID.
Public field | UploadDate | The date of the contact list upload.
Public field | UploadId | The Id assigned to a contact list upload.

See Also

ContactListPenetration..::..ContactListPenetrationUpload Structure
ININ.IceLib.Dialer.Supervisor Namespace


PenetrationDataCollection Field

[image]

IceLib Dialer Technical Reference
ContactListPenetration..::..ContactListPenetrationUpload..::..PenetrationDataCollection Field
ContactListPenetration..::..ContactListPenetrationUpload Structure See Also Send Feedback
Collection of Penetration Data for the given upload ID.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<ContactListPenetration..::..ContactListPenetrationData> PenetrationDataCollection
Visual Basic
Public PenetrationDataCollection As Collection(Of ContactListPenetration..::..ContactListPenetrationData)

See Also

ContactListPenetration..::..ContactListPenetrationUpload Structure
ContactListPenetration..::..ContactListPenetrationUpload Members
ININ.IceLib.Dialer.Supervisor Namespace


UploadDate Field

[image]

IceLib Dialer Technical Reference
ContactListPenetration..::..ContactListPenetrationUpload..::..UploadDate Field
ContactListPenetration..::..ContactListPenetrationUpload Structure See Also Send Feedback
The date of the contact list upload.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly DateTime UploadDate
Visual Basic
Public ReadOnly UploadDate As DateTime

See Also

ContactListPenetration..::..ContactListPenetrationUpload Structure
ContactListPenetration..::..ContactListPenetrationUpload Members
ININ.IceLib.Dialer.Supervisor Namespace


UploadId Field

[image]

IceLib Dialer Technical Reference
ContactListPenetration..::..ContactListPenetrationUpload..::..UploadId Field
ContactListPenetration..::..ContactListPenetrationUpload Structure See Also Send Feedback
The Id assigned to a contact list upload.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public readonly long UploadId
Visual Basic
Public ReadOnly UploadId As Long

See Also

ContactListPenetration..::..ContactListPenetrationUpload Structure
ContactListPenetration..::..ContactListPenetrationUpload Members
ININ.IceLib.Dialer.Supervisor Namespace


ContactListPenetration.ContactListPenetrationUpload Methods

[image] [image]

IceLib Dialer Technical Reference
ContactListPenetration..::..ContactListPenetrationUpload Methods
ContactListPenetration..::..ContactListPenetrationUpload Structure See Also Send Feedback

The ContactListPenetration..::..ContactListPenetrationUpload type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

ContactListPenetration..::..ContactListPenetrationUpload Structure
ININ.IceLib.Dialer.Supervisor Namespace


DialerHealthMonitor Class

[image]

IceLib Dialer Technical Reference
DialerHealthMonitor Class
Members See Also Send Feedback
Provides capabilities to monitor the current status and history of active campaigns and Dialer in general.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class DialerHealthMonitor
Visual Basic
Public Class DialerHealthMonitor

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Dialer.Supervisor..::..DialerHealthMonitor

See Also

DialerHealthMonitor Members
ININ.IceLib.Dialer.Supervisor Namespace


DialerHealthMonitor Members

[image] [image]

IceLib Dialer Technical Reference
DialerHealthMonitor Members
DialerHealthMonitor Class Constructors Methods Properties Events See Also Send Feedback

The DialerHealthMonitor type exposes the following members.

Constructors

 | Name | Description
Public method | DialerHealthMonitor | Initializes a new instance of the DialerHealthMonitor class.

Methods

 | Name | Description
Public method | ClearHistory | Deletes all of a campaign's history messages from the server.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHistory | Retrieves a list of history messages pertaining to a particular campaign.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatchingStatus | Retrieves the list of currently active status messages and begins watching for updates.
Public method | StopWatchingStatus | Stop watching for updates to status messages.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ActiveStatusMessages | The list of currently active status messages.
Public property | Session | Gets the Session used by the DialerHealthMonitor.

Events

 | Name | Description
Public event | StatusMessageReceived | Occurs when a new status message is received or an existing one is updated.

See Also

DialerHealthMonitor Class
ININ.IceLib.Dialer.Supervisor Namespace


DialerHealthMonitor Constructor

[image]

IceLib Dialer Technical Reference
DialerHealthMonitor Constructor
DialerHealthMonitor Class See Also Send Feedback
Initializes a new instance of the DialerHealthMonitor class.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DialerHealthMonitor(
    Session session
)
Visual Basic
Public Sub New ( _
    session As Session _
)

Parameters

session
Type: Session
The Session to be used. The session must already be initialized and connected.

Exceptions

Exception | Condition
System..::..ArgumentNullException | A parameter is a null reference (Nothing in Visual Basic).
IceLibException | The supplied Session is not valid or is not connected.

See Also

DialerHealthMonitor Class
DialerHealthMonitor Members
ININ.IceLib.Dialer.Supervisor Namespace


DialerHealthMonitor Methods

[image] [image]

IceLib Dialer Technical Reference
DialerHealthMonitor Methods
DialerHealthMonitor Class See Also Send Feedback

The DialerHealthMonitor type exposes the following members.

Methods

 | Name | Description
Public method | ClearHistory | Deletes all of a campaign's history messages from the server.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHistory | Retrieves a list of history messages pertaining to a particular campaign.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | StartWatchingStatus | Retrieves the list of currently active status messages and begins watching for updates.
Public method | StopWatchingStatus | Stop watching for updates to status messages.
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DialerHealthMonitor Class
ININ.IceLib.Dialer.Supervisor Namespace


ClearHistory Method

[image]

IceLib Dialer Technical Reference
DialerHealthMonitor..::..ClearHistory Method
DialerHealthMonitor Class See Also Send Feedback
Deletes all of a campaign's history messages from the server.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void ClearHistory(
    ConfigurationId campaignID
)
Visual Basic
Public Sub ClearHistory ( _
    campaignID As ConfigurationId _
)

Parameters

campaignID
Type: ConfigurationId
The ID of the campaign that should have its history cleared. Use None to clear general Dialer history.

See Also

DialerHealthMonitor Class
DialerHealthMonitor Members
ININ.IceLib.Dialer.Supervisor Namespace


GetHistory Method

[image]

IceLib Dialer Technical Reference
DialerHealthMonitor..::..GetHistory Method
DialerHealthMonitor Class See Also Send Feedback
Retrieves a list of history messages pertaining to a particular campaign.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<DialerHistoryMessage> GetHistory(
    ConfigurationId campaign
)
Visual Basic
Public Function GetHistory ( _
    campaign As ConfigurationId _
) As Collection(Of DialerHistoryMessage)

Parameters

campaign
Type: ConfigurationId
The ID of the campaign to retrieve history for. Use None to retrieve general Dialer history.

Return Value

A collection of DialerHistoryMessages.

See Also

DialerHealthMonitor Class
DialerHealthMonitor Members
ININ.IceLib.Dialer.Supervisor Namespace


StartWatchingStatus Method

[image]

IceLib Dialer Technical Reference
DialerHealthMonitor..::..StartWatchingStatus Method
DialerHealthMonitor Class See Also Send Feedback
Retrieves the list of currently active status messages and begins watching for updates.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void StartWatchingStatus()
Visual Basic
Public Sub StartWatchingStatus

See Also

DialerHealthMonitor Class
DialerHealthMonitor Members
ININ.IceLib.Dialer.Supervisor Namespace


StopWatchingStatus Method

[image]

IceLib Dialer Technical Reference
DialerHealthMonitor..::..StopWatchingStatus Method
DialerHealthMonitor Class See Also Send Feedback
Stop watching for updates to status messages.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void StopWatchingStatus()
Visual Basic
Public Sub StopWatchingStatus

See Also

DialerHealthMonitor Class
DialerHealthMonitor Members
ININ.IceLib.Dialer.Supervisor Namespace


DialerHealthMonitor Properties

[image] [image]

IceLib Dialer Technical Reference
DialerHealthMonitor Properties
DialerHealthMonitor Class See Also Send Feedback

The DialerHealthMonitor type exposes the following members.

Properties

 | Name | Description
Public property | ActiveStatusMessages | The list of currently active status messages.
Public property | Session | Gets the Session used by the DialerHealthMonitor.

See Also

DialerHealthMonitor Class
ININ.IceLib.Dialer.Supervisor Namespace


ActiveStatusMessages Property

[image]

IceLib Dialer Technical Reference
DialerHealthMonitor..::..ActiveStatusMessages Property
DialerHealthMonitor Class See Also Send Feedback
The list of currently active status messages.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Collection<DialerStatusMessage> ActiveStatusMessages { get; private set; }
Visual Basic
Public Property ActiveStatusMessages As Collection(Of DialerStatusMessage)
    Get
    Private Set

See Also

DialerHealthMonitor Class
DialerHealthMonitor Members
ININ.IceLib.Dialer.Supervisor Namespace


Session Property

[image]

IceLib Dialer Technical Reference
DialerHealthMonitor..::..Session Property
DialerHealthMonitor Class See Also Send Feedback
Gets the Session used by the DialerHealthMonitor.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Session Session { get; private set; }
Visual Basic
Public Property Session As Session
    Get
    Private Set

Field Value

The session.

See Also

DialerHealthMonitor Class
DialerHealthMonitor Members
ININ.IceLib.Dialer.Supervisor Namespace


DialerHealthMonitor Events

[image] [image]

IceLib Dialer Technical Reference
DialerHealthMonitor Events
DialerHealthMonitor Class See Also Send Feedback

The DialerHealthMonitor type exposes the following members.

Events

 | Name | Description
Public event | StatusMessageReceived | Occurs when a new status message is received or an existing one is updated.

See Also

DialerHealthMonitor Class
ININ.IceLib.Dialer.Supervisor Namespace


StatusMessageReceived Event

[image]

IceLib Dialer Technical Reference
DialerHealthMonitor..::..StatusMessageReceived Event
DialerHealthMonitor Class See Also Send Feedback
Occurs when a new status message is received or an existing one is updated.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public event StatusMessageReceivedEventHandler StatusMessageReceived
Visual Basic
Public Event StatusMessageReceived As StatusMessageReceivedEventHandler

See Also

DialerHealthMonitor Class
DialerHealthMonitor Members
ININ.IceLib.Dialer.Supervisor Namespace


DialerHistoryErrorType Enumeration

[image]

IceLib Dialer Technical Reference
DialerHistoryErrorType Enumeration
See Also Send Feedback
Possible types of errors that may occur.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum DialerHistoryErrorType
Visual Basic
Public Enumeration DialerHistoryErrorType

Members

Member name | Value | Description
None | 1 | Message is not an error, check WarningType or InfoType
CampaignNotFound | 2 | Campaign could not be found in the dialer cache.
CSCommunicationFailed | 3 | Failure to register Dialer site with central campaign server.
MemoryAllocationFailed | 4 | A memory allocation failed while trying to create a new object.
AgentPingFailed | 5 | Agent automatically logged out because the connection between the agent's scripter application and Dialer was lost.
LinegroupNotActive | 6 | Configured linegroup is not active on the server.
CallIdNotFound | 7 | Call ID attribute not present among contact attributes
CampaignIdNotFound | 8 | Campaign ID not found among contact attributes
UnknownException | 9 | An unknown exception occurred
Win32Exception | 10 | A Win32 exception occurred
TranServerNotStarted | 11 | Dialer TranServer failed t ostart
TranServerRestarting | 12 | Dialer TranServer is restarting because of too many hung threads
COMException | 13 | A COM exception occurred
Exception | 14 | An exception occurred
UnknownException2 | 15 | An unknown exception occurred
NotifierError | 16 | A notifier request failed
NoFields | 17 | Insert or update operation was aborted because there was no data to process
InvalidDateFormat | 18 | Data passed in as a date value could not be parsed
ContactListUpdateWarning | 19 | Warnings were generated while processing a database update
WorkgroupNotActive | 20 | The ACD workgroup is not active on the server
TableValidationFailed | 21 | An error occurred while validating a database table
PolicySetLoadFailed | 22 | A policy set could not be loaded by the campaign server.
ContactsLeftQueryFailed | 23 | A query for the number of remaining contacts failed
PolicyMessage | 24 | A policy reported an error
BadConnection | 25 | A connection to the database could not be established
SQLFailed | 26 | A SQL operation failed to complete
BehaviorFailed | 27 | A behavior failed to run properly
EventInterfaceNotFound | 28 | An event interface object was not found in the global interface table.
CreateEvalVisitorFailed | 29 | An error occurred while attempting to evaluate a rule item
WriteXMLFailed | 30 | The campaign server was unable to read/write the xml configuration file.
ClientObjectNotFound | 31 | The campaign server management interface pointer could not be obtained
InvalidObjectId | 32 | An operation failed because the requested object identifier was not found
StatInitFailed | 33 | The campaigin server's request for statistic data failed
TableCommitFailed | 34 | The campaign server was unable to commit table properties to the configuration file.
MaxCSThreadCountReached | 35 | The campaign server has reached the maximum number of threads allowed, typically because all processing threads are hung.
GetRecycleSizeFailed | 36 | Unable to retrieve the number of contacts left in the current recycle
RuleActionMessage | 37 | An error was reported by a rule action
PropertyLoadFailed | 38 | An error occurred while trying to load a property
ActiveStationLookupFailed | 39 | An error occurred while looking up the active station for an agent
TableInitializationFailed | 40 | A database table could not be initialized or validated
StatusMessage | 41 | An error status message was deactivated
MalformedContactListUpdate | 42 | A contact list updated was in an incorrect format
CampaignErrorThresholdExceeded | 43 | A campaign was paused because it exceeded the maximum number of errors
CampaignGetContactColumnsFailed | 44 | A campaign was paused because it could not load the contact columns

See Also

ININ.IceLib.Dialer.Supervisor Namespace


DialerHistoryInformationType Enumeration

[image]

IceLib Dialer Technical Reference
DialerHistoryInformationType Enumeration
See Also Send Feedback
Possible types of informational events that may occur.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum DialerHistoryInformationType
Visual Basic
Public Enumeration DialerHistoryInformationType

Members

Member name | Value | Description
None | 2000 | Message is not an informational entry, check ErrorType or WarningType
CampaignStarted | 2001 | A campaign has started
TranServerStarted | 2002 | Dialer TranServer has started
CampaignAdminPauseLifted | 2003 | A campaign has been manually unpaused
CPUPauseLifted | 2004 | All campaign dialing has resumed because CPU utiliazation dropped below the configured maximum
CampaignStopped | 2005 | A campaign has stopped
ContactListRecycled | 2006 | A contact list has recycled
ForcedPowerModeOff | 2007 | A campaign has exited forced power mode due to the abandon rate dropping below the configured maximum
BlendedPauseLifted | 2008 | A campaign has resumed making predictions due to the number of inbound calls dropping below the configured maximum for the workgroup
CampaignRestarted | 2009 | A campaign has been manually restarted
PolicyMessage | 2010 | A policy reported an informational message
RuleActionMessage | 2011 | A rule action reported an informational message
CreatedCampaignTables | 2012 | One or more database tables were created for a campaign
CampaignRestartRules | 2013 | A campaign was restarted by a rule
CampaignRestartUser | 2014 | A campaign was restarted by a user
CampaignRecycleRules | 2015 | A campaign was recycled by a rule
CampaignRecycleUser | 2016 | A campaign was recycled by a user
StatusMessage | 2017 | An informational status message was deactivated
ActiveGroupChanged | 2018 | The active group changed in a rule set. The group that has become active is reported.
AgentActiveGroupChanged | 2019 | The active group changed in a rule set. The group that has become active is reported.
CampaignGroupTransitioned | 2020 | The campaign has transitioned to the next campaign group.
CampaignCompleted | 2021 | A campaign has completed

See Also

ININ.IceLib.Dialer.Supervisor Namespace


DialerHistoryMessage Class

[image]

IceLib Dialer Technical Reference
DialerHistoryMessage Class
Members See Also Send Feedback
A brief summary of an event that occurred within some Dialer-related process.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class DialerHistoryMessage
Visual Basic
Public Class DialerHistoryMessage

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Dialer.Supervisor..::..DialerHistoryMessage

See Also

DialerHistoryMessage Members
ININ.IceLib.Dialer.Supervisor Namespace


DialerHistoryMessage Members

[image] [image]

IceLib Dialer Technical Reference
DialerHistoryMessage Members
DialerHistoryMessage Class Methods Properties See Also Send Feedback

The DialerHistoryMessage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Agent | The agent that this message applies to.
Public property | Campaign | The Id of the campaign this message applies to.
Public property | Content | The textual content of the message.
Public property | ErrorType | THe type of error-level event, or None if it is not an error-level event.
Public property | Footer | Optional additional information.
Public property | InfoType | The type of information-level event, or None if it is not an information-level event.
Public property | MessageTime | The time that this message was generated.
Public property | ProcessName | The name of the process that this message originated from.
Public property | Severity | The severity level of this message.
Public property | Site | The site that this message originated from.
Public property | Title | A brief summary of the message contents.
Public property | WarningType | The type of warning-level event, or None if it is not a warning-level event.

See Also

DialerHistoryMessage Class
ININ.IceLib.Dialer.Supervisor Namespace


DialerHistoryMessage Methods

[image] [image]

IceLib Dialer Technical Reference
DialerHistoryMessage Methods
DialerHistoryMessage Class See Also Send Feedback

The DialerHistoryMessage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DialerHistoryMessage Class
ININ.IceLib.Dialer.Supervisor Namespace


DialerHistoryMessage Properties

[image] [image]

IceLib Dialer Technical Reference
DialerHistoryMessage Properties
DialerHistoryMessage Class See Also Send Feedback

The DialerHistoryMessage type exposes the following members.

Properties

 | Name | Description
Public property | Agent | The agent that this message applies to.
Public property | Campaign | The Id of the campaign this message applies to.
Public property | Content | The textual content of the message.
Public property | ErrorType | THe type of error-level event, or None if it is not an error-level event.
Public property | Footer | Optional additional information.
Public property | InfoType | The type of information-level event, or None if it is not an information-level event.
Public property | MessageTime | The time that this message was generated.
Public property | ProcessName | The name of the process that this message originated from.
Public property | Severity | The severity level of this message.
Public property | Site | The site that this message originated from.
Public property | Title | A brief summary of the message contents.
Public property | WarningType | The type of warning-level event, or None if it is not a warning-level event.

See Also

DialerHistoryMessage Class
ININ.IceLib.Dialer.Supervisor Namespace


Agent Property

[image]

IceLib Dialer Technical Reference
DialerHistoryMessage..::..Agent Property
DialerHistoryMessage Class See Also Send Feedback
The agent that this message applies to.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Agent { get; private set; }
Visual Basic
Public Property Agent As String
    Get
    Private Set

See Also

DialerHistoryMessage Class
DialerHistoryMessage Members
ININ.IceLib.Dialer.Supervisor Namespace


Campaign Property

[image]

IceLib Dialer Technical Reference
DialerHistoryMessage..::..Campaign Property
DialerHistoryMessage Class See Also Send Feedback
The Id of the campaign this message applies to.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ConfigurationId Campaign { get; private set; }
Visual Basic
Public Property Campaign As ConfigurationId
    Get
    Private Set

See Also

DialerHistoryMessage Class
DialerHistoryMessage Members
ININ.IceLib.Dialer.Supervisor Namespace


Content Property

[image]

IceLib Dialer Technical Reference
DialerHistoryMessage..::..Content Property
DialerHistoryMessage Class See Also Send Feedback
The textual content of the message.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Content { get; private set; }
Visual Basic
Public Property Content As String
    Get
    Private Set

See Also

DialerHistoryMessage Class
DialerHistoryMessage Members
ININ.IceLib.Dialer.Supervisor Namespace


ErrorType Property

[image]

IceLib Dialer Technical Reference
DialerHistoryMessage..::..ErrorType Property
DialerHistoryMessage Class See Also Send Feedback
THe type of error-level event, or None if it is not an error-level event.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DialerHistoryErrorType ErrorType { get; private set; }
Visual Basic
Public Property ErrorType As DialerHistoryErrorType
    Get
    Private Set

See Also

DialerHistoryMessage Class
DialerHistoryMessage Members
ININ.IceLib.Dialer.Supervisor Namespace


Footer Property

[image]

IceLib Dialer Technical Reference
DialerHistoryMessage..::..Footer Property
DialerHistoryMessage Class See Also Send Feedback
Optional additional information.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Footer { get; private set; }
Visual Basic
Public Property Footer As String
    Get
    Private Set

See Also

DialerHistoryMessage Class
DialerHistoryMessage Members
ININ.IceLib.Dialer.Supervisor Namespace


InfoType Property

[image]

IceLib Dialer Technical Reference
DialerHistoryMessage..::..InfoType Property
DialerHistoryMessage Class See Also Send Feedback
The type of information-level event, or None if it is not an information-level event.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DialerHistoryInformationType InfoType { get; private set; }
Visual Basic
Public Property InfoType As DialerHistoryInformationType
    Get
    Private Set

See Also

DialerHistoryMessage Class
DialerHistoryMessage Members
ININ.IceLib.Dialer.Supervisor Namespace


MessageTime Property

[image]

IceLib Dialer Technical Reference
DialerHistoryMessage..::..MessageTime Property
DialerHistoryMessage Class See Also Send Feedback
The time that this message was generated.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DateTime MessageTime { get; private set; }
Visual Basic
Public Property MessageTime As DateTime
    Get
    Private Set

See Also

DialerHistoryMessage Class
DialerHistoryMessage Members
ININ.IceLib.Dialer.Supervisor Namespace


ProcessName Property

[image]

IceLib Dialer Technical Reference
DialerHistoryMessage..::..ProcessName Property
DialerHistoryMessage Class See Also Send Feedback
The name of the process that this message originated from.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string ProcessName { get; private set; }
Visual Basic
Public Property ProcessName As String
    Get
    Private Set

See Also

DialerHistoryMessage Class
DialerHistoryMessage Members
ININ.IceLib.Dialer.Supervisor Namespace


Severity Property

[image]

IceLib Dialer Technical Reference
DialerHistoryMessage..::..Severity Property
DialerHistoryMessage Class See Also Send Feedback
The severity level of this message.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DialerHistoryMessageSeverity Severity { get; private set; }
Visual Basic
Public Property Severity As DialerHistoryMessageSeverity
    Get
    Private Set

See Also

DialerHistoryMessage Class
DialerHistoryMessage Members
ININ.IceLib.Dialer.Supervisor Namespace


Site Property

[image]

IceLib Dialer Technical Reference
DialerHistoryMessage..::..Site Property
DialerHistoryMessage Class See Also Send Feedback
The site that this message originated from.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Site { get; private set; }
Visual Basic
Public Property Site As String
    Get
    Private Set

See Also

DialerHistoryMessage Class
DialerHistoryMessage Members
ININ.IceLib.Dialer.Supervisor Namespace


Title Property

[image]

IceLib Dialer Technical Reference
DialerHistoryMessage..::..Title Property
DialerHistoryMessage Class See Also Send Feedback
A brief summary of the message contents.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Title { get; private set; }
Visual Basic
Public Property Title As String
    Get
    Private Set

See Also

DialerHistoryMessage Class
DialerHistoryMessage Members
ININ.IceLib.Dialer.Supervisor Namespace


WarningType Property

[image]

IceLib Dialer Technical Reference
DialerHistoryMessage..::..WarningType Property
DialerHistoryMessage Class See Also Send Feedback
The type of warning-level event, or None if it is not a warning-level event.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DialerHistoryWarningType WarningType { get; private set; }
Visual Basic
Public Property WarningType As DialerHistoryWarningType
    Get
    Private Set

See Also

DialerHistoryMessage Class
DialerHistoryMessage Members
ININ.IceLib.Dialer.Supervisor Namespace


DialerHistoryMessageSeverity Enumeration

[image]

IceLib Dialer Technical Reference
DialerHistoryMessageSeverity Enumeration
See Also Send Feedback
Possible levels of severity for a message.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum DialerHistoryMessageSeverity
Visual Basic
Public Enumeration DialerHistoryMessageSeverity

Members

Member name | Value | Description
Unknown | 0 | An invalid level of severity
Error | 1 | Error-level severity
Warning | 2 | Warning-level severity
Information | 4 | Information-level severity.

See Also

ININ.IceLib.Dialer.Supervisor Namespace


DialerHistoryWarningType Enumeration

[image]

IceLib Dialer Technical Reference
DialerHistoryWarningType Enumeration
See Also Send Feedback
Possible types of warnings that may occur.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum DialerHistoryWarningType
Visual Basic
Public Enumeration DialerHistoryWarningType

Members

Member name | Value | Description
None | 1000 | Message is not an warning, check ErrorType or InfoType
InboundStatMonitorFailed | 1001 | An error occurred while attempting to enable workgroup period stats
AgentNotLoggedIn | 1002 | A requested action was ignored because the associated agent is not logged into the campaign
AgentNotActive | 1003 | A requested action was ignored because the associated agent is not active in the campaign
CampaignAdminPause | 1004 | A campaign has been manually paused
InteractionNotFound | 1005 | An interaction could not be found in the dialer cache
BadScheduledDate | 1006 | The scheduled date passed in from the script was invalid
AmbiguousCall | 1007 | A call was placed and routed to an agent, but not completed
CampaignNotOn | 1008 | The campaign will not be started because it is not configured as active.
NoPhoneNumber | 1009 | A contact does not have a callable phone number
NoLinesAvailable | 1010 | No lines available in the linegroup
CPUPause | 1011 | All campaigns are paused until CPU utilization drops below the configured point
AgentNotFound | 1012 | An agent could not be found in the dialer cache
CampaignCompleted | 1013 | A campaign has stopped because it has completed the maximum number of recycles
ForcedPowerModeOn | 1014 | A campaign has entered forced power dialing mode because its abandon rate exceeded the maximum rate.
BlendedPause | 1015 | Predicitions made for a campaign are paused because the number of inbound calls is greater than the configured maximum for the workgroup.
PolicyMessage | 1016 | A policy reported a warning
RuleActionMessage | 1017 | A rule action reported a warning
DispositionIgnored | 1018 | An agent attempted to disposition an interaction that he/she does not own.
PaceAdjustedManually | 1019 | A campaign's pace was manually adjusted
AgentAvailableNoDisposition | 1020 | An agent changed to an available status prior to call disposition
StatusMessage | 1021 | A warning status message was deactivated
DialingCompliance | 1022 | Calling compliance warning reported

See Also

ININ.IceLib.Dialer.Supervisor Namespace


DialerStatusMessage Class

[image]

IceLib Dialer Technical Reference
DialerStatusMessage Class
Members See Also Send Feedback
A brief diagnostic summary of Dialer-related processes that can be useful for troubleshooting issues.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class DialerStatusMessage
Visual Basic
Public Class DialerStatusMessage

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Dialer.Supervisor..::..DialerStatusMessage

See Also

DialerStatusMessage Members
ININ.IceLib.Dialer.Supervisor Namespace


DialerStatusMessage Members

[image] [image]

IceLib Dialer Technical Reference
DialerStatusMessage Members
DialerStatusMessage Class Methods Properties See Also Send Feedback

The DialerStatusMessage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Campaign | The Id of the campaign this message applies to.
Public property | Content | The textual content of the message.
Public property | CreatedTime | The time that this status message was originally generated.
Public property | LastModifiedTime | The last time the status of diagnostic inFormation in this message was updated.
Public property | MachineName | The name of the computer that generated the message.
Public property | MessageType | The type of status message.
Public property | ProcessName | The name of the process that generated the message.
Public property | Severity | The level of seriousness of this status message.
Public property | Title | A brief summary of the message contents.

See Also

DialerStatusMessage Class
ININ.IceLib.Dialer.Supervisor Namespace


DialerStatusMessage Methods

[image] [image]

IceLib Dialer Technical Reference
DialerStatusMessage Methods
DialerStatusMessage Class See Also Send Feedback

The DialerStatusMessage type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DialerStatusMessage Class
ININ.IceLib.Dialer.Supervisor Namespace


DialerStatusMessage Properties

[image] [image]

IceLib Dialer Technical Reference
DialerStatusMessage Properties
DialerStatusMessage Class See Also Send Feedback

The DialerStatusMessage type exposes the following members.

Properties

 | Name | Description
Public property | Campaign | The Id of the campaign this message applies to.
Public property | Content | The textual content of the message.
Public property | CreatedTime | The time that this status message was originally generated.
Public property | LastModifiedTime | The last time the status of diagnostic inFormation in this message was updated.
Public property | MachineName | The name of the computer that generated the message.
Public property | MessageType | The type of status message.
Public property | ProcessName | The name of the process that generated the message.
Public property | Severity | The level of seriousness of this status message.
Public property | Title | A brief summary of the message contents.

See Also

DialerStatusMessage Class
ININ.IceLib.Dialer.Supervisor Namespace


Campaign Property

[image]

IceLib Dialer Technical Reference
DialerStatusMessage..::..Campaign Property
DialerStatusMessage Class See Also Send Feedback
The Id of the campaign this message applies to.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public ConfigurationId Campaign { get; private set; }
Visual Basic
Public Property Campaign As ConfigurationId
    Get
    Private Set

See Also

DialerStatusMessage Class
DialerStatusMessage Members
ININ.IceLib.Dialer.Supervisor Namespace


Content Property

[image]

IceLib Dialer Technical Reference
DialerStatusMessage..::..Content Property
DialerStatusMessage Class See Also Send Feedback
The textual content of the message.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Content { get; private set; }
Visual Basic
Public Property Content As String
    Get
    Private Set

See Also

DialerStatusMessage Class
DialerStatusMessage Members
ININ.IceLib.Dialer.Supervisor Namespace


CreatedTime Property

[image]

IceLib Dialer Technical Reference
DialerStatusMessage..::..CreatedTime Property
DialerStatusMessage Class See Also Send Feedback
The time that this status message was originally generated.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DateTime CreatedTime { get; private set; }
Visual Basic
Public Property CreatedTime As DateTime
    Get
    Private Set

See Also

DialerStatusMessage Class
DialerStatusMessage Members
ININ.IceLib.Dialer.Supervisor Namespace


LastModifiedTime Property

[image]

IceLib Dialer Technical Reference
DialerStatusMessage..::..LastModifiedTime Property
DialerStatusMessage Class See Also Send Feedback
The last time the status of diagnostic inFormation in this message was updated.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DateTime LastModifiedTime { get; private set; }
Visual Basic
Public Property LastModifiedTime As DateTime
    Get
    Private Set

See Also

DialerStatusMessage Class
DialerStatusMessage Members
ININ.IceLib.Dialer.Supervisor Namespace


MachineName Property

[image]

IceLib Dialer Technical Reference
DialerStatusMessage..::..MachineName Property
DialerStatusMessage Class See Also Send Feedback
The name of the computer that generated the message.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string MachineName { get; private set; }
Visual Basic
Public Property MachineName As String
    Get
    Private Set

See Also

DialerStatusMessage Class
DialerStatusMessage Members
ININ.IceLib.Dialer.Supervisor Namespace


MessageType Property

[image]

IceLib Dialer Technical Reference
DialerStatusMessage..::..MessageType Property
DialerStatusMessage Class See Also Send Feedback
The type of status message.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DialerStatusMessageType MessageType { get; private set; }
Visual Basic
Public Property MessageType As DialerStatusMessageType
    Get
    Private Set

See Also

DialerStatusMessage Class
DialerStatusMessage Members
ININ.IceLib.Dialer.Supervisor Namespace


ProcessName Property

[image]

IceLib Dialer Technical Reference
DialerStatusMessage..::..ProcessName Property
DialerStatusMessage Class See Also Send Feedback
The name of the process that generated the message.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string ProcessName { get; private set; }
Visual Basic
Public Property ProcessName As String
    Get
    Private Set

See Also

DialerStatusMessage Class
DialerStatusMessage Members
ININ.IceLib.Dialer.Supervisor Namespace


Severity Property

[image]

IceLib Dialer Technical Reference
DialerStatusMessage..::..Severity Property
DialerStatusMessage Class See Also Send Feedback
The level of seriousness of this status message.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DialerStatusMessageSeverity Severity { get; private set; }
Visual Basic
Public Property Severity As DialerStatusMessageSeverity
    Get
    Private Set

See Also

DialerStatusMessage Class
DialerStatusMessage Members
ININ.IceLib.Dialer.Supervisor Namespace


Title Property

[image]

IceLib Dialer Technical Reference
DialerStatusMessage..::..Title Property
DialerStatusMessage Class See Also Send Feedback
A brief summary of the message contents.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public string Title { get; private set; }
Visual Basic
Public Property Title As String
    Get
    Private Set

See Also

DialerStatusMessage Class
DialerStatusMessage Members
ININ.IceLib.Dialer.Supervisor Namespace


DialerStatusMessageSeverity Enumeration

[image]

IceLib Dialer Technical Reference
DialerStatusMessageSeverity Enumeration
See Also Send Feedback
The level of seriousness of a status message.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum DialerStatusMessageSeverity
Visual Basic
Public Enumeration DialerStatusMessageSeverity

Members

Member name | Value | Description
Unknown | 0 | An unknown level of severity
Information | 1 | Information-level severity
Warning | 2 | Warning-level severity
Error | 3 | Error-level severity

See Also

ININ.IceLib.Dialer.Supervisor Namespace


DialerStatusMessageType Enumeration

[image]

IceLib Dialer Technical Reference
DialerStatusMessageType Enumeration
See Also Send Feedback
Possible types of status messages.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum DialerStatusMessageType
Visual Basic
Public Enumeration DialerStatusMessageType

Members

Member name | Value | Description
None | 14500 | Invalid status message type.
InvalidLinegroup | 14501 | Configured linegroup is invalid or contains no lines.
InvalidWorkgroup | 14502 | Configured workgroup is invalid or contains no agents.
FewAgentsForPredictive | 14503 | Campaign has fewer than six active agents, potentially decreasing agent utilization and increasing abandon rate.
CampaignAbandonRateExceeded | 14504 | Current abandonment rate exceeds the configured target rate
ContactCacheEmpty | 14505 | Contact cache has been depleted
CampaignRetrievingContacts | 14506 | Contact cache has been depleted
CampaignAllZonesBlocked | 14507 | Configured Zone Set is blocked all callable contacts
GlobalMaxCallsReached | 14508 | Dialing is being restricted because the configured line capacity has been reached
GlobalHistoryInsertsSlow | 14509 | History updates (campaign stats, agent stats, call history) are accumulating in queue
GlobalContactListUpdatesSlow | 14510 | Contact list updates are accumulating in queue
CampaignStrictAbandonRateExceeded | 14511 | Current abandonment rate exceeds the configured strict abandonment rate
DialerTranSlowToRespond | 14512 | Dialer TranServer is not responding
CampaignFilterSizeEmpty | 14513 | No callable contacts left
HistoryDelayed | 14514 | History updates (campaign stats, agent stats, call history) are accumulating in queue
CallListDelayed | 14515 | Contact list updates are accumulating in queue
IncorrectProvider | 14516 | The database provider in use is not recommended for use with Dialer
IncorrectCollation | 14517 | Default database is not specified or UDL file is not compatible with Dialer.
NoInitialCatalog | 14518 | Default database is not specified or the UDL file is invalid.
TSDown | 14519 | Campaign is paused because TS API calls are failing, likely due to TS Server not running.
DNCScrubFailing | 14520 | DNC scrubbing failed
InvalidContactColumnBehavior | 14521 | Policy set contains one or more behaviors referencing contact columns not used by the campaign
NoAgentSkills | 14522 | Agent has none of the required skills for the campaign, so no calls will be placed for the agent.
TimezoneMappingUnavailable | 14523 | Automatic time zone mapping is unavailable because the time zone source data could not be initialized.
NoDialPlanData | 14524 | Automatic time zone mapping source data file is not accessible because no CCS dialplan is available for phone number standardization.
MapDataSetFileUnavailable | 14525 | Automatic time zone mapping source data file is not accessible because the map data set file is missing.
NoTimezoneMappings | 14526 | Automatic time zone mapping is unavailable for all campaigns because mo automatic time zone mappings are present.
NoTimezoneMapDataSets | 14527 | Automatic time zone mapping is unavailable because no time zone map data sets are configured for automatic time zone mapping.
AgentTSFailure | 14528 | An agent has been placed on break because a TS API call failed.
HighNonDialerReservation | 14529 | A campaign is reserving a high percentage of active agents for non-Dialer calls.
RecycleInProgress | 14530 | A campaign is recycling its contact list.
NoPersistentConnectionWavFile | 14531 | An agent logged into a campaign with a persistent connection, but no persistent connection wav file is configured.
MaxDialerCallRateReached | 14532 | Dialing is being restricted by the configured maximum call rate setting.
DialerConfigLoadError | 14533 | A problem occurred while attemptingn to load the configuration XML file.
DispositionCustomSprocsSlow | 14534 | Calls to the custom stored procedure that runs when a call is completed are backing up.
CampaignMaxLinesReached | 14535 | A campaign has reached its max lines limit.
NoAgentProficiency | 14536 | The agent has skills that do not meet the minimum proficiency requirements defined for SkillSet.
EmailFailure | 14537 | Something went wrong attempting to send an email via a Campaign Policy Behavior.
SmsFailure | 14538 | Something went wrong attempting to send an sms via a Campaign Policy Behavior.

See Also

ININ.IceLib.Dialer.Supervisor Namespace


DialerStatusMessageUpdateType Enumeration

[image]

IceLib Dialer Technical Reference
DialerStatusMessageUpdateType Enumeration
See Also Send Feedback
Possible types of updates that a status message may undergo.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public enum DialerStatusMessageUpdateType
Visual Basic
Public Enumeration DialerStatusMessageUpdateType

Members

Member name | Value | Description
Unknown | 0 | Unknown update type
Add | 1 | Indicates a newly activated status message
Update | 2 | Indicates an update to a currently activated status message
Remove | 3 | Indicates that a status message was deactivated

See Also

ININ.IceLib.Dialer.Supervisor Namespace


RuleManager Class

[image]

IceLib Dialer Technical Reference
RuleManager Class
Members See Also Send Feedback
A class that exposes methods that can be applied directly to rules.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public class RuleManager
Visual Basic
Public Class RuleManager

Inheritance Hierarchy

System..::..Object
ININ.IceLib.Dialer.Supervisor..::..RuleManager

See Also

RuleManager Members
ININ.IceLib.Dialer.Supervisor Namespace


RuleManager Members

[image] [image]

IceLib Dialer Technical Reference
RuleManager Members
RuleManager Class Constructors Methods Properties See Also Send Feedback

The RuleManager type exposes the following members.

Constructors

 | Name | Description
Public method | RuleManager | constructs an instance of the Rule Manager class

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FireRule | Execute a given rule immediatly.
Public method | FireRuleAsync | Asynchronously request that a rule fires.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Session | Gets the Session used by the RuleManager.

See Also

RuleManager Class
ININ.IceLib.Dialer.Supervisor Namespace


RuleManager Constructor

[image]

IceLib Dialer Technical Reference
RuleManager Constructor
RuleManager Class See Also Send Feedback
constructs an instance of the Rule Manager class

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public RuleManager(
    Session session
)
Visual Basic
Public Sub New ( _
    session As Session _
)

Parameters

session
Type: Session

See Also

RuleManager Class
RuleManager Members
ININ.IceLib.Dialer.Supervisor Namespace


RuleManager Methods

[image] [image]

IceLib Dialer Technical Reference
RuleManager Methods
RuleManager Class See Also Send Feedback

The RuleManager type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | FireRule | Execute a given rule immediatly.
Public method | FireRuleAsync | Asynchronously request that a rule fires.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RuleManager Class
ININ.IceLib.Dialer.Supervisor Namespace


FireRule Method

[image]

IceLib Dialer Technical Reference
RuleManager..::..FireRule Method
RuleManager Class See Also Send Feedback
Execute a given rule immediatly.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void FireRule(
    Rule rule,
    CampaignConfiguration campaign
)
Visual Basic
Public Sub FireRule ( _
    rule As Rule, _
    campaign As CampaignConfiguration _
)

Parameters

rule
Type: ININ.IceLib.Configuration.Dialer..::..Rule
campaign
Type: ININ.IceLib.Configuration.Dialer..::..CampaignConfiguration

See Also

RuleManager Class
RuleManager Members
ININ.IceLib.Dialer.Supervisor Namespace


FireRuleAsync Method

[image]

IceLib Dialer Technical Reference
RuleManager..::..FireRuleAsync Method
RuleManager Class See Also Send Feedback
Asynchronously request that a rule fires.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public void FireRuleAsync(
    Rule rule,
    CampaignConfiguration campaign,
    EventHandler<AsyncCompletedEventArgs> callback,
    Object userState
)
Visual Basic
Public Sub FireRuleAsync ( _
    rule As Rule, _
    campaign As CampaignConfiguration, _
    callback As EventHandler(Of AsyncCompletedEventArgs), _
    userState As Object _
)

Parameters

rule
Type: ININ.IceLib.Configuration.Dialer..::..Rule
campaign
Type: ININ.IceLib.Configuration.Dialer..::..CampaignConfiguration
callback
Type: System..::..EventHandler<(Of <(<'AsyncCompletedEventArgs>)>)>
userState
Type: System..::..Object

See Also

RuleManager Class
RuleManager Members
ININ.IceLib.Dialer.Supervisor Namespace


RuleManager Properties

[image] [image]

IceLib Dialer Technical Reference
RuleManager Properties
RuleManager Class See Also Send Feedback

The RuleManager type exposes the following members.

Properties

 | Name | Description
Public property | Session | Gets the Session used by the RuleManager.

See Also

RuleManager Class
ININ.IceLib.Dialer.Supervisor Namespace


Session Property

[image]

IceLib Dialer Technical Reference
RuleManager..::..Session Property
RuleManager Class See Also Send Feedback
Gets the Session used by the RuleManager.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public Session Session { get; private set; }
Visual Basic
Public Property Session As Session
    Get
    Private Set

Field Value

The session.

See Also

RuleManager Class
RuleManager Members
ININ.IceLib.Dialer.Supervisor Namespace


StatusMessageReceivedEventArgs Class

[image]

IceLib Dialer Technical Reference
StatusMessageReceivedEventArgs Class
Members See Also Send Feedback
Provides data for the StatusMessageReceived event of the DialerHealthMonitor class.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public sealed class StatusMessageReceivedEventArgs : EventArgs
Visual Basic
Public NotInheritable Class StatusMessageReceivedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::..Object
System..::..EventArgs
ININ.IceLib.Dialer.Supervisor..::..StatusMessageReceivedEventArgs

See Also

StatusMessageReceivedEventArgs Members
ININ.IceLib.Dialer.Supervisor Namespace


StatusMessageReceivedEventArgs Members

[image] [image]

IceLib Dialer Technical Reference
StatusMessageReceivedEventArgs Members
StatusMessageReceivedEventArgs Class Methods Properties See Also Send Feedback

The StatusMessageReceivedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

 | Name | Description
Public property | Message | A new status message or an updated version of an existing message.
Public property | UpdateType | The type of update.

See Also

StatusMessageReceivedEventArgs Class
ININ.IceLib.Dialer.Supervisor Namespace


StatusMessageReceivedEventArgs Methods

[image] [image]

IceLib Dialer Technical Reference
StatusMessageReceivedEventArgs Methods
StatusMessageReceivedEventArgs Class See Also Send Feedback

The StatusMessageReceivedEventArgs type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

StatusMessageReceivedEventArgs Class
ININ.IceLib.Dialer.Supervisor Namespace


StatusMessageReceivedEventArgs Properties

[image] [image]

IceLib Dialer Technical Reference
StatusMessageReceivedEventArgs Properties
StatusMessageReceivedEventArgs Class See Also Send Feedback

The StatusMessageReceivedEventArgs type exposes the following members.

Properties

 | Name | Description
Public property | Message | A new status message or an updated version of an existing message.
Public property | UpdateType | The type of update.

See Also

StatusMessageReceivedEventArgs Class
ININ.IceLib.Dialer.Supervisor Namespace


Message Property

[image]

IceLib Dialer Technical Reference
StatusMessageReceivedEventArgs..::..Message Property
StatusMessageReceivedEventArgs Class See Also Send Feedback
A new status message or an updated version of an existing message.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DialerStatusMessage Message { get; private set; }
Visual Basic
Public Property Message As DialerStatusMessage
    Get
    Private Set

See Also

StatusMessageReceivedEventArgs Class
StatusMessageReceivedEventArgs Members
ININ.IceLib.Dialer.Supervisor Namespace


UpdateType Property

[image]

IceLib Dialer Technical Reference
StatusMessageReceivedEventArgs..::..UpdateType Property
StatusMessageReceivedEventArgs Class See Also Send Feedback
The type of update.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public DialerStatusMessageUpdateType UpdateType { get; private set; }
Visual Basic
Public Property UpdateType As DialerStatusMessageUpdateType
    Get
    Private Set

See Also

StatusMessageReceivedEventArgs Class
StatusMessageReceivedEventArgs Members
ININ.IceLib.Dialer.Supervisor Namespace


StatusMessageReceivedEventHandler Delegate

[image]

IceLib Dialer Technical Reference
StatusMessageReceivedEventHandler Delegate
See Also Send Feedback
Handles a StatusMessageReceived event.

Namespace: ININ.IceLib.Dialer.Supervisor
Assembly: ININ.IceLib.Dialer (in ININ.IceLib.Dialer.dll) Version: 0.0.0.0 (22.3.0.208)

Syntax

C#
public delegate void StatusMessageReceivedEventHandler(
    Object sender,
    StatusMessageReceivedEventArgs e
)
Visual Basic
Public Delegate Sub StatusMessageReceivedEventHandler ( _
    sender As Object, _
    e As StatusMessageReceivedEventArgs _
)

Parameters

sender
Type: System..::..Object
e
Type: ININ.IceLib.Dialer.Supervisor..::..StatusMessageReceivedEventArgs

See Also

ININ.IceLib.Dialer.Supervisor Namespace