
 

  

 
  

  

  

  

Archive and Restore Tools 
Printable Help 

 

Version 10.0 

  

Last updated December 19, 2018 

  

  

  

Abstract 
This document is a printable version of the Archive Configuration Tool, Archive Tool, and Restore Tool 

help. 

For copyright and trademark information, see 
https://help.genesys.com/latitude/10/desktop/Copyright_and_Trademark_Information.htm. 

https://help.genesys.com/latitude/10/desktop/Copyright_and_Trademark_Information.htm


Archive and Restore Tools Printable Help 

ii 

Table of Contents 
Introduction to the Archive Configuration, Archive, and Restore Tools ...................................................... 3 

Archive and restore permissions .............................................................................................................. 3 

Help Overview ............................................................................................................................................... 3 

Search feature ........................................................................................................................................... 4 

Search syntax ........................................................................................................................................ 4 

Wildcard expressions ............................................................................................................................ 4 

Boolean operators ................................................................................................................................ 5 

Nested expressions ............................................................................................................................... 5 

Archive Configuration Tool ........................................................................................................................... 6 

Archive Configuration Tool ....................................................................................................................... 6 

Log on to the Archive Configuration Tool ................................................................................................. 6 

Specify Configuration for Archiving Account Data.................................................................................... 7 

Import Table Definitions ........................................................................................................................... 8 

Synchronize the Archive Schema .............................................................................................................. 9 

Export Table Definitions .......................................................................................................................... 10 

View Archive History ............................................................................................................................... 10 

Archive Tool ................................................................................................................................................ 11 

Archive Tool ............................................................................................................................................ 11 

Log on to the Archive Tool ...................................................................................................................... 11 

Select Accounts to Archive...................................................................................................................... 12 

Archive Account Data .............................................................................................................................. 14 

View Archived Data ................................................................................................................................. 16 

Restore Tool ................................................................................................................................................ 16 

Restore Tool ............................................................................................................................................ 16 

Log on to the Restore Tool ...................................................................................................................... 16 

Select Accounts to Restore ..................................................................................................................... 17 

Restore Archived Account Data .............................................................................................................. 19 



Archive and Restore Tools Printable Help 

3 

Introduction to the Archive Configuration, Archive, and Restore Tools 
The Archive Configuration Tool allows you to configure the system for archiving account data. 
Configuration includes specifying the archive server, archive database, and which tables a user can 
archive, view, and purge. Configure the system before attempting to archive or restore account data. 

The Archive Tool allows you to archive account data to increase performance in your production 
database by removing most of the data for older, returned accounts.  Archiving moves most account 
data from your Latitude database to an archive database that you or a Latitude by Genesys 
representative created. The system doesn't archive all data it uses some data to open the account in the 
Work Form and some data for financial accounting. 

You can view the archived data in the Archive Panel in the Work Form in Latitude. For more information 
about the Archive Panel, see "View Archived Data" in the Latitude documentation. 

We recommend that you store the archive database on a different server than your Latitude database to 
increase performance on the production server. Since the archived data is rarely used, you can store it 
on a server with lower performance requirements, which can result in lowered data storage costs. If 
your company uses more than one production database, set up a separate archive database for each 
production database.  

The Restore Tool allows you to restore archived account data. Restoring moves account data from the 
archive database to your Latitude database. Once you restore account data, you can view it as you 
normally would in the Work Form in Latitude. 

Archive and restore permissions 

The system requires the following permissions to allow you to archive and restore account data: 

• Access Archive/Restore Functionality 

• Enable Archive of Account Data 

For more information about these permissions, see "Archive Permissions and Policies" in the Latitude 
documentation. 

Help Overview 
Archive Configuration, Archive, and Restore Tools help provides you with information for using the 
Archive Configuration, Archive, and Restore Tools. To locate and view a topic, use the table of contents, 
index, and search features. 

To open help 

Open the "\\Program Files (x86)\Latitude Software\Documents" folder and then double-click 
ArchiveAndRestore.chm. 

Tip: To adjust the width and height of the window or its panes, click the edge of the window or pane 
and drag it up or down, left or right. 

1. Toolbar: Allows you to hide or show tabs and the Navigation pane, move forward and backward 
through topics, and print the currently displayed topic.  

2. Tabs: Displays the following: 
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Contents: Displays the table of contents. To display a topic in the Content pane, expand a book 
and then click the link. 

Index: Displays the index. To display a topic in the Content pane, type a keyword or phrase in the 
box (or scroll through the list) and then click the link in the list. 

Search: Displays the search feature. To display a topic in the Content pane, type a keyword or 
phrase in the box and then press Enter. In the search results, click the link. 

Glossary: If available, displays a list of terms and their definitions. To display a definition, click the 
term. 

3. Breadcrumbs: Displays your current location within the help system. When you click a 
breadcrumb, the related topic displays. 

4. Content toolbar: Displays an option to send feedback through an email message to Latitude by 
Genesys Documentation. 

5. Content pane: Displays the contents of a topic. To view the Content pane menu, right-click in 
the Content pane. 

Search feature 

You can use the search feature to search for topics that contain words or phrases that you specify. You 
formulate a search query following a specific set of rules. You can include wildcard expressions, Boolean 
operators, and nested expressions in your search query. A list of topics that match your search criteria 
appear in the search results. When you click a topic title in the search results, the content of that topic 
appears in the Content pane. 

Search syntax 

The basic rules for formulating search queries are: 

• Searches are not case-sensitive, meaning you can type uppercase or lowercase characters. 

• You cannot search for a single character or the following reserved words: an, and, as, at, be, but, 
by, do, for, from, have, he, in, it, not, of, on, or, she, that, the, there, they, this, to, we, which, 
with, you. 

• The search engine ignores punctuation marks and special characters such as @#$%^&()=+[]\. 

• Enclose phrases and terms that include a period (such as a file name with an extension) in 
double quotation marks. 

Wildcard expressions 

Wildcard expressions allow you to search for one or more characters using a question mark or asterisk. 
A question mark represents a single character, while an asterisk represents one or more characters. 
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Search for... Example Result 

Topics with text that starts with one or 
more specified characters and ends in 
any character or number of characters 

log or log* Returns all topics with text that starts with the 
specified characters (for example, log, logon, logging). 

Topics with text that starts with the 
specified characters, has a single 
character that can be anything, and 
ends in the specified characters 

32?57 
Returns all topics with text that has any character 
where you placed the question mark (for example, 
32?57 returns 32257, 32457, and 32857). 

Topics that contain all the words 
specified, in any order or placement 
within the topic 

account 
status 

Returns all topics with both account and status, but 
not necessarily as a phrase or in the order specified. 
For example, the search returns topics with "the 
account status..." or "the status of the account..." 

Topics that contain the specified 
phrase 

"account 
status" 

Returns all topics with account status as a phrase. For 
example, the search returns topics with "the account 
status..." but not "the status of the account..." 

Boolean operators 

Boolean operators (AND, OR, NOT, NEAR) allow you to create a relationship between terms. If you don't 
specify an operator, the system uses AND by default. 

Search 
for... Example Result 

AND account AND 
status 

Returns all topics with both account and status, but not necessarily as a phrase or 
in the order specified. For example, the search returns topics with "the account 
status..." or "the status of the account..." 

OR account OR 
status Returns all topics with either account or status, or both. 

NOT account NOT 
status Returns all topics with account but not status. 

NEAR account 
NEAR status Returns all topics where account is within eight words of status. 

Nested expressions 

Nested expressions allow you to perform complex searches. For example, queue AND ((collector OR 
clerical) not supervisor) finds topics containing queue and collector but not supervisor, or containing 
queue and clerical but not supervisor. As with mathematical expressions, the system evaluates 
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expressions in parentheses first. If there is no parenthesis, the system evaluates the expression from left 
to right. For example, queue NOT (clerical OR supervisor) finds topics containing queue but not clerical 
or supervisor. Queue NOT clerical OR supervisor finds topics containing queue but not clerical, or topics 
containing supervisor. 

Archive Configuration Tool 

Archive Configuration Tool 

Use the Archive Configuration Tool to specify the configuration for archiving account data. 

Log on to the Archive Configuration Tool 

Use the Latitude Login dialog box to log on to the Archive Tool. 

To log on to the Archive Tool 

1. Click Start > All Programs > Latitude Software > Archive Tools > Archive Configuration Tool. 
The Latitude Login dialog box appears. 

 
2. In the User Name box, type your Latitude user name. 

3. In the Password box, type your Latitude password. As you type your password, periods display 
instead of the typed characters. 

Note: To log on using Windows authentication, select the Log in using Windows authentication 
check box and provide your Windows user name and password. 

4. Click Okay. The Latitude Archive Configuration Utility window appears. 
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Specify Configuration for Archiving Account Data 

Use the Latitude Archive Configuration Utility window to specify the configuration for archiving account 
data. 

To specify configuration for archiving account data 

1. Open the Latitude Archive Configuration Utility window. 
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Archive Server: Server where the archive database resides. 

Archive Database: Name of the database to store archived account data. 

Archive User: User ID for accessing the archive database. 

Archive Password: Password for accessing the archive database. 

Archive: If selected, the system archives the data in the corresponding production table. 

Viewable: If selected, you can view the archived data in the Archive Tool and in the Archive panel 
in Latitude. 

Archive: If selected, the system purges the data in the corresponding production table after 
archiving the data. 

2. Complete the information and then click Update. 

Import Table Definitions 

Use the Import Table Definitions dialog box to import table definitions into the archive table. The 
import process overwrites the existing archive table definitions. 

To import table definitions 

1. In the File menu, click Import Table Definitions. The Import Table Definitions dialog box 
appears. 
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2. In the Name column, click the name of the import file and then click Open. A confirmation 

dialog box appears. 

 
3. Click Yes. 

Synchronize the Archive Schema 

Use Synchronize Archive Schema feature to synchronize the production database schema to the archive 
database. Use this feature to ensure that your archive database has the latest changes to the production 
database. 

To synchronize the archive schema 

1. In the File menu, click Synchronize Archive Schema. A progress dialog box appears. When 
synchronization is complete, a notification dialog box appears. 
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2. Click OK. 

Export Table Definitions 

Use the Export Table Definitions dialog box to export the table definitions in the archive table. 

To export table definitions 

1. In the File menu, click Export Table Definitions. The Export Table Definitions dialog box 
appears. 

 
2. In the File name box, type a name for the export file and then click Save. The system exports the 

table definitions to the specified file. 

View Archive History 

Use the View Archive History dialog box to view the history of archive actions, such as configuration 
changes and archiving of account data. 
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To view archive history 

1. In the File menu, click View Archive History. The View Archive History dialog box appears. 

 

From: Start date for which to display information. 

To: End date for which to display information. 

Action: Action for which to display information. 

All Users: If selected, displays information for all users. If cleared, displays information for the 
current user only. 

2. Complete the information and then click GO. The system displays the archive history for the 
specified criteria. 

Archive Tool 

Archive Tool 

Use the Archive Tool to archive data for accounts that you specify. Only accounts with a "999" queue 
level (returned) are eligible for archive. 

Log on to the Archive Tool 

Use the Latitude Login dialog box to log on to the Archive Tool. 

To log on to the Archive Tool 

1. Click Start > All Programs > Latitude Software > Archive Tools > Archive Tool. The Latitude 
Login dialog box appears. 
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2. In the User Name box, type your Latitude user name. 

3. In the Password box, type your Latitude password. As you type your password, periods display 
instead of the typed characters. 

Note: To log on using Windows authentication, select the Log in using Windows authentication 
check box and provide your Windows user name and password. 

4. Click Okay. The Latitude Archive window appears. 

 

Select Accounts to Archive 

Use the Select Accounts tab in the Latitude Archive window to select the accounts to archive. 
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Note: These instructions are for creating a query. You can also open an existing query to select 
accounts. For more information about working with queries, see "Queries" in the Latitude 
documentation. 

To select accounts 

1. In the Latitude Archive window, click the Select Accounts tab. 

 
The system sets three conditions by default; however, you can delete them. 

2. To exclude duplicate records from the query results, select Exclude Duplicate Records. 

3. To limit the query results to a specific number of records, select Maximum Records and then, in 
the box, type the maximum number of records to include in the results. 

4. In the Select Columns pane, do the following as necessary to specify the data columns to include 
in the query results: 

a. Drag and drop one or more data items into the Select Columns pane. 

b. Arrange the order of the columns. 

5. In the Conditions pane, do the following as necessary to specify the query conditions: 

a. Drag and drop one or more conditions into the Conditions pane. 

b. Arrange the order of the conditions. 

c. Group conditions for evaluation. 
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6. In the Order pane, do the following as necessary to specify the sort order for the data returned 
in the query results: 

a. Drag and drop one or more data items to use to sort the query results into the Order pane. 

b. Arrange the order of the data items. 

c. Click the data item and then click the Ascending or Descending icon. 

7. To count the number of records that match the selection criteria, in the toolbar, click Count. The 
results appear in the Query Designer dialog box. Click OK. 

8. To save the query, do the following: 

a. In the toolbar, click Save. The Save Query Dialog box appears. 

 
b. In the Query Name box, type a name for the query and then click Save. 

Tip: To overwrite an existing query, in the Name column, click the query to overwrite and then 
click Save. 

9. Click Run. The query results appear on the Preview Results tab. 

Archive Account Data 

Use the Preview Results tab in the Latitude Archive window to review the accounts selected for archive, 
and then archive the data for those accounts. 

To archive account data 

1. After running a query, in the Latitude Archive window, click the Preview Results tab. The results 
appear in the data grid. 
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The columns that appear are based on the ones you specified when you selected accounts. 

2. Click Execute. 

3. In the confirmation dialog box, click Yes. The system archives data for the accounts and then 
displays a notification dialog box. 

4. Click OK. 

5. If errors occur during the archive, click the Exceptions tab. 

 
Note: To print or save the exceptions to a file, use the Print Exceptions or Save Exceptions 
option in the File menu. 
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View Archived Data 

Use the Latitude Archive View File Number window to view archived data for an account. 

To view archived data 

1. In the File menu, click View Archived Data. The Archive Data View dialog box appears. 

 

2. In the box, type the file number of the account to view and then click OK. 

 
3. Click the tabs to view the data. 

Restore Tool 

Restore Tool 

Use the Restore Tool to restore archived account data to your Latitude database. 

Log on to the Restore Tool 

Use the Latitude Login dialog box to log on to the Restore Tool. 

To log on to the Restore Tool 

1. Click Start > All Programs > Latitude Software > Archive Tools > Restore Tool. The Latitude 
Login dialog box appears. 
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2. In the User Name box, type your Latitude user name. 

3. In the Password box, type your Latitude password. As you type your password, periods display 
instead of the typed characters. 

Note: To log on using Windows authentication, select the Log in using Windows authentication 
check box and provide your Windows user name and password. 

4. Click Okay. The Latitude Archive Restore window appears. 

 

Select Accounts to Restore 

Use the Select Accounts tab in the Latitude Archive Restore window to select the accounts to restore. 
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Note: These instructions are for creating a query. You can also open an existing query to select 
accounts. For more information about working with queries, see "Queries" in the Latitude 
documentation. 

To select accounts 

1. In the Latitude Archive Restore window, click the Select Accounts tab. 

 

The system sets one condition by default. 

2. To exclude duplicate records from the query results, select Exclude Duplicate Records. 

3. To limit the query results to a specific number of records, select Maximum Records and then, in 
the box, type the maximum number of records to include in the results. 

4. In the Select Columns pane, do the following as necessary to specify the data columns to include 
in the query results: 

a. Drag and drop one or more data items into the Select Columns pane. 

b. Arrange the order of the columns. 

5. In the Conditions pane, do the following as necessary to specify the query conditions: 

a. Drag and drop one or more conditions into the Conditions pane. 

b. Arrange the order of the conditions. 
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c. Group conditions for evaluation. 

6. In the Order pane, do the following as necessary to specify the sort order for the data returned 
in the query results: 

a. Drag and drop one or more data items to use to sort the query results into the Order pane. 

b. Arrange the order of the data items. 

c. Click the data item and then click the Ascending or Descending icon. 

7. To count the number of records that match the selection criteria, in the toolbar, click Count. The 
results appear in the Query Designer dialog box. Click OK. 

8. To save the query, do the following: 

a. In the toolbar, click Save. The Save Query Dialog box appears. 

 
b. In the Query Name box, type a name for the query and then click Save. 

Tip: To overwrite an existing query, in the Name column, click the query to overwrite and then 
click Save. 

9. Click Run. The query results appear on the Preview Results tab. 

Restore Archived Account Data 

Use the Preview Results tab in the Latitude Archive Restore window to review the accounts selected for 
restoring, and then restore the data for those accounts. 

To restore archived account data 

1. After running a query, in the Latitude Archive Restore window, click the Preview Results tab. 
The results appear in the data grid. 
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The columns that appear are based on the ones you specified when you selected accounts. 

2. Click Execute. 

3. In the confirmation dialog box, click Yes. The system restores archived data for the accounts and 
displays a notification dialog box. 

4. Click OK. 

5. If errors occur during the restore, click the Exceptions tab. 

 
Note: To print or save the exceptions to a file, use the Print Exceptions or Save Exceptions 
option in the File menu. 
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