Interaction Tracker Filtered Directories

Technical Reference

Abstract

Tracker Filtered Directories are a feature in Interaction Desktop. This content describes how to create and configure custom client directories using Tracker contacts. Interaction Desktop users can increase daily productivity by quickly accessing their contacts that have been created and organized using Interaction Tracker attributes.

For the latest version of this document, see the PureConnect Documentation Library at: http://help.genesys.com/pureconnect.

For copyright and trademark information, see https://help.genesys.com/pureconnect/desktop/copyright_and TRADEMARK_information.htm.
Table of Contents

Table of Contents ........................................................................................................................................................................ 2
Introduction ......................................................................................................................................................................................... 3
   Installation ...................................................................................................................................................................................... 3
   CIC client ...................................................................................................................................................................................... 3
   About this information .................................................................................................................................................................. 3
   Referenced information ............................................................................................................................................................... 3
Prerequisites ...................................................................................................................................................................................... 4
   Hardware and Software prerequisites ...................................................................................................................................... 4
   Interaction Tracker plug-in ......................................................................................................................................................... 4
   Licensing prerequisites ............................................................................................................................................................... 4
   Security Rights and Access Control Rights .................................................................................................................................. 4
Configuration .................................................................................................................................................................................. 6
   Verify the Tracker Server License ........................................................................................................................................... 6
   Verify the Tracker Access licenses ........................................................................................................................................... 7
   Create an IC Tracker Contact List Source ................................................................................................................................... 7
Tracker Filtered Directory Views .................................................................................................................................................. 11
   Create and Display a Tracker Filtered Directory View ........................................................................................................... 11
   Display a Tracker Filtered Directory View ................................................................................................................................ 13
   Modify a Tracker Directory View ........................................................................................................................................... 14
   Close an Interaction Tracker Filtered Directory View ............................................................................................................ 15
   Delete a Tracker Filtered Directory View .................................................................................................................................. 15
Change Log ........................................................................................................................................................................................ 16
Introduction

The Interaction Tracker Filtered Directories feature enables Interaction Desktop users to create custom CIC client directory views using Interaction Tracker contacts. Interaction Tracker Filtered Directories enable users to communicate quickly and easily with these contacts created from their established Interaction Tracker customer accounts.

A Tracker Access license is required for each user who creates and uses Tracker Directories. After the CIC administrator creates the IC Tracker Contacts list source, licensed users can create Interaction Tracker directory views in the CIC client. For these views, users can specify filter criteria based on existing contact information stored in the Tracker database.

CIC client users can increase daily productivity by quickly accessing their contacts which are filtered and organized using Interaction Tracker attributes.

Included here:
- Installation information and prerequisites
- Configuration information for Interaction Administrator
- Information about creating and using Tracker Filtered Directories

Installation

The Tracker Filtered Directories plug-in is included in the Customer Interaction Center installation

CIC client

Customer Interaction Center (CIC) supports two interaction management client applications. This documentation uses the term “CIC client” to refer to Interaction Desktop.

About this information

The information in this technical reference is for partners, planners, installers, administrators, and users, who plan to create and configure Tracker Filtered Directories.

Referenced information

Because the Tracker Filtered Directories feature is integrated with Customer Interaction Center’s installation and Interaction Tracker, this document refers to other technical references and guides. These documents are available in the Documentation Library on your CIC server. The latest versions of these documents can also be accessed from the PureConnect Documentation website.

The following guide, help, and links are referred to in this document and provide more information for creating and configuring Tracker Directories:
- PureConnect Installation and Configuration Guide
- PureConnect Licensing Technical Reference
- Interaction Administrator Help
- Interaction Desktop Help
Prerequisites

This section explains prerequisites for installing the Tracker Filtered Directories plug-in.

Hardware and Software prerequisites

The Tracker Filtered Directories feature has no additional hardware or software prerequisites.

Interaction Tracker plug-in

Interaction Tracker features are controlled with licensing. The Tracker plug-in is always loaded in the CIC client. Tracker Directory views are available only if the CIC client user has an Interaction Tracker Access license.

Licensing prerequisites

The Customer Interaction Center installation installs the Tracker Filtered Directories plug-in. Tracker Directories views are available to CIC client users with a Tracker Access license.

The following licenses are required:
- A Tracker Feature license (I3_FEATURE_TRACKER) is required for your Interaction Tracker Server installation.
- An Interaction Tracker Access add-on license (I3_ACCESS_TRACKER) is required for each user of Tracker Filtered Directories.

For more information about licensing, see the
- Licensing in the PureConnect Installation and Configuration Guide.
- PureConnect Licensing Technical Reference in the PureConnect Documentation Library.
- Activation File Management Tool in the My Support Dashboard. (https://genesyspartner.force.com/customerCare/GenesysCommunityLogin)

Security Rights and Access Control Rights

CIC client users need the following licenses to take advantage of all the Interaction Tracker features available in the CIC client.
- The Related Interactions Page Security right and the Customize Client Security right control whether a user can display the Related Items View.
- The View History Users Access Control right determines whose interactions appear in the Related Items view. The CIC administrator can grant a CIC client user the necessary rights to the interactions belonging to all or selected users.
- Tracker Policy Security rights control which Tracker functions are available to CIC client users.
<table>
<thead>
<tr>
<th>Tracker Policy Right</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add Individuals</td>
<td>Enables you to add a Tracker contact or Quick add a contact.</td>
</tr>
<tr>
<td>Add Organizations</td>
<td>Enables you to add a Tracker organization.</td>
</tr>
<tr>
<td>Delete Individuals</td>
<td>Enables you to delete a Tracker contact.</td>
</tr>
<tr>
<td>Delete Organizations</td>
<td>Enables you to delete a Tracker organization.</td>
</tr>
<tr>
<td>Have Private Contacts</td>
<td>Enables you to designate a Tracker contact as private and prevent other users from viewing or using information for this contact. For more information, see the Allow others access to this Contact setting in the Add Contact Wizard.</td>
</tr>
<tr>
<td>Modify Individuals</td>
<td>Enables you to modify Tracker contact information.</td>
</tr>
<tr>
<td>Modify Organizations</td>
<td>Enables you to modify Tracker organization information.</td>
</tr>
<tr>
<td>Related Interactions Page</td>
<td>Enables you to use the Related Items view.</td>
</tr>
<tr>
<td>Tracker Administrator</td>
<td>Grants you all the Tracker Policy Rights, enabling you to perform all the Tracker functions that require any Tracker Policy Right.</td>
</tr>
<tr>
<td>View Other People's Private Interactions</td>
<td>Enables you to view other users' private interactions in the Related Items view and to have these interactions included in search results in the Find Interaction dialog box. A user can indicate that an interaction is &quot;Private&quot; to prevent other users from recording or listening to it.</td>
</tr>
</tbody>
</table>
Configuration

After an administrator installs CIC, a CIC administrator completes these tasks to make Tracker Directory views available in the CIC client.

- Verify the Tracker Server license.
- Verify the Tracker Access Licenses for authorized users.
- Verify that Interaction Tracker Server is configured and running.
- Create an IC Tracker Contact List Source in Interaction Administrator.

Verify the Tracker Server License

The Tracker Server must have the appropriate license to enable you to configure Tracker Filtered Directories.

To verify your license:

1. In Interaction Administrator, from the File menu, select License Management.
   Result: The License Management dialog appears.

2. Verify that you have the I3_FEATURE_TRACKER license.
3. Close the dialog.
Verify the Tracker Access licenses

To create and access Tracker Filtered Directories, users must have a Tracker Access license.

To assign Tracker access licenses:

1. In Interaction Administrator, right-click on a selected user and then select Properties.
   Result: The User Configuration dialog box appears.
2. On the Licensing tab, select the Interaction Tracker Access license, and apply it to the configuration for this user.
3. Make sure the Enable Licenses check box is selected.
4. To save your selections, click OK.

Create an IC Tracker Contact List Source

To enable CIC client users to access the Interaction Tracker Directories from inside the CIC client, create an IC Tracker Contacts Contact List Source in Interaction Administrator.

To add a Tracker Directory Contact List Source:

1. In Interaction Administrator, in the System Configuration container, under the Contact Data Manager, select Contact List Sources.
2. Right-click in the Contact List Source Name list pane and then select New.
Result: The Entry Name dialog appears.

3. Type the Contact List Source Name, IC Tracker Contacts and click OK.

Note: This name must be IC Tracker Contacts.

Result: The Contact List Source Configuration – IC Tracker Contacts dialog box appears.
4. In the Configuration tab, make the following selections:

**IC Data Source**
Select IC Tracker.

*Note:* The IC Data Source can have a different name than IC Tracker. It is named when the data source is created during Interaction Tracker setup.

**Label**
Enter a name. This name appears in the Interaction Administrator Contact List Source Name pane.

**Public**
Select this check box for IC Tracker Contacts. Tracker Filtered Directories contain only Public Tracker Contents.

**Driver**
Select the IC Tracker Contacts driver. This driver applies the appropriate formatting to the Tracker database.

5. In the Options tab, make the following selections:
Timeout (sec)

Consider your operating conditions when setting this value:

- Under usual operating conditions, set the value to 300
- Under heavy load or high tracing conditions, for example

Query Row Limit

Set this value to no less than 500,000. Increase this value if the customer site requires it. Set this value to more than the combined counts of Individuals, Addresses, Attributes, and Connections.

6. Click OK.

Result: The IC Tracker Contacts list source appears in the Contact List Source Name pane.
Tracker Filtered Directory Views

Agents create Tracker Filtered Directories views in the CIC client. Agents use these views to communicate quickly with contacts from your Interaction Tracker customer accounts.

Note: Agents with the Tracker Administrator security right can create directory views that contain all matching public and private contacts, including private contacts created by other users. Views created by an agent who does not have the Tracker Administrator security right contain all matching public contacts and only the matching private contacts belonging to the agent. For information about working with Directory views, see the CIC client help.

- Create and Display a Tracker Filtered Directory View
- Display a Tracker Filtered Directory View
- Modify a Tracker directory
- Close an Interaction Tracker Filtered Directory View
- Delete a Tracker Filtered Directory View

Create and Display a Tracker Filtered Directory View

You can add an Interaction Tracker Directory view to the CIC client.

To create and display a directory view:

1. Do one of the following:
   - From the Tracker menu, select Manage Tracker Directories. In the Tracker Directories dialog box, click New.
   - In Interaction Desktop, from the File menu, select New > View. In the Create New View dialog box, from the Categories list, select Directories. In the Views list, select Tracker Directories. In the Select Tracker Directories to Add dialog box, click the Add button (Plus sign).

Result: The Interaction Tracker Directory Settings dialog box appears.

![Interaction Tracker Directory Settings dialog box](image)

Note: None of the filter criteria fields in this dialog are required. You can filter for any of the filter fields, or none. If you only specify a directory name and no filter criteria, a directory view is created but does not contain any contacts.

2. In the General section, specify the filtering criteria for the new Tracker directory. The contacts created for this directory are based on the information in the existing Tracker database.
### Directory Name
Type a name for this directory. This directory view name appears in the CIC client.

### Organization
To search for or add an organization, enter the name of an organization or click the Search icon.

### Location
To filter by location, after you specify an organization, click the Search icon next to the Location text box to select a location or to add a location.

**Note:** If you do not select an Organization, you cannot select a Location.

### Individual Type
The drop-down box contains Individual Types that were created in Interaction Tracker. Select an Individual Type from the drop-down box.

### Department
Type a department you want to include when filtering information from the Tracker database for this directory.

3. **In the Address section**, specify any necessary address filtering criteria:

<table>
<thead>
<tr>
<th>Address Type</th>
<th>From the drop-down list, select an Interaction Tracker address type.</th>
</tr>
</thead>
<tbody>
<tr>
<td>City</td>
<td>Optionally, add any additional address filtering criteria.</td>
</tr>
<tr>
<td>State</td>
<td></td>
</tr>
<tr>
<td>Zip</td>
<td></td>
</tr>
<tr>
<td>Country</td>
<td></td>
</tr>
</tbody>
</table>

4. **In the Attributes section**, create a filter based on Tracker database attributes:
   a. **Click New.**

   **Result:** The Add Attribute dialog box appears.

   ![Add Attribute dialog box]

   b. **In the Attribute Type box**, select a type that has been created in Interaction Tracker.
   c. **In the Attribute Value box**, select a value that is associated with the selected Attribute Type.
   d. Click OK.

   **Result:** The information you choose appears in the Name and Value columns in the Attributes section.

5. **To create the Interaction Tracker Directory view, Click OK.**

   **Result:** One of two things happens.
   - If you added the new view from the Tracker Directories dialog box, the name of the new view appears there.
   - If you added the new view from the Create New View dialog box, the name of the new view is added to the Available Items list.

6. **To display your new Interaction Tracker Filtered Directory view**, do one of the following:
   - From the Tracker menu, select Open Directory. From the Open Directory menu, select the name of the directory view you want to display.
   - In the Create New View dialog box, select the view from the Available Items list and click the Add button between the Available items and Selected items lists. Click OK.

   **Tip:** To locate the view name, enter all or part of the view name in the Filter items text box.

   **Result:** The new Interaction Tracker Directory view appears in the CIC client.

   **Note:** See the next section for information about displaying an existing Filtered Tracker Directory view.
Display a Tracker Filtered Directory View

CIC client users with a Tracker Access license can display Tracker Filtered Directory views.

To display an existing Interaction Tracker Filtered Directory view:
1. Select a tab in the CIC client in the area where you want to display the new view.
2. From the Tracker menu, select Open Directory.
3. Select the name of the directory view you want to display.
   Result: The selected view appears in the CIC client.

You can also choose which Tracker Filtered Directory views to display from the same dialog box where you create views.
1. In Interaction Desktop, from the File menu, select New > View.
2. In the Create New View dialog box, from the Categories list select Directories.
3. In the Views list, select Tracker Directories.
   Result: All of your previously created Interaction Tracker Filtered Directory views appear in the Select Tracker Directories to Add dialog box.

4. From the Available Items list, select a directory view and then click Add >.
   Result: The selected view appears in the Selected items list.
5. Optional. Select and add more views to the Selected items list.
6. When you complete your selection or selections, click OK.
   Result: The selected view appears in the CIC client.
Modify a Tracker Directory View

You can modify an existing Interaction Tracker Directory view to update the filtered information and contacts that are included in the directory.

To modify an existing Interaction Tracker Directory:

1. Do one of the following:
   - From the Tracker menu, select Manage Tracker Directories. In the Tracker Directories dialog box, select the name of the view and click Edit.
   - Right-click the tab of a displayed Interaction Tracker Filtered Directory view and click Rename.
   - For a non-displayed view, in the Create New View dialog box, from the Categories list, select Interaction Tracker Directories. In the Select Tracker Directories to Add dialog box, from the Available Items list, select the name of the view and click the Edit button.

<table>
<thead>
<tr>
<th>Available items:</th>
<th>Selected items:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tracker Directory</td>
<td>Filter items</td>
</tr>
<tr>
<td>ABC Corporation</td>
<td>Filter items</td>
</tr>
<tr>
<td>XYZ Company</td>
<td>Filter items</td>
</tr>
</tbody>
</table>

Tip: The Add, Edit, and Delete buttons appear below the Available Items list. Point your mouse to a button to see an identifying tooltip.

Result: The Interaction Tracker Directory Setting dialog box appears.

2. Make any necessary adjustments to the filter settings.

   Tip: See Create and Display a Tracker Filtered Directory for details on filter settings.

3. Click OK.
Close an Interaction Tracker Filtered Directory View

You stop displaying an Interaction Tracker directory view in the CIC client, but keep it available to display in the future. Close a view instead of deleting it, if you do not currently want to display it, but still want it available for future use.

To close an Interaction Tracker Directory Filtered Directory view:
- In the CIC client, right-click the tab for the Interaction Tracker Filtered Directory view and then click Close view.

Result: The Interaction Tracker Filtered Directory view tab no longer appears in your CIC client. However, it remains available for future use.

Delete a Tracker Filtered Directory View

To delete a displayed Interaction Tracker Filtered Directory view:
1. From the Tracker menu, select Manage Tracker Directories. In the Tracker Directories dialog box, select the name of the view and click Delete.
2. Click Yes to confirm you want to delete the view.

Result: The Interaction Tracker Filtered Directory view is removed from your CIC client interface and from the list of available views.

To delete an Interaction Tracker Filtered Directory view that is not currently displayed:
1. Do one of the following:
   - From the Tracker menu, select Manage Tracker Directories. In the Tracker Directories dialog box, select the name of the view.
   - In the Create New View dialog box, from the Categories list, select Directories. In the Views list, select Tracker Directories. In the Select Interaction Tracker Directories to Add dialog box, in the Available Items list, select the view name.

   Tip: To locate the view name, enter all or part of the view name in the Filter items text box.

2. Click the Delete button.

   Tip: The Delete button is active only if you have the appropriate rights to the selected Interaction Tracker Filtered Directory view.

   Note: In the Select Tracker Directories to Add dialog box, the Add, Edit, and Delete buttons appear below the Available Items list. Point your mouse to a button to see an identifying tooltip.

3. Click Yes to confirm you want to delete the view.

Result: The name of the Interaction Tracker Filtered Directory view is permanently removed from the list of Available Items.
## Change Log

<table>
<thead>
<tr>
<th>Date</th>
<th>Changes</th>
</tr>
</thead>
<tbody>
<tr>
<td>09-January-2012</td>
<td>Updated Copyright and Trademark Information page.</td>
</tr>
<tr>
<td>16-March-2012</td>
<td>Updated procedures to 4.0 SU 1. Replaced most screen captures.</td>
</tr>
<tr>
<td>07-August-2012</td>
<td>Updated this technical reference for these SCRs:</td>
</tr>
<tr>
<td></td>
<td>- IC-89474: Allow Tracker Directories to be added from an expandable menu item collection</td>
</tr>
<tr>
<td></td>
<td>- IC-89475: Create a form to manage Tracker Directories</td>
</tr>
<tr>
<td></td>
<td>- IC-89476: Generate a localizable description for Tracker directories using the filter criteria</td>
</tr>
<tr>
<td></td>
<td>- IC-90267: Tracker Filtered Directories Does Not Honor Private Contacts</td>
</tr>
<tr>
<td>25-November-2012</td>
<td>Verified technical reference procedures and screen captures are up-to-date and reflect changes in 4.0 SU 2 and SU 3.</td>
</tr>
<tr>
<td></td>
<td>- IC-101392: Interaction Tracker Filtered Directories TR need to be updated</td>
</tr>
<tr>
<td>01-August-2014</td>
<td>Updated documentation to reflect changes required in the transition from version 4.0 SU# to CIC 2015 R1, such as updates to product version numbers, system requirements, installation procedures, references to Interactive Intelligence Product Information site URLs, and copyright and trademark information.</td>
</tr>
<tr>
<td>31-March-2015</td>
<td>Updated document to reflect the changes required for the transition from Interaction Client .NET Edition to Interaction Desktop. This includes a new CIC client section.</td>
</tr>
<tr>
<td></td>
<td>- Updated the Copyright and Trademarks page.</td>
</tr>
<tr>
<td>25-June-2015</td>
<td>Rebranding changes, new logo and font colors.</td>
</tr>
<tr>
<td></td>
<td>- Updated Copyright and Trademark Information page.</td>
</tr>
</tbody>
</table>
| 28-July-2015 | IC-131357 Make rebranding changes in technical references  
| // Introduction  
| \- Removed reference to Interaction Client .NET Edition. (This is no longer distributed.)  
| // CIC client  
| // Referenced information  
| \- Verified URL for license website: http://license.inin.com  
| // Security Rights and Access Control Rights  
| \- Verified right names in Interaction Administrator, CIC 2016 R1.  
| // Configuration  
| \- Corrected bullet point typo, changed "Create an IC Tracker Contacts C" to "Create an IC Tracker Contact List Source in Interaction Administrator".  
| // Create and Display a Tracker Filtered Directory View  
| \- Step 1, 2nd bullet point was strictly for ICNET. Corrected it to read: In Interaction Desktop, from the File menu, select New > View. In the Create New View dialog box, from the Categories list, select Directories. In the Views list, select Tracker Directories. In the Select Tracker Directories to Add dialog box, click the Add button.  
| \- Verified Interaction Desktop screen capture.  
| // Display a Tracker Filtered Directory View  
| \- Removed Tracker Directories dialog box screen capture in step 3. Open Directory now displays a context menu list of directory names.  
| \- Changed step 1 of 2nd procedure to "In Interaction Desktop, from the File menu, select New > View."  
| \- Replaced Select Tracker Directories to Add dialog box screen capture in step 3. It has IDT icon in title bar now instead of telephone.  
| \- In step 6 Result, replaced Tracker Directory view in ICNET with one in Interaction Desktop, showing new tab and button icons.  
| // Modify a Tracker directory  
| \- In step 1, changed 2nd bullet point to read: Right-click the tab of a displayed Interaction Tracker Filtered Directory view and click Rename.  
| \- In step 6 Result, replaced Tracker Directory view in ICNET with one in Interaction Desktop, showing new tab and button icons. Also with tooltip for Edit button.  
| // Close an Interaction Tracker Filtered Directory View  
| \- To match IDT UI, changed Close (view name) to Close view  
| \- Replaced IDT screen capture with one showing new tab and button icons. Also with tooltip for Edit button.  
| // Delete a Tracker Filtered Directory View  
| \- Removed step 1 bullet point: Right-click the Interaction Tracker Filtered Directory view tab and click Delete (view name). (This does not appear on context menu in IDT.)  
| // Verify the Tracker Server License  
| // Verify the Tracker Access licenses  
| // Create an IC Tracker Contact List Source  

| 17-January-2018 | Converted to HTML format.  

| 03-May-2019 | Reorganized the content only, which included combining some topics and deleting others that just had an introductory sentence such as, "In this section..." For more details, see CICDOc-179.  

---

17